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1 Interface overview
About Working in Maya

Maya is the premier application for creating compelling 3D digital 
content, including models, animation, visual effects, games, and 
simulations.

The work you do in Maya generally falls into these categories:

• Creating models. Polygons, NURBS, and subdivision surfaces are 
different object types with different ways of modeling. Each has its 
own strengths, and different artists prefer working with different 
types.

• Polygons let you model a surface by building up and reshaping a 
number of simple surface facets.

• NURBS let you easily create smooth, curving surfaces with 
high-level control.

• Subdivision surfaces let you edit surfaces at a high level with 
minimum overhead data, while still letting you work with 
subsections of the surface as if they were made from polygons.

• Character rigging. Most animations involve “characters,” articulated 
models such as a person, an animal, robot, or anything else that 
moves by articulation. Maya lets you define internal skeletons for 
characters and bind skin to them to create realistic movement with 
deformation.

• Animation. Just about everything you can think of in Maya is keyable 
or able to be animated.

• Dynamics, fluids, and other simulated effects. Maya includes a 
comprehensive suite of tools for simulating real world effects such as 
fire, explosions, fluids, hair and fur, the physics of colliding objects, 
and more.

• Painting and paint effects. Maya includes an incredible system for 
using a graphics tablet (or the mouse) to paint 2D canvases, paint 
directly on 3D models, paint to create geometry, scriptable paint, and 
virtually limitless other possibilities.

• Lighting, Shading, and Rendering. When you want to render a still 
image or movie of you scene or animation, you can create them using 
your choice of renderers.
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1 | Interface overview 
About > 3D coordinates
3D

3D coordinates

The most basic visual entity is the point. The point has no size, but it has a 
location.

To determine the location of points, we first establish an arbitrary point in 
space as the origin.

We can then say a point’s location is so many units left (or right) of the 
origin, so many units up (or down) from the origin, and so many units 
higher (or lower) than the origin.

These three numbers give us the 3D coordinates of the point in space. For 
example, a point 7 units right (x), 4 units down (z), and 3 units above (y) the 
origin has the XYZ coordinates (7,4,3).

To specify points on the opposite side of the origin, we use negative 
numbers. In the example, a point at (-5, -2, -1) would be 5 units left of the 
origin, 2 units up, and 1 unit below.

In computer graphics, we don’t really say the point is “left/right”, “up/
down”, or “higher/lower”. Instead we call the three dimensions the X 
axis, the Z axis, and the Y axis.

Y-up and Z-up

In animation and visual effects, the tradition is to use Y as the “up” or 
elevation axis, with X and Z as the “ground” axes. However, some other 
industries traditionally use Z as the up axis and X and Y as the ground 
axes.

Origin
(0,0,0)

(7,3,4)

47 3

Y
 a

xi
s

X axis

Z ax
is
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About > Objects and components
Maya lets you switch the up axis between Y and Z. Choose Windows > 
Settings/Preferences > Preferences, then click Settings in the list on the 
left.

”Switch between Y-up and Z-up” on page 287

Maya’s Interface

Objects and components

In Maya, you model, animate, and render using objects such as spheres, 
NURBS surfaces, polysets, and so on. Objects are made up of or contain 
components, such as control points, patches, polygon faces, and so on.

Selection, tools, and actions

Selection

When you select multiple objects, the last selected object is drawn in a 
different color from other selected objects. This is known as the key object. 
Some tools use the key object to determine what to do with the selection. 
For example:

• When you transform multiple objects, the transformation uses the key 
object’s pivot point.

• The constrain actions constrain all selected objects to the key object.

Tools and actions

Maya makes a distinction between tools and actions.

• Tools work continuously: any clicks or drags you make in while the 
tool is active apply the tool.

For example, the selection arrow is a tool. Any clicks or drags in the 
view window while the selection arrow is active performs a selection.

• Actions are immediate, “one shot” operations applied to the selection. 
Most items in the menus are actions.

Tools appear in the toolbox. Almost all menu items are actions, however 
there are some tools in the menus. You can tell which menu items are tool 
by the following:

• The menu item has the word Tool in it.

• When you choose the tool it shows up in the toolbox.

• Instructions appear on the help line when the tool is active.
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Related topics

”Select objects or components” on page 45

”Choose tools and actions” on page 25

Main window

This section is a brief summary of Maya’s main interface. As you read, 
keep in mind the following:

• You can show or hide any of the UI elements in the main window 
using the Display > UI Elements menu.

• You can also hide a UI element by clicking the hide button to the left 
 of or above  the UI element. To show a UI element, press the 

right mouse button on another hide button and select the desired UI 
element from the pop-up menu.

• You can hide all the interface elements and instead use Maya’s quick 
command features: the Hotbox, Marking Menus, and hotkeys.

• A menu icon  appears to the right of the mouse pointer when a 
right mouse button pop-up menu is available for the control over 
which the mouse is hovering.
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About > Main window
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The status line (or toolbar) lets you

• Change the menu set.

• Access common functions.

• Control the selection mask.

• Set various options.

• Change the contents of the sidebar.

Related topics

”Shelves” on page 22
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”Display > UI Elements” on page 41

”Quick layout buttons” on page 69

”Status line (toolbar)” on page 34

”Command line” on page 37

”Attribute Editor” on page 189

”Channel Box” on page 196

Menus and menu sets

The menus in Maya are grouped into menu sets. Each menu set 
corresponds to a module of the software: Animation, Modeling, 
Dynamics, and Rendering. Maya Unlimited has additional modules: Cloth 
and Live. As you switch between menu sets, the right-hand menus 
change, but the left-hand menus remain the same; these are the common 
menus. 

To switch between menu sets, use the Status Line pull-down menu or 
hotkeys. The hotkeys are: F2 (Animation), F3 (Modeling), F4 (Dynamics), 
and F5 (Rendering). 

Tear-off menus

You can display menus as separate windows. This is helpful when you 
use a menu repeatedly. Pull down the menu and click the tear-off line at 
the top. Tear-off menus always display on top.

Select the menu set you want to work with.

... and these menus changeThe common menus stay the same
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About > Marking menus
Related topics

”Marking menus” on page 21

”Choose tools and actions” on page 25

Marking menus

Marking menus allow very quick access to a few of your most commonly 
used tools.

Marking menus are used throughout the Maya interface. When you press 
the right mouse button on an object, a marking menu appears that lets you 
choose a selection mode and other options. Some marking menus appear 
when you hold a key and press a mouse button.

Marking menus are very fast for experienced users because once you get 
used to showing them and the positions of their items, you can select the 
items using very quick gestures with the mouse or tablet pen, sometimes 
so fast the entire menu won’t even display.

Related topics

”Choose actions from marking menus” on page 26

”Create or edit a marking menu” on page 280

”Assign a marking menu to a hotkey” on page 281

”Add a marking menu to the hotbox” on page 282

”Marking Menus editor” on page 325

Click the 
tear-off 
line to 
tear off 
the 

Click the Close button (x) 
to close the tear-off menu

Drag the window by the 
title bar to move it to a 
new location
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Shelves

Shelves hold commonly used actions and tools, allowing them to be 
accessed by clicking an icon. You can also put custom scripts and panel 
layouts on a shelf.

Related topics

”Choose actions on a shelf” on page 27

”Create, rename, rearrange, or delete a shelf” on page 276

”Add a tool, action, or MEL script to a shelf” on page 277

”Edit the MEL script associated with a shelf item” on page 278

”Edit the contents of a shelf” on page 278

”Use a custom name or icon for a shelf item” on page 279

”Change the display of shelves” on page 279

Web browser in a panel

This feature is supported on the Windows, Mac OS X, and Linux platforms.

You can use a Web browser within a Maya panel to browse through and 
view Web content, or issue MEL commands from an HTML page. This 
makes it possible to integrate Internet solutions into your Maya workflow.

This browser uses Gecko as a layout engine, employing Mozilla Open 
Source to properly display W3C compliant Web content. This means that 
you can add plugins to view Flash movies or do any of the other activities 
you’re used to doing from a Web browser window, all from a panel 
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About > Web browser in a panel
within the Maya interface. Just like any other Maya panel, the Maya 
browser can be placed in the main Maya window beside other panels, or 
into a separate window.

The Maya browser does not provide all of the features supported by your 
current Web browser, and is not intended as a replacement. For example, 
it won’t create multiple windows or popup windows, so links that create 
and open new windows will not work. As well, secure sites are not 
supported for this release.

Examples of workflow

The Maya browser makes it easier for you to view Web content while you 
work in Maya, without having to flip between browser windows and the 
Maya interface. Some examples of what you can view from within your 
Maya window include:

• Help and tutorials, with the Maya interface in front of you to use 
while you follow instructions or look for interface controls

• Flash content that you’ve exported from Maya

• 2D images from the Internet (or from your organization’s intranet) 
that you can compare with models you are creating in Maya 

• Project criteria on the Web that you’re using to construct models, 
animations, and renderings

By issuing MEL commands from the Maya browser, you can:

• Design your own user interface for Maya using HTML and JavaScript

• Set up multiple controls (widgets) within HTML pages for easy 
reference, comparison, or tweaking of Maya characters

• Set up custom MEL tools to share over the Internet, or to interface 
with custom pipeline tools such as render farms

Related topics

”Use the Maya browser” on page 31

”Configure the Maya browser” on page 32

”Maya Browser (Web browser in a panel)” on page 38
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How do I? Get help

Print the Maya Help

The Maya Help is also provided in PDF format. You can print the online 
books using Adobe Acrobat Reader, available free from Adobe at 
www.adobe.com.

To print the online books (Windows, Mac OS X)

1 Insert the Documentation, Lessons, and Extras CD.

2 Navigate to the /pdf directory.

3 Double-click to open contents.pdf. This file lists all of the available 
books.

4 Click to select the book you want to print. The selected PDF document 
opens.

5 Select File > Print.

To print the online books (IRIX)

1 Insert the Documentation, Lessons, and Extras CD.

2 Start Adobe Acrobat Reader and open /CDROM/pdf/contents.pdf by 
entering the following:

cd /CDROM/pdf 
acroread contents.pdf

3 Click to select the book you want to print. The selected PDF document 
opens.

4 Select File > Print.

To... Do this

Show the online help in a 
browser.

Choose Help > Maya Help, or press F1.

Show the help for a 
window.

Choose an item in the window’s Help menu.

Find a tool or menu item 
in the interface.

Choose Help > Find menu.

Get a description of/
instructions for the action 
under the mouse pointer.

Look in the help line.
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How do I? > Choose tools and actions
To print the online books (Linux)

1 Insert the Documentation, Lessons, and Extras CD.

2 Start the PDF viewer and open /mnt/cdrom/pdf by entering the 
following: 

cd /mnt/cdrom/pdf 
xpdf contents.pdf

3 Click to select the book you want to print. The selected PDF document 
opens.

4 Select the print icon.

Work with menu items, tools, and 
options

Choose tools and actions

To use a tool

• Click a tool in the toolbox to make it active.

• Double-click a tool to show the tool’s options panel.

To use an action (menu item)

• Click a menu item to perform the action on the selected objects or 
components.

Some actions work differently depending on the order you select the 
objects. For example, you select all the objects you want to constrain, 
and then select the object to constrain to last when you create a 
constraint.

The help line for an action tells you the order you need to select 
objects if order is important.

• Click the ❑ box next to the name of a menu item to open the action’s 
options window.

• Click the lines at the top of a menu or sub-menu to keep the menu 
open in its own window.

To reset a tool or action to its original (“factory”) options

• In the option window, choose Edit > Reset settings.

• In the Tool Settings editor, click Reset Tool.
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Related topics

”Selection, tools, and actions” on page 17

”Menus and menu sets” on page 20

Set the options for a tool or menu item

• Click the ❑ box next to the name of a menu item to open the action’s 
options window.

• Double-click a tool to show the tool’s options panel.

To reset a tool or action to its original (“factory”) options

• In the option window, choose Edit > Reset settings.

Choose actions from marking menus

Marking menus appear at the mouse pointer when you use certain key 
and mouse button combinations. They allow you to quickly choose an 
action from a small list.

Marking menus are common in the Maya interface:

• When you press the right mouse button on an object Maya shows a 
context-sensitive marking menu of actions you can apply to the object.

• The hotbox provides five customizable marking menus you can show 
by clicking inside, above, below, left, or right of the hotbox menus.

• You can assign marking menus to hotkeys. Hold the key and press the 
mouse button to show the marking menu.

The q, w, e, and r keys have default marking menus attached to them.

• Marking menu items can show additional marking menus, allowing 
you to pack more commands onto the marking menu.

To choose an item from a marking menu

1 Show the marking menu through one of the methods listed above (for 
example, hold q and press the left mouse button).

2 With the mouse button held, drag in the direction of the item you 
want to choose.

It doesn’t matter how far you drag or if you hit the item exactly. This 
allows you to make the drag very quickly with a little practice.

Dragging over an item with a submenu attached shows the submenu.

3 Release the mouse button to choose the item.
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Related topics

”Marking menus” on page 21

”Choose actions from the hotbox” on page 27

”Create or edit a marking menu” on page 280

”Assign a marking menu to a hotkey” on page 281

”Add a marking menu to the hotbox” on page 282

”Marking Menus editor” on page 325

Choose actions from the hotbox

The hotbox contains every action available in the Maya interface. It 
appears when you hold down the space bar.

The hotbox has three main functions:

• It contains every menu and menu item. This is useful if you want to 
quickly use an action from another menu set without switching menu 
sets.

• You can use the hotbox to choose actions even if you’ve hidden the 
menu bar and other UI to save space.

• The hotbox provides five customizable marking menus you can show 
by clicking inside, above, below, left, or right of the hotbox menus.

To choose an action from the hotbox

1 Hold the space bar to show the hotbox. The hotbox remains on screen 
as long as you hold the space bar.

2 Click one of the menus, or hold the left mouse button above, below, to 
the left, to the right, or in the center of the hotbox to show marking 
menus.

Related topics

”Add a marking menu to the hotbox” on page 282

”Customize the hotbox” on page 283

Choose actions on a shelf

• Click an icon on the shelf to perform the action.

• Click a tab above the icons to show a different shelf.

• Use the pull down menu to the left of the icons (the black arrow) to 
show or hide the tabs.
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• If the tabs are hidden, or if there are too many to fit on screen, click 
the tab icon to the left of the icons to show a menu of available 
shelves.

• Drag menu items or snippets of code onto a shelf with the middle 
mouse button.

Load the default shelves

Maya for Windows and Mac OS X include default shelves with buttons for 
commonly used features. The shelves are: Animation, Cloth, Curves, 
Custom, Deformation, Dynamics, Fluids, Fur, General, Hair, Paint Effects, 
Polygons, Rendering, Subdivs, and Surfaces.

Maya does not include the shelves in IRIX and Linux because they can 
slow the startup time on those platforms. However you can use the 
following instructions to load them.

1 Open the Script Editor (Window > General Editors > Script Editor).

2 To load all shelves, copy the following and paste it into the Script 
Editor window, then select Script > Execute. (Select only some shelves 
from the list below if you do not want to load them all by default.)

loadNewShelf "shelf_General.mel";
loadNewShelf "shelf_Curves.mel";
loadNewShelf "shelf_Surfaces.mel";
loadNewShelf "shelf_Polygons.mel";
loadNewShelf "shelf_Subdivs.mel";
loadNewShelf "shelf_Deformation.mel";
loadNewShelf "shelf_Animation.mel";
loadNewShelf "shelf_Dynamics.mel";
loadNewShelf "shelf_Rendering.mel";
loadNewShelf "shelf_Cloth.mel";
loadNewShelf "shelf_Fluids.mel";
loadNewShelf "shelf_Fur.mel";
loadNewShelf "shelf_Hair.mel";

Click to switch between shelves 

Click to show shelf options
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saveAllShelves $gShelfTopLevel;

Related topics

”Main window” on page 18

”Create, rename, rearrange, or delete a shelf” on page 276

”Add a tool, action, or MEL script to a shelf” on page 277

”Edit the contents of a shelf” on page 278

”Window > Settings/Preferences > Shelves” on page 300

Start Maya from the command line 

If you start Maya from the command line, there are various startup 
options you can specify. For example, you can open a file at startup using 
the -file flag: 

maya -file filename

To see the available startup flags, type the following:

maya -help

Running Maya in batch or prompt mode

Maya can be run in several distinct modes that affect its overall manner of 
operation, two of which allow you to execute Maya commands without 
the interface, -prompt and -batch.

• The -prompt flag issues a MEL prompt for you to type commands as 
you would in the Script Editor. Some commands that require the 
graphical user interface are either unavailable or have no effect. Type 
quit to exit the prompt mode. 

• Use the -batch flag to run commands without user input, such as in 
shell or batch scripts. The -batch flag starts Maya, executes any 
commands you specify, and then closes Maya. For example, you could 
create a script to open a file from a prior version of Maya in order to 
update it to the current version: 

maya -batch -file someMayaFile.mb -command "file -save"

There is an example of simulating Cloth in batch mode. See ”Simulate 
cloth in batch mode” on page 119 of the Cloth guide.

Additional Maya startup flags

These are additional flags you can use when starting up Maya from the 
command line.
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-archive [file] Displays a list of files required to archive 
the specified scene and then exits Maya.

-command [mel command] Runs the specified command on startup. 
The command should be enclosed in 
double quotes to protect any special 
characters, including spaces.

-log [file] Copies all error, warning, and information 
messages (those that normally appear in 
the Script Editor window) to the specified 
file (use complete file name).

-optimizeRender [file] 
[outfile]

Processes the specified scene file to 
optimize it for rendering, puts the result in 
outfile and then exits. Use maya 
-optimizeRender -help for more 
options. See ”-optimizeRender flags” on 
page 31.

-proj [dir] Looks for scene files in the specified 
project directory.

-recover Recovers the last journal file.

-render  [file] Renders the specified Maya scene file 
(either a single frame or a sequence of 
frame, depending on the render globals 
settings or other command-line flags 
specific to the -render option) and then 
exits. Use Render -help for more options.

-script [file] Sources the specified file (which is 
expected to be a MEL script) on startup.

-v Displays the product version and cut 
number, and then exits.

Notes The -batch command is not used for batch rendering. Instead, use 
the Render command. However, -batch does check out a 
render-only license instead of a full Maya license.

On Windows, type mayabatch when using the -batch flag. The 
mayabatch command runs within the command prompt window, 
whereas the maya command starts a separate window.
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-optimizeRender flags

Use this command to optimize the specified scene file for rendering, send 
the result to an output file and then close Maya.

maya -optimizeRender [options] [file] [outfile]

The available [options] are:

Use the Maya browser

To access the Maya browser

1 Do one of the following:

• From any Maya panel, select Panels > Panel > Web Browser. The 
browser appears in the Maya panel.

• Right-click a Quick Layout button and select the Web Browser 
Panel menu item:

-botRes [int] Specify a minimum file texture resolution 
that will cause BOT files to be produced. 
For example, specifying “-botRes 256” 
means that all file textures bigger than 
256x256.will be converted to BOT format.

-botLoca [name] Specify the directory in which BOT files 
reside. The default is in the same directory 
as the original file.

-help Displays all the flags available for use 
with -optimizeRender.

-noBOT Does not create BOT files.

-noCleanup Does not clean up useless data.

-tessFreeze 
[startframe] [endframe] 
[byframe]

Calculates NURBS tessellation that gives 
the best image quality based on the 
camera projection.
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2 Type in a URL or MEL command in the entry field. 

• Precede URLs with http:// 

• Precede MEL commands with mel://

Related topics

”Web browser in a panel” on page 22

”Configure the Maya browser” on page 32

”Maya Browser (Web browser in a panel)” on page 38

Configure the Maya browser

If you are on a LAN, you may need to set up one or more proxies to access 
external Internet servers. If you don’t know the name or port number of 
your proxy server, check the settings of your current browser, or contact 
your LAN administrator.

To configure the Maya browser for use with a network proxy

1 Select Window > Settings/Preferences > Preferences.

The Preferences dialog box appears.

2 Under Settings, select Web Browser from the Categories list.

3 Type in the appropriate settings under Network Configuration. You 
can choose from Direct Connection, Manual Proxy (which you must 
specify), or Automatic Proxy.
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4 Click Save.

To set whether the Maya help opens in the Maya browser or 
an external browser

1 Select Window > Settings/Preferences > Preferences.

The Preferences dialog box appears.

2 Select Misc from the Categories list.

3 In the Help Browser section, select one of the following:

• Open Help In Main Maya Window – select this to launch the 
Maya online help in a panel

• Open Help Using External Browser – select this to launch the 
Maya online help in your default Web browser (default)

4 Click Save.

To set the home page

1 Select Window > Settings/Preferences > Preferences.

The Preferences dialog box appears.

2 Select Settings > Web Browser from the Categories list.

3 Type in the URL of the new home page, or click Use Current Page.

4 Click Save. 

Related topics

”Web browser in a panel” on page 22

”Use the Maya browser” on page 31

”Maya Browser (Web browser in a panel)” on page 38
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Reference Tools

Status line (toolbar)

Menu set menu

”Menus and menu sets” on page 20

”Choose tools and actions” on page 25

File buttons

These buttons let you start a new scene file, open an existing scene file, or 
save the current scene file.

”Create, open, or save a scene file” on page 219

Selection mask

The toolbar contains several different controls to change the selection 
mask. The selection mask determines what type of objects or components 
you can select.

The selection mode menu lets you choose common preset selection masks.

The selection mode buttons let you switch between Select by hierarchy 
and combinations mode, Object mode, and Component mode.

The selection mask buttons let you make specific object/component types 
selectable or unselectable.
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”Selection, tools, and actions” on page 17

”Select objects or components” on page 45

”Select only certain types of objects or components (selection masks)” 
on page 48

Selection options

Click the lock to lock the selection so the left mouse button operates the 
manipulator instead of selecting. Click the lock again to unlock the 
selection.

   

”Select objects or components” on page 45

Snapping buttons

Snap to grids

Snaps a vertex (CV or polygonal vertex) or pivot point to a grid 
corner. If you select Snap to grids before you create a curve, its 
vertices snap to the grid corners.

Snap to curves

Snaps a vertex (CV or polygonal vertex) or pivot point to a curve or 
curve on surface.

Snap to points

Snaps a vertex (CV or polygonal vertex) or pivot point to a point.

Snap to view planes

Snaps a vertex (CV or polygonal vertex) or pivot point to a view 
plane.

”Snap to the grid, a curve, points, or a view plane” on page 116

”Snap all creation tools to a surface or construction plane” on 
page 117
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Render buttons

Click these buttons to perform a normal render, perform an IPR render, or 
open the render global settings window.

Input box

Use the menu on the left to choose what the input box does.

Quick Selection (sel)

Type the name of an object to select it. Use wildcards (* and ?) to select 
multiple objects.

”Select objects or components” on page 45

Quick Rename (nam)

Edit the name of the currently selected object. When more than one 
object is selected, Maya increments a number at the end of the name 
for each object.

”Change the name of one or more objects” on page 224

Numeric input: Absolute (abs)

Type numbers to move to, scale to, rotate to, etc,. based on the 
transformation tool currently selected.

Numeric input: Relative (rel)

Type numbers to move by, scale by, rotate by, etc,. based on the 
transformation tool currently selected.

”Move, rotate, or scale objects” on page 110

Sidebar buttons

Click a button to show a sidebar:

• Attribute Editor/notes

• Settings for the current tool

• Channel Box/Layer Editor
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Command line

The command line lets you type single MEL commands without having to 
open the Script Editor. The result from the command appears in the 
output 

Type MEL commands in the command line. The result appears in the 
colored box to the right of the command line.

• To enter more complex scripts, click the Script Editor button to the 
right of the result box.

• Drag the divider between the input and result boxes to resize them.

• When the cursor is in the command line, press up and down to scroll 
through the command history.

Toolbox

Select tool

Lets you select objects and components in view panels and the texture 
editor.

The select tool has no options when you use it in view panels. When you 
work in a texture editor panel the move tool has texture editor specific 
options.

Related topics

”Selection, tools, and actions” on page 17

”Select objects or components” on page 45

Lasso tool

Lets you select objects and components in view panels by drawing a 
freeform shape around them.

Enter MEL commands Result Show Script Editor

Select Tool
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Draw Style

Open As you draw the lasso, the shape remains open.

Closed As you draw the lasso, Maya connects the end and 
start points to show the enclosed space.

Component Selection

Fast Uses an approximation of the lasso shape to select 
components slightly faster when you release the 
mouse button.

Accurate Uses the exact shape of the lasso, but can take 
slightly longer to select components when you 
release the mouse button.

On modern machines there is very little difference in speed between Fast 
and Accurate component selection.

Related topics

”Selection, tools, and actions” on page 17

”Select objects or components” on page 45

Show Manipulator tool

Shows a manipulator tailored for the selected node or attribute.

Related topics

”Use manipulators” on page 107

”Show a custom manipulator for the selected node” on page 122

Windows and editors

Maya Browser (Web browser in a panel)

Related topics

”Web browser in a panel” on page 22

”Use the Maya browser” on page 31

”Configure the Maya browser” on page 32

Lasso Tool

Show Manipulator Tool
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Maya browser controls

The following controls are available in the Maya browser:

Web browser menu items

File > Open

Lets you load a particular file.

File > Reload

Reloads a page with its latest version (to ensure that you’re not viewing a 
cached page).

File > Stop Loading

Stops the loading of a page.

Go > Back

Goes to previous pages.

Go > Forward

When you are browsing through previous pages, goes to pages you had 
viewed subsequently.

Go > Home

Goes to the browser home page.

Examples of MEL Commands in the browser

You can communicate with Maya from its Web browser by using MEL 
commands, which you must precede by mel://

The following examples of Maya browser MEL code could be used in a 
Web page. They produce links that you click in the Maya browser to 
create and move a cube and a sphere.

Type in URLs or MEL commands 

Refresh the page
Go to the browser homepage

Stop loading the requested page

Move forward or backward through previously viewed pages

Access bookmarks Open a file
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1 | Interface overview 
Reference > Maya Help search engine
<a href="mel://nurbsCube/">Create default cube</a><br>
<a href="mel://sphere -radius 3/">Create sphere with radius 3</a><br>
<a href="mel://select nurbsCube1/">Select cube</a><br>
<a href="mel://move -x 5/">Move cube 5 units along X axis</a><br>
<a href="mel://select nurbsSphere1">Select sphere</a><br>
<a href="mel://sphere -edit -radius 8 nurbsSphere1/">Change radius of sphere to 
8</a><br>

Maya Help

Maya Help search engine

The Maya Help search engine is based on Lucene (jakarta.apache.org/
lucene/). It provides powerful, accurate, and efficient searches. This 
section gives more details on how the Maya Help search engine works, so 
you can get maximum use out of the Maya Help system.

Default search

The Maya Help search engine creates an OR search by default; that is, it 
matches any word specified. If you do a search for render lights, the 
search engine finds all documents that contain render and all documents 
that contain lights. It boosts all documents that contain both terms to the 
top of your search results, but it also finds all documents that contain only 
one or the other search term.

This means that simply adding terms won’t make your query more 
constrained; it will make more results appear, as the number of pages 
with any of those terms get larger and larger. To constrain your 
multiple-word query, use the + symbol before the search terms, which 
tells the search engine that word or phrase must appear in the result. 

Stemming searches

One of the features of the Maya Help search engine is that it automatically 
performs a case-insensitive search for all grammatical variants of a word, 
to get maximally useful search results.

Searching for render also returns search results for renders, rendering, 
rendered, etc. 

Other search features

• Search terms appearing in the title of a document cause the matched 
document to appear higher in the list of search results, compared to a 
match in the body of a document.

• Search terms appearing in the Glossary cause the matched document 
to appear higher in the list of search results.
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1 | Interface overview

Reference > Edit > Undo, Redo, Repeat
• The Maya Help search engine compares your search against a 
dictionary of common words to help catch misspellings and typos.

• If no term is matched, the Maya Help search engine automatically 
performs a fuzzy search to find closely-matching terms.

Related topics

”Maya Help search tips” on page 42

Menus

Edit

Edit > Undo, Redo, Repeat

”Undo, Redo, and Repeat” on page 121

Modify

Modify > Make Live

Converts the selected surface to a “live surface”. For NURBS surfaces, 
curves drawn on a live surface become curves-on-surface. All other 
creation tools automatically snap to the live surface.

Choose this item again to turn it off.

Related topics

”Snap all creation tools to a surface or construction plane” on 
page 117

Display

Display > UI Elements

The items in this menu control the visibility of various user interface parts.

Hide UI Elements

Hide all UI parts so only the panels and menus are visible.

Show UI Elements

Show all UI parts.
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Reference > Window > Settings/Preferences > Tool Settings
Restore UI Elements

Restores the visibility of UI parts to their state before you selected 
Hide UI Elements. If certain parts were hidden before you selected 
Hide UI Elements, they will still be hidden.

Related topics

”Main window” on page 18

Window

Window > Settings/Preferences > Tool 
Settings

Shows the options for the current tool in a window. If the tool options are 
already visible in the side panel, Maya closes the side panel first.

Related topics

”Selection, tools, and actions” on page 17

”Choose tools and actions” on page 25

Tips

Maya Help search tips

Related topics

”Maya Help search engine” on page 40

You can use the following special syntax in your search query for more 
exact searches.

Search for a phrase

Enclose the words in quotation marks (").

Example

"test render"
"curve on surface"

Require or exclude terms

Type a plus (+) before a term to require that all results contain that term. 
Type a minus (-) before a term to exclude all results that contain that term.
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Reference > Maya Help search tips
Example

Find both polygon and NURBS: 

+polygon +nurbs

Find test but not render:

test -render

Perform boolean searches

Use (), AND, OR, and NOT to group terms into boolean searches.

Example

(polygon AND nurbs) OR subdivision

Search using wildcards

Use a question mark (?) to match a single character. Use an asterisk (*) to 
match any characters. You cannot use a * or ? symbol as the first character 
of a search.

Example

poly*

matches polygons, polys, polygonal, all nodes starting with poly-.

d?ne

matches done, dune, dine.

r*ing

matches rendering, running.

Match a word that's close to your search word

Type a tilde (~) at the end of a word to allow fuzzy matches of that word. 
Note: fuzzy matches are not ranked as high in the search results as exact 
matches.

Example

subd~

matches subds, subdivision, all nodes starting with subd-.

Make some terms more important than others

Type a carat (^) at the end of a word or phrase followed by a number 
(typically between 1 and 5). Higher numbers make that word more 
important in the ranking of search results.
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Reference > Maya Help search tips
Example

test render^2

"shadow pass"^3

Search for special characters

To search for strings containing special characters, for example, \, :, or -., 
put quotes (") around the entire string or use \ before the character.

Example

"C:\Program Files\"

"anti-aliasing" or anti\-aliasing

Search a subsection of the Maya Help

You can search particular sections of the Maya Help by adding  
+section:"<section_name>" to your query, where <section_name> is 
What's New or Tutorials.

You can also search in a book in the Using Maya documentation, by 
adding +module:"<book_name>";  for example: +module:"Rendering" 

You'll get best results when doing a section or module search when you 
use a + sign in front of the word you're looking for; for example, +fur 
+section:"What's New" finds everything new about Fur. 
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2 Selecting
How do I? Select

Select objects or components

To... Do this

Select by clicking or 
dragging.

Click the Select tool in the toolbox.

or

Press q.

Select an object/
component.

Click the left mouse button.

Select multiple objects/
components.

Drag a selection box/lasso around the 
objects/components, or hold Shift and click.

Deselect objects/
components.

Hold Ctrl and click or drag.

Select by drawing 
selection lasso.

Click the Lasso tool in the toolbox.

Show a marking menu of 
options and actions 
related to selection.

Hold q and press the left mouse button.

Object mode Component mode
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2 | Selecting 
How do I? > Select objects or components
Select objects. Click the “Select by object type” icon in the 
toolbar.

or

Press the right mouse button on an object 
and choose Object Mode from the marking 
menu.

Select components. Click the “Select by component type” icon in 
the toolbar.

or

Press the right mouse button on an object 
and choose a component type from the 
marking menu.

or

Press F9 (vertices), F10 (edges), F11 (faces), 
or F12 (UVs).

Toggle between selecting 
object and component.

Press F8.

Select an object by name. Open the drop-down list next to the input 
box on the status line and choose Quick 
Selection.

In the input field, type the name of the 
object.

Use wildcards (* and ?) to select multiple 
objects. “*” matches any string of 
characters. “?” matches any single 
character.

Select all objects. Choose Edit > Select All.

Select all objects of a 
certain type.

Choose an item in the Edit > Select All by 
Type submenu.

To... Do this
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2 | Selecting

How do I? > Select objects or components
Selecting specific component types

The following table has tips for selecting certain types of components. 
They follow the same general pattern for selecting components, but 
demonstrate some selection techniques or component types that may not 
be obvious.

Related topics

”Selection, tools, and actions” on page 17

Invert the selection.

(Select all unselected 
objects, and deselect all 
selected objects.)

Choose Edit > Invert Selection.

To... Do this

Select polygon faces. Press the right mouse button on a polyset 
and choose Face, or press F11.

Select the dots in the center of the faces.

Select an arbitrary point on 
a curve.

Press the right mouse button on a curve 
and choose Curve Point.

Press the left mouse button on the curve 
and drag to select a point along the curve.

Select an isoparm on a 
surface.

Press the right mouse button on a surface 
and choose Isoparm.

Press the left mouse button on a visible 
isoparm that runs in the direction you 
want, then drag to the position you want.

Select an arbitrary point on 
a surface.

Press the right mouse button on a surface 
and choose Surface Point.

Press the left mouse button on an isoparm 
and drag to select a point on the surface.

Select a NURBS surface 
patch.

Press the right mouse button on a NURBS 
surface and choose Surface Patch.

Select the dots in the center of the patches.

To... Do this
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How do I? > Select a node
”Edit > Select All, Select Hierarchy, Invert Selection” on page 52

”Edit > Select All by Type” on page 53

Select a node

To select a node, do any of the following:

• Select an object with which the node is associated, click the node’s tab 
in the Attribute Editor, and click the Select button at the bottom of the 
Attribute Editor.

• Select an object with which the node is associated, then click the 
node’s heading in the Channel Box.

• Open the Hypergraph (Windows > Hypergraph) and choose Graph > 
Input and Output Connections. Then click the node in the graph.

With a node selected, you can click the Show Manipulators tool in the 
toolbox to show custom manipulators for the node.

Related topics

”Select objects or components” on page 45

 ”Nodes and attributes” on page 149

Select only certain types of objects or 
components (selection masks)

You can limit the types of objects or components Maya selects when you 
click or drag with the selection tools. This lets you work on certain parts of 
a complex model without accidentally selecting other objects.

To limit selections, you choose which types of objects or components you 
can and can’t select. This is called the selection mask.

To... Do this...

Switch between selecting 
objects and components.

Use the Select by object type and the Select 
by component type icons in the toolbar.

The icons available in the selection mask 
depend on whether you are in object or 
component selection mode.

Turn a object/
component type on or off 
in the selection mask.

Click the type icon in the selection mask area 
of the toolbar.

When an icon is depressed, that type is 
selectable.
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2 | Selecting

How do I? > Save and reuse a selection
Related topics

”Select objects or components” on page 45

”Status line (toolbar)” on page 34

Save and reuse a selection

Quick-select sets are useful to:

• Make it easier to quickly select commonly used sets of objects/
components.

• Save a complex selection so you can re-use it later without having to 
reselect each object.

To create a quick-select set

1 Select the objects or components.

2 Choose Create > Sets > Quick Select Set.

3 Type a name for the set.

Set the selection mask to 
all types.

Press the left mouse button on the pop-up 
menu icon to the left of the selection mask 
and choose All Objects/Components On.

Clear the selection mask. Press the left mouse button on the pop-up 
menu icon to the left of the selection mask 
and choose All Objects/Components Off.

When all types are off, you cannot select 
anything. Make sure to turn at least one type 
on again if you want to select.

Set the selection mask to 
a preset combination of 
objects and components 
based on workflow.

If the area to the left of the selection mode 
icons on the toolbar is hidden, click the bar to 
expand it.

Press the left mouse button on the pop-up 
menu icon and choose a workflow. The 
selection mask is set to objects and 
components related to that workflow.

To... Do this...

Click the bar to expand
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How do I? > Select objects based on hierarchy
To select the members of a quick-select set

• Choose the set in the Edit > Quick Select Sets submenu.

To edit the membership of a quick-select set

• Use the Relationship Editor to control which objects are in a quick 
select set.

Related topics

”Edit > Quick Select Sets” on page 53

”Create > Sets > Quick Select Set” on page 55

Select objects based on hierarchy

To set the selection mask to only select top level nodes 
(roots)

1 Click the Select by hierarchy and combinations icon in the toolbar.

2 Set the selection mask to Root.

To set the selection mask to only select only nodes without 
children (leaves)

1 Click the Select by hierarchy and combinations icon in the toolbar.

2 Set the selection mask to Leaf.

To select all nodes under the selected node

Choose Edit > Select Hierarchy.

Related topics

”Select objects or components” on page 45

”Edit > Select All, Select Hierarchy, Invert Selection” on page 52

Select components by painting

You can select components such as vertices or faces by painting over the 
components with your graphics tablet pen.

1 Select the object on which you want to select components.
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2 | Selecting

How do I? > Change one type of selection to another
2 Choose Edit > Paint Selection Tool > ❑.

3 Use the tool options panel to set up the tool, including choosing 
whether you are selecting, deselecting, or toggling components 
between selected and unselected.

4 Set up the selection mask to choose what types of components you 
want to select.

5 Paint on the selected object to select components.

Change one type of selection to another

When you have one type of component selected you can automatically 
select a corresponding component of a different type. For example, you 
can select a face and then use Convert Selection to Edges to select the 
edges around the face.

The Convert Selection... type menu items do not change or convert the 
actual geometry. They only change which components are selected.

• To change polygon selections, use the Convert... items in the Edit 
Polygons > Selection submenu.

• To change subdivision surface selections, use the Convert... items in 
the Subdiv Surfaces menu.

Related topics

”Select objects or components” on page 45

Grow, shrink, or change the selected region of 
CVs or polygon components

Polygon components

To... Do this

Grow or shrink a 
selection.

• Chose Edit Polygons > Selection > 
Grow Selection Region.

• Chose Edit Polygons > Selection > 
Shrink Selection Region.

Select the components 
around the current 
selection.

Chose Edit Polygons > Selection > Select 
Selection Boundary.
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Reference > Edit > Select All, Select Hierarchy, Invert Selection
NURBS CVs

Related topics

”Select objects or components” on page 45

Reference Menus

Edit

Edit > Select All, Select Hierarchy, Invert 
Selection

• Select All selects all objects in the scene.

• Select Hierarchy selects all parent and child objects of the current 
selection.

• Invert Selection selects all unselected objects, and deselects all selected 
objects.

Select all edges 
connected to the current 
selection.

Chose Edit Polygons > Selection > Select 
Contiguous Edges.

To... Do this

Grow or shrink a 
selection.

• Chose Edit NURBS > Selection > Grow 
CV Selection.

• Chose Edit NURBS > Selection > Shrink 
CV Selection.

Select the CVs around the 
current selection.

Chose Edit NURBS > Selection > Select CV 
Selection Boundary.

Select CVs on the edges 
of the surface.

Chose Edit Polygons > Selection > Select 
Surface Border.

To... Do this
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Reference > Edit > Select All by Type
Related topics

”Select objects or components” on page 45

”Select objects based on hierarchy” on page 50

Edit > Select All by Type

The items in this submenu select every object of a certain type in the 
scene. 

Related topics

”Select objects or components” on page 45

Edit > Quick Select Sets

The items in this submenu correspond to the quick selection sets you 
create with Create > Sets > Quick Select Set. Use this menu to quickly 
switch between common selections.

Related topics

”Save and reuse a selection” on page 49

”Create > Sets > Quick Select Set” on page 55

Edit > Paint Selection Tool

Lets you select components by painting over them with the stylus. See 
also “How Artisan brush tools work” in the Paint Effects, Artisan, and 3D 
Paint guide.

Related topics

”Select components by painting” on page 50

Edit > Paint Selection Tool > 

The options described below are unique to the Paint Selection Tool. 
Descriptions of the rest of the options and sections in the Paint Selection 
Tool settings editor can be found in “Common Artisan Brush Tool Settings” 
in the Paint Effects, Artisan, and 3D Paint guide. 

Paint Operations

Select one of the following paint operations.

Select  Selects painted components. 

Unselect Unselects selected painted components.
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Reference > Edit > Paint Selection Tool
Toggle Unselects selected components and selects 
unselected components. 

Add to Current Selection

By default, this option is turned on so that each stroke adds to the 
previous selection. This means you do not have to press the Shift key 
when you make a brush stroke to select, unselect, or toggle the selection of 
more components. If you want each stroke to override the previous one, 
turn Add to Current Selection off. 

Select All

Selects all components on the selected surface(s).

Unselect All

Unselects all selected components on the selected surface(s).

Toggle All

Selects all unselected components and unselects all selected components 
on the selected surface(s).

ToggleUnselectSelect

Tips • To unselect selected components while Select is chosen, press 
the Ctrl (Windows, Linux, and IRIX) or Control (Mac OS X) 
key and paint over them. Similarly, when Unselect is chosen, 
press the Ctrl or Control key and paint to select unselected 
components.

• Press u + left mouse button and select the paint operation from 
the marking menu instead of the from the Tool Settings editor.

Before selection Select All Toggle AllUnselect All
Basics 

54



2 | Selecting

Reference > Create > Sets > Quick Select Set
Create

Create > Sets > Quick Select Set

Creates a new “quick select set” from the current selection. The new 
selection set appears in the Edit > Quick Select Sets submenu.

You can edit the membership of an existing quick select set with the 
Relationship Editor.

Related topics

”Save and reuse a selection” on page 49

”Edit > Quick Select Sets” on page 53

”Relationship Editor” on page 259
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Reference > Create > Sets > Quick Select Set
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3 Viewing the scene
How do I? View the scene and change the 
display

Move and rotate the camera

Tumble, track, dolly, or tilt the view

To look around in a scene, you move the virtual camera associated with a 
view panel.

Hold Drag To...

Alt The left mouse button

Tumble

Alt The middle mouse button

Track
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3 | Viewing the scene 
How do I? > Tumble, track, dolly, or tilt the view
These keyboard shortcuts actually correspond to tools. While it is much 
more convenient to use these keyboard shortcuts, you may occasionally 
want to use the tool form, or set the options for the tool:

”View > Camera Tools > Tumble Tool” on page 80

”View > Camera Tools > Track Tool” on page 81

”View > Camera Tools > Dolly Tool” on page 82

To roll (tilt) the camera

1 In a view panel, choose View > Camera Tools > Roll Tool.

2 Drag the left mouse button to roll the camera.

To zoom the camera lens

1 In a view panel, choose View > Camera Tools > Zoom Tool.

2 Drag the left mouse button to zoom the camera lens.

Related topics

”Use the mouse to control camera azimuth, elevation, yaw or pitch” 
on page 59

”Return to previous views” on page 60

”View > Camera Tools > Zoom Tool” on page 83

”View > Camera Tools > Roll Tool” on page 83

Alt The right mouse button
or
The left and middle 
mouse buttons

Dolly

Alt + Ctrl The left mouse button Draw a box around the part 
of the view you want to 
dolly in on.
• If you drag the box out 

from left to right, you 
dolly in.

• If you drag the box out 
from right to left, you 
dolly out.

Hold Drag To...
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3 | Viewing the scene

How do I? > Use the mouse to control camera azimuth, elevation, yaw or pitch
Use the mouse to control camera azimuth, 
elevation, yaw or pitch

Related topics

”Tumble, track, dolly, or tilt the view” on page 57

”Return to previous views” on page 60

”View > Camera Tools > Azimuth Elevation Tool” on page 83

”View > Camera Tools > Yaw Pitch Tool” on page 84

”View > Camera Tools > Fly Tool” on page 85

Center the view on selected or all objects

Related topics

”Return to previous views” on page 60

In a panel, choose... holding the left mouse button ..

View > Camera Tools > 
Azimuth Elevation Tool

• Drag left and right to change the 
azimuth.

• Drag up and down to change the 
elevation.

View > Camera Tools > Yaw 
Pitch Tool

• Drag left and right to change the 
yaw.

• Drag up and down to change the 
pitch.

View > Camera Tools > Fly 
Tool

• Drag to change yaw and pitch.

• Hold Ctrl and drag up and down to 
move forward and back.

To... Do this

Show the selected objects In the panel menus choose View > Frame 
selected or press F.

Show all objects In the panel menus choose View > Frame all.

Point the camera at the 
selected objects but don’t 
move the camera.

In the panel menus choose View > Look at 
selection.
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3 | Viewing the scene 
How do I? > Return to previous views
”Show or hide objects” on page 64

Return to previous views

Related topics

”Tumble, track, dolly, or tilt the view” on page 57

”Center the view on selected or all objects” on page 59

Change and resize panels

Change the panel layout

You can set up the division of the main window into panels, adjust their 
size, and change the contents of panels between view and editors.

To... Do this

Go back in the view history. In a panel, choose View > Previous or 
press [.

Go forward in the view history. In a panel, choose View > Next or 
press ].

Bookmark the current view. In the panel menus choose View > 
Bookmarks > Edit bookmarks.

Click New bookmark.

Change the name of the bookmark 
to something descriptive.

Return to a bookmarked view. In the panel menus choose View > 
Bookmarks and then click the name 
of the bookmark.

Create a shelf button for a 
bookmark

In the panel menus choose View > 
Bookmarks > Edit bookmarks.

Click the bookmark.

Click Add to shelf.
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3 | Viewing the scene

How do I? > Change the panel layout
To... Do this

Switch to a saved layout 
of panels.

• Click one of the Quick Layout buttons 
below the toolbox.

or

• In a panel, choose an item from the 
Panels > Saved Layouts submenu.

Change the number and 
division of panels

• Press the right mouse button on the 
panel contents proxy (at the bottom of 
the Quick Layout buttons below the 
toolbox) to show the layout menu.

or

• In a panel, choose an item from the 
Panels > Layouts submenu.

Resize the panels Drag the dividers between panels. Drag the 
point where the dividers cross to resize all 
panels at the same time.

Switch between panel 
layout and filling the 
screen with the active 
panel.

Tap the space bar.

Set the contents of a 
panel.

• Click the icon for that panel in the 
layout proxy below the layout 
thumbnails, then choose a panel from 
the pop-up menu.

or

• In the panel, choose an item from the 
Panels > Panel submenu.

Use a preset layout of 
panels.

In a panel, choose an item from the Panels > 
Saved layouts menu.

Go back in the panel 
layout history.

In a panel, choose Panels > Layouts > 
Previous arrangement.

Go forward in the panel 
layout history.

In a panel, choose Panels > Layouts > Next 
arrangement.
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3 | Viewing the scene 
How do I? > Create a window from the contents of a panel (tear off)
Related topics

”Control what camera is shown in a view” on page 62

”Create a custom panel layout” on page 274

”Quick layout buttons” on page 69

”Panel editor” on page 93

Create a window from the contents of a panel 
(tear off)

Control what camera is shown in a view

When you start a new scene it has four default cameras: persp 
(perspective), front, side, and top. You can assign a view panel to show 
the view through one of these camera, or create new cameras and assign 
them.

To... Do this

Copy a panel into a floating 
window.

In the panel, choose Panels > Tear Off 
Copy.

Move the contents of a panel 
into a floating window and 
change the panel’s contents.

In the panel, choose Panels > Tear Off.

To... Do this

Assign a camera to a 
view

In the panel, open the Panels menu and 
choose a camera from the Perspective or 
Orthographic submenu.

or

If the camera object is visible in the scene, 
select it and in the panel choose Panels > 
Look Through Selected.

Create a new camera for 
a view

In the panel, choose Panels > Perspective > 
New or Panels > Orthographic > New.
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3 | Viewing the scene

How do I? > Show, hide, or change the grid
Show, hide, or change the grid

Related topics

”Show information over top of a view (heads-up display)” on page 63

”Display > Grid” on page 69

”Show > Grid” on page 86

Show information over top of a view (heads-
up display)

In the Display > Heads Up Display submenu, turn items on or off.

Related topics

”Create a custom heads-up display readout” on page 291

”Display > Heads Up Display” on page 71

Change the display of objects

Change the look and smoothness of the 
selected objects

Changing the smoothness affects how accurately Maya draws NURBS and 
subdivision surfaces on screen. It does not affect the actual geometry of 
the surface. Using a rougher display results in faster screen drawing for 
complex scenes.

You can also change whether Maya draws the object as a wireframe (only 
lines), with shading (showing the solid surfaces), or shaded with textures.

To... Do this

Show or hide the grid in all 
view panels.

Choose Display > Grid.

Hide the grid in one panel. In the panel, choose Show > Grid.

Edit the spacing, look, and 
extent of the grid.

Choose Display > Grid > ❑.
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3 | Viewing the scene 
How do I? > Show or hide objects
Related topics

”Tumble, track, dolly, or tilt the view” on page 57

”Show or hide objects” on page 64

”Change an object’s wireframe color” on page 68

Show or hide objects

Press... To display the selected objects as

1 Rough

2 Medium

3 Fine

You can also use Display > NURBS Smoothness > Hull 
and Display > Subdiv Smoothness > Hull to get an even 
faster/rougher approximation of a NURBS or subdivision 
surface than the “Rough” option.

4 Wireframe

5 Shaded

6 Shaded with hardware-rendered textures

You can also use X-ray shading, which automatically 
displays objects with slight transparency to let you see and 
select things behind opaque surfaces.

In a view panel, select Shading > Shade Options > X-ray.

To... Do this

Hide the selected objects. Choose Display > Hide > Hide Selection.

Redisplay the last 
object(s) you hid.

Choose Display > Show > Show Last 
Hidden.

Show all hidden objects. Choose Display > Show > All.
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3 | Viewing the scene

How do I? > Show or hide components
Related topics

”Show or hide components” on page 65

”Show or hide object-specific UI” on page 66

”Show an isolated subset of objects or components in a panel” on 
page 67

Show or hide components

Use the items in the Display > NURBS Components, Display > Polygon 
Components, and Display > Subdiv Surface Components submenus, as 
well as the Display > Hide and Display > Show menus submenus.

Hide or show all objects 
of a specific type.

• To change the display of all panels, use 
the items in the Display > Hide and 
Display > Show sub-menus.

• To change the display of one panel, use 
the items in the panel’s Show menu.

Show a specific hidden 
object.

Select the object’s node in one of the editors 
and choose Display > Show > Show 
Selection.

Select a hidden object. Use the Outliner or Hypergraph to select the 
object’s node.

Hide the actual geometry 
of an object while leaving 
other components 
visible.

Choose Display > Object Display > No 
Geometry.

Show only an object’s 
bounding box.

Choose Display > Object Display > 
Bounding Box.

Tip When you are in component selection mode, Maya automatically 
shows the components on the selected objects.

To... Do this
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3 | Viewing the scene 
How do I? > Show or hide object-specific UI
Related topics

”Show or hide objects” on page 64

Show or hide object-specific UI

To... Do this

Show or hide geometry 
components on the 
selected objects.

Use the Display > NURBS Components, 
Display > Polygon Components, and 
Display > Subdiv Surface Components 
submenus.

Show CVs on all NURBS 
surfaces.

Choose Display > Show > All Surface CVs.

Show or hide backfaces 
(polygon faces hidden 
behind other faces) on 
the selected polygons.

Choose Display > Component Display > 
Backfaces.

To show or hide... Do this

A lattice deformer 
attached to the selected 
object.

Choose Display > Component Display > 
Lattice Points to show or hide the control 
points on the lattice.

Choose Display > Component Display > 
Lattice Shape to show or hide the lattice 
object.

Pivot points on the 
selected objects.

Choose Display > Component Display > 
Rotate Pivots or Display > Component 
Display > Scale Pivots.

Selection handles 
attached to the selected 
objects.

Choose Display > Component Display > 
Selection Handles.

Manipulators on the 
selected cameras or 
lights.

Use the Display > Camera/Light 
Manipulator submenu.
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How do I? > Show an isolated subset of objects or components in a panel
Related topics

”Show or hide objects” on page 64

Show an isolated subset of objects or 
components in a panel

Use the Isolate Select feature (Show > Isolate Select > View Selected) to 
show only certain objects or components in a view panel.

Unlike the Display > Hide commands, the Isolate Select feature can also 
isolate components (polygon faces, NURBS CVs, or subdivision surface 
mesh faces), and only affects the display, not rendering.

Each panel maintains its own Isolate Select settings.

To... Do this

Only show the selected 
objects/components in a 
panel.

In the panel, choose Show > Isolate Select 
> View Selected.

Always only show the 
selected objects in the panel 
as the selection changes.

In the panel, turn on Show > Isolate 
Select > Auto Load Selected Objects.

Choose whether new 
objects will or won’t be in 
the isolated subset.

In the panel, turn Show > Isolate Select > 
Auto Load New Objects on or off.

Add or remove objects in 
the isolated subset when 
Auto Load is off.

In the panel:

• To change the isolated subset to the 
current selection, choose Show > 
Isolate Select > Load Selected 
Objects.

• To add the current selection to the 
isolated subset, choose Show > 
Isolate Select > Add Selected Objects.

• To remove the current selection from 
the isolated subset, choose Show > 
Isolate Select > Remove Selected 
Objects.
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How do I? > Change an object’s wireframe color
Related topics

”Show or hide objects” on page 64

Change an object’s wireframe color

You can assign different wireframe colors to objects to make them easier 
to keep track of in the view panels.

Related topics

”Change the look and smoothness of the selected objects” on page 63

”Change user interface colors” on page 273

Save and reuse isolation 
settings.

In the panel:

• To save the current isolation settings, 
choose Show > Isolate Select > 
Bookmarks > Bookmark Current 
Objects.

• To recall an isolated subset, choose it 
from the Show > Isolate Select > 
Bookmarks submenu.

To... Do this

Change an object’s 
wireframe color.

Select the object(s) and choose Display > 
Wireframe Color.

Change the colors 
available in the 
wireframe color palette.

Choose Display > Wireframe Color and 
double-click a color swatch.

or

Choose Window > Settings/Preferences > 
Colors. On the General tab, open the User 
Defined section.

Make an object use the 
default wireframe color.

Select the object(s) and choose Display > 
Wireframe Color, then click Default.

To... Do this
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Reference > Quick layout buttons
Reference Tools

Quick layout buttons

The quick layout buttons let you switch to one of a few common panel 
layouts quickly.

• Click one of the layout thumbnails to switch to the pictured layout 
and panels.

• Press the right mouse button on one of the layout thumbnails to 
change the layout/panels the button loads.

• Press the left mouse button on a box in the layout thumbnail at the 
bottom to change the content of a panel in the current layout.

• Press the right mouse button on the layout thumbnail to change the 
current layout.

Related topics

”Change the panel layout” on page 60

”Create a custom panel layout” on page 274

”Panel editor” on page 93

Menus

Display

Display > Grid

Shows or hides the grid in all view panels.

When the grid is visible, you can turn it off in an individual panel using 
the panel’s Show > Grid item.

Single Perspective View

Four View

Persp/Outliner

Panel/Layout

Persp/Graph/Hypergraph

Quick Layout buttons
Persp/Graph

Hypershade/Persp
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Reference > Display > Grid
Related topics

”Show, hide, or change the grid” on page 63

”Show > Grid” on page 86

Display > Grid > 

Size

You can change the size and length of the grid, set the number of 
subdivision lines, and the increment for the grid lines.

Length and Width

Sets the number of units for the length and width of the grid. The 
default is 12 units.

Grid Lines Every 

Displays a grid line every n units. The default is 5.

Subdivisions

Specifies the number of divisions between major grid lines. Setting the 
Subdivisions option to a value greater than 1 specifies that each main 
grid interval is subdivided by the amount specified. The default is 5.

Color

You can change the color of the axes, grid lines and labels, and 
subdivision lines.

Axes

Specifies a color for the X and Z axes on the grid. The default is dark 
grey.

Grid Lines & Numbers

Specifies a color for the grid lines and the grid line numbers. The 
default is light grey.

Subdivision Lines

Specifies a color for the subdivision lines. The default is light grey.

Note You can also change the color of the axes, grid lines and numbers, 
and subdivision lines in the Colors window (Window > Settings/
Preferences > Colors). Go to the Inactive tab and then the Modeling 
category to find these color options. Here you can also change the 
color of the X-, Y-, and Z-axis that appear in the Origin and View 
axes.
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Reference > Display > Heads Up Display
Display

You can turn on and off the display of grid elements, including axes, 
thicker lines for axes, grid lines, subdivision lines, and grid line numbers.

Axes

Turns on or off the display of the axes. The default is on.

Thicker Line for Axes

Turns on or off the display of thicker lines for the axes. The default is 
on.

Grid Lines

Turns on or off the display of the grid lines. The default is on.

Subdivision Lines

Turns on or off the display of the subdivision lines. The default is on.

Perspective Grid Numbers

In the Perspective view, you can set the grid line numbers to display 
on the axes, along the edge of the grid, or just hide them.

Orthographic Grid Numbers

In the Orthographic views (top, side, front), you can set the grid line 
numbers to display on the axes, along the edge of the grid, or just hide 
them.

Hide Hides the grid line numbers. This is the default for 
both Perspective and Orthographic Grid Numbers.

On Axes Displays the grid line numbers along the axes. 

Along Edge Displays the grid line numbers along the edge of the 
grid.

Display > Heads Up Display

This submenu contains a number of readouts you can show or hide over 
top of the view panel content.

Note To restore the default grid option settings, select Edit, Reset 
Settings in the Grid Options window. However, this does not 
restore the default grid color settings. To restore the default 
colors, go to the Colors window (Window > Settings/Preferences 
> Colors) and select Edit, Reset to Defaults. This restores all color 
defaults, including the grid colors.
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Reference > Display > Heads Up Display
Related topics

”Show information over top of a view (heads-up display)” on page 63

”Create a custom heads-up display readout” on page 291

Items

Object Details

Displays a list of object details that includes: Backfaces, Smoothness, 
Instance, Display Layer, Distance From Camera and number of 
Selected Objects. The details are displayed in the top-right corner of 
the panel. The default is off.

Poly Count

Displays polygon statistics for the visible objects displayed in the view 
panel, including Vertices, Edges, Faces, Triangles, and UVs. This 
feature is useful for games development. The first column on the left 
lists the total components of all the polygons in the scene. The second 
column lists the total components of the selected polygon(s). The third 
column lists the total selected components. The default is off. 

Animation Details

Turns on or off the display of a list of animation details, which 
include: Playback Speed, Current Character, and IK Solver Enable. 
The details are displayed above the Frame Rate in the bottom-right 
corner of the panel. The default is off.

Camera Names

Displays the camera name (persp, top, side, front) in the bottom-
center of camera views. The default is on.

Frame Rate

Displays the frame rate in Hertz (fps) for the current port in the 
bottom-right corner. The default is off.

View Axis

Displays the global axis in the bottom-left corner of all views. The 
default is on.

Origin Axis

Displays the global axis at the origin (0, 0, 0) within the perspective 
view. The default is on.
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Reference > Display > Hide, Show
Display > Hide, Show

Use Display > Hide to hide items you aren’t working on and reduce visual 
clutter. This is handy if you want to remove an object from the view, but 
do not want to delete it or move it. 

To redisplay items, use the Display > Show submenu, which includes the 
same selections as Display > Hide. 

Related topics

”Show or hide objects” on page 64

The Hide menu items are:

Items

Hide Selection

Hides selected object(s).

Hide Unselected Objects

Hides all unselected objects.

Object 
Details

Camera 
Name

Animation 
Details

Origin Axis

View Axis

Poly Count
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Reference > Display > Hide, Show
Hide Unselected CVs

To control the display of CVs, select the CVs that you want to remain 
visible, and then use Display > Hide > Hide Unselected CVs to hide 
all the other CVs on that surface. This affects the display of CVs in 
component selection mode, as well as CVs displayed in object 
selection mode by the use of Display > NURBS Components > CVs.

The selective CV display function operates exclusively from other 
Maya Hide and Show commands, and therefore menu selections such 
as Display > Show > All and others do not effect CVs whose display 
has been set using selective CV display.

All

Hides all objects, whether they are selected or not.

Hide Geometry

Displays a menu that lets you select the type of geometry you want to 
hide.

Hide Kinematics

Displays a menu that lets you select the type of kinematics you want 
to hide.

Hide Deformers

Displays a menu that lets you select the type of deformers you want to 
hide.

Hide Cloth

Available only if you have Maya Unlimited and are using Maya Cloth. 
Hides cloth objects. For details, see Cloth.

Lights

Hides lights.

Cameras

Hides cameras.

Texture Placements

Hides texture placements.

Tip It is possible to use selective CV display on more than one surface 
at a time.
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Reference > Display > Wireframe Color
Construction planes

Hides construction planes.

Animation Markers

Hides animation markers.

Light Manipulators

Hides light manipulators.

Camera Manipulators

Hides camera manipulators.

Display > Wireframe Color

Lets you set the wireframe color of the selected objects. You can leave the 
color selection window open and keep selecting and applying colors.

Display > Object Display

The items in this submenu control the display and selectability of the 
selected objects.

• Bounding box draws a box around the total space occupied by each 
object.

• Geometry shows or hides the actual geometry of the object (for 
example, the surface or polygon mesh). This lets you turn on the 
display of components (such as CVs) but turn off the actual object 
itself.

Related topics

”Change the look and smoothness of the selected objects” on page 63

”Show or hide objects” on page 64

Display > Component Display

The items in this submenu let you show or hide object-specific UI in the 
view windows.
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Reference > Display > Component Display
Related topics

”Show or hide components” on page 65

”Show or hide object-specific UI” on page 66

Items

Backfaces

If you selected a polygonal object, turns on or off the display of the 
object’s backfaces. 

Lattice Points

If you selected a lattice deformer (an L icon represents a lattice 
deformer handle), turns on or off the display of the lattice points. For 
information on lattices, see Character Setup.

Lattice Shape

If you selected a lattice deformer, turns on or off the display of the 
object’s lattice shape. The lattice deformer switches between 
displaying its lattices and the L icon. For information on lattices, see 
Character Setup.

Local Rotation Axes

Turns on or off the display of the object’s local rotation axes.

Joint Labels

Turns on or off the display of joint labels in the scene view for selected 
joints.

Rotate Pivots

Turns on or off the display of the object’s rotate pivots.

Scale Pivots

Turns on or off the display of the object’s scale pivots.

Backfaces No backfaces
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Reference > Display > Camera/Light Manipulator
Selection Handles

Turns on or off the display of selection handles on manipulators.

Display > Camera/Light Manipulator

Camera items

Center of Interest

Turns on or off the display of the camera’s center of interest manipulator.

Pivot

Turns on or off the display of the camera’s pivot.

Clipping Planes

Turns on or off the display of the camera’s clipping planes.

Cycling Index

Turns on or off the display of the camera’s cycling index. By clicking 
on this control, you can cycle through the available manipulator 
controls one at a time for the selected camera.

Light items

Center of Interest

Turns on or off the display of a light’s center of interest manipulator.

Pivot

Turns on or off the display of a light’s pivot.

Cone Angle

Turns on or off the display of a light’s cone angle.

Penumbra

Turns on or off the display of a light’s Penumbra.

Look Through Barn Doors

Barn doors are doors or shutters fitted on the spotlight, which let you 
create a square spot effect. Shows the view through the spotlight’s 
barn doors. These manipulators appear when you are in Render View 
or are looking through the selected light (Panels > Look Through 
Selected).

Decay Regions

Turns on or off the display of a light’s decay regions.
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Reference > Window > Frame All in All Views, Frame Selection in All Views
Cycling Index

Turns on or off the display of the light’s cycling index. By clicking on 
this control, you can cycle through the available manipulator controls 
for the selected light one at a time.

For more information about creating lights and editing light 
attributes, see Rendering.

Window

Window > Frame All in All Views, Frame 
Selection in All Views

Tracks and dollies all view panels to show all objects or the selected 
objects.

To show all objects or the selected objects in a specific view panel, use the 
panel’s View menu.

Related topics

”Center the view on selected or all objects” on page 59

Panel menus

View > Camera Settings

Perspective

Turn Perspective on so that the camera uses a perspective view. This 
means that the lines converge at infinity. If turned off, the camera uses 
an orthographic view.

Journal

Turn Journal on to copy camera view actions, such as tumble, track, 
and zoom, to the MEL journal making the commands undoable. 
Normally, the camera command view actions are not copied to the 
MEL journal and they are not undoable. For more information on the 
MEL journal, see MEL.

No Gate

Displays no frustrum. This is the default.
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Reference > View > Camera Settings
Film Gate

Displays the viewable frustum according to the film back size. The 
aspect ratio of the window (or rendering resolution) determines what 
you actually see. Also sets the camera Overscan attribute to 1.5. The 
following illustration shows the film gate representing the maximum 
viewable (or renderable) area.

Resolution Gate

Displays the renderable frustum for the current resolution specified in 
Render Globals. This often specifies a more exact rendered image than 
the Film Gate option. Also sets the camera Overscan attribute to 2.0.

Field Chart

Turn Field Chart on to display a grid that represents the twelve 
standard cell animation field sizes. The largest field size (number 12) 
is identical to the rendering resolution (the resolution gate). Render 
Resolution must be set to NTSC dimensions for this option to have 
meaning.

Safe Action

Turn this option on to display a box defining the region that you 
should keep all of your scene’s action within if you plan to display the 
rendered images on a television screen. The safe action view guide 
represents 90% of the rendered resolution (the resolution gate). 
Render Resolution must be set to NTSC dimensions for this option to 
have meaning.

Note If the aspect ratio between the film back and the resolution is the 
same, then the two resulting rendered images match.

Film Back Gate
Basics

79



3 | Viewing the scene 
Reference > View > Camera Tools > Tumble Tool
Safe Title

Turn this option on to display a box defining region that you should 
keep titles (text) within if you plan to display the rendered images on 
a television screen. The safe title region represents 80% of the 
rendered resolution (the resolution gate). Render Resolution must be 
set to NTSC dimensions for this option to have meaning.

Fill

Automatically selects a horizontal or vertical fit so that the selected 
image fills the render frame. 

Horizontal

Selects a horizontal fit for the selected image in the render frame.

Vertical

Selects a vertical fit for the selected image in the render frame.

Overscan

Selects a slightly larger fit for the selected image in the render frame.

View > Camera Tools > Tumble Tool

Revolves the camera by varying the azimuth and elevation angles in a 
perspective view. You can also press alt + the left mouse button. Hold 
Shift to constrain the camera movement.

Related topics

”Tumble, track, dolly, or tilt the view” on page 57

View > Camera Tools > Tumble Tool > 

Tumble scale

Scales the speed of the camera movement. The slider range is 0.01 to 
10. The default value is 1.

Tumble camera about

Center of Interest

The camera tumbles about its center of interest. Tumble camera about 
is set to Center of interest by default.

Tumble Pivot

The camera tumbles about its pivot point. This tumble pivot can also 
be set in the camera’s Attribute Editor.These values are stored in 
world space coordinates. 
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Reference > View > Camera Tools > Track Tool
View operations such as Frame Selection, Frame All, Look at 
Selection, Default Home, and Bookmarks all set the tumble pivot.

Orthographic views

Locked

If on, you cannot tumble an orthographic camera. If off, you can 
tumble an orthographic camera. Locked is on by default.

Stepped

If on, you can tumble an orthographic camera in discrete steps. The 
Stepped operation lets you easily return to the Default Home 
positions. If off, you can tumble an orthographic camera smoothly. 
Stepped is only available if Locked is off. Stepped is on by default.

Ortho step

The angle of steps (in degrees) that you can tumble an orthographic 
camera when Locked is off and Stepped is on. The valid range is 0.01 
to 180. The default value is 5.

View > Camera Tools > Track Tool

Tracks the camera vertically and horizontally. You can also press alt + the 
middle mouse button. Hold Shift to constrain the camera movement.

Related topics

”Tumble, track, dolly, or tilt the view” on page 57

View > Camera Tools > Track Tool > 

Track Geometry

If off, as the camera moves an object moves at a speed that may be 
different than the speed of the cursor. This problem occurs with 
objects far from the camera. Track Geometry is off by default.

If on, as the camera moves, an object moves at the same speed as the 
cursor. The object selected at the beginning of the Track operation 
remains under the cursor.Tracking is slower (especially if there are 
many objects in the scene) if Track Geometry is on. 

Track Scale

Scales the speed of the camera movement. The slider range is 0 to 100. 
The default value is 1.
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Reference > View > Camera Tools > Dolly Tool
View > Camera Tools > Dolly Tool

Tracks the camera forward and backward. You can also press alt + the 
right mouse button (or alt + the left and middle mouse buttons). Use Ctrl 
+ Alt + the left mouse button to drag a marquee around the area you want 
to dolly in on.

Related topics

”Tumble, track, dolly, or tilt the view” on page 57

View > Camera Tools > Dolly Tool > 

Scale

Scales the speed of the camera movement. The slider range is 0.01 to 
10. The default value is 1.

Dolly

Local

If on, drag in the camera’s view to move the camera toward or away 
from its center of interest. If off, drag in the camera’s view to move 
both the camera and its center of interest along the camera’s sight line. 
Local is on by default.

Center of Interest

If Center of Interest is on, MMB-drag in the camera’s view to move the 
camera’s center of interest toward or away from the camera. If off, 
drag in the camera’s view to move the camera toward or away from 
its center of interest. LMB-marquee a region and snap the center of 
interest to the center of those objects.Center of Interest is off by 
default.

If Center of Interest (and/or Local) and Bounding box are on, when 
you drag in the views, a red line with a small x at the end points to 
indicate the Center of Interest. 

Snap box dolly to

A box dolly moves the center of interest to the marquee region when 
you use the Ctrl-Alt-drag (Windows, Linux, and IRIX) or Control-
Option-drag (Mac OS X) method to dolly the camera.

Surface

If on, when you perform a box dolly (Ctrl-drag or Control-drag) on an 
object, the center of interest moves onto the surface of the 
object.Calculating the surface point is slower if Smooth Shade mode is 
off (and especially if there are many visible objects in the scene). 
Basics 

82



3 | Viewing the scene

Reference > View > Camera Tools > Zoom Tool
Bounding box

If on, when you perform a box dolly (Ctrl-drag or Control-drag) on an 
object, the center of interest moves to the center of the object’s 
bounding box. Bounding Box is on by default.

View > Camera Tools > Zoom Tool

Changes the focal length on a camera. Zooming in is like using a telephoto 
lens. Zooming out is like using a wider angle lens.

You can use zoom in both a perspective or orthographic view.

To move in or out without changing the viewing angle, use Dolly.

Related topics

”Tumble, track, dolly, or tilt the view” on page 57

”Use the mouse to control camera azimuth, elevation, yaw or pitch” 
on page 59

View > Camera Tools > Zoom Tool > 

Zoom Scale

Scales the speed of the camera movement. The slider range is 0.01 to 3. 
The default value is 1.

View > Camera Tools > Roll Tool

Rotates the display around its horizontal axis.

Related topics

”Tumble, track, dolly, or tilt the view” on page 57

”Use the mouse to control camera azimuth, elevation, yaw or pitch” 
on page 59

View > Camera Tools > Roll Tool > 

Roll Scale

Scales the speed of the camera movement. The slider range is 0.01 to 
10. The default value is 1.

View > Camera Tools > Azimuth Elevation 
Tool

Revolves the camera about the center of interest in the perspective view.
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Reference > View > Camera Tools > Yaw Pitch Tool
The angle of a camera’s sight line relative to the ground plane is also 
referred to as its elevation; the angle of a camera’s sight line relative to a 
plane perpendicular to the ground plane is also referred to as its azimuth.

Related topics

”Tumble, track, dolly, or tilt the view” on page 57

”Use the mouse to control camera azimuth, elevation, yaw or pitch” 
on page 59

View > Camera Tools > Azimuth Elevation Tool > 

Scale

Scales the speed of the camera movement. The slider range is 0.01 to 
10. The default value is 1.

Rotation type

Controls whether the camera movement is an Azimuth Elevation 
movement or a Yaw Pitch movement.

View > Camera Tools > Yaw Pitch Tool

Tilting a camera means rotating the camera up or down; panning a 
camera means rotating the camera left or right. The scene in the camera’s 
view moves in the opposite direction.

The angle of rotation up or down is also referred to as pitch; the angle of 
rotation left or right is also referred to as yaw.

Related topics

”Tumble, track, dolly, or tilt the view” on page 57

”Use the mouse to control camera azimuth, elevation, yaw or pitch” 
on page 59

View > Camera Tools > Yaw Pitch Tool > 

Scale

Scales the speed of the camera movement. The slider range is 0.01 to 
10. The default value is 1.

Tip Press Shift to constrain the camera’s movement.
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Reference > View > Camera Tools > Fly Tool
Rotation type

Controls whether the camera movement is a Yaw Pitch movement or 
an Azimuth Elevation movement.

View > Camera Tools > Fly Tool

Lets you navigate your scene as if you were playing a 3D first-person 
perspective game. The camera flies through your scene without being 
constrained by any geometry. 

• Hold Ctrl and drag up to fly forward or down to fly backward.

• To change the camera direction, release the Ctrl or Control key and 
drag the left mouse button.

• Tumble, track, and dolly are available while the Fly Tool is active.

Show menu

Use the items in this menu to show or hide specific object types in a panel.

Related topics

”Show or hide objects” on page 64

Show > Isolate Select

Lets you limit a panel to show only an isolated subset of all objects in the 
scene.

Related topics

”Show an isolated subset of objects or components in a panel” on 
page 67

Items

View Selected

Activates or deactivates the isolate select feature. When activated, the 
word “Isolate” appears at the bottom of the panel and the current 
selection becomes isolated.

Tip Press Shift to constrain the camera’s movement.
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Reference > Show > Grid
Auto Load New, Selected Objects

Turn on to automatically update the isolate select panel when you add 
new objects or change your selection. If turned off, you must use the Load, 
Add, or Remove Selected Objects options to update the panel.

Load, Add, Remove Selected Objects

If you don’t have auto load on, you can use these options to control the 
isolate select display. Select items from the isolate panel or another panel 
and then load, add, or remove them as needed. Note that Load Selected 
Objects replaces the display with the current selection, while Add Selected 
Objects adds the current selection to the selections already displaying. 

Bookmarks

Enables you to bookmark an isolated selection. To create a bookmark, 
choose Show > Isolate Select > Bookmarks > Bookmark Current Objects. 
Choose the option box if you want to name the bookmark; otherwise, a 
default name is used. 

To view bookmarked items, choose Show > Isolate Select > Bookmarks > 
BookmarkName. Choose it again to turn it off and return to the previous 
view. You can view multiple bookmarks at the same time.

Bookmarks are saved with the scene as a set.

Show > Grid

Allows you to turn the grid off in a single panel.

Related topics

”Show, hide, or change the grid” on page 63

”Display > Grid” on page 69

Shading menu

The Shading menu provides a number of ways to look at your scene. The 
quality can range from a simple wireframe display to a smooth- shaded 
view.

Related topics

”Change the look and smoothness of the selected objects” on page 63

Wireframe

Draws edges for polygon meshes and isoparametric curves for 
surfaces. This is the default shading quality.
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Reference > Shading menu
Smooth Shade All

Displays all surfaces, meshes, and particles as smooth-shaded objects.

Smooth Shade Selected Items

Displays selected items as smooth-shaded objects.

Flat Shade All

Displays all surfaces and meshes as flat-shaded objects.

Flat Shade Selected Items

Displays selected items as flat-shaded objects.

Bounding Box

Shows objects as boxes that represent their bounding volumes. 
Bounding boxes speed up Maya operations and can make a significant 
difference for complex models.

The bounding box encompasses the hulls as well as the actual 
geometry. As a result, the bounding box may have dimensions larger 
than those of the geometry.

Points

Shows objects as groupings of individual points.

Shade Options

There are three display options for shaded objects.

Wireframe on 

Shaded Superimposes a wireframe display on all shaded 
objects in a view.

Note To see bounding box coordinates, open the Attribute Editor, 
click on the shape node tab, and open the Object Display section. 
It shows the read-only minimum and maximum world space 
boundary coordinates of a surface along the X, Y, and Z axes. 

Wireframe isoparms 
appear over the 
shaded objects
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Reference > Shading menu
X-Ray Displays all shaded objects as semi-transparent. This 
can be useful for seeing hidden parts of a model.

Transparency 

Sorting Draws transparent objects in order corresponding to 
their distance from the camera. This is not 
equivalent to transparency sorting in high-quality 
rendering. 

Interactive Shading

Controls the display of objects during interactive modes (such as 
transformations, camera navigation, and playbacks). At the same time 
the normal display can be in some sort of shaded mode. For example, 
the normal display can be smooth-shaded while the interactive 
display is bounding box. There are four interactive shading options:

High Quality 

Rendering There are several sub-options for the high-quality 
rendering setting. You can choose from: 

Shaded 

Wireframe Displays objects in wireframe mode during the 
interactive mode.

Bounding Box Displays objects as bounding boxes during the 
interactive mode.

Points Displays objects as points during the interactive 
mode.

Color Index Mode

On Linux and IRIX only, lets you manipulate a wireframe object in a 
complex scene more quickly (for example, if you are using a full-color 
image plane while working in wireframe mode).

Backface Culling

For objects displayed in smooth shade or flat shade mode, makes the 
object’s back face transparent which helps speed the display or 
manipulation of objects.

Smooth Wireframe

Displays smooth wireframed objects in Maya’s 3D views, including 
the Hardware Render Buffer and the 3D Paint Effects view.

Note Does not work in 2D views, including the UV Texture Editor.
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3 | Viewing the scene

Reference > Lighting menu
Hardware Texturing

Displays Maya's hardware textured rendered results as if they were 
being displayed in an external viewer. (See also the Rendering book in 
the Maya documentation set.)

Hardware Fog

Simulates hardware fog effects achievable in programs outside of 
Maya. Displays how a spotlight's fog is distributed before you render. 
Used for preview purposes, Hardware Fog only displays in the 
perspective view. (See also the Rendering book in the Maya 
documentation set.)

Apply Current to All

Applies the current 3D view's shading style to all objects in the scene.

Lighting menu

Use the items in this menu to select which lights or groups of lights to use 
in your scene.

Related topics

”Change the look and smoothness of the selected objects” on page 63

Items

Use Default Lighting

Lights the scene using only a single point light situated at the camera.

Use All Lights

Uses all lights in the scene, to a maximum of eight lights. This option 
gives you a representation of what the lights look like when the image 
is rendered.

Use Selected Lights

Uses only selected lights. If you change the light selection, the lighting 
also changes respectively.

Note This option does not include the default light.

If there are no lights in the scene, the scene renders as an all 
black image.
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Reference > Panels menu
Use Previously Specified Lights

Select this option to use the lights selected with the Specify Selected 
Lights option. This option is grayed until you choose Specify Selected 
Lights. If you select a different set of lights when this option is 
selected, the scene still uses the previously selected lights.

Two Sided Lighting

Turn this option on to illuminate both sides of an object. Note that 
Maya’s performance may decrease on some systems.

Shadows

This menu item is only available on cards with Transform and Lighting 
capabilities. Display hardware shadow maps from directional and spot 
lights for geometry (NURBS, polygons, subdivision surfaces) and 
particles (points, multipoints, and spheres only). These hardware 
shadow maps can be calculated and displayed on graphics cards with 
drivers that support the ARB_multitexture and 
EXT_texture_env_combine OpenGL extensions (such as graphics 
cards with NVidia GeForce or Quadro GPU, or ATI Radeon 8800). See 
the Rendering guide for details on how to preview hardware shadow 
maps.

Specify Selected Lights

Lets you use a preset selection of lights. Select the lights you want to 
use then select Specify Selected Lights. Once specified, turn on 
Lighting > Use Previously Specified Lights to use this light selection. 
Unlike Use Selected Lights, if you change the light selection, the scene 
will still use the previously selected lights. For additional information 
on lighting, see Rendering.

Panels menu

The items in this menu let you set the contents of this specific panel as 
well as the overall layout and panel contents.

Related topics

”Change the panel layout” on page 60

”Control what camera is shown in a view” on page 62

Note This menu item can be turned off by picking any of the items 
above it.
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3 | Viewing the scene

Reference > Panels menu
”Create a custom panel layout” on page 274

”Quick layout buttons” on page 69

”Panel editor” on page 93

Items

Perspective

Lets you change to a perspective view or create a new perspective 
view.

Orthographic

Lets you change to an orthographic view or create a new orthographic 
view.

Look Through Selected

Lets you look through a selected camera, object, or light.

Panel

Displays a menu containg the following:

Outliner Opens the Outliner, where you can view objects and 
their attributes hierarchically.

Graph Editor Opens the Graph Editor where you can edit visual 
representations of keys and animation curves 
(keysets). For more information, see Animation.

Dope Sheet Opens the Dope Sheet, where you can edit event 
and sound synchronization and timing. For more 
information, see Animation.

Trax Editor Opens the Trax Editor, where you can create and 
edit time-independent clips of character animation. 
For more information, see Animation.

Hypergraph Opens the Hypergraph, which gives you an 
overview of your entire scene, all objects it contains, 
and the relationships between those objects.

Hypershade Opens the Hypershade, which you can use to create 
and edit rendering nodes, and to view and edit 
rendering (or shading) networks. For more 
information, see Rendering.

Visor Opens the Visor, which you can use to show images 
of shading nodes you can create, those already in 
your scene, and those in online libraries, in a visual 
outline form. For more information, see Rendering.
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3 | Viewing the scene 
Reference > Panels menu
UV Texture 

Editor Opens the UV Texture Editor window, which you 
use to map textures to a polygonal model. For more 
information, see Polygonal Modeling.

Render View Opens the Render View window, where you can test 
render single frames and interactively tune 
rendering attributes. For more information, see 
Rendering.

Blend Shape Lets you create character deformations. For more 
information, see Character Setup.

Dynamic 

Relationships Lets you view or edit connections between 
dynamics elements such as particle emitters, 
collisions, etc. For more information, see Dynamics.

Devices Lets you use external tools and plug-ins for special 
devices, such as Motion Capture.

Relationship 

Editor Opens the Relationship Editor, which you can use to 
group and manipulate objects as sets and assign 
shading groups to geometry.

Reference 

Editor Opens the Reference Editor, which you can use to 
specify settings for importing files by reference.

Component 

Editor Opens the Component Editor, which you can use to 
edit data assigned to components.

Paint Effects Opens the Paint Effects Panel, where you can 
interactively render strokes without rendering the 
rest of the scene. New strokes render as you paint 
them in this view. For more information, see 
Painting.

Layouts

Lets you specify how different camera views are arranged spatially in 
the Maya window. 

Saved Layouts

Lets you select a panel layout.

Tear Off

Moves the current camera view into a separate window. The current 
view is replaced with the next view in the Panels list (to see this list, 
select Panels > Panel Editor).
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Reference > Panel editor
Tear Off Copy

Copies the current camera view into a separate window.

Panel Editor

Opens the Panel editor window, where you can create new panels, re-
label existing panels, rename layouts, and change layout 
configurations.

Windows and editors

Panel editor

To show the panel editor, choose Panels > Panel Editor in a panel

Tabs

Panels

Displays existing panels you can rename or delete.

• Select a panel and edit the Label field to rename it. You cannot rename 
the Top, Side, Front, or Persp view panels.

• Select a panel and click Delete to remove it from the list.

New Panel

Contains controls for creating a new panel type.

”Add a new panel to the list of available panels” on page 275
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Reference > Panel editor
Layouts

Displays existing panel layouts.

• Click New Layout to add an item to the list.

• Click a layout and click the Edit Layouts tab to edit it.

• To delete a layout, click it in the list, then click Delete.

Edit Layouts

Displays the current panel layout for editing.

”Create a custom panel layout” on page 274

Configurations 

Use this tab to change the configuration and proportions of the layout.

From the pull-down menu, select the panel layout you want.

Resize the panes by dragging the borders in the thumbnail view of the 
layout. The main window changes to reflect your changes.
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3 | Viewing the scene

Reference > Panel editor
Contents

Use this tab to change which panel contents appear in the layout.

Scene 

Independent  Scene independent layouts are available for all 
scenes. Their contents are defined by panel types. 

If you have multiple panels of the same type in a 
scene, it is not certain which panels show up when 
you select your layout. This is not a problem in most 
cases; however, if you are working in a particular 
scene a great deal, then develop layouts that you can 
save specifically with that scene.

Associated with 

Scene These layouts are only usable with the current 
scene. You can specify a particular panel if you have 
more than one of the same type.
Basics

95



3 | Viewing the scene 
Reference > Panel editor
History

Displays the history of the panels you used.

Maya keeps a record of panel layout changes. This lets you step forward 
or back through each view. This is helpful if you are moving between two 
layouts and cannot remember their names.

History Depth

Specify the number of configurations you want stored in the history.

Wrap History

Toggle this on to return you to the first view or the most recent view 
configuration when you reach the end of recorded history.
Basics 

96



3 | Viewing the scene

Reference > Camera node
Clear History

Click this button to delete the record of all the panels you have used.

Previous Layout

Click this button to browse back through the panel layouts.

Next Layout

Click this button to browse forward through the panel layouts.

Nodes

Camera node

Auto Render Clip Plane

If on, Maya automatically sets the near and far clipping planes so they 
enclose all objects within the camera’s view. All objects render and depth 
precision problems are eliminated. Clipping planes are only available to 
the software renderer (not visible in the views).

If off, the near and far clipping planes are set to the Near Clip Plane and 
Far Clip Plane values. Auto Render Clip Plane is on by default.

In some cases you should turn off Auto Render Clip Plane:

• to ensure frames rendered from previous versions of Maya exactly 
match frames rendered from Maya 4.5

• to limit which objects render based on their distance from the camera

Film Back

The Film Back attributes control the basic properties of a camera (for 
example, the camera’s film format: 16mm, 35mm, 70mm).

Film Gate

Lets you select a preset camera type. Maya automatically sets the 
Camera Aperture, Film Aspect Ratio, and Lens Squeeze Ratio. To set 
these attributes individually, set Film Gate to User. The default setting 
is User.

Camera Aperture

The height and width of the camera’s aperture or film back, measured 
in inches. The Camera Aperture determines the relationship between 
Focal Length and Angle of View. The default values are 1.417 and 
0.945.
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Reference > Camera node
Film Aspect Ratio

The ratio of the camera aperture’s width to its height. Maya 
automatically updates the Film Aspect Ratio (and vice versa). The 
valid range is 0.01 to 10. The default value is 1.5.

Film Offset

Vertically and horizontally offsets the resolution gate and the film 
gate relative to the scene. Changing the Film Offset produces a two-
dimensional track. Film Offset is measured in inches. The default 
setting is 0.

Depth of Field

These attributes provide control over the camera’s focus.

Depth Of Field

If on, some objects in the scene are sharply focused and others are 
blurred or out of focus, based on their distance from the camera. If off, 
all objects in the scene are sharply focused. Depth Of Field is off by 
default.

Focus Distance

The distance from the camera at which objects appear in sharp focus, 
measured in the scene’s linear working unit. Decreasing the Focus 
Distance also decreases the depth of field. The valid range is 0 to ∞. 
The default value is 5.

F Stop

The range of distances from the camera within which objects appear 
in sharp focus (the depth of field). The range of distances is centered 
on the Focus Distance. The range is smaller toward the camera and 
larger away from the camera. The valid range is 1 (small depth of 
field) to 64 (large depth of field). The default value is 5.6.

1 The view guide fills the view. The edges of the view guide may 
be exactly aligned with the edges of the view, in which case the 
view guide are not visible.

> 1 The higher the value, the more space is outside the view guide.

Tip The more out of focus an image is, the longer it takes to generate 
the final rendered image (that is, the post-render blur takes longer.)
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3 | Viewing the scene

Reference > Camera node
Focus Region Scale

Scales the Focus Distance value. The valid range is 0 to ∞. The default 
value is 1.

Output Settings

Control whether a camera generates an image during rendering, and what 
types of images the camera renders.

Renderable

If on, the camera can create an image file, mask file, and/or depth file 
during rendering. By default, Renderable is on for the default 
perspective camera, and off for all other cameras.

Image

If on (and Renderable is on), the camera creates an image file during 
rendering. The default setting is on.

Mask

If on (and Renderable is on), the camera creates a mask during 
rendering. A mask is an 8-bit channel (the alpha channel) in the image 
file that represents objects in shades of gray. Black areas represent 
areas where there are no objects (or fully transparent objects), and 
white areas represent areas where there are (solid) objects. Masks are 
used primarily for compositing.

Note Changing the Camera attribute in the Image File Output section 
of the Render Globals window can change the Renderable setting 
in a camera’s Attribute Editor.

Note If the Image Format in the Render Globals window is not set to 
Maya IFF, Maya16 IFF, RLA,or one of the alpha channel enabled 
formats which are supported by QuickTime, the camera does not 
include the mask information in the alpha channel of the image 
file. Instead, it creates a separate mask file. See also the Render 
Globals chapter in the Rendering book.
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Reference > Camera node
Depth

If on (and Renderable is on), the camera creates a depth file during 
rendering. A depth file is a type of image file that represents the 
distance of objects from the camera by shades of gray. Depth files are 
used primarily for compositing. When on, the Depth Type attributes 
(next) are enabled.

Depth Type

Determines which objects Maya uses to create the Depth file.

Closest Visible Depth

Uses the closest object to the camera. When transparent objects are 
located in front of other objects, turn on Transparency Based Depth to 
ignore the transparent object.

Furthest Visible Depth

Most often used when a Particle Effect is occluded by an opaque 
object. Maya uses the Furthest Visible Depth to create a Depth file.

Transparency Based Depth

Turns on Threshold, which determines which object is closest to the 
camera, based on transparency. Transparency Based Depth is only 
enabled when you select Closest Visible Depth. 

Threshold

Used when compositing multiple layers of transparency (which varies 
from 0 to 1). For example, if Threshold is 0.9 (the default), when 
transparent surfaces add up to 0.9 or larger, the surface becomes 
opaque.

Environment

Control the appearance of the scene’s background as seen from the 
camera. Different cameras can use different backgrounds.

Background Color

The color of the scene’s background. The default color is black.

Tip When transparent objects are located in front of other objects, 
you can turn on Transparency Based Depth to ignore the 
transparent object.
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3 | Viewing the scene

Reference > Camera node
Image Plane

Creates an image plane and attaches it to the camera. Clicking the 
Create button automatically changes the focus of the Attribute Editor 
to include attributes for an image plane. See the Rendering book for 
details about Image Plane attributes.

Special Effects

Shutter Angle

Controls the blurriness of motion blurred objects. 

In a real-world camera, the shutter is actually a metal disk that is 
missing a pie-shaped section. This disk sits between the lens and the 
film, and rotates at a constant rate. When the missing section is in 
front of the film, it allows light from the lens to pass through and 
expose the film. The larger the angle of the pie-shaped section, the 
longer the exposure time, and moving objects are more blurred. 
Shutter Angle is measured in degrees. The valid range is 1 to 360. The 
default value is 144.

Display Options

Controls the display of view guides in the camera’s view, and provides 
options for moving the camera. You can also access most of these 
attributes in any panel’s View > Camera Settings pull-out menu.

Display Film Gate

Displays a rectangle that indicates the area of the camera’s view that a 
real-world camera would record on film. The dimensions of the film 
gate represent the dimensions of the camera aperture. The film gate 
view guide indicates the area of the camera’s view that renders only if 
the aspect ratios of the camera aperture and rendering resolution are 
the same.

Display Resolution

Displays a rectangle that indicates the area of the camera’s view that 
renders. The dimensions of the resolution gate represent the rendering 
resolution. The rendering resolution values are displayed above the 
resolution gate. See also the Rendering book.

Note Motion Blur must be on in the Render Globals window and in at 
least one object’s Attribute Editor for the Shutter Angle to have 
any effect.
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3 | Viewing the scene 
Reference > Camera node
Display Field Chart

Displays a grid that represents the twelve standard cel animation field 
sizes. The largest field size (number 12) is identical to the rendering 
resolution (the resolution gate). See also the Rendering book.

Display Safe Action

Displays a rectangle indicating the region in which all of the scene’s 
action takes place if you plan to display the rendered images on a 
television screen. The safe action view guide represents 90% of the 
rendering resolution (the resolution gate). See also the Rendering 
book.

Display Safe Title

Displays a rectangle indicating the region in which to keep titles (text) 
if you plan to display the rendered images on a television screen. The 
safe title view guide represents 80% of the rendering resolution (the 
resolution gate). See also the Rendering book.

Journal Command

If on, all camera movements are written to the Script Editor and 
become part of the undo queue which lets you undo or redo them. 
This also lets you copy camera movements and use them for other 
cameras or scenes.

If off, you cannot undo or redo camera movements. Use Previous 
View or Next View instead. Journal Command is off by default. 

Center of Interest

The distance from the camera to the center of interest, measured in the 
scene’s linear working unit. 

Tumble Pivot

The point the Tumble tool pivots the camera about when Tumble 
Camera About is set to Tumble Pivot in the Tumble Tool settings 
window. 

Orthographic Views

When you create a camera from the Create menu, the default view is 
perspective. If you want an orthographic camera view, click the 
Orthographic check box and change the Orthographic Width if necessary.

The Orthographic Views attributes also let you control the field of view 
for orthographic cameras.
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4 Transforming 
objects
About 3D

Transformations

Transformations change an object’s position, size, and orientation without 
changing its shape. “Transform” is basically a fancy way of saying “Move, 
Scale, and/or Rotate”.

Transformations are relative to an object’s (or component’s) pivot point, 
and take place along/around either the world axes, object axes, or local axes.

In Maya, the transformations you make to an object are saved in a 
transform node. That is, Maya remembers that the object is rotated 32,0,5 
degrees and moved -3,6.2,7 cm from its original position.

When you group objects together, each group remembers its own 
transformations. This lets you create hierarchical animations easily.

Related topics

”The pivot point” on page 103

”World space, object space, and local space” on page 104

”Nodes and attributes” on page 149

”Move, rotate, or scale objects” on page 110

”Set transformation values to zero” on page 115

”Group objects together” on page 227

The pivot point

Pivot points control how objects rotate and scale, and also represent the 
exact locations of objects in space. All transformations to an object are 
relative to the pivot point:

You can change the pivot point of an object or the selected components by 
pressing Insert or Home and using the pivot point manipulator.

Transformation Relationship to Pivot

Move Moves the pivot point (and the object 
travels along with it).
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About > World space, object space, and local space
Related topics

”Change the pivot point” on page 113

”Move, rotate, or scale objects” on page 110

World space, object space, and local space

3D positions and transformations exist within coordinate systems called 
spaces.

World space is the coordinate system for the entire scene. Its origin is at 
the center of the scene. The grid you see in view windows shows the 
world space axes.

Object space is the coordinate system from an object’s point of view. The 
origin of object space is at the object’s pivot point, and its axes are rotated 
with the object.

Scale Scales object out from or in toward the 
pivot point.

Rotation Rotates object around the pivot point.

Transformation Relationship to Pivot
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4 | Transforming objects

About > Construction history
Local space is similar to object space, however it uses the origin and axes 
of the object’s parent node in the hierarchy of objects. This is useful when 
you haven’t transformed the object itself, but it is part of a group that is 
transformed.

Related topics

”Transformations” on page 103

”The pivot point” on page 103

Maya’s interface

Construction history

As you work in Maya, most of your actions create nodes in the 
construction history of the objects you work on. At each point in your 
work, the current scene is the result of all the nodes you’ve created so far.

For example, you can revolve a curve around a centerpoint to create a new 
surface with a cross-section in the shape of the curve. When you apply 
this action to the curve, a new revolve node is created. The new node has 
the shape of the curve as an input. It has attributes that control how it 
creates the surface from the curve. And it has the resulting surface as its 
output.

This chain of nodes, from the curve to the revolve node to the surface, is 
called the surface’s construction history. The most important thing about 
construction history is that you can change it. You can reshape the curve, 
or change the attributes on the revolve node, and the resulting surface 
updates automatically.

Construction history is part of Maya’s dependency graph. While 
construction history refers to the history of actions that created the scene, 
the entire dependency graph refers to all connections (input and output) 
between nodes.

Related topics

”Edit completed commands (construction history)” on page 121

”Show a custom manipulator for the selected node” on page 122

”Nodes and attributes” on page 149

”Dependency graph” on page 153
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About > Construction planes
Construction planes

A construction plane is a construction aid that can make creating objects 
with orientations other than along XYZ easier. When you make a 
construction plane “live”, all drawing is locked to the plane.

Related topics

”Snap to the grid, a curve, points, or a view plane” on page 116

”Snap all creation tools to a surface or construction plane” on 
page 117

Copies vs. instances

The Duplicate command lets you create a “real” duplicate or a lightweight 
“instance” of the original.

This lets you create armies and forests full of duplicate objects without 
needing the memory or computing power to handle that much actual 
geometry.

An instance is like an alias or shortcut or symbolic link in a file system. It 
doesn’t have its own shape, it’s just a visual pointer back to the original. 
However each instance has its own transform node so it can have its own 
position, rotation, and scaling.

An instance stays linked to the original so when the original changes the 
instance changes too. If you move a control point on the original, all 
instances automatically update. The instances do not have their own 
control points.

(In the Outliner an instance appears to have its own shape node but this is 
actually shared with the original.)

Limitations

• Instanced lights have no effect.

• Some functions, such as extrude and insert, cannot be used on 
instances.

• You can’t apply clusters and deformations to instances, although you 
can of course use them on the original.

• There is always at least one non-instanced transformation node 
between the instance nodes and the actual geometry nodes.

• You cannot create a hierarchy of instances. If you create an instance of 
an instance node, Maya simply makes a new sibling.
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4 | Transforming objects

How do I? > Use manipulators
• File referencing connects objects by name. If you replace a reference 
with a different file, instanced objects within both files should have 
the same name. Otherwise you may encounter errors when retrieving 
the scene.

Related topics

”Duplicate” on page 124

How do I? Transform objects and components

Use manipulators

The Move, Rotate, and Scale tools show a manipulator on the selected 
objects. You move, rotate, or scale the objects by dragging handles on the 
manipulator.

Other tools and objects can also have manipulators. Usually these are the 
same manipulators (or combinations of the manipulators) used the move, 
rotate, or scale tools.

Position manipulator

• Drag an arrow to move along that axis.

• Drag the center handle to move freely across the view plane.

• Click a handle to make it active (yellow), then drag the middle mouse 
button anywhere in a view window to move along the active handle.

• Hold Shift and drag the middle mouse button up and down or left 
and right to move in that direction.

• In a perspective view, Ctrl-click an arrow to switch the center handle 
to move across an axis plane.

Ctrl-click the center handle to switch it back to moving across the 
view plane.

Y handle

Center handle

X handleZ handle
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How do I? > Use manipulators
Rotation manipulator

• Drag the rings to rotate around the different axes.

• Drag the outer ring to rotate around the view axis.

Scale manipulator

• Drag a box to scale along that axis.

• Drag the center box to scale uniformly in all directions.

• Click a handle to make it active (yellow), then drag the middle mouse 
button anywhere in a view window to move along the active handle.

• Hold Shift and drag the middle mouse button up and down or left 
and right to scale in that direction.

Drag to rotate in the 
Y direction

Drag to 
rotate in the 
X direction

Drag the virtual 
sphere area to rotate 
in X, Y and Z

Drag the outer 
ring to rotate 
about view axis

Drag to rotate in the 
Z direction

Drag to scale in the 
Z direction

Drag to scale in 
the Y direction

Drag to scale in the 
X direction

Drag to scale 
proportionally
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4 | Transforming objects

How do I? > Use manipulators
Combined move/rotate/scale manipulator

This manipulator combines the handles from the Position, rotation, and 
scale manipulators in one. The Move/Rotate/Scale tool and Proportional 
Modification tool use this manipulator.

When a move or scale handle is active, the axis rotation rings are hidden. 
Click the outer ring rotation ring to show all rotation handles.

Some tools add another handle projecting from the center of the 
manipulator. Clicking this handle switches the manipulator axes between 
world and local space.

Complex manipulators

Many objects/nodes have manipulators that let you control the attributes 
of the node. Often these manipulators are based on the position, rotation 
and scale manipulators, although some objects and nodes (for example, 
the spotlight) use complex custom manipulators.

Partial curve manipulators

Some actions (such as Revolve) let you operate on only part of a curve 
using the Curve Range: Partial option.

When you show manipulators for an action with a partial curve, boundary 
handles appear on the curve that let you adjust what part of the curve is 
used.
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Related topics

”Transformations” on page 103

”World space, object space, and local space” on page 104

”Move, rotate, or scale objects” on page 110

Lock a manipulator to the current selection

1 Select the object or objects.

2 Choose the Move, Rotate, Scale, or Show Manipulator tool.

3 Click the Lock current selection icon in the toolbar.

While the lock icon is on, you cannot select other objects using this 
tool. Clicking or dragging the left mouse button operates the active 
manipulator handle (like the middle mouse button does normally).

Click the Lock current selection icon again to unlock the manipulator.

Move, rotate, or scale objects

To move

• Choose the Move tool or press w.

• Use the position manipulator to change the position of the selected 
objects.

• Hold w and press the left mouse button to show a marking menu of 
options and actions related to the Move tool.

To rotate

• Choose the Rotate tool or press e.

• Use the rotation manipulator to rotate the selected objects. The 
selection rotates around the pivot of the key object.

• Hold e and press the left mouse button to show a marking menu of 
options and actions related to the Rotate tool.

To scale

• Choose the Scale tool or press r.

• Use the scale manipulator to scale of the selected objects. The selection 
scales from the pivot of the key object.

• Hold r and press the left mouse button to show a marking menu of 
options and actions related to the Scale tool.
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To use the combined Move/Rotate/Scale tool

This tool shows the move, rotate, and scale handles all in one 
manipulator. You may find it easier to use than the individual tools when 
you’re performing a lot of move, rotate, and scale operations on an object 
to get it into position.

• Choose Modify > Transformation Tools > Move/Rotate/Scale Tool.

To type exact transformation values

1 Choose the Move, Rotate, or Scale tools.

2 Set the pop-up menu next to the numeric input field to Absolute (abs) 
or Relative (rel).

3 Click the input field and type X, Y, and Z values separated by spaces.

You can also type -a or -r before the numeric input to switch to 
absolute or relative mode. For example -a 5 2 1.

Related topics

”Transformations” on page 103

”Use manipulators” on page 107

”Move, rotate or scale components proportionally” on page 111

”Change the pivot point” on page 113

”Flip objects” on page 114

”Transform along different axes” on page 114

”Modify > Transformation Tools > Move Tool, Rotate Tool, Scale Tool, 
Show Manipulator Tool” on page 135

Move, rotate or scale components 
proportionally

The Proportional Modification tool lets you move a manipulator and have 
the surrounding control points follow proportional to their distance from 
the moving point. This effect is controlled by the Distance Cutoff setting.
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“Proportional modification” is sometimes shortened to propmod.

To transform the selected components proportionally

1 Select the components you want to modify. Only the selected 
components are influenced by the tool.

2 Choose Modify > Transformation Tools > Proportional Modification 
Tool > .

3 Use the options in the tool options panel to control how distance is 
measured and how quickly the influence of the manipulator falls of 
with distance:

• Set the Modification Type to World to calculate distance in world 
space. Set it to Parametric to calculate distance across the surface 
(Parametric only works on NURBS).

• Set Modification Falloff to Linear to have influence fall off at a 
steady rate. Set it to Power to have influence fall off very quickly.

4 Press Insert or Home to change the manipulator to pivot point mode. 
Drag the manipulator to move it where you want the center of 
influence. Press Insert or Home again to change the manipulator back 
to normal mode.

5 Use the other handles on the manipulator to move or scale the selected 
components based on their distance from the manipulator.

Related topics

”Use manipulators” on page 107

”Move, rotate, or scale objects” on page 110
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Change the pivot point

To move the selected object’s pivot

1 Choose a transformation tool such as the move tool, rotate tool, or 
scale tool.

2 Press the Insert or Home key to switch the manipulator to pivot point 
mode.

3 Use the manipulator to move the pivot point.

4 Press Insert or Home again to switch the manipulator back to normal 
mode.

To move the pivot point using exact values

1 Show the Attribute Editor and click the transform node’s tab.

2 In the Pivots section, turn on the pivot display options so you can see 
the effects of editing the pivot values.

3 Do one of the following:

• In the Local Space section, type X, Y, and Z coordinates for the 
Rotate Pivot and Scale Pivot relative to the object’s origin.

• In the World Space section, type X, Y, and Z coordinates for the 
Rotate Pivot and Scale Pivot relative to the world origin.

To reset the selected object’s pivots to center

1 Choose the Rotate or Scale tool.

2 Choose Modify > Center Pivot.

To make the selected object’s pivot points visible in the 
scene

• Choose Display > Component Display > Rotate Pivots and Display > 
Component Display > Scale Pivots.

To keep the pivot in place while working with components

When you transform components, Maya creates a temporary pivot at the 
center of the selected components. Because the pivot is always at the 
center of the selection, selecting or deselecting additional components 
moves the pivot.

You can lock the pivot in place so it won’t move as components are added 
to or removed from the selection.

1 Press the Insert or Home key to show the pivot point manipulator.

2 Move the pivot point.
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3 Click the circle at the top of the pivot point manipulator to lock or 
unlock the pivot point for component transformations. When the circle 
is filled, the pivot is locked.

Related topics

”Transformations” on page 103

”The pivot point” on page 103

”Modify > Center Pivot” on page 144

Flip objects

Scaling an object by a negative amount in one or more directions has the 
same effect as flipping it across its axes.

1 Click the Scale tool and then click the object you want to flip.

2 In the toolbar press the right mouse button on the input box and set it 
to Numeric Input: Absolute or Numeric Input: Relative.

3 In the text box, type three numbers representing X, Y, and Z, 
separated by spaces. To flip the object across an axis, enter -1 for that 
axis, otherwise type 1.

For example, to flip the object across Y, type 1 -1 1. To flip the object 
across X and Z, type -1 1 -1.

4 Press Enter.

Related topics

”Transformations” on page 103

”Move, rotate, or scale objects” on page 110

”Change the pivot point” on page 113

Transform along different axes

In the Move tool and Rotate tool, you can choose what axes to use.

Note If the pivot point of an object is changed from its default value, 
duplicating multiple copies of that object results in additional 
transforms to the channels of the duplicated transform node. 
However, the resulting position, orientation and the pivots of the 
duplicated objects will be correct. To avoid these extra 
transforms, the duplicate command should be invoked with No 
of copies set to 1. The hotkey g can then be used as many times 
as needed. 
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Move tool

• Object moves along an object’s own rotated axes.

• Local moves along an object’s parent’s rotated axes.

• World moves along the world (grid) axes.

• Normal lets you move CVs on a NURBS surface along U, V, or 
Normal directions.

Rotate tool

• Local rotates around an object’s own axes.

• Global rotates around the world (grid) axes. When this option is on 
the rings do not rotate with each other but instead stay locked to the 
world axes.

• Gimbal changes only the X, Y, or Z rotation value. In local and global 
modes, the rings may change more than one of the rotation XYZ 
channels.

Related topics

”Transformations” on page 103

”World space, object space, and local space” on page 104

”Move tool” on page 127

”Rotate tool” on page 129

Set transformation values to zero

When you transform an object, Maya stores it in a transform node as the 
difference from its original (zero) position. These menu items let you 
control this saved transformation information for an object.

To... Do this

Reset transformations on 
the selected object back 
to zero (return to first or 
last “frozen” position).

Choose Modify > Reset Transformations.

Make the selected 
object’s current 
transformations be the 
zero position.

Choose Modify > Freeze Transformations.
Basics

115



4 | Transforming objects 
How do I? > Snap to the grid, a curve, points, or a view plane
Related topics

”Transformations” on page 103

”Modify > Reset Transformations, Freeze Transformations” on 
page 139

Align and snap

Snap to the grid, a curve, points, or a view 
plane

When using the Move tool and various creation tools, you can snap to 
existing objects in the scene.

To snap a move, press the middle mouse button on the object you want to 
snap to (pressing the left mouse button just selects the object).

Related topics

”Snap all creation tools to a surface or construction plane” on 
page 117

To snap to... Hold Or turn on this icon in the 
toolbar

Grid 
intersections

x

Curves c

CV, vertex, or 
pivot

v

View plane

Note If you have snapping turned on and drag an arrow on the 
position manipulator (as opposed to the center), the manipulator 
snaps to the first available point along that axis.
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Snap all creation tools to a surface or 
construction plane

You can set a surface so that all creation tools (such as the curve drawing 
tools) are locked on to the surface. This does not affect actions (such as the 
create primitives commands).

To snap creation tools to the selected surface

• Click the “Make the selected object live” icon on the toolbar, or choose 
Modify > Make Live.

While the Make live icon is on, creation tools snap to the surface. Click 
the icon again to stop snapping to the surface.

To snap creation tools to a plane

1 Choose Create > Construction Plane > ❐, set the initial orientation of 
the plane and click Create.

2 Use the Move and Rotate tools to orient the plane.

3 Select the plane and choose Modify > Make Live.

While the Make live icon is on, creation tools snap to the surface. Click 
the icon again to stop snapping to the surface.

Related topics

”Construction planes” on page 106

”Snap to the grid, a curve, points, or a view plane” on page 116

”Create > Construction Plane” on page 144

Align objects

To align objects using an interactive manipulator

1 Choose Modify > Snap Align Objects > Align Tool.

2 Select the objects you want to align.

Note When you use Make Live to snap a curve to a NURBS surface, 
the curve becomes a curve-on-surface and you can use it to trim.

For more information, search the online help for Trim Curves
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The other objects align to the last selected (key) object. This object is 
highlighted in green.

3 Do any of the following:

• Click an icon to align the objects. The icons show how the 
bounding boxes align. For example:

• Use Edit > Undo or press z to reverse an align.

In the following example, the objects align to the far right of the cube 
outside the transparent box.

To align objects by setting options

1 Select the objects you want to align.

2 Choose Modify > Snap Align Objects > Align Objects > .

This is the object the
other objects align to.

Align tops. Align bottoms. Align tops to the 
bottom of the key 
object.

Align centers.

Objects align
to the far right
of the cube.
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3 Choose the align mode. Min aligns objects along the side closest to 0. 
Max aligns objects to the side farthest from 0. Mid aligns centers. Dist 
distributes objects equally along the distance between them. Stack 
moves objects so they are lined up with no space between them.

4 Choose which axes to align along. For example, to align tops/bottoms 
turn on World Y.

5 Choose what to move the objects to. Selection Average moves the 
objects to the average of the object’s coordinates. Last selected object 
moves the objects to the key object. This object is highlighted in green.

6 Click Align.

Related topics

”Snap one object to another” on page 119

”Modify > Snap Align Objects > Align Objects” on page 141

”Modify > Snap Align Objects > Align Tool” on page 142

Snap one object to another

To snap objects together with interactive control

1 Choose Modify > Snap Align Objects > Snap Together Tool.

2 Click the point on the first object you want to snap.

3 Click the point on the second object you want to snap to.

4 An arrow appears showing how the objects snap together. To change 
the points, click or drag new points on either object.

5 Press Enter to snap the objects together.

The Snap Together Tool normally moves and rotates the objects to make 
the points touch. Use the tool settings to make the tool move the objects 
without rotation.
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To snap two objects together at one point

1 Select the point that will move.

2 Shift-select the point to snap to.

3 Choose Modify > Snap Align Objects > Point to Point.

Maya moves the first point’s object so the two points touch.

To snap two objects together at two points

1 Select two points on the object that will move.

2 Shift-select two points on the object to snap to.

3 Choose Modify > Snap Align Objects > 2 Points to 2 Points.

Maya moves the first object so the first point you selected on each 
object touch, and the second point you selected on each object touch.

To snap two objects together at three points

1 Select three points on the object that will move.

2 Shift-select three points on the object to snap to.

3 Choose Modify > Snap Align Objects > 3 Points to 3 Points.

Maya moves the first object so the first point you selected on each 
object touch, the second point you selected on each object touch, and 
the third point you selected on each object touch.

Related topics

”Snap to the grid, a curve, points, or a view plane” on page 116

”Snap all creation tools to a surface or construction plane” on 
page 117

”Align objects” on page 117

”Modify > Snap Align Objects > Point to Point, 2 Points to 2 Points, 3 
Points to 3 Points” on page 140

”Modify > Snap Align Objects > Align Objects” on page 141

”Modify > Snap Align Objects > Align Tool” on page 142

”Modify > Snap Align Objects > Snap Together Tool” on page 143

Tip You can also use the Snap Together Tool on polygon edges. 
Press the right mouse button on an object and choose Edge from 
the marking menu to enter edge selection mode, then apply the 
Snap Together Tool to polygon edges.
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Change history

Undo, Redo, and Repeat

Related topics

”Edit completed commands (construction history)” on page 121

Edit completed commands (construction 
history)

Most actions you perform in Maya create a node in the dependency graph.

To select and edit history nodes

1 Select the object.

2 Do one of the following:

• Hold the a key and press the left mouse button to show a marking 
menu of commands related to attributes. Choose Select All Inputs.

• Press the left mouse button on the input icon in the toolbar and 
choose a history node from the menu.

• In the Attribute Editor, click the tab for the history node you want 
to edit.

• Click the node’s heading in the Channel Box.

3 Edit the node’s attributes in the Attribute Editor or the Channel Box.

To... Do this

Undo. Choose Edit > Undo or press z.

Redo. Choose Edit > Redo or press Shift + z.

Repeat the last command. Choose Edit > Repeat or press g.

Repeat a recent command. • Choose Edit > Recent Commands to 
show a list of recent commands.

• Hold the space bar to open the 
hotbox and press the left mouse 
button in the Recent Commands area 
on the left to show a menu of recent 
commands.
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To show a custom manipulator for this node, click the Show 
Manipulator tool in the toolbox.

To temporarily turn off creation of construction history

Click the Construction History On/Off icon on the toolbar.

Related topics

”Construction history” on page 105

”Dependency graph” on page 153

”Edit completed commands (construction history)” on page 121

”Show inputs and outputs (dependency graph)” on page 171

”Edit > Delete by Type > History” on page 132

Show a custom manipulator for the selected 
node

Select the node and click the Show Manipulator tool in the toolbox, or 
choose Modify > Transformation Tools > Show Manipulator Tool.

The manipulator lets you edit the attributes of the node visually.

Related topics

”Construction history” on page 105

”Nodes and attributes” on page 149

”Show or hide the manipulator for an attribute in the Channel Box” 
on page 161

Create and edit models

Create geometric primitives

Use the items in the Create > Polygonal Primitives, Create > NURBS 
Primitives, and Create > Subdiv Primitives to add geometric primitives 
such as spheres, cubes, cylinders, cones, planes, and tori to the scene.

Show Manipulator Tool
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Create text

The Create > Text action lets you create curves or surfaces in the shape of 
styled text.

1 Choose Create > Text > ❐.

2 Type the text you want to create.

3 Use the menu button at the right end of the Font box to choose a type 
face and style.

4 Choose one of the following:

• Click Curves to create NURBS curves from the outline of the text.

• Click Trim to create planar NURBS surfaces trimmed to the shape 
of the text.

• Click Poly to create polygonal surfaces in the shape of the text.

5 Click Create.

Notes

• The text is always created starting at the origin in the XY plane. In 
some views it may appear to be a line because it is edge-on to the 
view.

• The letters of the text are individual objects in a group. To transform 
the text, select the group in the Outliner.

• When you use the Curves option, the NURBS curves use CV 
multiplicity to achieve sharp corners.

Related topics

”Create geometric primitives” on page 122

”Annotate or document objects” on page 230

”Create > Text” on page 144

Edit objects

Delete

To... Do this

Delete the selection. Choose Edit > Delete.
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How do I? > Duplicate
Related topics

”Edit > Delete” on page 131

”Edit > Delete by Type > Channels, Static Channels, Non-particle 
Expressions” on page 132

”Edit > Delete All by Type” on page 132

Duplicate

The Duplicate command lets you create multiple copies of the selected 
objects, with optional transformations applied to each copy.

You can also make lightweight references to existing objects, known as 
instances. Instances are linked to the original object, so changing to the 
original automatically updates all its instances.

To duplicate the selected objects

1 Choose Edit > Duplicate > ❑.

2 Set the Geometry Type to Copy.

3 Set the options for the number of copies and the transformations to 
apply to each copy.

Duplicate the selected objects and reapply the last transform

Edit > Duplicate With Transform lets you create a single duplicate of the 
selected object and automatically apply the last transformation you did 
with the current manipulator.

For example, if you move an object 2 units up, then choose Edit > 
Duplicate With Transform, a duplicate object is created and move 2 units 
up again.

To create lightweight instances of the selected objects

1 Choose Edit > Duplicate > ❑.

2 Set the Geometry Type to Instance.

Delete components of a 
certain type from the 
selected objects

Choose an item from the Edit > Delete by 
Type submenu.

Delete all objects of a 
certain type.

Choose an item from the Edit > Delete All by 
Type submenu.

To... Do this
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3 Set the options for the number of copies and the transformations to 
apply to each copy.

Related topics

”Copies vs. instances” on page 106

”Flip objects” on page 114

”Edit > Duplicate” on page 133

”Edit > Duplicate with Transform” on page 135

Edit component numeric values directly

With the Component Editor you can view and edit the numeric values of 
each individual component of an object in a spreadsheet format. For 
example:

• The stiffness of individual springs.

• The colors of individual particles.

• Polygon vertex colors and normals.

• Weights of CVs, vertices, or lattice points with cluster deformers or 
after skinning.

Note If the pivot point of an object is changed from its default value, 
duplicating multiple copies of that object results in additional 
transforms to the channels of the duplicated transform node. 
However, the resulting position, orientation and the pivots of the 
duplicated objects will be correct. To avoid these extra 
transforms, the duplicate command should be invoked with No 
of copies set to 1. The hotkey g can then be used as many times 
as needed. 
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Each component is a row in the spreadsheet. Each value or influence is a 
column.

Related topics

”Component editor” on page 145

To... Do this

Edit components on an 
object.

Select the object and choose Window > 
General Editors > Component Editor.

Show different component 
types or influences.

Click the tabs across the top of the 
Component Editor window.

Enter values in cells. Select all the cells you want to enter the 
same value in, then type the value or use 
the slider at the bottom of the window.

You can select one or more cells, rows, 
columns, or any combination.

Switch between always 
showing the current 
selection and manually 
updating the selection.

In the Component Editor, turn List > Auto 
Update on or off.

When Auto Update is off, use the Load 
Components button to update the 
window with the current selection.

Change the decimal 
precision in the cells.

Select List > Change Precision.
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Reference Tools

Toolbox

Move tool

Shows a move manipulator for the selected objects or components.

Related topics

”Transformations” on page 103

”The pivot point” on page 103

”World space, object space, and local space” on page 104

”Use manipulators” on page 107

”Move, rotate, or scale objects” on page 110

Choosing a coordinate system for the Move Tool

Use the Tool Settings options window to specify the coordinate system for 
the Move Tool.

Object

Moves an object in object space coordinate system. Axis orientation 
includes rotations on the object itself. If several objects are selected, 
each object moves the same amount relative to its own object space 
coordinate system.

Local

Aligns the object to the rotation of the parent object. Movement is 
constrained to those axes in the local space coordinate system. The 
object is aligned to the rotation of the parent object and does not 
include the rotations on the object itself. If several objects are selected, 
each object moves the same amount relative to its own object space 
coordinate system.

World

Moves in the world space coordinate system. The object is aligned to 
the world space axis. This is the default.

Move Tool
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Normal

Moves selected CVs on a NURBS surface in the U or V direction of the 
surface. Typically you would use this option for small sets of CVs. The 
manipulator indicates the surface Normal, U, and V directions.

When you select Normal, the Update [UVN] Triad checkbox appears. 
Turned on, this option causes the manipulator orientation to reflect 
the moved surface rather than the original surface. This is the default. 
Turned off, the manipulator retains the orientation for the original 
surface.

Discrete Move

The Discrete Move setting enables the Relative option and lets you 
specify the amount an object is moved in increments (determined by 
the Step Size value).

Relative

While Maya moves the object, relative spacing is maintained. Turn 
this option off if you don’t want to preserve relative spacing while 
translating.

Step Size

Enter a value to determine the amount an object is moved in 
increments when the Discrete Move option is selected.

Move Snap Settings

The following settings let you snap to polygon face centers and vertices 
while translating. 

Retain Component Spacing

Turned on by default. This means that while Maya moves the 
component, relative spacing is maintained. Turn this option off if you 
don’t want to preserve relative spacing while translating and 
snapping polygonal components.
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Snap to Live Polygon—Face Center or Vertex

These settings let you move and snap to a live polygon’s components 
(face centers and vertices).

To snap to components on a live polygon

1 Select the polygon you want to snap to and click the Make Live icon 
on the Status Line.

2 Double-click the Move icon from the Tool Box to open the Tool 
Settings window.

3 In the Tool Settings window, select a Snap to Live Polygon setting—
Face Center or Vertex.

4 Click the object you want to move and use the center Move 
manipulator handle to drag. The movement is restrained to the 
nearest face centers or vertex locations of the live polygon.

Note: The arrow manipulator handles do not restrain movement.

Rotate tool

Shows a rotation manipulator on the selected objects or components.

Related topics

”Transformations” on page 103

”The pivot point” on page 103

”World space, object space, and local space” on page 104

”Use manipulators” on page 107

”Move, rotate, or scale objects” on page 110

Choosing a rotate mode

Local 

Rotates the object about the object space axes.

Global

Rotates the object about the world space XYZ axes. Notice that in this 
mode the rings never change.

Rotate Tool
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Gimbal 

Changes only the X, Y, or Z rotation value. In local and global modes, 
the XYZ constraint rings may change more than one of the rotation 
XYZ channels.

Discrete Rotate

The Discrete Rotate setting enables the Relative option and lets you 
specify the amount an object is rotated in increments (determined by 
the Step Size value).

Relative

While Maya rotates the object, relative spacing is maintained. Turn 
this option off if you don’t want to preserve relative spacing while 
rotating.

Step Size

Enter a value to determine the amount an object is rotated in 
increments when the Discrete Move option is selected.

Component Use Object Pivot

Lets you rotate object components about the object’s pivot point.

Changing the rotation order and axis orientation 

In the Transform Attributes section of an object’s Attribute Editor, you can 
change the rotation order of the axes by selecting an order from the Rotate 
Order pop-up menu. You can also enter values in the Rotate Axis X, Y, or 
Z boxes to rotate the axes in a specific direction, and to rotate the object 
around a different axis.

Keep in mind that these attributes have a combined effect with the Rotate 
Mode settings in the rotate Tool Settings.

Scale tool

Shows a scale manipulator on the selected objects or components.

Related topics

”Transformations” on page 103

”The pivot point” on page 103

”World space, object space, and local space” on page 104

”Use manipulators” on page 107

”Move, rotate, or scale objects” on page 110

Scale Tool
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Choosing a scale mode

You use the Tool Settings window to specify the behavior for the Scale 
Tool.

or

Use the marking menu when scaling. Press the letter r and the left mouse 
button over a selected object to display the following marking menu. 

Discrete Scale

The Discrete Scale setting enables the Relative option and lets you 
specify the amount an object is scaled in increments (determined by 
the Step Size value).

Relative

While Maya scales the object, relative spacing is maintained. Turn this 
option off if you don’t want to preserve relative spacing while scaling.

Step Size

Enter a value to determine the amount an object is scaled in 
increments when the Discrete Scale option is selected.

Component Use Object Pivot

Lets you scale object components about the object’s pivot point.

Menus

Edit

Edit > Delete

Deletes the selected items.
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Edit > Delete by Type > History

Removes construction history from the selection, “baking” it in its current 
state.

Related topics

”Construction history” on page 105

”Edit completed commands (construction history)” on page 121

”Dependency graph” on page 153

Edit > Delete by Type > Channels, Static 
Channels, Non-particle Expressions

Hierarchy

To delete the component from the selected object only, choose 
Selected. To delete the component from the selected object and all 
objects below it in the DAG hierarchy, choose Below.

Channels

To delete all channels attached to all the selected object’s keyable 
attributes, select All Keyable. To delete channels attached to those 
attributes selected in the Channel Box, select From Channel Box. 
(Instead of Channels, this same option affects Expressions for Non-
particle Expressions.)

Driven Channels

Turn this option on to delete driven channels attached to the selected 
object’s set driven key attributes.

Control Points

Turn this option on to delete channels attached to lattice, polygon, and 
NURBS curves and surface CVs. If you select All Keyable, this is 
automatically turned on. The default is off.

Shapes

Removes the object's geometry channels. If you select All Keyable, this 
is automatically turned on. The default is off.

Edit > Delete All by Type

The items in this submenu let you delete every object of a certain type in 
the scene.
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4 | Transforming objects

Reference > Edit > Duplicate
Related topics

”Delete” on page 123

Edit > Duplicate

Creates one or more duplicates of the selection, optionally with 
transformations applied to each duplicate.

Related topics

”Duplicate” on page 124

”Edit > Duplicate with Transform” on page 135

Edit > Duplicate > 

Translate, Rotate, Scale

Specify the offset values for X, Y, and Z. Maya applies these values to 
the copied geometry. You can position, scale, or rotate objects as Maya 
duplicates them.

Number of Copies

Specify the number of copies to create. The range is from 1 to 1000.

Geometry Type

Select how you want the selected object(s) duplicated.

Copy Make a copy of the geometry being duplicated.

Instance Create an instance of the geometry being duplicated. 
When you create an instance, you do not create 
actual copies of the selected geometry. Instead, 
Maya redisplays the geometry being instanced.

Group under

Group objects under one of the following:

Parent Groups the selected objects under their lowest 
common parent in the hierarchy.

Note The default for Translate and Rotate is 0.0000. The default for Scale 
is 1.0000. With the default values, Maya places the copy on top of 
the original geometry. You can specify offset values (positive or 
negative floating point) for translation, rotation, and scaling that 
are then applied to the copied geometry.
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Reference > Edit > Duplicate
World Groups the selected objects under the world (at the 
top level of the hierarchy).

New Group Create a new group node for the duplicates.

Smart Transform

Turn Smart Transform on so that when you duplicate and transform a 
single copy or instance of the object (without changing the selection), 
Maya applies the same transformations to all subsequent duplicates of 
the selected duplicate.

Duplicate Input Graph

Turn this option on to force the duplication of all upstream nodes 
leading up to the selected object. Upstream nodes are defined as all 
nodes with connections feeding into selected nodes.

For example, if A, B, and C are the upstream nodes connecting to D...

A > B > C > D

...and you select D and use the Duplicate Input Graph option, the 
resultant graph is as follows:

A1 > B1 > C1 > D1

(where A1, B1, C1, and D1 are duplicates of A, B, C, and D 
respectively).

Duplicate Input Connections

Turn this option on so that in addition to duplicating the selected 
node, the connections feeding into the selected node are also 
duplicated. 

For example, if A, B, and C are connections feeding into C...

A > B > C

...and you select C and use the Duplicate Input Connections option, 
then the resultant graph is as follows:

A > B > C and

A > B > C1

(where C1 is a duplicate of C).

Tip As a shortcut for duplicating with Smart Transform on, use Edit 
> Duplicate with Transform. 
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Reference > Edit > Duplicate with Transform
Assign Unique Name to Child Nodes

The child node is renamed when the hierarchy is duplicated.

Instance Leaf Nodes 

Duplicate entire node hierarchies except for the leaf nodes, which are 
instanced to the original hierarchy. The new menu item is an 
improvement over the existing instance menu item, in that all 
dynamic attributes on the non-leaf nodes are properly duplicated into 
the new hierarchy. 

Edit > Duplicate with Transform

Duplicates the selection and applies the last transformation you did with 
the current manipulator.

If you do a transform and then make the manipulator go away (for 
example, but deselecting the object), Maya forgets the last transformation.

Related topics

”Duplicate” on page 124

Modify

Modify > Transformation Tools > Move Tool, 
Rotate Tool, Scale Tool, Show Manipulator 
Tool

These menu items act the same as clicking the Move tool, Rotate tool, 
Scale tool, or Show Manipulator tool in the toolbox.

”Move tool” on page 127

”Rotate tool” on page 129

”Scale tool” on page 130

”Show Manipulator tool” on page 38

Modify > Transformation Tools > Move 
Normal Tool

Use the Move Normal Tool to move selected CVs on a NURBS surface in 
the U or V direction of the surface. This is the same as selecting the 
Normal option for the Move Tool. 

The Update [UVN] Triad check box is turned on by default. 

All other settings are the same as the Move tool.
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Reference > Modify > Transformation Tools > Move/Rotate/Scale Tool
”Move tool” on page 127

Modify > Transformation Tools > Move/
Rotate/Scale Tool

Lets you move, rotate, and scale the selection using a single more complex 
manipulator.

Related topics

”Use manipulators” on page 107

”Move, rotate, or scale objects” on page 110

Modify > Transformation Tools > Default 
Object Manipulator

These items let you use the Move, Rotate, or Scale manipulators with the 
Show Manipulator tool instead of the custom manipulator for a node.

Choose None to show the node’s custom manipulator, rather than a 
transform manipulator. This is the default.

This information is saved with the scene. It is also shown in the Attribute 
Editor in the Transform Display section.

Related topics

”Use manipulators” on page 107

”Show a custom manipulator for the selected node” on page 122

Modify > Transformation Tools > Proportional 
Modification Tool

Lets you move components based on their distance from a manipulator.

Related topics

”Move, rotate or scale components proportionally” on page 111

Modify > Transformation Tools > Proportional 
Modification Tool > 

Modification type

World Proportional modification happens in XYZ space.

Parametric

(NURBS) Proportional modification happens in UV space. 
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Reference > Modify > Transformation Tools > Proportional Modification Tool
Modification Falloff: Linear

This is the default modification falloff. Maya performs the modification in 
a linear fashion and displays the Distance Cutoff option.

Distance Cutoff

Objects further away than this value are ignored. The distance is 
measured in 3D from the manipulator handle. For Parametric 
(NURBS) modification type, you set Distance Cutoff U and Distance 
Cutoff V.

Distance Based On

The distance from the manipulator handle to the object directly 
influences the modification factor. The distance is computed along the 
selected axes only. If any of these is turned off, the distance used in 
the computation of the propmod effect from the handle to the point 
ignores that component.

Modification Falloff: Power

Using the Proportional Modification Tool, you can set the degree to any 
value between +5 and -5 and the falloff is non-linear (it forms a logistic 
curve). However, if you set the degree to 1, the falloff is linear again.

Distance Cutoff 

Objects further away than this value are ignored. The distance is 
measured in 3D from the manipulator handle. For Parametric 
(NURBS) modification type, you set Distance Cutoff U and Distance 
Cutoff V.

Degree

Specifies the degree of effect in the U and V directions. A value of 0 
applies the transformation equally over the entire region.

A positive value decreases the effect of the transformation for objects 
further away from the manipulator handle; the greater the degree, the 
greater this dampening effect.

If Degree is negative, the effect of the transformation is increased for 
objects further away from the manipulator handle.

Distance Based On

The distance from the manipulator handle to the object directly 
influences the modification factor. The distance is computed along the 
selected axes only.

Modification Falloff: Script

This method uses a MEL script to determine the falloff.
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Reference > Modify > Transformation Tools > Proportional Modification Tool
With the appropriate parameters set, you can choose the Script option and 
type a command for the settings in the User Defined Script box to save the 
current parameter settings without actually invoking the function. If you 
want to use these settings again later, you can retrieve the tool’s script 
from the Reference Editor.

User Defined Script

The script should return a modification factor. The inputs to the script 
are “float” numbers. The first three represent the position of the 
manipulator handle. The second three represent the position of the 
point manipulated. For example, the points for which this script 
returns 1 moves with the manipulator handle. The points for which 
this script returns 0.5 move half as fast as the manipulator handle.

Modification Falloff: Curve

This option uses an animation curve to create the falloff. An animation 
curve profile can be used to produce a modification factor.

Anim. Curve 

Enter the name of an existing animation curve. Its vertical direction 
maps into the modification factor. The distance maps to the anim 
curve time axis (in seconds).

You can use the pull-down menu to the right of the box to list and 
choose all the anim curves with names starting with 
propModAnimCurve. You can also create one of those by choosing 
Create New from the same pull-down menu.

Scale U, Scale V

For Parametric (NURBS) Modification type only. 

Distance Based On

The distance from the manipulator handle to the object directly 
influences the modification factor. The distance is computed along the 
selected axes only.

Modification Falloff: NURBS Curve 

For World Modification type only. This option uses a NURBS curve to 
create the falloff. A NURBS curve profile can be used to produce a 
modification factor.

Enter the name of an existing NURBS curve. Its vertical direction maps 
into the modification factor. The distance maps to the NURBS curve.

You can use the pull-down menu to the right of the box to list and choose 
from all the NURBS curves. 
Basics 

138



4 | Transforming objects

Reference > Modify > Reset Transformations, Freeze Transformations
Using the PropMod script

The PropMod script is similar to the Move script except that it has 
additional settings for the move distance. Using the Script option, you can 
compute each object’s factor individually.

The user-defined script command considers both the position of the 
manipulator and the object. The value returned by the script is used as a 
multiplying factor for a specific object.

Example

Create myPropMove.mel file as:

global proc float myPropMove
         (float $mx, float $my, float $mz,
          float $px, float $py, float $pz)
{
float $value = rand (1.0);
return $value;
}

...which produces a random value between 0 and 1.

If you select myPropMove as the script name, you get a random 
modification factor for all selected points.

Modify > Reset Transformations, Freeze 
Transformations

Reset transformations sets the transformations on the selected objects back 
to zero. This undoes any transformations since the object was created or 
the last “freeze”.

Freeze transformations makes the current transformations on the selected 
objects be the objects’ zero position.

Related topics

”Set transformation values to zero” on page 115

Tip Perform a freeze transform before executing operations such as 
stitch, align, attach, sculpt, wire, and wrinkle; or delete history 
before doing freeze.
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Reference > Modify > Snap Align Objects > Point to Point, 2 Points to 2 Points, 3 Points to 

3 Points
Modify > Reset Transformations, Freeze 
Transformations > 

Use the options to control which types of transformations (translate/
move, rotate, scale, joint orientation) is reset or frozen.

Normals

The normals on polygonal objects will be frozen.

Only for non-rigid deformations

The normals on polygonal objects will be frozen only if it’s a non-rigid 
transformation matrix (that is, a transformation that does not contain 
shear, skew or non-proportional scaling).

This option is only available when Normals is on.

Modify > Snap Align Objects > Point to Point, 
2 Points to 2 Points, 3 Points to 3 Points

Snap objects together at one, two, or three points.

Related topics

”Snap one object to another” on page 119

Options

Move

Object Apply the transformation to the object itself.

Parent Apply the transformation to the object’s parent.

Grandparent Apply the transformation to the object two levels up 
in the scene hierarchy.

Note You only need to turn on Normals if you are applying Modify > 
Freeze Transformation to an object that has been sheared, 
skewed or non-proportionally scaled. Turning on Normals will 
bake the normals so they will not update if you make 
subsequent tweaks to the object’s shape.

Normals will not be frozen on a polygonal object that has been 
negatively scaled.
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Reference > Modify > Snap Align Objects > Align Objects
Snap Type

Only appears in Snap 2 points to 2 points. You click two pairs of 
points on the two objects to align them. This option controls what 
Maya does when the pairs of points are different distances.

Left Snaps the first and third points you click, and aligns 
the second and fourth points in the same direction 
as the first and third.

Middle Snaps the second and fourth points, aligns the first 
and third in the same direction.

Right Snaps the midpoint of the first and third points to 
the midpoint of the second and fourth, and aligns 
the other matching points in the same direction.

Modify > Snap Align Objects > Align Objects

Aligns objects in space.

Related topics

”Align objects” on page 117

Modify > Snap Align Objects > Align Objects > 

Align Mode

You can select from one of five different alignment modes according 
to the objects’ bounding boxes.

Min Aligns objects with the side closest to 0.

Mid Aligns centers.

Max Aligns objects with the side farthest from 0.

Dist Distributes objects evenly along the total distance 
between them.

Stack Lines the objects up so there is no distance between 
their sides.
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Reference > Modify > Snap Align Objects > Align Tool
Align In

You can select an axis or multiple axes in which to align the selected 
objects. For example, to align tops/bottoms turn on World Y.

Align to

You can use this pull-down menu to specify how to align objects in 
the Min, Mid, and Max modes. This pull-down menu does not apply 
to the Dist (Distribute) or Stack modes.

Selection 

Average Uses the average minimum, middle, or maximum 
value of the objects’ bounding boxes as the 
alignment reference.

Last Selected 

Object Uses the minimum, middle, or maximum value of 
the bounding box of the key object as the alignment 
reference. This object is highlighted in green.

Modify > Snap Align Objects > Align Tool

Lets you align objects visually by clicking icons representing the planes 
and positions you want to align.

Select the objects you want to align. The other objects align to the last 
selected (green) object.

• Click an icon to align the objects. The icons show how the bounding 
boxes align. For example:

• Use Edit > Undo or press z to reverse an align.

This is the object the
other objects align to.

Align tops. Align bottoms. Align tops to the 
bottom of the key 
object.

Align centers.
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Reference > Modify > Snap Align Objects > Snap Together Tool
In the following example, the objects align to the far right of the cube 
outside the transparent box.

Related topics

”Align objects” on page 117

Modify > Snap Align Objects > Snap Together 
Tool

Lets you visually pick the points on two objects to snap together.

Click a point on one object, then click a point on the second object. You 
can drag the selected points to edit them. Then press Enter to snap the 
points together.

Related topics

”Snap one object to another” on page 119

Modify > Snap Align Objects > Snap Together Tool > 

Move and rotate object(s)

As the tool snaps the points together, it rotates the moving object so 
the objects snap together along normals. This can help prevent the 
objects from intersecting.

Move object(s) only

The tool snaps the points together without rotating the moving object. 
The objects retain their orientation after the snap.

Snap to Polygon Face

Constrains the snap points to the centers of polygon faces.

Objects align
to the far right
of the cube.
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Reference > Modify > Center Pivot
Modify > Center Pivot

Moves the pivot to the center of the object (based on its bounding box).

Related topics

”Change the pivot point” on page 113

Create

Create > Text

Adds objects to the scene in the shape of styled text.

Related topics

”Create text” on page 123

”Annotate or document objects” on page 230

Create > Text > 

Text

Specifies the text to be created.

Font

Typographical style for the text. For details on using a 
character from an expanded character set on 
Windows, see the steps that follow.

Type

Curves creates text as NURBS curves you can transform and 
manipulate.

Trim creates text as trim surfaces. You can render the letters.

Poly creates text as polygons you can transform and manipulate. A 
planar trim curve is created between the curve and tessellate nodes, 
but you see only the polygonal surface, not the planar surface.

Create > Construction Plane

Creates a construction plane to which you can snap construction tools.

Related topics

”Construction planes” on page 106
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Reference > Component editor
”Snap all creation tools to a surface or construction plane” on 
page 117

Create > Construction Plane > 

Pole Axis

Sets the orientation of the construction plane. The default is an XY 
plane.

Size

Sets the size of the plane in grid units.

Windows and editors

Component editor

A spreadsheet of values contained in the components of an object.

Related topics

”Edit component numeric values directly” on page 125

Menus

Options

Auto Update

Controls whether the editor automatically shows the components of 
the current selection, or you need to manually update the editor to 
show the current selection.

When Auto Update is off, click the Load Components button to 
update the editor with the current selection.

YX YZ XZ
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Reference > Component editor
Hide Zero Columns 

When this item is turned on, all columns whose values are zero are 
hidden (for example, a joint with no influence on vertices in the 
Smooth Skins tab). When this item is turned off, columns whose 
values are zero are shown.

Sort Alphabetically 

When Sort Alphabetically is turned off, the items that make up the 
columns are displayed in their order in the hierarchy. When Sort 
Alphabetically is turned on, the items are sorted in alphabetical order. 
Layout

Show Path Name

Shows the path.

Change Precision

Controls how many decimal places Maya shows for numbers in the 
cells.

Layout

Load Selected Components

This is the same as the Load Components button at the bottom of the 
window. Updates the editor with the current selection when Auto 
Update is off.

Show Selected Columns

Removes all columns from the view, except those which are selected. 
This gives you a way to specify a set of influences/joints and view 
only them.

Show Selected Objects

Allows you to view only those components which are influenced by a 
selected object. 

For example, create a Smooth Skinned object and select all of its CVs. 
The Component Editor shows all the CVs. If you select one of the 
influences and choose Show Selected Objects, you'll see only CVs for 
that influence; the others will be hidden.

Show All Columns

Shows all columns.
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Reference > Component editor
Tabs

Polygons

Lists component data of polygonal vertices, including color or normal 
data in world space coordinates. If color or normal data are not shared at 
the vertex level, the column displays the word UnShared. These unshared 
values can be viewed and edited from the AdvPolygons tab.

AdvPolygons

Lists vertex face component data, including color and normal values for 
the vertex face.

Weighted Deformers

Lists component data of CVs, vertices, or lattice points influenced by 
cluster deformers (cluster weights).

Rigid Skins

Lists component data of CVs, vertices, or lattice points bound to a 
skeleton’s joints by rigid skinning (joint cluster weights).

Smooth Skins

Lists component data of CVs, vertices, or lattice points bound to a 
skeleton’s joints by smooth skinning (skin cluster weights).

Springs

Lists component data for springs, including stiffness and damping data.

Particles

Lists component data for particles, including color or velocity data.

Spreadsheet area

• Each component is a row, and each value or influence on the 
component is a column.

• Click, shift-click, or drag across a cell, column, or row to select it.

• Type a value to enter it in all selected cells.
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Reference > Component editor
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5 Nodes and 
attributes
About Nodes and attributes

Nodes and attributes

Nodes

Maya is built around nodes. An “object”, such as a sphere, is built from 
several nodes: a creation node that records the options that created the 
sphere, a transform node that records how the object is moved, rotated, 
and scaled, and a shape node that stores the positions of the spheres 
control points.

Attributes

An attribute is a position associated with a node that can hold a value or a 
connection to another node. Attributes control how a node works. For 
example, a transform node has attributes for the amount of rotation in X, 
Y, and Z. You can set attributes to control practically every aspect of your 
animation.

There are many ways to set attributes in Maya: with the Attribute Editor, 
the Channel Box, the attribute spread sheet, menu selections, and MEL.

Shape 
node

Input 
node

Shading 
node

Transform 
node

Channel Box

Attribute Editor
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About > Nodes and attributes
Every node is created with certain default attributes. Some attributes (such 
as Opacity and Color of particle objects) are added dynamically when you 
need them.

You can also add your own attributes to any node to store information. 
This is often useful for animation expressions and scripts, and can be used 
to control several normal attributes using one custom attribute.

Related topics

”Two views of the scene: hierarchy and dependency” on page 152

”Node types” on page 157

”Change attribute values in the Attribute Editor or Channel Box” on 
page 159

”View and edit the hierarchy of nodes” on page 168

”Show inputs and outputs (dependency graph)” on page 171

Construction history

As you work in Maya, most of your actions create nodes in the 
construction history of the objects you work on. At each point in your 
work, the current scene is the result of all the nodes you’ve created so far.

For example, you can revolve a curve around a center point to create a 
new surface with a cross-section in the shape of the curve. When you 
apply this action to the curve, a new revolve node is created. The new 
node has the shape of the curve as an input. It has attributes that control 
how it creates the surface from the curve. And it has the resulting surface 
as its output.

This chain of nodes, from the curve to the revolve node to the surface, is 
called the surface’s construction history. The most important thing about 
construction history is that you can change it. You can reshape the curve, 
or change the attributes on the revolve node, and the resulting surface 
updates automatically.

Direct manipulation

Much of working in Maya involves directly manipulating nodes and 
attributes using manipulators.

Manipulators are visual objects that let you accomplish complex tasks 
easily, concretely, and visually by dragging handles and seeing the results 
immediately.
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About > Nodes and attributes
Using the revolve example above, you can select the revolve node and edit 
its attributes (how it creates the surface) visually by showing its 
manipulator with the Show Manipulator tool.

This lets you control attributes (such as how far around the centerpoint 
the surface goes) simply by dragging a handle.

You can also show manipulators for individual attributes to edit their 
values visually.

Keyable attributes

Animation in Maya is not limited to making things move. You can 
animate practically any attribute of any node in Maya. Attributes that 
control how a surface is constructed, or the look of a texture, or the 
influence of a deformer or physical force, can all change over time.

MEL

MEL stands for Maya Embedded Language. It is Maya’s scripting 
language. It is deeply integrated with Maya, and allows you to do 
anything from open a window or perform a simple action with a 
command, to total customization of the Maya interface, to writing an 
entirely new application on top of Maya. Practically everything that Maya 
can do can be accomplished through MEL (and what can’t can be done in 
another language with the Maya API).

AxisMidPoint

AxisEndPoint

AxisStartPoint

CircleSweep
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About > Two views of the scene: hierarchy and dependency
Two views of the scene: hierarchy and 
dependency

There are two basic ways to view your scene in Maya:

• As a hierarchical list of nodes. This shows which nodes are parents 
and children of other nodes.

See ”Scene hierarchy” on page 152.

• As a graph of connections between nodes. This shows which nodes 
provide input or output to other nodes.

See ”Dependency graph” on page 153.

Scene hierarchy

The scene hierarchy is the grouping of child nodes under parent nodes.

While you could create a scene without establishing a hierarchy, you will 
find that it makes modeling and especially animation much easier.

You can view and edit the scene hierarchy with the Outliner or the 
Hypergraph.

Example 1

When you transform a parent, its children are transformed with it. This 
lets you, for example, model a leg by making the thigh the child of the hip, 
the knee the child of the thigh, the shin the child of the knee, the foot the 
child of the shin, and so on. Rotating one join rotates the rest of the leg 
under that joint.

Example 2

Suppose you animate a planet to orbit the center of the workspace. If you 
make a moon the child of the planet, it follows the motion of the planet. 
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About > Dependency graph
Though the moon is the child of the planet, you can also give the moon 
motion that’s independent of the planet. For example, you can make it 
orbit the planet. If you later change the orbiting motion of the planet, the 
moon continues to follow the planet’s motion, but stills retains its original 
orbiting motion.

“Parenting”

Among Maya users, establishing hierarchy is often called parenting objects. 
When make node B the child of node A, we say you have parented node B 
to node A.

(This might be somewhat confusing at first, since “parenting” something 
does not mean “making it a parent” but rather means “making it a child”, 
but that’s the way it is.)

Grouping

To control multiple objects with one node, you can group objects together 
under a new transform node. By grouping objects, you can move, shade, 
texture, and do many other actions to all the objects at the same time.

Organizing

You can also use the scene hierarchy to organize objects to make them 
easier to work with, even if you’re not animating them.

Related topics

”Nodes and attributes” on page 149

”Dependency graph” on page 153

”The Outliner” on page 154

”The Hypergraph” on page 155

”View and edit the hierarchy of nodes” on page 168

”Group objects together” on page 227

Dependency graph

The dependency graph is one of two ways Maya represents your scene 
(the other being the scene hierarchy). It’s a chain of nodes.

The dependency graph is like a series of instructions for how to get the 
current scene starting from scratch: “create a sphere A, move these CVs, 
create a curve B, project curve B onto sphere A to create curve-on-surface 
C, trim sphere A using curve on surface C”, and so on.
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About > The Outliner
The dependency graph gets its name from the connections between nodes. 
In the example above, the project curve operation depends on two inputs: 
sphere A and curve B.

Each node in the dependency graph represents an action to build up or 
change the scene, with the final result being the scene in its current state.

What this lets you do is modify or reshape input objects, change attributes 
on a node, change node connections, or delete nodes, and have Maya 
automatically and instantaneously update the entire scene to reflect the 
changes.

The connections between creation and editing nodes is also called 
construction history, because it records the history of how the scene was 
constructed.

You can view and edit the dependency graph in the Hypergraph.

Related topics

”Construction history” on page 105

”Scene hierarchy” on page 152

”Edit completed commands (construction history)” on page 121

”Show inputs and outputs (dependency graph)” on page 171

”Connect input and output attributes” on page 172

”Connect attributes with an expression” on page 173

The Outliner

The Outliner is one of two main scene management editors in Maya (the 
other is the Hypergraph).

The Outliner shows the hierarchy of all objects in the scene in outline 
form: You can expand and collapse the display of branches in the 
hierarchy, and lower levels of the hierarchy are indented under higher 
levels.
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About > The Hypergraph
The outline includes objects that are normally hidden in the view panels, 
such as the default cameras. You can control what objects appear in the 
Outliner using the menus and the text filter box. For example, type *top* 
in the box and press Enter to only show objects with the letters top in their 
names.

Clicking the name of a node in the Outliner selects the node. The selected 
node(s) are shown with a gray background. You can double-click the 
name of a node to renaming it.

You use the Outliner most often for two functions:

• Selecting objects. With complex scenes it is often easier to select an 
object by clicking its name in the Outliner than trying to hit it in a 
view panel.

• Changing the hierarchy of nodes. You can move nodes around the 
hierarchy and parent nodes to other nodes by dragging them with the 
middle mouse button.

Related topics

”Nodes and attributes” on page 149

”The Hypergraph” on page 155

”View and edit the hierarchy of nodes” on page 168

”Outliner” on page 185

The Hypergraph

The Hypergraph is one of two main scene management editors in Maya (the 
other is the Outliner).
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The Hypergraph shows a network of boxes representing nodes and lines 
connecting them representing relationships.

You can use the Hypergraph to view and edit hierarchical relationships 
(the same information the Outliner shows) or dependency relationships 
(input and output connections between attributes).

While the Hypergraph can seem more intimidating than the Outliner at 
first, it has several advantages of its own:

• You can use it to show and edit connections between nodes.

• You use the same move keys to move around the graph as you do to 
move around view panels (alt + the middle mouse button and alt + 
the right mouse button).

• You can bookmark different views of the scene and zoom between 
them

• The Hypergraph draws animated nodes with slanted sides making 
them easy to see.

Related topics

”Nodes and attributes” on page 149

”The Outliner” on page 154

”View and edit the hierarchy of nodes” on page 168

”Show inputs and outputs (dependency graph)” on page 171

”Connect input and output attributes” on page 172

”Connect attributes with an expression” on page 173

”Hypergraph” on page 202
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Node types

Transform node

A node that contains an object’s transformation attributes—values for its 
translation, rotation, scale, and so on. It also holds information on parent-
child relationships it has with other nodes. InnerSolarSystem, Sun, Moon, 
and all other boxes shown in the example are transform nodes.

Shape nodes

Holds an object’s geometry attributes or attributes other than the object’s 
transform node attributes. A shape node is the child of a transform node. 
A transform node has only one shape node.

Auxiliary nodes

There are several nodes, such as unitConversion, that Maya hides them to 
reduce clutter in the editors. They are not normally useful to see or edit, 
however if you need to you can show these nodes. (You can also hide 
nodes that are normally shown if you want to further reduce clutter.)

Hidden nodes

Any object hidden using Display > Hide. Maya hides the default cameras 
(top, front, side, and persp) by default.

Underworld nodes

A pair of nodes below a shape node. When you create a curve-on-surface, 
Maya creates an underworld transform node and shape node for the 
curve-on-surface below the surface’s shape node. The CV positions of 
underworld nodes have UV coordinates on the surface rather than 
coordinates in world or local space.

Rendering nodes

Materials and textures each have nodes containing attributes that control 
their look. Texture placement nodes have attributes that control how a 
texture is fitted onto a surface.

Lights are of course nodes too, with attributes controlling their properties.

Utility nodes

Maya has a few utility nodes that provide extra functions you can use in a 
shader network. For example, multiply/divide nodes let you alter inputs 
and outputs between other nodes.
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Script nodes

Script nodes are a way of storing a MEL script in a Maya scene file:

You can set a script node to execute its “payload” in response to various 
events:

• When the node is read from a file.

• Before or after rendering a frame.

• Before or after rendering an animation.

• When a file is closed or de-referenced.

Examples

Example 1

If you select Create > NURBS Primitives > Sphere to create a sphere, Maya 
creates a transform node and a shape node.

The sphere’s shape node holds the mathematical description of the 
sphere’s shape. The sphere’s transform node holds the sphere’s position, 
scaling, rotation, and so on. The shape node is the child of the transform 
node. 

If you select Options > Display > Shape Nodes in the Hypergraph, the 
scene hierarchy shows these nodes for the sphere:

Maya gives the nodes the default names shown in the preceding figure. 
The transform node is nurbsSphere1, the shape node is 
nurbsSphereShape1. If you rename the transform node, for example, to 
Bubble, Maya renames the shape node to BubbleShape.

If you rename the shape node, Maya does not rename the transform node. 
Maya doesn’t transmit a child’s attribute changes up to its parent. 

Example 2

If you select Create > NURBS Primitives > Sphere to create a sphere, Maya 
creates a transform node and a sphere node. If you then select Modify > 
Make Live, then use the Create > CV Curve Tool to draw a curve on the 
surface of the sphere and turn on the display of shape nodes and 
underworld nodes, the scene hierarchy appears as follows:
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Maya gives the nodes the default names shown. The transform node is 
nurbsSphere1, the shape node is nurbsSphereShape1. The curve1 and 
curveShape1 nodes are underworld nodes for the curve created on the 
sphere’s surface.

When a curve-on-surface is hard to select in the workspace because of 
crowding or complex geometry, you can select it easily in the scene 
hierarchy with underworld nodes displayed.

Related topics

”Nodes and attributes” on page 149

”Scene hierarchy” on page 152

”Dependency graph” on page 153

How do I? Work with nodes and attributes

View and edit attributes

Change attribute values in the Attribute Editor 
or Channel Box

Attribute values with an purple background in the Channel Box or 
Attribute Editor are controlled by a connection to another attribute. You 
cannot edit them manually.

To... Do this

Enter a value for an 
attributes

Click in the text box and type a new value and 
press Enter.

For boolean (on/off) values, type 1 or on, or 0 
or off.
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Change a value and 
return the keyboard 
focus to the view 
windows so you can 
use hotkeys.

Type the value and press the Enter or Return 
key.

Change a value and 
leave the keyboard 
focus in the edit box.

Type the value and press the Enter key on the 
numeric keypad.

Enter the same value in 
multiple attributes at 
once.

Shift-click, Ctrl-click, or drag across multiple 
text boxes to select them. Then type a new 
value and press Enter.

Change the sensitivity 
of sliders in the 
Channel Box.

• Click the slider speed icon to switch 
between slow, medium, and fast sliders.

• Click the hyperbolic icon to switch to a 
hyperbolic scale. This causes the value to 
change very fast. Use this for values that 
need large adjustments.

Adjust the value of a 
numeric attribute with 
the mouse.

• Click the attribute and drag left or right 
with the middle mouse button.

• Use the icons in the Channel Box toolbar 
to control the mapping between mouse 
move distance and numeric change.

Enter a value relative 
to the current one.

• Type +=n to add n to the current value.

• Type -=n to subtract n from the current 
value.

• Type *=n to multiply n by the current 
value.

• Type /=n to divide the current value by 
n.

To... Do this

Medium FastSlow

Linear Hyperbolic
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Related topics

”Show or hide the manipulator for an attribute in the Channel Box” 
on page 161

”View and edit multiple attributes on multiple nodes” on page 162

”Save and reuse attribute presets” on page 164

”Lock the value of an attribute” on page 166

Creating animation expressions

Show or hide the manipulator for an attribute 
in the Channel Box

Normally when you click an attribute name, a manipulator appears on the 
selected object to control that attribute, and you can also drag the middle 
mouse button to change the attribute’s value. You can disable the 
manipulator and dragging features.

Quickly link the 
attribute to another 
value. (Attribute Editor 
only)

You can type =time or =frame in the text box to 
use the reserved keywords time or frame and 
link the value of the attribute to the current 
time or the current frame. You can also include 
simple operators; for example, =frame/2, 
=time*3.5.

Create a complex 
expression

Right-click on the text box and choose Create 
New Expression (Attribute Editor) or 
Expressions (Channel Box). See the MEL book 
for details on creating and using expressions.

Tip When typing values in the Channel Box:

• Press the Enter key on the numeric keypad to enter a value 
and keep the focus in the Channel Box.

• Press the Enter key on the keyboard to enter the value and 
return focus to the view windows (so you can use hotkeys).

To... Do this

Standard 
Manips

Invisible 
Manips

No 
Manips
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Related topics

”Change attribute values in the Attribute Editor or Channel Box” on 
page 159

View and edit multiple attributes on multiple 
nodes

The attribute spread sheet lets you edit the values of many attributes on 
many nodes at the same time by presenting them in a spreadsheet format.

To... In the Channel Box, choose...

Prevent the manipulator 
from appearing when 
you click an attribute 
name.

Channels > Settings > Invisible Manips.

Prevent the manipulator 
from appearing and 
disable dragging the 
middle mouse button.

Channels > Settings > No Manips.

Show the manipulator 
when you click an 
attribute name and allow 
dragging the middle 
mouse button.

Channels > Settings > Standard Manips.

To... Do this

Open the attribute spread 
sheet.

Select a node and choose Windows > 
General Editors > Attribute Spread Sheet.
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Enter values in cells. Select all the cells you want to enter the 
same value in, then type the value.

You can select one attribute, multiple 
attributes on the same object, or the same 
attribute on multiple objects, or any 
combination.

Enter a value relative to the 
current one.

• Type +=n to add n to the current 
value.

• Type -=n to subtract n from the 
current value.

• Type *=n to multiply n by the 
current value.

• Type /=n to divide the current value 
by n.

Switch to short attribute 
names to save room.

In the attribute spread sheet, select Names 
> Short Attribute Names.

Display different types of 
attributes.

Click the tabs across the top of the 
attribute spread sheet window.

Many useful attributes of an object are 
not stored in its main node, but instead 
in its shape node. The Attribute Editor 
includes tabs that show attributes from 
an object’s associated shape node.

Only show certain 
attributes.

In the attribute spread sheet, click, shift-
click, or drag to select the attributes 
(columns) you want to show.

Then select Layouts > Show Selected 
Columns Only.

To return to the full display, select 
Layouts > Show All Columns.

Save the current layout of 
visible columns as a new 
tab.

In the attribute spread sheet, select 
Layouts > Remember This Layout. The 
attribute spread sheet now has a new tab 
that shows the layout.

To delete a layout tab, click the tab and 
select Layouts > Delete Current Layout.

To... Do this
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When the Attribute Editor opens for the first time, the Keyable tab is 
shown. This tab only shows attributes that are marked as keyable (able to 
be animated). Click the All tab to show all attributes, keyable and not.

Related topics

”Change attribute values in the Attribute Editor or Channel Box” on 
page 159

”Show or hide the manipulator for an attribute in the Channel Box” 
on page 161

”Open multiple Attribute Editors” on page 167

Save and reuse attribute presets

The Attribute Editor lets you save and re-apply presets. A preset is a 
collection of attribute settings you can save from one node and reapply to 
any number of other nodes.

This lets you store complex node setups, such as a library of lights set up 
with the attribute values you want.

Maya comes with a variety of presets for various nodes, such as fluids.

To create a preset

1 Open the node you want to take presets from in the Attribute Editor.

2 In the Attribute Editor, press the left mouse button on the Presets 
button (to the right of the node name) to show a pop-up menu and 
choose Save (preset type) Preset.

Key certain attributes. Select the cells and choose Key > Key 
Selected.

To... Do this
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3 Type a name for the new preset and click Save Attribute Preset.

If the preset already exists, you are prompted to overwrite it or save it 
with a different name.

To apply a preset to another node

1 Open the node you want to apply a preset to in the Attribute Editor.

2 In the Attribute Editor, press the left mouse button on the Presets 
button (to the right of the node name) to show a pop-up menu.

3 Point to the name of the preset to show another sub-menu with 
options for applying the preset to this node. You can replace the 
current attribute values with the values in the preset, or blend the 
preset values together with the current values.

Notes

• Presets do not save connections to other nodes (such as texture maps). 
Applying a preset does not overwrite connections to other nodes.

• Maya saves presets as editable MEL scripts in a presets folder inside 
the main Maya application folder. Presets for each node type are in 
separate folders inside the presets folder.

Create a new Select egg and The result is an egg 50%
smaller than the original.

2. 3.
a blend value of 50%.poly sphere.
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What if...?

The Presets button is grayed out?
Some node types cannot be saved as presets. Shape nodes, for example, 
would be meaningful as presets.

Related topics

”Change attribute values in the Attribute Editor or Channel Box” on 
page 159

”Lock the value of an attribute” on page 166

Lock the value of an attribute

Press the right mouse button on the attribute and choose Lock Attribute. 
Maya displays locked attributes with a gray background.

To unlock an attribute, press the right mouse button on the attribute and 
choose Unlock Attribute.

Create, edit, or delete custom attributes

To add custom attributes to objects

1 Select the objects/nodes you want to add attributes to.

2 In the Attribute Editor, choose Attributes > Add Attributes.

3 Type the name of the attribute.

4 Choose the type of value the attribute holds:

• Vector: three floating point values.

• Float: a single floating point value. Maya does not display floating 
point numbers in the user interface with their full precision.

• Although Maya only displays numbers to a customizable number 
of decimal places, and the Attribute Editor always shows only 
three decimal places, the true value of a float attribute is kept in 
memory.

• Integer: a single integer value.

• Boolean: an on/off switch.

• String: a text string.

• Enum: a list of choices.

5 Set the Keyable option. When an attribute is keyable, you can use its 
value in keyframe animation, and it appears in the Channel Box.

6 Click Add.
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Remember that Maya adds the attribute to the selected node, not 
necessarily the node currently displayed in the Attribute Editor.

To edit a custom attribute

1 Select the object/node with custom attributes you want to edit.

2 Choose Modify > Edit Attributes.

Or, in the Attribute Editor, choose Attributes > Rename Attributes.

In attribute names, all punctuation except for the underscore (_) and 
the pound sign (#) are illegal characters

3 Click the name of the attribute.

To delete a custom attribute

1 Select the object/node with custom attributes you want to delete.

2 Choose Modify > Delete Attributes.

3 Click the name of the attribute.

4 Click Delete.

Open multiple Attribute Editors

1 Choose Window > Attribute Editor to show the Attribute Editor.

2 Select the first object.

3 In the Attribute Editor, click Copy Tab. A new Attribute Editor is 
created with the object attributes loaded.

4 Select another object. Its attributes load in the original Attribute 
Editor.

You can set an option in Window > Settings/Preferences > Preferences to 
always open the Attribute Editor in a window instead of in the side panel.

Related topics

”Window > Settings/Preferences > Preferences” on page 298

Control the display of attributes in the 
Channel Box

To change the display precision of floating point attribute 
values

1 In the Channel Box choose Channels > Settings > Change Precision.

2 Type the number of decimal places to show in the Channel Box and 
attribute spread sheet.
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To change the display of attribute names

The default (“Nice”) attribute names in the Channel Box are easy to read, 
but cannot be used in expressions or MEL scripts. To show the actual 
internal names of the attributes, use the Long or Short options.

1 In the Channel Box, open the Channels > Channel Names submenu.

2 Do one of the following:

• Choose Nice to show attribute names that are easier to 
understand, but cannot be used in expressions or MEL scripts. 
This is the default.

• Choose Long to show the long versions of the actual attribute 
names.

• Choose Short to show the short versions of the actual attribute 
names.

To change the width of the Channel Box

Click the << or >> button at the bottom of the Channel Box to resize it.

Related topics

”Change attribute values in the Attribute Editor or Channel Box” on 
page 159

View and change the hierarchy of nodes

View and edit the hierarchy of nodes

To... Do this

Show scene hierarchy in 
the Hypergraph.

1 Choose Window > Hypergraph.

2 In the Hypergraph, choose Graph > 
Scene Hierarchy.

Show scene hierarchy in 
the Outliner.

Choose Window > Outliner.
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Tips

• You can set the options of the Parent menu item to make the 
command create an instance under the new parent instead of moving 
the actual object in the hierarchy.

• Unparenting an object removes it from under its parent’s 
transformation node, which can change the object’s position in the 
scene.

Open the Unparent menu item’s options and turn on the Preserve 
Position option to apply the transformations to the object as it is 
unparented so it retains its current position.

Related topics

”Change the visual layout of nodes in the Hypergraph” on page 170

”Change the order of nodes” on page 171

”Show or hide nodes” on page 175

Move a node under 
another (parent) node.

• In the Hypergraph or Outliner, drag 
the node onto the parent with the 
middle mouse button.

or

• Select the objects you want to assign to 
the parent, then shift-select the parent 
and choose Edit > Parent.

Remove a node from the 
hierarchy under another 
node (unparent).

• In the Hypergraph or Outliner, drag 
the node away from its parent with the 
middle mouse button.

or

• Select the child object you want to 
remove from under the parent and 
choose Edit > Unparent > ❑.

To... Do this
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Change the visual layout of nodes in the 
Hypergraph

Related topics

”Two views of the scene: hierarchy and dependency” on page 152

”The Hypergraph” on page 155

”Hypergraph” on page 202

To... Do this

Switch between 
automatic and manual 
layout.

Choose one of the following:

• Options > Layout > Automatic Layout.

• Options > Layout > Freeform Layout.

Move nodes in freeform 
layout.

Drag nodes with the left mouse button.

Display an image in the 
background of the 
freeform layout.

To load an image, choose View > Load 
Background Image.

To turn the image on or off, Options > 
Display > Background Image.

Reset the positions of 
nodes in the freeform 
layout.

Choose Edit > Reset Freeform Layout.

Switch the automatic 
layout between stacking 
root nodes horizontally 
or vertically.

Choose one of the following:

• Options > Orientation > Horizontal.

• Options > Orientation > Vertical.

Change the color of 
nodes as they display in 
the Hypergraph.

In the Attribute Editor for that node, go to 
Drawing Overrides. (You may have to 
expand Object Display to see this section.) 
Turn on Enable Overrides and set a color 
using the color slider.

You must have Node Display Override 
Color turned on in the Hypergraph to 
display color changes. Changing the color 
of a layer overrides this node display 
setting.
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Change the order of nodes

When Maya draws or renders the scene, it looks at each node in the scene 
in order and applies the node’s effect (for example, creating an object or 
applying a rotation) to the scene. In certain limited situations, the order in 
which Maya evaluates nodes can affect the final result.

To view the nodes in order

• In Outliner (Window > Outliner), choose Display > Sort Order > Scene 
Hierarchy.

• In the Hypergraph (Window > Hypergraph), choose Graph >Scene 
Hierarch and then Options > Layout > Automatic Layout. 

To change the order of nodes in the Outliner

Drag a node with the middle mouse button and drop it between nodes.

As you drag, Maya draws a single line to indicate that dropping the node 
results in reordering, or a double line (above and below the target) to 
indicate that dropping the node makes it a child of the target node.

To change the order of nodes in the Hypergraph

Hold Ctrl, drag a node with the middle mouse button, and drop it on the 
node you want it to precede in the order.

Related topics

”Scene hierarchy” on page 152

”The Outliner” on page 154

”Outliner” on page 185

View and change input and output history 
relationships between nodes

Show inputs and outputs (dependency graph)

To show connections between nodes

1 Open the Hypergraph (Window > Hypergraph).

2 Choose one of the following menu items in the Hypergraph:

• Choose Graph > Input and Output Connections to show both the 
input chains leading up to nodes, and the output chains leading 
from nodes.
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• Choose Graph > Input Connections to show the input chains 
leading up to nodes.

• Choose Graph > Output Connections to show the output chains 
leading from nodes.

To show connections for only certain types of nodes

1 Select a node of the type, or multiple nodes of different types you 
want to show.

2 In the Hypergraph, select Show > Show Selected Type(s).

3 To show all nodes again, choose Show > Show All.

To show connections for a node or nodes in the Outliner or 
hypershade window

1 Set up the Hypergraph to show connections.

2 Drag the node from the Outliner or hypershade window into the 
Hypergraph.

Show or hide extra connections

You can show color-coded lines between nodes representing expression, 
constraint, and deformer connections in the Hypergraph.

Choose the following menu items in the Hypergraph to show or hide 
different types of connections:

• Options > Display > Expression Connections.

• Options > Display > Constraint Connections.

• Options > Display > Deformer Connections.

Related topics

”Connect input and output attributes” on page 172

”Connect attributes with an expression” on page 173

”Show or hide nodes” on page 175

Connect input and output attributes

To connect attributes in the Hypergraph using context menus

1 Point to the right end of the node in the Hypergraph (the cursor 
changes). Press the right mouse button and choose an output attribute.

2 Press the right mouse button on the node you want to connect to, and 
choose an input attribute.
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You may need to choose Graph > Layout to update the view with the 
new connection.

To connect attributes in the Hypergraph using the 
Connection Editor

1 Hold Shift and drag with the middle mouse button from the output 
node to the input node.

2 Use the Connection Editor to choose which attributes to connect.

To change the input or output of a connection

1 Point to the connection line in the Hypergraph, toward the connection 
you want to change (input or output).

2 Drag the line end with the left mouse button and drop it on a new 
node.

3 Choose the attribute you want to connect.

Related topics

”Connect input and output attributes” on page 172

”Connect attributes with an expression” on page 173

”Break connections between attributes” on page 174

Connect attributes with an expression

To connect the value of one attribute to another with an 
expression

• In the Attribute Editor, type an equals sign (=) followed by a MEL 
expression in the attribute’s text box.

or

• Select the node with the attribute you want to edit and choose 
Window > Animation Editors > Expression Editor. Click the attribute 
and type a MEL expression in the box at the bottom.

For example, to make the translateX value of pTorus1 always equal the 
translateY value of pCone2, type =pCone2.translateY in pTorus1’s 
translateX box. When you move the cone up and down in Y, the torus 
moves side-to-side in X.

You can create more complex expressions using multiple attributes and 
MEL’s math functions.
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When you type an expression into a text box in the Attribute Editor or 
Channel Box and press Enter, Maya then shows the computed value with 
an purple background. You can’t edit values that are the result of an 
expression. To edit the expression, use the Expression Editor.

Related topics

”Connect input and output attributes” on page 172

”Connect input and output attributes” on page 172

”Break connections between attributes” on page 174

Break connections between attributes

Attribute values that are controlled by a connection have an purple 
background in the Channel Box and Attribute Editor.

Do one of the following:

• In the Channel Box or Attribute Editor, press the right mouse button 
on the attribute and choose Break Connections.

• Select the connection line (or lines) in the Hypergraph and press 
Delete.

Related topics

”Connect input and output attributes” on page 172

”Connect attributes with an expression” on page 173

Set a node’s update state

To show the Node State attribute

1 Select the node you want to change.

2 Show the Attribute Editor (Window > Attribute Editor).

3 Expand the Node Behavior section.

To... Set the Node State attribute to...

Disable the effect of the 
selected node.

HasNoEffect.

Keep the selected node 
from updating when its 
inputs change.

Blocking.
Basics 

174



5 | Nodes and attributes

How do I? > Show or hide nodes
Notes

• The “HasNoEffect” state has a different meaning for each node type. 
Some node types do not implement the state, in which case the state 
acts just like “Normal”.

• The “Waiting” node states are used internally by Maya to keep track 
of nodes that are waiting for a view update in the Hypergraph. You 
should not normally set nodes to a “Waiting” state.

Change the display of nodes and attributes

Show or hide nodes

Make the node active 
again.

Normal.

To... Do this

Expand or collapse 
hierarchy under a node.

• In the Outliner, click the plus or 
minus icon to the left of the node 
name.

• In the Hypergraph, double-click the 
node.

Show auxillary node types. In an editor, choose Show > Show 
Auxiliary Nodes.

Control which node types 
are hidden as auxillary.

In an editor, choose Show > Auxiliary 
Nodes.

• To remove a node from the hidden 
list, click it in the top list and click 
Remove From List.

• To add a node to the hidden list, click 
it in the bottom list and click Add to 
Hide List.

Show or hide shape nodes 
in the Hypergraph.

In the Hypergraph, choose Options > 
Display > Shape Nodes.

Show or hide hidden nodes 
in the Hypergraph.

In the Hypergraph, choose Options > 
Display > Hidden Nodes.

To... Set the Node State attribute to...
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Related topics

”View and edit the hierarchy of nodes” on page 168

”Show inputs and outputs (dependency graph)” on page 171

Control which objects or attribute types 
appear in an editor

The Outliner, Hypergraph, Graph Editor, Dope Sheet, and Relationship 
Editor let filter out information you’re not interested in right now.

To temporarily filter out objects or attributes from the editor 
display

Show or hide underworld 
nodes in the Hypergraph.

In the Hypergraph, choose Options > 
Display > Underworld Nodes.

Underworld nodes are only visible if 
shape nodes are also visible.

To... Do this

Only show items with 
specific text in their 
names.

Type text in the text filter box and press 
Enter. An asterisk (*) matches anything. A 
question mark (?) matches any single 
character.

For example, to show all items whose name 
starts with spot, type spot* in the text filter 
box. To show items with new anywhere in 
their names, type *new*.

Only show certain types 
of objects.

In the Show > Objects submenu, choose the 
object types you want to show.

To show all object types again, choose Show 
> Objects > Clear Below.

To... Do this
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Related topics

”Outliner” on page 185

”Hypergraph” on page 202

Save and reuse object or attribute visibility 
filters in editors

To save an object filter

1 Select objects of the type you want to show.

2 In the editor, choose Show > Show Selected Type(s).

3 Choose Show > Create Entry.

4 Type a name for the filter and click Save.

The filter appears in the Show > Objects submenu.

To save an attribute filter

1 Select attributes of the type you want to show.

2 In the editor, choose Show > Show Selected Type(s).

3 Choose Show > Create Entry.

4 Type a name for the filter and click Save.

The filter appears in the Show > Attributes submenu.

Only show certain types 
of attributes.

In editors that show attributes (Relationship 
Editor with characters, Outliner with 
Display > Attributes on):

In the Show > Attributes submenu, choose 
the object types you want to show.

To show all object types again, choose Show 
> Attributes > Clear Below.

Only show objects or 
attributes of the same 
type(s) as the selection.

Choose Show > Show Selected Type(s).

Show all objects and 
attributes.

Choose Show > Show All.

To... Do this
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To delete a saved filter

1 Choose Show > Delete Entry.

2 Click the Objects or Attributes tab.

3 Click the name of the filter and click Delete.

Related topics

”Outliner” on page 185

”Hypergraph” on page 202

Reference Menus

Edit

Edit > Select Hierarchy

Selects all nodes under the currently selected node in the scene hierarchy.

Related topics

”Scene hierarchy” on page 152

Edit > Parent

Makes the selected nodes children of the last node you selected (the key 
object). Select the objects you want to assign to the parent, then shift-select 
the parent and choose Edit > Parent.

Related topics

”View and edit the hierarchy of nodes” on page 168

”Edit > Unparent” on page 179

Edit > Parent > 

Parent Method

Select what you want done with the selected object:

Move Objects Move the object from its current parent to the new 
parent (the last selected object).
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Add Instance Create an instance under the new group instead of 
moving the object.

Preserve Position

Turn Preserve Position on to preserve the overall world-space position 
by changing the parented objects’ transformation matrix.

Edit > Unparent

Related topics

”View and edit the hierarchy of nodes” on page 168

”Edit > Parent” on page 178

Edit > Unparent > 

Unparent Method

Select how you want to unparent the selected object:

Parent to World Remove the object from its current parent and place 
it under the world.

Remove 

Instance Remove a particular instance instead of moving the 
object.

Preserve Position

Turn Preserve Position on to preserve overall world-space position by 
modifying the parented objects’ transformation matrix.

Modify

Modify > Evaluate Nodes

The items in this submenu let you turn off evaluation of various 
animation and modeling nodes to improve performance. The effects of the 
nodes do not appear in the view panels until you turn them on again.

Modify > Prefix Hierarchy Names

Adds a prefix to the name of the selected parent object and all its children.

1 Select the parent.

Note If two objects are selected, the first object goes under the second.
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2 Choose Modify > Prefix Hierarchy Names.

3 Type a prefix and click OK.

Related topics

”Change the name of one or more objects” on page 224

Modify > Add Attribute

Custom attributes are attributes you optionally add and define from the 
Add Attribute window. Although custom attributes are dynamically 
added to an object, we refer to them as custom to distinguish them from 
the built-in dynamic attributes.

Custom attributes have no direct effect on any characteristic of an object in 
Maya. You can use them to control a combination of other attributes. You 
might also use a custom attribute as a variable—a place to store a value 
temporarily to be read by other attributes.

When you add a custom attribute to an object, it appears in the Extra 
Attributes section of the Attribute Editor (and in the Channel Box, if you 
make the attribute keyable).

Related topics

”Create, edit, or delete custom attributes” on page 166
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Options

Attribute Name

Type the name of the attribute you are adding.

Make Attribute Keyable

Turn this option on to make this attribute keyable. For information 
about keyable attributes, see Animation.

Data Type

Select the data type for the attribute: 

Vector  Creates a vector attribute consisting of three floating 
point values.

Float Creates a floating point attribute.

Integer  Creates an integer attribute.

Boolean  Creates an attribute consisting of an on/off turn.

String Creates a string attribute that accepts alphanumeric 
entries as data entry, such as a filename.

Enum Creates an attribute that accepts selections from an 
“enumerated” or drop-down list. 
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Attribute Type

Select a type:

Scalar  Creates a per object attribute that you can set to a 
single value that applies to every particle in the 
object. A vector scalar is considered a single value 
with three numbers. If you select Scalar, you can 
specify Minimum, Maximum, and Default values 
for a Float or Integer attribute. 

Per Particle 

(Array)  Creates a per particle attribute. You can set this type 
of attribute to different values for each particle. If 
you select Per Particle (Array), you can also create a 
counterpart initial state attribute by turning on Add 
Initial State Attribute.

Add Initial State 

Attribute  Turn on to create a corresponding initial state 
attribute for the added attribute. Without this 
corresponding attribute, you can’t save a particle 
object’s current attribute values for initial state 
usage. You must write a creation expression if you 
decide to initialize the custom attribute’s value upon 
rewinding the animation. If you know you’re going 
to write a creation expression for a custom attribute, 
you can set Add Initial State Attribute to off when 
you add the attribute. Otherwise, set Add Initial 
State Attribute to on whenever you add a custom 
per particle attribute. 

Numeric Attribute Properties

For scalar attributes, Minimum and Maximum set the lowest and 
highest values you can enter for the attribute in the Attribute Editor or 
Channel Box. Default sets the default value for the attribute. 

Enum Names

When you're adding a new Enum attribute, you need to define the list 
of acceptable strings. There are two default strings, “Green” and 
“Blue”, in the Enum Names list that you can change. To change, select 

Note If you select Float or Integer, you can also set Numeric Attribute 
Properties.
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Green or Blue and then enter the new string in the New Name text box. 
To add a new string, click the blank entry below the last list item and 
type the string in the New Name text box. 

The following list of names are reserved internally for (dynamic) shading 
attributes. You may use these names for custom attributes, but beware 
they may produce unexpected results in the shading network. For 
example, during shading the uvCoord value is provided, therefore 
ignoring your custom uvCoord attribute value.

blobbySurfaceFactor 
displacement 
easMask 
farPointCamera 
farPointObj 
farPointWorld 
filterSize 
flippedNormal 
illuminationIndex 
infoBits 
lightData 
lightTable 
matrixObjectToWorld 
matrixWorldToObject 
mediumRefractiveIndex 
normalCamera 
numShadingSamples 
objectId 
objectType 
opticalDepth 
outColor 
outGlowColor 
outMatteOpacity 
outParticleEmission 
outTransparency 
particleAge 
particleAttrArray 
particleColor 
particleEmission 
particleEntryParam 
particleExitParam 
particleIncandescence 
particleLifespan 
particleOrder 
particleTransparency 
particleWeight 
pixelCenter 
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pixelCoverage 
pointCamera 
pointObj 
pointWorld 
primitiveId 
rayDepth 
rayDirection 
rayOrigin 
receiveShadows 
refPointCamera 
refPointObj 
refPointWorld 
renderState 
shadowAttenuation 
tangentUCamera 
tangentVCamera 
translucenceDepth 
triangleNormalCamera 
uvCoord 
uvFilterSize 
vertexCameraOne 
vertexCameraThree 
vertexCameraTwo 
vertexUvOne 
vertexUvThree 
vertexUvTwo

Modify > Edit Attribute

You can edit custom (or dynamic) attributes from either the main menu 
(Modify > Edit Attribute) or from the Attribute Editor (Attributes > 
Rename Attributes).You can perform the following editing operations on 
custom attributes.

Related topics

”Create, edit, or delete custom attributes” on page 166

Options

• You can rename a custom attribute. Select it in the Attributes list and 
modify the name in the New Name text box.

In attribute names, all punctuation except for the underscore (_) and 
the pound sign (#) are illegal characters
Basics 

184



5 | Nodes and attributes

Reference > Modify > Delete Attribute
• You can add, remove, or modify minimum and maximum values (for 
Integer, Float, and Vector type attributes). Select the attribute in the 
Attributes list and then turn on or off the Has Minimum and Has 
Maximum checkboxes, as well as type values for these in the 
corresponding Min/Max text boxes.

• You can control the display of custom attributes in the Channel Box. 
Select the attribute in the Attributes list and then turn the Keyable 
check box on or off. When Keyable is turned on, the custom attribute 
appears in the Channel Box. 

• You can change Enum strings. Select the Enum attribute in the 
Attributes list and modify the strings in the Enum list the same way 
you created them. 

Modify > Delete Attribute

You can delete custom attributes from the main menu (Modify > Delete 
Attribute) or from the Attribute Editor (Attributes > Delete Attributes). 
You cannot delete built-in attributes.

Related topics

”Create, edit, or delete custom attributes” on page 166

Windows and Editors

Outliner

The Outliner shows a hierarchical list of all objects in the scene in outline 
form.

To show the Outliner choose Windows > Outliner.

Note You cannot key string attributes.

Note When you create a Vector type custom attribute, three child 
attributes are created (nameX, nameY, nameZ, where name is the 
name of the attribute).

For example, if you created a vector attribute named Speed, the 
children would be SpeedX, SpeedY, and SpeedZ. You can’t 
access the Numeric Attribute Properties (Keyable and Min/Max) 
of the parent vector attribute. You have to select a child attribute 
and modify its Numeric Attribute Properties.
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Related topics

”The Outliner” on page 154

”View and edit the hierarchy of nodes” on page 168

Outline

To... Do this

Expand or collapse the level 
under a node.

Click the square plus  or minus  next to 
the node’s name.

Expand all levels under a 
node.

Hold Shift and click the square plus  next 
to the node’s name.

Change a node’s order in 
the hierarchy.

Drag the node with the middle mouse 
button and drop it between two other 
nodes.

Make a node a child of 
another node.

Drag the node with the middle mouse 
button and drop it on top of the node you 
want to be its parent.

If you can’t see both nodes at the same 
time in the Outliner, use Edit > Parent 
instead.

Bring a node out from 
under its parent.

Select the child node and choose Edit > 
Unparent.

Split the Outliner window. Drag the divider bar at the bottom of the 
window up.

When the pointer is over the bar the cursor 
changes to a up/down drag indicator .

To unsplit the window, drag the divider 
back down to the bottom of the window.

Rename a node. Double-click the node’s name.

In node names, all punctuation except for 
the underscore (_) and the pound sign (#) 
are illegal characters. 
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Menus

Display

DAG Objects Only

Only show transformable nodes.

Shapes

Show shape nodes.

Attributes (Channels)

Allow the display of attributes on nodes. Use the round plus and 
minus buttons to show a node’s attributes.

Set Members

Allow the display of members under the sets.

Allow the display of 
attributes (channels) in the 
Outliner.

Turn on Display > Attributes (Channels).

You can also limit the display of 
attributes with the Outliner’s Show > 
Attributes sub-menu.

Show or hide the attributes 
on a node.

Click the round plus ( ) or minus ( ) next 
to the node’s name.

You can further expand multi-value 
attributes.

You cannot edit attribute values in the 
Outliner.

Open a node in the 
Attribute Editor.

Double-click the icon next to the node’s 
name.

Open an attribute in the 
Expression Editor.

Double-click the attribute name.

Note The Display and Show menu settings are saved with a scene file. 
The menu settings are not saved when you open a new or 
different scene.

To... Do this
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Connected

Only show attributes that are connected another node, keyed, or 
connected by set driven key, a constraint, a motion path, or an 
expression.

Reveal Selected

Expands the outline to show the currently selected node(s).

Channel Names

Choose what attribute names to show when Attributes (Channels) is 
on. Nice names are more readable. Long and Short names are the 
actual names of attributes, which you can use in expressions and 
MEL.

Sort Order

Choose Scene Hierarchy to show the hierarchy. Choose Alphabetical 
Within Type to show flat alphabetical lists of each node type.

Select Set Members

Selects the members of the highlighted set.

Show

Objects

Choose which object types to show in the Outliner. Choose Clear 
Below to turn off all filters.

Attributes

Choose which attribute types to show in the Outliner. Choose Clear 
Below to turn off all filters.

Hidden Hidden attributes.

Keyable Keyable attributes. 

Scale, Rotate, 

Translate  Scale, Rotate, or Translate attributes.

Driven by Anim 

Curve Attributes with an animation curve. This includes 
attributes animated with keys, set driven keys, 
constraints, and motion paths.

Driven by 

Expression Attributes controlled by expressions.

User Defined User-defined attributes.
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Invert Shown

Reverse the filters so visible objects are hidden and hidden objects are 
visible.

Show All

Turns off all filters in the Show menu.

Show Selected Type(s)

Shows only object types of the same type as the current selection.

Create Entry

Lets you save the current filter with a name.

Delete Entry

Lets you delete a saved filter.

Show Auxiliary Nodes

Shows node types that the Outliner normally does not show because 
they are rarely needed (such as underworld nodes).

Auxiliary Nodes

Lets you set what nodes are considered “auxiliary”.

Attribute Editor

Lists attributes on the selected object. Tabs across the top of the Attribute 
Editor let you select nodes connected to the shown node.

While the Channel Box provides a more compact view of keyable 
attributes, the Attribute Editor gives you full graphical controls to edit 
attributes rather than just text boxes.

You can set an option in Window > Settings/Preferences > Preferences to 
have the Attribute Editor open in a window instead of the side panel.

Related topics

”Nodes and attributes” on page 149

”Change attribute values in the Attribute Editor or Channel Box” on 
page 159

”Save and reuse attribute presets” on page 164

”Lock the value of an attribute” on page 166

”Create, edit, or delete custom attributes” on page 166

”Open multiple Attribute Editors” on page 167

”Channel Box” on page 196
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Loading object attributes into the Attribute Editor

Loading attributes into the Attribute Editor makes them available to view 
or edit. There are three ways to load object attributes into the Attribute 
Editor:

• automatically when you select the object

• manually

• by selecting the object from the Attribute Editor Selected menu

• by selecting the object from the Focus menu

Loading attributes automatically

When you select an object, its attributes are automatically loaded into the 
Attribute Editor where you can view and edit them. Each node of the 
selected object automatically appears as a tab. This is the default method.

To automatically load attributes for selected objects

In the Attribute Editor, select List > Auto Load Selected Attributes to turn 
it on.

Loading attributes manually

If Auto Load Selected Attributes is turned off, after selecting an object, 
you must manually load the object’s attributes into the Attribute Editor to 
view and edit them.

To manually load attributes for selected objects

• Click the Load Attributes button at the bottom of the Attribute Editor.

Attribute Editor colors

The color of the attribute box changes depending on its state. For more 
information, see ”Channel Box colors” on page 199.

Menus

List 

Use this menu to load attributes into the Attribute Editor and to define 
which items display in the Selected/Object menu.

Note If you select more than one item, Maya automatically updates 
the most recently selected one (that is, the most recent one in the 
pick list).
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Selected/Object

The Selected menu lists objects currently selected in the scene while the 
Object menu displays all the objects in the scene of a selected type.

Focus

This menu displays all nodes that have been selected in the scene while 
the Attribute Editor is open. The most recently selected node is at the top 
of the list.

Attributes

Use this menu to add, edit, and delete extra attributes for an object or 
node. These appear under the Extra Attributes section. You can also add, 
edit, and delete attributes using the Modify menu.

Context menu

output connection node

If you set a key for the attribute or connect a texture to it, the resulting 
output connection node name displays as the first menu item. To load the 
attributes for this node into the Attribute Editor, select it. 

Create New Expression

Select this option to create a new expression for the attribute.

Set Key

Select this option to set a key for the attribute. This options disappears 
from the menu if you have already connected a texture to the attribute.

Set Driven Key

Select this option to link the attribute values.

Break Connection

Select this option to break the connection between the attribute and a key 
or texture.

Create New Texture

Select this option to connect a texture to the attribute.

Color Chooser

This option displays for color attributes only. Select it to open the Color 
Chooser.

Lock/Unlock Attribute

Select the Lock option to lock an attribute value so that it cannot be 
changed. Use Unlock Attribute to unlock the value.
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Ignore/Don’t Ignore when Rendering

This option displays only for attributes that are connected to keys or 
textures. Select the Ignore when Rendering option to ignore the 
connection when rendering. If the attribute has a map button, the button 
changes to indicate that the connection is ignored.

Select the Don’t Ignore when Rendering option to render with the set 
connection. For details, see Rendering.

Attributes > Add Attributes

New tab

Attribute Name

Type the name of the attribute you are adding.

Make Attribute Keyable

Turn this option on to make this attribute keyable. For information about 
keyable attributes, see Animation.

Data Type

Select the data type for the attribute: 

Vector  Creates a vector attribute consisting of three floating 
point values.

Float Creates a floating point attribute.

Integer  Creates an integer attribute.

Boolean  Creates an attribute consisting of an on/off turn.

String Creates a string attribute that accepts alphanumeric 
entries as data entry, such as a filename.

Enum Creates an attribute that accepts selections from an 
“enumerated” or drop-down list. 

Attribute Type

Select a type:

Note If you select Float or Integer, you can also set Numeric Attribute 
Properties.

Indicates that the connection is ignored when rendering

Indicates that the attribute is connected to a key or texture
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Scalar  Creates a per object attribute that you can set to a 
single value that applies to every particle in the 
object. A vector scalar is considered a single value 
with three numbers. If you select Scalar, you can 
specify Minimum, Maximum, and Default values 
for a Float or Integer attribute. 

Per Particle 

(Array)  Creates a per particle attribute. You can set this type 
of attribute to different values for each particle. If 
you select Per Particle (Array), you can also create a 
counterpart initial state attribute by turning on Add 
Initial State Attribute.

Add Initial State 

Attribute  Turn on to create a corresponding initial state 
attribute for the added attribute. Without this 
corresponding attribute, you can’t save a particle 
object’s current attribute values for initial state 
usage. You must write a creation expression if you 
decide to initialize the custom attribute’s value upon 
rewinding the animation. If you know you’re going 
to write a creation expression for a custom attribute, 
you can set Add Initial State Attribute to off when 
you add the attribute. Otherwise, set Add Initial 
State Attribute to on whenever you add a custom 
per particle attribute. 

Numeric Attribute Properties

For scalar attributes, Minimum and Maximum set the lowest and 
highest values you can enter for the attribute in the Attribute Editor or 
Channel Box. Default sets the default value for the attribute. 

Enum Names

When you're adding a new Enum attribute, you need to define the list 
of acceptable strings. There are two default strings, “Green” and 
“Blue”, in the Enum Names list that you can change. To change, select 
Green or Blue and then enter the new string in the New Name text box. 
To add a new string, click the blank entry below the last list item and 
type the string in the New Name text box. 

Warning!The following list of names are reserved internally for (dynamic) 
shading attributes. You may use these names for custom attributes, 
but beware they may produce unexpected results in the shading 
network. For example, during shading the uvCoord value is 
provided, therefore ignoring your custom uvCoord attribute value. 
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blobbySurfaceFactor 
displacement 
easMask 
farPointCamera 
farPointObj 
farPointWorld 
filterSize 
flippedNormal 
illuminationIndex 
infoBits 
lightData 
lightTable 
matrixObjectToWorld 
matrixWorldToObject 
mediumRefractiveIndex 
normalCamera 
numShadingSamples 
objectId 
objectType 
opticalDepth 
outColor 
outGlowColor 
outMatteOpacity 
outParticleEmission 
outTransparency 
particleAge 
particleAttrArray 
particleColor 
particleEmission 
particleEntryParam 
particleExitParam 
particleIncandescence 
particleLifespan 
particleOrder 
particleTransparency 
particleWeight 
pixelCenter 
pixelCoverage 
pointCamera 
pointObj 
pointWorld 
primitiveId 
rayDepth 
rayDirection 
rayOrigin 
receiveShadows 
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refPointCamera 
refPointObj 
refPointWorld 
renderState 
shadowAttenuation 
tangentUCamera 
tangentVCamera 
translucenceDepth 
triangleNormalCamera 
uvCoord 
uvFilterSize 
vertexCameraOne 
vertexCameraThree 
vertexCameraTwo 
vertexUvOne 
vertexUvThree 
vertexUvTwo

Attribute Spread Sheet

Lists multiple attributes on multiple objects in a spreadsheet format.

Related topics

”View and edit multiple attributes on multiple nodes” on page 162

Menus

Names

Names > Short Attribute Names, Long Attribute Names

Choose whether to show the short or long attribute names at the tops of 
the columns.

Layouts

Layouts > Show Selected Columns Only/Show All Columns

Hides the attribute columns that are not currently selected. Choose 
Show All Columns to return to the full display.

Layouts > Remember This Layout

Creates a new tab with only the currently visible attribute columns. 
Select the columns you want in the new tab, choose Show Selected 
Columns, then Remember This Layout.
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Layouts > Delete This Layout

Deletes a custom tab created with Remember This Layout. Click the 
tab and choose Delete This Layout to delete the tab.

Key

Key > Key Selected

Sets keys at the current frame for the attributes (cells) currently 
selected in the spreadsheet.

Tabs

The different tabs show different types of attributes.

Use the arrows at the right end of the tabs to show more tabs that are 
hidden by the window’s edge.

Use Layouts > Show Selected Columns Only and Layouts > Remember 
This Layout to create a new custom tab with only the attributes you want.

Spreadsheet

• Each object is a row, and each attribute on the object is a column.

• Click, shift-click, or drag across a cell, column, or row to select it.

• Type a value to enter it in all selected cells.

Channel Box

The Channel Box is the primary, fastest, and most streamlined tool for 
editing object attributes. It lets you quickly set keys, and lock, unlock, or 
create expressions on attributes.
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Like the Attribute Editor, you use the Channel Box to modify an object’s 
attribute values. The Channel Box is different from the Attribute Editor in 
the following ways:

• It displays only the keyable attributes for the selected object. (You can 
make an object keyable, and therefore display in the Channel Box by 
selecting Window > General Editors > Channel Control.

• You can change multiple attribute values of multiple objects (see 
”View and edit multiple attributes on multiple nodes” on page 162)

• It takes up much less space in the window.

• You can control construction history.

The information displayed in the Channel Box varies, depending on what 
kind of object or component you have selected. If you haven’t selected an 
object, the Channel Box is blank.

Related topics

”Nodes and attributes” on page 149

”Change attribute values in the Attribute Editor or Channel Box” on 
page 159

”Show or hide the manipulator for an attribute in the Channel Box” 
on page 161

”Lock the value of an attribute” on page 166

Channel Box
Selected object

Object attributes

Object attributes
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”Create, edit, or delete custom attributes” on page 166

”Control the display of attributes in the Channel Box” on page 167

”Connect attributes with an expression” on page 173

Showing the Channel Box

The Channel Box appears in the sidebar when you select Display > UI 
Elements > Channel Box/Layer Editor, or click the Channel Box/Layer 
Editor icon  in the toolbar.

You can display either the Channel Box or the Attribute Editor in the 
sidebar, but not both.

Use the Channel Box toolbar to control the display of the Channel Box and 
Layer Editor.

You can resize the Channel Box using the arrow buttons at the bottom of 
the Channel Box / Layer Editor.

Click  to widen the Channel Box. Click  to 
narrow the Channel Box.

Attributes

When you select a geometric object, the Channel Box displays these 
sections:

Section Usage

objectName Lists the keyable transform attributes that translate, 
scale, and rotate the object’s absolute position in the 
world space. Also shows the object’s visibility attribute.

SHAPES Lists the names of nodes that define the geometry of the 
object. Other nodes, such as related particle emitters may 
be found here.

INPUTS Lists the names of other nodes that affect this one. 
Typically, these comprise the “construction history” of 
the node.

OUTPUTS Lists the names of the output nodes (nodes that receive 
data) for this node.

Show the Layer Editor
Show the Channel Box Show the Channel Box and 

Layer Editor
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If you’ve selected two or more objects, the Channel Box displays the 
attributes for the last object selected only. To display the attributes in the 
Channel Box of another selected object, select Object > objectName.

Edits you make in the Channel Box affect all selected objects of the same 
type as the one displayed.

Component attributes

If you display attributes of an object component, the Channel Box displays 
only one section for shape attributes that pertain to the component.

For example, suppose you’ve created a NURBS curve with the following 
CVs:

If you turn on component selection mode (in the main menu bar) and 
select the CVs, the Channel Box displays this:

You can display the CV values in the Channel Box and enter new values. 
To display the values, click CVs (click to show) in the Channel Box.

Channel Box colors

The following colors represent the state of channels in the Channel Box:
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Setting keys in the Channel Box

To set a key for one attribute

1 Select the object.

2 Click the timeline frame number where you want to set the key.

3 Click the attribute name to select it.

For example, click Translate X.

4 Type the value of the attribute and press Enter.

For example, enter 10 and press Enter.

5 In the Channel Box, choose Channels > Key Selected.

or

Press the right mouse button on the attribute name or text box and 
select Key Selected.

This sets the key for the object attribute value you specified.

Setting a key for all attributes

1 Click the timeline frame number where you want to set the key.

State Color

Locked • Gray (Windows, IRIX, and Linux)

• Pink (Mac OS X)

Muted Brown

Blended Green

Keyed Light Orange

Expression Purple

Constrained Blue

Connected Yellow

Click the timeline 
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2 Enter values for the desired attributes in the Channel Box. Press Enter 
after entering the attributes.

3 In the Channel Box, select Channels > Key All.

or

Press the right mouse button on the attribute name or text box and 
select Key All.

This sets the key for all the object attribute values displayed in the 
Channel Box.

You can key the same attribute value for two or more objects. Select the 
objects, click the frame, enter the value in the text box, then select 
Channels > Key Selected.

You can also key multiple attribute values for multiple objects. Follow the 
instructions in the previous paragraph, only select several attribute text 
boxes using Ctrl- or Shift-click before typing the numerical entry.

To copy keyed attribute values

1 Select the object.

2 In the Channel Box, select the desired attributes. (You can select either 
the attribute name, or the attribute text boxes.)

3 Select Channels > Copy Selected.

or

Press the right mouse button on the attribute name or text box and 
select Copy Selected.

4 Select the attributes you want to paste the keyframed values to.

5 Select Channels > Paste Selected.

or

Press the right mouse button on the attribute name or text box and 
select Paste Selected.

Breakdowns are a type of key that maintains a proportional relationship 
with adjacent keys. You can set a breakdown key for an attribute from the 
Channel Box.

To set a breakdown for selected attributes

1 Select the object.

2 Click the timeline frame number where you want to set the 
breakdown.

3 Select the attributes you want to set breakdowns for.

4 Enter the values of the attributes.
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5 Select Channels > Breakdown Selected.

or

Press the right mouse button on the attribute name or text box and 
select Breakdown Selected.

To set breakdowns for all attributes

1 Select the object.

2 Click the timeline frame number where you want to set the 
breakdowns.

3 Enter the values of the attributes.

4 In the Channel Box, select Channels > Breakdown All.

or

Press the right mouse button on the attribute name or text box and 
select Breakdown All.

INPUTS

Use the INPUTS component of the Channel Box to modify an object’s 
construction history.

Hypergraph

Hypergraph

Presents a graphical view of the scene hierarchy or dependency graph, 
with box representing nodes and lines representing relationships.

Related topics

”The Hypergraph” on page 155

”View and edit the hierarchy of nodes” on page 168

”Change the order of nodes” on page 171

”Change the visual layout of nodes in the Hypergraph” on page 170

”Show inputs and outputs (dependency graph)” on page 171

”Connect input and output attributes” on page 172

”Connect attributes with an expression” on page 173

”Break connections between attributes” on page 174

”Show or hide nodes” on page 175
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Graph area

Use the camera move keys (alt + the middle mouse button and alt + the 
right mouse button) to move around the graph the same way you move 
around in view panels.

Edit > Expand, Collapse, Expand All, Show Selected

Edit > Expand to expand a node to one level below.

Edit > Expand All to expand all subnodes below a node.

Edit > Show Selected to display and expand a node not visible in the 
graph.

Options > Display > Shape Nodes, Hidden Nodes, 
Underworld Nodes

By default, the scene hierarchy does not display shape nodes, hidden 
nodes, or underworld nodes. It displays only transform nodes—nodes 
that hold attributes and other information on an object’s transformation 
and parent-child relationships.

Shape node—holds an object’s geometry attributes or attributes other 
than the object’s transform node attributes. A shape node is a child of a 
transform node. A transform node has only one shape node.

Hidden node—any object hidden using Display > Hide from Maya’s 
menu bar. The default cameras top, front, side, and persp are also hidden 
nodes.

Underworld node—a pair of nodes below a shape node. When you create 
a curve on a NURBS surface, Maya generates an underworld transform 
node and shape node below the shape node of the surface. The CV 
positions of underworld nodes have UV coordinates on the surface rather 
than coordinates in world or local space.

A dotted line in the scene hierarchy indicates a connection to an 
underworld node. Connections to instanced objects are also indicated by 
dotted lines.

Example

If you select Create > NURBS Primitives > Sphere to create a sphere, Maya 
creates a transform node and a shape node.

Note Hypergraph option settings are saved with a scene file. The 
options are not saved for Maya globally.
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The sphere’s shape node holds the mathematical description of the 
sphere’s shape. The sphere’s transform node holds the sphere’s position, 
scaling, rotation, and so on. The shape node is the child of the transform 
node. 

If you select Options > Display > Shape Nodes in the Hypergraph, the 
scene hierarchy shows these nodes for the sphere:

Maya gives the nodes the default names shown in the preceding figure. 
The transform node is nurbsSphere1, the shape node is 
nurbsSphereShape1. If you rename the transform node, for example, to 
Bubble, Maya renames the shape node to BubbleShape.

If you rename the shape node, Maya does not rename the transform node. 
Maya doesn’t transmit a child’s attribute changes up to its parent. 

Example

If you select Create > NURBS Primitives > Sphere to create a sphere, Maya 
creates a transform node and a sphere node. If you then select Modify > 
Make Live, then use the Create > CV Curve Tool to draw a curve on the 
surface of the sphere and turn on the display of shape nodes and 
underworld nodes, the scene hierarchy appears as follows:

Maya gives the nodes the default names shown. The transform node is 
nurbsSphere1, the shape node is nurbsSphereShape1. The curve1 and 
curveShape1 nodes are underworld nodes for the curve created on the 
sphere’s surface.

When a curve-on-surface is hard to select in the workspace because of 
crowding or complex geometry, you can select it easily in the scene 
hierarchy with underworld nodes displayed. 
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Options > Display > Expression Connections, 
Constraint Connections, Deformer Connections

You can display color-coded lines in the scene hierarchy that illustrate 
nodes connected by an expression, constraint, or deformer. 

Example

You create a NURBS sphere named Ball and a NURBS cone named Cone. 
You write an expression to assign the value of Ball’s translateY attribute to 
Cone’s translateY attribute. The expression links the two values. When 
you move Ball up or down in the view (in a Y-axis direction), Cone moves 
up or down the same amount.

If you select Options > Display > Expression Connections, the scene 
hierarchy displays this:

Rendering > Show ShadingGroups, Show Materials, 
Show Textures, Show Lights

You can show connections to shading groups, materials, textures, and 
lights. See Rendering for details.

Example

Suppose you create a NURBS sphere, then use the Hypershade to create 
and assign a Phong shading group to it. Next you use the Hypershade to 
create a 2D checker texture and assign it to the Phong node. 

The Hypershade displays the following contents: 

Tip You can change the color-coding of the connection lines and 
other important entities by selecting Window > Settings/
Preferences > Colors from Maya’s main menu bar and 
expanding Hypergraph/Hypershade.

This red line means attributes in 
the two nodes are connected, 
for instance, by an expression.
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The following dependency graph appears when you select Rendering > 
Show Shading Groups in the Hypergraph.

The connection lines between nodes show connection direction. The 
connection line originates at a node that outputs data, and the line points 
to a node receiving the data as input. The example above shows that the 
flow of output goes from the phong1SG shading group to the 
renderPartition. 

Although you can see most of the same nodes in the Hypershade, the 
dependency graph shows the nodes in a flow diagram. This makes it easy 
to see the connections between the nodes that make up a shading group.

If you glide the mouse pointer over a connection line, small white boxes 
appear next to the input node and output node. The white box next to an 
input node shows the node’s name and attribute that receives the input.

Note—This graph is shown vertically. By default, a dependency graph 
displays horizontally.

Connection line
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The white box next to an output node shows the node’s name and 
attribute that provides the output. Each node name and attribute is 
separated by a period, for example, checker1.outColor and phong1.color. 
In the preceding figure, the outColor attribute of checker1 is output to the 
color attribute of phong1.

In many cases, you must be familiar with Maya internal operation details 
to understand the node and attribute names you see in the white boxes.

Graph > Input and Output Connections, Input 
Connections, Output Connections

You can show Input and Output connections to a selected node. An Input 
connection is a node that provides input to the selected node. A Output 
connection is a node that receives input from the selected node. 

To see connections to most objects, you must select the shape node of the 
object rather than the transform node.

provide input to each other all the way to the selected node. 

When you display output connections for a node, you see the chain of 
nodes that output to each other, all the way through to the end 
receiving node.

Example

You create a wine glass surface by revolving a NURBS curve. The 
following dependency graph appears when you select the revolved 
surface’s shape node and select Graph > Input and Output Connections:

Note—This graph is shown vertically. By default, a dependency graph 
displays horizontally.
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The connection lines between nodes show connection direction. The 
connection line originates at a node that outputs data, and the line points 
to a node receiving the data as input.

The example graph shows that a curve provides input to the revolve 
operation node. The revolve operation generates a revolved shape—the 
wine glass. The revolved shape is connected to initialShadingGroup, 
which sets the default color of all geometric shapes created in Maya. 

If you move your mouse pointer over a connection line, small white boxes 
appear next to the input node and output node. The white box next to an 
input node shows the node’s name and attribute that receives the input. 

The white box next to an output node shows the node’s name and 
attribute that provides the output. Each node name and attribute is 
separated by a period.

In many cases, you must be familiar with Maya’s internal operation 
details to understand the node and attribute names you see in the white 
boxes.

Example

You keyframe the translateX attribute of a NURBS sphere named Ball. If 
you select Ball’s transform node and display all input and output 
connections, this graph appears:

The slanted box indicates Ball’s transform node has been animated. The 
graph doesn’t indicate which type of animation technique controls the 
attribute.

Connection line colors

The connection lines are color-coded to indicate the type of attribute that 
is connecting the nodes. In this case, attribute types are single, double, 
triple, data, and array. See the following table for an explanation.

Note The dependency graph and scene hierarchy display animated 
nodes as slanted boxes. If you animate a node with an expression, 
it displays a regular rectangle rather than a slanted box. All other 
animation techniques display a slanted box. Specifically, a slanted 
box indicates Ball has a param curve connected to it.
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You can change these default colors in the Colors window (Window > 
Settings/Preferences > Colors). 

Graph > Rebuild

If your scene hierarchy or dependency graph doesn’t seem up to date, you 
can rebuild the graphs. For example, if you add an object to a scene and it 
doesn’t appear in the scene hierarchy, rebuild the graphs to make the 
scene hierarchy aware of the object’s presence.

Options > Transitions > Animate Transitions, 5/10/15/
20 frames

When you change the panel view of a graph, for example, by selecting 
View > Previous View, Maya dollies from one view to another 
instantaneously, by default. You can slow Maya’s transition speed 
between views to make the view change action easier to see. 

20 Frames dollies slowest, 5 Frames dollies fastest.

Default 
Color

Attribute 
Type

Example Attributes

Blue Single transform.translateX, 
makeNurbsSphere.radius

Cyan Double file.repeatUV, 
cameraShape.cameraAperature

Green Triple transform.translate, lambert.color

Magenta Data nurbsSurface.create, 
makeNurbsSphere.outputSurface

Red Array particleShape.position, 
particleShape.velocity

Tip A dotted line in the scene hierarchy indicates a connection to an 
underworld node or an instanced object.
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Options > Update > On Nodes Creation, On Selection

Whenever you add or delete an object, rendering node, or other item in 
the scene, the Hypergraph updates the scene hierarchy and dependency 
graph, by default. 

When you select an object in the scene hierarchy or dependency graph, the 
object is also selected in the workspace, Outliner, and elsewhere in Maya. 
Also, when you select an object in the workspace, Outliner, and elsewhere 
in Maya, the object becomes selected in the scene hierarchy or dependency 
graph. 

These updates slow Maya operation when you work with a complex scene 
or when you’re examining nodes or dragging nodes to new positions in a 
free-form hierarchy. You can turn off updating to improve operation 
speed.

Hypergraph tips

Use the following tips to define an easier and faster workflow when using 
the Hypergraph.

Upstream and downstream connections

To show a shape’s upstream and downstream connections, select it 
before you go to the DG view. It is not enough to select the transform 
parent. 

Selecting multiple nodes

If you select multiple nodes in the DAG view, the DG graph 
containing all selected nodes is displayed when you go to the DG 
view. 

Free-form layout mode

In free-form layout mode, Maya saves layout information for any 
node you directly drag or for a collection of nodes that you select and 
drag. 

DG node display

The node type for a given DG node is displayed in the pop-up 
window only during mouse-over feedback. 

Connection lines in the DAG view

Connection lines in the DAG view may clip when you scroll one node 
out of view. (This includes DG connections and IK handle joint span 
lines.)
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Improve performance when viewing large graphs

To improve performance when viewing large graphs, DAG 
connections are not drawn while the view changes.

Hypergraph limitations

The following limitations and workarounds relate to the Hypergraph.

Hiding or collapsing shapes in the Hypergraph

A transform node displays the icon of its child shape when you hide 
or collapse the shape. Depending on the order the graph was built in, 
the icon may still occasionally show the transform icon, even if it has a 
shape child. 

Workaround

Use Graph > Rebuild to update the icon.

Changing default Hypergraph colors

If you change the default Hypergraph colors (Options > Customize UI 
> Colors), some objects may lack contrast or appear to be invisible. 

Workaround

Select colors that contrast with the background or foreground colors.

Deleting connections in the DG view of the Hypergraph

Connections in the DG view can be deleted only when you single-
select them. You cannot delete a multiple selection of connections with 
a single delete action.

Workaround

Delete each connection individually while you are in the DG view.

Using the IK Handle Tool in the Hypergraph

The IK Handle Tool behaves differently in the Hypergraph than it 
does in a model view. In a model view you can select the start joint 
and then select the end joint to add an IK handle. However, in the 
Hypergraph after you select the first joint you must hold down the 
Shift key to extend the selection for the end joint. 
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About Files and organization

Organizing objects

Groups

A group is a way to transform multiple objects at once. The group shares a 
single pivot point for rotation and scaling.

In terms of the scene hierarchy, grouping objects together moves them 
under a new transformation node.

Display layers

Layers are a way of grouping large pieces of the scene together so you can 
show, hide, or edit them all at once.

Related topics

”Scene hierarchy” on page 152

”Organize objects on display layers” on page 226

Sets and partitions

Sets

A set is a collection of objects or components. Any item you can select can 
be in a set. The set exists as a separate object representing the collection. 
Unlike groups, sets do not alter the hierarchy of the scene.

In some instances, Maya creates sets for you as you work with objects. For 
example, when you add a cluster deformer to some CVs of a NURBS 
surface, Maya makes a set for the CVs. You can edit the set to control the 
effect of the deformation. Maya also creates sets that represent shading 
groups and layers, and points controlled by deformers, flexors, and skin.

You can create a custom set so you can work on its items with a single 
action. For example, you can create a set of NURBS objects, then hide or 
display the set as a single entity.

You can control the membership of sets easily using the Relationship 
Editor.

Sets are useful for the following:
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• Simplifying selection of objects or components that you regularly 
select or have difficulty selecting in the workspace.

• Assigning objects to shading groups for rendering.

• Moving objects from one layer to another.

• Adjusting deformer, skin, and flexor deformation.

• Adjusting the weight of cluster, cluster flexor, and skin points.

• Working with shading groups.

Partitions

A partition is a collection of related sets. Partitions prevent the sets in 
them from having any overlapping members. Maya uses partitions to 
keep sets separate where overlapping members could cause problems.

Maya creates partitions to keep character sets, shading groups, skin point 
sets, and exclusive deformers from having overlapping members.

You can create your own partitions when you want to create sets that 
have no overlap.

For example, suppose you’re animating a cartoon character’s nose as he 
smiles and laughs. You added a cluster to several CVs for adjusting the 
nose as he smiles and another cluster to different CVs for adjusting the 
nose as he laughs. 

Creating the two clusters creates a set for each group of CVs. Occasionally 
you want to move CVs from one set to the other. When you move the CVs 
from one set to the other set, they remain in the first set. You might not 
want the CVs in the first set because they add undesirable deformations as 
you transform the cluster. 

To avoid this problem, you can create a partition and put both sets in it. 
The partition prevents one set from having members of another set. When 
you move the CVs from the first set to the second set, they’re 
automatically removed from the first set.

Related topics

”Create and edit sets” on page 228

”Keep a collection of sets from having overlapping membership” on 
page 228

File referencing

File referencing is a very powerful tool to help organize complex scenes 
and manage a production process. Within a Maya scene, you can create 
references to other Maya scenes and objects within those scenes. These 
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referenced files can be the end product of an entirely separate production 
process; for example, one group of animators creates and works on the 
mesh file, which is referenced into the rig file, which is referenced into the 
shot file. 

A technical director create a rigged character used for all the shots; that 
master rig is then used for various animations. Any issues with the rigged 
character can then be fixed once, rather than having to re-import the 
model into many different scenes. 

Related topics

”Import or reference data in an external file” on page 220

”Reference Editor” on page 253

”Preload Reference Editor” on page 255

Supported file formats

Translators

Translators are plug-ins that let you open and/or save data in a given file 
format. You must have the proper translator plug-in loaded to be able to 
open, save, import, or export data in the format.

Use the plug-in manager to load or unload translators.

The following lists general file format support. There may be slight 
differences in support between platforms and depending on variations in 
file formats. For example, TIFF is a very loosely defined format. It may be 
possible to save TIFF files in another program that Maya cannot open.

Note Any connections added to a file that is used as a reference will 
take precedence over connections made in the referencing file. 
To restore the connections in the referencing file, the referenced 
connections must be broken, and the attributes reconnected in 
the referencing file. For example, if animation is added to a file 
after it is referenced, any animation on those attributes in the 
referencing file will no longer be displayed. As a general rule, 
you should try to avoid changes of this type once a file has been 
referenced.

Data Import Windows Mac OS X IRIX Linux

Maya ASCII Yes Yes Yes Yes
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Maya Binary Yes Yes Yes Yes

MEL Yes Yes Yes Yes

DXF Yes Yes Yes Yes

DWG Yes Yes Yes Yes

OBJ Yes Yes Yes Yes

IGES Yes Yes Yes Yes

StudioTools wire Yes Yes Yes

AIFF Yes Yes Yes Yes

image Yes Yes Yes Yes

mov (ascii motion) Yes Yes Yes Yes

VRML2 Yes * * *

EPS Yes Yes Yes Yes

Illustrator Yes Yes Yes Yes

OpenFlight Yes Yes Yes Yes

STL Yes Yes Yes Yes

Data Import Windows Mac OS X IRIX Linux

Data Export Windows Mac OS X IRIX Linux

Maya Ascii Yes Yes Yes Yes

Maya Binary Yes Yes Yes Yes

MEL Yes Yes Yes Yes

DXF Yes Yes Yes Yes

OBJ Yes Yes Yes Yes

IGES Yes Yes Yes Yes

StudioTools wire Yes Yes
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mov (ascii motion) Yes Yes Yes Yes

VRML2 Yes Yes Yes Yes

GE2 Yes Yes Yes Yes

RTG Yes Yes Yes Yes

mental ray Yes Yes Yes Yes

RIB Yes Yes Yes

Open Inventor2 Yes Yes Yes Yes

OpenFlight Yes Yes Yes Yes

Shockwave3D Yes

Data Export Windows Mac OS X IRIX Linux

Image Input Windows Mac OS X IRIX Linux

Maya IFF Yes Yes Yes Yes

AVI Yes

Quicktime Yes Yes

GIF Yes Yes Yes

Softimage Yes Yes Yes

Wavefront RLA Yes Yes

BMP Yes Yes Yes

TIFF Yes Yes Yes Yes

SGI RGB Yes Yes Yes Yes

Alias Pix Yes Yes Yes

JPEG Yes Yes Yes Yes

EPS Yes

Cineon Yes Yes Yes
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Quantel Yes Yes Yes

Targa Yes Yes Yes Yes

MacPaint Yes

PhotoShop Yes

PNG Yes

QuickDraw Yes

Image Input Windows Mac OS X IRIX Linux

Image Output Windows Mac OS X Irix Linux

Maya IFF Yes Yes Yes Yes

AVI Yes Yes

Quicktime Yes Yes

GIF Yes Yes Yes

Softimage Yes Yes Yes

Wavefront RLA Yes Yes Yes

BMP Yes Yes Yes Yes

TIFF Yes Yes Yes Yes

SGI RGB Yes Yes Yes Yes

Alias Pix Yes Yes Yes

JPEG Yes Yes Yes Yes

EPS Yes Yes Yes

Cineon Yes Yes Yes

Quantel Yes Yes Yes

Targa Yes Yes Yes

MacPaint Yes
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* via wrl2ma

How do I? Work with files

Create, open, or save a scene file

To start a new, blank scene file

• Choose File > New Scene.

You can choose to always create new scenes with default content by 
choosing File > New Scene > ❒  and turning on Enable Default Scene.

To open an existing scene file

• Choose File > Open Scene.

The Open dialog box appears, open in the scene folder of the current 
project.

To save the current scene file

• To save the scene with its current name, choose File > Save Scene.

• To save the scene with a new name, choose File > Save Scene As.

• To change how Maya saves the scene, choose File > Save Scene > ❑ 
and set the options.

When you use Save Scene As you can choose whether to save the file as 
Maya Binary (smaller) or Maya ASCII (human readable). To save in a 
different format, use File > Export All.

Related topics

”Translators” on page 215

PhotoShop Yes

PNG Yes Yes Yes Yes

QuickDraw Yes

DDS Yes Yes Yes Yes

Image Output Windows Mac OS X Irix Linux
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”Supported file formats” on page 215

”Import or reference data in an external file” on page 220

”Export objects to a new file” on page 222

”Optimize scene size” on page 222

Import or reference data in an external file

To... Do this

Import data from a file into 
the scene.

Choose File > Import.

To set file format import options, click 
the file in the Import dialog box and 
then click Options.

Reference the contents of a 
file.

Choose File > Create Reference.

Open the Reference Editor. Choose File > Reference Editor.

Import the contents of a 
currently referenced file.

In the Reference Editor, click the 
referenced file and choose File > 
Import Objects from Reference.

Select the objects that come 
from a referenced file.

In the Reference Editor, click the 
referenced file and choose Edit > Select 
File Contents.

Temporarily load or unload 
the objects from a referenced 
file.

In the Reference Editor, click the 
referenced file and choose Reference > 
Load Reference or Reference > Unload 
Reference.

Change the location of a 
reference.

In the Reference Editor, click the 
referenced file and choose Reference > 
Replace Reference.

Use the dialog box to find the new 
location of the file.

Stop referencing a file. In the Reference Editor, click the 
referenced file and choose Edit > 
Remove Reference.
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Referencing limitations

The following operations can cause problems with referenced character 
sets:

• Removing a member from the character set.

• Deleting a member of the character set.

The animation in the referencing file will be connected to the character 
but will no longer affect the object. Additionally, if you then add a 
member to the character, it may or may not take the slot vacated by 
the previous member, which can cause the referenced file's animation 
to go to a new object. 

• Renaming a member or renaming the character set itself.

This operation is always forbidden when using referencing if the 
referenced file modifies or connects to the renamed object. 

These operations can lead to animation that does not affect the character 
set or affects the wrong member of the character set.

Related topics

”Translators” on page 215

”Supported file formats” on page 215

”Import or reference data in an external file” on page 220

”Export objects to a new file” on page 222

”Optimize scene size” on page 222

Specify which references to 
load.

Select File > Open > ❒  and turn on 
Selective Load. Then click Open and 
select your file. The Preload Reference 
Editor appears. In this editor, specify 
which references to load.

Open a file with no references 
loaded.

Select File > Open > ❒  and turn on 
Load No References. Then click Open 
and select your file, which is opened 
with no references loaded.

Create a reference with a 
locator.

Choose File > Create Reference > ❒  
and make sure the Group and Locator 
options are turned on, then click 
Reference.

To... Do this
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Export objects to a new file

To save scene data in a non-native file format such as OBJ or DXF, you 
must have a plug-in for that file format loaded.

View images or animations

A file browser appears and FCheck is launched with the image or 
animation you specify.

Related topics

Overview of FCheck

Optimize scene size

There are several functions available in Maya to decrease the size and 
complexity of your scene.

To... Do this

Export the selected objects 
to a file.

Choose File > Export Selection.

Export the scene to a 
different file format.

Choose File > Export All.

Export the selected objects 
to a file and then reference 
it.

Choose File > Reference Editor.

In the Reference Editor, choose File > 
Export Selection as a Reference.

Choose the file type from the File of Type 
drop-down list.

To... Do this

View an image. Select File > View Image.

View an animation. Select File > View Sequence. 
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Related topics

”Construction history” on page 105

”Delete” on page 123

Organize files into projects

Maya organizes the various files associated with scene files into projects. A 
project is a collection of folders for different types of files.

To start a new project

1 Choose File > Project > New.

2 Type the name of the project in the Name text box.

3 Click Browse to choose where to save the Project folder.

To... Do this

Remove empty, invalid, and 
unused information from 
the scene.

File > Optimize Scene size > ❑.

Remove construction 
history from the selected 
object(s).

Only do this if you are sure 
you do not need to edit the 
objects’ history again.

Select the objects and choose Edit > 
Delete by Type > History.

Do not save panel layouts 
with the scene.

Choose Window > Settings/Preferences 
> Preferences.

Under Misc, turn off Save Panel Layouts 
with File.

Remove unused file 
references.

Choose File > Reference Editor.

In the Reference Editor, choose File > 
Clean Up Reference

Delete static animation 
channels.

Edit > Delete by Type > Static Channels.
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4 The Locations text boxes control where Maya looks for files of 
different types. Click Use Defaults at the bottom of the window to fill 
in the usual project sub-folder names.

To switch to a different project

1 Choose File > Project > Set.

2 Choose the top level folder of the project.

To change where the project stores different types of files

1 Choose File > Project > Edit Current.

2 Edit the paths.

Recover data after a crash

If Maya crashes, it tries to save your scene in Documents/temp in your 
home folder.

If the TEMP (Windows/Mac OS X) or TEMPDIR (IRIX/Linux) variables 
are set, the recovery file is be saved to the path in the variable instead.

Organize and annotate

Organize objects

Change the name of one or more objects

You can give different objects in the scene the same name, but two sibling 
nodes (nodes with the same parent) cannot have the same name.

To change the name of an object or node

Do any of the following:

• Select an object or node and edit its name at the top of the Attribute 
Editor.

Tips Relative paths start from the project folder.

You can enter multiple paths in a text box by separating them 
with semicolons (;).

Note In node and attribute names, all punctuation except for the 
underscore (_) and the pound sign (#) are illegal characters.
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• Double-click a node in the Outliner.

• Press the right mouse button on a node in the Hypergraph and choose 
Rename.

To rename multiple objects at once

1 Select the objects.

2 Open the pop-up menu next to the input field on the status line and 
choose Quick Rename.

3 Type the base name for all the objects. Maya renames the objects to 
have the base name plus an incremental number.

To add a prefix to the names of a parent node and all its 
children

Select the parent node and choose Modify > Prefix Hierarchy Names.

Make an object unselectable (template)

Related topics

”Select objects or components” on page 45

”Select a node” on page 48

”Select objects based on hierarchy” on page 50

To... Do this

“Template” an object so it 
can’t be selected.

Select the objects you want to template 
and choose Display > Object Display > 
Template.

Make a template object 
selectable again.

Use the Hypergraph or Outliner to select 
the templated node and choose Display > 
Object Display > Untemplate.

Templated nodes have a different color 
in the Hypergraph.

Select a templated object. Use the Hypergraph or Outliner to select 
the templated node.

or

Click the “Select by hierarchy and 
combinations” icon in the toolbar and set 
the selection mask to Template.
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Organize objects on display layers

Related topics

”Organizing objects” on page 213

”Edit all objects on a layer at once” on page 227

”Group objects together” on page 227

To... Do this

Show the Layer Editor. Choose Display > UI Elements > Channel Box/
Layer Editor, or click the Show or hide the 
Channel Box/Layer Editor button in the 
toolbar.

Set the pop-up menu to Display.

Create a new layer. In the Layer Editor choose Layers > Create 
Layer, or click the Create a new layer button on 
the Layer Editor’s toolbar.

Rename a layer. Double click the layer in the Layer Editor and 
type the new name in the layer window.

Assign the selected 
objects to a layer.

Select the layer in the Layer Editor and choose 
Layers > Add Selected Objects to Current 
Layer.

Remove the selected 
objects from whatever 
layers they are on.

Choose Layers > Remove Selected Object(s) 
from Layers.

Delete a layer. Select the layer in the Layer Editor and choose 
Layers > Delete Selected Layer(s).

Delete layers without 
any objects.

In the Layer Editor, choose Layers > Delete 
Unused Layers.
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Edit all objects on a layer at once

The Attribute Editor for a layer contains additional, seldom-used 
attributes in addition to the settings available in the layer window.

To show the Attribute Editor for a layer, select the layer in the Layer 
Editor and choose Layers > Layer Attributes.

Related topics

”Organizing objects” on page 213

”Organize objects on display layers” on page 226

Group objects together

When you group objects together, you can select, move, rotate, and scale 
the group as a single unit.

To... Do this

Show the Layer Editor. Choose Display > UI Elements > Channel Box/
Layer Editor, or click the Show or hide the 
Channel Box/Layer Editor button in the 
toolbar.

Set the pop-up menu to Display.

Show or hide a layer. Click the left column next to the name of the 
layer.

A “V” in the box means the layer is visible.

Cycle the layer’s 
display type between 
normal, reference, and 
template.

Click the middle column next to the name of 
the layer to cycle through three values:

• A blank box means the layer is normal.

• A “T” means the layer is templated.

• An “R” means the layer is reference.

Change the wireframe 
color of all objects on a 
layer.

Double click the layer in the Layer Editor and 
click a color in the layer window.
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In terms of the scene hierarchy, the Group command moves the selected 
objects under a new transformation node.

Related topics

”Transformations” on page 103

”Scene hierarchy” on page 152

”View and edit the hierarchy of nodes” on page 168

Create and edit sets

To create a set with the selected objects

• Choose Create > Sets > Set.

To delete a set

Select the set in the Outliner or Relationship Editor, and press Delete.

Deleting the set does not delete its members.

Related topics

”Sets and partitions” on page 213

”Keep a collection of sets from having overlapping membership” on 
page 228

Keep a collection of sets from having 
overlapping membership

Partitions lets you group sets together while ensuring that the sets do not 
share members.

To... Do this

Group the selected 
objects together.

Choose Edit > Group.

Ungroup the selected 
group.

Choose Edit > Ungroup.

Select a group. Open the Outliner (Window > Outliner) and 
expand the group node to show the objects 
inside the group, then click the object you 
want to select.
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To create a partition

1 Use the Outliner or Relationship Editor to select the sets you want to 
go in the new partition.

2 Choose Create > Sets > Partition.

The sets in the partition are now prevented from having overlapping 
membership.

To create a new set in a partition

1 Select the items you want to go in the new set.

2 Choose Create > Sets > Set > ❑.

3 Do one of the following:

• To add the set to a partition only if it’s already exclusive (that is, it 
doesn’t overlap with any of the sets in the partition), click Only If 
Exclusive.

• To add the set to a partition and remove any members that are 
already in other sets in the partition, click By Making Exclusive.

4 Choose the name of the partition to add this set to from the Partition 
pop-up menu.

5 Click Apply and Close.

If you chose Only If Exclusive and the set overlaps sets in the 
partition, Maya does not add the set to the partition and a warning 
appears on the status line.

To edit the membership of a partition

1 Choose Window > Relationship Editors > Partitions.

2 On the left side, click the partition you want to add to.

3 On the right side, click to highlight the sets you want in the partition.

You can also select the sets you want to add to a partition in the Outliner, 
and then in the Relationship Editor’s left side menus choose Edit > Add 
Selected Items.

To remove a set from a partition

1 Choose Window > Relationship Editors > Partitions.

2 On the left side, click the plus icon to next to the partition name to 
show its contents.

3 Click the set you want to remove.

4 In the Relationship Editor’s left side menus choose Edit > Remove 
Highlighted From Partition.
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To delete a partition

1 Choose Window > Relationship Editors > Partitions.

2 Select the partition and press Delete.

Deleting the partition does not delete its member sets.

Related topics

”Sets and partitions” on page 213

”Create and edit sets” on page 228

Annotate and measure

Annotate or document objects

To attach a label to an object in the scene

1 Select the object.

2 Choose Create > Annotation.

3 Type the label text and click OK.

You can then select and move the label.

To add text notes to a node

1 Select the object or node you want to add notes to.

2 Type in the Notes field at the bottom of the Attribute Editor.

Related topics

”Measure the distance between two points” on page 230

”Show parameter or arc-length values on a curve or surface” on 
page 231

Measure the distance between two points

1 Choose Create > Measure Tools > Distance Tool.

2 Click two points.

Maya creates two locators with a distance measurement. You can 
select and move the locators to edit the measurement.

If you snap a measurement locator to an object, the locator moves 
with the object.
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Related topics

”Show parameter or arc-length values on a curve or surface” on 
page 231

Show parameter or arc-length values on a 
curve or surface

To show parameter values

1 Choose Create > Measure Tools > Parameter Tool.

2 Press the left mouse button on a curve or surface and drag to show 
parameter values.

Release the mouse button to create a parameter locator.

To show arc-length

1 Choose Create > Measure Tools > Arc Length Tool.

2 Press the left mouse button on a curve or surface and drag to show 
arc-length from the beginning of the curve or (0,0) corner of the 
surface.

Release the mouse button to create an arc-length locator.

Related topics

”Measure the distance between two points” on page 230

Reference Menus

File

File > New Scene

Clears the current scene and starts a new one. Maya gives you the chance 
to save the current scene before clearing it.

File > New Scene > ❒

Enable Default Scene

Turning on this option allows you to choose a file to be loaded into 
the scene whenever a new scene is created.
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Default scene

Click the folder (browse) icon and select a Maya file.

Related topics

”Create, open, or save a scene file” on page 219

File > Open Scene

Opens a saved scene from disk.

Related topics

”Supported file formats” on page 215

”Create, open, or save a scene file” on page 219

”Import or reference data in an external file” on page 220

”File > Import” on page 237

”File > Create Reference” on page 245

File > Open Scene > 

General options

File Type

Select the file format you want to use as a default for the next time 
you open a file.

If you have a project set up, when you open a scene, the browser 
points to the directory containing files of that type. On Windows and 
Mac OS X, it also sets the filter to display only files of the selected 
type.

For example, if you set File Type to DXF, when you open a scene, the 
Open window displays the contents of CurrentProject/DXF. On 
Windows and Mac OS X, it also sets your filter type to DXF.

Depending on the File Type you select, various File Type Specific 
Options are displayed.

Note When you open a file with File > Open, the working units (mm, 
degrees, etc) are changed to those specified in that file. If you 
want to avoid having the working units changed, use File > 
Import to read the file.
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Execute Script Nodes

Script nodes contain MEL scripts in mayaAscii or mayaBinary files. 
You can designate a script node to execute its script when the node is 
read from a file, or before or after rendering a frame. You can create 
and edit the script nodes using the Expression Editor. See the chapter 
“Using Script Nodes” in the MEL book for information on creating 
and editing script nodes.

User interface configuration information is stored inside the Maya 
scene file as an attribute on a script node. If you disable the Execute 
Script Nodes option, the UI script nodes are not executed. However, 
we recommend disabling script node execution only if you have an 
error in your script.

Load No References

This opens the file without loading any references. You can load 
references after the file is open in Maya by opening the Reference 
Editor (”Reference Editor” on page 253) and selecting the references 
you want to load.

Load All References

Opens the file with all references loaded. You can change the state of 
reference loading after the file is open in Maya by opening the 
Reference Editor (”Reference Editor” on page 253) and selecting the 
references you want to unload.

Selective Preload

Selecting this option opens the Preload Reference Editor before 
opening any file (”Preload Reference Editor” on page 255). You can 
choose to load or defer any references in the file. 

mayaAscii, MayaBinary, and MEL. File Type Specific Options

Use Full Names for Attributes on Nodes

Displays the full names of node attributes in the file. 

For example, if you select the Use Full Names for Attributes on Nodes 
option, attribute names are listed as, setAttr.translate 0 0 0 when you 
open the Maya ASCII file in a text editor. If you turn off the Use 
Verbose Names option, attribute names are listed as setAttr .t 0 0 0.

OBJ File Type Specific Options

Create Multiple Objects

Specifies how shapes are created in OBJ files. 

Select True to create individual shapes based on grouping information 
specified in the OBJ file. 
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Select False to create one shape for the entire file, with object sets 
corresponding to each of the specified groups.

You cannot have overlapping groups. If you do, Maya informs you 
that overlapping groups exist, and re-reads the file as if the option 
were set to False. 

Sound (audio) File Type Specific Options

Sound File Offset

Specifies the time the sound should start playing. 

For example, suppose you created an animation of a bird walking a 
tightrope, and you wanted the sound file to play after the bird 
reached the end of the rope. If you knew that the bird reached the end 
of the tightrope at time 108, you would specify a sound file offset of 
108.

Move files

You must import move files. See ”File > Import” on page 237.

Anim files

You must import anim files. See ”File > Import” on page 237.

Illustrator and EPS files

You must import Illustrator and EPS files. See ”File > Import” on 
page 237.

File > Save Scene

Saves the scene under its current name.

Related topics

”Supported file formats” on page 215

”Create, open, or save a scene file” on page 219

”Import or reference data in an external file” on page 220

”Export objects to a new file” on page 222

”File > Save Scene As” on page 235

”File > Export All, Export Selection” on page 242
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File > Save Scene > 

Incremental Save

When Incremental Save is turned on and you save the scene, a backup 
folder by the same name is created in the scenes\incrementalsave folder 
and a backup is made of the file that was previously saved to disk. 
Each time you save, another backup file is created. These backup files 
are incremental (filename.001.mb, filename.002.mb) so the previous 
backup is not overwritten. The number of incremental backups 
created is infinite by default.

Limit Incremental Saves

Applies a limit to the number of incremental backup files that Maya 
creates and stores. The default limit is 20 increments.

Number of Increments

Type a value or drag the slider to specify a limit. 

File > Save Scene As

Allows you to choose a new name and location for the scene file.

Related topics

”Supported file formats” on page 215

”Create, open, or save a scene file” on page 219

”Import or reference data in an external file” on page 220

”Export objects to a new file” on page 222

”File > Save Scene” on page 234

”File > Export All, Export Selection” on page 242

File > Save Scene As > 

File Type 

Sets the file type to mayaBinary or mayaAscii. The default is 
mayaBinary.

Note When the Limit Increment Saves checkbox is turned on, 
Incremental Save stores only the limited number of incremental 
backup files. Once the limit is reached, Maya deletes the oldest 
incremental file and replaces it with the latest incremental backup 
file.
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Default File Extensions 

Adds the file extension .ma to Maya ASCII filenames and .mb to Maya 
Binary filenames.

3D Paint Texture Options

These options define how Maya saves file textures created with the 3D 
Paint Tool when you save a scene.

Always Saves different versions of the file textures when 
you save different versions of a scene. Use this 
setting if you are working on different iterations or 
versions of the file texture.

Unless 

Referenced Saves file textures only if the painted character is not 
referenced. When this option is selected, Maya uses 
the file textures from the referenced file, even if you 
save the scene with a new name. If the character is 
not referenced and you save a copy of the scene 
with this option selected, Maya creates a copy of the 
file textures.

Never Does not save a new file texture. Use this setting if 
you are no longer changing the file textures and 
want to continue to use the saved file textures, even 
if you save the scene with a new name.

Disk Cache Options

This refers to the new jiggle deformer requiring disk cache, which is 
implemented as a DG node and gets updated during a file save. 

Always Creates a copy of the jiggle disk cache file when the 
scene is saved for the first time or saved to a new 
name. The cache file name corresponds with the 
scene file name. This is the default.

Never Does not save a copy of the jiggle disk cache file. 
Use this option to prevent the copy from being 
created and save disk space.

In the New Project and Edit Project windows, we’ve added a Disk 
Cache option to the list of Data Transfer Locations (File > Project > 
New, File > Project > Edit Current). This allows you to set the default 
directory in which to store the jiggle deformer’s disk cache files.
Basics 

236



6 | Files and organization

Reference > File > Optimize Scene Size
Unload References

Facilitates selective file loading by saving files with all references 
unloaded. 

Use Full Names for Attributes on Nodes

Displays the full names of node attributes.

File > Optimize Scene Size

Allows you to remove empty, invalid, or unused parts from the scene to 
reduce its size and complexity.

Choose File > Optimize Scene Size >  and turn on or off the types of 
information to remove, or run individual types of optimizations.

A progress bar displays as Maya optimizes the scene. You can interrupt 
the operation by pressing Esc. You get a report of all the results of the 
optimization in the Script editor.

Related topics

”Optimize scene size” on page 222

File > Import

Loads data from a scene file into the existing scene.

Related topics

”Supported file formats” on page 215

”Create, open, or save a scene file” on page 219

”Import or reference data in an external file” on page 220

Note In both the New Project and Edit Project windows, there is a Disk 
Cache option in the list of Data Transfer Locations (File > Project > 
New, File > Project > Edit Current). This allows you to set the 
default directory in which to store the jiggle deformer’s disk cache 
files.
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File > Import > 

Group

Specifies whether the imported objects are grouped under a single 
transform when you import the file. Grouping makes it easier to work 
on the nodes of imported objects. The default is off.

Remove Duplicate Shading Networks

This setting prevents the duplication of geometry and shading 
networks if you import a file more than once into Maya 

Preserve References

If Preserve References is turned on, the references within the imported 
file are preserved. If it is turned off, all references are imported into or 
exported within the file; that is, they are no longer references, but are 
now objects in the scene. The default is off.

Use Namespaces

When you import or reference a scene with the Use Namespaces 
option turned on, Maya creates a new namespace that contains the 
imported or referenced data. Turning on the Use Namespaces option 
ensures that all nodes are uniquely named.

A namespace is a grouping of objects under a given name. Each item in 
a namespace is identified by its own name along with the namespace 
it belongs to.

By default, the basename of the imported or referenced file is added to 
the beginning of the imported or referenced object names, separated 
by colons. 

For example, if you are importing a scene named foo.ma that contains 
an object named ball, after it’s imported the ball is named foo:ball.

You can change the prefix by selecting Resolve clashing nodes with 
this string and entering a prefix. 

You can create, name, parent, and remove namespaces using the 
namespace command. 

Namespaces do not effect selection, the DAG, the Dependency Graph, 
or any other aspect of Maya.

Tip Before importing or referencing a file, make sure that the 
renaming prefix contains no invalid characters. 
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Name clash options

When you import a scene into another scene, naming conflicts occur if 
the nodes share the same name and parent nodes. 

To resolve these naming conflicts, you can rename only nodes with 
the same name and parents (clashing nodes) or you can rename all 
nodes. You specify whether to use the filename as the prefix (the 
default) or to create a prefix string. 

For more information on node hierarchy, see MEL and Expressions.

File Type

Choose from the pull-down menu the file type you are importing. If 
you aren’t sure what type of file you are importing, you can select 
Best Guess. 

Depending on the file type you select, various file type specific options 
may be displayed.

Move file options

The following file type-specific options apply to importing move files:

Attributes

Type the name of an attribute in the Attributes box and click Add to 
add the attribute to the list of attributes to use when importing or 
exporting. If the attribute is already included in the list, a duplicate is 
not made. You can add several attributes at one time by separating 
them with a space. To remove an attribute, type the name of the 
attribute and click Remove. 

From Channel Box

Click From Channel Box to combine all of the selected objects in 
Maya, in the order of their selection, with the channels selected in the 
Channel Box and place them in the list. For example, if sphere and 
cone are selected, and tx, sx are selected in the Channel Box, sphere.tx 
sphere.sx cone.tx and cone.sx are added to the list of attribute to 
import and export.

Tip We recommend you use namespaces to resolve naming conflicts 
instead of using the Name clash options when importing or 
referencing files.
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Remove Selected

Click Remove Selected to remove all of the attributes selected in the 
list.

Remove All

Click Remove All to remove all of the attributes from the list.

Precision

This is ignored in file export. For file import, this sets the precision of 
the file.

When you click import or export, the move file is written or read and 
only the attributes in the list are affected.

Adobe Illustrator® and EPS options

The Illustrator importer cannot import Illustrator text objects. Convert any 
text objects in your file to paths before you import the file into Maya.

Scale Factor 

Allows you to control the scale of the curves produced from the 
import. It is the same operation as using the Scale Tool.

Group 

Turn on this option to group the imported curves. It is the same 
operation as using the Edit > Group option. 

Animation curve options

Time Range 

Select a time range option and specify the appropriate settings.

Start  Imports the animation information to the selected 
objects so that the animation starts at the time 
specified in the Start Time field.

Start/End Imports the animation information to the selected 
object or objects, scaling the animation to fit into the 
time range as specified in the Start Time and End 
Time fields. Animation information from the keys 
clipboard is either scaled or clipped depending on 
the setting of the Clipboard Adjustment option.

Current  Imports the animation information to the selected 
objects so that the animation starts at the current 
time as displayed in the Animation Controls.
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Clipboard  Transfers the animation information to the selected 
object(s), preserving the duration and timing of the 
animation information on the keys clipboard.

Copies  The value specifies the number of copies of the anim 
curves that are imported. Multiple copies are 
appended sequentially. 

Help Images

Turn on Help Images to display illustrations of the effects of the 
various anim import options.

Clipboard Adjustment

Specify an option for how to handle the Clipboard contents.

Preserve Pastes the contents of the clipboard into their new 
positions on the curve without any changes.

Scale  Becomes enabled when Start/End is selected. The 
complete contents of the clipboard curves are 
stretched or compressed to fit into the specified 
import Time Range.

Fit Becomes enabled when Start/End is selected. The 
contents of the clipboard are preserved (that is, not 
stretched or compressed) and as much as will fit 
into the specified time range is pasted into the new 
area.

Paste Method

Specify a paste method.

Insert Places the clipboard contents before any existing 
keys in the specified time range. The keys from the 
original curve that were after the specified time 
range are shifted in time by the pasted range times.

Replace Becomes enabled when Start/End or Clipboard is 
selected. The clipboard contents overwrite any 
existing keys in the specified time range.

Merge  The clipboard contents are added to any existing 
keys on the curve. In the case where a clipboard key 
is at the same time as an existing key, the 
clipboard’s key replaces the existing key.

Replace Region

These buttons are enabled when Paste Method is set to Replace.
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Time Range Replace keys and curve segment information in the 
specified time range with the contents of the keys 
clipboard.

Entire Curve Is available only when the Time Range setting is 
Clipboard. The Entire Curve setting replaces the 
animation curve(s) on the imported attributes with 
the contents of the keys clipboard, in effect deleting 
any existing animation curves on these attributes 
and applying the new curves from the keys 
clipboard.

Connect

When turned on, adjusts the keys clipboard curves in value, so there’s 
no discontinuity in the animation at the start of the pasted segment.

File > Export All, Export Selection

Saves all objects or the selected objects to a new scene file.

Related topics

”Supported file formats” on page 215

”Create, open, or save a scene file” on page 219

”Import or reference data in an external file” on page 220

”File > Save Scene” on page 234

”File > Save Scene As” on page 235

Default File Extensions

Defaults to exporting the file with the extension for that file type.

Preserve References

If Preserve Reference is turned on, the references within the exported 
file are preserved. If it is turned off, all references are exported within 
the file; that is, they are no longer references, but are now objects in 
the scene. The default is off.

Maya native file (.ma and .mb) options

For Maya ASCII (.ma) and Maya Binary formats (.mb), the Export All 
options are the same as the File > Save Scene As options 

”File > Save Scene As” on page 235

mental images (.mi) file options

See File > Export All, Export Selection (mental ray) in the Rendering guide.
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Move file options

Attributes   

Type the name of an attribute in the Attributes box and click Add to 
add the attribute to the list of attributes to use when importing or 
exporting. If the attribute is already included in the list, a duplicate is 
not made. To remove an attribute, type the name of the attribute and 
click Remove. You can add several attributes at one time by 
separating them with a space.

From Channel Box

Click From Channel Box to combine all of the selected objects in 
Maya, in the order of their selection, with the channels selected in the 
Channel Box and place them in the list. For example, if sphere and 
cone are selected, and tx, sx are selected in the Channel Box, sphere.tx, 
sphere.sx, cone.tx, and cone.sx are added to the list of attribute to 
import and export.

Remove Selected

Click Remove Selected to remove all of the attributes selected in the 
list.

Remove All

Click Remove All to remove all of the attributes from the list.

Precision

This is ignored in file export. For file import, this sets the precision of 
the file.

When you click import or export, the move file is written or read and 
only the attributes in the list are affected.

Animation curve options

Precision

Sets the precision of the numbers stored in the file. The choices are:

Float – Eight digits of precision

Double – Seventeen digits of precision

Custom – A setting between 1 and 18.

File Contents

Use Node and Leaf Attribute Names – When the Use Node and Leaf 
Attribute checkbox is selected, the node and leaf attribute names in 
the clipboard are written to the file. 
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When the checkbox is not selected, only the full attribute name is 
written to the file.

Verbose Units – When the Verbose Units checkbox is selected, long 
unit names are used in the file, otherwise short unit names are used.

Hierarchy

The Hierarchy setting provides control over which nodes are copied 
within a hierarchy. 

Selected – Only the selected object’s animation copies to the keys 
clipboard.

Below – Copies the animation of the selected object and all objects 
below it to the clipboard.

Channels

This setting is available when you want to copy only attributes 
selected in the Channel Box.

All Keyable – All keyable channels of the selected object’s animation 
are copied to the clipboard.

From Channel Box – Only those channels selected in the Channel Box 
are copied to the clipboard.

Control Points

This option enables or disables the copy action for all the CVs, 
polygon vertices, and lattice points associated with a geometry shape 
(or transform node hierarchically above the geometry shape).

Normally, when a control point is copied, only the selected control 
point is copied. The Control Points option enables the copying for all 
the control points associated with an object. This is useful when you 
are doing control point-intensive animation and don’t want to select 
each control point to copy the animation.

Shapes

This option determines if the animation of a shape attribute of an object as 
well as the animation of the associated transform attribute are copied, or if 
only the transform node’s animation is copied.

Generally, when an object is selected in a modeling window, the 
transform node (above the shape hierarchically) is selected.

For example, if a camera, NURBS object, or light is selected, the associated 
transform node is selected for copying.
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Time Range

All – Copies all the animation information of the selected object or 
objects to the keys clipboard.

Start/End – copies only the animation information in the range 
specified in the Start Time and End Time fields of the selected object 
or objects to the keys clipboard.

Help Images

When checked, this option displays a diagram of the copy action, and in 
particular represents graphically the two methods of copying animation 
information.

Method

Keys – Copies only keys within the selected range to the keys 
clipboard.

Segments – Copies animation curve segments and any keys in the 
selected range to the keys clipboard. 

File > Create Reference

Lets you import data from an external file by reference. The data remains 
in the external file and is loaded on the fly when Maya needs it.

Related topics

”Import or reference data in an external file” on page 220

File > Create Reference > 

Group

Specifies whether the referenced objects are grouped under a single 
transform when you reference the file. Grouping makes it easier to 
work on the nodes of imported objects. The default is off.

Note The Segments method of copying keys creates keys for the 
copied animation segment at the start and end times in order to 
preserve the shape of the animation curve, if keys do not already 
exist at those points.
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Locator

When used with the Group option, groups the contents of the 
referenced file under a locator, annotated with the reference node 
name. The reference node has a message connection to the locator’s 
transform.

Use Namespaces

When you reference a scene with the Use Namespaces option turned 
on, Maya creates a new namespace that contains the imported or 
referenced data. Turning on the Use Namespaces option ensures that 
all nodes are uniquely named.

A namespace is a grouping of objects under a given name. Each item in 
a namespace is identified by its own name along with the namespace 
it belongs to.

By default, the basename of the imported or referenced file is added to 
the beginning of the imported or referenced object names, separated 
by colons. 

For example, if you are importing a scene named foo.ma that contains 
an object named ball, after it’s imported the ball is named foo:ball.

You can change the prefix by selecting Resolve clashing nodes with 
this string and entering a prefix.

You can create, name, parent, and remove namespaces using the 
namespace command. 

Namespaces do not effect selection, the DAG, the Dependency Graph, 
or any other aspect of Maya.

Name clash options

When you reference a scene into another scene, naming conflicts occur 
if the nodes share the same name and parent nodes. 

To resolve these naming conflicts, you can rename only nodes with 
the same name and parents (clashing nodes) or you can rename all 
nodes. You specify whether to use the filename as the prefix (the 
default) or to create a prefix string. 

For more information on node hierarchy, see MEL and Expressions.

Tip We recommend you use namespaces to resolve naming conflicts 
instead of using the Name clash options when importing or 
referencing files.
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File type

Choose from the pull-down menu the file type you are importing. If 
you aren’t sure what type of file you are importing, you can select 
Best Guess. 

For more information on file type options, see File > Import.

File > Reference Editor

Opens the Reference Editor. See ”Reference Editor” on page 253.

Related topics

”Import or reference data in an external file” on page 220

File > Project > New

Starts a new project. A project lets you group together all the different files 
needed for a scene or group of related scenes.

You can choose the paths of directories for each type of file.

Related topics

”Organize files into projects” on page 223

Options

Scenes 

Specifies the directory used to save scene files. This directory 
normally contains only geometry information, unless you instruct 
Maya to put all of the information on the file into this subdirectory. 
You can also use this text box to enter search criteria for scene 
information. 

Project Data Locations

Specifies the directories for files containing project textures, lights, 
source images, images, and render scenes.

Data Transfer Locations 

These locations specify the paths to the directories containing files in 
formats that may require conversion. 
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File > Project > Edit Current

Lets you edit the paths of the current project. A project lets you group 
together all the different files needed for a scene or group of related 
scenes.

Related topics

”Organize files into projects” on page 223

File > Project > Set

Lets you choose a current project to work on. A project lets you group 
together all the different files needed for a scene or group of related 
scenes.

Related topics

”Organize files into projects” on page 223

Edit

Edit > Group

Groups objects together under a new transform node, allowing you to 
select and transform them all at once.

Related topics

”Group objects together” on page 227

Note The location directories can be expanded using plug-ins. Each time 
you add a plug-in, the New Project window displays the addition. 
You can then specify the path to the plug-in’s directory.

Note If you leave a text box blank, Maya does not create a subdirectory. 
If you create a scene using an unspecified project setting, Maya 
saves the information in the project location directory.
Basics 

248



6 | Files and organization

Reference > Edit > Ungroup
Edit > Group > 

Group Under

Group objects under one of the following:

Parent Groups the selected objects under their lowest 
common parent in the hierarchy. For example, 
selecting a single object and grouping puts the 
group node immediately above the selected object in 
the hierarchy. 

Selecting objects that are in different hierarchies 
puts the group under the world since they don’t 
share a common parent.

Selecting objects in different parts of the same 
hierarchy puts the objects under their lowest 
common parent. If you go from each selected object, 
the new group will be placed under the first node 
containing all the selected objects.

World Puts the new group under the world (at the top 
level of the hierarchy).

Group Pivot

Select where you want the pivot point for the group to be.

Center Puts the new group’s pivot point at the center of the 
bounding box of the grouped objects.

Origin Puts the new group’s pivot point at the origin of the 
new group’s coordinate system.

Preserve Position

Turn this option on to modify the selected object’s matrix so that 
Maya preserves the overall world-space position of the object. If 
turned off, the matrix of grouped objects are changed and the object’s 
world-space position changes when grouped.

Edit > Ungroup

Ungroups the objects under a group node.

Related topics

”Group objects together” on page 227
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Edit > Ungroup > 

Ungroup Under

Ungroup objects under one of the following:

Parent Puts all objects under their lowest common parent 
in the hierarchy. If there is none, then it puts the 
objects as the world level.

World Puts all objects at world level (at the top-level of the 
hierarchy).

Preserve Position

When on, Maya preserves the transformation information of the 
group. If off, the ungrouped objects lose their grouped transformation 
attributes, therefore changing their position when ungrouped.

Edit > Level of Detail

Lets you associate multiple versions of some geometry to be replaced 
based on distance in a game engine. This lets you produce a high-quality 
version of a model for up-close and a low-quality version for far-away, 
with multiple versions in between.

Related topics

”Level of Detail group node” on page 271

Adding and editing levels

To add a new level

1 Create a new object to add to the level of detail group.

2 Do one of the following:

• In the Hypergraph, use the middle mouse button to drag the new 
object onto the lodGroup node. 

Notes • Level of Detail doesn’t handle instances; instanced geometry 
will not be displayed consistently if it is added into a Level 
of Detail. Only use uninstanced geometry when creating 
levels of detail.

• Edit > Ungroup should not be used with Level of Detail; the 
LOD threshold information will not be reset properly on 
Undo. Use Edit > LevelOfDetail > Ungroup to properly 
ungroup an lodGroup node.
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• In the Outliner, use the middle mouse button to drag the new 
object onto the group.

The new object is added to the bottom of the lodGroup’s hierarchy.

Previewing more than one object at the same time

You can preview different objects at the same time to compare them.

To view more than one object

1 In the Hypergraph, select the level of detail group node.

The node’s attributes are displayed in the Channel Box. Each Display 
Level has three possible settings: uselod, show, and hide.

2 Use the left mouse button to click on one of the Display Level’s uselod 
text. A drop-down menu with the three options is displayed. 

3 Select one of the options. You can show or hide any combination of 
objects.

Notes about orthographic cameras and level of detail

Level of Detail displays one child of a level of detail group, depending on 
the group’s distance to a camera. For perspective cameras, this means 
measuring the distance between the camera position to the center of the 
bounding box of the group. 

For orthographic cameras, the distance is measured differently. This is 
because zooming, panning, and dollying in an orthographic view does not 
change the camera position, but instead changes the camera’s orthographic 
width. So the distance is measured as:

distance = (default camera distance) * (camera’s orthographic 
width)/(default orthographic width)

Substituting Maya’s default values in this equation results in the 
following:

distance = 3.333 * (camera’s orthographic width)

Tip You can also re-order a group by selecting Edit > Level of Detail 
> Ungroup. Re-order the objects and create a new group.

Tip Reset the Display Levels to uselod to return to the regular level of 
detail behavior.
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Display

Display > Object Display > Template, 
Untemplate

Templated objects appear slightly dimmed. You cannot select or snap to 
templated objects.

Templating is useful to get objects “out of the way” so you don’t 
accidentally select them.

Related topics

”Make an object unselectable (template)” on page 225

Create

Create > Measure Tools > Distance Tool, 
Parameter Tool, Arc Length Tool

Create measurement objects that let you measure and annotate objects in 
the scene. As you move the points of the annotations, the listed 
measurements automatically update.

Related topics

”Measure the distance between two points” on page 230

”Show parameter or arc-length values on a curve or surface” on 
page 231

Create > Locator

Creates a locator object in the scene. A locator is a very simple 3D cross 
that marks a point in space. They are useful as UI for characters: you can 
parent joints to the locator so moving the locator pushes and pulls the 
joint.

Create > Annotation

Creates a text label with an arrow pointing to the selected object.

Deleting annotations does not remove the corresponding locator node 
from the scene. To delete the locator node, do one of the following: 

• After deleting the annotation node, select the locator node and delete 
it.
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• Select the annotation and press the pick walk up hotkey (default is up 
arrow key). The locator node will be selected and deleting it will also 
delete the annotation node. 

• Selecting File > Optimize Scene Size.

Related topics

”Annotate or document objects” on page 230

Create > Sets > Set, Partition

Create sets and partitions. Sets are loose groupings of objects used for 
various purposes in Maya. Partitions are groupings of sets that ensure the 
sets do not share members.

Related topics

”Create and edit sets” on page 228

”Keep a collection of sets from having overlapping membership” on 
page 228

Create > Empty Group

Creates an empty group node in the scene hierarchy.

Related topics

”Transformations” on page 103

”Scene hierarchy” on page 152

”Group objects together” on page 227

Windows and editors

Reference Editor

The Reference Editor allows you to select the loaded or unloaded state of 
all references in your scene with the check box icons or commands, and 
access other reference commands.

File menu

Create Reference

See ”File > Create Reference” on page 245.
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Import Objects from Reference

Imports the selected reference’s objects directly into the current scene.

Export Selection as a Reference

Exports the selected objects as a reference and links that reference into 
the current scene. A file browser opens to save the file with the name 
and location you specify.

Clean Up Reference

Removes unused file references in the scene file.

Edit Menu

Remove Reference

Removes the selected reference.

Select File Contents

Selects all items in the selected reference file.

Reference Menu

Load Reference/Unload Reference

Loads or unloads the selected reference.

Load Related Reference/Unload Related Reference

Loads or unloads references related to all selected objects.

Replace Reference

Opens a file browser to replace the current reference with the one you 
select. The group node and/or locator remains the same.

Recent Files

Lists recently-referenced reference files.

File Particulars

The following file information displays when a referenced file is selected 
in the editor. You can choose to show or hide this information by clicking 
on the disclosure triangle. 

Unresolved Name

Displays a relative or absolute path including name of the referenced 
file, without locations where Maya searches for the file.

Resolved Name

Displays the filename and path where Maya found the file.
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Rename Prefix

Displays a prefix that can be applied to object names in the event of 
name clashes or namespaces.

Using relative paths and environment variables in the 
Reference Editor

You can edit reference paths in the Reference Editor, which allows you to 
specify a reference using relative paths and environment variables. 

Enter an environment variable or relative path in the Unresolved Name 
text box of the Reference Editor, and click Reload to load the reference 
from that location.

If Maya can’t find the referenced file in the specified location, it looks in 
several default locations to find the file.

Preload Reference Editor

The Preload Reference Editor looks very much like the Reference Editor. It 
appears when you open a file when the Selective Preload option is turned 
on in the File > Open > ❒  window. 
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To select which references will be read in (loaded) and which 
deferred (unloaded)

1 Select one or more items in the Preload Reference Editor.

2 Do one of the following:

• Click the checkbox next to each item.

• Right-click an item and select Bring in Reference Loaded or Bring 
in Reference Unloaded from the menu that appears. 

Layer Editor

Lets you organize large-scale pieces of the scene so you can show, hide, or 
edit them all at once.

Related topics

”Organize objects on display layers” on page 226

”Edit all objects on a layer at once” on page 227

Layers menu

Create Layer

Creates a new display layer or render layer, depending on the 
selection in the pull-down menu, with a default name, for example 
layer1.

Note Loading and unloading references works hierarchically; that is, 
switching the top-level load status of a parent to unloaded 
means that all children references are also not loaded. 
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Layer > Create Layer > 

Name Sets the name of the layer you’re creating.

Number Sets the number of the layer you’re creating.

Make the 

created display 

layer current Makes the created display layer current.

Add to new 

display layer You can choose to add Nothing, Selected objects or 
Selected objects and their Children to the layer 
you’re creating.

Delete Selected Layer(s)

Deletes the selected layer(s), but not the objects in the layer.

Edit Selected Layer(s)

Opens the Edit Layer window for the selected layer(s) so you can edit 
layer attributes.

Select Objects in Selected Layer(s)

Selects the objects contained in the selected layer(s). 

Add Selected Objects to Current Layer

Adds the selected objects to the selected layer.

Remove Objects from Selected Layer(s)

Removes all objects from the selected layer(s) and assigns them to the 
default layer. The selected layer(s) becomes empty so you can assign 
other objects. 

Layer Attributes

Opens the Attribute Editor for the selected layer(s). There are some 
attributes in the Attribute Editor not available through the Edit Layer 
window.

Membership

Opens the Relationship Editor for removing or adding objects to 
layers.

Select Unused Layers

Selects all layers in the Layer Editor that do not have objects assigned 
to them. This option is only available from the Layer menu and not 
the right mouse button pop-up menu.

Delete Unused Layers

Delete layers if they have no content.
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Remove Selected Object(s) from Layers

Removes the selected object(s) from the assigned layer(s). This option 
is only available from the Layer menu and not the right-mouse button 
pop-up menu.

Sort Layers Alphabetically

Sorts layers by name. 

Sort Layers Chronologically

Sorts layers by time of creation.

Display layer properties window

Display Layer

Type the name of the layer.

Enable Overrides

Turn this option off to disable the effects of the layer. Objects in the 
layer appear and behave as though they do not belong to the layer.

Display Type

Select how the layer appears.

Normal Objects in the layer display normally, according to 
the settings for the layer. You can select objects in 
the layer and snap to them.

Template  Objects in the layer become templates. You can see 
template objects in the workspace, but you cannot 
select them, nor can you snap them. 

Reference You can snap to objects in the layer, but you cannot 
select them or modify them. 

Level of Detail

Select the level of display detail for layer objects:

Full Displays full detail for layer objects.

Bounding Box  Shows objects as boxes that represent their 
bounding volumes. Bounding boxes speed up Maya 
operations making a significant difference for 
complex models.

Shading

Turn on to make layer objects appear shaded when in shaded display.
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Texturing

Turn on to show textures on layer objects when in shaded display.

Playback

Turn on to animate layer objects during playback. If you have several 
characters in a scene and want to look at each character’s animation 
separately, you can place each character in its own layer and play 
back the animation of each character as desired.

Visible

Turn on to make the objects in the layer visible. 

Color

Select the color of all objects belonging to the layer. 

Number

This is the number assigned to the layer.

Merging display layers when importing files

To facilitate the merging of layers when you read in files, select 
Window > Settings/Preferences > Preferences, click the Files/Projects 
category, and in the Display Layer section select one of the following 
options for File Import Merge:

None All layers read in are put in a new layer, and 
renumbered and renamed, if necessary to preserve 
uniqueness.

By Number All layers read in that have the same index number 
as an existing layer are merged with that layer 
rather than creating a new layer.

By Name All layers read in that have the same name as an 
existing layer are merged with that layer rather than 
creating a new layer.

Relationship Editor

Use the Relationship Editor to edit relationships in Maya, where a 
relationship is a collection or grouping of objects or components. These 
relationships include:

• sets

• deformer sets

• character sets

• partitions
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• display layers

• render layers

• light linking (light-centric and object-centric)

• UV linking (texture-centric, UV-centric, Paint Effects/UV, Hair/UV, 
and Fur/UV)

Related topics

”Organize objects on display layers” on page 226

”Create and edit sets” on page 228

”Keep a collection of sets from having overlapping membership” on 
page 228

Menus

List

Auto Load All Sets

Turn this on to automatically display all relationships of the selected 
type in the scene. This is the default.

Manual Load Sets

Turn this on to display relationships by choosing one of the following 
options:

Load Set from 

Selection Display only the relationships associated with the 
objects selected in the scene.

Add Set from 

Selection Add to the display the relationships associated with 
the objects selected in the scene.

Remove Set 

from Selection  Remove from the display the relationships 
associated with the objects selected in the scene.

To display objects

On the right side panel, select one of the following options from the List 
menu.

Note The Relationship Editor is separate from the Dynamic 
Relationships Editor, which is used to control relationships of 
particle objects.
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Auto Load All

Turn this on to automatically display all objects in the scene.

Auto Load Selection

Turn this on to automatically display objects in the relationships 
associated with the objects selected in the scene.

Manual Load

Turn this on to display objects by choosing one of the following 
options:

Load List from 

Selection Display only the selected objects.

Add Selection 

to List Add to the display the objects selected in the scene.

Remove 

Selection from 

List Remove from the display the objects selected in the 
scene.

Toolbar

Drop down menu

Controls which type of relationship to edit. This is the same as the 
items in the Window > Relationship Editors submenu.

Plus and Minus icons

When you are editing a container-like relationship, such as sets, 
partitions, or characters, the plus and minus icons add or remove the 
current selection from the highlighted container in the editor.

For example, if you are editing sets, you can highlight a set on the left 
side of the editor and click the Plus icon to add the currently selected 
objects to the set.

Panels

• Type text in the text boxes at the top of each panel to only show items 
with that text in their names. Click the icon to the left of the text boxes 
to switch the filter on or off.

• Click a set on the left side, then click items on the right side to 
highlight or unhighlight them. Highlighted items on the right are 
connected to the item on the left.
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Color editor

The color editor appears whenever you click a color swatch. You can also 
open it by choosing Window > Settings/Preferences > Colors.

Related topics

”Change an object’s wireframe color” on page 68

”Change user interface colors” on page 273

Controls

Color wheel and storage tiles

The fastest way to select a color is to drag the selector in the color wheel. 
Once you have the color selected, you can drag the brightness control on 
the left. 

Another quick way to select a color is to left click on one of the storage 
tiles at the top. To store the current color on a tile, right click a tile or click 
the arrow button. 

Storage tiles—to store, 
right-click a tile or click the 
arrow button

Current color

Color wheel

Eyedropper

Sliders (RGB and HSV)

Blend box
Palettes (including 
Adobe palettes)
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Eyedropper 

The eyedropper tool lets you grab a color from anywhere on the computer 
screen, including other applications. Click the eyedropper button, then 
position the eyedropper cursor anywhere on your screen. Click again to 
grab the color.

Using the sliders

For precise color selection, you can use the color sliders. You can switch 
between RGB sliders (Red, Green, Blue) or HSV (Hue, Saturation, Value), 
depending on the color model you want. 

HSV

In this color model, Hue corresponds to the pure colors of the 
rainbow, such as yellow, blue, and green. Saturation is the amount of 
white mixed with the hue to set the intensity of the color. Value is the 
amount of black mixed with the hue to make it darker. If the Value is 
0 (zero), then the color is black, regardless of the values for Hue and 
Saturation.

RGB

This color model describes how red, green, and blue light combines at 
different intensities to produce different colors. Using RGB, you can 
choose which value range you want.

0 to 1  Each component color has a value from 0 to 1.

0 to 255  Each component color has a value from 0 (zero 
intensity) to 255 (full intensity). This model is useful 
because it relates directly to how monitors emit light 
to create colors. However, it is often hard for people 
to figure out what the RGB values are for a specific 
color.

A (alpha) slider

With the A (alpha) slider, you can control the opacity or transparency 
of the color you choose. Many Maya options already have an alpha or 
transparency control, but if it does not or you are calling the Color 
Chooser from the command line, you can use this slider to control the 
alpha channel.

”Organize objects on display layers” on page 226

Blend box

The Blend box creates a blend between colors so that you can select a new 
color from the blended gradient. The following illustration explains how 
to use it. 
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Palette

In the Palette section, you can create and save custom color palettes. You 
can also open Adobe color palettes (file extension .aco), if it is in one of the 
following formats: RGB, HSV, CMYK, Lab, or Inverted Lab. (Other 
formats, such as Pantone, are not supported.)

The following illustration highlights the palette components.

To create a custom palette

1 Select a color using any of the Color Chooser tools, such as the Wheel.

2 Right click on any tile to store the current color there.

3 To create a blended gradient, select several tiles by dragging the 
mouse, then click Blend. 

A color gradient is created between the first and last tiles in your 
selection. For example, as shown below, you may want more color 
gradations than in the default palette.

4 When finished assigning colors, click Save and specify the filename.

You can save the file in any directory. It is saved in ascii format.

1. To set a blend color, 
click a corner. It’s 
replaced with the 
current color in memory.

2. Click anywhere in 
the blend box to select 
a blended color.

Choose a palette 
from the pull-down

Click Blend to 
create a color 
gradient between a 
group of cells you 
selected

Left click a cell to 
select a color
...or...
right click a cell to 
store a color

Open, Save, and 
Close palettes

Blended tiles
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Visor

Window > General Editors > Visor

The Visor displays textures, images, and shading nodes in the project 
directory.

Visor tabs contain a collection of items in the scene, or directories and files 
on disk. You can customize the way you view files, and create and 
customize tabs.

You can also drag items with the middle mouse button from Visor into 
Hypershade to create a new node, or onto a swatch in Hypershade to 
connect nodes.

To view an image

Double-click an image file in the images directory to view the image in 
fcheck.

To create a new tab

1 Select Tabs > Create New Tab.

2 Enter a new tab name.

3 Select a Tab Type and specify the corresponding options.

4 Click Create.

Scene

Displays a collection of nodes in the current scene.
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Disk

Displays files on disk, such as a texture library.

Paint Effects

Displays Paint Effects files, such as brush settings.

Show Nodes Which Are

For Scene tabs, select to display only certain nodes types within a 
specified tab. 

Root Directory

For Disk and Paint Effects tabs, either type the path name if you know 
it, or click the folder icon to browse through directories to select the 
directory where the items are stored.

Only Show Files (Hide Directory Tree)

For Disk and Paint Effects tabs, turn this on or off to hide or show the 
directory tree. This is especially helpful if you find you routinely work 
with files located in one specific directory. You can switch between 
viewing directory folders or just the files within that directory.

Menus

File menu

Import

Opens the Import dialog box so you can select a Maya scene file (such 
as a file containing a shader) to import into Maya.

Import Selected Scene Files

Reads information from another file and loads it into the current file.

Import Selected Image Files

Select an item from the pull-out menu to choose how to import image 
files. Include Placement is on by default.

As Normal For normal textures, Maya applies a texture map 
according to the geometry characteristics—textures 
are placed onto polygons based on UV information 
or placed onto NURBS surfaces based on 
parametrized information.

As Projection To create projection textures, Maya applies a texture 
map to the surface of a 3D object by projecting a 2D 
texture into 3D space—in other words, Maya 
projects the texture maps independently of the 
geometry characteristics. 
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As Stencil Lets you place an image file or texture on a surface 
and manipulate its placement and size to look like a 
label. You can use masking techniques to hide 
unwanted parts of the image.

Include 

Placement When on, Maya automatically creates a texture 
placement node when you create a texture render 
node. The default setting is on.

Export Selected Network

Exports the selected item into a new file. The file browser opens to its 
best guess directory, but can browse to any directory, or cancel, before 
exporting.

View menu

Frame Selected

Frames only the selected nodes in the current Visor layout.

Frame All

Frames all the nodes displayed in the current Visor layout.

Tabs menu

Each tab contains the nodes that make up the current scene. These options 
let you create new tabs and customize the default tabs.

Create New Tab

You can create and name tabs to help you organize a scene’s 
rendering elements. 

Move Tab Left/Right

Select a tab then select one of these options to re-arrange the tabs.

Rename Tab

Select a tab then select this option to rename it.

Remove Tab

Select a tab then select this option to remove it.

Tip For textures created with As Projection turned on, you need to 
explicitly connect the texture to the bump so the texture is visible 
in the bump map.
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Revert to Default Tabs

Removes new tabs and reverts to the default organization.

Current Tab Options

Select a tab, then select one of these options to control the display: 
Show Directories Only, Show Files Only, Show Both, Refresh File 
Listing.

Nodes

General attributes

General attributes

• the name of the node (for example, nurbsSphere1 or lambert1)

• Input Connection button 

Click the Input Connection button to display the first input connection 
node for the currently displayed node. Right-click the Input 
Connection button to display a list of all input connection nodes. You 
can then choose a node from this list to display in the Attribute Editor.

• Output Connection button 

Click the Output Connection button to display the first output 
connection node for the currently displayed node. Right-click the 
Output Connection button to display a list of all output connection 
nodes. You can then choose a node from this list to display in the 
Attribute Editor.

• Focus button — Click this button to set the Attribute Editor focus to 
this node.

• a sample image or icon that represents the node (where appropriate)

• Select button — Click this button to select the node that is currently 
displayed in the Attribute Editor.

• Load Attributes button — Click this button to manually load the 
attributes of the selected object or node.

• Copy Tab button — Click this button to create a new window 
containing the selected tab.

Transform attributes

Translate

Specifies the object’s translation (Translate X, Y, and Z) attribute 
values in world space.
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Rotate

Specifies the rotation (Rotate X, Y, and Z attribute values) of the object   
in world space.

Scale

Specifies the objects’s scale (Scale X, Y, and Z) attribute values in 
world space.

Rotate Order

Specifies the object’s rotation order. You can set the rotate order when 
you want a specific final rotation for an object, because each rotate 
order option produces a different end orientation. For example, if the 
rotation order for an object is set to xyz, the object first rotates about 
its X-axis, then its Y-axis, and finally its Z-axis. Default is xyz.

Rotate Axis

Offsets the orientation of the object relative to the orientation of the 
object’s local rotation axis.

Inherits Transform

When this attribute is on, the current object inherits the 
transformations (Translate, Rotate, Scale, and Shear values) of its 
parent object.

Display

Sets the overall display settings for the current object.

Display Handle

When this attribute is on, the display handle for the current object is 
displayed.

Display Local Axis

When this attribute is on, the local axis of the current object is 
displayed.

Selection Handle (xyz)

Lets you offset the selection handle in the X, Y, and Z axes from the 
object relative to the handle’s current position.

Show Manip Default

Sets the current object’s default manipulator shape. 

For more information, search the online help for the Manipulator 
Tool.
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Manip History Node

Sets the specified shape as the default manipular, instead of using one 
of the defaults.

Visibility

When this attribute is on, the current object is visible in the scene 
view. When this attribute is off, the current object is hidden in the 
scene view.

Template

When this attribute is on, the current object is appears a template. See 
”Display > Object Display > Template, Untemplate” on page 252 and 
”Make an object unselectable (template)” on page 225.

LOD Visibility

If the current object is connected to a lodGroup node, then this check 
box displays the Hide/Show status of the object’s display level. Also, 
this attribute is read-only.

If the current object is not connected to a lodGroup node, this attribute 
turns off the objects visibility in the scene view.

Node behavior

To change node behavior, select the node and expand the Node Behavior 
section of the Attribute Editor. 

Caching

Turn Caching on to temporarily store input node evaluations in the cache. 
When Maya needs these evaluations (as input to the node), it uses the 
information stored in the cache rather than re-evaluating the input node. 
If no changes have been made to the node, it redraws more quickly. The 
cache is destroyed when you edit an attribute. Note that caching uses 
more memory, which could affect Maya’s performance.

Node State

Changing the node state can improve performance. There are six possible 
node states: 

Normal  Causes the node to behave normally, according to 
the defined settings and effects. This is the default.
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HasNoEffect  Disables any effects on the node so that fewer 
calculations are necessary at the time of redraw. The 
effect does not render until you reset the Node State 
back to Normal. Maya evaluates the nodes in the 
node’s history, but not the node itself.

For example, if you translate a cluster to deform a 
geometry, then set the Node State of the cluster 
node to HasNoEffect, the geometry appears 
undeformed, as though the translation had not 
occurred. To view the effect, change the Node State 
back to Normal.

Blocking  Temporarily hides the node and does not display 
the results of any input (input evaluations) to the 
node. This can speed the redraw. It is also useful 
when you have complex scenes and want to edit 
only one aspect of a node. Blocked nodes do not 
render. 

For example, if you have a complex revolved 
surface and want to edit the curve, but don’t want to 
wait while the curve redraws, select Blocking and 
edit the curve. To display the modified revolved 
surface, reset the Node State to Normal. 

Notes

• The “HasNoEffect” state has a different meaning for each node type. 
Some node types do not implement the state, in which case the state 
acts just like “Normal”.

• The “Waiting” node states are used internally by Maya to keep track 
of nodes that are waiting for a view update in the Hypergraph. You 
should not normally set nodes to a “Waiting” state.

Level of Detail group node

In the Level of Detail (LOD) group’s Attribute Editor, you can modify the 
following LOD Attributes:

Min Max 

Distance If the minMaxDistance is turned off (default) there is 
no change in behavior. If it is turned on, the 
minDistance and maxDistance attributes define the 
visibility range for the object.

Min Distance The minimum distance at which the group is 
displayed.
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Max Distance The maximum distance at which the group is 
displayed.

Changing the Threshold distances

You can change the distances at which the levels are switched using the 
Channel Box.

To change a Threshold distance

1 Select the level of detail group node in the Hypergraph.

Its level of detail attributes are displayed in the Channel Box. 

2 Edit the Threshold value for the object whose distance you want to 
change, and press Enter (Linux, IRIX and Windows) or Return (Mac 
OS X).

Re-ordering the levels

You can re-order the levels after you create a level of detail group. 

To re-order the levels in the Outliner

In the Outliner, use the middle mouse button to drag the object you want 
to move into its new position within the group. This is the easiest way to 
re-order the levels.

To re-order the levels in the Hypergraph

1 In the Hypergraph, use the middle mouse button to remove the object 
you want to re-order from the group.

The other objects in the group move up the group hierarchy.

2 Use the middle mouse button to drag the removed object onto the 
lodGroup node. The object is added to the bottom of the lodGroup’s 
hierarchy.

Tip You can also re-order a group by selecting Edit > Level of Detail > 
Ungroup. Re-order the objects and create a new group.
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customization
How do I? Customize Maya

Customize the look and feel of the interface

Show or hide user interface elements

Related topics

”Main window” on page 18

”Display > UI Elements” on page 41

Change user interface colors

To open the color editor

1 Choose Window > Settings/Preferences > Colors.

2 The three tabs control different color uses and work slightly 
differently:

• The General tab lets you change user interface and view panel 
colors, including the view background color.

• The Active and Inactive tabs let you change the colors of selected 
and unselected objects and components.

To change a color on the General tab

• Click the arrow next to a section heading to show the colors inside.

• Double-click a color swatch to edit it or drag the slider next to a color 
to change its brightness.

To... Do this

Show or hide a specific 
part of the user interface

Open the Display > UI Elements submenu 
and choose an item.

Hide all user interface 
and only show the view/
editor panels.

Choose Display > UI Elements > Hide UI 
elements.
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To change a color on the Active or Inactive tabs

In the Active and Inactive tabs, you cannot edit the colors directly. 
Instead, you set up a palette of available colors (at the top of the tab) and 
then choose each active or inactive color from that palette.

• Double-click a color swatch at the top of the tab to edit the palette of 
available colors.

• Click the arrow next to a section heading to show the colors inside.

• Drag the slider next to a color to change which color Maya uses from 
the palette.

Related topics

”Change an object’s wireframe color” on page 68

”Window > Settings/Preferences > Colors” on page 298

Create a custom panel layout

To create a new custom panel layout

1 Set up the layout, panel sizes, and panel contents you want.

2 In a panel, choose Panels > Panel editor.

3 Click the Layouts tab.

4 Click New Layout.

5 Type a descriptive name for the layout in the Name text box.

To assign a custom layout to one of the icons in the Quick 
Layout bar below the toolbox

1 Create custom panel layout.

2 In the Quick Layout bar, press the right mouse button on the 
thumbnail you want to assign the new layout to, and choose the 
layout from the menu.

3 To change the thumbnail image, press the right mouse button on the 
thumbnail again and choose Change Image. You can choose a pre-
made image or load an icon image from a file.

To delete a saved layout

1 In a panel, choose Panels > Panel editor.

2 Click the Layouts tab.

3 Click the layout name, then click Delete.
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Related topics

”Change the panel layout” on page 60

”Add a new panel to the list of available panels” on page 275

”Quick layout buttons” on page 69

”Panel editor” on page 93

Add a new panel to the list of available panels

You can add a new item to the list of available panel contents. This lets 
you have more than one instance of a particular type of panel.

For example, you might create a character with so many parts that you 
can’t view the entire skeleton in the Outliner. In this case, you could create 
a second Outliner panel so you could view different parts of the hierarchy 
at the same time.

Not all panels can be duplicated. For example, only one Hypergraph 
panel is allowed. 

To create a new panel

1 In a panel choose Panels > Panel Editor and click the New Panel tab.

2 Click the name of a panel (such as the Outliner), then click Make New 
Panel.

3 In a panel, choose the new item from the Panels > Panel menu.

To delete a panel you created

Once you have deleted a panel, you cannot restore it.

1 In a panel choose Panels > Panel Editor and click the Panels tab.

2 Click the panel you want to delete, then click Delete.

Change the length (scale) of normals in the 
display

Occasionally you may want to change the length of normals (lines 
indicating the normal direction of a face or vertex) to make them more 
visible or less distracting. You can change the scale of normals on a per-
object basis.
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Customize shelves

Create, rename, rearrange, or delete a shelf

To open the shelf editor

1 Choose Window > Settings/Preferences > Shelves.

2 Click the Shelves tab.

To add a new shelf

1 Open the shelf editor.

2 Click New Shelf.

3 Type a name for the shelf in the text box.

To rename, rearrange, or delete a shelf

1 Open the shelf editor.

2 In the list box, click the shelf you want to edit.

3 Do any of the following:

• To rename the shelf, type a new name in the text box.

• To change the shelf’s position on the shelf bar, click Move Up or 
Move Down.

• To delete the shelf, click Delete Shelf.

To... Do this

Change the size of normals 
on polygonal surfaces.

• Show the Attribute Editor for the 
surface.

• Open the Mesh Component Display 
section.

• Turn on Display Normal and set the 
Normal Size.

Change the size of normals 
on subdivision surfaces.

• Show the Attribute Editor for the 
surface.

• Open the Subdiv Surface Display 
section.

• Set the Normals Scale.
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Related topics

”Add a tool, action, or MEL script to a shelf” on page 277

”Edit the contents of a shelf” on page 278

”Change the display of shelves” on page 279

”Window > Settings/Preferences > Shelves” on page 300

Add a tool, action, or MEL script to a shelf

To add a tool to a shelf

1 Choose the tool.

2 Drag the tool icon with the middle mouse button from the tool box 
onto the shelf.

You can add multiple versions of the same tool with different settings to a 
shelf. For example, you can add a Sculpt Surfaces Tool with the Push 
option selected and another Sculpt Surfaces Tool with the Pull operation 
selected. This only works with tools, not regular menu items (actions).

To add a menu item (action) to a shelf

1 Click the shelf you want to add the menu item to.

2 Open the menu with the menu item you want to add.

3 Do one of the following:

• (Windows and Mac OS X) Hold Ctrl + Shift and click the menu 
item.

• (IRIX) Hold Ctrl + Shift + Alt and click the menu item.

• (Linux) Hold Shift + Alt and click the menu item.

To add a MEL command or script to a shelf

1 In the Script Editor (Window > General Editors > Script Editor), select 
the MEL commands you want to add to the shelf.

2 Drag the selection with the middle mouse button from the editor onto 
the shelf.

To add a panel layout to a shelf

1 Click the shelf you want to add the layout to.

2 In a panel, choose Panels > Panel editor.

3 Click the Layouts tab.

4 Click the layout name, then click Add to Shelf.
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Related topics

”Create, rename, rearrange, or delete a shelf” on page 276

”Edit the MEL script associated with a shelf item” on page 278

Edit the MEL script associated with a shelf 
item

1 Click the shelf tab containing the item.

2 Choose Window > Settings/Preferences > Shelves.

3 On the Shelf Contents tab, click the name of the item.

4 Click the Edit Commands tab.

5 Edit the commands in the text box and press Enter.

Related topics

”Add a tool, action, or MEL script to a shelf” on page 277

”Window > Settings/Preferences > Shelves” on page 300

Edit the contents of a shelf

Related topics

”Create, rename, rearrange, or delete a shelf” on page 276

”Add a tool, action, or MEL script to a shelf” on page 277

”Use a custom name or icon for a shelf item” on page 279

To... Do this

Remove an icon from a 
shelf.

Drag the icon with the middle mouse button 
onto the trash icon in the upper right corner 
of the shelf bar.

Rearrange icons on a 
shelf.

Drag the icon with the middle mouse button 
to a different position on the shelf.

Move an icon to another 
shelf.

Drag the icon with the middle mouse button 
onto the shelf tab you want to move the icon 
to.

Copy an icon to another 
shelf.

Hold Ctrl and drag the icon with the middle 
mouse button onto the shelf tab you want to 
copy the icon to.
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”Change the display of shelves” on page 279

”Window > Settings/Preferences > Shelves” on page 300

Use a custom name or icon for a shelf item

To select an item in the shelf editor

1 Click the shelf tab containing the item.

2 Choose Window > Settings/Preferences > Shelves.

3 On the Shelf Contents tab, click the name of the item.

To use a custom icon for a shelf item

1 Select the item in the shelf editor.

2 Click Change Image.

3 Use the file open dialog box to choose a 32 by 32 pixel image.

The image must be in XPM, BMP (Windows only), or IFF format.

To change the name of a shelf item as it appears in lists and 
tooltips

1 Select the item in the shelf editor.

2 Type the new name in the Label & Tooltips text box and press Enter.

To overlay a short text label on an icon

1 Select the item in the shelf editor.

2 Type up to four characters in the Icon Name text box and press Enter.

The characters are overlayed on the icon.

Related topics

”Change the display of shelves” on page 279

Change the display of shelves

To... Do this

Hide the shelf tabs to 
save space.

Press the left mouse button on the black 
triangle to the left of the shelf area. In the 
pop-up menu, turn off Shelf Tabs.
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Related topics

”Use a custom name or icon for a shelf item” on page 279

Customize marking menus and the hotbox

Create or edit a marking menu

Making a new marking menu is a two step process: first you create the 
marking menu. Then to actually use the marking menu you assign it to a 
hotkey or to a region of the hotbox.

You can add multiple versions of the same tool with different settings to a 
marking menu. For example, you can add a Sculpt Surfaces Tool with the 
Push option selected and another Sculpt Surfaces Tool with the Pull 
operation selected. This only works with tools, not regular menu items 
(actions).

Switch shelves when the 
shelf tabs are hidden.

Press the left mouse button on the small tab 
icon to the left of the shelf area. In the pop-
up menu, choose the shelf to display.

To... Do this

Open the Marking 
Menus dialog box.

Choose Window > Settings/Preferences > Marking 
Menus.

Start a new 
marking menu.

In the Marking Menus dialog box, click Create 
Marking Menu.

Edit an existing 
marking menu.

In the Marking Menus dialog box, click the name of 
the marking menu you want to edit, then click Edit 
Marking Menu.

Add an item to a 
marking menu.

1 Start a new marking menu or edit an existing 
one.

2 Use the middle mouse button to drag items 
onto spaces in the marking menu editor. You 
can do any of the following:

• Drag a tool from the tool box.

• Drag a shelf item from the shelf.

• Drag selected text from the Script Editor.

To... Do this
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Related topics

”Assign a marking menu to a hotkey” on page 281

”Add a marking menu to the hotbox” on page 282

Assign a marking menu to a hotkey

Marking menus appear when you hold a hotkey and press the left mouse 
button. You can set a hotkey to show one of the pre-made marking menus 
that come with Maya, or a custom marking menu you have created.

To assign a marking menu to a hotkey

1 Choose Window > Settings/Preferences > Marking Menus.

2 Click the marking menu in the list.

3 Set the Use Marking Menu In option to Hotkey Editor.

4 Click Apply Settings.

5 Choose Window > Settings/Preferences > Hotkeys.

6 In the Categories list on the left, click User Marking Menus.

Change the label 
or MEL script of an 
item.

Press the right mouse button on an item and choose 
Edit Menu Item.

Make an item open 
a submenu.

Press the right mouse button on a space in the 
marking menu editor and choose Popup Submenu.

When you’re finished editing the submenu, close 
the submenu’s window.

Delete an item. Press the right mouse button on an item and choose 
Delete Menu Item.

Save your changes 
to a marking 
menu.

Click Save and close the marking menu editor 
window.

Set when the 
marking menu 
appears.

• ”Assign a marking menu to a hotkey” on 
page 281

• ”Add a marking menu to the hotbox” on 
page 282

To... Do this
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7 For each marking menu you’ve created, the list has two items in the 
Commands list: “menu_Press” and “menu_Release”. Click the “press” 
command.

8 Type a key name in the Key text box and turn on any modifiers you 
want on the hotkey.

For example, type m in the text box and turn on the Alt setting to 
assign the marking menu to alt + m.

As you edit these settings, Maya shows the command currently 
assigned to the hotkey, if any. Only assign the hotkey if you don’t 
mind overriding this command.

9 Set the Direction option to Press.

10 Click Assign.

If the hotkey you set already has a command assigned, Maya asks if 
you want to override it.

11 Maya warns you that it should assign the release command also. Click 
OK to do this.

Related topics

”Create or edit a marking menu” on page 280

”Add a marking menu to the hotbox” on page 282

Add a marking menu to the hotbox

Marking menus appear in the hotbox when you point above (north), 
below (south), left (west), or right (east) of the hotbox menus and press a 
mouse button.

You can set each mouse button press (left, middle, or right) in each 
different area (north, south, east, or west) to show one of the pre-made 
marking menus that come with Maya, or a custom marking menu you 
have created.

To assign a marking menu to a hotbox area and mouse 
button

1 Choose Window > Settings/Preferences > Marking Menus.

2 Click the marking menu in the list.

3 Set the Use Marking Menu In option to Hotbox.

4 Set the Hotbox Region option to the part of the hotbox (North, West, 
Center, East, or South) where the marking menu appears.

5 Set the Mouse Button(s) option to the mouse buttons (Left, Middle, 
and/or Right) you must hold for the marking menu to appear.
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For example, if you set the region to South and turn on Middle and 
Right, the marking menu appears when you show the hotbox (hold 
the space bar), move the mouse pointer below the menus, and press 
the middle and right mouse buttons.

6 Click Apply Settings.

Related topics

”Create or edit a marking menu” on page 280

Customize the hotbox

To change what functions are available in the hotbox

1 Hold the space bar to show the hotbox.

2 Press the left mouse button in the Hotbox Controls area to show the 
marking menu.

3 Drag down to the Hotbox Style sub-menu.

4 Choose one of the following options:

• Zones and menu rows: show all menus, as well as the “zones” 
containing marking menus above, below, left, and right of the 
hotbox.

• Zones only: don’t show all menus.

• Center zone only: only show the center marking menu. This 
makes the hotbox equivalent to a hotkey marking menu.

To c7hange what extra menus are available in the hotbox

1 Hold the space bar to show the hotbox.

2 Press the left mouse button in the Hotbox Controls area to show the 
marking menu.

3 Drag left, right, up, or down to show sub-menus allowing you to 
either not show a menu set or only show that menu set.

To change the way you access the extra menus

You can set up Maya to hide the extra menu sets at the bottom of the 
hotbox, and show them as pop-up menus by pressing the right mouse 
button in the center of the hotbox.

1 Hold the space bar to show the hotbox.

2 Press the left mouse button in the Hotbox Controls area to show the 
marking menu.

3 Drag down to the Hotbox style submenu.
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4 In the submenu, turn on the Center zone RMB pop-ups option.

Related topics

”Add a marking menu to the hotbox” on page 282

”Hotbox Controls > Hotbox Style” on page 302

Customize hotkeys

Assign a predefined command to a hotkey

Maya includes a number of pre-made commands that correspond to the 
actions you can accomplish with the user interface (for example, opening 
editors or creating objects). These commands are organized into 
categories.

To assign a command to a hotkey

1 Choose Window > Settings/Preferences > Hotkeys.

2 Click a category name in the Categories list to show a sublist of 
commands, then click the command you want to assign a hotkey to.

To find a command in the categories, click Search (near the bottom of 
the hotkey editor window) and type some text to find. Use * to match 
anything. To find all commands that start with Delete, type delete*. 
To find all commands with the word “light”, type *light*.

3 Type a key name in the Key text box and turn on any modifiers you 
want on the hotkey.

For example, type m in the text box and turn on the Alt setting to 
assign the marking menu to alt + m.

As you edit these settings, Maya shows the command currently 
assigned to the hotkey, if any. Only assign the hotkey if you don’t 
mind overriding this command.

4 Set the Direction option. If you choose Press, Maya runs the command 
when you press the key down. If you choose Release, Maya runs the 
command when you let the key up.

The distinction between Press and Release can be important, for 
example when you assign a hotkey to a snapping mode. You want to 
assign the command to turns the snapping mode on to the key press, 
and the command that turns the snapping mode off to the key release.

5 Click Assign.

If the hotkey you set already has a command assigned, Maya asks if 
you want to override it.
Basics 

284



7 | Preferences and customization

How do I? > Assign a MEL script to a hotkey
Related topics

”Assign a marking menu to a hotkey” on page 281

”Assign a MEL script to a hotkey” on page 285

”View a list of all assigned hotkeys” on page 286

”Hotkey editor” on page 329

Assign a MEL script to a hotkey

To associate a MEL script with a hotkey, you must first add the script to 
the list of available hotkey commands, then assign a hotkey to the 
command you created.

1 Choose Window > Settings/Preferences > Hotkeys.

2 Commands are grouped into categories. Click the category name in 
the Categories list you want to put your script in.

3 In the command area at the bottom of the hotkey editor, click New.

4 Type a Name and Description for the new command.

5 In the Command text box, type the MEL commands you want the 
hotkey to run.

6 Click Accept.

7 Type a key name in the Key text box and turn on any modifiers you 
want on the hotkey.

For example, type m in the text box and turn on the Alt setting to 
assign the marking menu to alt + m.

As you edit these settings, Maya shows the command currently 
assigned to the hotkey, if any. Only assign the hotkey if you don’t 
mind overriding this command.

8 Set the Direction option. If you choose Press, Maya runs the command 
when you press the key down. If you choose Release, Maya runs the 
command when you let the key up.

The distinction between Press and Release can be important, for 
example when you assign a hotkey to a snapping mode. You want to 
assign the command to turns the snapping mode on to the key press, 
and the command that turns the snapping mode off to the key release.

9 Click Assign.

If the hotkey you set already has a command assigned, Maya asks if 
you want to override it.

Related topics

”Assign a marking menu to a hotkey” on page 281
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”Assign a predefined command to a hotkey” on page 284

”View a list of all assigned hotkeys” on page 286

”Hotkey editor” on page 329

View a list of all assigned hotkeys

1 Choose Window > Settings/Preferences > Hotkeys.

2 Click List All.

Related topics

”Assign a marking menu to a hotkey” on page 281

”Assign a MEL script to a hotkey” on page 285

”Hotkey editor” on page 329

Customize how Maya works

Load or unload plug-ins

A plug-in is an add-on module that extends Maya’s capabilities. File 
translators are plug-ins you use to import and export various file formats. 
You can create or purchase specialty plug-ins to customize Maya for a 
specific job. 

Some features that can be added through plug-ins are:

• File translators for new file formats.

• New tools, menu items, and MEL commands.

• New object types (nodes).

• Drivers for new devices.

To load or unload plug-ins

1 Choose Window > Settings/Preferences > Plug-In Manager.

2 Do any of the following:

• Check the “loaded” box next to a plug-in to load the plug-in.

• Check the “auto load” box next to a plug-in to always load the 
plug-in when Maya starts up.

• Click the “i” icon next to a plug-in to show additional information 
about the plug-in, for example the version number and any MEL 
commands it adds to Maya.
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To force Maya to unload a plug-in being used in the current 
scene

If you try to unload a plug-in that is providing functionality in the current 
scene (for example, the scene contains a node type that is provided by the 
plug-in), Maya warns you and gives you the opportunity to force the 
removal of the plug-in.

If you choose to force Maya to unload the plug-in, Maya converts any 
nodes in the scene provided by the plug-in to the “Unknown” node type. 
Even if you reload the plug-in, the nodes remain Unknown.

Related topics

”Supported file formats” on page 215

”Plug-in Manager” on page 331

Improve performance, quality, or interactivity

Use the settings in Window > Settings/Preferences > Performance 
Settings to choose trade-offs between quality and performance.

Related topics

”Window > Settings/Preferences > Performance Settings” on page 298

Switch between Y-up and Z-up

1 Choose Window > Settings/Preferences > Preferences.

2 Under World Coordinate System, click Y or Z.

Related topics

”3D coordinates” on page 37

Note You cannot load a plug-in for any version of Maya that predates 
the Maya version the plug-in was compiled for. For example, 
you cannot use a plug-in compiled with the Maya 5 API in Maya 
4.

Check the “For API Version” number in the plug-in’s 
information window.
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Customize the Maya Help

Customize the Maya Help

You can customize the look and feel of the Maya Help by modifying 
settings on the Maya Help Preferences page.

To switch between dual pane and single pane search results

1 In the Maya Help navigation (left-hand) frame, expand Developer 
Resources and click Customize the Maya Help.

2 In Search - Results View, click the Tabs or Dual Pane radio button.

3 Click Save Settings.

To change the number of hits per page displayed in the 
search

1 In the Maya Help navigation (left-hand) frame, expand Developer 
Resources and click Customize the Maya Help.

2 In Searching - Default Hits per Page, change the value using the drop-
down menu.

3 Click Save Settings.

To switch which navigation folder to auto-expand

1 In the Maya Help navigation (left-hand) frame, expand Developer 
Resources and click Customize the Maya Help.

2 In Navigation - Folder to auto-expand, choose which folder you want 
to expand when you load the Help for the first time or click Home.

3 Click Save Settings.

To show or hide Quick Links (developer links) on the home 
page

1 In the Maya Help navigation (left-hand) frame, expand Developer 
Resources and click Customize the Maya Help.

2 In Homepage - Show quick links, click the on or off radio button

3 Click Save Settings.

Note You must load the preference page from the Help Server (not by 
clicking on preferences.html in the help directory), and have 
cookies enabled in your browser to save settings. Settings only 
apply to the specific browser they are saved in; otherwise, you’ll 
see the default view of the Maya Help.
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Customize the Maya Web browser

Customize the Maya Web browser

You can customize the Maya Web browser to handle files of various types 
(including Flash, Shockwave, etc.), by adding the appropriate Mozilla 
plug-in to the following directory:

<Maya directory>/bin/plugins

On Mac OS X, there are standard places where all the internet plug-ins go:

• /Library/Internet Plug-Ins/ (these plug-ins are accessible by all 
users on this system

• ~/Library/Internet Plug-Ins/ (these plug-ins are accessible by 
current user only)

In some cases, you’ll be able to drop a Mozilla-compatible plug-in directly 
into that directory. Some installers will create the plug-in in a different 
directory, such as the one for the Netscape or Mozilla Web browsers. 
You’ll have to copy that plug-in from the plug-in directory of Mozilla or 
Netscape to the directory listed above, and then restart Maya to get the 
plug-in functionality in the Maya Web browser.

Advanced customization

Directly modify the settings files

Maya stores preferences files in the following path:

• Windows: <drive>:\Documents and Settings\<username>\My 
Documents\maya\<version>\prefs

• Mac OS X: ~/Library/Preferences/Alias/maya/<version>/prefs

• IRIX/Linux: ~/maya/<version>/prefs.

Most preferences are saved as text files of MEL commands.

Shelves are stored in the shelves subdirectory, icons are stored in the icons 
subdirectory, and marking menus are stored in the markingMenus 
subdirectory.

When you customize Maya, your new settings are stored in user 
preference files, so that each time you open Maya, your settings are used 
instead of the Maya default settings. If you delete a preference file, Maya 
uses the default settings.
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Color and hotkey files

The following .mel files store settings you have customized using the 
Colors window and Hotkey Editor.

• userColors.mel – Contains preferences defined on the Active and 
Inactive tabs of the Colors window.

• userRGBColors.mel – Contains preferences defined on the General tab 
of the Colors window.

• paletteColors.mel – Defines the colors (RGB) making up the index 
palette in the Active and Inactive tabs of the Colors window.

• userHotkeys.mel – Contains any hotkeys you have assigned in the 
Hotkey Editor window.

• userNamedCommands.mel – Contains all the commands that have 
hotkeys assigned to them.

Default hotbox marking menus

The following files define the default Hotbox marking menus. 

• menu_ChangePanelLayout.mel – North

• menu_ChangePanelType.mel – South

• menu_ChangeSelectionMask.mel – West

• menu_CommonModelingPanes.mel – Center

• menu_ControlPaneVisibility.mel – East

User preferences

The following files define user preferences. 

• userPrefs.mel – Contains preferences defined in the Preferences 
window (Window > Settings/Preferences > Preferences).

• windowPrefs.mel – Defines the default size and position of Maya 
windows.

Note Maya does not detect if you are out of space if your disk 
overflows while Maya is saving preferences. If this occurs, your 
preferences may become corrupt or irretrievable. Ensure that 
your hard drive has space available to save your Maya 
preference files. If the disk runs out of space, free up some space 
before exiting the Maya application.
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Run MEL commands whenever Maya starts 
up

Maya runs any commands in the userSetup.mel file whenever it starts 
up. You can use this file to set up your working environment or execute 
commonly used MEL commands like aliasing.

The scene is created after userSetup.mel runs, so you cannot use 
userSetup.mel to create objects.

To run a certain set of MEL commands every time Maya 
starts up

1 Create a file named userSetup.mel in the following folder:

• Windows: <drive>:\Documents and Settings\<username>\My 
Documents\maya\<Version>\scripts

• Mac: ~/Library/Preferences/Alias/maya/<version>/
scripts.

• IRIX/Linux: ~/maya/<version>/scripts.

(where ~ is your home folder)

2 In the userSetup.mel file, type the commands you want to Maya to 
run on start up.

Run MEL commands whenever a scene is 
opened or closed

A script node lets you attach a MEL script to a scene, and have the script 
run whenever the scene is opened (loaded from disk) or closed (when the 
user opens another scene file or starts a new scene).

Refer to the MEL and expressions guide for information on script nodes.

For more information, search the online help for Script Nodes

Create a custom heads-up display readout

Use the headsUpDisplay MEL command to create or edit a custom 
readout in the heads-up display.

The following explains the basics of using the command. Read the 
headsUpDisplay command documentation in the online help for a full 
explanation of the command’s usage and flags.

Related topics

”Show information over top of a view (heads-up display)” on page 63
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Ingredients

Procedure

Create a MEL procedure that returns the information you want to show in 
the heads-up display.

Update event

Decide when Maya needs to update the display item. For example, if your 
display item shows some information about the selected object, Maya only 
needs to change it when the selection changes. This is the event that 
triggers a display update.

Maya has a number of events you can listen for. Use headsUpDisplay -
listEvents to see the list of all events.

If you update on a selection-based event (“SelectionChanged” or 
“SomethingSelected”), you can refine the event listening to only fire on a 
specific type of change to the selected nodes using the -nodeChanges flag.

-nodeChanges “attributeChange” fires when any attribute on a selected 
node changes.

-nodeChanges “connectionChange” fires when any input or output on a 
selected node changes.

-nodeChanges “instanceChange” fires when any selected instanced 
node changes.

Section and block position

Choose a column for the item to appear in. This is called the section. The 
following chart shows the number the command uses to refer to each 
column. 0 is the upper-left corner, 9 is the bottom-right corner of the 
screen.

Choose a line within the section on which the display item appear. This is 
called the block.

Label

Choose the label that appears before the information on the display line, 
for example “Position:”.

0 1 2 3 4

5 6 7 8 9
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The command

To create a heads-up display item:

headsUpDisplay 
    -section         <section number>
    -block           <block number>
    -label           "<label>"
    -command         "<procedure()>"
    -event           "<event>"
    <object name>;

Then, to show the item:

headsUpDisplay -edit -visability 1 <object name>;

Or to hide the item:

headsUpDisplay -edit -visability 0 <object name>;

See the example below.

The command has many more options than are described here, especially 
for changing the appearance of the display item and checking the usage of 
blocks. Read the headsUpDisplay command documentation for more 
information.

Make the change permanent

Add the commands that create the heads-up display item (and any 
associated user interface) to userSetup.mel to have them permanently 
added to your copy of Maya.

Example

For example, if you want to show the XYZ coordinates of the selected 
object in the heads-up display, create a MEL procedure (for example, 
objectPosition() ) that returns the XYZ coordinates of the selected object.

objectPosition procedure

global proc float[] objectPosition ()
{
    string $selectedNodes[] = `selectedNodes`;
    float $position[3];
    if (size($selectedNodes) > 0)
    {
        string $mainObject = $selectedNodes[ (size($selectedNodes) - 1) ];
        $position[0] = `getAttr $mainObject.translateX`;
        $position[1] = `getAttr $mainObject.translateY`;
        $position[2] = `getAttr $mainObject.translateZ`;
    }
    else
    {
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        $position[0] = 0;
        $position[1] = 0;
        $position[2] = 0;
    }
    return $position;
}

headsUpDisplay command

Then use the headsUpDisplay command to create the heads-up display 
object, and add a user interface to turn the display item on or off.

// Create custom HUD objects
// To create a script like this for testing, see the command documentation
// for the headsUpDisplay command.
//
headsUpDisplay 
    -section         4
    -block           5
    -label           "Position:"
    -command         "objectPosition()"
    -event           "SelectionChanged"
    -nodeChanges     "attributeChange"
    HUDObjectPosition;

// Add menu items to control the custom items
//  
global string $gHeadsUpDisplayMenu;

// Add a divider to separate Maya items from custom items
menuItem -parent $gHeadsUpDisplayMenu -divider true;

// Add one menu item per heads up display object created above
//
menuItem -parent $gHeadsUpDisplayMenu
        -checkBox true
        -label "Object Position"
        -command "headsUpDisplay -e -vis 1 HUDObjectPosition"
        -annotation "Object Postion: Toggle the display of object position"\
        myObjectPostionItem;
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Reference Hotkeys

View hotkeys

Hold + drag Function

Alt + the left mouse button Tumble.

Alt + the middle mouse button Track.

Alt + the right mouse button

or

Alt + the left and middle mouse buttons

Dolly.

Press Function

a Show all.

f Show selected.

Press Function

1 Rough display.

2 Medium display.

3 Smooth display.

Press Function

4 Wireframe display.

5 Shaded display.

6 Shaded and textured display.

7 Display with lights.
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Related topics

”Create or edit a marking menu” on page 280

”Assign a predefined command to a hotkey” on page 284

”View a list of all assigned hotkeys” on page 286

Tool and action hotkeys

Ctrl+Space Switches between the standard view and a 
full-screen view.

Alt+B Changes the background color of the 
perspective and orthographic panels: 
standard (light gray), dark gray, or black. 

Press Function

q Select tool.

w Move tool.

e Rotate tool.

r Scale tool.

t Show Manipulator tool.

y Last tool used.

+

-

Change the size of the manipulator.

Press Function

z Undo.

Shift + z Redo.

g Repeat last action.

Press Function
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Related topics

”Create or edit a marking menu” on page 280

”Assign a predefined command to a hotkey” on page 284

”View a list of all assigned hotkeys” on page 286

F8 Toggle object/component selection mode.

p Parent.

Shift + p Unparent.

s Set key.

Shift + w Key the selected object position.

Shift + e Key the selected object rotation.

Shift + r Key the selected object scale.

Press Function

8 Paint effects panel.

ctrl + a Attribute editor.

Hold Function

x Snap to grid.

c Snap to curve.

v Snap to point.

Press Function
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Menus

Window

Window > Settings/Preferences > Preferences

Shows the Preferences window.

”Preferences” on page 303

Window > Settings/Preferences > Colors

The Colors window has three tabs. Each tab allows you to change the 
default colors for a different set of components.

Related topics

”Change user interface colors” on page 273

Options

General tab

Use the General tab to change the default colors for components in these 
areas: 3D Views, User Defined, Ghosts, Heads Up Display, Animation, 
Animation Editors, Multilister, Hypergraph / Hypershade, Outliner, and 
Trax Editor.

Active tab

Use the Active tab to change the default colors for components in these 
areas: General, Objects, Components, Deformers, Manipulators, 
Animation, and Artisan Brushes.

Inactive tab

Use the Inactive tab to set the colors for objects that are not selected. The 
Inactive tab lets you change the default colors in the following areas or 
tools: General, Modeling, Objects, Components, Deformers, and 
Animation.

Window > Settings/Preferences > Performance 
Settings

Lets you choose trade-offs between performance and quality, as well as 
temporarily disable some visual updates to improve interactivity.
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Options

Screen refresh options

To set when to refresh (or redraw the screen) when manipulating objects, 
in the Dependency Graph Evaluation section, select one of the following:

Drag

Refreshes the display during the drag. 

Demand

Refreshes the display only when you release the mouse button and click 
the Refresh button that appears in the bottom right of the display 
window. 

Release

Refreshes the display only when you release the mouse button. 

Controlling complex operations on surfaces

To control complex operations on surfaces during mouse interaction, in 
the Surfaces section, select one of the following beside the surface:

On

Performs complex operations during mouse interactions.

Off

Completely disables complex operations during mouse interaction.

Interactive

Suspends complex operations during mouse interaction.

Controlling complex operations on deformers

To control complex operations on deformers during mouse interaction, in 
the Deformers section, select one of the following beside the surface:

On

Performs complex operations during mouse interactions.

Off

Completely disables complex operations during mouse interaction.

Interactive

Suspends complex operations during mouse interaction.
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Per Node

For Cluster Resolution and Lattice Resolution only, improves redraw 
performance for individual cluster or lattice deformations by setting 
the Use Partial Resolution attribute to partial and setting the Percent 
Resolution on a per node basis. For details, see Character Setup.

Global

For Cluster Resolution and Lattice Resolution only, improves the 
redraw performance of all cluster or lattice deformations. (You do not 
need to set the Percent Resolution for each cluster or lattice.)

Set Global Cluster Resolution and Global Lattice Resolution to Full, 
High, Medium, or Low. A Low setting corresponds to a low 
percentage, and therefore more improved performance.

For more information on surfaces, see NURBS and Polygonal modeling. 
For more information on deferrers, see Character Setup.

Window > Settings/Preferences > Shelves

The shelf editor provides a dialog box with which you can create and edit 
shelves.

Related topics

”Shelves” on page 22

”Choose actions on a shelf” on page 27

”Add a tool, action, or MEL script to a shelf” on page 277

”Edit the contents of a shelf” on page 278

”Use a custom name or icon for a shelf item” on page 279

”Change the display of shelves” on page 279

Tabs and controls

Shelves

Click the Shelves tab to display existing shelves. From here you can 
create, delete, and rename shelves and change their order.

Shelf Contents

Click the Shelf Contents tab to display the contents of a specific shelf. 
From here you can move and delete shelf items, change an item’s label 
and tooltip, as well as change its icon and icon name.
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Edit Commands

Click the Edit Commands tab to view and edit the MEL code 
associated with a tool or action.

Label & Tooltips

Specify a brief description of the tool. This description appears with 
the icon in the icon or text modes, as well as in the tooltip (the pop-up 
description when the mouse hovers over the icon). 

Icon Name

Type a label for the icon. This text appears on top of the icon to 
distinguish it from other items that use the same icon. Note that the 
icon name always appears on top of the icon, unlike the label, which 
you can specify to show or hide.

Change Image

Click this button to change the icon image.

Save All Shelves

Click Save All Shelves to save all changes immediately and write the 
information to the user shelves directory. The file name for a shelf file 
has the prefix shelf_.

Close

Click Close to accept your changes but not write them to the disk 
immediately. If your UI preference is to save shelf changes only when 
explicitly requested, the changes stay in effect only for the current 
session. Otherwise your changes are saved the next time you save a 
file or quit the application.

Options menu

Icon Only

Displays only the icon. This is the default.

Icon/Text Below 

Displays the label below the icon.

Icon/Text Beside

Displays the label beside the icon.

Save Automatically

When this option is on, your changes to the shelves are saved when 
you exit Maya. This is the default.
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Save Only on Request

When this option is on, your changes to the shelves are only saved 
when you select Save All Shelves in the Shelves window. If you don’t 
save your changes, then they are lost when you exit Maya.

Window > Settings/Preferences > Marking 
Menus

Shows the Marking menus editor.

”Marking Menus editor” on page 325

Window > Settings/Preferences > Panels

Shows the panel editor. This is the same as selecting Panels > Panel Editor 
in a panel.

”Panel editor” on page 93

Window > View Arrangement, Saved Layouts

Let you choose a layout and layout/contents presets. These are the same 
as the layouts/presets available using the quick layout buttons or the 
Panels menu in a panel.

”Quick layout buttons” on page 69

”Panels menu” on page 90

Windows and Editors

Hotbox

Hotbox Controls > Hotbox Style

Controls what controls are available in the hotbox. The hotbox appears 
when you hold down the space bar.

Related topics

”Customize the hotbox” on page 283

Menu

Zones and Menu Rows

Make all of the menu rows visible.
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Reference > Preferences
Zones Only 

Display just the five marking menu zones. Menu sets are not 
available.

Center Zone Only

Make only the center zone (Alias) active everywhere. North, South, 
East, and West Zones and menu sets are not available.

Center Zone RMB Popups

Turn this option on to display menus for the selected menu set when 
you right-click on the workspace. The menu set appears as a pop-up 
instead of a row. Note that the functional menu sets do not display 
when this option is on, even if you have selected to show them.

Windows and editors

Preferences

Interface 

Menu Set

This determines which menu set displays in the main Maya menu bar 
on start-up. The default is Animation.

Show Menubar 

Hides or displays the main menu bar (Windows, Linux, and IRIX 
only) and the Panels menu bar.

Show Title Bar

Hides or displays the title bars in the main window and the Script 
Editor (Windows, Linux, and IRIX only). The title bar includes 
window control buttons for expanding and collapsing the application.

Windows

Turn on Remember Size and Position so that Maya restores the size 
and position of all windows when closed and re-opened. If turned off, 
the Maya windows always display in the center of the screen upon 
opening.

Command Line

Turn on Hold Focus if you want the cursor to stay in the Command 
Line after you press Enter (Windows, Linux, and IRIX) or Return (Mac 
OS X). Otherwise, the cursor returns to the current window.
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Reference > Preferences
Open Attribute Editor 

Use this option to specify how the Attribute Editor displays when you 
open it (such as pressing Ctrl+a (Windows, Linux, and IRIX) or 
Command+a (Mac OS X)). To open the Attribute Editor in a separate 
window, select In Separate Window. To open the Attribute Editor in 
the main Maya window, select In Main Maya Window. By default, the 
Attribute Editor opens in Maya’s main window.

Open Tool Settings

Use this option to specify how the Tool Settings display when you 
open them. To open the Tool Settings in a separate window, select In 
Separate Window. To open the Tool Settings in the main Maya 
window, select In Main Maya Window. By default, the Tool Settings 
window opens in Maya’s main window.

Expression Editor

Select an Expression Editor for editing text.

UI Elements

Visible UI Elements

Hides or displays UI elements. You can also control this display from 
the Display > UI Elements menu. 

Turns on any elements you want displayed in the Maya main 
window.

Editor in Main Window

You can choose to show or hide the Editor. The Editor can be one of 
the Attribute Editor, Tool Settings, or Channel Box/Layer Editor. You 
can also control this display from the Display > UI Elements menu or 
the three icons on the far right of the Status Line.

Panel Configurations

When Saving

When Save Panel Layouts with File is turned on, the panel layouts are 
saved with the scene file. The default is on. (This replaces the former 
Save File options.) 
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Reference > Preferences
When Opening

When turned on, this restores saved layouts from the file. The default 
is on. (This replaces the former Open File options.)

Starting New Scenes

You can specify a layout for new scenes. 

Keep Current 

Layout Keeps the current layout for new scenes.

Use Layout 

Specified 

Below Creates new scenes based on the layout selected 
from the drop-down menu. Single Perspective View 
is the default.

Help

Popup Help

Display Time

Specify a display time for pop-up help. The default is four seconds.

Help Browser

Open Help

You can choose to open the Maya documentation within Maya (in the 
Maya browser) or in an external Web browser (set by your system’s 
file association with .html).

Help Language

Sets which documentation language set Maya loads when you use the 
help. If you have another documentation language set installed you 
can click Other and type a language/dialect code in the Specify 
language box.

Tip Turn this option off when making objects/sub-scenes to use as 
referenced files. By default, Maya remembers everything about 
every editor you’ve opened, such as location, size, window-
specific options, etc., in every scene file (.ma/.mb). This is saved 
as a attribute on a script node named uiConfigurationScriptNode 
that displays as MEL code added into a node's string-valued 
attributes.
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Help Location

Local Maya displays online help from its own help server. 
Maya starts the server when Maya launches and 
stop the server when Maya quits.

Remote Maya displays online help from the URL in the URL 
box. This can be a help server running on the 
network.

If you change the setting from Remote to Local, quit and restart Maya 
to get Maya to start up the local help server.

Display 

Performance

Fast Interaction

Turns Fast Interaction on to improve performance by displaying fewer 
geometric entities (such as polygons). The default is off.

Viewport textures

You can set the slider to display viewport textures in a trade-off 
between fast and high quality.

View

Axes

Displays one or both of the XYZ coordinates (view and origin axes). If 
you disable both choices, no XYZ coordinates appear.

View Axis Displays the XYZ coordinates in the bottom left 
corner of the view. The default is on.

Origin Axis Displays the XYZ coordinates at coordinates 0, 0, 0. 
The default is off.

Notes • If the scene has only hardware textures, this slider has no 
effect. 

• The scene’s textures are not automatically updated with any 
changes; you'll need to force an update; for example, by 
reloading the scene. 

• The only textures affected are the ones set to use the default 
texture quality but whose 2d texture placement options are 
not handled in hardware (for example, use stagger or some 
other option the card/drivers don't support in hardware). 
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Reference > Preferences
Grid Plane

Displays or hides the grid plane. The grid is a 2D plane that represents 
3D dimensions in the view. It is useful when you want to animate 
motion relative to a solid surface. Select Hide to hide the grid. The 
default is Show.

This setting overrides the Display > Grid setting.

Active Object Pivots

Specify whether to display pivot points. The default is off.

Affected Highlighting

Turns highlighting display on or off. An object associated with or 
affected by a selected object is highlighted in a different color. The 
default is on.

Wireframe on Shaded

Select how you want to display the wireframe on shaded objects.

Full  Displays normal resolution wireframes on shaded 
objects. This is the default.

Reduced Displays fewer wires on shaded objects.

None Displays no wires on shaded objects. Performance is 
enhanced if you select None.

Region of Effect

This option lets you turn on or off the region of effect display. Region 
of effect is the part of an object that potentially changes as a result of 
moving selected CVs. Note that curves show the region of effect as 
well as surfaces. The default is on.

Note You can edit this highlight color by selecting Window > 
Settings/Preferences > Colors, clicking the Active tab, expanding 
General, and modifying Active Affected.
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Shade Templates

If on, template objects appear shaded in shaded view. If off, the 
templated objects appear as wireframes while all other objects appear 
shaded. The default is off.

Kinematics

Joint Size

Changes the display size of skeleton joint sizes. The range is from 0.01 
to 5.0.

IK/FK Joint Size

For skeletons with blended IK/FK animation, this option sets the 
display size for the joints and bones in your IK and FK skeletons. This 
option does not affect the display size of the joints and bones in the 
IK/FK Blend skeleton.

IK Handle Size

Changes the display size of IK handles. The range is from 0.01 to 5.0.

Ik/Fk Blending Display

For skeletons with blended IK/FK animation, this option specifies 
which skeletons appear in the scene view.

None Only the IK/FK Blend skeleton appears in the scene 
view.

IK Only the IK skeleton appears in the scene view.

FK Only the FK skeleton appear in the scene view.

Both The FK, IK, and IK/FK Blend skeletons appear in 
the scene view.
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Ghosts

Steps before Current Frame

Specifies how many ghosted images are drawn at frames before the 
current frame. Type a value or drag the slider. The default is 3.

Steps after Current Frame

Specifies how many ghosted images are drawn at frames after the 
current frame. Type a value or drag the slider. The default is 3.

Frames Per Step

Specifies the number of frames between drawing the ghosts. Type a 
value or drag the slider. The default is 1.

Manipulators

Global Scale

Specifies the size of the manipulators. The range is from 0.10 to 10.00. 

Handle Size

Specifies the size of the handle. The range is from 4 to 100.

Note By default, joints and bones appear dark navy blue. But when a 
skeleton has both IK and FK, each skeleton appears as a different 
color (FK is Black, IK is a Dark Red/Brown, and Blend appears 
pink/magenta.
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Line Size

Specifies the line thickness size of the rotate manipulator’s rings.

Line Pick Size

Determines the line thickness used when picking the rotate 
manipulator rings. The pick size should be the same as line size, so 
you can identify which handle will be picked by the size of the ring. 

Previous State Size

Controls the size of the points drawn for a previous feedback. For 
example, for the Move Tool, an axis is drawn to indicate the previous 
position, with square points at the end of the axes. This controls the 
size of the squares. 

Rotate and scale manipulators also have previous state feedback. This 
type of feedback is shown only when you drag; it disappears as soon 
as you release the mouse.

Default Manipulator

You can specify a Default Manipulator option in the Show Manipulator 
section to control what manipulator, if any, appears when you select 
the Show Manipulator Tool. The Default Manipulator options include:

None Does not display a manipulator.

Translate Displays the Move Tool’s manipulator.
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Rotate Displays the Rotate Tool’s manipulator.

Scale Displays the Scale Tool’s manipulator.

Transform Displays the Transform (triple) manipulator.

Smart Checks the first child and if it is a shape displays the 
history manipulator for the shape. Otherwise 
displays the Transform (triple) manipulator. This is 
the default.

NURBS

New Curves, New Surfaces

Select whether you want Edit Points, Hulls, CVs, or origins on new curves 
or new surfaces:

Surface Divisions

Controls the smoothness of an object in a view. It also affects the 
rendering of newly created surfaces. Enter a value or use the slider. 
The range is from 0 to 64. The higher the value, the smoother the 
surface.

Curve Divisions

Controls the smoothness of a curve in a view. Enter a value or use the 
slider. The range is from 1 to 128. The higher the value, the smoother 
the curve.

Shaded Divisions 

Controls how smooth your smooth-shaded object looks. Enter a value 
or use the slider. The range is from 1 to 64. The higher the value, the 
smoother the smooth-shaded object.

Polygons

Vertices

Specify how you want vertices to display:

Display  Turns the display of vertices on or off.

Normals Displays vertex normals on or off.

Backculling  Makes vertices invisible in areas where the normal 
is pointing away from the camera.

Note These options work only on new curves or surfaces, not existing 
items.
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Edges

Specify how you want edges to display:

Standard Displays all edges the same (hard or soft).

Soft/Hard Displays soft edges as dotted lines and hard edges 
as solid lines.

Only Hard  Displays hard edges only (makes soft invisible).

Highlight

Specify how you want to highlight polygons:

Border Edges Displays thicker outside edges to make them more 
visible for certain operations.

Texture 

Borders Displays a thick border to highlight the area a 
texture affects per polygon or per vertex.

Border Width

Specify the width of the polygon border. The range is from 1 to 10.

Faces

Specify how you want faces to display:

Centers Displays a small square to indicate the face center.

Normals Shows the normals at the center of each polygon.

Triangles  Displays all polygons as triangles. 

Non-planar Displays non-planar faces with a tinted color for 
easy identification. A non-planar face has vertices 
that lie outside the plane of the face. By identifying 
and eliminating non-planar faces, you can avoid 
unexpected results from reshaping the surface later.

Show Item Numbers

Specify where you want item numbers displayed: at each vertex 
(Vertices), at each edge (Edges), on each face (Faces), or at each UV 
(UVs).

Normals Size

Specifies the display size of the normals. The range is from 0.1 to 10.

Color

Turn Colored Shading on to use the Apply Color operation (Edit 
Polygons > Colors > Apply Color).
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Color Material

These menu options override any existing material channels and 
replace them with the vertex colors you assign. For all options other 
than None, lighting affects the object’s shading.

None None of the material properties of the shader(s) 
assigned to the object are used. In this case lighting 
is also disabled. 

Ambient  The ambient material channel of the assigned 
shader(s) is overridden by the vertex color. 

Ambient + 

Diffuse The ambient and diffuse material channels of the 
assigned shader(s) are overridden by the vertex 
color. 

Diffuse  The diffuse material channel of the assigned 
shader(s) is overridden by the vertex color. 

Specular The specular material channel of the assigned 
shader(s) is overridden by the vertex color. 

Emission The emission material channel of the assigned 
shader(s) is overridden by the vertex color.

Material Blend

Renders material blends in hardware. For details of how Material 
Blend operates, see Color per vertex now supported by hardware 
renderer.

Backface Culling

Specify the display for backface culling:

Off  No backface culling occurs. This is the default.

On Surfaces become invisible in areas where the normal 
is pointing away from the camera.

Keep Wire Displays wireframe outlines, but any areas where 
the normal is pointing away from the camera are 
hidden.

Keep Hard 

Edges  Sets backface culling for soft edges only. See 
Polygonal Modeling for more information on 
polygonal modeling.
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Up Axis

Sets the up axis to Y or Z. The default is Y.

Linear

Sets the unit of measure for operations that use linear values, for 
example, moving and scaling. The default is centimeters.

Angular

Sets the unit of measure for operations that use an angular value, for 
example, rotation. The default unit is degrees.

Time

Sets Maya’s internal representation of what one “second” is. For 
example, in a dynamics simulation, which relies on real world 
timings, the resulting simulation produces keys which represent one 
second as 24 frames (Maya’s default value). 

It also allows you to compensate for intermediate output devices (for 
example, Abekas, etc.) which may have different frame rates to your 
final output (for example, Film). When changed, your animation keys 
move in time to match that range. This is only while your time units 
are on that alternate setting. Returning the time units to your creation 
setting returns your keys to their original location.

The default for measuring time is Film 24fps (24 frames per second).

Keep Keys at Current Frames

By default when you change the current time unit, the times for any 
existing keys are modified so that playback timing is preserved. For 
example, a key set at frame 12film changes to frame 15ntsc when the 
current time unit is changed to NTSC, since they both represent a key 
at 0.5 seconds. When this option is on, it leaves the key at 12ntsc that 
was originally at 12film. The default setting for this option is off. The 
option turns on once the current time unit is changed.

Note Be sure you set your preferred time unit for a particular session, 
before creating any animation. This ensures correct timing of 
your keyframes, for the final output and final fps setting.
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Tolerance 

The Tolerance value determines the degree of accuracy that is 
maintained between the original and fit (or interpolated) curves. This 
setting applies globally to Maya. You can change it on a case-by-case 
basis. Set the following tolerance options:

Positional Set the degree of accuracy between the actual 
positions of the original and interpolated curves.

Tangential Set the degree of accuracy required to determine if 
two NURBS objects are to be made tangent across a 
shared edge or point.

Cameras

Default Cameras

Sets the default Near Clip and Far Clip values for cameras. For more 
information, see Clipping planes. 

Dynamics

Auto Create Rigid Body

Turn this option on to automatically create active rigid bodies when 
you connect an object to a field (apply a field’s influence to geometry).

Run Up to Current Time

If you click a frame in the Time Slider, the correct state of all dynamic 
objects in the scene is displayed only if Maya performs run-up to 
calculate each frame prior to that frame. Turn this option on if you 
want to click frames in the Time Slider. Note that run-up also occurs 
for hidden objects.

Leave run-up turned off if you want to prevent Maya from calculating 
dynamics when you click in the Time Slider. This is useful in a scene 
that has both nondynamic objects and complex dynamic objects, 
where you want the state of nondynamic objects to appear promptly 
after you click the Time Slider. If you are keying dynamic objects, it’s 
also useful leave run-up turned off to avoid waiting for run-up 
calculations that are irrelevant to your keying activities. 

Run Up From

Select one of the following options:

Previous Time If you click a frame higher than the current frame, 
run-up starts from the prior current time and ends 
at the frame you click. Select this option if you won’t 
be changing any attributes of a dynamic object in 
the scene. This setting lessens the time you’ll spend 
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waiting for run-up. If you click a frame lower than 
the current frame, run-up starts from the beginning 
of the animation. 

Start Time Run-up starts from the start frame regardless of 
where you click in the Time Slider. Select this option 
if you plan to change any attributes of a dynamic 
object in the scene. This ensures that you see the 
correct object states when you click in the Time 
Slider after modifying an object’s dynamics. 

Save Startup Cache for Particles

When this option is turned on (the default), Maya automatically saves 
the start-up cache for all your particles every time you save the file. 
Unlike particle disk caches, you don't have to create the start-up cache 
explicitly every time. See Dynamics for more information.

Echo Collision Commands

 When you have a particle collision MEL callback specified, every time 
a collision happens, Maya echoes the command that it is running, then 
runs it. In a scene with thousands of particles, that produces a great 
deal of unnecessary output to the Script Editor. This preference 
enables and disables echoing of the collision commands before they 
are run. 

Files/Projects

Default Projects Directory, Always Start in This Project

Use these settings to set up a default projects directory when you 
create new projects and on startup. 

Files, Increments, Projects

Specify how many files, increments, and projects you want to have 
listed in each of the File > Recent submenus.

Ascii File Compression Mode

On File Save

Specify the compression mode you want to use when saving an ASCII 
file:

Compressed Saves files in compressed mode. File compression 
reduces the sizes of large files so they do not occupy 
as much space on your hard drive. 

Uncompressed  Saves files in uncompressed mode.
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As Is  Keeps files in their original compression mode 
rather than compressing or decompressing them. As 
Is is the default.

Display Layer

File Import Merge

Specify how you want the Display Layer merged when you import a file.

None All layers read in are put in a new layer, 
renumbered, and renamed, if necessary to preserve 
uniqueness. 

By Number Rather than creating a new layer, all layers read in 
that have the same index number as an existing 
layer are merged with that layer. 

By Name Rather than creating a new layer, all layers read in 
that have the same name as an existing layer are 
merged with that layer. 

Keys 

Auto Key

Turn Auto Key on to automatically set keys on keyable attributes of 
an animated object (including lights, shaders, textures, cameras, and 
so on). You can choose to key modified attributes or all attributes.

New Curve Default

Use this menu to create blends between rotations using quaternions 
rather than Euler angles.

Weighted Tangents

Turn Weighted Tangents on to give animation curve tangents weight. 
The default is turned off, which means the tangents are non-weighted.

Default In Tangent, Default Out Tangent

Set the default In and Out Tangents to:

Spline  Creates an animation curve that is smooth between 
the key before and the key after the selected key.

Linear Creates an animation curve as a straight line joining 
two keys.

Note To use compression modes, please ensure that a zip utility is 
installed and in the path on your machine.
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Clamped Creates an animation curve which has the 
characteristics of linear and spline curves. 

Flat Sets the in and out tangents of the key to be 
horizontal (with a slope of 0 degrees).

Stepped Creates an animation curve whose out tangent is a 
flat curve.

Modeling

Output Geometry as

These settings determine the type of geometry created from modeling 
actions such as Revolve, Loft, Extrude, Fillet Blend, and so forth. 
Setting it here affects all applicable modeling actions. Otherwise, 
select Mixed to use the individual settings of each modeling action. 

NURBS Interaction: Interaction Mode

Specify whether you want certain NURBS modeling commands to 
behave like actions or tools. An action performs a discrete function on 
selected objects. A tool lets you manipulate objects until you complete 
the operation. You may want to change actions to tools as you become 
proficient at Maya’s NURBS modeling. 

To globally change the applicable modeling tools, choose Everything 
is a Tool or Everything is an Action. To individually set each 
command, choose Mixed. 

Rendering

Preferred Renderer

You can choose your preferred renderer. This is the renderer that 
Maya resets to when you create a new scene (File > New Scene) or 
when you start Maya. This can be one of Maya Software, Maya 
Hardware, Maya Vector (if loaded), or mental ray (if loaded).

Selection 

Modifiers 

Modifiers control Maya selection operations. They work with masks to 
control what is displayed when you select items. You can turn on one or 
more of the following: 

Single Marquee Select

Selects the first object in a hierarchy.
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Click Drag Select

Lets you perform one-step click-dragging with the transformation 
tools. You can move one object using the Move tool, then click on a 
second object and the Move tool displays. This means you do not have 
to select the object and the Move tool again—you can keep using the 
Move tool on any subsequent selected object. The default is off.

Affects Active

If you change from object to component selection mode, the selected 
object is not affected. This option lets you select objects and 
components at the same time. The default is on.

Popup Menu Selection

When objects overlap in the view, lets you display a pop-up list of the 
objects so you can select them. Left-click on the overlap area to 
display the menu. The default is off. Your selection is highlighted in 
the scene view as you select an item in this list. Currently-selected 
items are marked with a box when the list appears.

Ignore Selection Priority

Treats all objects with the same priority. The selection order does not 
matter. The default is off.

Expand Popup List

If you turned on Expand Popup List, displays all the pop-up list of 
objects and everything underneath it in the hierarchy. The default is 
off.

Note You must hold down the left mouse key on Linux and IRIX to 
select an item in this list.
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Click Box Size 

This option controls the size of the selection area around the mouse 
pointer, or click box. If you are having problems with selecting objects 
or components, try adjusting this option. For example, a higher click 
box size might make it easier to select curves. Increasing the click box 
size is also useful if you have a high resolution screen display.

Polygon Selection

Select Faces with

Specify how you want to select polygonal faces:

Center Select polygonal faces at their center. In other 
words, you must click the box at the center of the 
face to select the entire face.

Whole Face Select the entire face. You can click anywhere on the 
face, even any face edge, to select it.

Priority

You can specify a selection priority for objects and components. By 
default, NURBS curves have a higher selection priority than surfaces. This 
means that Maya selects the NURBS curve before the surface when you 
select geometry that contains both NURBS curves and surfaces.

1 Scroll to select the item 
you want to prioritize.

3 Enter the 
priority number.

2 Select Custom.
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Snapping 

With these options, you can control the size region around the mouse 
pointer that is used for the snap operation. 

Use Snap Tolerance 

When on, the snap region is restricted to a square area around the 
cursor, defined by the Snap Tolerance option. When off, the snap 
region is unlimited; you can snap to anything viewable.

Snap Tolerance

Controls the size of the snapping area around the cursor when Use 
Snap Tolerance is on. For example, if you have two curves close 
together and you try snapping to one of the curves, the object may 
snap to the wrong curve. To avoid this, try using a small Snap 
Tolerance value. 

UV Texture Editor Snapping

UV Snap Tolerance

This preference defines how close UVs are together before they snap 
when moving and using the v hotkey (snap to points).

Edge Snapping

Snap Magnets

Controls the number of magnet points inside edges. For example, 3 
means there are magnet points at each end and in the middle.

Magnet Tolerance

Controls how “sticky” each magnet is; that is, how close the point 
must be to a magnet before the point snaps to it. Set this to 100 to 
constrain points to always be at magnet points.

Sound

Waveform Display

The Waveform Display option allows you to control how much of the 
sound’s waveform is displayed. 

Top  Displays only the top half of the sound.
Basics

321



7 | Preferences and customization 
Reference > Preferences
Bottom  Displays only the bottom half of the sound.

All Displays the full waveform.

Repeat on Hold

Repeats a sound at the current time. You must hold the mouse button 
down in the Time Slider. For more information on using sound with 
Maya, see Animation.

Repeat Size

Controls how much sound (in the current time unit) is repeated when 
you turn on Repeat on Hold.

Timeline

Playback Start/End

Specifies the range of time to use as your time playback range.

Animation Start/End

Displays the entire range of times available. 

Height

Adjusts the height of the time slider. This helps with sound synching 
(as a soundtrack can be displayed in the time slider). Select 1x for the 
default size, 2x to double the size of the slider, and 4x to quadruple 
the size of the slider.

Key Ticks

Keyframe ticks show the location of keys along the time slider. Select 
None to turn the key tick display off, Active to display only active 
keys, or Channel Box to display only those keys in the Channel Box.

Options

Turn the following options on or off:
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Timecode  Changes the default display of time to video 
standard timecode. Enables the Timecode Offset box 
so you can supply timecodes to match the timing 
from videotape. 

Snapping Turns key snapping on or off. When on, the time 
indicator shows integer values only.

Timecode Offset

The Timecode Offset lets you specify how time 0 on the Time Slider 
appears when displaying in Timecode mode. For example, if the 
Timecode Offset is set to three hours (a value of 03:00:00:00), the 
Timecode Display would read 03:00:00:00 at time 0.

Playback

Update View

Specifies whether Maya plays back an animation in All modeling 
views or only in the active view. The default is Active.

Looping

Specifies how you want Maya to play back an animation. Select Once 
to play an animation once, then stop. Select Oscillate to play an 
animation forwards and backwards continuously. Select Continuous 
to play an animation continuously. Continuous is the default setting.

Playback Speed

Specifies the frame rate for playback.

Play every 

frame Displays all the frames of your animation. Each 
frame is updated completely before proceeding to 
the next one. Specify the exact rate in the Playback 
by box. This rate reflects your system’s ability to 
draw your animation on screen and is not 
necessarily a real-time playback mode. This is the 
default setting.

Real-time 

(24 fps) Plays your animation in real-time. Some frames may 
be dropped (not displayed) to execute this in real-
time. This depends on your system’s capabilities, 
the complexity of your scenes, and the display mode 
for the playback.

Half (12 fps) Plays back at exactly half the speed of real time.

Twice (48 fps) Plays back at twice real-time speed.
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Other  Enables the Other box so you can enter an exact 
ratio of playback rate to real-time.

Playback by

If you select Play every frame for the Playback Speed, specify the 
exact rate in this box. This rate reflects your system’s ability to draw 
you animation on screen and is not necessarily a real-time playback 
mode. The default setting is 1.0.

Undo

Undo

Select On if you want to be able to undo operations. This is the 
default.

Queue

Select Infinite to perform an unlimited number of undo operations. 
This option can use a lot of memory. Select Finite to limit the number 
of undo operations you can perform (specified in the Queue Size box). 
The default is Finite.

Queue Size

If Finite is the selected Queue setting, specify here the number of undo 
operations you can perform. The default is 50.

Web browser: Network and User settings

Home page

Sets the home page that the Maya browser goes to on launch or when 
you click the Home button.

Font size

Set the variable and fixed font sizes in pixels. 

General

Set the web browser to resize images to fit the browser window, or to 
display them full-size.

Network Configuration

You can choose from Direct Connection, Manual Proxy (enter the 
URLs and port numbers of the HTTP, SSL, and FTP proxies), or 
Automatic Proxy (enter the configuration URL). You can also set the 
Web browser to bypass the proxy server(s) for specified URLs.
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Modules

Maya includes a number of different software modules. Each time you 
start Maya, the software loads all the available licensed modules. 

Loading several modules can use a lot of RAM and thus increase the start-
up time. To avoid this, you can disable one or more of the modules. You 
can still load a disabled module by selecting it from the main menu bar.

You can also disable various modules based on the specific tasks you are 
performing. For example, if you are only rendering, you can improve 
system response time by disabling Dynamics.

Marking Menus editor

Lets you edit the available marking menus. Once you define a marking 
menu, you must assign it to a hotkey or add it to the hotbox before you 
can use it.

Related topics

”Create or edit a marking menu” on page 280

”Assign a marking menu to a hotkey” on page 281

”Add a marking menu to the hotbox” on page 282
Basics

325



7 | Preferences and customization 
Reference > Marking Menus editor
Marking menu editor

Use Marking Menu in

Specify whether the marking menu is linked to the Hotbox or a hotkey.

Hotbox Region

If you selected Hotbox for Use Marking Menu in, select the Hotbox zone 
the marking menu occupies: North, South, East, West, or Center. 

Mouse Button(s)

Select the left, middle, or right mouse button used to display the marking 
menu. You can select one, two, or three mouse buttons.

Marking menu item editor

Label

Enter the name of the marking menu item.

Icon Filename

Enter the name of the icon file. For more information, see MEL and 
Expressions.

Marking menu defaults Zone Associated mouse buttons
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Command(s)

Enter the MEL script used as the command for the menu item. You can 
drag the MEL script from the Script Editor’s bottom panel with the middle 
mouse button. 

Check Box

Displays a check box beside the marking menu item.

Radio Button

Displays a check box beside the marking menu item.

Neither

Displays nothing beside the marking menu item.

Option Box

Turn Option Box on to display the option box  beside the menu item so 
you can change a tool’s options from the marking menu. 
 

Option Box Command(s)

Enter the MEL script to use as the command for the menu item’s option 
box.

Assign hotkey area

Key

Enter the key you want to assign to the selected command. Enter a 
letter from A to Z (upper and lower case are different keys) or a 
number from 0 to 9. You cannot use more than one letter or number. 

Or, choose a special key from the pull-down list. For example, if you 
want the right arrow key to act as the trigger, assign it here.

Modifier

Select either Alt (Windows, Linux, and IRIX)/Option (Mac OS X) or 
Ctrl or Command (Mac OS X) for the hotkey modifier. 

Note If the tool or action does not have an options window, you must 
use MEL code to create the box. Once the box is created, you 
must write MEL code to invoke the option window. For more 
information on MEL commands, see MEL and Expressions.
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Direction

Use Press or Release to associate a command with the press or a 
release of a key. For example, you can create a hotkey to instruct 
Maya to snap to a curve when you press a key, then turn off the 
snapping when you release it. 

If you added a key to an operation ending with (Press) or (Release), 
add the same key to the corresponding (Release) or (Press) operation.

Add to Recent Command List

Turn on so that this hotkey can appear in the Edit > Recent 
Commands window. 

Query 

Click Query to determine whether the specified key settings have 
already been assigned to a command.

Find 

Click Find to highlight the category and command for the key you 
enter in the Key field.

List All window

No Modifiers

Lists only single hotkeys, without Ctrl or Alt (Windows, Linux, and 
IRIX) or Option (Mac OS X).

Ctrl or Control

 Lists only hotkeys with a Ctrl-key combination. 

Alt or Option

 Lists only hotkeys with an Alt or Option-key combination.

Command

Lists only hotkeys with a Command + key combination. Available for 
Mac OS X only.

List All

Lists all hotkeys.

Ignore Release

Turn on to ignore the hotkeys that activate when you release the key, 
versus when you press the key. Turn off to see all hotkeys, including 
the ones activated when you release the key.
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Hotkey editor

Lets you assign predefined commands, MEL scripts, or marking menus to 
keys and key combinations.

Related topics

”Assign a marking menu to a hotkey” on page 281

”Assign a predefined command to a hotkey” on page 284

”Assign a MEL script to a hotkey” on page 285

”View a list of all assigned hotkeys” on page 286

Windows > Settings/Preferences > Hotkeys

Categories and Commands

Maya includes a large number of useful pre-defined hotkey commands. 
You can use these commands instead of writing your own MEL script.

Click a category in the Categories list to see the list of available pre-
defined Commands in the category.

Click a command in the Commands list to see its current hotkey(s) or 
assign it to a new key.
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Current hotkeys

List box

Shows all hotkeys that active the selected command.

Remove

Select a hotkey and click Remove to unassign the hotkey.

List All

Opens a window listing every assigned hotkey and its command.

Restore Defaults

Returns all hotkey assignments to their “factory defaults” (the original 
commands they were assigned to when Maya was installed).

Assign New Hotkey

Key

Type a keyboard symbol in the text box, or use the pull-down list next 
to the text box to select other keys.

If you type an upper-case letter in the text box, Maya requires you to 
type the letter with the shift key to activate the hotkey.

Modifier

Choose a modifier to add to the key.

Direction

Choose when the command activates: when you press the key down, 
or when you let the key back up (release).

Add to Recent Commands List

Choose whether Maya should add the command to the Recent 
Commands list (Edit > Recent Commands) when you activate the 
hotkey.

Edit area

New

Create a new user-defined command which you can then assign to a 
hotkey.

Edit

Edit the selected user-defined command in the Commands list.

Delete

Delete the selected user-defined command in the Commands list.
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Name

The name of the selected command.

Description

A description of the command’s purpose and effect.

Category

The category in which the command appears (in the Categories list 
box).

Command

The script that runs when the command is activated.

Accept

Click to save the command you are creating or editing. This button is 
only available after you click New or Edit to create or edit a 
command.

Cancel

Click to cancel editing a command. This button is only available after 
you click New or Edit to create or edit a command.

Search

Lets you search for text in the name or script of all defined commands. 
Use asterisks as wildcards.

Plug-in Manager

A plug-in is an add-on module that extends Maya’s capabilities. File 
translators are plug-ins you use to import and export various file formats. 
You can create or purchase specialty plug-ins to customize Maya for a 
specific job. 

Some features that can be added through plug-ins are:

• file translators

• tools

• objects (nodes)

• MEL commands

• device drivers

Related topics

”Supported file formats” on page 215

”Load or unload plug-ins” on page 286
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Reference > Plug-in Manager
Windows > Settings/Preferences > Plug-in Manager

The Plug-in Manager identifies which plug-ins are loaded into Maya. If 
you have a plug-in that you use frequently, you can make sure it is always 
there. The Plug-in Manager automatically scans all the directories in the 
plug-in path and lists available plug-in features.

loaded

Turn on loaded to load the plug-in for the current Maya session. 

auto load

Turn on auto load to load the plug-in so that the next time you start Maya 
the plug-in loads automatically. 

Information window

To view information about a particular plug-in, you must first load it, then 
click the i button beside the plug-in.

Maya displays the following information for a selected plug-in:

Name

The name of the plug-in. On Linux and IRIX, plug-ins have the extension 
.so. On Windows, they have the extension .mll. On Mac OS X, the 
extension is .lib.

Click here to display 
information on the plug-in
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Reference > Plug-in Manager
Path

The location of the file. On Linux and IRIX, the default plug-in location is:

/usr/aw/maya6/bin/plug-ins

On Windows, the default plug-in location is:

drive:\Program Files\Alias\Maya6.0\bin\plug-ins 

On Mac OS X, the default location is 

/Applications/Alias/Maya6/Application Support/plug-ins

Vendor

The manufacturer of the plug-in.

Plug-in Version

The version number of the plug-in.

For API Version

The version of the Maya API (Application Programmer Interface) the 
plug-in was compiled for. 

Auto Load

Indicates whether the plug-in has been marked for auto load.

Is Loaded

Indicates whether the plug-in is loaded.

Plug-in Features

Displays a list of the features added by the plug-in (for example, 
commands, dependency nodes, file translators).

To display additional plug-ins, click the triangle to open the Other 
Registered Plug-ins section.

Note You cannot load a plug-in for any version of Maya that predates 
the version it was compiled for.
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