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1 What’s New in 
Maya

Introduction to what’s new in Maya 6

This book describes the new features we’ve added in Maya 6. For 
your convenience, we’ve included complete procedures for using 
the new features in this book. You can also find the information 
on the new features in the Maya Help.

All features are common to all four platforms—Windows, 
Mac OS X, Linux, and IRIX—unless otherwise indicated. Some 
features—Fluid Effects, Cloth, Fur, Live, and Hair—are only 
found in Maya Unlimited, which is available on Windows, Linux, 
and IRIX platforms.

The following sections contain descriptions of some of the major 
features and improvements.

Long hair and dynamic curves for Maya 
Unlimited

Maya Unlimited 6 introduces Hair, a major new feature set that 
combines a dynamic curve simulation engine with a variety of 
rendering options for the creation of hair and other objects, such 
as ropes, chains, feathers and vines. The simulation engine can 
also be used to control NURBS curves connected to other objects, 
such as IK chains, surfaces, emitters, and deformers.
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1 | What’s New in Maya 
  > Soft Modification Tool and Deformer
Using Hair, you can easily and 
quickly create realistic hair on 
characters directly within Maya 
that:

• reacts to character motion 
and dynamic forces, such 
as wind

• can collide with objects, like 
shoulders

• can be constrained into 
hairstyles, such as 
ponytails, braids or hair 
clips

The dynamic curves can also be used to create a huge range of 
other effects, such as suspension bridges, octopi, curtains, fishing 
lines, and much more.

For more information, see “Hair overview” in the online Hair and 
Dynamic Curves guide.

Soft Modification Tool and Deformer

This new feature combines selection with manipulation. You can 
move, scale and rotate a selection with customizable falloff. The 
tool mode does not create history unless the original object has 
history: it is available from the Tool Box. The deformer mode 
creates history which can be edited after the fact and animated. 
Deformation weights can be painted using the Paint Attributes 
Tool.
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1 | What’s New in Maya
 > Enhancements to character animation
With the Soft Modification Tool you can quickly manipulate 
geometry in an intuitive manner, similar to sculpting with clay. 
You can subtly blend changes with the surrounding geometry by 
controlling the falloff. For more information, see ”Soft 
Modification Tool and Deformer” on page 59.

Enhancements to character animation

Maya 6 offers substantial enhancements to character animation. 
Trax has been redesigned and streamlined to provide enhanced 
productivity and ease-of-use. With new Motion Retargeting, 
motion capture or other animation data can be adapted and 
reused on different characters, removing the necessity to generate 
original data for each character. With new Motion Redirection, 
you now have the ability to redirect motion capture or other 
animation data that facilitates the reuse of stock or pre-existing 
data for new purposes. 

Related topics

”Improved Trax Editor” on page 103

”What is animation retargeting?” on page 185

New deformers on particles

Nearly all deformers, such as lattices, clusters, and non-linears, 
can now be used on particles, just as they can on geometry. This 
provides powerful control over particle simulations, particularly 
useful for situations that defy physical reality, such as a wisp of 
smoke coiling around a character. For more information, see 
”Deforming particles” on page 211.
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1 | What’s New in Maya 
  > Shader organization and filtering in Hypershade
Shader organization and filtering in 
Hypershade

You can now organize render nodes into sorting bins. You can 
also filter nodes by name or type, with a separate filter for each 
Hypershade tab. These tools allow you to better manage and 
organize complex scenes with large numbers of shaders and 
associated nodes. Render nodes can be categorized logically, and 
therefore located more quickly, streamlining your workflow.

Related topics

”Organize render nodes with Hypershade sorting bins” on 
page 234

”Node filtering improvements in Hypershade” on page 237

Continued mental ray integration

We’ve continued to integrate mental ray more completely with 
Maya, adding support for Maya-specific features and making 
underlying functionality more accessible.

Adobe Photoshop integration

We’ve added several features which allow you to work directly 
with PSD files within Maya. This enables tighter, more efficient 
workflows with the most commonly used texturing tool for Maya. 
For more information, see ”Adobe Photoshop file support” on 
page 219.
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1 | What’s New in Maya
 > Enhancements to file referencing/scene segmentation
Enhancements to file referencing/scene 
segmentation 

Selective pre-loading for references

You now have control over which references, at all levels in the 
hierarchy, you want to load with your file upon opening. By 
saving out the selective load settings with a given file, or building 
a set before opening the file, you can cut down on the time it takes 
to open the file by only loading reference files of interest. For 
more information, see ”Selective file loading” on page 28.

Load/unload related references in scene view

You can now create references with an associated annotated 
locator that is visible in the scene view. From this locator, you can 
load and unload the related reference. This allows you to better 
manage complex scenes, by making it easier to visually select 
parts of the scene for loading and unloading. For more 
information, see ”Reference locators and reference manipulation” 
on page 33.

Embedded Web browser in a panel

This applies to Windows, Mac OS X and Linux only. You can now 
use a Web browser within a Maya panel to browse through and 
view Web content, or to issue MEL commands from an HTML 
page.

The Web browser can be used simply for displaying 
documentation (either internal or external to Maya), but since it 
can execute MEL commands it can also be used to build user 
interfaces or interactive tutorials, or to manage assets and scene 
date. This will facilitate the integration of intranet infrastructure 
tools directly into Maya.

For more information, see ”Web browser in a panel” on page 51.
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1 | What’s New in Maya 
  > Render Fur in mental ray
Render Fur in mental ray

You now have the option to render Fur in the mental ray 
renderer. The Fur is created using mental ray’s hair primitive and 
renders in the main render pass. Since it is not a post-process, Fur 
rendered in mental ray behaves like any other object in the scene:

• it can show up in reflections and refractions, through 
transparent objects, and can take advantage of global 
illumination and caustics

• lighting, shadows and motion blur match the rest of the scene 
perfectly

• artifacts caused by z-depth compositing are no longer an issue

For more information, see ”Rendering Fur in mental ray” on 
page 309.

View, edit and blend between Cloth 
caches

This includes support for multiple Cloth caches per node and the 
implementation of core editing functions such as copying, 
blending and interpolation. This allows you to easily compare 
different simulations, to select the best parts of each and blend 
between them to produce the best possible overall result. For 
more information, see ”Advanced Cloth cache editing” on 
page 343.

Improved search and navigation in Maya 
Help

The Maya Help now has improved search, index, navigation and 
layout, letting you more easily find what you’re looking for. For 
more information, see ”Maya Help improvements” on page 48.
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2 General
Wheelmouse use

Maya now supports the use of scrolling wheels on mouse input 
devices. This feature allows you to:

• dolly in perspective or orthographic views

• zoom in the Hypershade, Graph Editor, Dope Sheet, Render 
View, Paint Effects, and other windows and editors 

• scroll in the Script Editor and Console window

Component Editor

The Component Editor’s performance has been improved, 
especially on large component sets.

We have added several display options. Instead of one List menu, 
there are now two menus, Options and Layout, and there are four 
new menu items: Hide Zero Columns, Sort Alphabetically, Show 
Selected Columns, and Show Selected Objects.

Options menu

• Auto Update

• Hide Zero Columns (New)

When this item is turned on, all columns whose values are 
zero are hidden (for example, a joint with no influence on 
vertices in the Smooth Skins tab). When this item is turned off, 
columns whose values are zero are shown.

• Sort Alphabetically (New)
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2 | General 
  > Layout menu
When Sort Alphabetically is turned off, the items that make 
up the columns are displayed in their order in the hierarchy. 
When Sort Alphabetically is turned on, the items are sorted in 
alphabetical order. 

• Show Path Name

• Change Precision

Layout menu

• Load Selected Components

• Show Selected Columns (New)

Removes all columns from the view, except those which are 
selected. This gives you a way to specify a set of influences/
joints and view only them.

• Show Selected Objects (New)

Allows you to view only those components which are 
influenced by a selected object. 

For example, create a Smooth Skinned object and select all of 
its CVs. The Component Editor shows all the CVs. If you 
select one of the influences and choose Show Selected Objects, 
you'll see only CVs for that influence; the others will be 
hidden.

• Show All Columns

Selective file loading

In Maya 6 you now have control over which references, at all 
levels in the hierarchy, you want to load with your file upon 
opening. 

We’re introducing a new concept—selective load settings—that 
refers to the state of reference loading when the top-level file of a 
series of referenced files is saved. This improves file opening 
performance in large scenes. 
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2 | General
 > Selective file loading
By saving out the selective load settings with a given file, or 
building a set before opening the file, you can cut down on the 
time it takes to open the file by only loading reference files of 
interest. 

The workflow is the following:

1 Decide if you want to open a file with references with the 
default (previous) selective load settings or if you want to 
specify which references to load when you open the file. 

2 Do one of the following:

• To open the file with the default settings, select File > 
Open and then select the file. Any referenced files that 
were saved as loaded with this file last time will be 
loaded now.

• To specify which references to load, select File > Open 
>  and turn on Selective Load. Then click Open and 
select your file. The Preload Reference Editor appears. In 
this editor, specify which references to load. See ”Preload 
Reference Editor” on page 30.

• To open a file with no references loaded, select File > 
Open > ❒  and turn on Load No References. Then click 
Open and select your file, which is opened with no 
references loaded. (You can also Load All References, an 
option which was available in previous Maya releases.)

• Use the MEL file command with new selective load of 
reference flags. See ”Selective load of references” on 
page 358.

Note Selective file loading works fastest when your file is 
saved with all references unloaded. File > Save As now 
has an Unload References option to facilitate this. 
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2 | General 
  > Preload Reference Editor
Preload Reference Editor

The Preload Reference Editor looks very much like the Reference 
Editor. It appears when you open a file when the Selective Preload 
option is turned on in the File > Open > ❒  window. 

To select which references will be read in (loaded) and 
which deferred (unloaded)

1 Select one or more items in the Preload Reference Editor.

2 Do one of the following:

• Click the checkbox next to each item.

• Right-click an item and select Bring in Reference Loaded 
or Bring in Reference Unloaded from the menu that 
appears. 

Note Loading and unloading references works hierarchically; 
that is, switching the top-level load status of a parent to 
unloaded means that all children references are also not 
loaded. 
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2 | General
 > File > Open Scene > 
File > Open Scene > 

There are two new options in File > Open Scene  > .

Load No References

This opens the file without loading any references. You can 
load references after the file is open in Maya by opening the 
Reference Editor (File > Reference Editor) and selecting the 
references you want to load.

Selective Preload

Selecting this option opens the Preload Reference Editor 
before opening any file. You can choose to load or defer any 
references in the file.

”Preload Reference Editor” on page 30

Reference Editor changes

• You can now edit reference paths in the Reference Editor, 
which allows you to specify a reference using relative paths 
and environment variables. 

Enter an environment variable or relative path in the 
Unresolved Name text box of the Reference Editor, and click 
Reload to load the reference from that location.
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2 | General 
  > Reference Editor changes
If Maya can’t find the referenced file in the specified location, 
it looks in several default locations to find the file.

• We have removed a number of the fields in the File 
Particulars section of the Reference Editor because they were 
uninformative. 

• There is a new column of icons to switch the loaded/
unloaded state of a reference in memory.

• There are two new items in the Reference menu:

• Load Related References. This loads references related to 
all selected objects.

• Unload Related References. This unloads references 
related to all selected objects.

• You can select multiple items in the Reference Editor and 
apply most operations to them (for example, loading and 
unloading references).
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2 | General
 > Selective file loading error handling
Selective file loading error handling

We’ve improved error handling for missing references. An 
warning dialog box appears if Maya cannot locate one or more 
references when opening a file.

You can choose to do one of the following:

• Abort File Read – Stops the file read operation. If a nested 
reference is being read, Abort File Read aborts the reference 
file read but may not stop the top level File Open operation.

• Skip – Skips the current missing reference (and all other 
references to the same file).

• Skip All – Skip this and all future missing references without 
showing the dialog box again.

• Browse – A file browser dialog box appears, allowing you to 
find the missing reference. If found, the new location is used 
for all references to that missing file. 

• Always Browse – A file browser dialog box appears for this 
and all future missing references without showing this dialog 
box again.

Reference locators and reference 
manipulation

You can create references with a locator, which names and shows 
the location of a reference. You can also manipulate references in 
the modeling view. 
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2 | General 
  > Reference locators
Reference locators

When you create a grouped reference with a locator, you can see 
and transform the locator in the modeling view whether the 
reference is loaded or not. 

References display in Maya with an RN suffix.

Note To have a locator on a reference, you must have created 
the reference with the Group and Locator options 
turned on in the Create Reference Options dialog box. 
See ”File > Create Reference > ❒ ” on page 35.

Locator of a 
loaded reference

Locator of an 
unloaded reference
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2 | General
 > File > Create Reference > ❒
File > Create Reference > ❒

There is one new option in File > Create Reference > ❒ .

Locator

When used with the Group option, groups the contents of the 
referenced file under a locator, annotated with the reference 
node name. The reference node has a message connection to 
the locator’s transform.

Reference manipulation

You can manipulate references on the locator or the reference 
contents.

To load an unloaded reference

1 Select the locator of an unloaded reference.

2 Right-click the locator and select Load Related Reference.

The reference appears within the Maya scene.

You can also select Load Related Reference from the Reference 
Editor.

To unload a reference

1 Select a loaded reference.

2 Right-click geometry or the locator of the reference and select 
Unload Related Reference.

The reference disappears from your Maya scene. If you added the 
reference with a locator, the locator continues to be visible.

You can also select Unload Related Reference from the Reference 
Editor.
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2 | General 
  > Preserve references
To reload a reference

1 Select a loaded reference.

2 Right-click the reference and select Reload Related Reference.

Preserve references

You can now select Preserve Reference when importing and 
exporting a file.

File > Import > , File > Export Selection > , 
File > Export All > 

There is one new option in File > Import > , File > Export All > 
, and File > Export Selection > .

Preserve References

If Preserve References is turned on, the references within the 
imported or exported file are preserved. If it is turned off, all 
references are imported into or exported within the file; that 
is, they are no longer references, but are now objects in the 
scene. The default is off.

Creating references vs. importing with 
preserved references

Importing with preserved references behaves differently than 
creating a reference. When creating a reference, the reference file 
is parented under the main scene file and the reference objects in 
the referenced file are children. 

Mainscene.ma

Refscene.ma

Sphere2.maSphere1.ma
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2 | General
 > Exporting references: all objects visible
However, importing references forces the references in the 
imported file to be children of the main scene file; that is, there is 
no additional reference node created. 

Exporting references: all objects visible

Because Maya is storing a reference in the exported scene, all of 
the objects in the reference file will be visible in the exported file. 
That is, if you attempt to export a single object from a referenced 
file with two objects while preserving references, both of those 
objects will be visible when loading the exported file.

Optimize scene size

The following improvements were made to the Optimize Scene 
Size menu item.

Speed boost

The Optimize Scene Size menu item is faster by 2-10 times, 
depending on the scene. In addition, the new progress reporting 
and interruptability features make it feel more responsive than 
before. 

Mainscene.ma

Sphere2.maSphere1.ma
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2 | General 
  > Shows progress
Shows progress

Maya now shows its progress as it optimizes. While Optimize 
Scene Size is running, the Command Line shows a progress bar 
for each optimization step.
 

Interruptability

You can press Esc at any time to interrupt the Optimize Scene Size 
process. If you’re interrupting a series of optimization steps, a 
dialog box appears asking you if you want to continue or abort.

(Restarting an interrupted optimization step produces the same 
result as if the step was run fully through the first time.)

Reporting

In the Script Editor, you get a list of all operations performed 
during optimization, and a final summary of all optimizations. 
For example:

[...]
Removing empty sets
-------------------
delete "__PrenotatoPerDuplicare_sine2Set8";
delete "tankRoll";
delete "tweakSet51";
delete "tweakSet52";

[...]

Optimize Scene Size Summary:
----------------------------
- Removed 0 invalid NURBS curves and surfaces
- Removed 0 unused constraints
- Removed 0 unused pairBlends
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2 | General
 > Individual optimizations
- Removed 119 unused deformers
- Removed 185 unused groupID nodes
[...etc....]

Individual optimizations

In the Optimize Scene Size options dialog box, you can click 
buttons to run different types of optimizations individually.

Add custom optimizations

Customizing this dialog box is done through the use of several 
MEL procedures. For more information, see ”Customizing 
Optimize Scene Size” on page 360.
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2 | General 
  > Default file loading
Default file loading

We've added options to File > New Scene that allows a default file 
to be loaded when you select New Scene. 

An example for using this is a default lighting rig. If you 
constantly create the same rig, the rig can be saved to a file and 
automatically loaded when you create a new scene.

File > New > ❒

There are two new options in File > New Scene > ❒ . 

Enable Default Scene

Turning on this option allows you to choose a file to be loaded 
into the scene whenever a new scene is created.

Default scene

Click the folder (browse) icon and select a Maya file.

Launching images and animations from 
Maya

There are two new menu items: File >View Image and File > View 
Sequence. These allow you to view an image or image sequence 
from within Maya. 

When you select one of these menu items, a file browser appears 
and you can select the image or image sequence to view. The 
image or image sequence is then displayed in FCheck.
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2 | General
 > Instance improvements
Instance improvements

Instance Leaf Nodes

We have added a new option that allows you to duplicate entire 
node hierarchies except for the leaf nodes, which are instanced to 
the original hierarchy. 

Edit > Duplicate > 

Instance Leaf Nodes 

Duplicate entire node hierarchies except for the leaf nodes, 
which are instanced to the original hierarchy. The new menu 
item is an improvement over the existing instance menu item, 
in that all dynamic attributes on the non-leaf nodes are 
properly duplicated into the new hierarchy. 

Freeze transform now works on hierarchies 
containing multiple instances

We have modified the Freeze Transformations menu item so that 
it functions on hierarchies that contain multiply-instanced shapes 
or transforms. 

Previously, this function could not be run on hierarchies that 
contained multiple instances. Now, this menu item freezes as 
much of the hierarchy as is possible given the instancing 
structure. After this operation, all transforms in the selected 
hierarchy will be set to the identity except in branches of the 
hierarchy that are multiply-instanced. When such unfreezable 
branches are encountered, Maya warns you which nodes were not 
frozen. 
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2 | General 
  > Script Editor changes
Script Editor changes

We have made changes that let you filter the output of the Script 
Editor in a more finely-grained way than was previously possible. 
You can choose to not show command results, info messages, 
warning messages, or error messages. (You cannot choose to 
suppress the output of print or eval echo.)

We have added four commands to the Script menu of the Script 
Editor:

Script > Suppress Command Results

When turned on, the Script Editor does not show the result of 
commands. Result messages start with // Result:. 

Script > Suppress Info Messages

When turned on, the Script Editor does not show informational 
messages. Informational messages are of many different types and 
do not have a set prefix (except for //).

Script > Suppress Warning Messages

When turned on, the Script Editor does not show warning 
messages. Warning messages start with // Warning:.

Script > Suppress Error Messages

When turned on, the Script Editor does not show error messages. 
Error messages start with // Error:.

The script editor menu items can also be controlled through the 
scriptEditorInfo command (-sr/suppressResults
 -si/suppressInfo, -sw/suppressWarnings, 
--se/suppressErrors). 
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2 | General
 > Other interface changes
Other interface changes

Hotkeys

New hotkeys allow you to change the user interface quickly:

• Ctrl+Space switches between the standard view and a full-
screen view of the current panels (the Status Line, Shelf, Tool 
Box, Time Slider, Channel Box, Attribute Editor, etc. are 
hidden).

• Alt+B changes the background color of the perspective and 
orthographic panels: standard (light gray), dark gray, or 
black. 

Node colors

You can change the color of nodes as they display in the 
Hypergraph.

Note Suppressing Script Editor messages does not suppress 
messages from appearing in the Help Line. 

Note You may need to go to the Hotkey Editor (Window > 
Settings/Preferences > Hotkey) and reassign the hotkeys 
(Alt+B, Ctrl+Space) to their current values in order to 
use these hotkeys in your Maya setup. 

To do so, use the following buttons: Query on the 
hotkey assignment, Find that assignment, and click 
Assign again.
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2 | General 
  > Improvements to selection of overlapping objects
To change a node color

1 In the Attribute Editor for that node, go to Drawing 
Overrides. You may have to expand Object Display to see this 
section.

2 Turn on Enable Overrides.

3 Set a color using the color slider.

You must have Node Display Override Color turned on in the 
Hypergraph to display color changes.

Changing the color of a layer overrides this node display setting.

The Drawing Override options allow you to change the display of 
the object in Maya: you can turn off the display of shading, 
texture, animation playback or whether that object is visible in the 
interface. As well, you can turn the object into a template or 
reference, and set the level of detail visible.

Improvements to selection of overlapping 
objects

The pop-up menu that appears when you try to select 
overlapping objects has been improved.

• Your selection now is highlighted in the scene view as you 
select an item in this list.

Note You must turn on Pop-up Menu Selection in the 
Selection section of Window > Settings/Preferences > 
Preferences to see this pop-up menu.
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2 | General
 > Outliner improvements
• Currently-selected items are marked with a box when the list 
appears.

Outliner improvements

You can now select User Defined from the Show > Attributes 
menu in the Outliner to show user-defined attributes.

Layer Editor improvements

In the Layer Editor (which displays along with the Channel Box), 
there are now new options and commands:

• Layer > Create Layer now has options, which allow you to:

• set the name and number of the layer you’re creating.

• make the created display layer current.

• decide what to add to the layer you’re creating (Nothing, 
Selected objects, or Selected objects and all their Children).

Note You must hold down the left mouse key on Linux and 
IRIX to select an item in this list.
What’s New in Maya 6

45



2 | General 
  > FCheck improvements
• Layers > Delete Unused Layers immediately deletes layers 
with no content.

• Layer > Sort Layers Alphabetically allows you to sort layers 
by name.

• Layer > Sort Layers Chronologically allows you to sort layers 
by the time they were created.

FCheck improvements

We have made the following improvements to FCheck on 
Windows.

Control Bar 

FCheck now has a Control Bar.

Use the Control Bar buttons for the following:

Go to first frame.

Go back one frame.

Play backwards. (Changes to Stop when 
playing backwards.)

Play forward. (Changes to Stop when 
playing forward.)

Go forward one frame.
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You can turn the Control Bar on and off using the View > Control 
Bar menu item.

New sound capabilities 

FCheck can import sound files, associate them with an image 
sequence, and play them back in sync with your image sequence. 
To import a sound file, select File > Import Sound. To turn sound 
on or off, select File > Toggle Sound.

New view capabilities

You can display your image at full screen size by choosing View > 
Full Screen.

Launch FCheck from Maya 

You can now launch FCheck from within Maya by selecting File > 
View Image, or File > View Sequence.

Go to last frame.

Shows frames per second.

Show alpha channel.

Show all channels.

Show Z buffer.
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Improved help system

FCheck has an improved help system available from the Help 
menu of FCheck.

Maya Help improvements

Maya Help and the MEL/Nodes/API reference documentation 
have new layouts with improved navigation and search.

Maya Help

Navigation

Maya Help now displays an improved navigation pane on the left 
with content appearing on the right.

Search

The Maya Help search now supports intelligent matching and 
wild cards, provides improved search ranking, and displays 
Information and Tutorials separately, letting you more easily 
focus your search.

Navigation

Content
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Index

Maya Help now includes an alphabetical list for easy access to the 
index.

Information and Tutorials

Maya Help content is now classified as Information or Tutorials. An 
icon identifies each topic as either Information or Tutorial. These 
icons are used throughout the Maya Help, letting you more easily 
find what you’re looking for.

Information

Tutorials

Search Tips

Clicking a 
letter...

...displays the 
index
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MEL Commands, Nodes, and API reference 
documentation

The technical reference documentation—MEL Commands, Nodes, 
and API—have improved navigation including:

• look and feel improvements 

• two-frame navigation (top navigation, bottom content) 

• four-column lists of MEL commands and nodes; two-column 
lists of API classes 

• improved alphabetical navigation 

• added Fn, It, and Px alphabetical categories for API 

• improved categorization for Command documentation 
including a new Curves category 

• substring search 

Information topics include definitions of Maya 
terminology, overviews of 3D concepts and Maya 
features, detailed descriptions of Maya features, 
and new features and improvements in Maya.

Tutorial topics include step-by-step instructions or 
lessons.
What’s New in Maya 6

50



2 | General
 > Web browser in a panel
Web browser in a panel

This feature is supported on the Windows, Mac OS X, and Linux 
platforms.

You can now use a Web browser within a Maya panel to browse 
through and view Web content, or issue MEL commands from an 
HTML page. This makes it possible to integrate Internet solutions 
into your Maya workflow.

This browser uses Gecko as a layout engine, employing Mozilla 
Open Source to properly display W3C compliant Web content. 
This means that you can add plugins to view Flash movies or do 
any of the other activities you’re used to doing from a Web 
browser window, all from a panel within the Maya interface. Just 
like any other Maya panel, the Maya browser can be placed in the 
main Maya window beside other panels, or into a separate 
window.

The Maya browser does not provide all of the features supported 
by your current Web browser, and is not intended as a 
replacement. For example, it won’t create multiple windows or 
popup windows, so links that create and open new windows will 
not work. As well, secure sites are not supported for this release.

Alphabetical

Substring search
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Examples of workflow

The Maya browser makes it easier for you to view Web content 
while you work in Maya, without having to flip between browser 
windows and the Maya interface. Some examples of what you can 
view from within your Maya window include:

• Help and tutorials, with the Maya interface in front of you to 
use while you follow instructions or look for interface controls

• Flash content that you’ve exported from Maya

• 2D images from the Internet (or from your organization’s 
intranet) that you can compare with models you are creating 
in Maya 

• Project criteria on the Web that you’re using to construct 
models, animations, and renderings

By issuing MEL commands from the Maya browser, you can:

• Design your own user interface for Maya using HTML and 
JavaScript

• Set up multiple controls (widgets) within HTML pages for 
easy reference, comparison, or tweaking of Maya characters

• Set up custom MEL tools to share over the Internet, or to 
interface with custom pipeline tools such as render farms

To access the Maya browser

1 Do one of the following:

• From any Maya panel, select Panels > Panel > Web 
Browser. The browser appears in the Maya panel.
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• Right-click a Quick Layout button and select the Web 
Browser Panel menu item:

2 Type in a URL or MEL command in the entry field. 

• Precede URLs with http:// 

• Precede MEL commands with mel://

Maya browser controls

The following controls are available in the Maya browser:
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Configuring the Maya browser

If you are on a LAN, you may need to set up one or more proxies 
to access external Internet servers. If you don’t know the name or 
port number of your proxy server, check the settings of your 
current browser, or contact your LAN administrator.

To configure the Maya browser for use with a network 
proxy

1 Select Window > Settings/Preferences > Preferences.

The Preferences dialog box appears.

2 Under Settings, select Web Browser from the Categories list.

3 Type in the appropriate settings under Network 
Configuration. You can choose from Direct Connection, 
Manual Proxy (which you must specify), or Automatic Proxy.

Type in URLs or MEL commands 

Refresh the page
Go to the browser homepage

Stop loading the requested page

Move forward or backward through previously viewed pages

Access bookmarks Open a file
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4 Click Save.

To set whether the Maya help opens in the Maya 
browser or an external browser

1 Select Window > Settings/Preferences > Preferences.

The Preferences dialog box appears.

2 Select Misc from the Categories list.

3 In the Help Browser section, select one of the following:

• Open Help In Main Maya Window – select this to launch 
the Maya online help in a panel

• Open Help Using External Browser – select this to launch 
the Maya online help in your default Web browser 
(default)

4 Click Save.

To set the home page

1 Select Window > Settings/Preferences > Preferences.

The Preferences dialog box appears.

2 Select Settings > Web Browser from the Categories list.

3 Type in the URL of the new home page, or click Use Current 
Page.
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4 Click Save. 

Examples of MEL Commands in the browser

You can communicate with Maya from its Web browser by using 
MEL commands, which you must precede by mel://

The following examples of Maya browser MEL code could be 
used in a Web page. They produce links that you click in the 
Maya browser to create and move a cube and a sphere.

<a href="mel://nurbsCube/">Create default cube</a><br>
<a href="mel://sphere -radius 3/">Create sphere with radius 3</a><br>
<a href="mel://select nurbsCube1/">Select cube</a><br>
<a href="mel://move -x 5/">Move cube 5 units along X axis</a><br>
<a href="mel://select nurbsSphere1">Select sphere</a><br>
<a href="mel://sphere -edit -radius 8 nurbsSphere1/">Change radius of 
sphere to 8</a><br>

Web browser menu items

File > Open

Lets you load a particular file.

File > Reload

Reloads a page with its latest version (to ensure that you’re not 
viewing a cached page).

File > Stop Loading

Stops the loading of a page.

Go > Back

Goes to previous pages.
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Go > Forward

When you are browsing through previous pages, goes to pages 
you had viewed subsequently.

Go > Home

Goes to the browser home page.
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Soft Modification Tool and Deformer

The new Soft Modification Tool lets you push and pull geometry 
as a sculptor would push and pull on a piece of clay.

By default, the amount of deformation is greatest at the center of 
the push/pull, and gradually falls off further away from the 
center. However, you can control the falloff of the deformation to 
create various types of effects.

The Soft Modification Tool is located in the Tool Box. The 
corresponding action is Deform > Soft Modification.

You can use the Soft Modification Tool on NURBS surfaces, 
polygonal surfaces, subdivision surfaces, curves, particles or any 
object with components.

Soft Modification Tool
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Deform > Soft Modification > 

These are the options in the Soft Modification Options window.

Falloff Radius

The radius that the deformation falls off to zero.

Falloff Curve

Controls the falloff of the modification.

Preserve History

When Preserve History is on, all nodes that the Soft 
Modification Tool creates are maintained. If you want to 
animate the effect of the soft modification deformer, you will 
need to turn on Preserve History to ensure the deformation 
history is maintained.

When Preserve History is off, the Soft Modification Tool 
attempts to remove the deformation history and all additional 
nodes that it creates. If you are using Soft Modification as a 
modeling tool, and do not want modeling history, you should 
turn off Preserve History. (In order to generate the correct 
result, the Soft Modification Tool can only delete deformation 
history when the underlying shape does not have existing 
history. If deformer history nodes are still created even when 
Preserve History is off, try deleting history on the target shape 
and then try deforming it again. See ”Example 2: Modeling 
without history” on page 67.)

Mask Unselected

Controls whether all components are deformed (off) or only 
selected components are deformed (on).
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Falloff Around Selection

On The falloff is radial around each selected 
vertex. This can produce more natural 
falloff, especially when the selected vertices 
form an unusual shape.

Off The falloff is spherical around the center of 
the selection.

When Falloff Around 
Selection is on, the 
falloff is radial around 
each selected vertex, 
producing a more 
natural falloff.
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Falloff Based On

The direction(s) in which the deformation falloff curve is 
applied. By turning off falloff along one or more directions, 
you can create various effects (for example, ramps, edges).

Notes

• Soft modification is like a deformer in that it works on 
clusters.

• You can control the effect of the soft modification by adjusting 
the Soft Modification Options, the soft modification 
manipulators, and the softMod node attributes.

• The Soft Modification Tool is similar to the Modify > 
Transformation Tools > Proportional Modification Tool. 
However, the Soft Modification Tool provides history and 
more control (for example, over falloff). The Proportional 
Modification Tool only works on components. The Soft 
Modification Tool works on components, objects or multiple 
objects. The Proportional Modification Tool only works on 
multiple NURBS surfaces. The Soft Modification Tool works 

Falloff 
Based On 
X, Y, Z Falloff 

Based 
On Y, Z

Falloff 
Based 
On X, Y
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on multiple surfaces of any surface type. The Soft 
Modification Tool can be used with the Deform > Edit 
Membership Tool.

Deforming objects or components with Soft 
Modification

To deform objects or components with Soft 
Modification

1 Select the objects or components you want to deform.

2 Select the Soft Modification Tool in the Tool Box or select 
Deform > Soft Modification.

3 Use the manipulator to create a deformation.

4 Adjust the softMod attributes to interactively modify the 
deformation.

To deform an object with Soft Modification

1 Select the Soft Modification Tool in the Tool Box or select 
Deform > Soft Modification.

2 Click the part of the object you want to modify.

3 Use the manipulator to create a deformation.

4 Adjust the softMod attributes to interactively modify the 
deformation.

Tip When you turn on Window > Settings/Preferences > 
Preferences > Settings > Selection > Click Drag Select, 
you can simply choose the Soft Modification Tool, and 
click-drag on the object to modify it. This lets you 
quickly perform several modifications on an object. See 
”Example 2: Modeling without history” on page 67.
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Example 1: Modeling with history

This example shows you how to interactively deform an object 
using the Soft Modification Tool.

1 Select the Soft Modification Tool in the Tool Box.

2 Click the part of the surface you want to modify.

3 Move the manipulator to create a deformation.

4 Click the cycling index to display the falloff manipulator.
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5 Drag the falloff manipulator circle to adjust the falloff radius.

6 Adjust the softMod node Falloff Curve to interactively adjust 
the falloff of the deformation.

Cycling index

Falloff manipulator
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7 Move the falloff manipulator to re-position the deformation.
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Example 2: Modeling without history

This example shows you how to quickly model an object using the 
Soft Modification Tool to push and pull the surface like a piece of 
clay without creating deformation history.

1 Select Window > Settings/Preferences > Preferences to open 
the Preferences window.

2 Select Selection, turn on Click Drag Select, and click Save to 
close the Preferences window.

3 Select the object you want to modify, and select Edit > Delete 
by Type > History to delete history on the object.

By deleting history on the object, and turning off the Preserve 
History option (see below), the Soft Modification Tool will 
attempt to remove the deformation history on the object.

4 Clear the selection (so the object is no longer selected).

5 Select Deform > Soft Modification > ❒ , and set the following:

• turn off Preserve History

Before After
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• turn off Mask Unselected

• turn off Falloff Around Selection 

Then click Soft Modification.

6 Click and hold the left mouse button on the part of the object 
you want to modify, and without releasing the mouse button, 
drag in the direction you want to deform the object.

7 Continue dragging different parts of the object to create the 
desired shape.
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Example 3: Moving a character’s ear

This example shows you how to move a character’s ear so that the 
skin surrounding the ear adjusts to accommodate the new 
position of the ear.

1 Select the vertices of the ear and surrounding skin that you 
want to move. Make sure you select the ear vertices on both 
sides of the head so the deformation will be symmetrical.

(The region surrounding the selection will deform so the 
vertices you move blend naturally into the surrounding area.)

AfterBefore
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2 Select Deform > Soft Modification > ❒ , and set the following:

• turn on Preserve History

• turn off Mask Unselected

• turn on Falloff Around Selection 

Then click Soft Modification.

3 Use the manipulator to move the ear (for example, up).
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4 Adjust the softMod attributes (for example, Falloff Radius, 
Falloff Curve) to interactively adjust how the new ear position 
blends into the surrounding skin.

Example 4: Symmetrically deforming a character’s nose

This example shows you how to symmetrically modify the nose 
on a character’s face using the Soft Modification deformer.

1 Select a single vertex in the center of the character’s nose.

AfterBefore
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2 Select Deform > Soft Modification > ❒ , and set the following:

• turn on Preserve History

• turn off Mask Unselected

• turn on Falloff Around Selection 

Then click Soft Modification.

3 Use the manipulator to create a deformation.
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4 Adjust the softMod attributes (for example, Falloff Radius, 
Falloff Curve) to interactively adjust the effect of the 
deformation (for example, to make the new nose shape blend 
smoothly into the rest of the face).

Polygon Mirror Cut

The new Polygons > Mirror Cut creates a plane of symmetry that 
mirrors the selected object. You can position the symmetry plane 
using the manipulator. Changes that you make to the original 
object are then updated on the mirrored object. This can make 
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symmetrical modeling of certain types of objects much easier (for 
example, creating an environment with streets, creating a 
skateboard park).

To model an object symmetrically with Mirror Cut

1 Select a mesh.

2 Select Polygons > Mirror Cut.

3 Use the manipulator to adjust the plane of symmetry.

Plane of symmetry

Click to show the 
Rotate manipulator
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Poly Mirror Cut Options

These are the options in the Poly Mirror Cut Options window.

Cut Along

The pair of axes to mirror the object across: YZ, XZ, or XY.

Combine Meshes

Combines the original object and the mirrored object into a 
single mesh. Changes that you then make to the original 
object are not updated on the mirrored object.

Merge Vertex Tolerance

Vertices within this distance of each other will be merged. 
This option is only available when Combine Meshes is on.

Smooth Proxy

The following improvements have been made to Polygons > 
Smooth Proxy:

• Performance improvement

Notes • If you position the plane of symmetry so it is beyond 
the positive edge of the original object, then both the 
original object and its mirror image will disappear 
(except for one face on each). If you want to mirror 
the object in the direction of its positive edge, then 
move the symmetry plane so it intersects the original 
object and rotate the symmetry plane 180 degrees.

• When you delete history of an object on which you 
have applied Polygons > Mirror Cut, the plane of 
symmetry is not deleted. You must manually delete 
the plane of symmetry.
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• Mirroring

• Share Transform Node

• Proxy Mesh Renderable

• Hotkeys

• Smooth UVs on non-manifold geometry.

Performance improvement

Polygons > Smooth Proxy now performs much faster:

• When tweaking the base mesh vertices, Smooth Proxy is at 
least six times faster than in Maya 5.0. (When Subdivision 
Method is Linear and the object contains triangles or polygons 
with more than four edges, then the performance will be the 
same as in Maya 5.0.)

• For small models, interactive edits are at least 3 times faster 
than in Maya 5.0. The performance improvement increases 
with larger models. For example, for a large model with 40k 
faces, and using 1 level of subdivision, the performance 
improvement is 18 times faster than in Maya 5.0.

• Playback (when the base mesh vertices have been keyframed) 
is now faster.

Mirroring

Polygons > Smooth Proxy has new options that let you create a 
symmetrical smooth proxy.

Mirror Behavior

Controls how the smooth mesh and proxy mesh are mirrored 
and/or located relative to each other.

None The smooth mesh is created within the 
proxy mesh.
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Full The smooth mesh is created within the 
proxy mesh, and both the proxy mesh and 
the smooth mesh are mirrored about the 
Mirror Direction.

Adjustments that you make to one half of 
the proxy mesh are automatically mirrored 
onto the other half, making symmetrical 
modeling much easier.

Half The smooth mesh is created adjacent to the 
proxy mesh (based on the Mirror Direction). 
This allows you to modify the proxy mesh 
and clearly see the result on the smooth 
mesh.

Before

None

Full

Half
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Mirror Direction

The direction that the selected mesh will be mirrored.

Smooth Proxy will mirror the proxy mesh at the extent of its 
bounding box in the Mirror Direction.

Merge Vertex Tolerance

When a vertex on the original mesh and its corresponding 
mirrored vertex are closer than the Merge Vertex Tolerance, 
then they will be merged into a single vertex.

Note You would usually use mirroring for modeling an object, 
not animating it. Otherwise, the object’s animation 
would be symmetrical.

After you have finished modeling an object with 
mirroring, use Polygons > Unmirror Smooth Proxy to 
remove the smooth mesh (see ”Unmirror Smooth 
Proxy” on page 82). Then create a new smooth proxy 
(with Mirror Behavior set to None) for animating the 
object.

Note If you modify the mirrored half of the smooth proxy in 
object space mode, dragging a manipulator in one 
direction will modify the proxy in the opposite direction.

If you modify the mirrored half of the smooth proxy in 
world space mode, dragging a manipulator in one 
direction will modify the proxy in the same direction.

If you modify the original half of the smooth proxy, in 
object space or world space mode, dragging a 
manipulator in one direction will modify the proxy in 
the same direction.
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Example

1 Select a mesh.

2 Select Polygons > Smooth Proxy > ❒ , set Mirror Behavior to 
Full, set the Mirror Direction, and click Smooth. The original 
mesh is mirrored along the Mirror Direction.

3 Modify one half of the smooth proxy (for example, using Edit 
Polygons > Extrude Face). The modification automatically 
updates on the opposite half of the smooth proxy.
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Share Transform Node

Polygons > Smooth Proxy has a new Share Transform Node 
option that controls whether the smooth mesh is transformed 
when you transform the proxy mesh.

For example, you may prefer to move the proxy mesh away from 
the smooth mesh in order to adjust the proxy mesh and clearly see 
the effect on the smooth mesh. In this case, turn off Share 
Transform Node.

Or you may prefer to keep the proxy mesh and smooth mesh 
together. In this case, turn on Share Transform Node.

Share Transform Node

On If you transform the proxy mesh, the 
smooth mesh will also be transformed.

Off If you transform the proxy mesh, the 
smooth mesh will not be transformed.

Tip When working with Smooth Proxy, you can save the 
low-res mesh and use it for fast interactive playback.

Use Polygons > Smooth Proxy with Share Transform 
Node turned off. Bind the proxy mesh to a skeleton, and 
hide the smooth mesh using the hotkey ` (left open 
quote beside the 1 key). The low-res mesh will provide 
fast interactive playback.

To display the smooth mesh (for example, for 
rendering), press the ` hotkey again. (Or turn off the 
Proxy Mesh Renderable option so the proxy mesh is not 
rendered.)
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Proxy Mesh Renderable

Polygons > Smooth Proxy has a new option that lets you control 
whether the proxy mesh is rendered or not.

Proxy Mesh Renderable

Controls whether the proxy mesh is rendered (on) or not (off).

Hotkeys

Polygons > Smooth Proxy now uses the following hotkeys.

Previously, the ` hotkey was used to set keyboard focus to the 
Command Line.

` (left single quote 
beside the 1 key)

Turns on/off the display of the proxy mesh 
or the smooth mesh.

Shift + ` Displays both the proxy mesh and the 
smooth mesh.

Ctrl + ` Polygons > Smooth Proxy

Ctrl + Shift + ` Polygons > Smooth Proxy > ❒

Page Up Increases the denseness of the smooth 
mesh.

Page Down Decreases the denseness of the smooth 
mesh.
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Unmirror Smooth Proxy

The new Polygons > Unmirror Smooth Proxy removes the smooth 
mesh created by Polygons > Smooth Proxy (with Mirror Behavior 
set to Full) and combines the two halves of the proxy mesh (the 
original mesh and the mirrored mesh) into a single mesh (similar 
to using Polygons > Mirror Geometry on the original mesh).

Adjustments that you make to one half of the mesh will no longer 
be automatically mirrored onto the other half.

After you have created a symmetrical model using Polygons > 
Smooth Proxy (with Mirror Behavior set to Full), use Polygons > 
Unmirror Smooth Proxy to remove the smooth mesh. Then use 
Polygons > Smooth Proxy (with Mirror Behavior set to None) to 
create a smooth mesh that you can animate non-symmetrically.

Unmirror Direction

The direction that the original proxy mesh will be mirrored. 
(Set Unmirror Direction to the same setting you used for 
Mirror Direction with Polygons > Smooth Proxy.)

Smooth UVs on non-manifold geometry

Polygons > Smooth Proxy can now smooth UVs on non-manifold 
geometry. Previously, the Polygons > Smooth Proxy operation 
would fail on non-manifold geometry unless Smooth UVs was 
turned off.

Vertex Normal Edit Tool

The new Edit Polygons > Normals > Vertex Normal Edit Tool lets 
you adjust the user-defined normal of a vertex (or several selected 
vertices) using a manipulator, for example, in order to make sharp 
corners appear smoother or to adjust the lighting on a polygonal 
object. (Previously you had to adjust normals using Edit Polygons 
> Normals > Set Vertex Normal and entering values numerically.)
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Vertex Normal Manip Settings

These are the options in the Vertex Normal Manip Settings 
window.

Rotate Mode

Local Rotates the vertex normal about the object 
space axes.

Global Rotates the vertex normal about the world 
space XYZ axes.

Deformable

Allows user-defined vertex normals to be affected by 
skinning.

On Vertex normals will be modified by the 
same weight skinning as the vertex.

Off Vertex normals will remain in the original 
object space.

A cube with default 
vertex normals.

A cube with vertex 
normals modified to 
simulate lighting.
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Modify Curve Tools

Several new curve modification tools have been added to the Edit 
Curves > Modify Curves menu. These tools are especially useful 
for modifying curves that have many CVs. These tools work on 
selected curves or selected CVs.

Lock Length

When you select Edit Curves > Modify Curves > Lock Length, the 
selected curve (or selected CVs) will maintain a constant hull 
length. If you then modify the curve, for example, by moving a 
CV, the shape of the curve will adjust so that it maintains a 
constant hull length (that is, CVs other than the one you move 
will also move).

When you select Edit Curves > Modify Curves > Lock Length, a 
Lock Length attribute is added to the curveShape node.

Tip Because Straighten, Smooth, Bend, and Scale Curvature 
are actions that you apply to curves, you cannot 
interactively adjust their effect as you would with a tool. 
However, you can set the scaling of the tool very low 
(for example, set Straightness to 0.1) and repeatedly 
apply the action until the curve has the desired shape.

Note These tools are also included in the Hair > Edit Curves 
menu in Maya Unlimited. For more information on hair, 
see ”Long hair and dynamic curves for Maya 
Unlimited” on page 21.
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Notes

• You can use the l (lower-case L) key as a momentary hotkey. 
Press and hold down the l key to lock the length of the 
selected curve. Release the l key to unlock the length of the 
curve.

• Lock Length is useful for modeling purposes. Because 
modifying a curve with Lock Length turned on behaves 
similar to a dynamic simulation, animating a curve in this 
way (with keyframes) may produce unexpected results.

• If you turn on Lock Length, move a CV and then select Undo, 
only the CV you moved will return to its original position.

• If you turn on Lock Length and modify the curve, the curve’s 
first CV will not move (unless you explicitly move the first 
CV). For example, if you move the curve’s first CV, the curve 
will respond differently than if you move the curve’s last CV.

Unlock Length

When you select Edit Curves > Modify Curves > Unlock Length, 
the selected curve (or selected CVs) will no longer maintain a 
constant hull length. If you then modify the curve, for example, by 
moving a CV, the curve’s hull length will not remain constant 
(and only the CV you move will actually move).

When you select Edit Curves > Modify Curves > Unlock Length, 
the curveShape’s Lock Length attribute is turned off.

Straighten

Makes the selected curves (or selected CVs) straighter (in the 
direction of the curve’s first segment). The curve’s first CV will 
maintain its original position.

Straighten Curves Options

These are the options in the Straighten Curves Options window.
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Straightness

Determines how much each segment of the selected curves 
will be straightened. The higher the Straightness, the greater 
the effect. The effect will be greater on a curve with many CVs 
than on a curve with few CVs because the Straightness affects 
each segment.

When Straightness is 0, selected curves will not be 
straightened at all. When Straightness is 1, selected curves 
will become entirely straight. When Straightness is 2, selected 
curves will be flipped so they have the opposite curvature.

Preserve Length

The selected curve will remain the same length after 
straightening. The curve’s first CV will maintain its original 
position, but its last CV will change position. (If you are 
applying Straighten to selected CVs with Preserve Length on, 
then some non-selected CVs may also be affected.)

If preserve Length is off, the curve’s first and last CVs will 
both maintain their original positions.

Curve after Straighten with Preserve Length OFF
Curve after Straighten with Preserve Length OFF

Original Curve

Curve after Straighten with Preserve Length ON

Curve after Straighten with Preserve Length ON
What’s New in Maya 6

86



3 | Modeling
 > Smooth
Smooth

Makes the selected curves (or selected CVs) smoother. The curve’s 
first and last CVs will maintain their original positions.

Smooth Curves Options

This is the option in the Smooth Curves Options window.

Smooth Factor

Determines how much each segment of the selected curves 
will be smoothed. The higher the Smooth Factor, the greater 
the effect. The effect will be greater on a curve with many 
CVs, than on a curve with few CVs, because the Smooth 
Factor affects each segment.

Curl

Makes the selected curves (or selected CVs) curly so they 
resemble a helix. The curve’s first CV will maintain its original 
position.

Curl Curves Options

These are the options in the Curl Curves Options window.

Curl Amount

Determines how much each segment of the selected curves 
will be curled. The higher the Curl Amount, the greater the 
effect. The effect will be greater on a curve with many CVs 
than on a curve with few CVs because the Curl Amount 
affects each segment.

Tip Do not apply Curl to a curve twice. The second Curl 
will produce poor results because it is trying to curl a 
curve that is already curly.
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Curl Frequency

Determines how many curls the selected curves will be curled 
into.

Bend

Makes the selected curves (or selected CVs) bend in one direction. 
The curve’s first CV will maintain its original position.

Bend Curves Options

These are the options in the Bend Curves Options window.

Bend Amount

Determines how much each segment of the selected curves 
will be bent. The higher the Bend Amount, the more the curve 
will be bent. A curve with many CVs will be bent more than a 
curve with few CVs because the Bend Amount affects each 
segment.

Twist

Controls the direction in which the selected curves will be 
bent.

Scale Curvature

Makes the selected curves (or selected CVs) straighter or 
exaggerates their existing curvature, depending upon the Scale 
Factor and Max Curvature values.

Scale Curvature Options

These are the options in the Scale Curvature Options window.

Scale Factor

Determines how much each segment of the selected curves 
will be straightened or have their existing curvature 
exaggerated. The higher the Scale Factor, the greater the 
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effect. The effect will be greater on a curve with many CVs 
than on a curve with few CVs because the Scale Factor affects 
each segment.

If Scale Factor is less than 1, the selected curves will become 
straighter.

If Scale Factor is greater than 1, the selected curves will have 
their existing curvature exaggerated (by exaggerating the 
curvature of each segment in the same direction as its existing 
curvature).

Max Curvature

Controls the maximum angle allowed between adjacent 
segments.

If Max Curvature is 1, then the maximum angle allowed 
between adjacent segments is 180 degrees. If Max Curvature is 
0.5, then the maximum angle allowed between adjacent 
segments is 90 degrees.

Polygon Smooth

Polygons > Smooth can now smooth UVs on non-manifold 
geometry. Previously, the Polygons > Smooth operation would 
fail on non-manifold geometry unless Smooth UVs was turned 
off.

Note If the selected curve already has adjacent segments with 
an angle greater than that allowed by the Max 
Curvature value, and you apply Scale Curvature with a 
Scale Factor greater than 1 (that is, to exaggerate the 
curvature of the curve), the curve may actually become 
straighter. This is because the Max Curvature value is 
reducing the angle between adjacent segments.
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Subdivision Surface Polygon Proxy 
Mode

The performance of Subdiv Surfaces > Polygon Proxy Mode has 
improved. When editing native subdiv surfaces by pulling CVs on 
the proxy cage, performance has been significantly improved. 
(This performance improvement does not apply when making 
topology changes to the poly cage.)

The performance is typically 8 times faster (than in Maya 5.0) 
when moving a small number of vertices, and 2.5 times faster 
when moving all vertices.

Polygon Bevel

Edit Polygons > Bevel has improved.

• Previously, you could potentially create inside-out bevels or 
bad geometry. This is now much less likely.

• Previously, Polygon Bevel may have inserted extra unwanted 
edges. This has now been fixed.

• Roundness can now be negative to create inward bevels.

• Polygon Bevel now works in worldspace by default.

• Polygon Bevel now preserves UVs on unbeveled faces.

Tip If you find it difficult to work with Subdiv Surfaces > 
Polygon Proxy Mode because the subdivision surface 
and the polygon proxy are the same color (for example, 
light blue), set your preferences so subdivision surfaces 
and polygon surfaces are displayed in different colors. 
Select Window > Settings/Preferences > Colors and set 
the Active/Inactive colors for Polygon Surfaces and 
Subdivision Surfaces.
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• Polygon Bevel no longer triangulates faces with holes before 
beveling.

• When Segments is greater than 1, the profile of the bevel is 
now circular (previously it was not exactly circular) and the 
faces are now equally spaced.

• The Polygon Bevel Options window and the polyBevel node 
contain new options (see below).

Polygon Bevel Options

These are the options in the Polygon Bevel Options window.

Offset Type

Fractional The bevel will not be greater than the 
shortest edge (to prevent inside-out bevels).

Absolute Polygon Bevel behaves the same as it did in 
Maya 5.0.

Offset Space

Determines whether a bevel applied to a scaled object will 
also be scaled.

Tip You can use Edit Polygons > Bevel on a smooth proxy 
object to control the shape of the smooth proxy at a 
corner.

World Local
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World If you bevel a scaled object, the offset will 
ignore the scaling. This is now the default 
setting.

Local Polygon Bevel behaves the same as it did in 
Maya 5.0. If you bevel a scaled object, the 
offset is also scaled.

Offset Distance

Controls the distance between the original edge and the center 
of the offset face.

When Offset Type is Absolute, Offset Distance is the distance 
between the original edge and the offset face measured in the 
scene’s linear unit. This is like the radius of the bevel. A large 
Offset Distance can produce inside-out bevels.

When Offset Type is Fractional, Offset Distance is a value 
from 0 to 1 that controls the distance between the original 
edge and the center of the offset face. When Offset Distance is 
1, the distance will be the maximum possible that will not 
produce an inside-out bevel. An Offset Distance greater than 1 
will produce inside-out bevels.

0.2 0.5 0.8
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polyBevel node

Angle Tolerance

Polygon Bevel uses this angle to decide whether it needs to 
insert extra edges. If your model still has unwanted edges, try 
increasing this value to remove them.

Create Meshes Single Sided

The new menu item Polygons > Tool Options > Create Meshes 
Single Sided controls whether new polygonal meshes are created 
single-sided or double-sided.

When this is turned on, new polygonal meshes (for example, 
created by the polygon primitive tools or by polygonal 
operations) automatically have their Render Stats > Double Sided 
attribute turned off.

If your model has unwanted edges...

...try increasing Angle Tolerance
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UV Texture Editor

Several improvements have been made to the UV Texture Editor.

Pixel snap to center of pixel

Image > Pixel Snap now lets you snap to the corner or center of a 
pixel. Previously, it would only let you snap to pixel corners.

To control whether snapping is to pixel corners or centers, display 
the Move Tool options, (make sure focus is on the UV Texture 
Editor) and set Placement to Snap Corner or Snap Center.

Display improvements

The alternative display option added to the UV Texture Editor in 
Maya 5.0.1 has been improved to provide more control over the 
resolution of baked textures. Several display problems have also 
been fixed.

Whenever possible, baked textures make use of repeating regions 
to make best use of texture resolution.

Image > Editor Image > Display has been renamed to Image > UV 
Texture Editor Baking. The Editor Image button has been 
renamed to Bake editor texture on/off.

Image > Editor Image > Bake has been removed. The Bake button 
has been renamed to Force editor texture rebake. Now, when you 
select Image > UV Texture Editor Baking, the texture is 
automatically baked and stored in memory. (Previously you had 
to manually bake the texture, which was then saved to disk, in 
some cases taking several minutes.) You can control image quality 
by selecting Image > UV Texture Editor Baking ❒ .

File format support

Maya now supports the following file formats:
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• Adobe Photoshop (see ”Adobe Photoshop file support” on 
page 219)

• PNG (see ”Image file support” on page 365)

• DDS (see ”Image file support” on page 365).

Split Polygon Tool

When using the Edit Polygons > Split Polygon Tool, you can now 
click the right mouse button to finish the split. This lets you very 
quickly split successive polygons. Previously, you had to press y 
to finish the split.

Convert Polygons to Subdiv, NURBS to 
Subdiv

Modify > Convert > Polygons to Subdiv and Modify > Convert > 
NURBS to Subdiv now use the following hotkeys.

` (left single quote 
beside the 1 key)

Turns on/off the display of the original 
surface or the converted subdiv surface.

Shift + ` Displays both the original surface and the 
converted subdiv surface.

Alt + ` If a NURBS surface is selected: Modify > 
Convert > NURBS to Subdiv

If a polygonal surface is selected: Modify > 
Convert > Polygons to Subdiv

Alt + Shift + ` If a NURBS surface is selected: Modify > 
Convert > NURBS to Subdiv > ❒

If a polygonal surface is selected: Modify > 
Convert > Polygons to Subdiv > ❒
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Heads Up Display

Display > Heads Up Display > Poly Count now displays the 
number of triangles.

Curve/CV Selection

Several new actions let you easily adjust the selection of CVs for 
the active curve:

• Edit Curves > Selection > Select Curve CVs

• Edit Curves > Selection > Select First CV on Curve

• Edit Curves > Selection > Select Last CV on Curve

• Edit Curves > Selection > Cluster Curve (creates a cluster for 
each CV on the curve, for example, when building a 
character’s back with spline IK)

You can also access these actions for the active curve from the 
marking menu Ctrl + the right mouse button.

Page Up Increases the Display Level of the subdiv 
surface (when in subdivision surface 
standard mode).

Page Down Decreases the Display Level of the subdiv 
surface (when in subdivision surface 
standard mode).

Number of triangles
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Convert NURBS to Polygons as Single 
Mesh

Modify > Convert > NURBS to Polygons now has an Attach 
Multiple Output Meshes option that produces a single mesh (even 
if the original NURBS object consists of separate surfaces). (The 
new Merge Tolerance option controls how close vertices must be 
in order to be merged into a single mesh.)

For example, if you convert a NURBS cube (which consists of six 
separate faces), the resulting polygon cube will consist of a single 
mesh. Previously, the polygon cube would consist of six separate 
meshes.

This tool also works on trimmed surfaces.

Scale/Rotate Components About Object 
Pivot Point

The Scale Tool and Rotate Tool now have a Component Use 
Object Pivot option that lets you scale and rotate object 
components about the object’s pivot point.

Component Use Object Pivot is also included in the marking 
menus for the Scale Tool (r + the left mouse button) and the Rotate 
tool (e + the left mouse button).

Merge Vertices

Edit Polygons > Merge Vertices is now faster in most cases.
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Rebuild Curve

Edit Curves > Rebuild Curve now lets you set Number of Spans 
greater than 100.

Rebuild Surfaces

Edit NURBS > Rebuild Surfaces now has an enhanced version of 
the Rebuild Type named Match Knots that lets you set the new 
Rebuild Method option to Classic or Match.

Setting Rebuild Method to Match can produce better quality 
surfaces, especially if the rebuild or reference surface is periodic 
or if either surface does not have multiple knots at the ends.

Set Rebuild Method to Classic to maintain compatibility with 
Maya 5.0 files.

Sculpt Surfaces/Polygons Tools

The following tools now use the new Artisan architecture, 
providing a common, streamlined options interface:

• Edit Polygons > Sculpt Polygons Tool

• Edit NURBS > Sculpt Surfaces Tool (This tool also now 
respects Global Stitch.)

Freeze Transformations (makeIdentity)

Modify > Freeze Transformations has two new options (Normals, 
Only for non-rigid deformations) and the makeIdentity 
command has a new flag (-normal). These let you use Modify > 
Freeze Transformations on an object without modifying the 
object’s vertex normals as follows:
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• Vertex normals that have been modified by Edit Polygons > 
Normals > Set Vertex Normal (or the polyNormalPerVertex 
command) will now remain correct after using Modify > 
Freeze Transformations (or performing the makeIdentity 
command). Previously, using Freeze Transformations or 
makeIdentity would cause modified vertex normals to retain 
their object space values, which would be incorrect for the 
new transform and object space positions of the components.

• Vertex normals that have been modified as a result of a 
non-proportional scale will now remain correct after using 
Modify > Freeze Transformations (or performing the 
makeIdentity command).

-normal

The makeIdentity command now has a -normal (-n) flag. If this 
flag is set to 1, the normals on polygonal objects will be frozen. 
This flag is valid only when the -apply flag is on. If this flag is set 
to 2, the normals on polygonal objects will be frozen only if it’s a 
non-rigid transformation matrix (that is, a transformation that 
does not contain shear, skew or non-proportional scaling). The 
default behavior is not to freeze normals.

Freeze Transformation Options

Modify > Freeze Transformations has two new options.

Normals

The normals on polygonal objects will be frozen.
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Only for non-rigid deformations

The normals on polygonal objects will be frozen only if it’s a 
non-rigid transformation matrix (that is, a transformation that 
does not contain shear, skew or non-proportional scaling).

This option is only available when Normals is on.

Persistence of Backface Culling and Color 
Per Vertex Display Settings

Backface culling and color per vertex display settings for each 
mesh are now maintained when a scene is saved. Previously, 
these settings were not saved with the scene.

polyNormalPerVertex

The following improvements have been made to the 
polyNormalPerVertex command:

• The polyNormalPerVertex command now has an -allLocked 
(-al) flag that queries if all normals on the selected vertices are 
locked (frozen) or not. See ”Freeze Transformations 
(makeIdentity)” on page 98.

• The polyNormalPerVertex command now has a -deformable 
(-def) flag that allows user-defined vertex normals to be 
affected by skinning and other deformers.

Note You only need to turn on Normals if you are applying 
Modify > Freeze Transformation to an object that has 
been sheared, skewed or non-proportionally scaled. 
Turning on Normals will bake the normals so they will 
not update if you make subsequent tweaks to the 
object’s shape.
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• Previously, using the polyNormalPerVertex command with 
the -q and -fn flags would not return a result. This now 
queries if the normals on the selected vertices are locked or 
not.

Annotation Node

The annotationShape node now contains a Display Arrow 
attribute that lets you display or hide the annotation line and 
arrow.
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Redesigned Trax Editor

Improved Trax Editor

In Maya 6, the Trax Editor and non-linear animation workflow 
have been redesigned to address many issues.

When working with non-linear animation in Trax, you no longer 
have to manipulate clip values from the Channel Box, select 
characters from the Current Character Set drop-down list, or 
navigate your track hierarchy using the Trax Outliner.

You can now select and control characters and their clips, and 
navigate their hierarchies, all in the track view area of Trax. Also, 
you can now drag-and-drop animation clips between mapped 
characters. See ”Character > Character Mapper” on page 138 and 
”How do I map one character to another?” on page 134.

The following is a list of some of the new features in Trax:

• Organize and control all clips for each character in one step

• Lock, mute, and solo tracks

• Cycle, hold, trim, and scale clips using new clip interaction 
functionality

• Key into clips

• Create clips from animations that have expressions or 
constraints

• More intuitive display of animation blends

• Import and playback multiple audio clips
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Related topics

”New Trax Editor menu bar items” on page 110

”New Trax Editor toolbar buttons” on page 114

”New Trax Editor track control area” on page 116

”Revised Trax Editor track view area” on page 118

How do I use the new Trax Editor?

To load characters into Trax

1 Select the character you want to load from the scene view or 
from the Current Character Set drop-down list beside the 
Time Slider.

2 Do one of the following:

Track view area

 Menu bar
Toolbar

Trax timeline

Track control area
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• In the Trax toolbar, click the Load/Add Character button.

• In the Trax menu bar, select List > Load Selected 
Characters. See ”Load Selected Characters” on page 114.

The character appears in the track view area.

To highlight a character, group, or subcharacter in 
Trax

Select any clip that is under the character, group, or subcharacter 
you want to select.

To add a track to a character, group, or subcharacter

1 Select a clip in your character, subcharacter, or group.

2 Do one of the following:

• Drag the clip upwards or downwards.

Note When List > Auto Load Selected Characters is on, all 
selected characters are automatically loaded into Trax. 
See ”Autoload Selected Characters” on page 114.

Note When a character is highlighted in Trax, its summary is 
outlined in orange.

Highlighted 
character
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A black line appears above or below the selected clip’s 
track. This line indicates that Maya will insert a single 
track above or below the selected clip’s track when you 
release the mouse button.

• Right-click a track, and from the menu that appears select 
one of the following options: Insert Track Above or Insert 
Track Below. See ”Context-sensitive menus” on page 130.

These options insert a track above or below the selected 
clip’s track.

To remove a track from a character, group, or 
subcharacter

• Right-click the track you want to remove, and select Remove 
Track from the menu that appears.

The track you clicked and all its clips are deleted from its 
character, group, or subcharacter.

To remove all the empty tracks from a character

1 Highlight the character from which you want to remove all its 
empty tracks. See ”To highlight a character, group, or 
subcharacter in Trax” on page 105.

2 In the Trax menu bar, select Modify > Remove Empty Tracks. 

All the empty tracks are deleted from the highlighted character.

Black line indicates where Maya will insert the track
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To remove all the empty tracks from all the characters 
in Trax

1 Make sure that there are no characters highlighted in Trax.

2 In the Trax Editor, select Modify > Remove Empty Tracks.

All the empty tracks are deleted from all the characters in 
Trax.

To create a clip

1 Select a character from the scene view or from the Current 
Character Set drop-down list beside the Time Slider.

2 In the Trax toolbar, click the Create Clip  button.

A clip is created for the current character’s animation.

To create a constraint or expression clip

1 Select a character from the scene view or from the Current 
Character Set drop-down list that is constrained or is 
animated by an expression.

2 In the Trax menu bar, select either Create > Constraint Clip or 
Create > Expression Clip.

If the character has any constraint channels, then a constraint 
clip is created for those channels.

If the character has any expression channels, then an 
expression clip is created for those channels.

To copy and paste a clip within a character or between 
characters

1 Select the clip you want to copy.

2 Do one of the following:

• In the Trax menu bar, select Edit > Copy.
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• Right-click the selected clip and select Copy Clip from the 
context-sensitive menu that appears.

• Press Ctrl+c.

The selected clip is copied to your system’s virtual clipboard.

3 Right-click the track where you want to paste the copied clip.

4 Select Paste Clip from the menu that appears.

The copied clip is pasted to the specified character and track.

To create a group

1 Select a clip and Shift-click to select additional clips.

2 Do one of the following:

• In the Trax toolbar, click the Group button.

• In the Trax menu bar, select Edit > Group.

A new group containing the clips you selected appears under 
their respective character.

To create an audio clip

For more information, see ”Soundtrack” on page 120.

Do one of the following:

• In the Trax Editor, select File > Import Audio.

The Import File browser window appears.

• Browse for the .wav or .aiff file you want to place in Trax.

• Select the desired audio file and click Import.

Note Only copy and paste clips between characters if they 
have been mapped. See ”What is character mapping?” 
on page 134.
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The selected audio file appears as an audio clip in the 
Soundtrack. 

• Import (Maya main menu bar > File > Import) or drag the 
desired audio file from your desktop to the Time Slider.

The audio file automatically appears as a waveform in the 
Time Slider and as an audio clip under the Soundtrack in 
Trax.

To hear audio clips present in Trax

1 Right-click the Time Slider.

A pop-up menu appears.

2 Select Sounds > Use Trax Sounds.

The audio clips in Trax now play during animation playback.

To scale or move groups of clips

1 Select a clip and Shift-click to select additional clips.

The clip manipulator appears.

2 Do one of the following:

• Drag the clip manipulator’s scale handles (arrows) to 
scale all the clips in your selection.

• Drag the clip manipulator’s translate handle (circle) to 
move all the clips in your selection. 

For more information, see ”Scale and move multiple clips at a 
time” on page 127.

Note You can only move clips horizontally (side to side) using 
the manipulator’s translate handle.
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To view clips in the Outliner

1 Select Window > Outliner.

2 In the Outliner, turn off Display > DAG Objects Only.

3 Turn on Show > Objects > Clips.

All the source and regular clips in your scene are now listed 
in the Outliner. 

To set the Time Slider’s playback range to the range of 
the clips in Trax

1 In the Trax toolbar, click the Frame All  button.

All the animation and audio clips in Trax are now visible in 
the track view area.

2 Right-click the Time Slider.

A pop-up menu appears.

3 Select Set Range to > Enable Clips.

The Time Slider’s playback range is now the same as the 
range of clips in Trax.

New Trax Editor menu bar items

For information on all the Trax menu bar menus and options, see 
Trax menu bar in the Nonlinear Animation chapter of the 
Animation guide.

Tip You can create instances of clips by dragging them from 
the Outliner onto a character in the track view area of 
the Trax Editor.
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Character Mapper

Launches the new Character Mapper window. See ”Character > 
Character Mapper” on page 138.

Edit >

Trim Before

See ”Trim clip before current time” on page 116.

Trim After

See ”Trim clip after current time” on page 116.

Duplicate

In Maya 6, Instance and Duplicate have been combined under 
the same Trax menu item. When you duplicate a clip, a new 
track is generated and the copy of the clip is added to this 
track.

Duplicate 

Input 

Connections When on, creates a copy of the selected clip 
whose duplicate animation is independent 
of the original clip’s source animation. This 
means you can edit the animation on this 
new clip and it won’t affect the animation 
on your original clip—it will only affect the 
duplicate. This acts like Edit > Duplicate in 
Maya 5.0.

When off, creates a copy of the selected clip 
whose duplicate animation is dependent on 
the original clip’s source animation. This 
means any modifications made to the 
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original clip’s animation are propagated to 
the duplicate clip. This acts like Edit > 
Instance in Maya 5.0.

Duplicate Input Connections is off by 
default.

Put Copy in 

Visor Only Places the duplicate clip in the Visor only.

Put Copy in Visor Only is available only 
when Duplicate Input Connections is on.

Put Copy in 

Trax Editor 

and Visor Places the duplicate clip in both the Trax 
Editor and the Visor.

Put Copy in Trax Editor and Visor is 
available only when Duplicate Input 
Connections is on.

Duplicate 

Time Warp 

Curve When on, an independent copy of the 
selected clip’s time warp curve is created for 
the duplicate clip. This is useful, for 
example, when you want a group of 
characters to all have the same run cycle 
animations, but you want each of the 
characters to run at different speeds.

Note When you place clips in the Visor, you can then view 
and access them from the Outliner. See ”To view clips in 
the Outliner” on page 110.
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Instance Time 

Warp Curve When on, a dependent copy of the selected 
clip’s time warp curve is created for the 
duplicate clip. Any changes you make to the 
original clip’s time warp curve are 
propagated to the duplicate time warp 
curve. 

Instance Time Warp Curve is on by default.

No Time 

Warp Curve When on, the selected clip’s time warp 
curve is not copied to the duplicate clip.

Group

See ”Group” on page 115.

Ungroup

See ”Ungroup” on page 113.

View >

Frame Playback Range

Frames the current playback range in the Trax view area.

Center Current Time

Centers the Trax view area on the current time.

Note These new View menu items are also available in the 
Graph Editor and Dope Sheet.
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List >

Autoload Selected Characters

When on, any characters you select in either the scene view or 
the Time Slider’s Current Character drop-down list are 
automatically loaded into Trax. When you cancel your 
selection, all characters are automatically removed from Trax.

Load Selected Characters

Loads all selected characters into Trax. If you use Load 
Selected Characters, canceling your selection does not remove 
the characters from Trax.

Only available when Autoload Selected Characters is off.

Add Selected Characters

Loads the selected characters into Trax. Use this to add 
characters to Trax when you have already loaded a number of 
characters using Load Selected Characters.

Only available when Autoload Selected Characters is off.

New Trax Editor toolbar buttons

The new toolbar buttons in Trax let you easily access the most 
commonly used functions.

Create Clip Creates a clip with the keyframe 
animation of the current character.

Create Blend Creates a blend between two, selected 
clips. See ”Blends” on page 128.
What’s New in Maya 6

114



4 | Animation
 > New Trax Editor toolbar buttons
Get Clips Launches the Visor. For more 
information, see Visor in the Basics 
guide.

Frame All Makes all clips in Trax visible in the 
track view area. This button can also be 
found in the Graph Editor and Dope 
Sheet toolbars.

Frame 

Playback 

Range

Frames all the track view area contents 
within the Time Slider’s current 
playback range. This button can also be 
found in the Graph Editor and Dope 
Sheet toolbars.

Graph Anim 

Curves
Displays the current clip’s animation 
curves in the Graph Editor. See Graph 
Editor graph view in the Animation 
guide.

Load Selected 

Characters
Loads the character selected in the 
scene view into Trax.

Graph Weight 

Curves
Displays the selected clip’s weight 
curve in the Graph Editor.

Group Creates a group of clips under the 
current character and places the 
selected clips in tracks under that 
group. See ”Groups” on page 119.

Ungroup Removes the selected group from its 
character and places the group’s tracks 
directly under its character or parent 
group.
What’s New in Maya 6

115



4 | Animation 
  > New Trax Editor track control area
New Trax Editor track control area

The new track control area lets you lock, solo, or mute all the 
animation clips in a track.

Trim clip 

before current 

time

Removes the segment of the selected 
clip that comes before the Trax current 
time indicator’s position.

Trim clip after 

current time
Removes the segment of the selected 
clip that comes after the Trax current 
time indicator’s position.

Key into clip Sets a key on all the curves in the 
selected clip at the current position of 
the Trax current time indicator. See 
”Key into clips” on page 133.

Lock The Lock button freezes the current animation 
track. When a track is locked, you can not edit its 
clips, but its animation is present during playback.
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Solo The Solo button isolates the clips on the current 
track so that they are the only animation sequences 
that are played during playback for the character. 
Soloing is useful when you want to isolate and 
review a specific animation sequence for a 
character. You can solo single or multiple tracks at 
a time.

Mute The Mute button mutes all the clips on the current 
track. Muting suppresses or hides the animation 
on a track without removing it from the Trax 
Editor. Muting is useful when you want to 
suppress a specific animation sequence for a 
character during playback. See “Muting animation” 
in the Animation guide.
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Revised Trax Editor track view area

”New track hierarchy” on page 118

”New information displayed on clips” on page 121

New track hierarchy

Since the Trax Outliner has been removed for Maya 6, the way in 
which tracks appear has changed. We have enhanced groups to 
help you organize your scene and to create a hierarchy of clips in 
Trax. Also, the hierarchical relationships between tracks are now 
shown by their positions in the track view area.

Note In addition to tracks, you can also enable and disable a 
single clip. To enable or disable a clip, right-click the clip 
and select Modify > Enable/Disable from the menu that 
appears. See ”Context-sensitive menus” on page 130.
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Characters

The top-most level of each track hierarchy is always the character. 
A character in Trax can contain multiple tracks, groups, or 
subcharacters. See ”To load characters into Trax” on page 104.

Groups

Groups contain arbitrary collections of clips for a single character. 
You can collapse and expand groups just like you would a 
character. See ”To create a group” on page 108.

Subcharacters

When you add or display a character in Trax, all of its 
subcharacters are automatically placed under your character. 
Subcharacters and Groups exist on the same level under the 
character, and can be controlled in a similar manner. You do not 
need to have subcharacters to be able to work with a character’s 
animation in Trax.

Character

Subcharacter

Track

Track

Track

Group

Track

Track

Soundtrack

Audio Track

Audio Track
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Summaries

Each level in the Trax hierarchy has a summary. A summary gives 
you a high level of control over the collection of clips under a 
character, group, or subcharacter. 

You can collapse and expand summaries for characters, 
subcharacters, or groups by clicking the arrow that is beside each 
of their names in their respective summaries.

The summary clip represents all the clips under your character, 
group, or subcharacter. The length of a summary clip is 
determined by the cumulative range of all the clips under its 
character, group, or subcharacter.

You can drag the summary clip to move all the clips in all the 
tracks under a character, group, or subcharacter.

You can also scale a summary clip by Shift-dragging its beginning 
and end or by editing its Start and End frame numbers. When you 
scale a summary clip, all the clips under its character, 
subcharacter, or group are also scaled.

Soundtrack

You can now display and play multiple audio waveforms in Trax. 
The new Soundtrack lets you import .wav or .aiff audio files as 
clips. Once you import an audio file into Trax, you can then move 
and rename its audio clip.

Collapsed set of tracks for a character

Arrow Summary clip

Summary

Start and End frame numbers 
for the summary clip
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The play priority of audio clips goes from the top-most clip to the 
bottom-most clip. Also, you can play only one audio clip at a time 
and any new audio clips that you add to your scene appear at the 
bottom of the stack of audio tracks in the Soundtrack.

For example, if you have multiple audio tracks and clips that 
overlap in time, then the audio clip in the top-most track will 
always play instead of other audio clips on other tracks that are at 
the same position on the Trax timeline.

If you want to hear the audio clips that are present in your 
Soundtrack, see ”To hear audio clips present in Trax” on page 109.

New information displayed on clips

Source In/Out

Start and end frame numbers for the range of frames from the 
source clip contained in this animation clip. 

Does not play

Plays frames 0-97

Plays frames 98-168

Source In Source Out

Frame In Frame Out

Duration

Scale Clip Name
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When you create an animation clip, a source clip is automatically 
generated in addition to the clip that is created in the track view 
area. The source clip is placed in the Visor, and can only be 
modified from that location. This protects the source clip from 
being accidentally modified. Any modifications you make to a 
source clip are reflected in all the clips that originate from that 
source clip. Source clips are useful if you want to access or revert 
back to the original animation for a character. For more 
information on source clips, see “Nonlinear animation components in 
Trax” in the Animation guide.

When you trim a clip in Trax, you are excluding sections of 
animation from the beginning or end of a clip. This changes a 
clip’s Source In and Source Out times, but does not affect the 
source clip itself.

Frame In/Out

Current start and end frame numbers for a clip. These numbers 
control when a clip takes effect.

Duration

Number of frames over which the current clip’s source clip takes 
place. This value is affected by any modifications to the source 
clip’s Source Start or Source End attributes. Duration is read-only.

For more information on source clips, see “Nonlinear animation 
components in Trax” in the Animation guide.

Scale

The scale percentage for the current clip. The scale percentage is 
the multiplier on the length of the original animation clip. See 
”Scale” on page 125.
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Editable Clip attributes

You can now change any attributes (for example, name, duration, 
scale and so on) displayed on clips by double-clicking the 
attributes and entering a new value.

Time warp curve indicator

When you create a time warp for a clip, a new visual cue appears 
on the respective clip to indicate that it is influenced by a time 
warp curve.

This visual cue appears as a green colored bar at the top of the 
clip.

Weight curves on clips

When you animate the weight of a clip, a new visual 
representation of the Weight attribute’s curve appears on the clip.

Disabled clips

In the new Trax Editor, disabled clips appear dark blue in color. 
When a clip is disabled, its animation is suppressed during 
playback. Enabling and disabling a clip is just like muting or 
unmuting a track.

To enable/disable a clip, right-click the clip and select Enable Clip 
from the menu that appears. See ”Context-sensitive menus” on 
page 130.

Time warp
indicator

Weight curve
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Additional clip functionality

Expression and constraint clips

You can now create clips for animations with expressions or 
constraints. In the Trax Editor, you can access and edit your 
expression and constraint clips just like regular animation clips. 
Expression or constraint clips can contain only expression or 
constraint channels.

For example, if your animated character has both keyframe 
animation channels and expression channels, then you have to 
create a regular clip for the keyframe channels and a separate 
expression clip for the character’s expression channels. See ”To 
create a constraint or expression clip” on page 107. 

By separating expressions and constraints from regular animation 
clips, Maya gives you more control over when expressions and 
constraints contribute to a character’s overall animation sequence.

Clip interaction controls

Clips now have hotspots which you can drag to produce various 
effects. For example, if you drag the top-right corner of a clip, you 
Trim a clip. See ”Trim” on page 125, ”Scale” on page 125, ”Hold” 
on page 126, and ”Cycle” on page 126.

Disabled clip
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When you move your mouse pointer over a clip, white outlines 
appear around its hotspots when the pointer passes over them.

Trim

Drag the top corner clip hotspots to trim clips.

You can omit segments from the beginnings and ends of 
animation clips by trimming clips. This changes a clip’s 
Source In and Source Out times, but does not affect the clip’s 
source clip itself. See ”Source In/Out” on page 121. The 
segments that you omit from a clip using Trim are not 
deleted, and can be reinstated if the clip’s original length is 
restored.

Scale

Drag the lower corner clip hotspots to scale clips.

Drag to Scale 
Shift-drag to create a Cycle

Drag to Trim
Shift-drag to create a Hold 

Drag to Scale
Shift-drag to create a Cycle 

Drag to Trim

Clip hotspot

The Trim mouse pointer appears 
when you are trimming a clip.

The Scale mouse pointer appears 
when you are scaling a clip.
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When you reduce (<100% of the original clip length) or scale 
down a clip, you are actually compressing the animation on 
the clip, so that the resulting animation appears faster or sped 
up.

When you scale up a clip (>100% original clip length), you are 
actually extending the animation on the clip, so that the 
resulting animation appears to be slower.

Hold

Shift-drag the upper corner of clips to create holds after the 
original clip.

You can create holds for your animation clips. A hold is a part 
or an extension of a clip where the last pose is held for a 
specified period of time. Holds are represented by the letter 
H.

Cycle

Shift-drag the lower corners of clips to create cycles before 
(pre-cycle) or after (post-cycle) the original clip.

The Hold mouse pointer appears when 
you are creating a hold for a clip.

End of original clip/start of Hold
Hold

# of frames held

End frame for Hold

The Cycle mouse pointer appears when 
you are creating a cycle for a clip.
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You can repeat an animation contained in a clip by extending 
the clip with duplicate animation sequences called cycles. You 
can create whole or partial cycles. The end of the original clip, 
and the beginning of the first cycle, is marked by a small 
vertical line. The end of each cycle sequence for a clip is 
marked by a small cycle tick or marker.

Cycles are represented by the letter C and appear a lighter 
blue than the rest of the clip. 

Scale and move multiple clips at a time

You can now select multiple clips (Shift-click) in one or more 
characters and move or scale them all at once using the new clip 
manipulator.

Cycle

Cycle markerEnd of original clip/start of cycle(s) # of cycles

End frame for clip

Translate handle

Scale handles
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For information on how to use the clip manipulator, see ”To scale 
or move groups of clips” on page 109.

Blends

When you apply a blend to clips, a new visual cue appears on (if 
clips are overlapping) or between (if there is a gap in time 
between the clips) the blended clips. Also, the parts of clips that 
overlap in blends are now colored differently than the rest of the 
clips.

Blends between animation clips are indicated by green arrows 
and the regions of overlap between blended clips appear green.

If clips that participate in a blend do not overlap in time, then 
only a green arrow appears connecting the blended clips. The 
green arrow is drawn from the end of the first clip in the blend to 
the beginning of the second clip in the blend.
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To select a blend region

Select the blend’s green arrow.

Non-overlapping clips on different tracks with a blend 

Non-overlapping clips on the same track with a blend 

Overlapping clips on different tracks with a blend

Selected 
blends
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To delete a blend

1 Select the blend that you want to remove.

2 Press Delete.

To edit a blend’s values

1 Select the blend that you want to edit.

2 Open the Attribute Editor (press Ctrl+n).

3 Set the blend’s Weight attribute and select a rotation 
interpolation type from the Rotation Blend drop-down list.

For more information, search the online help for Rotation Type.

To graph a blend’s weight curve

1 Select the blend whose curve you want to edit in the Graph 
Editor.

2 Do one of the following:

• In the Trax toolbar, click the Graph Anim Curves  
button.

• In the Trax menu bar, select View > Graph Anim Curves.

The Graph Editor appears with the weight curve for the 
selected animation blend framed in its graph view.

Context-sensitive menus

Now when you right-click anywhere in the track view area, a 
context-sensitive menu appears depending on where you click. 

This section contains a selection of the available
context-sensitive menu items, since most of the options in the 
context-sensitive menus can be found in the Trax menu bar. See 
”New Trax Editor menu bar items” on page 110.
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For detailed descriptions of all the options that appear in the Trax 
context-sensitive menus, see Context-sensitive menu in the 
Nonlinear chapter of the Animation guide.

Summaries

When you right-click on a summary or a track, the following 
items are present in the context-sensitive menu that appears:

• Paste Clip

Places the clip copy present in your system’s clipboard at the 
current time in the track, group, or character you are clicking 
on.

• Import Clip to Character

Lets you import a clip from your disk to the character or 
group you are clicking on. Opens the Import file browser 
window. 

Tracks

• Paste Clip

See above section.

• Import Clip to Character

See above section.

• Insert Track Above

Creates a single, empty track above the track you are clicking 
on.

• Insert Track Below

Creates a single, empty track below the track you are clicking 
on.

• Remove Track

Deletes the track—including all the clips it contains—you are 
clicking on.
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Clips

When you right-click on a single clip, the following items are 
present in the context-sensitive menu that appears:

• Enable Clip

Lets you enable or disable the clip you are clicking on. When 
a clip is disabled, the animation on the clip does not play 
during playback. See ”Disabled clips” on page 123.

• Relative Clip

Relative Clip lets you set the offset type for the clip you are 
clicking on. When on, the selected clip’s offset is set to 
relative. When off, the selected clip’s offset is set to absolute. 

• Activate Keys

Activate Keys lets you key into a clip from outside of the Trax 
Editor. When Activate Keys is on for a clip, manipulating and 
keying the objects whose curves are in that clip from the scene 
view automatically places all those keys in the clip. Also, 
when Activate Keys is on for a clip, all that clip’s keys appear 
in the Time Slider. See ”Key into clips” on page 133. 

• Select Character Set Members

Selects all the objects in the clip’s character set in the scene 
view.

• Select Source Clip

Selects the source clip for the clip you are clicking on.

Note In addition to the above items, Blend appears as an 
option in the context-sensitive menu when two clips are 
selected.
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Absolute Rotations

With the new Absolute Rotations attribute for clips, you can now 
specify whether the animation contained in the clip has relative or 
absolute rotations. This is useful when you want to create a 
sequence of cycled animation.

For example, if you want to create a walk cycle, the animation clip 
should have a relative offset (translation) so that your character 
doesn’t jump back to its initial position at the end of each cycle 
and you want the cycle to have absolute rotations.

Key into clips

In Maya 6, there are two ways you can key into clips:

• Key into clips from the Trax Editor

• Key into clips from the scene view

To key into a clip from the Trax Editor

1 In the scene view, select and transform an object whose 
animation curves are in a clip.

2 In the Trax Editor, select the clip that contains the animation 
curves for the object you transformed in step 1.

3 Click the Key into Clip icon in the Trax toolbar.

Keys are placed at the current time on all the animation curves in 
the selected clip. If you key into a clip (original) that has 
duplicates (dependent copies), those keys are also inserted into 
the duplicate clips.

To key into a clip from outside of the Trax Editor

1 Select the clip in which you want to place keys.

2 Right-click the clip.

The Trax context-sensitive menu appears.

3 Select Activate Keys to turn it on in the menu.
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The clip is now active. The clip turns purple to indicate that 
when you now set keys for the objects whose animation 
curves are in the active clip, all those keys are automatically 
placed in the clip. Also, all the active clip’s keys now appear 
in the Time Slider.

4 In the scene view, transform and key (press s) the objects 
whose animation curves are in the active clip in Trax. 

All keys automatically appear on the animation curves in the 
active clip in Trax.

New Character Mapper window

What is character mapping?

Use the Character Mapper to create a correspondence between a 
source and target character’s nodes or attributes so that you can 
import and export or copy and paste animation clips between the 
mapped characters in the Trax Editor.

Mapping or linking one character’s nodes and attributes to that of 
another character creates a characterMap node. This node stores 
the array of connections between the mapped nodes and 
attributes. The information stored on this node can only be 
accessed by Maya.

How do I map one character to another?

For more information on mapping character animation, see 
”Character > Character Mapper” on page 138.
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To map animation from one character to another

1 Select Character > Character Mapper.

The Character Mapper window appears.

2 Select the root joint of your source character.

3 In the Character Mapper window, click Load Source.

The source character’s name appears in the From: field and all 
the names of its nodes or attributes appear in the left 
Unmapped column.

4 Select the root joint of your target character.

5 Click Load Target.

The target character’s name appears in the To: field and all the 
names of its nodes or attributes appear in the right 
Unmapped column.

6 Select one node or attribute from the left unmapped column, 
and select its corresponding node or attribute in the right 
column. For example, if the left ankle joint for your source 
character is lfoot and the left ankle joint of your target 
character is named joint29, then your selection would 
resemble the following:

7 Click Map.
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The nodes or attributes that you selected in the Unmapped 
columns now appear as a pair of nodes or attributes in the 
Mapped column.

8 Repeat steps 6 and 7 until you have mapped all the nodes or 
attributes from the source and target characters.

Now you can copy and paste animation clips between the 
mapped characters in the Trax Editor.

To map animation from one character to another 
based on hierarchy

1 Select the root joint of your source character.

2 Shift-click to select the root joint of your target character.

3 Select Character > Character Mapper.

The Character Mapper window appears with the source and 
target characters already loaded.

The name of the first character you selected appears in the 
From field and all its nodes or attributes appear in the 
lefthand Unmapped column. The name of the second 
character you selected appears in the To field and all its nodes 
or attributes appear in the righthand Unmapped column.

4 Do one of the following:

• In the Character Mapper, select Edit > Map based on 
hierarchy.

The character mapper searches for the source and target 
character’s root joints, maps the roots, and then continues 
down the hierarchy mapping each of the character’s nodes 
or attributes.
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• Select a node or attribute from both the Source and Target 
character.

• In the Character Mapper, select Edit > Map based on 
hierarchy.

The character mapper finds the selected nodes or 
attributes in the Source and Target character’s 
hierarchies, maps those nodes or attributes, and from 
there continues down the hierarchy mapping each 
node or attribute. For example, if the you selected the 
Source and Target character’s left_hip joints, then the 
character mapper would automatically map those 
nodes and then would continue down the hierarchy 
(left_knee, left_ankle, and so on) mapping each node.

Workflow for mapping characters

• Open the Character Mapper window.

• Select the character from which you want to copy clips.

This character is the source character.

• In the Character Mapper, click Load Source.

All the nodes or attributes for the source character appear in 
the lefthand Unmapped column.

The state of the menu items Display Node Names and Display 
Channel Names determines whether node or attribute names 
appear in the Unmapped and Mapped columns. See ”Display 
Node Names” on page 140 and ”Display Channel Names” on 
page 140.

• Select the character to which you want to paste clips.

This character is the target character.

• In the Character Mapper, click Load Target.

All the nodes and attributes for the target character appears in 
the righthand Unmapped column.
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• Select pairs of corresponding nodes or attributes from the left 
and righthand Unmapped columns, and click Map.

The mapped pairs of nodes or attributes appear in the 
Mapped column.

Creating these pairs of mapped nodes or attributes generates a 
character map between the source and target characters. See 
characterMap.

Character > Character Mapper

The new Character Mapper window lets you map animation from 
one character (source) to another (target) character. Use the 
Character Mapper to establish a relationship between a source 
and target character’s nodes or attributes so that you can import 
and export or copy and paste animation clips between the 
mapped characters in the Trax Editor. 

There are four different ways you can view a character’s mapped 
and unmapped nodes or attributes in the Character Mapper: 
Hierarchical, Alphabetical, Node, and Channel views. See ”Show 
menu” on page 139. These views can help you better navigate 
long node or attribute lists (hierarchical or alphabetical) and 
isolate specific nodes (Node view) or animation channels 
(Channel view).

The Character Mapper is most useful when you want to map 
animation from one similar character to another. For example, 
mapping the animation from the translateX channel of one biped 
character to the translateZ channel of another biped character.
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Show menu

Alphabetical

Lists the nodes or attributes in the Mapped and Unmapped 
columns alphabetically, starting with A.

Hierarchical

Lists the nodes or attributes in the Mapped and Unmapped 
columns by their hierarchical relationships. This means that 
the nodes or attributes are displayed in parent-child order 
starting from the root. This option is on by default.

Source 
character

Source 
character’s 
unmapped 
nodes or 
attributes

Target 
character

Mapped 
character 
nodes or 
attributes

Target 
character’s 
unmapped 
nodes or 
attributes
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Display Node Names

Displays all the character set’s nodes in the Mapped and 
Unmapped columns. This option lets you map animation 
from source to target character nodes. The node view format 
is as follows:

SourceJoint -----> TargetJoint

Display Channel Names

Displays all the character set’s keyable channels in the 
Mapped and Unmapped columns. Use this option if you need 
to map animation from certain source character channels to 
specific target character channels. For example, use this option 
if you want to map the animation on the X rotation channel 
for the source character’s left shoulder to the Z rotation 
channel of the target character’s left shoulder. The channel 
view format is as follows:

SourceNode.SourceChannel -----> TargetNode.TargetChannel

Edit menu

Unmap

Breaks the link between the node or attribute pair selected in 
the Mapped column.

Unmap All

Breaks all the links between the nodes or attributes of the 
source and target characters that are currently loaded in the 
Character Mapper. These links or relationships between the 
nodes or attributes of the source and target characters are 
displayed in the Mapped column.

Clear All

Clears the current contents of the Unmapped and Mapped 
columns.
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Refresh

Refreshes the Mapped and Unmapped columns to display the 
most recent (current) version of their contents.

Map based on node names

Maps the source and target characters by their node or 
attribute names. Select this menu item when both your source 
and target character’s node or attribute names are the same. 
For example:

lshoulder -----> lshoulder

lelbow -----> lelbow

lhand -----> lhand

Map based on hierarchy

Maps the source and target characters by their hierarchical 
structures. Select this menu item when you want to 
automatically map the various node hierarchies in your 
character.

There are two ways you can map your animation based on the 
hierarchies of the Source and Target characters:

• You can automatically map all the nodes and attributes of 
the source and target characters. If no nodes or attributes 
are selected in the Unmapped columns, the Character 
Mapper will search for the root of the Source and Target 
characters and will then traverse and map their 
hierarchies accordingly.

• You can automatically map the nodes or attributes of a 
specified segment of the character’s hierarchy (for 
example, limb to limb). You specify which segment you 
want to map by selecting a single Source and a single 
Target node or attribute at the top of the segment’s 
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hierarchy. The Character Mapper will then map down the 
segment of each character’s hierarchy based on the nodes 
or attributes you selected.

For example, if you selected the left_shoulder joint of each 
character, then the Character Mapper will map the Source and 
Target left_shoulder nodes, and will continue down the 
hierarchy mapping the left_elbow nodes, the left_forearm nodes, 
and so on.

See ”To map animation from one character to another based 
on hierarchy” on page 136.

Map based on order

Maps the source and target characters by the order 
(descending) in which their nodes and attributes were added 
to their character sets. You can view the order of a character’s 
nodes and attributes by expanding their respective character 
nodes in the Outliner. Select this menu item when both your 
source and target character’s nodes and attributes have the 
same basic hierarchy. For example:

joint3 -----> 3joint

joint2 -----> 2joint

joint1 -----> 1joint

Fields

From:

Displays the name of the source character. The source 
character set contains the animation data that is remapped to 
the target character set’s skeleton.

To:

Displays the name of the target character. The target character 
set’s skeleton receives the remapped animation data from the 
source character set.
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Buttons

Load Left

Loads all the node or attribute names from the selected 
character into the Left (source) column.

Load Right

Loads all the node or attribute names from the selected 
character into the Right (target) column.

Map

Creates a correspondence between the animation from the 
selected source node or attribute (left Unmapped column) to 
the target node or attribute (right Unmapped column). For 
example, if you want to map node1 from the source character 
to node2 of the target character, the node pair or relationship 
would appear in the Mapped column as the following:

node1 -----> node2

Close

Closes the Character Mapper window.

Columns

Mapped

Displays all the node or attribute relationships between the 
source and target character sets. Once you link nodes or 
attributes by clicking them in the source (left) and target 
(right) Unmapped columns, the linked pairs appear in the 
Mapped column.

Unmapped

The left unmapped column lists all the nodes or attributes 
from the source character set’s skeleton, and the right 
unmapped column lists all the nodes or attributes from the 
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target character set’s skeleton. To link pairs of nodes or 
attributes, see ”To map animation from one character to 
another” on page 135.

Redirecting motion

What is motion redirection?

You can now redirect the motion of character animation more 
easily than before. Redirecting motion is the process by which you 
can modify a character’s path or orientation at anytime during its 
animation. For example, by redirecting a character’s motion, you 
can change where a character lands, as well as the direction the 
character is facing, at the end of a character’s jump animation.

You can use the new redirection controls to move and rotate a 
character, and key these new positions and orientations, at any 
point during its animation.

Rotation redirection control Translation redirection control
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Workflow for redirecting animation

1 Step forward in your animation to where you want your 
character’s redirection to occur.

2 Select the character (if you are redirecting an entire character, 
this would be its root joint) or the part of a character (if you 
are redirecting the motion of a character’s back, this would be 
one of its spine joints) you want to redirect.

3 Create the desired (translation, rotation, or translation and 
rotation) redirection controls. See ”To redirect an object’s 
animation” on page 147.

4 Reposition your redirection controls.

• For the rotation redirection control, move it to the point 
around which you want your character to rotate. For 
example, if you want to use the rotation redirection 
control to make a character go around a corner during its 
walk cycle, you would move the rotation redirection 
control to the ball of the foot the character pivots on when 
rounding the corner.

• For the translation redirect control, move it to where you 
want the character or the part of a character to move to.

5 Step backward in your character’s animation to where you 
want the character’s redirection to begin.

6 Key the appropriate channels for your controls.

You have to first key your controls at their base values. Base 
values are the values of the control’s Rotate and Translate 
channels at the time of the control’s creation.

Note You can use the redirection controls to redirect any type 
of motion in Maya (keyframe or motion capture 
animation, expressions, dynamics, and so on).
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7 Step forward in your character’s animation to where in the 
Trax timeline you inserted the redirection controls.

8 Manipulate your redirection controls.

• Rotate your rotation redirection control.

• Translate your translation redirection control.

9 Key the Rotate or Translate channels for your redirection 
controls once again.

This forms the redirection animation that redirects the character’s 
original animation.

Related topics

”Animation redirection example” on page 148

”To map animation from one character to another” on 
page 135

”To map animation from one character to another based on 
hierarchy” on page 136

How do I redirect the motion of an 
animated character?

To redirect a character set’s animation

1 Step forward in your animation to where you want your 
character’s redirection to occur.

2 Select the character set whose animation you want to redirect.

3  Select Character > Create Character Set > .

The Create Character Set Options window appears. See 
Character > Create Character Set in the Character Setup 
guide.

4 Set the options in the Character and Attributes sections as 
desired.
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5 In the Redirection section, turn on Redirect Character.

6 Do the following:

• If you want to redirect the rotation of your character, turn 
on Rotation Only.

• If you want to redirect the translation of your character, 
turn on Translation Only.

• If you want to redirect the rotation and translation of your 
character, turn on Rotation and Translation.

7 Click Apply.

Rotation and/or translation redirection controls appear at the 
root of the current character set. The Create Character Set 
Options window remains open.

8 Do the following:

• Move the rotation redirection control to change the 
position around which your character pivots.

• Move the translation redirection control to change the 
current character’s position relative to the position around 
which your character pivots.

9 Do steps 5 to 9 in the redirection workflow. See ”Workflow for 
redirecting animation” on page 145.

To redirect an object’s animation

1 Step forward in your animation to where you want your 
object’s redirection to occur.

2 Select the root of the object whose motion you want to 
redirect.

3 Select Character > Redirect > .

The Character Redirection Options window appears.

4 In the Redirection Type section, do the following:
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• If you want to redirect only the rotation of your character, 
turn on Rotation Only.

• If you want to redirect only the translation of your 
character, turn on Translation Only.

• If you want to redirect both the rotation and translation of 
your character, turn on Rotation and Translation.

5 Do one of the following:

• Click Redirect. The rotation and/or translation redirection 
controls appear at the root of the object and the Character 
Redirection Options window closes.

• Click Apply. The rotation and/or translation redirection 
controls appear at the root of the object and the Character 
Redirection Options window remains open.

6 Do the following:

• Move the rotation redirection control to change the 
position around which your character pivots.

• Move the translation redirection control to change the 
current character’s position relative to the position around 
which your character pivots.

7 Do steps 5 to 9 in the redirection workflow. See ”Workflow for 
redirecting animation” on page 145.

Animation redirection example

Scenario
You want to modify the walk cycle animation of a biped character 
so that during its walk cycle the character turns a corner and then 
walks down a ramp.
What’s New in Maya 6

148



4 | Animation
 > Animation redirection example
To make a biped character turn a corner during its 
walk cycle

1 Step forward in the character’s animation until you locate the 
point at which you want the character to turn around the 
corner, then stop the animation at a place in the walk cycle 
where the left foot of the biped character is on the ground.

2 Select the root joint of the character’s skeleton.

When redirecting the motion of a character, you want to 
create redirection controls for the parts of the character whose 
translation or rotation you want to change during its 
animation. In this scenario, the root joint is selected because 
we want to modify the orientation of the character’s entire 
body during its walk cycle.

3 In the Animation menu set, select Character > Redirect > .

The Redirection Options window appears. See ”Character > 
Redirect” on page 160.

4 Turn on Rotation Only and click Redirect.
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The rotation redirection control appears at the root joint of the 
character.

5 Select the rotation redirection control and using the Translate 
Tool, move the control to the tip of your character’s left foot.

Rotation redirection control
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Moving the rotation redirection control lets you reposition the 
point around which the biped character pivots. In this 
scenario, you want the character to pivot on the ball of its left 
foot when it turns the corner.

6 In the Channel Box, key the Rotate X, Y, and Z channels for 
the left foot’s rotation redirection control.

7 Step forward in the animation until the right foot is on the 
ground and the left foot’s heel is raised.

This is where the character will begin its turn.

8 Select the left foot rotation redirection control, rotate it 45 
degrees, and key its Rotate X, Y, and Z channels.

9 Select the character’s root joint and select Character > 
Redirect.

A rotation redirection control appears at the character’s root.
What’s New in Maya 6

151



4 | Animation 
  > Animation redirection example
10 Select the rotation redirection control and using the Translate 
Tool, move the control to the tip of your biped’s right foot.

11 In the Channel Box, key the Rotate X, Y, and Z channels for 
the right foot’s rotation redirection control.

12 Step forward in the animation until the left foot is once again 
on the ground and the right foot’s heel is raised.

This is the point where the character will begin its descent 
down the ramp.

13 Select the right foot’s rotation redirection control, rotate it 45 
degrees, and key its Rotate X, Y, and Z channels.
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14 Go to the beginning of the animation’s playback range and 
play the animation.

The character now walks and turns left around the corner.

Path of redirected 
walk cycle

Path of original walk cycle
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To make a biped character walk down a ramp during 
its walk cycle

1 Step forward in the animation until you reach the frame 
where the character is just about to walk down the ramp.

2 Select the root joint of the character.

3 In the Animation menu set, select Character > Redirect > .

The Redirection Options window appears. See ”Character > 
Redirect” on page 160.

4 Turn on Rotation and Translation and click Redirect.

The rotation and translation redirection controls appear at the 
root joint of the character.
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5 Select the rotation and translation redirection controls and 
using the Translate Tool, move the controls to the tip of your 
biped’s right foot.

Rotation redirection control
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6 Step back a few frames until the character appears to be 
standing on the edge of the ramp with both feet side-by-side.
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7 Do the following:

• For the rotation redirection control, key all its Rotate X, Y, 
and Z channels.

• For the translation redirection control, key all its Translate 
X, Y, and Z channels.

8 Step forward in the animation to the point where you inserted 
the redirection controls.

9 Select the rotation redirection control and using the Rotate 
Tool, rotate the control until the character’s feet are parallel to 
the ramp.
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Note that there is a gap between your character’s feet and the 
floor/ramp.

10 In the Channel Box, key the rotation redirection control’s 
Rotate X, Y, and Z channels.

11 Select the translation redirection control and using the Move 
Tool, translate your character downward until the right foot 
touches the ramp and the left foot touches the floor.
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12 In the Channel Box, key the translation redirection control’s 
Translate X, Y, and Z channels.

13 Go to the start of the animation’s playback range and play 
your animation.

After the character turns the corner, it now walks down the ramp.
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Character > Redirect

Adds translation and/or rotation redirection controls to the 
current character. The controls appear at the origin of the 
character.

When a character is redirectable, you can change the translation 
and orientation of its already established (for example, motion 
capture) animation.

Character > Redirect > 

When you select this menu item, the Character Redirection 
Options window appears.

Path of redirected 
walk cycle

Path of original walk cycle
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Redirection Type

Rotation and 

Translation Creates a rotation and translation control for 
the current object.

Rotation Only Creates a rotation redirection control for the 
current character. The rotation redirection 
control appears at the origin of the current 
object.

The rotation redirection control is useful if 
you want to change the orientation of the 
point around which your object pivots. For 
example, you can manipulate a rotation 
redirection control to get a character to turn 
90 degrees (around a corner perhaps) 
halfway through its walk cycle. 

Translation 

Only Creates a translation redirection control for 
the current character set. The translation 
redirection control appears at the origin of 
the current object.

The translation redirection control is useful 
if you want to change the translation of the 
point around which your object pivots. For 
example, you can manipulate the translation 
redirect controls to change the place at 
which a character lands from a jump.

Redirection in the Character Set Options 
window

The following options are located in Character > Create Character 
Set > .
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Redirect Character

Makes the current character set redirectable. When a character 
set is redirectable, this means that you can now change the 
translation and orientation of already established (for 
example, motion capture) animation.

Rotation and Translation

Creates a rotation and translation control for the current 
character set. 

Rotation Only

Creates a rotation redirection control for the current character 
set. The rotation redirection control appears at the origin of 
the current character.

The rotation redirection control is useful if you want to 
change the orientation of your character set’s pivot. For 
example, you can manipulate a rotation redirection control to 
get a character to turn 90 degrees (around a corner perhaps) 
halfway through its walk cycle. 

Translation Only

Creates a translation redirection control for the current 
character set. The rotation redirection control appears at the 
origin of the current character.

The translation redirection control is useful if you want to 
change the translation of the point around which your object 
pivots. For example, you can manipulate the translation 
redirection control to change the place at which a character 
lands from a jump.
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Miscellaneous improvements

Exposed muting in the Dope Sheet and 
Graph Editor

When you mute an animated object’s keys or channels, a Mute 
channel is generated for each animation channel. You can view, 
manipulate, and add keys to this Mute channel or curve in the 
Dope Sheet or Graph Editor. This is useful when you want to 
isolate and review specific parts of your animation.

When you edit a Mute channel or curve, its corresponding 
animation curve automatically updates in the Dope Sheet and 
Graph Editor view areas.

How do I mute or unmute a channel in the 
Dope Sheet or Graph Editor?

1 Open the Dope Sheet or Graph Editor.

2 In the Dope Sheet or Graph Editor’s outliner, select the 
channel you want to mute.

3 Do one of the following:

• If the current animation curve is not muted, select Curves 
> Mute Channel.

In the Graph Editor or Dope Sheet, Mute appears under the 
current animation channel’s name in the outliner and a Mute 
curve or channel appears in the view area.

The muted animation curve now appears as a dotted line in 
the graph view. 
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• If the current animation curve is muted, select Curves > 
Unmute Channel.

The current animation curve’s Mute node is deleted, and all 
occurrences of Mute are removed from the Graph Editor’s and 
Dope Sheet’s outliners and views.

How do I mute keys in the Dope Sheet or Graph 
Editor?

1 Open the Dope Sheet or Graph Editor.

Mute channel

Mute curve

Muted animation 
curve

Muted animation
channel
What’s New in Maya 6

164



4 | Animation
 > How do I mute keys in the Dope Sheet or Graph Editor?
2 In the outliner, select the animation channel that has the key 
you want to mute.

3 In the view, select the key you want to mute.

4 Do one of the following:

• If the current key is not muted, select Keys > Mute Key 
On.

The current key now no longer contributes to the animation 
on its channel. In the Graph Editor or Dope Sheet, Mute 
appears under the current animation channel’s name in the 
outliner and a Mute curve with keys appears in the view area.
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The Mute curve has the same number of keys and they are 
positioned the same as those on its animation channel.

• If the current key is muted, select Keys > Mute Key Off.

The current key now contributes to the animation on its 
channel. Unmuting a key does not remove the Mute curve. To 
remove the Mute curve from the current animation channel, 
see ”How do I mute or unmute a channel in the Dope Sheet or 
Graph Editor?” on page 163.

Muted key

Region of the 
animation 
curve/channel 
that is 
suppressed
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New ways to manipulate keys and curves 
in the Graph Editor

Manipulate groups of keyframes

You can now manipulate groups of keys proportionally or in 
relation to a selected key using the new Move Function options. 
The Move Keys Tool and the Move Function options can be 
accessed through the Graph Editor’s menu bar by selecting Edit > 
Transformation Tools > Move Keys Tool > .
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Before move

Direction of mouse movement

Result with Linear falloff

Result with Exponential falloff

Selected keys
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Move Falloff

Constant Moves all keys the same amount in the 
direction of the mouse movement.

Linear Moves all keys based on the distance they 
are from the mouse down location. The 
amount a key moves decreases linearly as 
its distance from the mouse down location 
increases.

Exponential Moves all keys based on the distance-
squared they are from the mouse down 
location. The amount a key moves decreases 
exponentially as its distance from the mouse 
down location increases.

Manipulate curves with the lattice manipulator

You can now manipulate curves in the Graph Editor with the new 
Lattice Deform Keys Tool.

The Lattice Deform Keys Tool lets you draw a lattice deformer 
around groups of keys, so that you can deform many keys at once. 
This tool gives you a high-level of control over your animation 
curves.

Once you draw a lattice around a group of keys, you can then 
move the control points of the lattice to deform the affected 
animation curves or scale the lattice points around a selected 
control point to transform the affected curves.

You can also use the Lattice Deform Keys Tool to deform keys 
that lie along a single (horizontal or vertical) graph view axis.

Lattice Deform Keys Tool
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Lattice Settings

Columns

Specifies the number of columns for the current lattice 
manipulator. The minimum number of columns is 2 and 
maximum number is 20.

Note When using the Lattice Deform Keys Tool to deform 
keys that lie on a single axis, selecting one lattice point 
in a row (vertical) or column (horizontal) selects all the 
points in that row or column.

For example, if you select a lattice control point on a 
horizontal lattice, all of the lattice points in the selected 
point’s column are also activated. Depending on your 
current dolly-view scale in the Graph Editor, not all the 
selected lattice points may be visible. The visibility of 
the selected lattice points does not affect the functioning 
of this tool.

Vertical lattice

Horizontal lattice

Row of 
control 
points

Column of 
control points
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Rows

 Specifies the number of rows for the current lattice 
manipulator. The minimum number of rows is 2 and the 
maximum number is 20.

Falloff

Specifies the lattice manipulator’s level of influence or falloff 
value.

Middle Button Scales

When on, you can scale the active control points around the 
current lattice point.

How do I use the Lattice Deform Keys Tool?

To deform animation curves with the lattice 
manipulator

1 Select the Lattice Deform Keys Tool from the Graph Editor’s 
toolbar.

2 Set the Lattice Deform Keys Tool options from the Tool 
Settings window.

See ”Lattice Settings” on page 170.

3 Select keys on the curves you want to deform to define the 
target curve region.

The lattice appears in the graph view. The lattice forms a 
bounding box around the selected keys.
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4 Select the lattice points, lattice edge, or lattice cell you want to 
manipulate by clicking them with the left mouse button.

Shift-click lattice points to include them in or remove them 
from your selection. You cannot select more than one lattice 
edge or cell at a time.

5 Do one of the following:

• For lattice edges, cells, or single points, drag to deform 
the target curve region.

Lattice edge

Lattice point

Lattice cell
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• For groups of lattice points, middle-drag to deform the 
target curve region.

Select lattice 
component

Drag lattice 
component

Resulting 
deformed curves
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• If you want to scale a region of the lattice, turn on the 
Middle Button Scales option in the Lattice Deform Keys 
Tool and then middle-drag to scale the selected lattice 
region. Scaling the lattice deforms the affected curves.

Select lattice 
points

Middle-drag 
lattice points

Resulting 
deformed curves
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Customize animation curve colors

You can now specify custom colors for the animation curves that 
appear in the Graph Editor. With the new Use Curve Color and 
Curve Color attributes you can set the colors for individual curves 
or use more global operations such as coloring a curve based on 
which characters they drive to color groups of curves at a time. 

Select lattice 
components

Middle-drag to 
scale the lattice 
component(s)

Resulting deformed 
curves
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This type of global operation can be achieved through MEL 
scripts. For a sample MEL script, see ”Example MEL procedure 
for customizing the color of multiple animation curves” on 
page 184.

All user-defined color settings for animation curves appear in 
both the Graph Editor’s Outliner and graph view. The Use Curve 
Color checkbox and Curve Color swatch are located in the Anim 
Curve Attributes section of each animation curve node (for 
example, animCurven). 

To switch between your custom colors and the default curve 
colors, turn Use Curve Color on or off.

To set custom animation curve colors

1 Select the animated object.

2 Open the Graph Editor.

3 In the graph view, select the animation curve.

4 Select Curves > Spreadsheet.

The Attribute Editor opens.

5 In the Anim Curve Attributes section of the animCurven tab, 
turn on Use Curve Color.

6 Double-click the color swatch to launch the Color Chooser.

7 In the Color Chooser, select a custom color for the curve and 
click Accept.

Note The maximum number of custom colored curves that 
can be displayed at any one time is 20. When this 
number is exceeded, curves are displayed using their 
default colors.
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The color you selected with the Color Chooser appears in the 
Curve Color swatch. In the Graph Editor’s graph view, the 
animation curve is now the color of the Curve Color swatch.

Additional time working units available

The following time working units have been added for animation 
playback in Maya 6:

2, 3, 4, 5, 6, 8, 10, 12, 16, 20, 40, 75, 80, 100, 120, 125, 150, 200, 
240, 250, 300, 375, 400, 500, 600, 750, 1000, 1200, 1500, 2000, 
3000, and 6000 fps (frames per second).

You can set the playback rate from the Time drop-down list in 
Window > Settings/Preferences > Preferences > Settings > 
Working Units.

Control what parts of characters are 
ghosted 

With the new Object Type options, you can specify which parts of 
a character are ghosted. The Object Type options are located in 
Animate > Ghost Selected > . For more information on ghosting, 
see “Previewing animation” in the Animation guide.

For hierarchical characters, turn on Hierarchy in the Ghost 
Selected Options window if you want to limit which parts of a 
character’s children are ghosted.

Object Type

Geometry Only the geometry of the current object is 
ghosted.

Locator Only the locators for the current object are 
ghosted.

Joint  Only the joints and bones for the current 
object are ghosted.
What’s New in Maya 6

177



4 | Animation 
  > Playblast specified frames
All Other 

Types Only the parts of the current object that are 
not geometry, locators, or joints are ghosted.

Playblast specified frames

You can now output single frames of your animation to Playblast 
using the new -frame flag for the playblast MEL command. For 
example:

playblast -frame 1 -frame 4 -frame 7

outputs frames 1, 4, and 7 of your current animation to Playblast. 
For more information, see Help > MEL Command Reference.

Off-screen Playblast (IRIX and Linux 
only)

You can now run Playblast when Maya is minimized on your 
screen using the new -os/offScreen flag for the playblast MEL 
command. For more information, see Help > MEL Command 
Reference. 

Advanced additions to animation

Bake referenced animation

You can now bake referenced animation data using the 
bakeResults and bakeSimulation MEL commands. See Help > 
MEL command reference. You can also bake referenced 
simulation data using Edit > Keys > Bake Simulation.

Note The -frame flag overrides any -startFrame/-endframe 
flags.
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New MEL flags for importing and 
exporting animation

You can now import and export all or selected main scene 
animation as well as referenced animation with the new -ean/
exportAnim, -eas/exportSelectedAnim, -ear/
exportAnimFromReference, and -esa/
exportSelectedAnimFromReference flags for the file MEL 
command.

For information on using MEL, see the MEL guide. For 
information on specific MEL commands like file, see Help > 
MEL command reference.

Main scene animation data

-ean/exportAnim

This flag lets you export all the animation nodes and 
connections in your scene.

-eas/exportSelectedAnim

This flag lets you export all the animation nodes and 
connections for the selected objects in your scene.

Referenced animation data

-ear/exportAnimFromReference

This flag lets you export the animation nodes and connections 
for all referenced objects in a scene. This flag can be used in 
conjunction with -rfn/referenceNode to constrain what is 
exported to only animation for referenced objects in a specific 
reference file. You can export the animation nodes and 
connections as mayaAscii or mayaBinary. For example:

file -type "mayaAscii" -exportAnimFromReference "C:\animExport.ma";
file -type "mayaBinary" -exportAnimFromReference -rfn "geomRN" 
"C:\animExportRN.ma";
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-esa/exportSelectedAnimFromReference

This flag lets you export the animation nodes and connections 
for selected referenced objects in a scene. This flag can be used 
in conjunction with -rfn/referenceNode to constrain what is 
exported to only animation for referenced objects in a specific 
reference file. You can export the animation nodes and 
connections as mayaAscii or mayaBinary. For example:

file -type "mayaAscii" -exportSelectedAnimFromReference 
"C:\animExportSelected.ma";
file -type "mayaBinary -exportSelectedAnimFromReference -rfn "geomRN" 
"C:\animExportSelRN.ma";

-sns/swapNamespace

This flag lets you replace a given namespace with a different 
namespace when importing or referencing a file. This flag has 
two parameters that must be specified. The first parameter is 
the namespace to be replaced (fromNamespace) and the 
second is the new namespace (toNamespace). The 
toNamespace parameter must already exist in the scene prior 
to calling swapNamespace. swapNamespace can be used 
multiple times in a single file command call to swap multiple 
namespaces when importing or referencing a file. 

For example:

file -reference -swapNamespace "fromName" "toName" "C:\animExport.ma";
file -import -swapNamespace "name1" "name2" -swapNamespace "name3" 
"name4" "C:\anim.ma";

Note The swapNamespace flag is saved out as both mayaAscii 
and mayaBinary formats for file references whose 
namespaces were swapped on reference.
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The namespace parameters operate on the current namespace. 
Thus when referencing a file, a new namespace is created for 
the file reference that is equivalent to the name of the file 
being referenced. If the namespace that you are swapping to 
is outside that namespace domain, a full namespace path 
must be specified. For example:

file -reference -swapNamespace "fromName" ":toName" "C:\animExport.ma";
The colon in front of the toNamespace parameter specifies a 
namespace path starting from the root namespace.

Limitations to the new import and export 
animation flags

• The new file command flags work only with the Maya 
namespace capability, not prefixes.

• The files (Animation Data Files) created using these new flags 
will contain only animation curve nodes, their connections, 
and the associated animation nodes that are required for type 
conversion.

• You must retain the namespace information used during the 
creation of the animation reference file since both the original 
and new model namespaces are required at the time of 
animation import. Otherwise, you will not be able to reuse the 
exported animation.

• When building a scene that reuses animation using the new 
file command flags, the models must be referenced in first 
and then the Animation Data File can be referenced. 
Otherwise, Maya will not be able to resolve the connections 
defined in the Animation Data File.

• The new file command flags are intended to work with 
single level file references. Multi-level referencing, where 
references are contained within references, is not supported.
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How do I use these new file command flags?

Example workflow:

Importing animation as a reference from a low resolution model in one 
file (reference scene) to a high resolution model (main scene).

Before you begin, you must ensure that the components of the 
each model (the one in the reference scene and the one in the main 
scene) use the same naming scheme. For example, if you are 
trying to reference the animation from low_ResModel left_leg to 
high_ResModel, high_ResModel must also have a component 
named left_leg. If you do not have consistent naming across your 
reference and main files, then a load error will occur when you try 
to import the animation as a reference.

1 Create a new scene.

2 Load the low resolution model using file referencing. For 
example:

file -reference -namespace lowResModel “/data/models/low_res_model.ma”;

Maya automatically assigns a unique reference node, such as 
lowResModelRN, to the model you open using file referencing.

3 Animate the model and save the scene.

This saved scene file is useful if you need to revise the 
animation at a later time.

4 Export the animation for the referenced model in your scene 
as a Maya ASCII or binary file using the
-exportAnimFromReference flag with the file command. 
For example:

file -exportAnimFromReference -referenceNode lowResModelRN “/data/
animation/model_animation.ma”;

The animation on your low resolution model is saved to an 
animation reference file that is separate from the model’s 
scene file.

5 Save your scene, and then create a new scene. 
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6 Load the high resolution model using file referencing. For 
example:

file -reference -namespace highResModel “/data/models/high_res_model.ma”;

7 Import the animation using file referencing from the low 
resolution model and swap namespaces as needed. For 
example:

file -reference -swapnamespace lowResModel :highResModel “/data/
animation/model_animation.ma”;

The file command substitutes the namespace prefix 
lowResModel: with:highResModel:. For more information 
on swapping namespaces, see ”-sns/swapNamespace” on 
page 180.

For this example, the animation reference file may contain the 
following:

createNode animCurveTA -name “leftArm_rotateZ”;
setAttr -size 3 “.ktv[0:2]” 1 -100.5 120 45.4 217 99.8;
connectAttr “leftArm_rotateZ.o” “lowResModel:leftArm.rz”;

Note • A colon (:) is required to specify the full namespace 
path in the model’s file. If a full namespace path is 
not specified, the namespace is interpreted relative 
to the current namespace. See:highResModel in the 
above example.

• You can specify only one -namespace flag per file 
command. This ensures a one-to-one mapping 
between the model and animation.
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Example MEL procedure for customizing 
the color of multiple animation curves

See the Animation chapter of the online What’s New in Maya 6 
guide in Maya Help. See also ”Customize animation curve colors” 
on page 175.
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Retargeting animation

What is animation retargeting?

In Maya 6 you can now retarget animation data from the joints of 
one skeleton (source) to the joints of another skeleton (target). The 
source skeleton is the skeleton from which you want to retarget its 
animation data, and the target skeleton is the skeleton to which 
you want to retarget the source’s animation.

Retargeting is useful when you want to transfer animation 
between skeletons that have the same or different proportions.

Retargeting workflow

• Set a neutral pose for your source and target skeletons.

See ”How do I set my skeleton’s neutral pose?” on page 186.

• Label the joints of your source and target skeletons.

See ”How do I label my skeleton’s joints?” on page 187.

• Set the retargeting solver options.

See ”Retargeting > Retarget Skeleton” on page 195.

• Perform the retarget.

See ”How do I retarget animation from one skeleton to 
another?” on page 192.

Note If you encounter an error, see “Retargeting error 
messages” in the Skeletons chapter of the Character 
Setup guide.
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How do I set my skeleton’s neutral pose?

To set a neutral pose

1 Position your character into the pose you want as its neutral 
pose.

The neutral pose maintains the distinct characteristics of your 
source and target skeletons. Since the neutral pose lets you 
differentiate your skeletons when retargeting animation, the 
pose you set for your character must be distinct. 

2 Select the root of your skeleton.

3 Select Skeleton > Set Neutral Pose.

Your character’s current pose is set as its neutral pose and the 
retargetPose tab appears on the root joint’s node. See 
”Retargeting > Set Neutral Pose” on page 193.
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How do I label my skeleton’s joints?

There are three ways in which you can label the joints of your 
skeleton:
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• Use the Skeleton > Retargeting > Joint Labelling menu to 
automatically label each joint in a selected joint chain. See ”To 
automatically label the joints of your skeleton’s limbs” on 
page 188.

• Use the Skeleton > Retargeting > Joint Labelling menu to label 
each individual joint in your skeleton. See ”To label your 
character’s joints using the Joint Labelling menu” on page 189.

• Select a joint and edit its label from the Attribute Editor. See 
”To set or adjust individual joint labels from the Attribute 
Editor” on page 190.

To automatically label the joints of your skeleton’s 
limbs

For the limbs of your source and target skeletons, do the 
following:

1 Select Skeleton > Retargeting > Show All Labels.

Joints labels will now appear in the scene view. See 
”Retargeting > Show All Labels” on page 194.

2 Select Skeleton > Retargeting > Joint Labelling.

Note • If you want to retarget an arm or a leg, then you 
must label the three primary joints for those limbs 
on both the Source and the Target skeletons. For the 
arm, the three primary joints are: shoulder, elbow, 
and hand. For the leg, the three primary joints are: 
hip, knee, and foot.

• As you label your joints, each label appears beside 
their respective joints in the scene view. If you do 
not see the joint labels in the scene view, see ”How 
do I turn the visibility of my joint labels on and off?” 
on page 191.
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The Joint Labelling menu appears. See ”Retargeting > Joint 
Labelling” on page 193.

3 Tear-off the Joint Labelling menu.

4 In the scene view, select the parent or top joint of each limb 
(joint chain) in your skeleton and do the following:

• Click a side label (Center, Left, Right) in the Joint 
Labelling menu.

• Click a type label (Arm or Leg) in the Joint Labelling 
menu.

Each joint, from the selected parent down its joint chain’s 
hierarchy, is automatically labeled according to their positions 
in their respective joint chain.

For example, if you select the left shoulder joint of a skeleton 
and click Left and then Arm in the Joint Labelling menu, then 
that joint will be labelled as Shoulder(L), the next joint in the 
chain will be automatically labeled as Elbow(L), and the next 
joint will be labeled as Hand(L) and so on.

5 If you want to adjust or change the labels of your joints, see 
”To label your character’s joints using the Joint Labelling 
menu” on page 189 or ”To set or adjust individual joint labels 
from the Attribute Editor” on page 190.

To label your character’s joints using the Joint 
Labelling menu

For your source and target skeletons, do the following:

1 Select Skeleton > Retargeting > Show All Labels.

Note For arms, the forearm joint is labelled as an elbow joint. 
For legs, the ankle joint is labelled as a foot joint.
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Joints labels will now appear in the scene view. See 
”Retargeting > Show All Labels” on page 194.

2 Select Skeleton > Retargeting > Joint Labelling.

The Joint Labelling menu appears. See ”Retargeting > Joint 
Labelling” on page 193.

3 Tear-off the Joint Labelling menu.

4 In the scene view, select a joint and do the following:

• Click a side label (Center, Left, Right) in the Joint 
Labelling menu. Joint types such as Head or Spine do not 
require a type label.

• Click a type label (Shoulder, Hip, Head, Spine and so on) 
in the Joint Labelling menu.

The side and type labels appear beside the current joint. For 
example, if you selected Right as the side label and Knee as 
the type label, then the label Knee(R) will appear beside the 
joint in the scene view.

5 Repeat step 4 for the rest of the joints you want to label.

To set or adjust individual joint labels from the 
Attribute Editor

1 Select the joint in your source or target skeleton whose 
labeling you want to change and open the Attribute Editor.

2 In the Joint section of your joint node’s tab, expand Joint 
Mapping.

The Side and Type drop-down menus appear.

3 Set or change the joint’s Side and Type labels as desired.
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How do I turn the visibility of my joint 
labels on and off?

There are three ways in which you can turn the visibility of joint 
labels in the scene view on and off:

• Use the Display > Component Display > Joint Labels or 
Skeleton > Retargeting > Toggle Selected Labels to turn the 
visibility of joint labels on and off in the scene view for 
selected joints.

• Use Skeleton > Retargeting > Show All Labels and Skeleton > 
Retargeting > Hide All Labels to turn the visibility of all joint 
labels on or off  in your scene view.

• Set the visibility of a single joint’s label from the Attribute 
Editor. To turn the display of a single joint’s label on or off in 
the scene view, select the joint, open the Attribute Editor, and 
turn Draw Label in the Joint Labelling section on or off.

How do I remove the labels from my 
joints?

1 Select the joint you want to unlabel.

2 Select Skeleton > Retargeting > Joint Labelling.

The Joint Labelling menu appears.

3 Select None.

The current joint’s label is removed and is replaced with 
None.
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How do I retarget animation from one 
skeleton to another?

To retarget animation from one skeleton to another

1 Set the neutral poses for your source and target skeletons.

See ”How do I set my skeleton’s neutral pose?” on page 186.

2 Make sure that all your source and target skeleton’s joints are 
labeled properly.

See ”How do I label my skeleton’s joints?” on page 187.

3 Select the root of the source character, and then Shift-click the 
root of the target character to include it in your selection.

The first root you select is considered the source, and the 
second root you select is considered the target.

4 Select Skeleton > Retargeting > Retarget Skeleton > .

The Retarget Skeleton Options window appears. See 
”Retargeting > Retarget Skeleton” on page 195.

5 Set the Neutral Pose, Lower Body, Upper Body, and Time 
options as desired. 

6 Click Retarget.

The animation on the source skeleton is retargeted to the target 
skeleton.

Note When your skeletons have an IK, FK, and an IK/FK 
skeleton, then choose just one of the types of skeletons 
on which to perform the retarget. For example, source FK 
skeleton > target FK skeleton.
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Skeleton > 

Retargeting > Set Neutral Pose

Sets the current skeleton’s pose as its neutral pose. The neutral 
pose is the common pose you want both the source and target 
skeletons to be in when retargeting animation data.

The neutral pose maintains the distinct characteristics of your 
source and target skeletons. This lets you differentiate your 
skeletons when retargeting animation. For example, if you are 
retargeting animation from an android to a hunchbacked 
character, the neutral pose prevents the android character’s stiff 
back from overriding the hunchback’s slouch.

See ”How do I set my skeleton’s neutral pose?” on page 186.

Retargeting > Go to Neutral Pose

Makes the current skeleton assume its predefined neutral pose. If 
the skeleton you want to perform this operation on does not have 
a neutral pose, then an error message appears.

Retargeting > Joint Labelling

The new Joint Labelling menu lets you assign standard, consistent 
labels to the joints of your source and target skeletons.

Assigning consistent labels to your source and target skeletons is 
required to properly retarget animation from one skeleton to 
another.

Note Skeletons that have neutral poses have a retargetPose 
tab on their root joint’s node in the Attribute Editor.
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Related topics

”How do I label my skeleton’s joints?” on page 187

”How do I turn the visibility of my joint labels on and off?” on 
page 191

”How do I retarget animation from one skeleton to another?” 
on page 192

Retargeting > Toggle Selected Labels

Shows or hides the joint labels in the scene view for the selected 
joints.

Retargeting > Show All Labels

Shows all joint labels in the scene view.

Retargeting > Hide All Labels

Hides all joint labels in the scene view.

Retargeting > Rename Joints From 
Labels

Changes the current joint’s name to its joint label. For example, if 
a joint is named joint2 and its label is Shoulder(L), then the joint’s 
name would change to LeftShoulder.

Retargeting > Label Based On Joint 
Names

Changes the current joint’s label to its joint name. For example, if 
a joint is labeled as Shoulder(L) and its joint name is Right_Hip, 
then the joint’s label would change to Hip(R).
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Retargeting > Retarget Skeleton

Retargeting > Retarget Skeleton > 

The Retarget Options window lets you set the retargeting solver’s 
options.

The retargeting solver is what looks at the animation on the 
source skeleton’s joints and retargets them to the corresponding, 
labelled joints of the target skeleton.
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Neutral Pose

Specifies whether a defined neutral pose (the pose set with 
Skeleton > Set Neutral Pose) will be used to relate the source 
and target skeletons during the retarget or whether it will be a 
pose at a specified frame. See ”Skeleton >” on page 193.

Neutral Pose

Pose Sets the neutral pose as the pose you set 
with Skeleton > Set Neutral Pose. If you 
have already set a neutral pose for each 
skeleton using Set Neutral Pose, use this 
option. Pose is on by default.

Frame Sets the poses of the source and target 
skeletons at the specified frame as their 
neutral poses. Use this option if you have 
not previously set the neutral poses for your 
skeletons using Skeleton > Set Neutral Pose.

Neutral Pose Frame

Specifies the frame to use to set the neutral poses of the source 
and target skeletons.

Maintain Offset

Maintains the source and target skeleton’s global positions so 
that the target skeleton does not move to the position of the 
source skeleton when you retarget.

Lower Body

Lower Body Solution

Lets you choose how the lower body animation of the source 
skeleton is retargeted to the lower part of the target skeleton.
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Joint Rotation 

Only When on, only joint rotations are retargeted. 
Use this option if you are mapping 
animation between rigs that have the same 
bone lengths. For example, if you are 
retargeting animation from a low resolution 
rig to a high resolution rig of the same 
skeleton. 

Scaled Foot 

Placement When on, all animation data is retargeted. 
Use this option if you are retargeting motion 
from one skeleton to a completely different 
skeleton. For example, retargeting 
animation from a giant to a dwarf.

This option takes into account the position 
and orientation of the source’s feet, and 
solves the retarget by translating/orienting 
the target’s feet like the source’s feet. This 
ensures that the target skeleton’s foot 
placement looks natural and that its feet 
move in relation to its proportions-not those 
of the source skeleton. This option is on by 
default.

Absolute Foot 

Placement When on, ensures that the target skeleton’s 
feet land at the same points as those of the 
source. Use this option when you need the 
target skeleton’s feet to land at very specific 
locations. For example, you would use this 
if you are retargeting a fight sequence or 
dance routine. 
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Lower Body Scale

Specifies how the animation on the hip, knee, ankle, foot, and 
toe joints of the source skeleton is retargeted to the 
corresponding leg joints of the target skeleton.

For example, if you are retargeting animation from a giant to 
a dwarf, you should select the Hip to Foot option because it 
best handles the retargeting of animation between skeletons 
whose legs have different bone lengths.

Only available when Scaled Foot Placement in on.

Hip to Foot Calculates the lower body scale for target 
using the source’s hip to foot scale.

Hip to Toe Calculates the lower body scale for the 
target using the source’s hip to toe scale.

Overall 

Height Calculates the lower body scale for the 
target using the overall height of the source.

Other Calculates the lower body scale for the 
target using the current Lower Scale Factor 
value.

Lower Scale 

Factor Lets you specify a custom scale factor for 
the target’s lower-body animation. Only 
available when Other in on.

Upper Body

Upper Body Solution

Lets you choose how the upper body animation of the source 
skeleton is retargeted to the upper part of the target skeleton.
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Joint Rotation 

Only When on, only joint rotations are retargeted. 
Use this option if you are mapping 
animation between rigs that have the same 
bone lengths. For example, if you are 
retargeting animation from a low resolution 
rig to a high resolution rig of the same 
skeleton. 

Scaled Hand 

Placement When on, all animation data is retargeted. 
Use this option if you are retargeting motion 
from one skeleton to a completely different 
skeleton. For example, retargeting 
animation from a giant to a dwarf.

This option takes into account the position 
and orientation of the source’s hands, and 
solves the retarget by orienting and 
positioning the target’s hands like the 
source’s hands. This ensures that the target 
skeleton’s hand placement looks natural and 
that its hands move in relation to its 
proportions-not those of the source skeleton. 
This option is on by default.

Absolute 

Hand 

Placement When on, ensures that the target skeleton’s 
hands move to the exact same points as 
those of the source. Use this option when 
you need the target skeleton’s hands to 
move to very specific positions. For 
example, you would use this if you are 
retargeting a fight sequence or dance 
routine. 
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Maintain 

Hand 

Distance Maintains the distance between the hands 
and the rest of the body for the target 
skeleton. Use this option when the source 
and target skeletons are carrying objects. For 
example, basketball players holding balls, 
waiters holding trays and so on.

Upper Body Scale

Specifies how the animation on the shoulder, elbow, wrist, 
hand, and finger joints of the source skeleton is retargeted to 
the corresponding arm joints of the target skeleton.

Only available when Scaled Hand Placement in on.

Shoulder-

Hand Calculates the upper body scale for the 
target using the source’s shoulder to hand 
scale.

Shoulder-

Wrist Calculates the upper body scale for the 
target using the source’s shoulder to wrist 
scale.

Follow Lower Calculates the upper body scale for the 
target using the lower body scale of the 
source.

Other Calculates the upper body scale for the 
target using the current Upper Scale Factor 
value.

Upper Scale 

Factor Lets you specify a custom scale factor for 
the target’s upper-body animation. Only 
available when Other in on.
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Scale Hand 

From Specifies what pivot is used in the 
calculations for scaling the target skeleton’s 
hands in respect to the source skeleton’s 
hands. Shoulder is selected by default.

Only available when Scale Hand Placement 
is on.

Time

Time Range

Selected Time 

Range  Sets the retargeting time range to the range 
of time selected (using Shift-drag) in the 
time slider.

Time Slider Sets the retargeting time range to the Time 
Slider’s current range.

Start/End Sets the retargeting time range to the 
specified Start Time and End Time.

General character setup improvements

Delete all non-skin history

With the new Delete Non-Skin History option, you can now 
delete the history from your geometry and still retain all its 
smooth bind skin history. 

Warning Any animation on the target skeleton within the 
specified time range will be overwritten by the 
source skeleton’s animation data.
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Use this option to clean up a skin’s history after you have edited 
the UVs or topology of your skinned geometry. Deleting all non-
skin history improves interactive performance in Maya and 
simplifies the history node list for export to game engines.

To delete all non-skin history from your geometry

1 Select all the geometry that is bound to your character’s 
skeleton.

2 If your character is not already at its bind pose, select Skin > 
Go to Bind Pose.

Delete Non-Skin History should always be performed at the 
character’s bind pose, otherwise an error may occur.

3 Select Skin > Edit Smooth Skin > Delete Non-Skin History.

All the geometry’s history is deleted except for its smooth 
bind skin history.

Rigid bind allows binding to zero-
weighted joints

The new Force All option lets you bind all selected joints, 
including those with 0 influence, to a specified geometry. You can 
select Force All from the Bind To drop-down menu in the Rigid 
Bind Skin Options window.

Warning Delete Non-Skin History looks at all your skeleton’s 
input connections. If all the geometry that is bound 
to the skeleton is not selected when you select Skin > 
Edit Smooth Bind > Delete Non-Skin History, then 
the Delete Non-Skin History will not evaluate 
properly.
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To open this window, select Skin > Bind Skin > Rigid Bind > . 
For more information on rigid binding geometry, see “Rigid 
Skinning” in the Skinning chapter of the Character Setup guide.

Soft bind skinning affects normals

You can use the new Vertex Normal Edit Tool to edit user-defined 
vertex normals so that they are affected by skinning. For more 
information, see ”Vertex Normal Edit Tool” on page 82.

Improvements to the Component Editor

Improved performance

Now when you view and edit the weight values of vertices from a 
complicated character rig, the Component Editor displays and 
updates the bound skin data more quickly. 

New options and layouts for smooth skinning

For more information, see ”Component Editor” on page 27.

Hide Zero Columns

When this item is turned on, all joint or vertex columns whose 
weight values are zero are hidden.

Show Selected Objects

When this item is turned on, only the vertices that are influenced 
by the selected joint are displayed.

Deform > Soft Modification

The new soft modification deformer lets you manipulate groups 
of vertices at a time to modify the surface of a target geometry. 
For more information, see ”Soft Modification Tool and Deformer” 
on page 59.
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Deform points outside the lattice

You can now specify the range of influence that lattice deformers 
have on their target object’s points. The new Outside Points 
Transform options let you transform all an object’s points, even 
when parts of the object are outside of the lattice. Also, these 
options let you specify a falloff distance in which object points 
continue to be deformed by the lattice when they are outside of 
the deformer.

Transforming object points outside of the lattice is useful when 
you want to maintain a normal lattice deformation for objects that 
randomly pop outside of the lattice. For example, maintaining 
lattice deformations when chaining lattices together. The Only If 
Inside Lattice option is on by default.

The Outside Points Transform options are located in the Create 
Lattice Options window. To open the lattice deformer options 
window, select Deform > Create Lattice > . For more 
information on lattice deformers, see “Lattice deformer” in the 
Deformers chapter of the Character Setup guide.

Outside Points Transform

Specifies the extent to which the lattice deformer affects its 
target objects points.

Only If Inside 

Lattice Only points within the base lattice are 
deformed.

Transform All 

Points All the target object’s points—inside and 
outside the lattice—are deformed by the 
lattice.

Transform If 

Within Falloff Points within the base lattice and up to the 
specified falloff distance are deformed by 
the lattice. For example, if you set the Falloff 
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Distance to 2.0, then points within the base 
lattice and up to 2 widths of the lattice are 
deformed.

Falloff Distance

Specifies the distance from the base lattice up to which points 
are affected by the lattice deformer. The units of falloff 
distance are measured in lattice widths. For example, a Falloff 
Distance value of 3.0 sets the falloff distance to 3 lattice 
widths.

The falloff degrades linearly from the edge of the base lattice 
to the specified falloff distance. This option is available only 
when Transform If Within Falloff is on.

Sculpt deform with texture map

You can now use 2-dimensional textures to control the strength of 
the deformation field that surrounds the sculpt object. This lets 
you deform geometry in a non-uniform manner.
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How do I control a Sculpt deformer’s strength 
using a texture?

To use a two dimensional texture with the Sculpt 
deformer

1 Select the object that you want to deform.

2 Create a sculpt deformer for that object.

See “Set sculpt deformers”.

3 Select the sculpt deformer and open the Attribute Editor.

4 Select the sculpt node’s tab and expand its Sculpt History 
section.

5 Click the Add Advanced Sculpt Attributes button.

The Advanced Sculpt Attributes appear in the Sculpt History 
section.

6 Turn on Enable Advanced.

7 Click the map button next to the Texture attribute. See 
”Texture” on page 207.

The Create Render Node window appears. See “Create > 
Create Render Node” in the Shading guide.

8 Click the 2D texture that you want to use with your sculpt 
deformer.

The strength of your sculpt deformer is now affected by the 
texture.

9 Set the advanced sculpt attributes.

See “Advanced Sculpt Deformer Attributes”.
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Advanced Sculpt Deformer Attributes

Enable Advanced

When on, the Advanced Sculpt Deformer Attributes are 
active. When off, the Advanced Sculpt Deformer Attributes 
are inactive.

Texture

Lets you set a 2D texture to drive the strength of the sculpt 
deformer. The texture coordinates are assigned to the sculpt 
object in the same manner as a similarly oriented NURBS 
object.

Texture Multiplier

Sets the strength of the 2D texture’s influence on the 
deformation.

Non Uniform

When on, Maya normalizes the sculpt deformation. Turn on 
this attribute if you want to compensate for any non-uniform 
scaling that may have been applied to the target object or the 
sculpt deformer.

Paint Resolution

If you want to use Paint Sculpt Map to paint deformation 
strengths for the sculpt deformer, then you can use these 
fields to set the resolution values for the file texture. 

To change the resolution, you must first disconnect the 
existing file texture, change the resolution setting, and then re-
click the Paint Sculpt Map button.
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Visualize Texture

When on, the objects influenced by the deformer are 
displayed in wireframe, and the deformer itself is displayed 
in textured mode. This lets you see the texture that is being 
used, and is useful when painting deformation textures.

Paint Sculpt Map

Opens the 3D Paint Tool for you to paint deformation 
strengths over the surface of the deformer. Also, Paint Sculpt 
Map creates a new file texture and connects it to the sculpt 
deformer’s Texture attribute. If a non-file texture is connected 
to the deformer, clicking this button disconnects it.

For more information, see “Texturing > 3D Paint Tool” in the 
Paint Effects, Artisan, and 3D Paint guide.

Restrict the direction of a surface’s jiggle

With the Jiggle deformer’s new Direction Bias attribute, you can 
control the direction of a surface’s jiggle relative to the direction of 
its normals. A Direction Bias of 1.000 causes a jiggle deformed 
surface to move only in the direction of its normals and a 
What’s New in Maya 6

208



5 | Character Setup
 > Restrict the direction of a surface’s jiggle
Direction Bias of -1.000 causes a jiggle deformed surface to move 
only in the opposite direction of its normals. A Direction Bias of 
0.000 causes the jiggle deformed surface to move in both 
directions. The default Direction Bias value is 0.000.

You can use the Direction Bias attribute to prevent any unwanted 
collapsing of a jiggle deformed surface. For example, if you are 
animating the jiggly stomach of a sumo wrestler, you can set the 
Direction Bias attribute’s value to 1.000 so that the surface of the 
character’s stomach will only jiggle outward.

For more information on the Jiggle deformer, see “Jiggle 
deformers” in the Deformers chapter of the Character Setup 
guide.

Direction Bias -1.000 Direction Bias 0.000 Direction Bias 1.000

Base surface

Jiggling surface

Direction of surface normals
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Create a Cluster for each CV on a curve

You can now create a cluster deformer for each CV on a curve by 
selecting Edit Curves > Selection > Cluster Curve from the 
Modeling menu set. This is useful for manipulating Spline IK 
curves. For more information, see ”Curve/CV Selection” on 
page 96.
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Deforming particles

Previously, deformers could only affect objects whose structure 
was defined by control points. In Maya 6, most deformers can 
now affect the behavior of particles. Deformers let you influence 
particle positions in a variety of ways. 

To deform particles

1 Create a scene with particles.

2 Select the particle object.

3 In the Animation menu set, click Deform.

4 Select the deformer you want to use on the selected particle 
object. You can deform particles with all deformers except for 
the skinning and blend shapes deformers.

The deformers operate in the same way as they do for 
geometry. You can also layer deformers. 

A bend 
deformer 
applied to 
particles (left) 
and geometry 
(right)
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You can also combine particle deformation with forces: deform 
the particles, then apply the desired forces to the intermediate 
object. Alternatively, you could apply forces to particles before the 
application of a deformer.

Per-particle field attributes

You can now manipulate field attributes on a per-particle level. 
This functionality works for the case where particleShape is used 
as the source of the field, as well as the case where the 
particleShape is affected by a field. In the case where the attribute 
is affected by both, the value from the particleShape acting as the 
source of the field will take precedence.

If the particleShape is acting as the source of the field, this feature 
allows each field to behave its own way. If the particleShape is 
simply affected by a field, this feature allows each particle to be 
affected by a unique set of field attributes.

To apply per-particle field attributes

1 Apply a field to a set of particles.

2 In the particleShape Attribute Editor, expand the Add 
Dynamic Attributes section, if necessary.

Note Particles affected by deformers do not exhibit inertia. 
Attributes such as velocity are not affected by 
deformations of particle shapes, and should be 
accounted for when animating particles using 
deformers.

For example, particles within a flow deformed with a 
bend deformer will not slow down or speed up in 
relation to their position within the bend.
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3 Click the General button. The Add Attribute dialog box is 
displayed.

4 Create a per-particle attribute of float or vector type on the 
particleShape with the name 
fieldName_attributeLongNameOnTheField or 
fieldName_attributeShortNameOnTheField. The type for the per-
particle attribute you use must match the attribute type on the 
field. 

For example, create airField1_magnitude to control the 
magnitude on airField1.

5 Write an expression to control this attribute.

6 In the field’s Attribute Editor, go to the Special Effects tab, and 
turn on Apply Per Vertex.

Per-particle goalU/goalV attributes for 
poly goal objects

Previously, goalU/goalV values were only respected for NURBS 
goal objects, and polymesh goal objects could only attract particles 
to their mesh vertices. In Maya 6, per-particle goalU/goalV 
attributes apply to polymesh goal objects, letting you specify 
particular points on the goal mesh surface to which particles will 
be attracted. Animation of goalU/goalV values, as well as the goal 
object and its UV coordinates, is fully supported. 

The following figure shows the Attribute Editor for polymesh 
goal objects. For each polymesh object, a UV Set control has been 
added to let you decide which UV set to use when determining 
the goal position of a particle given its goalU/goalV values.
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Since UV mappings on polymesh objects are arbitrary, it is 
possible that a given goalU/goalV pair may map to more than 
one point on the goal surface. If there are multiple potential goal 
points for a particle, Maya selects the point that is closest to the 
particle’s current position in world space, and uses that as the 
goal position. This decision is recomputed at every frame, so if the 
particle moves closer to one of the other potential goal positions, 
the particle will be attracted to that goal position instead of the 
original goal position.

UV Set 
controls
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Similarly, it is also possible that no point on the object matches the 
specified goalU/goalV values for a particular particle. In that case, 
the mesh vertex that is closest in UV space to the specified goal 
point is used. This decision is updated at every frame.

Expression applied before and after 
dynamics

In Maya 6, runtime expressions can now be evaluated before, 
after, or both before and after dynamics calculations.

The Runtime before Dynamics, Runtime after Dynamics, and 
Creation options located in the Particle section of the Expression 
Editor is where you specify when the expression you create is 
executed. To create runtime expressions that are evaluated both 
before and after dynamics, create a Runtime before Dynamics and 
a Runtime after Dynamics expression.

Scene files and scripts created with a previous version of Maya 
will still produce the same results.

Note For polymesh goal objects, if a particle’s goalU/goalV 
values are not present on the goal surface (that is, they 
are unmapped), the particle is attracted to the vertex 
nearest to the specified values. This may lead to the 
particle hopping between vertices of the mesh if the goal 
UV values are animated through unmapped space.
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Multiple random number streams for 
particles

In Maya 6, support for multiple random number streams has been 
added to the MEL language. Streams can be created, deleted, 
selected, and queried. This functionality lets you control the 
generation of a specific set of random numbers and ensure that 
they are repeatable.

For example, you can now create different repeatable random 
number streams for different expressions in the same scene. This 
will let you avoid having to use the same random number stream 
for the entire scene.

For more information, see ”Multiple random number streams” on 
page 357.

Textured surface emission for poly 
surface emitters

In Maya 6, polymesh surface emitters can now take advantage of 
the texture-based tools that were previously only available to 
NURBS surface emitters. Animation of the poly emitter and its UV 
coordinates are fully supported. 

The existing controls behave exactly as they do for NURBS surface 
emitters. One additional control has been added to let you select 
the UV set on the poly emitter that is used for textured emission 
effects. The same UV set is used for all textures attached to all 
textured emission effects (color/opacity and emission rate). If the 
UseCurrentUVSet option is selected, then the active UV set on the 
surface emitter is used.
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In addition, the Need Parent UV control now also applies to 
polymesh surface emitters. When this flag is enabled, emitter 
particles will have their parentU/parentV attributes set to the 
(U,V) values of the points at which they were emitted, relative to 
the selected emitter UV set.

Ability to disable script output on particle 
events

In previous versions of Maya, specifying a particle collision 
callback would first echo the collision callback command to the 
Script Editor before executing it whenever a particle collision 
occurred. In scenes containing thousands of particles, this could 
slow down playback and unnecessarily clutter the Script Editor 
output. In Maya 6, we have added the ability to disable script 
output on particle events.

The Echo Collision Commands option in the Maya preferences 
will allow you to enable or disable this behavior. It is checked 
(enabled) by default.

To enable/disable script output on particle events

1 Select Window > Settings/Preferences > Preferences.

The Maya Preferences window appears.

2 Click Dynamics under Settings to open the Dynamics 
Preferences.

Note For the textured surface emission controls, full UV-
linking of the attached textures is not supported. All 
attached textures (for emitted color, opacity, and 
emission rate) perform their lookups in the same UV set, 
namely the one specified in the new UV Set dropdown 
in the Texture Emission Attributes section of the 
emitter’s Attribute Editor.
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3 Do one of the following:

• Turn off the Echo Collision Commands to disable script 
output on particle events.

• Turn on the Echo Collision Commands to enable script 
output on particle events.

4 Do one of the following:

• Click Save to save all changes to the Dynamics 
Preferences. The Maya Preferences window remains open.

• Click Cancel to disregard any changes to the Dynamics 
Preferences. The Maya Preferences window closes.

Solvers > Interactive Playback

The Interactive Playback mode lets you interact with dynamic 
objects and see the simulation update as you playback. For 
example, you can shake an object with jiggle applied to it to view 
the effect immediately.

This playback mode can now be started by selecting Solvers > 
Interactive Playback in the Dynamics menu set, or by typing play 
-record in the Script Editor.

Parenting hinge constraints

In Maya 6, a hinge constraint parented to another object now 
behaves as expected after the parent is rotated.

Note When using Interactive Playback, playback looping is 
disabled.
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General rendering

Adobe Photoshop file support

(For Maya Software, Maya Hardware, and mental ray renderers.)

Photoshop files (version 6.0+) are now supported, facilitating 
simple painting workflows in the following ways: 

• You can use any existing Photoshop file as a texture in Maya, 
anywhere you would normally apply a texture. 

Paint layers in layer sets in 
Photoshop

...and see them in Maya

UV snapshots help 
you paint accurately
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• You can convert a PSD file with layer sets to a Layered 
Texture in Maya to help visualize and work with the 
individual layer sets.

• You can create a layered PSD file from within Maya in order 
to paint multiple channels (color, bump, specular, etc.) 
separately on an object, in Adobe Photoshop. 

• You can use Maya’s 3D Paint Tool to sketch out (“lipstick”) an 
object to act as guidelines for the areas on the Photoshop 
image that should be painted, useful when UVs are 
inappropriate or unavailable to be used as a guideline. 

• At anytime, you can modify a PSD file in Photoshop, then 
update (refresh) the image in Maya to see the modifications 
immediately. 

Use PSD files in Maya

The PSD File node lets you use a PSD file as a texture in Maya. It 
is similar to Maya’s File texture node, but it’s for PSD files only.

By default, Maya links a PSD file to the composite image, which is 
included in the PSD file. Maya can only read image and vector 
layers, so when the PSD node is linked to Photoshop’s composite 
image (it is by default), Maya supports anything that Photoshop 
supports, including (for example) layer styles, adjustment layers, 
text, and so on.
What’s New in Maya 6

220



7 | Rendering
 > Use PSD files in Maya
However, you can choose to link the PSD node to a layer set 
instead, in which case layer styles and adjustment layers are not 
supported and should be rasterized before the PSD file is read in 
Maya.

The advantage of PSD files with layer sets 

PSD files with layer sets facilitate iterative painting:

• Photoshop artists can add, modify, or delete any number of 
layers within a layer set while maintaining the connections in 
Maya (see also ”Create a PSD file with layer sets from within 
Maya” on page 222). 

• Maya artists can convert a PSD node to a Layered Texture, 
and see the layer sets as multiple PSD File Textures connected 
to a layered texture in Hypershade.

To use an existing PSD file in Maya

1 In Hypershade, load your PSD image file with the new PSD 
File Texture node (Create Maya Nodes > 2D textures > PSD 
File Texture).

The PSD file is linked to Photoshop’s composite image. 

2 If the file has multiple mask channels, you can choose which 
one to see. Select the mask from the Alpha to Use attribute in 
the Attribute Editor.

3 If the PSD file has layer sets, you can choose  a layer set to link 
to. Select the layer from the Link to LayerSet attribute in the 
Attribute Editor.

4 As with any File Texture in Maya, you can set any PSD File 
Texture attributes. 

Note Maya treats all layers within a layer set as a single 
flattened image.
What’s New in Maya 6

221



7 | Rendering 
  > Create a PSD file with layer sets from within Maya
See ”PSD File Texture attributes” on page 226.

To convert an existing Photoshop File Texture with 
layer sets to a Layered Texture

1 In Hypershade, do one of the following: 

• Right-click a PSD File Texture, then select Convert to 
Layered Texture.

• Select Edit > Convert PSD to Layered Network.

2 To see the multiple layer sets connected to the layered texture, 
regraph the layered texture.

Create a PSD file with layer sets from within 
Maya

When you create a PSD file from within Maya, you select the 
channels to be painted in Photoshop. 

These channels are then represented in Photoshop as layer sets, 
and you can add, edit, or delete any layer within a layer set (see 
also ”Use PSD files in Maya” on page 220). Any changes you 
make in Photoshop are piped back into the appropriate channels 
in Maya when you update the PSD node (see ”Update PSD 
textures” on page 225).
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To create and use a layered PSD file in Maya

Make sure UVs fit within the 0 to 1 texture space (see the online 
documentation for details) and select the required material (like 
Phong, for example).

1 Select the object you want to paint. 

2 Select Texturing > Create PSD Texture.

The Create PSD Texture window opens. 

3 Type the name of the Photoshop file to be created, and set any 
of the options (or use the default). 

Note An optional UV snapshot works as a guideline to help 
you paint the texture with greater accuracy. You can 
create a UV snapshot when you create a layered PSD file 
in Maya (see ”To create and use a layered PSD file in 
Maya” on page 223).

Channels you select from the first column and add to the 
second column become layer sets in Photoshop.

For a detailed (advanced) list of attributes, turn on Detailed Attribute List. 
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For information on the options, see ”Create PSD Texture 
window” on page 226.

4 In the list of Attributes, double-click an attribute you want to 
paint to add it to the list of Attributes. Repeat for additional 
attributes you want to include. If you want to paint an 
attribute not shown in the list, turn on the Detailed Attribute 
List.

5 Select Create. 

An empty PSD file is created by Maya with layer sets for the 
selected attributes you want to paint. The background colors 
are taken from the material.

6 Locate the PSD file in the sourceimages directory of your 
project.

7 Open the file in Photoshop. 

• Each attribute to be painted is represented by a layer set, 
and you can add or delete as many layers as you want 
within a given layer set. Maya treats each layer set as a 
separate flattened image, and the material’s base color is 
used.

• If you opted to include a UV snapshot, it is inserted on 
the topmost layer as reference for painting. (This layer 
does not contribute to the render.) 

8 Paint the layers in Photoshop, then save the file. 

9 In Maya, select Texturing > Update PSD Textures.

Each of the PSD image file’s layer sets are represented by a 
separate node attached to the PSD file node. 

Sketch out guidelines (“lipstick”) for paint 
application

You can use Maya’s 3D Paint Tool to initially sketch out 
(“lipstick”) where paint should be applied to an object. Painters 
can then paint more strategically in Photoshop because they can 
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easily see where to apply the paint. This works especially well for 
models with UVs that don’t give you enough information to paint 
effectively.

To lipstick a model

1 Roughly paint what you want to see (for example, eyes, 
mouth, beard) on the model with Maya’s 3D paint Tool (see 
”The paint tools” on page 17 in the Maya Help for details), then 
save the scene. 

2 Follow the steps to create and use a PSD File texture. See 
”Create a PSD file with layer sets from within Maya” on 
page 222.

The painted textures are inserted as the base layer in each 
layer set.

Update PSD textures

When you modify a PSD file (in Photoshop) that is connected to a 
Maya PSD node (in Maya), you can update (refresh) the image in 
Maya to show the modifications immediately. 

To update a PSD texture in Maya

• Select Texturing > Update PSD textures. All PSD textures in 
the scene are updated.

Note You can also start by mapping file textures (rather than 
using the 3D Paint Tool.

Note Once you have created the PSD, you cannot go back to 
3D Paint for those attributes.
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PSD File Texture attributes

Most of the PSD File Texture attributes are the same as Maya’s 
File Texture Node; see ”File” on page 167 in Shading guide for 
details.

Disable File Load

For more information, see ”Disable the initial load of a file 
texture image” on page 245.

Use Image Sequence

See ”Improved ability to use image sequences” on page 245.

Create PSD Texture window

Image Name

Type the name of the Photoshop file you will be painting. By 
default, Maya uses the scene name and model name.

Size X

Sets the horizontal resolution in pixels.

Size Y

Sets the vertical resolution in pixels.

Keep Aspect Ratio

Constrains the proportions of the X and Y resolution. That is, 
if you move the X slider, the Y slider moves an equal distance.

Include UV Snapshot

Creates a UV snapshot as a guideline to help you paint with a 
greater degree of accuracy in Photoshop. 

UV Set

Specifies which UV Set to use for the UV Snapshot.
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Color Value

Specifies the color to be used for the UV mesh in the snapshot 
image.

Anti-alias Lines

Specifies whether or not the lines forming the UV mesh in the 
snapshot image are anti-aliased. Anti-aliased lines appear 
smoother, but extend over more than one pixel with varying 
opacity.

Attributes, Selected Attributes

Choose from this list of default Attributes for the material. (If 
you want more advanced options, turn on Detailed Attribute 
List.)

Selected attributes in the Selected Attributes list represent the 
channels to be painted. When you open the PSD file in 
Photoshop, each attributes listed here appears as a layer set. 

The following table shows the default available channels that 
correspond to the layer sets that are created when you create 
the PSD file. 

Lambert Blinn Phong Phong E

Color x x x x

Transparency x x x x

Ambient Color x x x x

Incandescence x x x x

Bump Map (Normal 
Camera)

x x x x
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Detailed Attribute List

Shows a more detailed list of advanced options you can paint.

High quality interactive shading

You can now see high quality representations of your work in the 
scene views as you build and modify (shade, texture, and light) 
your scenes. High quality shading uses the same technology that 
produces hardware renders almost instantly in Render View or 
for batch rendering.

Displacement x x x x

Diffuse x x x x

Translucence x x x x

Specular Color x x x

Reflectivity x x x

Reflected Color x x x

Eccentricity x

Specular Rolloff x

Roughness x

Highlight size x

Whiteness x

Cosine Power x

Lambert Blinn Phong Phong E
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When high quality interactive shading is turned on, the scene 
views are drawn in high quality by the hardware renderer. This 
lets you see a very good representation of the look of the final 
render without having to software render the scene. 

The following is not supported:

• motion blur

• software multi sampling

Turn on High Quality shading

To turn on high quality shading

1 Make sure smooth shading (or higher) is on (press 5, 6 or 7).

2 In the desired scene view, select Shading > High Quality 
Rendering. 

Hardware renderer Display options

Display Quality

Low Quality Lighting

Low quality lighting is essentially per-vertex lighting, which 
calculates light only on vertices, then blends the results. 
Renders are faster and of reasonably good quality. 

Match Viewport Lights

When turned on, only as many lights as are supported by the 
graphics card (typically 8) are used. 

Tip If you require faster playback or camera tumbling while 
using Maya’s High Quality shading, turn on Interactive 
Shading (Shading > Interactive Shading).
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Transparency sorting

The method by which sorting is performed prior to rendering 
to improve transparency.

Per object  Transparent objects are sorted and drawn 
from furthest to closest in distance. This 
option provides faster results but may not 
render complex transparent objects 
correctly.

Per polygon  Each object's polygons are sorted and drawn 
from furthest to closest in distance from the 
viewer. This option provides more accurate 
transparency representation but may take 
longer to process.

Transparent Shadow Maps

Those regions of an object which are fully transparent will not 
cast a shadow. For example if you map the transparency 
channel of a shader (on an object) to a checker texture the 
fully transparent portions of the object would not cast a 
shadow.

Display Parameters

Occlusion Culling

This option improves performance for scenes with many 
objects, where one or more objects can be obscured from the 
viewpoint of the active camera. When turned on, this option 
increases performance by preventing out-of-view objects from 
being drawn. 

Culling Override

Every position on a surface has a normal which points in the 
direction that is considered (for culling purposes) to be the 
"front side" of the surface. 
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• Single sided means the surface is illuminated by a light if 
that normal is visible from the light. 

• Double sided means that the surface is illuminated on the 
front and the back sides. 

Color Texture Resolution

If hardware rendering cannot process a shading network on 
board the graphics hardware, the shading network is 
evaluated and converted to a file texture (2D image) that the 
hardware renderer can use. 

This option specifies the dimension of the resulting texture. 
Affected channels are color, incandescence, ambient, reflected 
color, and transparency. The default value is 128, which 
means that any baked color images will have a dimension of 
128 by 128 pixels.

Bump Texture Resolution

If hardware rendering cannot directly process a shading 
network on board the graphics hardware, the shading 
network is evaluated and converted to a file texture (2D 
image) that the hardware renderer can use. 

This option specifies the dimension of the resulting texture. 
The default value for this option is 256, which means that any 
baked bump images will have a dimension of 256 by 256 
pixels.

Interactive Shading Mode improvements

Two new options have been added to the new interactive shading 
options window. 

The options in this function drop the display mode down to a 
level (based on selected options), letting you choose the mode that 
best matches the speed with which you want to refresh the screen 
while interacting with the scene (for example, tumbling). As 
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always, faster refresh rates mean objects are drawn with less 
fidelity; however, lower fidelity levels let you work faster while 
interacting with objects. 

To use and set option for Interactive Shading Mode

1 In a panel, select Shading > Interactive Shading > . The 
Interactive Shading Option box appears. 

2 Set the options. See ”Shading (Panel menu) > Interactive 
Shading > ” on page 232.

Shading (Panel menu) > Interactive Shading > 

Interactive shading mode

WhenHigh Quality Rendering is turned on, this option 
smooth shades the display of objects using the standard 
quality hardware renderer. 

High Quality 

Rendering When High Quality Rendering is turned on, 
this option shades objects using the 
hardware renderer, but you can set the 
following options to quicken the refresh 
while interacting: 

Note Though the interactive shading options have moved to 
the new interactive shading option window, the 
Wireframe, Bounding Box and Points options still 
behave the same way they did in previous versions of 
Maya.
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Small Object Culling

Enables occlusion culling, determined by a value you specify 
for the size of an object (or the unobstructed portion of it), 
relevant to the screen size (in percentage or pixel values). Any 
object that falls below this level is not drawn. 

Example: If an object occupies 5000 pixels out of a viewport 
which shows 10000 pixels, then a tolerance of 50% would 
make the object fall below tolerance and therefore not be 
drawn. 

Disable Shadows

During interaction no shadows are drawn.

Backface Culling

During interaction, all polygon faces that face away from the 
viewer are not drawn. 

Hypershade performance improvements

The time required to open Hypershade or to switch between tabs 
within Hypershade has been significantly reduced. 

For very large scenes, some types of Hypershade Scene Tabs may 
still take some time to refresh the first time they are activated. 
Subsequent activations of the tab take only a few seconds to 
refresh.
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Organize render nodes with Hypershade 
sorting bins

Sorting bins, which are containers for shading nodes (materials, 
textures, etc.), have been added to Hypershade to help you 
organize and track shading nodes in your scenes. 

A default Master bin contains all shading nodes in your scene. 
You can add any number of additional bins to a scene and assign 
nodes to one or more of those bins. By strategically naming the 
bins, (for example, wood, metal, doors, foliage), you can quickly 
and more easily locate shading assets to work with them.

The Master Bin 
(default) contains all 
shader nodes
in a scene.

Add and name any 
number of bins, and 
assign assets to bins.
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To select (see the contents of) bins

When you select one or more bins, you can see the contents of the 
bins.

• To select and see the contents of one bin, click the bin.

• To select multiple bins, do one of the following:

• Shift+click a range of bins.

• Ctrl+click each bin you want to select.

• Ctrl+click a bin to toggle between selecting and deselecting it. 

To create a new empty bin

1 In the Hypershade Bins tab, click the Create Empty bin 
button. The New Bin Name window appears. 

2 Type the new name, then click OK. A new empty bin appears.

To create a new bin with selected content

1 Select the assets you want to add to a bin.

2 In the Hypershade Bins tab, click the Create bin from selected 
button. 

Notes • When a node is assigned to a bin, all the shading 
nodes upstream to this node are also assigned to 
this bin. 

• The Hypershade asset tabs (Materials, Textures, etc.) 
exist for all sorting bins, allowing for further 
organization and filtering. 

• While shading nodes can be assigned to more than 
one bin, they are not duplicated in the scene. 
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To rename a bin

1 In Hypershade, right-click the bin.

2 Select Rename.

To duplicate a bin

1 In Hypershade, right-click the bin.

2 Select Duplicate. The bin is duplicated and all the same assets 
are assigned to it.

To select assets

• To select one asset, click the asset. 

• To select multiple assets, do one of the following:

• Marquee drag across the assets.

• Shift+click to switch between selecting and deselecting an 
asset.

• To select assets that are not assigned to a bin, in the 
Hypershade Bins tab, click the Select unsorted content button. 

To add assets to a bin

In Hypershade, do one of the following:

• Select the assets you want to add to a bin, then right-click 
bin and select Add Selected. 

• Select the assets you want to add a bin, then middle-drag 
them to the bin. 

• To add a single asset to a bin, drag it to the bin. 

To make assets exclusive to one bin 

This procedure removes selected assets from all other bins.

1 In the Work Area, select the assets you want to make 
exclusive to one bin.
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2 Right-click any existing bin.

3 Select Make Selected Exclusive. 

To remove some assets from a bin

1 Select the assets you want to remove from a bin.

2 Right-click the bin.

3 Select Remove Selected. 

To remove all assets from a bin

• Right-click the bin, then select Empty.

New menu item in Hypershade

The following menu item lets you highlight all the node swatches 
from selected object:

Edit > Select Materials from Object All

If you want to know which materials are used by objects A,B,C, 
you can first select objects A,B,C, then select this menu item to 
select materials related to A,B,C. 

Objects A,B,C will no longer be selected. The initial objects you 
selected can be a normal object or a group or faces of a polygon 
geometry.

Node filtering improvements in 
Hypershade

Every scene tab (also called an Asset tab) in Hypershade has new 
controls for filtering the nodes displayed in the tab (similar to the 
ones in HyperGraph). 
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By default, each scene tab has an implicit filter that is determined 
by the tab type specified when the tab was created (or by the 
default tabs when the scene was first created). The tab only 
displays nodes that pass this filter, and you cannot disable this 
filter. For example, a Materials tab shows only material nodes. 

However, you can now filter the nodes in a tab by name (in the 
text box) or by type (with the Show button). 

At any given time, one or more of these filters can apply to each 
scene tab. Only nodes that pass all of the applied filters are 
displayed. You can clear filters at any time.

Clear button

Click to clear any applied filters (beyond the implicit one) and 
return the tab to its default contents. 

The text box

Lets you type in a character string, which can be a regular 
expression, to specify by name the nodes to be shown. Only 
nodes whose name matches the character string are displayed 
in the tab. 

Show button

Shows a menu from which you can select the types of nodes 
to be shown. 

Objects Choose which object types to show. Select 
Clear Below to turn off all filters.

Invert Shown Reverse the filters so visible objects are 
invisible and invisible objects are visible.

Show All Turns off all filters in the Show menu.

Show 

selected 

types Shows only object types of the same type as 
the current selection.
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Create Entry Lets you save the current filter with a name.

Delete Entry  Lets you delete a saved filter.

Show 

Auxiliary 

nodes Shows node types that are normally not 
shown because they are rarely needed (such 
as underworld nodes).

Auxiliary 

nodes Lets you set what nodes are considered 
"auxiliary". 

New (and support for custom) tabs in 
Hypershade

You can now create several new types of scene tabs (Tabs > Create 
New Tab) in Hypershade to better organize, view, and select 
render nodes. 

The new filtering controls (see ”Node filtering improvements in 
Hypershade” on page 237) work for any new tab you create. 

• The All Nodes tab shows every node in your scene. 

It provides a quick way for you to get an overview of all 
nodes in your scene.
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• The All mental ray Nodes tab shows all mental ray for Maya 
base shader nodes (and any custom shaders) in the scene. 

It provides a quick way for you to get an overview of all 
mental ray for Maya nodes in your scene.

• The rest of the new tab types display specific categories of 
mental ray for Maya base shader nodes (and any custom 
shaders). (The Apply flag on the mental ray for Maya base 
shader (or integrated custom shader declarations) determine 
which of these categories each node falls into.) 

Hide shape and transform nodes in 
Hypershade

Hypershade automatically displays all shape and transform nodes 
that are connected to various types of shading nodes (Shading 
Engine, Switch nodes, for example). 

Often, you want to view only those shapes and transforms that 
influence a shading network and not those that happen to be in 
the Shading Group to express set membership. 

You can now suppress the display of shapes and transforms in 
Hypershade to simplify a cluttered Work Area or to reduce the 
amount of time it takes for Hypershade to refresh.
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To control the display of shapes and transforms

1 In Hypershade, select Options > Display (Work Area Only), 
then specify the options.

2 Regraph to see the change.

No Shapes

No shapes are displayed in Hypershade. 

All Shapes except Shading Group members 

Only shapes that are directly connected to shading nodes are 
shown. Shapes that are only connected to the Shading Group 
are not shown. 

All Shapes

All shapes are displayed, including ones that are connected to 
the Shading Group only for the purpose of expressing set 
membership. 

Transforms

Transforms are shown.

The display of transform nodes in Hypershade is controled by 
the "Transforms" flag in the object’s Attribute editor. 
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Test textures (and texture ranges)

Available on Windows and Mac OS X.

Though most swatches in Hypershade and the Attribute Editor 
update automatically to show your changes as you build shading 
networks, you can now create a full image (or range of images), at 
various resolutions, on any node in a shading network. 

You can use this sample image to see the results of portions of a  
shading network texture or to verify the look of a texture that 
doesn’t have a visual interactive representation (such as Multiply 
Divide or Gamma Correct utilities). 

You can also perform simple compositing within Maya by 
connecting several File node outputs to a layered texture and 
setting the desired attributes. For example, you can composite 
hardware rendered particles over software rendered scenes.

Limitations and conditions

• Utility node’s output must be connected to something 
downstream to see a sample from it.

Tweak textures in scene views 
as usual

...and see your changes in 
Render View

Right-click the swatch, 
then select Test Texture
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• Texture testing supports the native Maya rendering nodes.

• The tested texture always overwrites the same image using 
the same file name (but you can save it to a different name) 
from Render View.

To test a texture on any native Maya rendering node

1 In Hypershade, do one of the following:

• Right-click a render node, then select Test Texture.

• Select the texture, then select Edit > Test Texture.

• If you want to change the resolution first, select the 
texture, then select Edit > Test Texture >  to display the 
options. 

A sample image is rendered in Render View.

2 To save the tested image, in Render View, select File > Save 
As. 

To test a range of images on any native Maya render 
node

• Do one of the following: 

• Select the texture, then select Edit > Render Texture 
Range.

• If you want to change the resolution, file format, frame 
range or padding, select the texture, then select Edit > 
Test Texture Range >  to display the options. 

The rendered range of images is automatically loaded and 
played back in FCheck. 

Edit (Hypershade) > Test Texture > 

x/y resolution

The x and y resolutions in the tested texture.
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Edit (Hypershade) > Render Texture Range > 

Image name

The name of the resulting rendered images. Images are 
written to the images directory of the active project. The file 
name will be padded (for example, checker.0001.iff).

File Format

The file format of the rendered texture images. 

x/y Resolution

The x and y resolutions for the rendered texture images.

Start Frame

The first frame number used for the sequence.

End Frame

The last frame number used for the sequence.

By Frame

The number of frames to advance between the Start and End 
frames (see ”Render Global Settings window” on page 165 in the 
Rendering guide for details).

Padding

The number of padding digits in the number (for example, 
001 is 3, 0001 is 4, and so on).

Fcheck

Launches and loads the newly created sequence into fCheck.
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Disable the initial load of a file texture 
image

To load scenes faster, you can now disable the initial loading of 
file texture images on a per-node basis from disk. 

To disable the initial loading of a file texture image

1 Select the file texture. 

2 In the File Attributes section of the Attribute Editor, turn on 
Disable File Load. 

Disable File Load

Turn this attribute on to prevent the file associated with the 
File Texture node from loading.

Improved ability to use image sequences

You can now more easily use image sequences with image planes 
and File textures. Previous workflow included having to set keys 
(for animation) or write expressions. Maya automates this for you 
now, and can recognize any of the various possible file formats. 

To use an image sequence with an image plane or File 
Texture

1 Create an image plane or File texture, using any of the usual 
methods. 

See ”Create, edit, or position an image plane” on page 265 or 
”Map a 2D or 3D texture” on page 76 of the Shading guide for 
instructions

Note Turning on disableFileTexture off after the file has been 
read does not "unload" the texture.
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2 Turn on Use Image Sequence. 

3 This automatically enters an expression (=frame) into the 
Image Number attribute. The Image Number is equal to the 
Timeline’s current frame.

To add file formats

Find the getFileSequenceFormats.mel file in the 
Maya6.0\Scripts\Others folder.

New image plane and File texture attributes

Use Image Sequence

If off (default), the image plane used is the single image file 
indicated by Image Name (the file name and extension). 

If on, the image loaded corresponds to an image from the 
sequence selected, determined by the Image Number.

Image Number

If Use Image Sequence is on, the default expression of 
“=frame” is used to synchronize the image sequence with the 
Timeline. 

In other words, at frame 1 the image with a numeric value of 
1 in it will be loaded. At frame 24, the image with a numeric 
value of 24 in it will be loaded. 

By modifying the default expression (or removing it and 
setting keys) for Image Number, you specify alternate 
timeline to image sequence number relations. For example, 
setting a key frame of the last image at the beginning of the 
timeline and the first image at the end of the timeline will 
result in reversing the sequence. 
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Frame Offset 

If Use Image Sequence is on, the default Frame Offset is set to 
0, which means that the image sequence numeric value 
corresponds exactly to the timeline frame number. If an offset 
between these values is needed, enter the desired offset in 
frames. For example, if the image sequence numeric value 
starts at 100 but the animation starts at frame 1, enter a value 
of 100 to compensate. Negative offset values are also 
supported.

New command line render utility

There is now a new rendering command-line utility called 
Render.

• To get quick renderer-specific information, type:

Render -r rendername -help

where rendername is the name of the renderer:

• mr = mental ray

• sw = software renderer

• hw = hardware renderer

• vr = vector renderer

Note As a result of these new attributes, the following 
attributes have become obsolete and are removed from 
the UI:

• Use Frame Extension

• Frame Extension
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All flags appear with a brief description. Each flag corresponds to 
the appropriate section of the Render Globals Settings Window 
(see ”Render Global Settings window” on page 165 in the Rendering 
guide)

• To get general information, type:

Render -help

Maya software rendering

New color utility nodes 

For software rendering only.

You can now more precisely define how an input value (value, 
point, color) remaps to a new output value. Three new color 
utility nodes have gradient attributes that give you far greater 
control over remapping than what Ramp textures provide. 

With these new utility nodes, you can (for example): 

• remap and control color values and alpha values separately

• perform simple color correction 

• affect the translation of objects

• finetune or totally change the hue, saturation, and luminance 
of a color

Note The previous command-line render utility has been 
renamed to mayaSWrender and is no longer 
recommended.
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To use a new color utility

1 In Hypershade, select > create Maya Nodes > Color Utilities.

2 Select whichever utility you want to use:

• See ”remapValue utility” on page 250 for a description of 
this utility and strategic uses.

• See ”remapColor utility” on page 251 for a description of 
this utility and strategic uses.

• See ”remapHsv utility” on page 251 for a description of 
this utility and strategic uses.

3 In the utility’s Attribute Editor, adjust the gradient graphs, 
and set the Input and Output ranges.

Input and Output ranges

The input attributes index into the gradient controls, which define 
a new output value. Usually, you connect a varying attribute of 
some sort (such as values from the sampler info node, texture/
shader outColors, or object position) to the input connection. 

inputMin, inputMax

Define the values that remap into the left and the right of the 
gradient controls. 

For example, if your input attribute varied between -1 and 1 
you can set the inputMin to -1 and the inputMax to 1. This 
way your minimum values result in the values defined at the 

Tip Maya’s new color utility nodes work well with the new 
test range feature. See ”Test textures (and texture 
ranges)” on page 242. 
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left of the ramp and the maximum map to the right. Values 
outside the min/max range will be clipped to the value at the 
edges of the gradient. 

outputMin, outputMax

Determine the range of the output attribute. These attributes 
represent the top (max) and bottom (min) values of the 
gradients, or (in the case of a color gradient control) the 
displayed white (max) and black (min) output. 

In some cases, you may want the outputMin/Max to match 
the inputMin/Max. For example if you are remapping the 
cameraNormalY to object color using a remapValue node, 
because the camera normal varies between -1 and 1, the 
inputMin/Max would be set to these values. However we do 
not want black to be -1,-1,-1, so it would make sense for the 
outputMin/Max to be 0 to 1.

remapValue utility

Remaps a scalar input to both scalar and color outputs. The scalar 
output is remapped with a scalar gradient, and the color output is 
remapped using a color gradient. 

You can remap color and alpha values and control each of them 
separately. So, for example, you can define mappings where the 
alpha is the inverse of the color, or where they have different 
ranges. 

Strategic use (an example)

How you use the remapValue depends on what you want to 
remap. 

For example you can vary reflectivity based on the facingRatio in 
either of the following ways: 

• Connect a samplerInfo facingRatio to the inputValue, and 
connect the outValue to your shader's reflectivity.
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• Connect the outColor the shader specularColor.

Initially the part of the surface facing the view will be more 
reflective, but you can reverse this by reversing the gradient 
(make the value gradient go down to the right, or if you mapped 
the outColor make the color gradient become darker to the right).

remapColor utility

Lets you remap a three-channel input (such as RGB color) to 
another three-channel output with three gradient controls for 
more precise shading. 

You can also use this utility for non-shading purposes, however. 
For example, you could connect the translate of one object to 
remapColor.color, then connect remapColor.outColor to the 
translate of a second object, which effectively maps the position of 
one object onto the other. In this particular case, the second object 
initially follows the first then stops outside a zero to 1 bounding 
box. (To increase the size of this bounding range, increase both the 
input and output Min/Max settings.) If you reverse the gradients, 
the second object moves in the opposite direction. And if the 
graphs are wiggly, the motion of the second object would also be 
wiggly. 

remapHsv utility

Lets you adjust the color output of nodes. It converts an RGB 
input to HSV, remaps using separate HSV gradients, then 
converts the result to a color output.

With this utility, you can fine-tune or completely change the hue, 
saturation, and luminance of a color with the provided gradients. 
For example, you could connect the outColor of a file texture to 
the color (input) attribute on remapHsv, then connect the 
remapHsv outColor to your shader color. By editing the gradients 
you could then modify the brightness range or hue of the file 
texture with a great deal of control:
What’s New in Maya 6

251



7 | Rendering 
  > Imported shading network optimizations
• You can make the image black and white make the saturation 
graph all zero.

• You can invert the brightness for an x-ray effect make the 
value graph 1 at the left and zero at the right. 

You can also remap the color of a shader by connecting the 
outColor of the shader into remapHsv.color then connecting 
remapHsv.outColor the outColor of a surface shader node. The 
surface shader then becomes a color correctable version of the 
original shader.

Imported shading network optimizations

By default, when you import a file more than once into Maya, the 
geometry and shading networks are duplicated. These redundant 
shading networks and reassignment of geometry inflate the scene 
size and load time, and clutter your working scene. 

You can now prevent the duplication of a shading network 
(unless, of course, you need it) when you import a scene, or you 
can delete any duplicated network from within your working 
scene. 

To prevent redundant shading networks on import

When you import a scene (File > Import ), turn on Remove 
Duplicate Shading Networks.

To delete a redundant shading network

In Hypershade, select Edit > Delete Duplicate Shading Networks. 

Note The surface shader performs no calculations directly, it 
is simply a placeholder for a shading outColor attribute.
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Maya can now recognize new IMF plug-
ins

You can now see IMF plug-ins listed in the following places: 

• Hardware Render Globals Settings window

• Image plane (input) 

• Render View (input and output) 

• File texture (input) 

Transfer surface information

You can now transfer surface characteristics from one surface to a 
texture map on another. The most common application of this tool 
is in the creation of high-performance, real-time models where 
some surface detail cannot be adequately represented within the 
polygon limit required. 

You can create a higher-detail (non-real-time) model that defines 
the desired details, then transfer the details across onto the real-
time model in the form of a map (for example, a normal map). 

To bake a normal map

1 Select the source surface, then the target surface. 

2 Select Lighting/Shading > Transfer Surface Information > 

3 Set any options, then click Bake and Close, Bake, or Close.

For a description of the options, see ”Transfer Surface 
Information Options” on page 254.
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Transfer Surface Information Options

Target Options

Transfer

Selects the information you want to transfer. 

Object space Object space normals always point in the 
same direction, even if the triangle is 
rotated, so use them for textures on non-
animated objects. 

Tangent 

space 

normals Tangent space normals are defined locally, 
per vertex, and can be rotated by 
deformation. They are good for textures on 
animated objects.

Map width

The width of the texture to be created, in pixels.

Map height

The height of the texture to be created, in pixels.

File name

The filename and location of the texture to be created.

File format

The format of the texture to create (for example, .dds, .bmp, 
.jpg).

Target UV Set

The UV set on the target surface for which this texture should 
be created. 
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The UV set defines how the target surface is mapped into 
texture space. For accurate results, the UV mapping must be 
non-overlapping (that is, you cannot map two different faces 
on the target surface to the same UV region). 

Shading Network

Controls how the newly created texture is displayed on the 
object. 

Preserve 

current 

shading 

network Leaves the current network intact, and 
creates the texture file on the disk; no visible 
change exists in the scene view. 

Attach a color 

channel 

preview 

network Replaces the current network with a simple 
shading network that provides a color-only 
preview of the result on the object itself. 

Attach a Cg 

preview 

network Replaces the current network with a simple 
hardware shader that displays the actual 
result of the mapping on the object; this 
requires the cgfxPlugin to be loaded (see 
”Improved hardware plug-in shader 
support” on page 257), otherwise this option 
is grayed out.

Algorithm Options

Search method

Controls how intersections between the source and target 
surfaces are selected. 
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Use 

outermost 

intersection Instructs the algorithm to find the furthest 
intersection from the target surface that is 
within the search depth. 

This option should be selected to capture 
modeled surface detail such as shoelaces, 
armor, pockets, etc. 

Use nearest 

Intersection Instructs the algorithm to use the closest 
point on the source surface, which prevents 
map artifacts that are caused when 
neighboring parts of the source surface are 
projected across gaps in concave surfaces. 

Common examples are under arms or 
between fingers, where the skin on one 
"side" of a gap is mapped across onto the 
wrong side. When using the first option 
(say, to map the effect of shoelaces), these 
same artifacts can often be removed by 
selecting appropriate Search Depth values.

Search depth 

Controls how far away from the target surface to look for 
intersections on the source surface. For concave models, this 
value should be set to around half of the minimum distance 
between parts of this surface which should remain separate 
(for example, fingers). If you are seeing large areas of the 
result which do not contain the correct surface information, 
try increasing this value. 
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Overscan Pixel Passes

Controls how many pixels to overscan in order to fill UV 
mapping seams and prevent blending discontinuities. Each 
pixel requires an additional pass and will increase the time 
taken to create the result. 

Texture Fill Pass

When turned on, all “empty” pixels in the final map are 
smoothly blended from the surrounding pixels to remove UV 
seam blending artifacts. This occurs after any pixel 
overscanning.

Maya hardware rendering

Performance improvements for hardware 
rendering

Performance-boosting improvements, such as geometry and 
texture caching, have been made to the Hardware Renderer. 

Specific results vary based on the actual graphics card used (refer 
to online qualification charts for the latest information).

Improved hardware plug-in shader 
support 

Hardware plug-in shaders are now supported by high quality 
interactive shading (see ”High quality interactive shading” on 
page 228) and batch hardware rendering. 

Use this new feature to visualize user-defined effects, such as 
color-per-vertex (using the hwColorPerVertexShader plug-in) or 
CgFX shaders (using the cgfxShader plug-in). The API is provided 
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through a new interface on the MPxHwShaderNode which does 
not have dependencies on Maya's UI data types. The majority of 
existing plug-ins are easily portable to the new interface.

Plug-in shaders can take advantage of the following features:

• Shaders are off screen batch hardware renderable. 

• Shaders are capable of shadow casting. 

• Full support for high quality transparency sorting. 

• Full support for mask render output.

• Full support for depth render output. 

• Full support for motion blur. 

• Full support by high quality multi-sampling. 

• Improved draw performance compared to standard shading 
mode in the 3D views.

API plug-in development considerations

Most plug-ins can easily be ported to the new interface by 
implementing glBind(), glUnbind(), and glGeometry(). The bind 
and unbind methods are slightly different compared to the old 
interface; they are called only once per frame. These methods 
should specifically be used to allocate resources, and not to set 
OpenGL state. The old interface is still used by the interactive 3D 
view, but does not need to be provided if the new interface has 
been implemented in the plug-in.

Care must be taken in the allocation and de-allocation of 
hardware resources (i.e., textures, vertex programs, fragment 
programs, etc.) because the batch hardware renderer will delete 
the graphics context at the end of the rendering. Instability will 
result if the plug-in shader allocates resources for batch, and 
attempts to re-use them for interactive. In this case it may be 
desirable to override both bind() and glBind() to determine in 
which situation the draw is being done.
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There is currently no obvious way to determine whether the plug-
in is being drawn for high quality interactive or batch hardware 
rendering. As a result on every refresh to the high quality view 
glBind() and glUnbind() will be called. The plug-in developer 
should take care to re-use resources where possible as allocating 
and de-allocating resources on every refresh will have a 
significant impact on performance.

Color per vertex now supported by 
hardware renderer

The implementation of the colour per vertex (CPV) feature has 
been changed to take advantage of the hardware renderer. (Using 
the PlayBlast or the Hardware Render Buffer to render CPV is no 
longer recommended.) 

This feature is available in the new High Quality Interactive 
Shading mode (see ”High quality interactive shading” on 
page 228) and for the batch hardware renderer. Make sure you are 
using a supported video card (see the Maya Hardware Renderer 
Qualification Chart (online) for more information).

As in previous versions of Maya, you can set color per vertex 
options in:

• the Attribute Editor for a polygonal surface (under the Mesh 
Component Display section)

• from the Custom Polygon Display Options window (Display 
> Custom Polygon Display > )

Note To see if your specific hardware graphics card supports 
color per vertex, run the hardware render diagnostics.
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modulate2x, a new material blend for CPV attempts to mimic the 
texture blend of same name available on games consoles. This 
blend is available only in the High Quality Rendering mode (see 
”High quality interactive shading” on page 228) within the scene 
views and for batch hardware rendering. When High Quality 
Rendering is not turned on, the previous shaded mode display 
provides a very rough approximation of the same function. The 
key difference is that CPV and textures are modulated in High 
Quality Rendering versus CPV and materials, when not in this 
mode.

Implementation details

This new implementation, along with the two new polygon object 
attributes that come with it, allows for a more accurate 
interpretation and display of color per vertex in the following 
ways: 

• Color calculations are more accurate now because they are 
performed in floating point and are not clamped to the frame 
buffer color range until the end (when writing out the final 
pixel color). 

• The quality of lighting is improved because the hardware 
renderer provides a more accurate lighting implementation. 

• Transparency (alpha) is taken into account only when all 
material channels on a shader are overridden, or the color 
channel on the shader is affected and the Material Blend is set 
to Overwrite. 

In all other cases the RGB component of CPV is pre multiplied 
by the CPV alpha before being used.

• When the Alpha Channel (Mask) Output option is turned on 
for the hardware renderer (in the Hardware Render Globals 
UI), the alpha channel is written out as part of the output 
image. This does not affect interactive display. The mask takes 
into account the CPV alpha values based on the Matte 
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Opacity options set for the shader. The alpha channel is taken 
into consideration only when all of the material channels on a 
shader are overridden or the Color channel on the shader is 
affected and the Material Blend is Overwrite. 

• The new implementation takes the alpha component of CPV 
when casting shadows if the Transparent Shadow Maps 
option is turned on for the hardware renderer (in the Render 
Globals Settings window) or the Hardware Renderer Display 
Options option box for the High Quality Shading in 
interactive viewports.

• CPV display is turned on only when Low Quality Lighting is 
not turned on for High Quality Rendering mode in viewports 
(default), or when High Quality Lighting is turned on for 
batch hardware rendering (default). For low quality lighting 
and CPV, disable High Quality Rendering use the old CPV 
display.

Polygon object attributes (Mesh Component 
Display section)

Display Colors 

Choose whether or not to display the internally stored colors 
on the polygonal geometry. By default these colors are not 
displayed. 

Display Color Channel

Indicates which Maya material channel should be affected. 
The mapping for the new implementation is as follows: 

None CPV overrides all material channels.

Ambient Maps to the Ambient Color channel on a 
shader. 
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(Note that the CPV has a visible effect in the 
display only if an ambient light illuminates 
the object.)

Diffuse Maps to the Color channel on a shader. 

Ambient and 

Diffuse Maps to both the Ambient Color and Color 
channels on a shader. 

Emission Maps to the Incandescence channel on a 
shader. 

Specular Maps to the Specular Color channel on a 
shader. In cases where a shader does not 
have this channel, (such as Lambert) the 
shader will act as if a channel did exist and 
was affected by CPV. It is recommended 
that users map the appropriate shader to the 
object for proper correspondence.

Material Blend

CPV values are now blended during lighting and texturing, 
which gives a more accurate result compared to pre-Maya 6, 
which was more an approximation.

New performance-enhancing render 
globals

New hardware render global settings

Small Object Culling

When this performance-improving option is turned on 
(default), opaque objects that are smaller than the specified 
threshold are not drawn. 
What’s New in Maya 6

262



7 | Rendering
 > New hardware render global settings
This option provides the same functionality as the Occlusion 
Culling option found in High Quality Rendering mode in 
viewports (see ”High quality interactive shading” on 
page 228) 

Culling 

Threshold (% 

of image 

size) This is the threshold suboption for the Small 
Object Culling option. The threshold you 
provide is the percentage of the image size 
that an object occupies in the output image. 

If an object is less than that percentage in 
size then it is not drawn. Size is measured in 
pixels in screen space (relative to the camera 
used for rendering). The default percentage 
is 0 percent. 

This option ignores View > Camera Settings 
options (such as Gate and Fill options), 
which are used for image output only.

E.g. % = 10.0. Image size 100 by 100 (pixels). 
The threshold in pixels would be 100X100 * 
.10 = 1000 pixels. If an object was less than 
1000 pixels in size then it would not be 
drawn. 

E.g. % = 0.0 Image size 100 by 100 (pixels). 
The threshold in pixels would be 100X100 * 
0 = 0 pixels. If an object was less than 0 
pixels in size then it would not be drawn. 
This can occur when one opaque object 
completely obscures another object with 
respect to the current camera used for 
rendering.
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mental ray for Maya rendering

mental ray shader manager 

The Shader Manager lets you interactively load and unload mental 
ray shader libraries and work with them during a Maya session. 
(You no longer need to shut down first, and you no longer need to 
set the environment variable MI_CUSTOM_SHADER_PATH.)

You can select from a list of.mi library files that contain the 
mental ray shader declarations. The shaders contained in the 
selected.mi library files automatically appear in Hypershade, just 
like the Maya and mental ray for Maya base shader nodes. mental 
ray for Maya base shaders are now fully integrated into 
Hypershade and Create Render Node panel.

(You no longer need to set the environment variable 
MAYA_MRFM_SHOW_CUSTOM_SHADERS to show custom shaders in 
Hypershade.)

To load or unload custom mental ray shaders

1 Select Window > Rendering Editors > mental ray > Shader 
Manager. 

The Shader Manager opens and shows which declaration files 
are loaded. 

2 Click to load or unload a declaration file, auto load the file, or 
get information on the file.

Note Though you can dynamically load/unload shaders in 
render time, those shaders that are used should be 
specified in the maya.rayrc file.

The maya.rayrc file requires both .mi and/or .so of the 
desired libraries to be included. 
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Window > Rendering Editors > mental ray > 
Shader Manager

Auto-load

These buttons show which files have been loaded by means of 
the MI_CUSTOM_SHADER_PATH mechanism.

Information button

This button displays a window that shows you which node 
types have been created from a loaded declaration file. 

Browse button

Opens a File Browser window that allows you to locate and 
load .mi declaration files not yet listed in the Shader Manager. 

Simplified shader connection workflow 

You can now work with mental ray for Maya shaders the way you 
do with Maya render nodes. That is, you can now drag and drop 
mental ray for Maya shaders in Hypershade to make default 
connections (or to choose from a list of common connections) to 
objects. The default connection is based on the type of shader you 
want to connect. 

IPR rendering with mental ray for Maya

mental ray for Maya now supports Interactive Photorealistic 
Rendering (IPR). 

IPR lets you interactively adjust attribute values and node 
connections in your scene and instantly see the rendered results in 
Render View. 
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Limitations

Supported while IMR is active:

• any connection change to supported shading nodes, including 
light and camera shading attributes

• any value change on supported shading nodes, even without 
stopping renderer if considered safe, including light and 
camera shading attributes

• any custom mental ray nodes connection/value changes

• any geometry type shading, including particles,

• fluids, and fur, with some exceptions

• any raytrace shading effect if raytracing is turned on

• global illumination impact on shading nodes (via irradiance)

• contour tuning via object attributes if contours are turned on

• post effects tuning, like shader glow

• render region change

• refresh render whole image

• pause mode

• creating and assigning a new shader through UI

• 'assign new/existing material' or create in Hypershade and 
drag to the object

NOT supported while IMR is active:

• Render View: resolution change, render camera change, 
render options, render globals, any options changes

• Shading nodes: texture nodes (color remap create)

• Materials: material assignment if the material is created 
outside IMR

• Lights: creation, transformation (orientation, movement, 
scaling)
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• Cameras: creation, camera view change, transformation

• Geometry: creation, tessellation/approximation change, 
displacement change

• mental ray features: photon tracing (done before IMR loop), 
final gather tracing (mostly done before IMR loop)

mental ray for Maya command line options

The following mental ray for Maya command line options are 
supported during IPR: 

-rg/region

Update the IPR region to the selected one.

-rr/regionRect

Set a new IPR region explicitly (works together with -region).

-pt/pauseTuning

Controls actual rendering of IPR requests, shader changes are 
always recognized in all cases.

-q -imr

Returns true (1) if IPR is active.

New features and support improvements

Support for Maya Fluids

You can now render Maya Fluid Effects as volumes or surfaces 
with mental ray for Maya, and you can use them as 2d or 3d 
textures. Fluids can also be exported to .mi format for offline, 
standalone rendering. 

For more information, see ”Rendering Fur in mental ray” on 
page 309.
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Limitations 

• You cannot render the pressure grid.

• Some differences in rendered results may occur. 

• Receive shadows in the Render Stat should be turned on to 
get self shadowing.

Support for Maya Fur

You can now render Fur in mental ray using the standard Fur 
workflow. 

Fur in mental ray is rendered with hair primitives within the main 
render pass, rather than as a post process. This allows Fur to show 
up in reflections and refractions, and through transparent objects. 

For more information, see ”Rendering Fur in mental ray” on 
page 309.

Integrated contour rendering 

You can now render simple contour lines for non-photorealistic 
rendering using the standard shading and lighting workflow. 

You can control contour rendering by defining the color and 
width of lines in the Shading Group and Render Globals. 

Some examples of simple 
contour rendering
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You can still use the mental ray for Maya base shaders (or any 
custom shaders) to render more sophisticated contour effects, 
beyond the standard contour rendering now provided. (See 
”Custom shaders” on page 275.)

To render contours

1 In the mental ray tab of the Render Globals Settings window, 
set the desired contour attributes, then enable contour 
rendering. 

For descriptions of options, see ”Contours (Render Global 
Settings window)” on page 269. 

2 For the Shading Group node of each object to participate in 
contour rendering, set the contour attributes. 

See ”Flag objects to participate in contour rendering (object 
Shading Group)” on page 275. 

Contours (Render Global Settings window)

The following attributes control the location and characteristics of 
contour line rendering.

General

Enable Contour Rendering

Turn on or off (default) contour rendering. 

Hide source

When turned on, only the contour is visible (that is, the object 
that causes the contour invisible). 

Note If all controls are disabled and all contrasts are 0, 
contour rendering is disabled. 
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Flood color

When Hide Source is turned on, this is the colour used to 
flood or fill the entire frame as the background colour before 
rendering the contour. In other words, this is the color onto 
which the contours caused by Hide Source are drawn. 

Quality

Over-Sample

Improves the quality by processing at N times larger than 
sampling down to the correct size. If this value is set to 2, the 
contours are processed at twice the resolution, so the quality 
(anti-aliasing mostly) will be approximately twice as good.

Filter Type

The filter type used when downsampling contours to image 
resolution. 

Filter Support

The filter support as (fractional) number of pixels. 

By Property Difference

Options in the detection section let you define the locations at 
which mental ray for Maya detects and draws contour lines.

Around Coverage
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Draw contour lines based on pixel coverage (where rendering 
samples detect objects are present) based on a pixel being 
covered by the object. 

Between Different Primitives

Draw contour lines between different primitives.

(Enabling this in effect draws tessellations.) 

Between Different Instances

Draw contour lines between different instances. 

Between Different Materials
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Draw contour lines between primitives with different 
materials. 

Between Different Labels

Draw contour lines between different labels (these are not the 
same as character labels).

Around Coplanar Faces

Draw contour lines between different normals. 

Front vs. Backface Contours

Draw contour lines between, if the sign of the dot product of 
the normal vector and the view vector differs from one 
sample to the other. 

By Sample contrast

Enable Color contrast

Turns on or off (default) the color contrast setting. 
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Color Contrast

Draw contour lines between pixels that have a color difference  
that is larger than the set value. 

Enable Depth contrast

Turns on or off (default) the depth contrast setting. 

Depth Contrast

Draw contour lines between pixels whose depth difference (in 
camera space) is larger than the set value. 

Enable Distance contrast

Turns on or off (default) the distance contrast setting. 
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Distance Contrast

Draw contour lines between pixels whose distance is larger 
than the set value. 

Enable Normal contrast

Turns on or off (default) the normal contrast setting. 

Normal Contrast

Draw contour lines between pixels whose normal difference is 
larger than the set value. (Normal difference is measured in 
degrees.) 

Enable UV contours

Turns on or off (default) the UV contour setting. 
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UV Contours

Draw contour at every Uth and Vth isoline of the primary UV 
space. 

Rendering/Compositing

These controls map to a mental ray for Maya output shader. This 
shader is respected only if at least one contour detection criterion 
is triggered (or custom shaders are connected) and Enable 
Contour Rendering is turned on. 

Custom shaders

You can connect mental ray for Maya base contour store and 
contrast shaders here. Any shaders connected here override the 
integrated contour rendering feature. 

Flag objects to participate in contour rendering 
(object Shading Group)

Each shading group can have individual contour rendering 
attributes defined. Set the following options to achieve the desired 
look.

Enable Contour Shading

Enables contour shading for all objects associated with the 
shading group. 
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Color

The color of the contour lines. This attribute can only be a 
color and cannot have a procedural or texture map connected 
to it.

Alpha

The alpha of the contour lines. 

Width

The width of the contour lines. 

Relative Width

If off, Width is specified as (fractional) number of pixels. If on, 
Width is specified in percents of the horizontal image 
resolution thus maintaining the relative contour size if the 
resolution changes. 

Render blurry reflections and refractions

Blurry reflections Blurry refractions (magnifying glass)

(Uffizi Light Probe image courtesy of Paul Debevec 
(www.debevec.org/Probes)
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Raytraced reflections and refractions are typically rendered 
perfectly sharp, but in the real world, no perfect mirror or 
transparency exists. Instead, small-scale impurities reflect or 
refract light slightly, creating a blurry, glossy look. You can now 
easily render natural looking blurry reflections and refractions 
with mental ray for Maya.

To render blurry reflections and refractions

1 With mental ray selected as the renderer, turn Raytracing on 
in the Render Globals Settings window (see ”Render Global 
Settings window” on page 165 in the Rendering guide). 

2 In the mental ray tab of the desired material’s Attribute 
Editor, set the reflection and/or refraction blur attributes. 

Reflection/Refraction Blur

Determines the blurriness of the reflection or refraction by 
calculating the angle (in degrees) between the perfect 
reflection or refraction direction and the jittered ray direction. 
A value of 0 creates a perfectly specular interaction; a value of 
90 a perfectly diffuse reflection or refraction. Values of 10 to 
30 are good starting points. 

Reflection/Refraction Rays

Specifies how many rays to use to sample the random 
deviation from the perfect specular direction. (Blurry 
reflections and refractions require supersampling because a 
ray's direction is not precisely determined with this feature. It 
may deviate (randomly) from the perfect specular direction, 
within the bounds specified by Reflection/Refraction Blur.) 

Note Previous workflow involving mental ray for Maya base 
shaders is still supported.
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In general, more rays are required for more blurry reflections 
or refractions. Other sampling parameters also affect this 
setting: per-object samples and the Render Globals sample 
setting supersample in image space. If you increase any of 
these two settings, you may be able to reduce the number of 
rays without loss of quality, while significantly improving 
performance. 

Irradiance

This is the ability to bounce indirect photons.

Irradiance color

This is the color of bounced photons.

Rendering Image-Based Lighting (sky-like 
illumination)

Image-based lighting
(Uffizi Light Probe image courtesy of Paul Debevec, 
www.debevec.org/Probes.)
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You can now simulate light emitted from an infinitely distant 
(environment) sphere to create image-based lighting more easily 
and efficiently. 

Image Based Lighting is a technique to create photo-realistic 
images. With image-based lighting, you use an environment 
texture (an image file) to illuminate the scene. Typically, the 
image is a photograph of a real environment, either a panoramic 
image or a photograph produced by taking pictures of a chrome 
ball (to capture the surrounding environment). 

(The existing method, where you had to surround your scene with 
a real, finite geometrical sphere, is still supported. If a finite 
distance to the environment is required (for example, for a closed 
room), you can still do this. However, because the shape is actual 
geometry, mental ray processes it as such. If is tesselated, it 
becomes part of acceleration structures (BSP tree) where it (due to 
its encompassing nature) can slow rendering down significantly 
and interactive Maya workflow can be hindered. With the new 
workflow, no geometry is created (or exported on .mi export); 
instead, IBL is represented by a set of shaders. You create the 
desired IBL node, then set its attributes to achieve the look you 
want.)

How image-based lighting works

When an IBL node is created one or more of the following mental 
ray for Maya shaders is used:

Environment Shader

Along with Final Gathering this shader implements classic 
style image-based lighting. The color of the environment is 
picked up by final gather rays and incorporated into surface 
illumination. An environment shader is passive. It doesn’t 
actively contribute to the scene’s lighting; instead, it gets 
sampled only as needed. Best results are achieved if the IBL 
What’s New in Maya 6

279



7 | Rendering 
  > How image-based lighting works
texture is diffuse. A specific case would be a texture consisting 
of a single color; this results in ambient occlusion 
computation. 

Photon Emission Shader

Photons are emitted from the IBL environment sphere. These 
photons pick up their energies (or colors) from the IBL 
texture. A photon emission shader emits all its photons once 
per frame. It is more active than an environment shader in 
this sense. Photons work best with mostly diffuse IBL 
textures. 

Light Shader

A low-resolution control texture is computed (from the file or 
procedural IBL texture) and mapped to the IBL environment 
sphere. Whenever direct lights are sampled, the light shader is 
invoked. In this sense, the light shader approach is the most 
active one, and the most expensive. The IBL environment can 
be seen as one big area light. This approach works best (also 
due to importance sampling) if the IBL texture contains sharp 
features, and preferably contains many more black than non-
black pixels. 

These three approaches may be combined to achieve specific 
effects, at the expense of computation time. 

To use image-based lighting

1 In the mental ray tab of the Render Globals Settings Window, 
click the Create button in the IBL section. 

2 A new IBL node is created, replacing any currently connected 
node. (Though multiple IBL environments can exist in a scene, 
only one can be used at a time.) 

A sphere-like tool appears in the scene view, and the IBL 
node’s Attribute Editor automatically pops up.

3 Set the IBL node’s attributes. 
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For details, see ”IBL node attributes” on page 281.

4 Position the IBL node with the sphere-like tool. 

For details, see ”Position an IBL texture” on page 281.

5 Render with Final Gather or Global Illumination to illuminate 
the scene.

Final gathering picks up incandescence samples from the 
environment texture. Illumination models deal with these 
samples similar to direct light arriving from, for example, a 
spot light. 

Position an IBL texture

When you create an IBL node, its shape is represented in the scene 
view. 

Moving (and to a certain extent scaling) the shape has no effect 
because the environment is considered infinitely distant. For best 
results, scale the shape as large as your clipping planes permit. 

Rotations, however, let you position the texture on the IBL node 
shaders. 

IBL node attributes

Image-based Attributes

Hardware Filter

Sets texture filter quality for shaded view: nearest or linear. 

Note IBL environments can be previewed interactively (if they 
are File texture based). 
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Hardware Alpha

Sets transparency of IBL shape locator in shaded view. 0 is 
transparent, 1 is fully opaque. 

Color Gain, Color Offset, Invert, Alpha Is Luminance

These attributes are the same as those of Maya's texture node. 
They apply in similar ways to IBL. 

Mapping

Select a UV space for the environment sphere: spherical 
(latitude-longitude) or angular (HDR Shop). 

Type

Select whether to map a file or a procedural texture as the IBL 
texture. File textures can be previewed interactively. See also 
Texture.

Image Name

If Type is set to File Texture, name of file on disk. 

Use Frame Extension

If turned on, the texture's file name may change on a per-
frame basis. This is used to load an image sequence instead of 
a single file. 

Frame Extension

The frame extension. 

Texture

If Type is set to Procedural, connect a 2D texture shading 
network to this input. 
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Visibility

Controls the IBL texture's visibility to certain ray types. This 
maps to a camera environment shader in mental ray. If all 
controls are deactivated, then no environment shader is 
processed. For classical image based lighting, the IBL texture 
must be visible to final gather rays and Final Gathering must 
be on. 

Light emission

You can emit light from the IBL environment radially inward 
toward the origin (of world space). If light emission is turned 
on, the IBL node acts like true light sources in the scene. The 
IBL texture is mapped to a mental ray light shader just like a 
real light source would be. 

Emit Light

Turn on, if you want to emit light from the infinitely distant 
IBL environment. 

Quality U, Quality V 

The light shader sets up a “control texture” for light emission. 
Every pixel in that texture virtually represents a directional 
light. These values specify the control texture's resolution. 
Higher values offer more precision but are more processor 
intensive. Loaded IBL textures are downsampled to the filter 
resolution; procedural textures are sampled at this resolution 
in pixel units for optimum performance.

Samples

Sampling all “directional lights” represented by the control 
texture is often prohibitively expensive. Therefore the shader 
has a built-in importance mechanism that attempts to select 
the primary (key) lights. 
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The first Samples parameter specifies the number of important 
lights that must be sampled. The second parameter quasi-
randomly selects a certain number of secondary (fill) lights. 

Low samples

Low Samples specifies the number of light samples taken 
from IBL during final gathering. It defaults to 1/8th of the 
regular samples (that is, 5/2).

Vary Focus 

Each “directional light” in the control texture sphere 
determines its direction. Turning on Vary Focus slightly 
offsets that direction (randomly) and thus improves quality. 

Disable Backlighting

If lights on the backside of surfaces do not contribute to the 
surfaces' illumination (i.e., there is no translucency in the 
scene), you should turn this on. It optimizes sampling 
significantly. 

Emit Diffuse, Emit Specular, Use Ray Trace Shadows, Shadow 

Color, Ray Depth Limit

These parameters are identical to attributes on Maya's 
standard lights. 

Photon Emission

Photons can be emitted from the IBL environment sphere. This 
requires Global Illumination and/or Caustic photons to be turned 
on in the Render Global Settings window. The emission direction 
is chosen randomly for individual photons. Similar to light 
emission, a photon picks up the color based on its emission 
direction from the IBL texture (file or procedural), possibly 
adjusted by color gain and offset. The results of this maps to a 
mental ray photon emission shader. 
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Emit Photons

Turn on, if you want to emit photons from the infinitely 
distant IBL environment. 

Globillumination

Determines how many global illumination photons are 
emitted. 

Caustic Photons

Determines how many caustic photons are emitted. 

Exponent

Determines the exponent used for photon emission. 

Standard emission

If off, photons will be stored on first hit. This is useful if IBL is 
to be achieved using global illumination photons alone. In 
terms of a real-world environment you can think of this 
switch as photons from the Sun being scattered in the 
atmosphere before reaching any surface.

Turn this option on, if you are emitting caustic photons, or if 
you are emitting light in combination with photons. 
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Photon and Final Gather visualization 
maps

You can generate a 3-dimensional visualization of a photon map 
or final gather map. 

Generate a map visualization to see the distribution of photons 
(and their energies) and final gather points (with stored 
irradiance) in the scene. This feedback can help you diagnose 
possibly unexpected global illumination effects or tune your scene 
more efficiently to get the desired look. 

Generated photon or final gather visualization maps appear in 
shaded and wireframe Scene views. Normals and directions are 
only visible in wireframe view. In shaded view, photons and final 
gather points are displayed as colored points, the color 
representing the irradiance estimate. 

To generate a photon or final gather visualization map

1 Select Window > Rendering Editors > mental ray > Map 
Visualizer. 

Shaded view of a 
scene

Photon map 
visualization

Final Gather 
visualization

Note Photon or final gather visualization maps are no visible 
in final rendering.
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If a mapVizShape node does not already exist in the scene 
(that it, if a visualization has not already been generated for 
the scene), a mapVizShape node is created and the mental ray 
Map Visualizer window appears. 

2 Adjust the display attributes of the visualization map.

See ”mapVizShape node” on page 287 for details.

3 Do any of the following: 

• Click Refresh to reload the map after you make changes. 

• Click Close to close the window but retain the 
visualization map (and thus the mapVizShape node). 

mapVizShape node

When you generate a photon or final gather visualization map, 
the mapVizShape shape node is added to the scene. Adjust the 
attributes of this node to change the visualization map. 

Map File Name

Name of the photon or final gather map file to be created and 
saved.

Photon Visibility

If the map is a photon map, turning any of these options off hides 
the corresponding photon type. 

Options

Point Size

This is the size of light rays on the surface to be drawn in 
screen space.

Normal Scale

Each photon and final gather point has an associated normal 
that tells which side of a surface it is on. Raise Normal Scale 
above zero to display normals.
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  > Render shader glow
Direction Scale

Raise Direction Scale to display the direction from which 
photons arrived on the surface. 

Search Radius Scale

Irradiance is estimated from a photon map by looking up 
photons within a certain radius. MapViz automatically 
determines a good search radius for visualization. That radius 
can be scaled by Search Radius Scale. 

Render shader glow 

Support for shader glow has been added. 

Render particle motion blur 

Motion-blurred particles are now supported with mental ray for 
Maya. 

Improved Lightmap/CPV generation time

Lightmap and CPV generation time has been significantly 
improved. 

Light linking

Light-linking for mental ray shaders 

mental ray for Maya now provides automatic light linking at 
render time, if the light array parameters are not connected. In 
other words, when rendering and exporting the scene, mental ray 
for Maya looks up the Maya light linking information between 
lights and the object, and connects light nodes to the light array 
parameters of the shader. 
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 > Light-linking on particle instances
Automatic light linking happens only if the light array parameter 
is not connected to any light (shared materials are not supported); 
if the shader is assigned to two different objects, and those two 
objects have different light linking, one light linking relationship 
will be applied to both objects. Previous files may not render 
exactly as they had before, and you may have to make some 
minor adjustments.

The default light is not considered in the automatic light linking. 

Light-linking on particle instances 

Light-linking on particle instances is fully supported. 

Support for diagnostics 

Support for mental ray for Maya diagnostics has been added. 

Better support for mental ray texture 
formats

Support for the following mental images texture formats has been 
added to Maya's File Texture and Image Plane nodes: 

• .ct

RGB/RGBA data types at 8bpp,16bpp, or floating-point 
32bpp

• .st

S data type at 8bpp, 16bpp, or floating-point 32bpp

• .map

S, RGB, RGBA data types at 8bpp, 16bpp, or floating-point 
32bpp. Tiled and pyramidal variants are supported.
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  > New support for triangle export of polygon meshes
You can now see these formats in Maya's rendering UI 
(HyperShade swatches, Attribute Editor preview swatches, etc.) 
and use them with the Maya Software renderer (though they get 
truncated to 8 bit). (These formats have always been supported for 
rendering with the mental ray renderer.)

New support for triangle export of 
polygon meshes 

Two dynamic attributes (exportTriangles and miTriangles) use the 
triangulation of Maya and exploit a far more memory effective 
translation to mental ray for Maya. 

If the Maya source geometry is actually a triangular mesh there is 
no difference in mental ray for Maya, but much less memory is 
used. 

Enable this mode globally for all meshes in the scene via a 
dynamic attribute on render globals node 'exportTriangles' (bool), 
or on a per-shape basis via a dynamic attribute 'miTriangles' 
(bool).
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8 Painting
Paint Effects
The following is new for Paint Effects in Maya 6.

Paint Effects on Polygons

As of Maya 6 Paint Effects can be used on polygons. Previously 
Paint Effects could be used only on NURBS. Before painting on 
polygons, select the geometry and then select Paint Effects > Make 
Paintable.

UV linking for Paint Effect on polygons

You can choose which UV set to use for Paint Effects on polygons 
by selecting Window > Relationship Editors > UV Linking > Paint 
Effects/UV. 

Isolating Paint Effects strokes for 
rendering

You can now isolate particular strokes when test rendering. Select 
Render Active from the Renderable Objects drop-down list in the 
Common tab of the Render Global Settings window. 

Progress indicator for rendering Paint 
Effects

When you render a Paint Effects pass you can determine the 
percentage of rendering that has been completed by viewing the 
progress indicator in the lower-left corner (Help Line) of the Maya 
window.
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  > Artisan
Artisan
The following is new for Artisan tools in Maya 6.

Artisan Tools ported to the new 
architecture

As of Maya 6 the last of the Artisan tools were ported to the new, 
and now standard, Artisan architecture:

• Sculpt Surfaces Tool (NURBS) 

• Sculpt Polygons Tool

• Paint Set Membership Tool

• Paint Blind Data Tool 

• Paint Fur Attributes Tool

• Paint Cloth Properties Tool

• New Paint Cloth Collision Properties Tool 

• New Paint Hair Tool 

There are no more Artisan tools in the former Artisan architecture.

For more information, see Artisan Brush Tool Settings in the online 
help.

New Paint Hair Tool

We’ve added a new Paint Hair Tool to paint attributes of a 
dynamic hair system. Hair is a new feature for Maya Unlimited. 
For more information, see Introducing Hair in the online Hair and 
Dynamic Curves guide. See also Hair > Paint Hair Tool in the 
online Hair and Dynamic Curves guide.
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 > New Paint Cloth Collision Properties Tool
New Paint Cloth Collision Properties Tool 

We’ve added a new Paint Collision Properties Tool you can use to 
paint collision properties of cloth objects. For more information, 
see ”Painting collision object properties” on page 327.

Sculpt Surfaces Tool improvements

Sculpt Surfaces now respects Global Stitch. The internal Artisan 
stitching has been removed.

The revised workflow is to select the surfaces to be sculpted and 
apply a Global Stitch before using the Sculpt Surfaces Tool. 

Paint Scripts Tool improvements

We added new flags to give access to the direction and brush 
center information from the Paint Scripts Tool (formerly known as 
the Script Paint Tool). You can obtain the direction of paint stroke 
or stamp position in the SetValueCommand and use them. These 
flags have to be set in InitializeCommand of the script. See ”Paint 
Scripts Tool improvements” on page 360.

3D Paint Tool
The following is new for the 3D Paint Tool in Maya 6.

Paint Sculpt Map

Paint Sculpt Map is a button in the Sculpt History section of the 
sculpt node. It invokes the 3D Paint Tool so you can paint 
deformation strengths over the surface of the deformer. If a non-
file texture is connected to the deformer, it will be disconnected 
before painting begins. 
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  > Paint Sculpt Map
This makes it easy to use the Sculpt Deformer to create realistic 
muscle shapes. For more information, see ”Sculpt deform with 
texture map” on page 205. 
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9 Fluid Effects
Fluids cache performance 
enhancements

Control the creation of temporary fluids 
cache files

Fluid caches are disk files with the extension .mcfp that are stored 
in your project's data directory. By default, when you open a scene 
file, Maya creates copies of a scene's fluids cache files and places 
them in your system’s temporary file directory. 

These temporary files are used to store any changes to your fluids 
cache that occur between file saves (File > Save Scene) and are 
required for you to be able to edit your fluids cache.

In Maya 6, you can use the new Copy Cache File Locally attribute to 
turn off the creation of these local copies for any fluids playback 
cache file. This is useful if you are low on disk space or are using a 

Note Fluid Effects is available only in Maya Unlimited.

Note You can use the diskCache -tmp MEL command to 
determine the location of your temporary disk cache 
files.

Warning When the Copy Cache File Locally attribute is off, 
you cannot append or truncate your fluids cache.
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9 | Fluid Effects 
  > Save one fluids cache file per frame
network for distributed rendering. The Copy Cache File Locally 
attribute is located in the Caching Node section of the Fluid’s Cache 
in the attribute editor.

To turn off the creation of local temporary fluids 
cache files

1 Save your scene.

This copies over your temporary cache file to your project 
data directory.

2 Select the cached fluid in your scene and open the Attribute 
Editor.

3 In the Cache_fluidShapen tab, expand the Caching Node 
section.

4 Turn off Copy Cache File Locally.

5 Save your scene once again.

Now when you open your scene, Maya does not copy your fluids 
cache to the temporary directory, and when you save your scene, 
Maya does not copy your fluids cache from the temporary 
directory to the permanent location.

Save one fluids cache file per frame

By default, Maya creates one cache file per fluid. However, some 
systems impose a limit on the maximum size a file can have. The 
size of a fluids cache file depends on the resolution of the fluid 
being cached and the properties (density, velocity, and so on) 
stored in the cache. Large fluid caches can sometimes exceed a 
system’s file size limit.

In Maya 6, you can save fluid caches in the One File per Frame 
(OFpF) format, which creates one cache file for each frame 
specified in Cache Time Range. The One File per Frame option is 
located in the Create Cache Options window.
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 > Save one fluids cache file per frame
Single fluids cache files are first stored in the disk cache temp 
directory and are only copied over to your project’s disk cache 
data directory on file save. Since OFpF fluids cache files are 
created and stored directly on your project's disk cache data 
directory, you need to consider the following limitations:

• Your scene must first have a name before you can create an 
OFpF fluids cache. You can name your scene by selecting 
File > Save As or by using the file -rename MEL command.

• Since OFpF caches are written directly into the project data 
directory, Maya cannot always determine when it's safe (for 
example, whether or not a disk cache file in the project data 
directory may be referenced by an unopened scene) to delete 
the cache file from the disk. Therefore, it is up to you to 
remove any unneeded cache files from the data directory.

• Since OFpF caches always copy the cache file for the current 
frame to the temporary directory (MEL: diskCache -tmp) 
control over the creation of the temporary file copies is 
disabled for OFpF caches.

Tip If a cache node is named cache_fluidShape1, the name 
of this intermediate file is available via the MEL 
command:

 getAttr cache_fluidShape1.hiddenCacheName.

The location of this file is the diskCache -tmp directory.
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  > How do I create an One Frame per File fluids cache?
Example

For a fluids cache for frames 1 to 5, One File per Frame creates 5 
different fluids cache files. Each file is named according to the 
following naming scheme:

   segmentPrefix%N_fluidShapeName__%F.mcfp

Where %N is the uniqueness identifier for segmentPrefix chosen 
by the system to guarantee unique file names among all 
diskCache nodes in the file scene and %F is the start frame for 
data in the cache file.

If the 5 frame cache in this example has been created for scene file 
joe.mb, the OFpF fluids cache files might be named: 

joe.mb1_fluidShape12_1.mcfp    (frames 1)
joe.mb1_fluidShape12_2.mcfp    (frames 2)
joe.mb1_fluidShape12_3.mcfp    (frames 3)
joe.mb1_fluidShape12_4.mcfp    (frames 4)
joe.mb1_fluidShape12_5.mcfp    (frames 5)

How do I create an One Frame per File fluids 
cache?

To create an OFpF fluids cache

1 Save your scene.

Note • You cannot change the Cache File Format once a 
cache has been created. You must first delete the 
existing cache and re-create it using the desired 
format.

• Over and Under sampling are only available for 
caches created in the Single File format.
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 > Advanced Fluids Caching in MEL
2 Select the fluid for which you want to create a segmented 
cache.

3 If your fluid already has a cache, delete its current cache by 
selecting Fluid Effects > Delete Cache.

4 Select Fluid Effects > Create Cache > .

The Create Cache Options window appears.

5 In the Cache File Format section, turn on One File per Frame.

6 Click Create or Apply to create a cache for each frame of your 
fluid. If you click Create, the Create Cache Options window 
closes. If you click Apply, the Create Cache Options window 
remains open.

Maya creates one cache file for each frame of your fluid.

7 Save your Maya scene.

Advanced Fluids Caching in MEL

With the new doFluidsDiskCache MEL command, you can 
segment fluid caches. A segmented cache is a fluids cache that is 
broken-up into multiple segments or chunks, where each segment 
contains a specified number of frames. Segmented caches can be 
used to split a large cache into smaller, more manageable files.

Since One File per Frame (OFpF) caches are a special type of a 
segmented cache (with a segment size of one), any limitations 
listed in the OFpF section also apply to segmented caches. See 
”Save one fluids cache file per frame” on page 296.

Warning Be aware that caching a fluid effect—especially a 
large fluid—may tie-up your system for an extended 
period of time and this operation cannot be 
interrupted.
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  > Advanced Fluids Caching in MEL
When you create any segmented cache for a fluid, the dynamic 
attribute Segment Start Frame is added to the diskCache node. 
This attribute connects to an expression node called 
%N_currentSegment (where %N is the segment naming prefix) 
which uses an animation curve to determine the appropriate 
segmentStartFrame value for the disk cache at the current time. 
Segment Start Frame cannot be modified directly in the Attribute 
Editor. 

May uses the segmentStartFrame value to generate the name of 
the segment file containing the cache data for the fluid at the 
current time. This cache file is then copied from the project's data 
directory to the
mcfp diskCache -tmp directory as needed.

The MEL procedure doFluidsDiskCache takes two arguments: 
doFluidsDiskCache (int $version, string $args[]) where 
$version is 2 for Maya 6, and $args is a string array whose 
values are mapped as follows: 

string $cacheType = $args[0];
int $rangeMode = $args[1];
int $sampling = $args[2];
float $diskCacheStartTime = $args[3];
float $diskCacheEndTime = $args[4];
int $samplingRate = $args[5];
int $cacheDensity = $args[6];
int $cacheVelocity = $args[7];
int $cacheTemperature = $args[8];
int $cacheFuel = $args[9];
int $cacheColor = $args[10];
int $cacheDensity = $args[11];
int $doSegment = $args[12];
string $namingPrefix = $args[13];
int $segmentSize = $args[14];

The last three elements of the $args array relate to segmented 
cache files: 
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 > Example
• $doSegment must be 1 to create segmented of OFpF caches

• $namingPrefix is a user-specified string to identify the cache 
files and expression nodes created in this operation

• $segmentSize is used to specify how many frames are stored 
in each cache file segment.

Example

The following command creates a segmented fluid cache from 
frame 1 to frame 100, with a segment size of 30:

doFluidsDiskCache 2 { "mcfp", 3, 1, 1, 100, 1, 
1, 1, 1, 1, 1, 1, 1, "joe.mb", 30 };

Since segmented fluids cache names depend on the name of the 
fluidShape being cached, the files created in your disk cache data 
directory might be named as follows: 

joe.mb1_fluidShape12_1.mcfp  
joe.mb1_fluidShape12_31.mcfp 
joe.mb1_fluidShape12_61.mcfp 
joe.mb1_fluidShape12_91.mcfp 

At frame 10, the segmentStartFrame attribute of the diskCache 
node has a value of 1 because the first cache segment contains the 
cache information for frame 10, and segmentStartFrame has a 
value of 61 at frame 75 because the third cache segment contains 
cache information for frames 61 to 90. Note that the last file 
created only contains cache information for frames 91 to 100.

Troubleshooting the Fluids cache

Maya cannot read the fluids cache

The following sections apply to both playback and initial state 
fluid caches.
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9 | Fluid Effects 
  > There is not enough space in your temp directory
There is not enough space in your temp 
directory

Maya cannot read the cache for the current fluid because your 
default temp directory does not have enough space. You can 
either make space on the drive where your temp directory is 
located, or you can change the path of your temp directory by 
editing your TEMP environment variable definition.

The default temp directories are:

(Windows)   username\Local Settings\Temp

(Mac OS X) /Users/username/Documents/temp

(IRIX and Linux) /usr/tmp

To make space in your temp directory

1 Browse to your temp directory.

2 Delete any nonessential files to free up space on the disk 
where the directory is located.

3 Check that there is now enough space in your temp directory 
for your fluids cache.

To change the temp directory folder

1 Do one of the following:

Note If your temp directory is set to something other than the 
default, you can still locate your temporary disk cache 
files using the diskCache -tmp MEL command. 
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 > The fluids cache is on a remote network drive that you are unable to access
• (Windows) Open the Control Panel and select System > 
Advanced > Environment Variables. Select TEMP from 
the list of user (not system) variables and click Edit. Enter a 
new system path for the TEMP environment variable and 
click OK.

• (Mac OS X) In the Maya.env file, type TEMP = path to 
define a new path for your temp directory. Save and close 
the Maya.env file.

• (IRIX and Linux) In a UNIX shell type: setenv TMPDIR 
path and press Enter. path is the new path for the temp 
folder.

2 If Maya is running, restart Maya.

To turn off the creation of temporary cache files

See ”To turn off the creation of local temporary fluids cache files” 
on page 296.

The fluids cache is on a remote network drive 
that you are unable to access

Maya cannot read the current fluid’s cache because the cache is 
located on a remote network drive that does not have shared 
permissions. If this occurs, you need to make the file available 
again.

Maya cannot find the current fluids cache

When a Maya file and a fluids cache are copied to a new location, 
the path from the Maya file to its fluids cache may break. If this 
occurs, you need to re-establish the connection between the fluid 
and its cache.
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  > Maya is unable to create a playback cache for the current fluid
To re-establish the link between a fluid and its cache 
data

1 Open your Maya file, select the fluid whose cache cannot be 
found, and then open the Attribute Editor.

2 In the Attribute Editor, select the cache or initial state node.

3 Click the folder button next to the Cache File Name field to 
browse (locally or over the network) for the current fluid’s 
cache.

4 Select the cache and click Assign to re-establish the connection 
between the current fluid and its cache.

To re-establish the link between a fluid and its 
segmented cache data

Make sure that your segmented cache files are located in the 
folder specified in the Disk Cache field of your current project’s 
settings. To view or change the contents of your current project’s 
Disk Cache field, go to File > Project > Edit Current.

Maya is unable to create a playback 
cache for the current fluid

There is not enough space on the specified disk

The temp folder that you have designated as the destination for 
your fluids playback cache is on a disk that does not have enough 
space for the cache data.

Warning The Disk Cache field specifies the destination for all 
your current project’s cache files. For example, fluids 
caches, jiggle caches, hair caches and so on.
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 > When saving fluids caches on Windows or Linux systems, the resulting files are

incomplete or contain blank frames
To make more space on the disk

• Delete any unnecessary or non-essential files from the temp 
folder’s disk to free up space for the fluids playback cache.

• Change the destination of the fluids playback cache data. For 
example, you can specify a new temp folder on a different 
disk as the destination for the fluids playback cache.

To turn off the creation of local temp fluids cache files

See ”Control the creation of temporary fluids cache files” on 
page 295.

When saving fluids caches on Windows or 
Linux systems, the resulting files are 
incomplete or contain blank frames 

The size of the cache file cannot exceed 2 gigabytes (GB). Cache 
files larger than 2GB will fail to write out completely. When 
saving a fluids cache file, Maya writes out up to the 2GB limit and 
then ignores the rest of the cache. You can work around this 
limitation by creating your fluids cache as segments (for example, 
500MB mini caches). Each cache segment can then be rendered 
separately. To segment your fluids cache, see ”Save one fluids 
cache file per frame” on page 296.

General Fluids improvements

Fluids render in mental ray for Maya

You can now render Maya fluids as volumes or surfaces with 
mental ray for Maya, and you can attach them as 2d or 3d 
textures. Fluids are exported to .mi format.
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  > Replace Cache Frame
Replace Cache Frame

In Maya 6, you can use the new Replace Cache Frame menu item to 
replace cached data for a selected fluid with the contents of the 
fluid at the current time. Replace Cache Frame is located under 
the Fluid Effects menu in the Maya main menu bar. Replace 
Cache Frame is only available for fluid caches created with the 
One Frame per File cache format.

To replace the fluids cache at the current frame

1 Make sure that your fluid has an OFpF cache. 

See ”To create an OFpF fluids cache” on page 298.

2 Drag the current time indicator in the Time Slider to the frame 
you'd like to replace in the cache.

3 Modify the contents of the fluid. For example, you can use the 
Paint Fluids Tool or the setFluidAttr MEL command.

4 Select Fluid Effects > Replace Cache Frame.

The current contents of the fluid is saved into your fluids 
cache at the current time and replaces the previous cache 
contents.

Easily view fluids cache contents

You can now easily view fluids cache files that do not have a 
container. In previous versions of Maya, there was no way of 
knowing the contents of a fluids cache without creating a fluid 
container to view the cache’s contents.

In Maya 6, you can view the contents of a fluids cache file by 
selecting the .mcfi or .mcfp fluids cache file on your disk and 
then dragging it into Maya’s scene view. When you drag a fluids 
cache file into Maya, Maya automatically creates the appropriate 
type of container for the fluids cache. The resolution of the fluid 
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 > Easily view fluids cache contents
that is created is determined by the cache data, and the size of the 
fluid is determined by the current settings in the Create 2D 
Container or Create 3D Container option windows.
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10 Fur
The following are improvements to Fur for Maya 6.

• “Rendering Fur in mental ray”

• “New Render Stats in Fur Feedback Shape node”

• “New mental ray Fur rendering options”

• “Fur Equalizer Maps improvements”

• “Fur on Subdivision Surfaces”

• “Paint Fur Attributes Tool improvements”

• “Update maps for referenced scenes or externally painted fur 
attributes”

• “Fur Feedback improvements”

• “Effect of lighting intensity on Fur”

• “Reverting to former Maya Fur behavior”

Rendering Fur in mental ray

You can now render Fur in mental ray. Fur in mental ray is 
rendered within the main render pass, rather than as a post 
process, which allows for Fur to show up in reflections and 
refractions, and through transparent objects. 

When rendering Fur in mental ray, keep in mind the following:

• Along with regular texture baking workflow, Fur in mental 
ray can now follow the complex shading connections, for 
example, 3D textures, for color attributes.

Note Fur is available only in Maya Unlimited.
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  > Rendering Fur in mental ray
• Calculate Area Values has no effect when rendering Fur with 
mental ray. In order to evenly distribute fur over a number of 
differently-sized NURBS patches, you need to adjust the 
baldness maps to compensate. Another alternative is to 
convert to a single polygon mesh. 

• Rendering Fur in mental ray for Maya can be significantly 
slower than in the Maya Software renderer.

• To improve the quality of Fur rendered with mental ray, set 
low Contrast RGB values and high Fur Sampling rates. The 
Preview Fur setting in Render Globals gives a good starting 
point. 

For more information, see mental ray for Maya renderer in the 
online Rendering guide and also Rendering scenes with fur in the 
online Fur guide.

Related topics

”New Render Stats in Fur Feedback Shape node” on page 314

”New mental ray Fur rendering options” on page 315
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 > Rendering in the Maya software renderer vs. mental ray for Maya
Rendering in the Maya software renderer vs. 
mental ray for Maya

Refer to the following table for the differences between rendering 
Fur in the Maya software renderer and mental ray for Maya.

Fur with Final 
Gather and 
raytraced color 
shadows

Caustics and 
Global Illumination 
received by Fur

Fur visible through 
transparent objects

Fur item Maya software 
renderer

mental ray for Maya

Support for reflections None Fur shows up in reflective 
material, but is not reflective 
itself
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  > Rendering in the Maya software renderer vs. mental ray for Maya
Support for refractions None Fur is refracted through 
refractive material, but is not 
refractive itself

Support for colored 
shadows

Supports only black 
shadows

Yes

Support for correct 
penumbra and drop off

Not accurate Yes

Support for correct 
DOF composition

Not accurate Yes

Support for 
transparency

Fur can be transparent, but 
is not visible through 
transparent material (can 
render in layers and 
composite)

Fur is able to be transparent 
and to show up through 
transparent material

Use of .sbs files Geometry information is 
written to a .sbs file that is 
then used by the Fur 
renderer

.sbs file is used for equalizer 
map generation only

Advanced Fur Render Can be used to generate fur 
files,  equalizer maps, 
shadows and images

Can be used to generate 
equalizer maps only

Fur item Maya software 
renderer

mental ray for Maya
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Support for motion blur 3D only Yes. 

For moving objects with fur 
or moving fur (attractors), set 
Motion Blur to “Exact” in the 
mental ray tab of the Render 
Global Settings window.

If the camera is moving, set 
Motion Blur to either 
“Linear” or “Exact” in the 
mental ray tab of the Render 
Global Settings window.

Need to add Fur 
Shadowing Attributes 
to lights to shadow Fur

Yes No

Support for fast fake 
Back and Root Shading 
(AutoShade)

Yes No

Support for ray-traced 
shadows

No Yes

Support for depth-map 
shadows

Yes Yes

Fur integrated into 
scene

As a post process via 
z-depth composite

Fully integrated

Fur item Maya software 
renderer

mental ray for Maya
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  > New Render Stats in Fur Feedback Shape node
New Render Stats in Fur Feedback Shape 
node

A new Render Stats section has been added to the 
FurFeedbackShape node. The Render Stats include some settings 
unique to using the mental ray for Maya renderer. 

The Maya Fur renderer uses the Casts Shadows and Primary 
Visibility settings. With these settings users have control over 
shadow casting and primary visibility on a per FurFeedback node 
basis. Users can now assign geometry and fur (FurFeedback) 
separately on different render layers. The Maya Fur renderer now 
respects render layers so users now have the ability to render only 
fur and not underlying geometry.

Primary Visibility

When on, the fur is visible in the view and renders. 

Support for area value 
calculations (Fur 
Globals > Calc. Area 
Values)

Yes Currently not possible

Support for 16 bit 
rendering 

No Yes

Fur item Maya software 
renderer

mental ray for Maya
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 > New mental ray Fur rendering options
Casts Shadows

Turns on the shadow casting ability of the fur. To make 
shadows render faster, for fur that does not need to cast 
shadows, turn off Casts Shadows. 

Receive Shadows (mental ray)

Turns on the shadow-catching ability of the fur. Works only 
when using the mental ray for Maya renderer.

Motion Blur (mental ray)

Turns on motion blur for the fur. You must also turn on 
Motion Blur in the Render Global Settings window. Only 
affects the mental ray for Maya renderer.

Visible in Reflections (mental ray)

When on, the fur reflects in reflective surfaces. Works only 
when using the mental ray for Maya renderer.

Visible in Refractions (mental ray)

When on, the fur refracts through transparent surfaces. Works 
only when using the mental ray for Maya renderer.

New mental ray Fur rendering options

A new mental ray section has been added to the 
FurFeedbackShape node. The mental ray settings are used when 
Fur is rendered in mental ray. These are descriptions of the 
options.

Override Caustics Settings

Turn this on to override the Caustics settings for Fur only. 
Then set the values for Caustic Accuracy and Caustic Radius. 
For descriptions of these attributes and for more information 
What’s New in Maya 6

315



10 | Fur 
  > New mental ray Fur rendering options
about Caustics, see Caustics and Global Illumination in the 
online Lighting guide. See also Global illumination and caustics 
workflow in the online Lighting guide.

Override Global Illumination Settings

Turn this on to override the Global Illumination settings for 
Fur only. Then set the values for Global Illum Accuracy and 
Global Illum Radius. For descriptions of these attributes and 
for more information about Global Illumination, see Caustics 
and Global Illumination in the online Lighting guide. See also 
Global illumination and caustics workflow in the online Lighting 
guide.

Override Final Gather Settings

Turn this on to override the Final Gather settings for Fur only. 
Then set the following options: Final Gather Rays, Final 
Gather Min Radius, Max Radius, Final Gather View, and Final 
Gather Filter. For descriptions of these attributes and for more 
information about Final Gather, see Final Gather in the online 
Lighting guide. See also Render with final gather in the online 
Lighting guide. 

Number of Samples

These settings relate to anti-aliasing when rendering with 
mental ray. For more information, see Anti-aliasing and flicker 
in the Rendering guide.

Note These per object sampling settings must lie within the 
range of the mental ray global sampling settings, 
otherwise they will be clipped. 
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Min Sample 

Level This is the guaranteed minimum number of 
samples per pixel used when processing an 
image. Based on Contrast Threshold 
(adaptive) settings, mental ray for Maya will 
increase these samples as needed. 

Max Sample 

Level This is the absolute maximum number of 
samples per pixel used when processing an 
image. 

Fur Equalizer Maps improvements

In the Fur Globals window there are now four options for 
equalizer maps:

• No Equalizer Maps 

• Default Equalizer Maps 

• Read Equalizer Maps (Per Surface) 

• Custom Equalizer Maps (Per Fur Description, Per Surface) 

New Custom Equalizer Maps option

We’ve added a Custom Equalizer Maps option so you can:

• paint your own equalizer maps and read them through the 
animation

• use any file as an equalizer map and read it through the 
animation

Note Use Custom Equalizer if you want to read equalizers in 
a scene referenced to a different project. This is because 
custom equalizers support absolute paths.
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If you select Custom Equalizer Maps, you can see the new Custom 
Equalizer attribute that appears in each fur description at the 
bottom of the list of attributes in the Attribute Editor. This 
attribute is grayed out when the Custom Equalizer Maps option is 
not selected. 

The Custom Equalizer attribute can be mapped or painted like 
any other fur description attribute. If you don’t make any changes 
to a particular fur description, the default equalizer map is 
generated and used. When you paint the attribute for the first 
time, the map is initially set to the default equalization. That’s 
because when you select Custom Equalizer Maps, default 
equalizers are automatically generated and a copy is saved for 
each fur description. The path of the Custom Equalizer Map files 
is displayed in the Fur Description in Details > Maps. The path 
should be able to be relative if the map resides in the standard 
project directory or absolute if the map resides elsewhere.

Changes to Read Equalizer Maps option

If you select Read Equalizer Maps, and a map has not already 
been generated through Advanced Fur Rendering, you are 
prompted with the following dialog box if you want to generate a 
default map. Otherwise you would choose your own map.

In either case, the path is filled in and can be seen and edited in 
the Reference Paths section of the Fur Globals window. This path 
is grayed out if any of the other three options are selected (No, 
Default, Custom). 
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Fur on Subdivision Surfaces

You can now create and work with Fur on subdivision surfaces 
with the following limitations:

• Direction painting does not work. Paint the Polar attribute 
instead. 

• There is no color feedback for subdivision surfaces in the 
Paint Fur Attributes Tool. 

• You cannot attach a grid of attractors to a subdivision surface. 
You can, however, attach attractors to selected subdivision 
surface faces. 

Due to these limitations, for major character work involving Fur, 
you may still wish to convert your subdivision surfaces to 
polygons.

Paint Fur Attributes Tool improvements

The Paint Fur Attributes Tool has been ported to the new 
standard Artisan architecture resulting in the following benefits:

• you can use it on NURBS, polygons, and subdivision surfaces

• UVs no longer have to be contiguous, therefore you can use 
Automatic Mapping to create them 

• World space reflection

• Color feedback on polygons

For more information, see Artisan Brush Tool Settings in the online 
Paint Effects, Artisan, and 3D Paint guide.
What’s New in Maya 6

319



10 | Fur 
  > Update maps for referenced scenes or externally painted fur attributes
Update maps for referenced scenes or 
externally painted fur attributes

We’ve added Update Maps to the Fur menu. Use this to update 
attribute maps when you: 

• map or paint fur attributes in scenes that are referenced

• paint fur attributes outside of the Paint Fur Attributes Tool, 
such as in the Paint Effects canvas, or in an external 
application, such as Photoshop

Fur Feedback improvements

We’ve made several improvements to Fur Feedback. 

• You can now display Fur Feedback for more than one fur 
description at the same time. See “Switching between Fur 
Feedback” below. (Each Fur description has its own Fur 
Feedback.)

• To see just one Fur Feedback for only one fur description (for 
speed or clarity), you can select and hide the others. See 
“Hiding and showing Fur Feedback” below.

• Hidden fur will no longer render, which means, in this 
respect, Fur behaves the same as other objects in Maya.

• You can select all fur in a scene quickly by selecting Edit > 
Select All by Type > Fur.

• In a scene in which the transform node of FurFeedback has 
transformations applied, interactive and rendered fur now 
respects these transformations. 

Hiding and showing Fur Feedback

In previous versions of Maya you used the Show Feedback menu 
item to show fur. Now you can hide and show fur using the 
Display menu. 
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To hide all fur

Select Display > Hide > Fur.

To show all fur

Select Display > Show > Fur.

To hide fur for one fur description

1 Select the FurFeedback.

2 Do one of the following:

• Select Display > Hide > Hide Selection.

• Press Ctrl + h.

To show the last hidden fur description

Do one of the following:

• Select Display > Show > Show Last Hidden.

• Press Ctrl + Shift + h.

Switching between Fur Feedback

In previous versions of Maya you used the Show Feedback menu 
item to switch between fur descriptions and you could only see 
one of them at a time. Now that you can display Fur Feedback for 
multiple fur descriptions at the same time, you don’t need to 
switch between Fur Feedback. 

To help you see what fur is displayed, Color Feedback Enabled is 
on by default (located in the FurFeedback node). Also, the default 
value for Fur Accuracy is now 1.
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Transforming Fur

In a scene in which the transform node of FurFeedback has 
transformations applied, interactive or rendered fur now respects 
these transformations. This is not only logical, but also consistent 
with how other transform nodes behave in Maya. In order to 
make this fix, a change was made in the transformation 
calculations for displaying or rendering fur. The effect is that fur 
displayed or rendered with the new version of Maya may look 
different compared with previous versions if there are 
transformations on the FurFeedback node. If you want to 
maintain compatibility in Maya Fur display or render, define the 
environment variable MAYA_FUR_OLD_BEHAVIOR. For more 
information about this variable, see ”Reverting to former Maya 
Fur behavior” on page 322. 

Effect of lighting intensity on Fur

In a scene in which the intensity of the lights exceeded 1.0, 
rendered fur would never be brighter than the diffuse and 
specular color values defined for the fur. You would expect the 
rendered fur to become increasingly brighter as the lighting 
increased. This is not only logical, but also consistent with how 
other renderers, including the Maya Renderer, behave with 
identical lighting and material assignments. In order to make this 
fix, a change in the shading calculations for rendering fur was 
implemented. The effect is that fur rendered with Maya 6 may 
look different compared with previous versions. If you want to 
maintain compatibility, define the environment variable 
MAYA_FUR_LIGHT_CLAMPING. 

Reverting to former Maya Fur behavior

With the changes to Maya Fur, if you wish to revert to the former 
Maya Fur behavior, you can set the environment variable 
MAYA_FUR_OLD_BEHAVIOR. 
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If this variable is set it does the following:

• In a scene in which the transform node of FurFeedback has 
transformations applied, interactive and rendered fur ignores 
these transformations. (These transformations are respected in 
the new version of Maya.)

• It ignores the Casts Shadows and Primary Visibility attributes 
in the Render Stats section of the FurFeedbackShape node.

• You can assign geometry and fur (FurFeedback) separately on 
different render layers and the Maya Fur renderer ignores the 
render layer of fur (as it did formerly).

Essentially there will be behavioral differences between mental 
ray Fur and Maya Fur if this environment variable is set.
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The following are improvements and enhancements to Cloth for 
Maya 6.

• ”Improved support for Cloth objects” on page 325

• ”Painting tessellation on garments and panels” on page 332

• ”Visualizing Cloth stress” on page 333

• ”Per-face collision depth” on page 336

• ”Stitch attribute for Cloth constraint” on page 337

• ”Mesh constraint improvements” on page 338

• ”Solver performance improvements” on page 338

• ”Advanced Cloth cache editing” on page 343

Improved support for Cloth objects

Improvements for Cloth objects

We’ve made various improvements for working with cloth 
objects. A cloth object is a piece of geometry simulated as cloth. 
You create cloth objects from polygonal shapes or NURBS shapes. 
The original shape is hidden and the tessellated cloth shape is 
displayed. The original shape and the cloth shape are grouped 
under the object's transform. For more information, see Create a 
cloth object in the online Cloth guide.

Some features have been made available for cloth objects that 
were previously available only on garments created from panels. 
Other new features have been added specifically for cloth objects.

Note Cloth is available only in Maya Unlimited.
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Constraints on Cloth objects

All cloth constraints now work on cloth objects. For information 
about constraints, see Use constraints in the online Cloth guide.

Cloth object resolution

Cloth object constraints support resolution independence. If you 
change the resolution of a cloth object, for example, change the 
number of subdivisions, the constraint locations update 
accordingly. See the following illustration.

See the selected vertices 
at the bottom center of the 
the Cloth Object plane

See the same selected 
vertices now in a Cloth 
Property set, indicated by 
the locators at the vertices 
in the set
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Cloth UV set

Cloth objects can be assigned a special clothUVset that will be 
used to assign the UVs on the output cloth mesh. If a special 
UVset is not specified, Maya Cloth will use the default UVset of 
the cloth object.

Painting cloth object properties

Now you can paint cloth properties for cloth objects. You paint 
cloth object properties the same way you would garments and 
panels. 

For more information, see Paint properties on cloth in the online 
Cloth guide.

Painting collision object properties

After increasing the 
Subdivisions on the Cloth 
Object plane the location 
of the selected vertices is 
updated.
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We’ve added a new tool, the Paint Collision Properties Tool, that 
you can use to paint collision properties of cloth objects. 
Specifically, the collision priority for collision objects is now 
paintable as well as the collision depth map offset. These two 
attributes are per-vertex maps and therefore cannot be painted on 
NURBS surfaces.

To paint collision properties of cloth objects

1 Select the collision object to be painted.

2 In the Cloth menu, set select Cloth > Paint Collision Properties 
Tool > .

The Paint Cloth Collision Properties Tool settings window 
appears.

3 Select a Paint Attribute: priorityMap or depthMapOffset. See 
below for descriptions of the attributes.

4 Set the rest of the painting attributes.

5 Drag to paint on the surface of the collision object.

For more information, see Using Artisan brush tools in the online 
Paint Effects, Artisan, and 3D Paint guide.

Priority Map

This is a per-vertex value [0,1]. These values are averaged 
over a face and added to Collision Priority. The resulting per-
face values are used to resolve collisions on a per-face level in 
the same way that Collision Priority was used on the per-
object level. 

Depth Map Offset

This is a per-vertex value [-1,1]. These values are averaged 
over a face and then used as a percentage offset applied to the 
calculated depth at that face. This is used to adjust for 
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situations where the depth map calculation method does not 
produce perfect results. The effective depth can be painted up 
or down as needed. 

If Depth Map Offset exists and Depth Map Enable is not 
turned on (see ”Per-face collision depth” on page 336), Depth 
Map Offset is instead applied to Collision Depth. This allows 
the depth map to be completely manually painted if that is 
desirable. 

Vertex level cloth properties

You can now assign cloth properties to sets of vertices on a cloth 
object. Previously cloth properties affected the entire cloth object. 

Keep the following things in mind when assigning cloth 
properties to sets of vertices:

• This works for cloth objects only, therefore you can’t add 
vertex property sets to panels. 

• You can’t assign vertices to a property that is already assigned 
to the entire cloth object. Instead, first remove the property 
from the cloth object and then reassign it as a set.

To create a cloth property for a set of vertices

1 Select the desired vertices.

2 In the Cloth menu set, select Simulation > Properties > Create 
Cloth Property.

The selected vertices are automatically assigned to the new 
property and the cpProperty node is displayed in the 
Attribute Editor. For more information about cpProperty 
attributes, see ”cpProperty node” on page 331.
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3 Optionally, you can change the Orientation value. The 
Orientation attribute controls the direction the indicator is 
facing that’s displayed on each vertex that’s part of the Cloth 
Property. This is to help distinguish between vertex property 
sets.

To add vertices to an existing property

1 Select the vertices on the cloth object you want to add.

2 Do one of the following:

• Select Simulation > Properties > PropertyName, where 
PropertyName is the name of the desired property.

• Go to the cpProperty node and in the Set List section, 
click the Add selected vertices to set button.

The vertices are added to the set.

To remove vertices from a property

1 Select the vertices on the cloth object you want to remove.

2 Go to the cpProperty node and in the Set List section, click the 
Remove selected vertices from set button.

To replace all vertices in a property

1 Select the vertices on the cloth object you want to be in the set.

2 Go to the cpProperty node and in the Set List section, click the 
Replace set with selected vertices button.

Indicators displayed on each 
vertex in the Cloth Property
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cpProperty node

These are the new attributes in the cpProperty node. For more 
information, see cpProperty node in the online Cloth guide.

Blend Weights

In the Blend Weights section, use the slider to set a blend weight 
value for vertices that overlap with other sets. The blend weight 
value can be between 0 and zero means the set has no weight, and 
1 means the set has full weight. For example, if two overlapping 
sets both had a blend weight of 1, then the sets property values 
would be averaged together. But if set A had a blend weight of 0.5 
and set B had a blend weight of 1.0, then set A would get half the 
weight of set B.

Set List

If the property contains a set of vertices the following buttons are 
available in the Set List section of the cpProperty node.

Select set vertices

This selects the vertices on the cloth object. 

Add selected vertices to set

This adds the selected vertices to the set of vertices in the 
cloth property.

Replace set with selected vertices

This replaces the set of vertices in the cloth property with the 
currently selected vertices.

Remove selected vertices from set

This removes the selected vertices from the set of vertices in 
the cloth property.
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Removing cloth properties

Use Remove Cloth Property to sever the connection between the 
cloth and the solver. The Cloth Property node remains in the 
Properties submenu.

To remove a cloth property

1 In the Cloth menu set select Simulation > Properties > 
PropertyName, where PropertyName is the name of the desired 
property.

2 Select Simulation > Properties > Remove Cloth Property. This 
removes the selected cloth property.

Painting tessellation on garments and 
panels 

Using the new paintable attribute, Coarseness, you can control the 
number of triangles (tessellation) on Cloth garments and panels. 
This does not work for Cloth objects.

In production, the Cloth tessellation is bumped to very fine to 
catch details in certain areas, allowing the tessellation to be very 
coarse in areas where you don't care or expect these details. The 
total number of triangles can be reduced to several times less and 
the overall performance and memory consumption also improve 
accordingly. Once Coarseness is selected, click the Apply 
Tessellation button to get the new tessellation result.

Coarseness ranges in [0,1] as other paintable attributes and it's 
used to reduce the tessellation. In general, you would set the max 
tessellation in the panel node or stitch node, and then use 
Coarseness to reduce the tessellation.
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Visualizing Cloth stress

You can now get visual feedback on areas of the cloth where 
there’s stress, as defined by the cloth solver. The cloth solver 
monitors the energy of the cloth on a per-vertex basis. With the 
Stress Visualizer you can see the stress areas reported by the 
solver.

Once you know the problem area of the cloth, you can frequently 
prevent the problem by increasing cloth resolution in that area, 
adding collision constraints, or modifying the collision geometry.

To show cloth stress

1 Select the cloth object or garment.

2 In the Cloth menu set select Simulation > Show Cloth Stress.

Make sure the display is in shaded mode (press 5) and the 
locator nodes are showing (Show > Locators).

3 Play the simulation.

At the zero frame there will be no stress because this is the 
initial state of the cloth. Once you start the simulation you will 
notice the cloth mesh displaying shaded areas; by default, 
white represents areas of high stress and black represents 
areas of low stress.

For descriptions of the attributes in the cpClothStress node, 
see ”cpClothStress node” on page 334.
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To hide cloth stress

1 Select the cloth object or garment.

2 In the Cloth menu set select Simulation > Hide Cloth Stress.

cpClothStress node

These are the attributes in the Cloth Stress Visualization section of 
the cpClothStress node.

High Stress Color

This color in the Stress Visualizer represents areas of high 
stress. The default color is white.

Low Stress Color

This color in the Stress Visualizer represents areas of low 
stress. The default color is black.

The lighter 
shading 
represents 
areas of high 
stress on the 
table cloth.
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Draw Type

This defines how the stress will be displayed on the cloth 
object or garment. The drop-down list includes: Default, 
Shaded, and Numeral. 

Default If you are in Wireframe mode, stress is 
displayed as Numeral by default; if you are 
in Shaded mode, stress is displayed as 
Shaded by default.

Shaded This applies only when you are in Shaded 
(as opposed to Wireframe) mode. Areas of 
stress are represented by colors, as defined 
by the High Stress Color and Low Stress 
Color attributes.

Numeral Areas of stress are annotated with values 
representing the level of stress. These values 
are the normalized values from the solver; 
high areas are close to 1.0 and low areas are 
close to 0.0.

Disable Cutoff

This is available only when the Numeral Draw Type is 
selected. By default this checkbox is turned off. When it is 
turned on the Cut Off value is disregarded and all stress 
values are displayed in the Stress Visualizer. This can result in 
a cluttered display.

Cut Off

This value is a lower limit on what numerals are displayed in 
the Stress Visualizer. The default value is 0.5; in this case only 
stress values of 0.5 and higher are displayed.
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Stress Scale Factor 

In large cloth objects or garments, the normalization of stress 
values can hide stress. With Stress Scale Factor you can 
increase or decrease the stress factors to better see the stress. 
The default is 1.

actual = Stress_Scale_Factor * normalized_stress_value

Mesh Draw Offset

This is only for the Shaded Draw Type. Use this to better see 
the stress. The cloth object or garment is drawn n-units closer 
to or farther from the user in the viewing direction. For 
example, if the Mesh Draw Offset was 1, but then increased to 
2, the cloth would be drawn 1 unit closer in the user’s viewing 
direction. The default is 0.05. 

Per-face collision depth

Maya now has the ability to support per-face collision depth. This 
can greatly help with cloth sticking to a collision object when the 
cloth is temporarily pushed inside the object. 

Keep in mind the depth map generation is done on demand, 
which means that if the current depth map is valid for the current 
collision object, it will not be regenerated. Because depth map 
generation is a fairly expensive process, it is recommended that 
the Depth Map Enable attribute be turned on for the first frame of 
the cloth simulation (this is usually the second frame of the scene) 
and then turned off for subsequent frames. The generated depth 
map will be used until Depth Map Enable is enabled again or 
Collision Depth is changed, in which case Collision Depth will be 
used for all faces until a new depth map is generated. If the 
collision object changes radically in shape or size during the 
animation, turn on Depth Map Enable at any time to create a new 
depth map based on the current geometry in that frame. 
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A per-face depth map can be generated automatically and 
adjusted using the Paint Collision Properties Tool or it can be 
completely defined using the Paint Collision Properties Tool. (See 
”Painting collision object properties” on page 327.) To 
automatically generate a depth map turn on the Depth Map 
Enable attribute for the collision object before simulating. 

For more information, see Adjust the collision object in the online 
Cloth guide.

Depth Map Enable

When turned on, this scans the collision object and calculates 
the ideal collision depth for each face on the object. A new 
depth map is generated for each frame so this can be 
expensive to use. This attribute is located in the Extra 
Attributes section of the collision object’s shape node in the 
Attribute Editor.

Depth Map Weight

This value is multiplied by the depth map value for each face, 
resulting in the depth map actually used by Maya. Generally 
the depth map weight should be left at its default value of 0.3. 
Raising this above 0.3 will result in a deeper depth map, but 
increase the possibility of erratic or unstable simulations. 
Lowering this value will result in a more shallow depth map 
that may increase the chance of cloth vertices getting stuck in 
the cloth object. This attribute is located in the Extra 
Attributes section of the collision object’s shape node in the 
Attribute Editor.

Stitch attribute for Cloth constraint

We’ve added a Stitch attribute to the Cloth constraint (Constraints 
> Cloth). When Stitch is turned on, the Offset, Damping and 
Stiffness attributes are all disabled so they have no effect. In 
“Stitch mode” constrained cloth vertices are kept very close (0.1 
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mm away) to the closest point on the target. This has the same 
effect that a user setting the offset to 0 would desire; however, an 
offset of zero will still result in a gap between the cloth vertices 
and the target because the solver considers the cloth to have 
thickness. This is useful for doing things like attaching a collar to 
a shirt when modeling clothing with cloth objects.

Mesh constraint improvements

We’ve added an Is Soft attribute to the Mesh constraint 
(Constraints > Mesh) that, when turned on, constrains cloth to a 
collision object via springs. The amount of elasticity of the springs 
is controlled by the Stiffness and Damping attributes, which are 
also paintable per-vertex.

Solver performance improvements

We’ve improved the Cloth solver performance by providing new 
Cloth diagnostics, performance controls, and error-reporting. In 
situations where the solver used to hang, we’ve improved its 
ability to detect and react to a hang.

In addition to the above improvements, painting Coarseness 
controls the number of triangles the cloth solver needs to deal 
with. If a part of a cloth garment or panel is invisible or its detail 

Note To use these new attributes with scene files created 
before Maya 6, delete the constraint and recreate it to see 
the new attributes.

Note To use this new attribute with scene files created before 
Maya 6, delete the constraint and recreate it to see the 
new attribute.
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motion is not important, the user can use Coarseness to reduce the 
triangles in that area to improve the performance. Since Cloth 
guarantees a smooth transition from coarse to fine tessellation, 
you can expect the motion to be continuous over the cloth with 
variant coarseness. For more information, see ”Painting 
tessellation on garments and panels” on page 332.

Solver hang detection

The solver can now detect instances where it is having difficulties 
solving a simulation. To control how a solver reacts to situations 
where there is a probability of it hanging, we’ve added two new 
attributes to the cpSolver node. For descriptions of these 
attributes, see ”cpSolver node” on page 339.

cpSolver node

These are the attributes we added to the cpSolver node.

Adaptation Control

This controls what steps the solver can take when it reacts to a 
situation where it is having difficulty solving a simulation. 
Select an option from the drop-down list.

Adapt Frame 

Samples And 

Time Step This gives the solver full control over 
reaction. The solver will adjust frame 
samples and time step as it sees necessary to 
try to resolve the problem.

Adapt Time 

Step This limits the solver's reaction to adjusting 
the time step variable.

Stop Solver This tells the solver to halt and release 
control to the user. A MEL script is executed 
if it is defined by the user. 
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No Action This tells the solver not to react. 

monitorScript

Specify the monitor control script, also known as the MEL 
callback script. If a script is defined and the solver has not 
been able to resolve a failing simulation, or Stop Solver is 
specified for Adaptation Control, then the script assigned to 
this string will be executed. For more information, see 
“Monitor script parameters.”

Monitor script parameters

To take advantage of the MEL callback, your MEL routine must 
have the following parameters: 

• string $solverName - This tells the callback the name of the 
solver that called it. 

• int $failureReason - This tells the callback the reason of 
failure. See ”Reasons for solver failure” on page 341.

• string $optionString - This string is reserved for future 
parameters. 

These arguments must be the last three arguments of your MEL 
callback. You can have additional parameters, but they must occur 
before the above parameters. 

Here is a sample callback:

global proc myReact( int $stepsBack, string 
$solverName, int $reason, string $optionVar )
{ 

print ("User defined script called" + $i + 
"\n"); 
print ("solverNode = " + $solverNode + "\n"); 
print ("reason = " + $reason + "\n"); 
print ("option = " + $option + "\n"); 

float $by = `playbackOptions -query -by`; 
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float $curr = `currentTime -query`; 
float $min = `playbackOptions -query -min`; 
float $max = `playbackOptions -query -max`; 

float $theStep = $stepsBack * $by; 

if (($curr != $min) && 
(($curr - $theStep) >= $min) && (($curr - 
$theStep) < $max)) 
{ 
currentTime -edit ($curr - $theStep); 
}

// Truncate the cache at the current time. 
// 
cpSolver -e -deleteRestOfCache; 

// Set frame samples to be 1. 
// 
string $plug1 = ($solverNode + ".frameSamples"); 
setAttr $plug1 1; 

// Play forward 
play; 

} 

monitorString attribute would equal myReact x where x would 
equal the number of frames you would want to step back.

Reasons for solver failure

There can be a few reasons for failure. These reasons equate to the 
internal fail detector in the solver node. 

1 Bad Cutoff - The cutoff value is a double precision value that 
represents, approximately, the amount of stress in the cloth. 
Very large cutoff values are usually an indication of a bad 
cloth configuration. When the cutoff value exceeds the 
internal threshold, the fail detector reports the problem and a 
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response is taken. When $failReason equals 1 this implies a 
large cutoff value occurred and the detector requested that the 
solver stop. 

2 Bad Adaptive Step - To solve a single frame the solver makes 
several steps within that frame to get a solution. Internally the 
solver has a mechanism for determining how large, or small, 
of a step it should take to get a solution. This is known as 
adaptive stepping. If the adaptive step size becomes too small, 
then the frame may not complete in a reasonable amount of 
time. The detector looks for cases where the adaptive size is 
very small and reports this. When $failReason equals 2 this 
implies a very small adaptive step was encountered. 

Solver diagnostics

The solver node monitors solver performance through a series of 
solver callbacks. These callbacks indicate how well the solver is 
performing. There are three types of callbacks that represent 
performance. 

• Adaptive Step Notification 

In midstep the solver may decide that it would be appropriate 
to restart the current step at a smaller time increment (recall 
that solver takes several steps between frames to compute the 
output mesh for a given frame). When the solver makes this 
internal adjustment it notifies the solver node. The solver 
node records this for analysis. Very small steps are indication 
the solver is having difficulty finding a solution for the frame. 

• Collision Detection Notification 

This callback indicates that collision detection is being 
performed. The solver tells the solver node the maximum 
amount of penetration found from a collision. 

• Linear Solution Notification 
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The solver uses a linear solver to determine the output mesh. 
This callback is invoked several times during this solution 
process. Encoded in the callback information is a cutoff value. 
This value roughly indicates the amount of stress in the 
simulation. Large values indicate poor cloth configuration. 
These values are recorded by the solver node and used for 
diagnostic purposes. 

Extracting and interpreting the diagnostic data

You can extract the recorded callback information after a 
simulation has stopped, either from the completion of playback or 
from fail detection. To extract information use the following 
command:

cpSolver -wsh "/path/fileName"

The solver command extracts the data from the solver node and 
stores it in the file you specify. A .cbd extension will be added to 
the name of that file. 

The output .cbd file contains four columns. 

• The first column is the time instance that the callback data 
was sampled from. The time corresponds to the current time 
units. 

• The second column is the cutoff parameter returned from the 
linear solution callback. 

• The third column is the maximum penetration value returned 
from the collision callback. 

• The final parameter is the array of adaptive step notifications. 

Advanced Cloth cache editing

With advanced Cloth cache editing in Maya 6 there is now 
support for multiple caches per node, plus you can copy, blend, 
and interpolate caches over a range of frames. 
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Multiple caches

You can now have more than one cache per solver and switch 
between caches dynamically. You can examine different 
simulations without having to load new caches to view them. 

All Cloth cache information is now in the new cpCache node and 
no longer stored in the cpSolver node. The default cache is 
attached to the cpSolver node.

Old scene files are automatically handled and converted.

To create a new cache

Select Simulation > Caches > Create Cache.

A new, empty cache is created and it becomes the current cache. 
You need to put data into the cache either by running a simulation 
or editing the cache.

To switch between caches

Select Simulation > Caches and then select the desired cache.

Each solver can have multiple caches, but solvers cannot share 
caches. 

Editing caches

With multiple caches you can now take parts of different 
simulations and blend or interpolate them. This will reduce the 
number of simulations needed to produce a good cloth 
simulation.

To edit a cache you need the following:

• an edit operation (copy, blend, interpolate)

• a collection of source cache segments

• a target cache segment
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An edit operation takes a series of source cache segments and 
produces a result in the target cache segment. A cache segment is 
made up of a cache node, range, and, optionally, a weight. Cache 
segments indicate what part of a cache to manipulate in the 
operation. The weight specifies how much of the cache segment 
you want to keep. In an operation all of the cache segments are 
normalized so their sum equals one.

The operation acts on the cache segments and combines the 
results into a target cache segment, which again specifies a cache 
node and a range, but not a weight.

Cache segments can start at different frames, but cannot be 
different in length (duration). In non-linear editing this is known 
as scaling and is not currently supported.

If a target cache segment is not specified then the default target is 
the same as the first source cache segment. 

To interpolate cache data

1 Select the cloth and then select the time range (shift-drag in 
the Time Slider). 

2 Select Simulation > Interpolate Cache. This interpolates the 
current cache between the selected time range.

Using the Cache Editor

Using the Cache Editor you can interpolate, blend or copy cache 
frames from different simulations in the same solver. This reduces 
the number of simulations needed to produce a good cloth 
simulation.

Note You can also interpolate cache data using the Cache 
Editor. With the Cache Editor you can specify the type of 
interpolation as either linear or sine. See “Using the 
Cache Editor.”
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To open the Cache Editor

Select Simulation > Cache Editor.

The Cache Editor window appears. For descriptions of the options 
in the Cache Editor window, see ”Simulation > Cache Editor” on 
page 348.

To interpolate caches using the Cache Editor

1 Select Simulation > Cache Editor. The Cache Editor window 
appears.

2 Click the Add Cache Segment button. This adds a panel in the 
Cache Editor window for you to set the options for the source 
cache segment. You can only have one source cache segment 
when interpolating.

3 Set the options for the source cache segment. 

4 Select a Target Cache from the drop-down list.

5 Specify a Target Range of frames.

6 Select interpolate from the Operation drop-down list.

7 Select an Interpolation Type from the drop-down list.

Linear

Specifies linear interpolation from the start of a cache segment 
range to the end.

Sine

Favors values close to the start and end of the cache segment 
range and follows a more linear interpolation in the middle.

8 Click Apply or Apply and Close.

To blend caches using the Cache Editor

1 Select Simulation > Cache Editor. The Cache Editor window 
appears.
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2 Click the Add Cache Segment button. This adds a panel in the 
Cache Editor window for you to set the options for the source 
cache segment. Add as many source cache segments as you 
need.

3 Set the options for each source cache segment, including the 
blend weight. Each range must be the same duration.

4 Select a Target Cache from the drop-down list.

5 Specify a Target Range of frames. The range must be the same 
duration as the source cache segments.

6 Select blend from the Operation drop-down list.

7 Click Apply or Apply and Close.

To copy frames between caches using the Cache 
Editor

1 Select Simulation > Cache Editor. The Cache Editor window 
appears.

2 Click the Add Cache Segment button. This adds a panel in the 
Cache Editor window for you to set the options for the source 
cache segment. You can only copy one segment at a time.

3 Set the options for the source cache segment. 

4 Select a Target Cache from the drop-down list.

5 Specify a Target Range of frames. The range must be the same 
duration as the source cache segment.

6 Select copy from the Operation drop-down list.

7 Click Apply or Apply and Close.
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Simulation > Cache Editor

This opens the Cache Editor window. Use this to blend, 
interpolate, or copy frame ranges from different caches into a 
target cache. For more information see ”Using the Cache Editor” 
on page 345. These are descriptions of the options in the Cache 
Editor window.

Add Cache Segment

Click this button each time you want to add a source cache 
segment. Then set the source cache segment’s options.

Cache Select the cache for the source cache 
segment.

Range Specify a range of frames for the source 
cache segment.

Weight Specify a weight if you are blending cache 
segments.

Target Cache

Select a target cache from the drop-down list.

Target Range

Specify the start and end frame in the target cache. The 
duration of this frame range must be the same as the source 
range(s). For example, the source range could be frames 1 to 5 
and the target range could be frames 21 to 25.

Operation

Select an editing operation from the drop-down list.

Interpolate Replaces the selected cloth particles' 
positions between the specified Target 
Range in the Target Cache with computed 
values between the values at Start Frame 
and End Frame of the Source Cache. The 
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interpolation type determines how the 
values are calculated. For instance, 
sinusoidal interpolation favors values that 
are close to the range boundaries and acts 
more like linear interpolation in the middle. 
Interpolation only works with a single 
Source Cache.

Blend Based on a specified blend weight, 
combines specified equal duration frame 
ranges from different simulations into the 
target cache segment at the specified range. 
Set the blend weight in the source cache 
segment options. Weighting values are 
normalized so the sum of cache segment 
weights equals 1.0. The source and target 
ranges can be in different caches.

For example, combine frames 1 to 5 of one 
simulation and frames 6 to 10 of another 
simulation into frames 21 to 25 of the target 
simulation. 

Copy Copies the specified frame range in the 
source cache segment to the specified frame 
range (of equal duration) in the target cache 
segment.

Interpolation Type

If you select interpolate as your editing operation, you’ll need 
to select a type of interpolation.

Linear Specifies linear interpolation from the start 
of a cache segment range to the end.

Sine Favors values close to the start and end of 
the cache segment range and follows a more 
liner interpolation in the middle.
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Changes to MAYA_SCRIPT_PATH

In Maya 6 we made some changes to how Maya searches for 
scripts in the search path (MAYA_SCRIPT_PATH). 

We have implemented caching of the script path in Maya. That 
means Maya searches the script path once and remembers what it 
saw for use in future searches. This was previously introduced in 
Maya 5.0, where it was activated using the 
MAYA_CACHE_SCRIPT_PATH environment variable that you 
could set in your Maya.env file. In Maya 6, the script path is 
always cached.

Keep in mind new scripts that are added to your script path will 
not be picked up automatically by a running copy of Maya. You 
need to tell Maya to re-scan the script path to find new scripts. To 
do this use the new rehash command.

The caching of the script path helps with the startup time of 
Maya, especially for users that have network drives in their script 
paths.

New and improved commands

General

• We’ve added a new rehash command to have Maya re-scan 
the script path to find new scripts. For more information, see 
“Changes to MAYA_SCRIPT_PATH.”

• There is a new webBrowser command that creates web 
browser control. For command and flag details, see ”New 
webBrowser command” on page 363.
What’s New in Maya 6

351



12 | MEL 
  > General
• There are several new MEL procedures to support 
customizing the Optimize Scene Size command. For details 
see ”Customizing Optimize Scene Size” on page 360.

• We’ve added a new imfPlugins command to query imf 
plugins.

• binMembership lets you categorize nodes for sorting in the 
Hypershade.

• The scriptJob command now has two new events. You can 
listen to Undo and Redo.

• The duplicate command now has a new instanceLeaf flag 
to duplicate with an instanced hierarchy. 

• The rand (random number generator) command can now 
generate multiple random number streams. This is useful for 
dynamics and other applications. For more information, see 
“Multiple random number streams.” We also added two new 
rand methods: randstate and delrandstr. 

• We’ve added a -r/-recursive boolean flag to the ls 
command. When -recursive true is used ls searches all 
namespaces for objects matching the given string. When 
-recursive false is used ls behaves as it did before and 
only searches the current namespace.  

• We’ve added the flag -dp/-dagPath to the reference 
command. This flag causes reference command queries to 
return the full dag path of all nodes (new functionality). 
Without this flag the reference command queries return node 
names (old behavior). 

• We added the flag -as/-asString to the getAttr command. 
This flag is only valid for enum attributes. It allows you to get 
the attribute values as strings instead of integer values.
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New flags for the file command

• We created some new commands and added a few flags to the 
file command relating to loading file references. For details 
see ”Selective load of references” on page 358.

• We added a -preserveReferences flag to the file command to 
allow references to be preserved during file import/export. 
The flag can only be used for import/export flags.

• We added a -lastTempFile flag to the file command. When 
queried, this flag returns the temp file name used during file 
save. The temp file will be left in the same directory as the 
intended file name if the save fails. 

• We added an -errorStatus flag to the file command. This 
queries the error status of the last file read. It returns true if an 
error occurred during the last file read. 

• We added a -resetError flag to the file command. 

• We added an -exportAnimFromReference flag to the file 
command. Export the main scene animation nodes and 
animation helper nodes from all referenced objects. This flag, 
when used in conjunction with the -rfn/referenceNode flag, 
can be constrained to only export animation on nodes from 
the specified reference file. For more information, see ”New 
MEL flags for importing and exporting animation” on 
page 179.

• We also added an -exportSelectedAnimFromReference flag 
to the file command. Export the main scene animation nodes 
and animation helper nodes from all referenced objects. This 
flag, when used in conjunction with the -rfn/referenceNode 
flag, can be constrained to only export animation on nodes 
from the selected nodes of a specified reference file. For more 
information, see ”New MEL flags for importing and exporting 
animation” on page 179.
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Modeling

• softMod gives you control over the new soft modification 
feature. See ”Soft Modification Tool and Deformer” on 
page 59.

• We’ve made changes to the makeIdentity and 
polyNormalPerVertex commands. For details of the changes, 
see ”Freeze Transformations (makeIdentity)” on page 98 and 
”polyNormalPerVertex” on page 100.

Animation

• You can now bake referenced animation data using the 
bakeResults and bakeSimulation commands.

• We added a new retarget command for animation.

• We updated flags for clipSchedule. The -cycle flag is now 
obsolete and we added the following flags: -preCycle, 
-postCycle, -sourceStart, and -sourceEnd.

• You can now output single frames of your animation to 
Playblast using the new -frame flag for the playblast 
command. For example:

playblast -frame 1 -frame 4 -frame 7

outputs frames 1, 4, and 7 of your current animation to 
Playblast. The -frame flag overrides any -startFrame/
-endframe flags.

• You can change the color of your animation curves. For more 
information, see ”Example MEL procedure for customizing 
the color of multiple animation curves” on page 184.

Painting

• pfxstrokes lets you dump Paint Effects stroke information to 
a file. 
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• The Paint Scripts Tool now supports stroke direction and 
stamp position. For details see ”Paint Scripts Tool 
improvements” on page 360.

Rendering

• We’ve added a new psdExport command that exports the 
Photoshop file layer sets into different file formats.   

• We’ve added a new psdTextureFile command that creates a 
Photoshop file with UVSnap shot image and the layer set 
names as the input. 

• We’ve added the convertLightmap command for baking and 
prelighting with mental ray for Maya.

• We’ve added the Mayatomr command, which provides access 
to most functionality of the mental ray for Maya plug-in, 
including .mi file export, preview and batch rendering, 
network rendering and shader management.

Cloth

• We made several improvements to the cpProperty command 
to support per-vertex property sets.

• The cpCache command is a new cloth command for 
manipulating cloth caches.

• We’ve added a new -uvs/getUVs flag to the cpSolver 
command. The flag will accept cloth/panel pair or simply a 
cloth object named followed by an empty string. For example,

cpSolver -uvs cloth1 ""

will return all of the solver UVs for cloth1. The command 

cpSolver -uvs cloth1 panel1

The UV values are 2d values that the solver uses to compute 
bending and shearing forces on the cloth.
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Converting between vector and float 
arrays

You can now convert between vector and float array types in 
MEL. Previously in MEL, in order to convert between a vector 
and float array, you had to manually assign each component, for 
example: 

float $a = {0.0, 1.1, 2.2};
vector $v;
$v.x = $a[0];
$v.y = $a[1];
$v.z = $a[2];

And the converse:

$a[0] = $v.x;
$a[1] = $v.y;
$a[2] = $v.z;

MEL now supports the ability to directly convert between these 
two types, for example:

$v = $a;
$a = $v;
$a = <<1.1,2.2,3.3>>;
$v = {1.1,2.2,3.3};
takesAfloatArray( $v );
takesAfloatArray( <<1,2,3>> );
takesAvector( $a );
takesAvector( {1.1,2.2,3.3} );

Script node improvements

The script node has a new trigger that fires when the current time 
changes.
What’s New in Maya 6

356



12 | MEL
 > Multiple random number streams
Multiple random number streams

You can now have multiple random number streams in Maya. 
Each stream is specified by a user-defined name. There is also the 
concept of a default stream (named “default”) that is used for 
random number calls that don’t use streams.

To support multiple random number streams, the existing MEL 
random functions have been enhanced to accept a string 
parameter as a new optional first argument. By specifying the 
name of a stream, Maya will use the specified stream when 
generating the random number, creating the stream first if 
non-existent. Whenever a new stream is created, it is seeded with 
a fixed internal default (the same seed the default stream is 
created with).

The variants of the MEL random number functions are:

string $stream;
floatORvector $range, $max, $result;
int $seedval;

$result = rand( [$stream,] $range [,$max] );
$result = sphrand( [$stream,] $range );
$result = gauss( [$stream,] $range );
seed( [$stream,] $seedval );

One convenience method is provided:

int $istream;
$result = rand( $istream, $min, $max );

This method allows an integer to be used as the stream name and 
is useful for simple particle work. For example, you can easily use 
the particleID without having to construct a string. Internally, this 
function converts $istream to a string when selecting the random 
number stream.
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To manage multiple random number streams, a new function has 
been added so you can delete streams by name. The function 
accepts a wildcard string.; currently only one “*” character is 
supported (for example, delrandstr ("p*.15") will delete all stream 
names which match the pattern, and delrandstr("*") will delete 
everything. If an attempt to delete the default stream is made, that 
request is silently ignored. The new function returns the number 
of streams that were deleted.)

int $count = delrandstr( $stream );

Selective load of references

In Maya 6 you now have control over which references, at all 
levels in the hierarchy, you want to load with your file upon 
opening. 

For more information on the workflow and concepts of selective 
load of references, see ”Selective file loading” on page 28. 

We’ve added the following MEL commands and flags to support 
selective loading of references.

file -o -buildLoadSettings "file.ma";

-buildLoadSettings builds settings of the current state of 
referenced files, whether they were loaded or not loaded upon 
saving last time. 

These “Selective Load Settings” can be edited using the 
Preload Reference Editor (see ”Preload Reference Editor” on 
page 30). Then to open the file with these “Selective Load 
Settings” use the following command:

file -o -loadPreferences "implicitLoadSettings" 
"file.ma";

If you want to open the file with the default settings, use the 
following command:

file -o "file.ma";
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This is the equivalent of File > Open.

If you wish to hook the selective preload functionality into your 
MEL scripts see the command documentation (Help > MEL 
Command Reference) for the selLoadSettings command and the 
file -buildLoadSettings flag.

Additional information

• We also added the -referenceDepthInfo flag to the file 
command. This flag is used to store preferences associated 
with a Maya ascii file (.ma). This flag is only useful during file 
I/O so users should not have any need to use this flag 
themselves. 

• We’ve also added the following three new flags to the file 
command: 

-unresolvedName
-shortName
-withoutCopyNumber

These flags are used to format the file paths returned by file 
command queries.

• We added a new command preloadRefEd that opens the 
Preload Reference Editor window. This window is used for 
editing which references you want to be loaded. See ”Selective 
file loading” on page 28.

• We added a new command selLoadSettings, which is called 
by Maya to edit the “Selective Load Settings” when you make 
changes in the Preload Reference Editor window. We’ve also 
provided two flags for this command: -unresolvedName and 
-shortName. These flags are used to format the file paths 
returned by selLoadSettings command queries.
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Paint Scripts Tool improvements

We added new flags to obtain direction and brush center 
information from the Paint Scripts Tool (formerly known as the 
Script Paint Tool). You can obtain the direction of paint stroke or 
stamp position in the SetValueCommand and use them. These 
flags have to be set in InitializeCommand of the script. (See the 
artUserPaintCtx command.) For more information, see Write 
MEL Scripts for the Paint Scripts Tool in the online Paint Effects, 
Artisan, and 3D Paint guide.

-dt/directionType string 

This flag indicates whether the (u,v,w) stroke direction should 
be sent to SetValueCommand. The possible values for this are 
none, screenV (a vector in screen space) or worldV (a vector in 
world space). The default is none. For projection painting, 
both screenV and worldV return a vector in screen space. The 
direction option is not supported for reflection painting. The 
third value(w) will be invalid if the user has requested 
direction as screen vector. 

-sp/stampPosition string 

This flag indicates whether the (spX, spY, spZ) stamp position 
should be sent to SetValueCommand. The possible values for 
this are none, local or world. The default is none.

Customizing Optimize Scene Size

For more details on the changes to Optimize Scene Size in this 
release, see ”Optimize scene size” on page 37.

We have changed the Optimize Scene Size function to 
accommodate additional optimization steps that can be added at 
runtime. The new MEL procedure cleanUp_AddUserCleanUp() 
can be used to add any number of new optimization steps. 

The syntax to use the command is as follows:
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global proc cleanUp_AddUserCleanUp( string $name, string $label, int 
$default, string $cmd )

where:

• $name – an internal name to identify this optimization

• $label – a user-friendly name for the optimization to be 
presented in the Optimize Scene Size dialog box

• $default – whether or not the optimization should be 
enabled by default (1=true, 0=false)

• $cmd – the MEL code to run when the optimization is 
executed 

For example, execute the following command: 

cleanUp_AddUserCleanUp( "deleteCustomShaders","Remove mr Custom Shaders", 
1, "deleteAllCustomShaders()" )

This adds the specified new optimization operation to the 
Optimize Scene Size dialog box (you must close and reopen the 
dialog box for the change to take effect). 
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A new initialization routine, cleanUp_RegisterUserCleanUps(), 
is provided to allow you to automatically add multiple custom 
optimizations at startup. 

This sample optimization is implemented by the 
deleteAllCustomShaders() procedure. The following example is 
an implementation of this procedure, which deletes all mental ray 
custom shading nodes. Please see the Maya Help version of this 
document (Help > Maya Help > What’s New in Maya > MEL) for 
the full script.

This procedure makes use of several new MEL utility functions to 
provide progress reporting and interruptibility: 

• cleanUp_StartProgress() – initializes the progress bar 

Customized 
optimization
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• cleanUp_SetProgress() – updates the progress bar and 
checks for user interrupt 

• cleanUp_EndProgress() – finalizes the progress bar 

• cleanUp_Summary() – records summary information for 
display at the end of the optimization 

A facility is also provided for automatically adding custom 
optimization steps. When the Optimize Scene Size feature is first 
invoked, it calls a routine called 
cleanUp_RegisterUserCleanUps() (from 
cleanUp_RegisterUserCleanUps.mel) to allow initialization of 
custom steps. By modifying this function, you can ensure that a 
specific set of custom optimizations are always available. Please 
see the Maya Help version of this document (Help > Maya Help > 
What’s New in Maya > MEL) for the full script.

New webBrowser command

The webBrowser command allows you to create a UI control 
which contains a web browser. This allows you to place a web 
browser within a panel that you create. For example, a custom 
panel you create could contain a webBrowser control which 
displays help information, or you could choose to implement 
parts of your GUI using HTML; or you could create a panel with 
an embedded web browser that navigates to www.alias.com. 

For additional information, in Maya select Panels > Panel > Web 
Browser. This displays a web browser panel containing 
information about what the Alias Web Browser is, how it’s 
different from other browsers and how to set up browser 
preferences.

webBrowser [flags] [webBrowserName] returns the full path 
name to the control.

The flags for the webBrowser command are:
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-url/openURL string

(C,E) URL to open in the web browser.

-bk/back

(E) Navigate to the previous page in the session history.

-fwd/forward

(E) Navigate to the next page in the session history.

-hm/home

(E) Navigate to the home page.

-rl/reload

(E) Reload last page.

-st/stop

(E) Stop current page loading process.

-ucc/urlChangedCb

(C,E,Q) An optional MEL callback. If set, it will be called 
whenever the current URL changes. The MEL callback should 
take one string that will contain the new URL. This is used by 
Maya to keep the url location bar up to date.

For the webBrowser command the flags -url, -bk and -fwd can be 
queried. In a query the -url flag will return the current URL. For 
-bk and -fwd it will return true/false depending if there are URLs 
to go forward/back to.

There is also a new webBrowserPrefs command that can be 
queried or edited. Use it to manage the embedded browsers 
preferences. There are several preferences that can be set, but the 
most common ones can be set in the Preferences window in the 
Web Browser category. (Window > Settings/Preferences > 
Preferences)
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Image file support

Maya now supports the following image types:

• png (Portable Network Graphics) image type, which allows 
24-bit color and lossless compression. For more information 
on PNG, see www.libpng.org/pub/png/. 

You can use this image type wherever you would import or 
save an image from Maya (for example, from the Render 
View, in FCheck, etc.)

• dds (Direct Draw Surface) image type, used by Microsoft’s 
Direct X. Many games on Windows use this file format. Maya 
supports importing of any of the five types of DDS encoding 
(DXT1 - DXT5), and allows export (UV snapshot, render, etc.) 
of a DXT1 DDS file with full alpha information.

• rla. We’ve added the ability to render to RLA format on 
Mac OS X. This format supports embedded depth that can be 
used in compositing  packages such as Adobe After Effects.

DWG translator improvements

We have added support for AutoCAD 2004 DWG files, and 
improved the speed and robustness of the translator.

New IGES import/export options

The following IGES import options are available when the IGES 
translator plug-in is loaded and IGES is selected from the File 
Type drop-down list of the File > Import > ❒  dialog box.

Note Maya was not previously able to support 8-bit file 
textures; you can in Maya 6 by using the DDS format.
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Default Trim Curves

Select Parameter Space trimming (curves defined in the 
parameter space of the surface) or World Space trimming 
(curves defined in world space of the model). The default is to 
use parameter space trimming.

IGES Trim Space. In IGES a trimmed surface can specify its 
preferred trimming method, either world space or parameter 
space. Choosing this option tells Maya to use whatever 
method is preferred in the file.

Scale Factor

Scales all imported geometry by a common factor. This allows 
very large scenes to be viewed more easily. 

Level Mapping

Controls whether layers from an IGES file are imported. The 
default is to import layers.

The following IGES export options are available when the Iges 
translator plug-in is loaded and IGES is selected from the File 
Type drop-down list of the File > Export Selection > ❒  or File > 
Export All > ❒  dialog box.

Note IGES files often contain geometry that is very large. In 
order to view this geometry properly, the Scale Factor 
can be used to scale it down. Otherwise, in the viewing 
window, select View > Frame All to frame your 
selection, and if the geometry does not appear, it is 
beyond the camera's rear clipping plane. Select View > 
Camera Attribute Editor and set the "Far Clip Plane" to a 
value sufficiently large such that the geometry is visible.
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Scale Factor

Determines the factor by which the resulting geometry in the 
IGES file is scaled upon export (default: 1.0000).

STL import

Maya can now import STL (Stereo lithography Tesselation 
Language) files. The STLImport plugin must be loaded in order to 
import STL files.

In the Import options for STL, you can set the Merge vertices with 
tolerance setting. This specifies the maximum allowable distance 
between vertices to be merged together.

When importing large STL files, it is often beneficial (both in 
terms of the time it takes to import a file and the size of a file) to 
merge vertices that are sufficiently close together into one vertex 
to condense the data without any noticeable sacrifice to the 
integrity of the data. 

Moreover, the STL importer will create the same vertex several 
times if Merge vertices with tolerance is left unchecked. This will 
occur three times for every face in the mesh, generating a lot of 
unnecessary data. 

IgesDxftoMaya removed

The functionality of this translator is now in the IGES and DXF/
DWG translator plug-ins. Please see the online Translator guide.

OpenFlight on Mac OS X

OpenFlight is now supported on Mac OS X. 
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StudioImport on Mac OS X

StudioImport is now supported on Mac OS X.
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14 API and DevKit
API

Improvements to the Maya API

Many changes have been made to the API for Maya 6. We have 
added new classes and additional functionality to existing classes. 
Also, we have included many new examples that demonstrate the 
new functionality.

”New classes and header files” on page 369

”Changes to existing classes” on page 370

”Examples of new plug-in functionality” on page 386

”Other significant changes” on page 388

”Compiler requirements” on page 389

New classes and header files

Classes

MFnRotateManip

Lets you access the built-in Maya rotate manipulator.

MFnScaleManip

Lets you access the built-in Maya scale manipulator.

MObjectHandle

Lets you query the validity state of an MObject.

MObjectSetMessage

Lets you register callbacks with set specific event types.
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MPolyMessage

Lets you register callbacks for poly messages. Currently, you can 
use this class to listen to component id changes for vertices, edges 
and faces.

MProgressWindow

Lets you access progress window functionality.

MTrimBoundaryArray

Lets you maintain an array of edges on a trim boundary. This 
class is required by the new MFnNurbsSurface functionality.

MUintArray

Lets you maintain an array of unsigned integers. This class is 
required by the new MPolyMessage class.

MUserEventMessage

Lets you post and respond to user defined messages.

Headers

MFStream

Lets you centralize the inclusion of the fstream header.

Changes to existing classes

M3dView

You can now access the renderer name and enhanced refresh 
options in this class.

RendererName getRendererName(MStatus *ReturnStatus /* 
= NULL */) const;
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Returns the name of the current renderer that is being used in 
the scene view.

enum RendererName {
// Equivalent to when the renderer name is "base_OpenGL_Renderer" 

when queried from the "modelEditor" command
kDefaultQualityRenderer, 
// Equivalent to when the renderer name is 

"hwRender_OpenGL_Renderer" when queried from the "modelEditor" command
kHighQualityRenderer

};

Enum used in getRendererName() method that describes 
which renderer is being used.

bool wireframeOnlyInShadedMode(MStatus *ReturnStatus /
* = NULL */) const;

Returns true if you are in shaded mode but only displaying 
wireframe.

MStatus refresh( bool all, bool force, bool offscreen 
);

This method lets you control whether or not the offscreen 
buffer is redrawn.

MStatus refresh( MPxGlBuffer &buffer, bool offscreen 
);

This method lets you control whether or not the offscreen 
buffer is redrawn.

MAnimControl

You can now get and set the animation start and end times.

static MTime animationStartTime();

Returns the animation start time.

static MTime animationEndTime();

Returns the animation end time.
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static MStatus setAnimationStartTime( MTime 
newStartTime );

Sets the animation start time.

static MStatus setAnimationEndTime( MTime newEndTime 
);

Sets the animation end time.

static MStatus setAnimationStartEndTime( MTime 
newStartTime, MTime newEndTime );

Sets the animation start and end times.

MDagMessage

You can now listen to instance added and instance removed 
messages. The enum DagMessage now has two new items for use 
with the addDagCallback() method:

kInstanceAdded,
kInstanceRemoved

static MCallbackIdaddInstanceAddedCallback( void (*func)( MDagPath 
&child, MDagPath &parent, void * clientData ), void * clientData = NULL, 
MStatus * ReturnStatus = NULL );

Lets you creates a callback that listens for all instance added 
messages.

static MCallbackIdaddInstanceAddedCallback( MDagPath &dagPath, void 
(*func)( MDagPath &child, MDagPath &parent, void * clientData ), void * 
clientData = NULL, MStatus * ReturnStatus = NULL );

Lets you create a callback that listens for new instances of the 
node described by the dagPath.

static MCallbackIdaddInstanceRemovedCallback( void (*func)(   MDagPath 
&child, MDagPath &parent,  void * clientData ), void * clientData = 
NULL, MStatus * ReturnStatus = NULL );

Lets you creates a callback that listens for all instance deleted 
messages.
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static MCallbackIdaddInstanceRemovedCallback( MDagPath &dagPath, void 
(*func)(   MDagPath &child, MDagPath &parent,  void * clientData ), void 
* clientData = NULL, MStatus * ReturnStatus = NULL );

Lets you create a callback that listens to the removal of 
instances described by the dagPath.

MDagPath

There is now better dag path support for when you have multiple 
shapes underneath a transform. The existing extendToShape() 
method fails under this case. 

MStatus extendToShapeDirectlyBelow( unsigned int index 
);

Extends to the shape directly below that is specified by the 
index.

MStatus numberOfShapesDirectlyBelow( unsigned int& );

Returns the number of shapes directly below the transform.

MFloatVector and MVector

We now have support for the one vector. 

The MFloatVector class now has a constant for the one vector 
<1.0,1.0,1.0>. For example:

static const MFloatVector one;

The MVector class now has a constant for the one vector 
<1.0,1.0,1.0>. For example:

static const MVector one;

MFnArrayAttrsData

You can now extract specific data types from array attributes data.

MVectorArray getVectorData( const MString attrName, 
MStatus *ReturnStatus = NULL);
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Returns an MVectorArray of the data the function set is 
operation on.

MDoubleArray getDoubleData( const MString attrName, 
MStatus *ReturnStatus = NULL);

Returns an MDoubleArray of the data the function set is 
operation on.

MIntArray getIntData( const MString attrName, MStatus 
*ReturnStatus = NULL);

Returns an MIntArray of the data the function set is operation 
on.

MStringArray getStringData( const MString attrName, 
MStatus *ReturnStatus = NULL);

Returns an MStringArray of the data the function set is 
operation on.

MFnCamera

You can now specify the context when accessing the camera 
projection matrices.

MFloatMatrix projectionMatrix( MDGContext& context, MStatus * 
ReturnStatus = NULL ) const;
MFloatMatrix postProjectionMatrix( MDGContext& context, MStatus * 
ReturnStatus = NULL ) const;

A new parameter has been added to this class that lets you specify 
the context.

MFnClip

You can now create pre-cycles when creating clips.

MObject createInstancedClip ( MObject& sourceClip, const MTime& start, 
MDGModifier& dgMod, MStatus * ReturnStatus = NULL, bool absolute = 1, 
double postCycle = 0.0, double weight = 1.0, double scale = 1.0, double 
preCycle = 0.0 );
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This method has been modified. The previously used cycle 
parameter has now been renamed to postCycle and a new 
preCycle parameter has been added.

double getPreCycle(MStatus *ReturnStatus = NULL);

This method returns the value of this clip's pre-cycle attribute.

double getPostCycle(MStatus *ReturnStatus = NULL);

This method returns the value of this clip's post-cycle 
attribute.

MStatus setPreCycle(double cycle, MDGModifier* mod = 
NULL);

This method sets the pre-cycle value for the clip.

MStatus setPostCycle(double cycle, MDGModifier* mod = 
NULL);

This method sets the post-cycle value for the clip.

MFnDagNode

You can now create instances more easily with this method.

MStatus addChild( MObject & child, unsigned int index = kNextPos, bool 
keepExistingParents = false );

This method has a new keepExistingParents. When 
keepExistingParents is set to true, you can create instances.

bool inModel( MStatus * );

This method allows you to determine if a dag node has been 
added to the Maya model.

MFnDirectionManip

You can now set the direction for this manipulator.

MStatus setDirection(MVector &direction);

This method lets you set the direction of the manipulator.
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MFnDoubleIndexedComponent

We now support MFn::kMeshVtxFaceComponent objects within 
this class.

MFnFluid

We now make it easier to get the velocity grid size and support 
new index methods into the fluid.

MStatus velocityGridSizes( int & xsize, int & ysize, int & zsize );

This method returns the number of elements in the velocity 
grid.

int index( int xi, int yi, int zi, int xres, int yres, int zres );

This method is used to find the index of a cell given the X, Y 
and Z resolutions.

void index( int ai, int xres, int yres, int zres, int & xi, int & yi, 
int & zi );

This method is used to find the coordinates of a cell given the 
index, and the X, Y and Z resolutions. 

MFnFreePointTriadManip

You can now set the point associated with this manipulator.

MStatus MFnFreePointTriadManip::setPoint(const MPoint& pointValue)

This method lets you set the point manipulator value to a 
specified vector.

MFnManip3D

You can now delete base manipulators with the following 
method:

MStatusMFnManip3D::deleteManipulator(MObject& manip);
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This method lets you delete manipulators that were created using 
base manipulator create() methods.

MFnNurbsCurve

There is now a new creation method and the ability to reverse a 
curve in this class.

MObject create( const MObjectArray& sources, MObject & parentOrOwner = 
MObject::kNullObj, MStatus* ReturnStatus = NULL );

This method creates a single curve that represents all the 
curves in the MObjectArray.

MStatus reverse(bool constructionHistory = false);

This method reverses a curve's direction.

MFnNurbsSurface

You can now use trim boundaries in this class.

MStatus getTrimBoundaries(MTrimBoundaryArray& result, unsigned region, 
bool paramEdge = true);

This method returns all trim boundaries of a region on the 
surface.

MStatus trimWithBoundaries(const MTrimBoundaryArray& mBoundaries, bool  
flipNormal = false, double e_tol = 1e-3, double pe_tol = 1e-5);

This method trims the surface with given trim boundaries.

MFnParticleSystem

You can now access particle id information in this class.

void particleIds( MIntArray& ) const;

Returns an array of particle identifiers at the start of the time 
step. The array of particle ids is correlated with the other per-
particle arrays returned by this class.
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MFnPlugin

We now have better support for creation and deletion scripts in 
batch mode. In addition, you can find out if a node has been 
registered.

MStatus registerUI(const MString & creationProc, const MString & 
deletionProc, const MString & creationBatchProc = "", const MString & 
deletionBatchProc = "");

Two new parameters have been added to this method. You 
can now set a creation and deletion procedure to be run if the 
plug-in is loaded in batch mode.

static bool isNodeRegistered( const MString& typeName );

This method queries if the given typeName has been 
registered.

MFnSubd

We have added new support for evaluating positions and 
normals. In addition, access to the cubic spline of certain faces is 
now provided.

MStatus evaluatePosition( MUint64 polyId, double u, double v, bool 
uvNormalized, MPoint& ) const;

This method evaluates the surface position at the given 
parameter point on the polygon.

MStatus evaluateNormal( MUint64 polyId, double u, double v, bool 
uvNormalized, MVector& nrml ) const;

This method evaluates the surface normal at the given 
parameter point on the polygon.

MStatus evaluatePositionAndNormal( MUint64 polyId, double u, double v, 
bool uvNormalized, MPoint& pos, MVector& nrml ) const;

This method evaluates the surface position and normal at the 
given parameter point on the polygon. 
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bool getCubicSpline( MUint64 polyId, MPoint vertices[16], MStatus* 
ReturnStatus = NULL );

Some subdivision faces (usually at level 2 or below) are 
exactly the same as uniform bi-cubic B-splines. This method 
will return the 16 points that define such spline.

bool polygonIsValid( MUint64 polyId, MStatus* ReturnStatus = NULL ) 
const;

This method returns if the polygon is valid or not. Valid 
means that the polygon has been instantiated on the surface. 
Not all polygons at all levels exist by default. A polygon only 
exists if it was created at the time the subdiv was first created 
or if the subdiv was refined.

bool polygonHasChildren( MUint64 polyId, MStatus* ReturnStatus = NULL ) 
const;

This method returns whether or not the given polygon has 
children.

MIOStream

You can now import std::types required by the devkit.

MLibrary

You can now initialize API standalone applications in a way that 
allows you to keep script output.

MStatus initialize (bool wantScriptOutput, char* applicationName,
bool viewLicense = false);

This method initializes a standalone API application and allows 
control over if script output will be generated.

MLightLinks

You can now find out information on ignored lights and objects.
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MStatus getIgnoredLights( const MDagPath& path, const MObject& component, 
MDagPathArray& lights );

This method queries the light link table to find the lights that 
ignores a particular object or object component.

MStatus getIgnoredObjects( const MDagPath& light, MSelectionList& objects 
);

This method queries the light link table to find the objects or 
object components that are ignored to a particular light.

MMessage

MCallbackId MMessage::currentCallbackId( MStatus* ReturnStatus );

You can use this method in a callback for returning the id of 
the current callback.

MStatus MMessage::nodeCallbacks( MObject& node, MIntArray& ids );

You can use this method to return the callback ids associated 
with a node.

MNodeMessage

MCallbackId MNodeMessage::addNodeDirtyCallback( MObject& node, void 
(*func)( MObject& node, void* 

clientData ), void * clientData, MStatus * ReturnStatus );

This method lets you add a callback for node dirty messages. 
Similar to the existing method but now the first parameter of 
the callback is the node that is dirty.

MCallbackId MNodeMessage::addNameChangedCallback( MObject& node, void 
(*func)( MObject & node,

const MString & prevName, void* clientData ), void * clientData, MStatus 
* ReturnStatus );

This method lets you add a callback for name change 
messages. Similar to the existing method but now the 
previous name of the node is a parameter to the callback.
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MCallbackId MNodeMessage::addNodePreRemovalCallback( MObject& node, void 
(*func)( MObject& node, 

void* clientData ), void * clientData, MStatus * ReturnStatus );

This method lets you add a callback that is invoked before the 
connections of a node about to be deleted are called. Similar to 
the message generated by: 
addNodeAboutToDeleteCallback() with the exception that 
no context is available. This message works correctly when 
the delete is undone and then redone.

MPxFieldNode

We now support per particle field attributes on this node.

static MObject  mInputPPData;
static MObject  mOwnerPPData;

MPxManipContainer

You can now create rotation and scale manipulators from this 
class. In addition, we have added new virtual methods which are 
called when Maya receives a press, drag or release event. 

MDagPath addRotateManip(const MString &manipName, const MString 
&rotationName);

This method creates a rotate manipulator and adds it to the 
MPxManipContainer container.

MDagPath addScaleManip(const MString &manipName, const MString 
&scaleName);

This method creates a scale manipulator and adds it to the 
MPxManipContainer container.

virtual MStatusdoPress();

This method gets called when the manipulator receives a 
mouse down event.

virtual MStatusdoDrag();
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This method gets called when the manipulator receives a 
mouse drag event.

virtual MStatusdoRelease();

This method gets called when the manipulator receives a 
mouse release event.

MPxNode

We now support attributeAffects() style relationships for 
dynamically-added attributes. Also, you can now get and set 
internal values using context information.

virtual MStatus setDependentsDirty( const MPlug &, MPlugArray & );

This method can be overridden in user defined nodes to 
specify which plugs should be set dirty based upon an input 
plug.

virtual bool getInternalValueInContext( const MPlug&, MDataHandle&, 
MDGContext&);

This method is similar to the existing getInternalValue() 
method but now you have access to the context.

virtual bool setInternalValueInContext( const MPlug&, const MDataHandle&, 
MDGContext&);

This method is similar to the existing setInternalValue() 
method but now you have access to the context.

MRenderView

You can now use a new flag for immediate feedback in the 
startRender() methods. 

static MStatus startRender( unsigned int width,  unsigned int height, 
bool doNotClearBackground = false, bool immediateFeedback = false );

static MStatus startRegionRender( unsigned int imageWidth, unsigned int 
regionRight, unsigned int regionBottom, unsigned int regionTop, bool 
doNotClearBackground = false, bool immediateFeedback = false );
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Both of the methods now have a new immediateFeedback 
parameter. When set to true, each call to refresh() will 
immediately redraw the Render View. The default setting of 
false adds a wait of at least two seconds between redraws. 

MRenderUtil

We now support a more general method for extracting the file 
texture name.

 static bool exactFileTextureName(const MString& baseName,bool 
useFrameExt,const MString& currentFrameExt,MString& exactName,MStatus 
*ReturnStatus = NULL);

Finds the file texture name on disk based on the input parameters.

MSelectionMask

Due to internal changes within Maya, the following mask has 
been removed: SelectReferences.

However, we have added the following enum SelectionType 
items:

• kSelectionHairSystems

• kSelectFollicles

MString

You can now expand environment variables (all platforms) and 
tilde (UNIX only).

MString expandEnvironmentVariablesAndTilde( MStatus * ReturnStatus = NULL 
);

Returns a new string constructed by duplicating the current string 
with all environment variables expanded (and on UNIX, tilde 
characters ("~") are also expanded).
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MTime

You can now use new enums for setting animation time units.

k2FPS // 1/2 sec k125FPS // 1/125 sec

k3FPS // 1/3 sec k150FPS // 1/150 sec

k4FPS // 1/4 sec k200FPS // 1/200 sec

k5FPS // 1/5 sec k240FPS // 1/240 sec

k6FPS // 1/6 sec k250FPS // 1/250 sec

k8FPS // 1/8 sec k300FPS // 1/300 sec

k10FPS // 1/10 sec k375FPS // 1/375 sec

k12FPS // 1/12 sec k400FPS // 1/400 sec

k16FPS // 1/16 sec k500FPS // 1/500 sec

k20FPS // 1/20 sec k600FPS // 1/600 sec

k40FPS // 1/40 sec k750FPS // 1/750 sec

k75FPS // 1/75 sec k1200FPS // 1/1200 sec

k80FPS // 1/80 sec k1500FPS // 1/1500 sec

k100FPS // 1/100 sec k2000FPS // 1/2000 sec

k120FPS // 1/120 sec k3000FPS // 1/3000 sec

k6000FPS // 1/6000 sec
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MPxHwShaderNode

We now support hardware shaders in high quality interactive and 
batch hardware rendering. For more information see ”Improved 
hardware plug-in shader support” on page 257.

virtual MStatus glBind  ( const MDagPath& shapePath );

This method will be invoked once per frame and should be 
overridden to allocate any resources needed for the draw.

virtual MStatus glUnbind( const MDagPath& shapePath );

This method will be invoked once per frame and should be 
overridden to deallocate any resources used to draw. 

virtual MStatus glGeometry( const MDagPath& shapePath,                                  
int glPrim,unsigned int writeMask, int indexCount, const unsigned 
int*indexArray, int vertexCount, const int * vertexIDs, const float * 
vertexArray, int normalCount, const float **  lArrays, int colorCount, 
const float ** colorArrays,int texCoordCount, const float ** 
texCoordArrays);

This method is used to perform OpenGL drawing. The arguments 
contain all the data to successfully call glDrawElements or 
glDrawRangeElements.

In addition, several examples have been updated to demonstrate 
this new functionality.

• cgfxShaderNode

• hwColorPerVertexShader

• hwPhongShader
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Examples of new plug-in functionality

affectsNode

A new example that demonstrates the use of the 
MPxNode::setDependentsDirty() method. This new method 
allows for attributeAffects() relationships involving dynamic and 
non-dynamic (i.e. static) Maya attributes.

blastCmd

This example plugin has been improved to demonstrate the use of 
the new off-screen rendering capabilities on the Linux platform.

componentScaleManip

A new example that demonstrates the use of the new scale 
manipulator function set.

customAttrManip

A new example that demonstrates how to create user-defined 
manipulators from a user-defined context.

deleteMsgCmd

A new example that demonstrates each of the node deletion 
callbacks available.

dynExprFieldTest

A new example that demonstrates the per particle field attributes 
support that has been added to the class MPxFieldNode.

fluidInfoCmd

A new example that demonstrates the usage of the MFnFluid class 
to retrieve fluid information. 
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instanceCallbackCmd

A new example that demonstrates listening to instance add and 
remove messages.

nodeCreatedCB

A new example that demonstrates how to use API messaging to 
invoke a callback whenever a node is created.

particlePathsCmd

A new example that demonstrates the use of the particle id 
information now available in the MFnParticleSystem class.

This example constructs curves from particle paths by tracking 
particle positions using the new available ids.

polyMessageCmd

A new example that demonstrates the use of the MPolyMessage 
class to listen to vertex, edge and face component id changes.

progressWindowCmd

A new example that demonstrates the use of the 
MProgressWindow class.

renderViewInteractiveRenderCmd

A new example that demonstrates the immediate feedback setting 
that has been added to the startRender() methods of the 
MRenderView class.

rotateManip

A new example that demonstrates the use of a rotation 
manipulator function set.
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surfaceBumpManip

A new example that demonstrates how to use the PointOnSurface 
manipulator function set to create surface bumps.

undoRedoMsgCmd

A new example that demonstrates the use of the new Undo and 
Redo events that have been added to the MEventMessage class.

userMsgCmd

A new example that demonstrates the use of the 
MUserEventMessage class. This example allows the creation, 
removal and posting of user-defined events identified by strings.

Other significant changes

• The method MPxNode::addAttributes() has been modified 
to fail if child attributes of a compound are added before a 
parent. Adding the children of a compound before the parent 
leads to Dependency Graph problems. This method has been 
modified to prevent this situation. Adding the parent will 
result in adding the children of a compound, so no additional 
calls to this method are needed in the compound case.

• The MFnDagNode class and its derivatives can crash under 
certain conditions when the destructor is executed. These 
classes currently allow the default bitwise copy constructor to 
be used. Internally, these classes contain pointers to data 
which can be freed more than once if the default copy 
constructor is used. If you are running into destructor crashes 
with the MFnDagNode class or its derivatives, define 
DISALLOW_COPY_CONSTRUCTOR before including these classes 
to provide compile time feedback on where you are using the 
default copy constructor.
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14 | API and DevKit
 > Compiler requirements
• We have improved the performance of removing messages 
with the MMessage class.

• The stability of the MObject class has been improved. Under 
certain situations an MObject could be left with a dangling 
pointer to a deleted depend node. When the MObject's 
destructor was then called, a crash would occur. This problem 
has been solved.

• For Windows, the plug-in and standalone API application 
project files have been updated for .NET 2003.

• For Windows, the Maya plug-in wizard has been updated 
for.NET 2003. Currently, the wizard needs to be manually 
installed. The required files are located in $MAYA_LOCATION/
devkit/pluginwizard and the associated readme file 
describes the installation process.

• For IRIX and Linux, the devkit/plug-ins/Makefile now 
uses a buildconfig file that sets the required platform specific 
flags and options.

• For Mac OS X, standalone API applications are now 
supported.

• The stand-alone API application build script 
$MAYA_LOCATION/bin/mayald now supports:

• A MAYA_LOCATION=... parameter which lets you hard-
code the MAYA_LOCATION variable a Makefile

• An environment variable MAYA_LDCMD that lets you 
specify an alternate linker.

Compiler requirements

• Maya 6 for Linux requires gcc 3.3.2 for developing API
plug-ins and stand alone applications.

• Maya 6 for Mac OS X requires gcc 3.3 for developing API
plug-ins and stand alone applications.
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14 | API and DevKit 
  > Maya lists new IMF plug-ins
• Maya 6 for Windows requires Microsoft Visual Studio .NET 
2003 for building plug-ins and stand alone applications.

Devkit

Maya lists new IMF plug-ins

Now when you write new IMF plug-ins for Maya, IMF (.imf) is 
automatically listed as an Image Format or File Type option in the 
following locations:

Software and hardware render globals Image File Output

Image plane node Input file browser only

File texture node Input file browser only

Render view Input and output file browsers

Artisan tools Input file browser only

Paint Effects panel in canvas mode Input and output file browsers

Paint Effects panel in scene mode Save Snapshot browser only
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Index
Numerics
3D Paint Tool

improvements 293
lipsticking with 224

A
Absolute Rotations 133

accessing Maya browser 52

Activate Keys 132

Adaptation Control
cpSolver 339

Add Cache Segment
Cloth Cache Editor 348

Add Selected Characters 114

adding tracks to characters 105

Adobe Photoshop 219

affectsNode
example 386

All mental ray Nodes tab 240

All Nodes tab 239

Alphabetical 139

Angle Tolerance 93

animation, referenced
bake 178
export 179
import 179

animation, retargeting 192, 195
about 185
labeling joints 187
Retarget Skeleton Options window 195
setting neutral pose 186
why use 185

Annotation node 101

API
significant changes for Maya 6 388
What’s New in Maya 6 369
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 |  
API classes
M3dView 370
MAnimControl 371
MDagMessage 372
MDagPath 373
MFloatVector 373
MFnArrayAttrsData 373
MFnCamera 374
MFnClip 374
MFnDagNode 375
MFnDirectionManip 375
MFnDoubleIndexedComp
onent 376

MFnFreePointTriadManip
376

MFnManip3D 376
MFnNurbsCurve 377
MFnNurbsSurface 377
MFnParticleSystem 377
MFnRotateManip 369
MFnScaleManip 369
MFnSubd 378
MIOStream 379
MLightLinks 379
MMessage 380
MNodeMessage 380
MObjectHandle 369
MObjectSetMessage 369
MPolyMessage 370
MProgressWindow 370
MPxFieldNode 381
MPxHwShaderNode 385
MPxManipContainer 381
MPxNode 382
MRenderUtil 383
MRenderView 382
MSelectionMask 383

MString 383
MTime 384
MTrimBoundaryArray 37
0

MUintArray 370
MUserEventMessage 370
MVector 373

API headers
MFStream 370

applying
per particle field 
attributes 212

Artisan 292
tools in new 
architecture 292

assets
sorting in 
Hypershade 234

Attach Multiple Output 
Meshes 97

audio
creating sound clips 108
playing sound clips 109
Soundtrack 120

Autoload Selected 
Characters 114

B
Back (Maya Browser) 56

baking, normal maps 253

baking, referenced 
animation 178

Bend
Modify Curves 88

Bend Amount 88

Bevel (Edit Polygons 
menu) 90

binding to zero-weighted 
joints 202

bins
working with 234

blastCmd
example 386

Blend Weights
cpProperty 331

blending animation clips 129

blends 128

blends, deleting 130

blends, editing 130

blends, graphing weight 130

browser
accessing 52
controls 53
MEL commands 56

browser in a panel 51

C
cache

cloth, advanced 
editing 343

fluids, One File per 
Frame 296, 298

fluids, segmented 299
fluids, temporary 295
multiple, cloth 344

Cache Editor
cloth 345

Cache Editor window 348

Center Current Time 113
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cgfxShader plug-in 257

changing fluids cache temp 
directory 302

channels
muting in Dope Sheet and 
Graph Editor 163

Character Mapper
about 138
buttons 143
columns 143
Edit menu 140
fields 142
how it works 134
Show menu 139

Character Mapper (Trax 
Editor) 111

Character menu
Redirect 160

characters
about mapping 134
autoload in Trax 114
Character Mapper 138
Select Character Set 
Members (Trax 
Editor) 132

Trax Editor 119

characters, creating clips 
for 107

characters, highlighting in 
Trax 105

characters, loading into 
Trax 104, 114

characters, making 
redirectable 146

characters, mapping 134

Clear All 140

clip manipulator 127

clips
about blends 128
Activate Keys 132
Cycle 126
editing blends 130
Enable Clip 132
Frame In 122
Frame Out 122
groups 119
Holds 126
interaction controls 124
Key into Clips 133
Paste Clip 131
Scale 122, 125
Source In 121
Source Out 121
Time Warp curve 123
Trim 125
weight curve 123

clips, blending 129

clips, constraint 124

clips, copying 107

clips, creating 107

clips, creating a group 108

clips, deleting blends 130

clips, disabling 123

clips, editing attributes 123

clips, expression 124

clips, graphing blends 130

clips, keying into 133

clips, multiple
manipulator 127
moving 109

clips, pasting 107

clips, sound 108
playing audio 109
Soundtrack 120

clips, source
Select Source Clip 132
Source In and Source 
Out 121

clips, viewing with 
Outliner 110

cloth
advanced cache 
editing 343

Cache Editor 345
multiple caches 344
per-face collision 
depth 336

solver diagnostics 342
visualizing stress 333

cloth objects
constraints 326
improved support for 325
painting collision 
properties 327

painting properties 327
resolution 326
UV sets 327
vertex level 
properties 329

cloth solver 
improvements 338

Cluster Curve 96

Cluster Curve (Edit Curves 
menu) 210

Cluster deformer, creating for 
CVs 210

collision depth
per face, cloth 336
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 |  
color per vertex
hardware support for 259

colors, custom
curves 175

colors, customizing curve 176

Combine Meshes 75

command line
new render utility 247

compiler
requirements for Maya 
6 389

Component Editor
improvements 27
improvements for Maya 
6 203

Component Use Object 
Pivot 97

componentScaleManip
example 386

configuring Maya browser 54

constraints
clips 124
cloth objects 326

context sensitive menus
Trax Editor 130

contour rendering 268

Control Bar
FCheck 46

controling sculpt deformers 
strength with texture 206

convert arrays
MEL 356

Convert NURBS to 
Polygons 97

Convert NURBS to Subdiv 95

Convert Polygons to 
Subdiv 95

copying clips 107

cpClothStress node 334

cpProperty node
new attributes 331

cpSolver node
new attributes 339

Create Blend (Trax icon) 114

Create Clip (Trax icon) 114

Create Lattice Options 
window

Falloff Distance 205
Outside Points 
Transform 204

Create Layer 45

Create Meshes Single 
Sided 93

creating a group of clips 108

creating clips 107

creating fluid caches 295

creating references
compared with importing 
preserved references 36

creating sound clips 108

Curl
Modify Curves 87

Curl Amount 87

Curl Frequency 88

curves
about custom colors 175
customizing color 176
deforming with 
lattice 169, 171

muting in Dope Sheet and 
Graph Editor 163

custom animation curve 
colors

about 175

Custom Equalizer Maps
fur 317

customAttrManip
example 386

customizing curve color 176
example (MEL) 184

Cut Along 75

Cut Off
cpClothStress 335

CV
clusters 210

Cycle 126

D
dds image type 365

default file loading 40

Default scene 40

Default Trim Curves 366

Deformable 83

deformer, Jiggle
restrict jiggle 
direction 208
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deformer, lattice
affecting points outside 
lattice 204

deforming curves with 
lattice 171

deforming particles 211

Delete Unused Layers 46

deleteMsgCmd
example 386

deleting blends 130

deleting non-skin history 202
why use 201

Depth Map Enable
collision object 337

Depth Map Weight
collision object 337

Devkit
What’s New in Maya 
6 369

diagnostics
mental ray for Maya 289

Direction Bias 208

directory, temp
making space for fluids 
cache 302

not enough space for 
fluids cache 302

Disable Clip 123

Disable Cutoff
cpClothStress 335

disabling clips 123

disabling script output on 
particle events 217

disk
not enough space for 
fluids cache 304

Display Channel Names 140

Display Node Names 140

Draw Type
cpClothStress 335

Duplicate (Trax Editor) 111

DWG translator 
improvements 365

dynExprFieldTest
example 386

E
Edit menu (Character 

Mapper) 140

Edit menu (Trax Editor) 111

editing clip attributes 123

editing, animation blends 130

Enable Advanced 207

Enable Clip 132

Enable Default Scene 40

environment variable
MAYA_FUR_LIGHT_CL
AMPING 322

MAYA_FUR_OLD_BEHA
VIOR 322

equalizer map
fur, improvements 317

examples
affectsNode 386
blastCmd 386
componentScaleManip 38
6

customAttrManip 386
customizing curve 
color 184

deleteMsgCmd 386
dynExprFieldTest 386
instanceCallbackCmd 387
One File per Frame fluids 
cache 298

particlePathsCmd 387
polyMessageCmd 387
progressWindowCmd 38
7

redirecting animation 148
renderViewInteractiveRen
derCmd 387

rotateManip 387
segmented fluids cache 
(MEL) 301

surfaceBumpManip 388
undoRedoMsgCmd 388
userMsgCmd 388

export
referenced animation 179

exporting references 37

expression
applied after 
dynamics 215

applied before 
dynamics 215

expressions
clips 124
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F
Falloff Around Selection 61

Falloff Based On 62

Falloff Curve 60

Falloff Distance 205

Falloff Radius 60

FCheck
Control Bar 46
Full Screen 47
improvements 46
sound 47

field attributes
per particle 212

File menu (Trax Editor) 111

files, loading selected 28

filtering
nodes in Hypershade 237

Final Gather
photon visualization 286

fluids cache
creating temporary 295
making space for 302
One Frame per File 298
re-establish link with 304
Replace Cache Frame 306
segmenting 299
troubleshooting 301, 303
turning off local 
creation 296

Force All 202

Forward (Maya browser) 57

Frame All (Trax icon) 115

Frame In 122

Frame Out 122

Frame Playback Range 113

Frame Playback Range (Trax 
icon) 115

frames
playblast 178

freeze transformation
improvements 41

Freeze Transformations 98

Fur
changes 309

fur
equalizer map 
improvements 317

painting 
improvements 319

rendering in mental 
ray 309

Subdivision Surfaces 319

Fur Feedback
hide fur 320
improvements 320
Render Stats 314
show fur 320
switch between 321

G
Get Clips (Trax icon) 115

ghosting
parts of objects 177

Go to Neutral Pose (Skeleton 
menu) 193

goalU 212

goalV 212

Graph Anim Curves (Trax 
icon) 115

Graph Editor
Lattice Deform Keys 
Tool 169

Move Keys Tool 167

Graph Weight Curves (Trax 
icon) 115

graphing blend curves 130

Group (Trax Editor) 113

Group (Trax icon) 115

grouping clips 108

groups
clips 119
highlighting in Trax 105

H
hardware plug-in shaders 257

Hardware rendering
color per vertex 
support 259

command line 
rendering 247

performance 
improvements 257

Heads Up Display 96

Hide All Labels 194

Hide Cloth Stress 333

Hide Zero Columns 27

Hierarchical 139

hierarchy
tracks in the Trax 
Editor 118

High Stress Color
cpClothStress 334
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highlighting characters in 
Trax 105

hinge constraints
parenting 218

history, deleting non-skin 202

Holds 126

Home (Maya browser) 57

hwColorPerVertexShader 
plug-in 257

Hypergraph
node colors 43

Hypershade
custom tabs 239
new sorting bins 234
performance 
improvements 233

shape and transform 
nodes in 240

tab filtering in 237

I
IBL. See Image-Based 

Lighting
IGES import/export options

improvements 365

illumination
sky-like 278

image file support
dds 365
png 365

image planes
using sequences with 245

image sequences
rendering 
improvements 245

Image-Based Lighting 278

IMF
new functionality for 
Maya 6 390

IMF plug-ins 253

importing
referenced animation 179
STL 367

importing preserved 
references

compared with creating 
references 36

importing shading 
networks 252

importing sound (FCheck) 47

Instance Leaf Nodes 41

instanceCallbackCmd
example 387

instancing
improvements 41

Interactive Playback
improvements 218

Interactive Shading Mode
setting options for 232

Interpolation Type
Cloth Cache Editor 349

IPR rendering
with mental ray for 
Maya 265

Is Soft
mesh constraint 338

J
Jiggle deformer

restrict jiggle 
direction 208

Joint Labelling menu 
(Skeleton menu) 193

joint labels
Hide All Labels 194
Joint Labelling 193
Label Based On Joint 
Names 194

Rename Joints Labels 194
Show All Labels 194
Toggle Selected 
Labels 194

visibility 191

joint labels, applying 187

joint labels, removing 191

joints, labeling 187

joints, retargeting 
animation 185, 192

joints, setting the neutral 
pose 186

K
Key into clip (Trax icon) 116

keying into clips 132, 133

keys
deforming with lattice 169
manipulating groups 167
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L
Label Based On Joint 

Names 194

labeling joints for 
retargeting 187

labels, joint
Hide All Labels 194
Joint Labelling 193
Label Based On Joint 
Names 194

Rename Joints From 
Labels 194

Show All Labels 194
Toggle Selected 
Labels 194

labels, removing from 
joints 191

labels, toggling visibility 191

Lattice Deform Keys Tool 169

Lattice deformer
deforming points 
outside 204

Lattice Settings (Lattice 
Deform Keys tool) 170

lattices
deforming curves 169, 171

Layer Editor
improvements 45

Level Mapping 366

light linking
improvements 288

lightmaps
performance 
improvements 288

lipsticking 224

List menu (Trax Editor) 114

Load No References 31

Load Related References 32

Load Selected Characters 114

loading characters into 
Trax 104, 114

loading default file 40

loading mental ray 
shaders 264

loading references 30, 35
MEL 358

loading selected files 28

loading textures, 
disabling 245

Locator 35

locators
reference 33

Lock 116

Lock Length 84

locking tracks 116

Low Stress Color
cpClothStress 334

Lower Body Scale 198

Lower Body Solution 196

M
M3dView

changes in Maya 6 370

Maintain Offset 196

makeIdentity 98

making space in directory for 
fluids cache 302

MAnimControl
changes in Maya 6 371

manipulating
references 33

manipulating curves with 
lattice manipulator 169

Map based on hierarchy 141

Map based on order 142

mapping characters 134
workflow 137

mapVizShape node 287

Mask Unselected 60

master bin 234

Match Knots 98

Max Curvature
Scale Curvature 89

Maya browser 51
accessing 52
configuring 54
controls 53
MEL commands 56

Maya hardware 
rendering 257

Maya software rendering 248

maya.rayrc 264

MAYA_FUR_LIGHT_CLAM
PING 322

MAYA_FUR_OLD_BEHAVI
OR 322

MAYA_MRFM_SHOW_CUS
TOM_SHADERS 264

MAYA_SCRIPT_PATH
changes 351

MDagMessage
changes in Maya 6 372
What’s New in Maya 6

398



 |
MDagPath
changes in Maya 6 373

MEL
convert arrays 356
new and improved 
commands 351

MEL commands in Maya 
browser 56

mental ray for Maya
fur, rendering 309

mental ray for Maya 
rendering 264

command line 
rendering 247

connecting shaders 265
diagnostics 289
IPR rendering 265

Menu bar
Trax Editor 110

menus
context sensitive (Trax 
Editor) 130

Merge Tolerance 97

Merge Vertex Tolerance 
(Mirror Cut option) 75

Merge Vertex Tolerance 
(Smooth Proxy 
option) 78

Merge Vertices 97

Merge vertices with 
tolerance 367

merging vertices 367

Mesh Draw Offset
cpClothStress 336

MFloatVector
change in Maya 6 373

MFnArrayAttrsData
changes in Maya 6 373

MFnCamera
changes in Maya 6 374

MFnClip
changes in Maya 6 374

MFnDagNode
change in Maya 6 375

MFnDirectionManip
changes in Maya 6 375

MFnDoubleIndexedCompone
nt

changes in Maya 6 376

MFnFreePointTriadManip
changes in Maya 6 376

MFnManip3D
changes in Maya 6.0 376

MFnNurbsCurve
changes in Maya 6 377

MFnNurbsSurface
changes in Maya 6 377

MFnParticleSystem
changes in Maya 6 377

MFnRotateManip 369

MFnScaleManip 369

MFnSubd
changes in Maya 6 378

MFStream 370

MI_CUSTOM_SHADER_PAT
H 264

MIOStream
changes in Maya 6 379

Mirror Behavior 76

Mirror Cut, Polygons 73

Mirror Direction 78

MLightLinks
changes in Maya 6 379

MMessage
changes in Maya 6 380

MNodeMessage
changes in Maya 6 380

MObjectHandle 369

MObjectSetMessage 369

Modify Curves 84

monitorScript
cpSolver 340
parameters 340

motion redirection
how to use 146
why use 144
workflow 145

Move Falloff 169

Move Keys Tool 167

moving groups of 
keyframes 167

moving multiple clips 109

MPolyMessage 370

MProgressWindow 370

MPxFieldNode
changes in Maya 6 381

MPxHwShaderNode
changes in Maya 6 385

MPxManipContainer
changes in Maya 6 381

MPxNode
changes in Maya 6 382

MRenderUtil
changes in Maya 6 383

MRenderView
changes in Maya 6 382
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MSelectionMask
changes in Maya 6 383

MString
changes in Maya 6 383

MTime
changes in Maya 6 384

MTrimBoundaryArray 370

MUintArray 370

MUserEventMessage 370

Mute 117

mute curve 163
why use 163

muting channels in Dope 
Sheet and Graph 
Editor 163

muting tracks 117

MVector
changes in Maya 6 373

N
Neutral Pose 196

neutral pose
Go to Neutral Pose 193
Set Neutral Pose 193

Neutral Pose Frame 196

neutral pose, setting 186

node colors 43

Node Display Override 
Color 44

nodes
sorting in 
Hypershade 234

Non Uniform 207

nonlinear animation
blends 128
Trax Editor in Maya 6 103

non-photorealistic 
rendering 268

normal map baking 253

Normals
Freeze Transformations 
option 99

O
Object space, normal map 

baking 254

Object Type 177

off-screen
playblast 178

Offset Distance
Polygon Bevel 
attribute 92

Offset Space 91

Offset Type 91

One File per Frame
about 296
creating segmented 
caches 298

Example 298
why use 296

Only for non-rigid 
deformations 100

Open (Maya browser) 56

Open Help In Main Maya 
Window 55

Open Help Using External 
Browser 55

OpenFlight
Mac OS X support 367

Operation
Cloth Cache Editor 348

Optimize Scene Size
customizing, MEL 360
improvements 37
reporting 38

Outliner
viewing all animation 
clips 110

Outside Points Transform 204

overlapping objects
selecting 44

P
paint

polygons, on 291

Paint Collision Properties 
Tool 293

Paint Effects 291
polygons 291
render progress 
indicator 291

UV linking 291

Paint Fur Attributes Tool
improvements 319

Paint Hair Tool 292

Paint Resolution 207

Paint Scripts Tool
improvements 293, 360

Paint Sculpt Map 208
3D Paint Tool 
improvements 293
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painting
fur, improvements 319
in Photoshop 224

painting cloth object 
properties 327

painting collision object 
properties 327

panel
Web browser 51

parenting hinge 
constraints 218

particle events
disabling script 
output 217

particle motion blur
rendering 288

particlePathsCmd
example 387

particles
deforming 211
random number 
streams 216

Paste Clip 131

pasting clips 107

per-face collision depth 336

performance improvements
Hardware rendering 257, 
262

Hypershade 233
lightmaps 288

per-particle field 
attributes 212

applying 212

per-particle goalU/goalV 
attributes 212

photons
visualization 286

Photoshop. See Adobe 
Photoshop. 219

Pixel Snap 94

playback range
setting to range of clips in 
Trax 110

Playblast
command 178

playing sound clips 109

plug-ins
IMF 390

png image type 365

Poly Mirror Cut 73

polyBevel node 93

polygon
Paint Effects 291
painting on 291

Polygon Proxy Mode 90

polygon surface
textured surface 
emission 216

Polygons menu
Unmirror Smooth 
Proxy 82

polymesh goal objects
per-particle attributes 212

polyMessageCmd
example 387

polyNormalPerVertex 100

Pop-up Menu Selection 44

poses, neutral
Go to Neutral Pose 193
Set Neutral Pose 193

Preload Reference Editor 30

pre-loading references 30

Preserve History 60

Preserve Length 86

Preserve Reference 36

preserving references 36

progress indicator
Paint Effects render 291

progressWindowCmd
example 387

Proxy Mesh Renderable 81

PSD files
converting to network 222
creating in Maya 222
updating 225
use existing 221

R
random number streams

MEL 357

random number streams for 
particles 216

Read Equalizer Maps
fur 318

Rebuild Curve 98

Rebuild Method 98

Rebuild Surfaces 98

Redirect (Character 
menu) 160

redirecting animation 146
example 148
workflow 145

Redirection Type 161
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redirection, motion
about 144
how to use 146

Reference Editor
improvements 31

reference locators 33

referenced animation
baking 178

references
exporting 37
loading 30, 35
loading, MEL 358
manipulating 33
pre-loading 30
preserving 36
reloading 36
unloading 35

reflections
rendering blurry 276

refractions
rendering blurry 276

Refresh 141

Reload 56

Reload (Maya browser) 56

reloading references 36

remapColor utility 251

remapHsv utility 251

remapValue utility 250

removing cloth properties
cloth objects 332

removing labels from 
joints 191

Rename Joints From 
Labels 194

render
fur in mental ray 309
Paint Effects progress 
indicator 291

render globals
hardware renderer 262

render nodes
bin organization 234

Render Stats
FurFeedbackShape 
node 314

render utility
new 247

rendering 219
blurry refractions 276
contours 268
Maya Fluids 267
Maya Fur 268

renderViewInteractiveRender
Cmd

example 387

Replace Cache Frame 306

restricting jiggle direction 208

Retarget Skeleton Options 
window 195

Lower Body 196
Neutral Pose 196
Time 201
Upper Body 198

retargeting animation 192
about 185
labeling joints 187
Retarget Skeleton Options 
window 195

setting the neutral 
pose 186

workflow 185

rigid bind 202

Rigid Bind Options window
Force All 202

RN suffix 34

Rotate Mode 83

rotateManip
example 387

rotations
absolute 133

runtime expressions
dynamics 215

S
Scale 122, 125

Scale Curvature 88

Scale Factor 366, 367
Scale Curvature 88

Script Editor
improvments 42

Sculpt deformer
using texture map 205

Sculpt Deformer Options 
window

Advanced Sculpt 
Deformer Attributes 207

Sculpt Polygons Tool 98
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Sculpt Surfaces Tool 98
improvements 293

See also PSD files.
segmenting fluids cache 298, 

299
example 301

Select Character Set 
Members 132

Select Curve CVs 96

Select First CV on Curve 96

Select Last CV on Curve 96

Select Source Clip 132

selecting
overlapping objects 44

selecting character set 
members 132

selective file loading 28

selective load settings 28

Selective Preload 30, 31

Set List
cpProperty 331

Set Neutral Pose (Skeleton 
menu) 193

setting neutral pose for 
skeletons 186

setting Time Slider’s playback 
range to the range of the 
clips in Trax 110

shader glow
rendering 288

Shader manager 264

shaders
connecting 265
hardware plug-in 257

shading networks
import improvements 252
removing redundant 252
testing portions of 242

shading, interactive 228

shape nodes
hiding 240

Share Transform Node 80

Show All Columns 28

Show All Labels 194

Show Cloth Stress 333

Show menu (Character 
Mapper) 139

Show Selected Columns 28

Show Selected Objects 28

skeletons, labeling 187

skeletons, retargeting 
animation 185, 192

skeletons, setting the neutral 
pose 186

skin, deleting history 202

skin, soft bind 203

sky-like illumination 278

Smooth
Modify Curves 87

Smooth Factor 87

Smooth Proxy (Polygons 
menu) 75

Smooth, Polygons 89

soft bind 203

Soft Modification Tool 59, 203

Software rendering
command line 
rendering 247

new color utility 
nodes 248

Solo 117

soloing tracks 117

solver
cloth, diagnostics 342
cloth, improvements 338

Sort Alphabetically 
(Component Editor) 27

Sort Layers Alphabetically 46

Sort Layers 
Chronologically 46

sound
importing to FCheck 47

sound clips 108

Soundtrack 120

Source In 121

Source Out 121

Split Polygon Tool 95

Stitch
cloth constraint 337

STL import 367

Stop Loading (Maya 
browser) 56

Straighten 85

Straightness 86

stress
cloth 333

Stress Scale Factor
cpClothStress 336

strokes
isolate for render 291
What’s New in Maya 6

403



 |  
StudioImport
Mac OS X support 368

subcharacters (Trax 
Editor) 119

highlighting 
summaries 105

Subdivision Surfaces
fur 319

summaries
characters 120
groups 120
subcharacters 120

Suppress Command 
Results 42

Suppress Error Messages 42

Suppress Info Messages 42

Suppress Warning 
Messages 42

surfaceBumpManip
example 388

T
tabs

in Hypershade 239

Tangent space, normal map 
baking 254

Target Cache
Cloth Cache Editor 348

Target Range
Cloth Cache Editor 348

testing
textures 242

Texture 207

texture map
Sculpt deformer 205

Texture Multiplier 207

textures
disabling loading 245
mental ray 289
testing 242

Time Range 201

Time Warp
display on clips 123

time working units
additions for Maya 6 177

Toggle Selected Labels 194

toggling joint label 
visibility 191

tools
Artisan new 
architecture 292

Lattice Deform Keys 169
Move Keys 167

Track control area 116

Track view area 118

tracks
hierarchy in Trax 118
Track control area 116
Track view area 118

tracks, adding to 
characters 105

tracks, locking 116

tracks, muting 117

tracks, soloing 117

transform nodes
hiding 240

Trax Editor
adding tracks 105
changes for Maya 6 103
context sensitive 
menus 130

creating clips 107
grouping clips 108
hierarchy of tracks 118
highlighting 
summaries 105

loading characters 104
Menu bar items 110
Soundtrack 120
summaries 120
Track control area 116
Track view area 118
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