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1 Glossary

About Preface

The Maya Glossary lists terms and concepts pertaining to Maya and 
computer animation. This document focuses on terms and concepts rather 
than on particular attributes and interface features. 

To look up information about a particular attribute, interface element, 
MEL command, or dependency graph node, use the advanced search 
capabilities in the online help.
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 absolute mode
Glossary: A

absolute mode

A state where an object is placed at coordinates relative to the world space 
origin.

Contrast with  relative mode.

" Move, rotate, or scale objects

" Tab sections

activation key 

An encrypted string consisting of numbers and letters, which allows you 
to activate Maya once it has been installed. The activation key is generally 
sent via email as part of the Online Product Activation (OPA) process.

See also Online Product Activation (OPA), serial number.

" Overview of licensing

active lines

The isoparms on currently selected surfaces.

See also isoparm.

" Insert additional edit points/isoparms in a curve or surface to add more CVs

" Edit NURBS > Insert Isoparms 

active view

The currently selected view.

AIFF file format

Audio Interchange File Format, a file format for audio data. Maya uses 
this file format for sound data when creating animations.

" Adding sound to your animation 

aim constraint

In animation, a type of constraint that keeps an object aimed toward 
another object. See also constraint. 

In other software packages, known as direction constraint.
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aim vector
" Aim constraints

" Constrain > Aim

aim vector 

In animation, the direction a constrained object must point toward so that 
it points at the target point. 

The aim vector starts at the constrained object’s pivot point, and is defined 
relative to the object’s local space. By itself, the aim vector does not 
completely constrain the object, because it does not control the orientation 
of the object (determined by the up vector and the world up vector).

See also up vector, vector.

" Create > Cameras > Camera and Aim

air field

In dynamics, a method of simulating the effects of moving air. As the 
animation plays, the air field affects the motion of objects connected to it.

" Fields > Air

For more information, search the online help for air field

algorithm

A rule or procedure for solving a mathematical problem that frequently 
involves the repetition of an operation.

aliasing

Unwanted visual effects or artifacts caused by limited display resolution. 
These effects include grainy surfaces, jaggies (staircasing along diagonal 
lines), moiré effects (grids or checkerboards), or temporal aliasing 
(strobing) in animated scenes.They are controlled by anti-aliasing settings.

See also anti-aliasing.

" Anti-aliasing and flicker

" Adjust anti-aliasing

alpha channel

A view of an image that represents the presence and degree of opacity of 
objects. The channel associated with each pixel determines the degree of 
opacity of that pixel. 
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 ambient light
In an alpha channel, areas that do not contain objects are black, areas that 
contain solid objects are white, and areas that contain partially transparent 
objects are a shade of gray.

In video production, the alpha channel is used to determine how one 
video image is laid over another.

When using Artisan tools, you can import image files created in other 
programs into Maya and if alpha channel values are available you can use 
them.

Also known as mask channel, matte channel.

" Display RGB, luminance, or alpha channels

ambient light

A pervasive background light source with no particular source location or 
direction. Ambient light appears to come from everywhere at the same 
time, like sunlight on a hazy day. Ambient light is typically used to 
control the overall brightness and color of a scene.

Use an ambient light to simulate a combination of direct light (for 
example, the sun or a lamp) and indirect light (sunlight diffused by the 
atmosphere, or lamp light reflected off the walls of a room).

See light source.

" Create > Lights > Ambient Light

" Ambient Light Attributes

angle of view

In photography, the measure of the angle of a lens' view. As you adjust a 
camera’s focal length, the angle of view narrows and expands, causing 
objects to get larger or smaller in the frame. 

In Maya, the angle of view is simulated by zooming the camera. See zoom.

" Angle of view (focal length)

angular unit

The unit of measure for operations that use an angular value (for example, 
rotation). The default unit for measuring angular values is degrees.

" Tab sections

angular velocity

In dynamics, the spin (rotational speed) of a rigid body.
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anim curve
" Soft/Rigid Bodies > Create Active Rigid Body

anim curve

A curve that represents motion. Each animation curve represents changes 
in the value of an attribute. You can directly edit animation curves with 
the Graph Editor. Also known as animation curve.

To work with animation curves, use the menus:

• Animate objects > Edit curves

• Animate objects > Edit keys from curves

  

" Edit a clip's animation curves

" Import anim curves

" Export anim curves

anim file

A file containing animation curve data. See also anim curve.

" Anim File Format

animation

The process of developing the actions (poses, timing, motion) of objects. 
Maya offers several animation methods, including keyframe animation, 
path animation, nonlinear character animation, and motion capture 
animation.

" Animation in Maya

animation control

In post-production video and film recording, the setup of a videotape 
recorder to record a single frame at a time. An animation controller is 
useful to guarantee real-time recording of data submitted from a 
computer.

Maya provides its own set of animation controls for developing the timing 
of animations.

" Animation controls
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 anti-aliasing
anti-aliasing

A group of over-sampling methods for avoiding the unwanted visual 
effects or artifacts caused by limited display resolution. These aliasing 
effects include jaggies (staircasing along diagonal lines), moiré effects in 
checkerboards, and temporal aliasing (strobing) in animated scenes.

Maya provides various solutions for edge aliasing and for shading 
aliasing. Some anti-aliasing techniques reduce performance, and will 
increase render times. Try to find the solution that gives you the best 
balance between image quality and performance.

" Anti-aliasing and flicker

" Adjust anti-aliasing

aperture

In photography, the size of hole allowing light from the lens to get 
through to the film. The aperture works in conjunction with the shutter to 
determine the amount of light that reaches the film.

In Maya, aperture effects are simulated by camera settings such as 
filmback and filmgate.

" fStop (aperture) and shutter speed/angle

API

Application Programming Interface. In Maya, refers to a set of C++ classes 
that provide internal access to Maya tools. The API is packaged as a set of 
OpenMaya libraries corresponding to the different functional areas of 
Maya.

For API reference information, go to the Developer section in the table of 
contents in the home page of the help.

area light

A type of light source that emits light from a two-dimensional area. A 
larger area light has a stronger intensity.

See light source.

" Area Light Attributes

" mental ray Area Light 

" Create > Lights > Area Light 
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area value
area value

In Maya Fur, the distribution of hairs, defined by the fur density that 
places hairs evenly over all surfaces that have the fur description attached. 

When you disable this option, the hairs defined by the fur Density are 
distributed per surface. For example, if you have a fur description with a 
Density of 1000 attached to 10 surfaces and this option is enabled, the 1000 
hairs will be distributed evenly across all 10 surfaces. If this option is 
disabled, each of the 10 surfaces will have 1000 hairs.

" Fur Globals

articulation

In animation, the state of a skeleton’s joints, including position, rotation, 
and scaling.

" Joints and bones

Artisan tools

A set of tools that use an intuitive paint and sculpting-based interface to 
accomplish a variety of modeling, animation, rendering, and effects tasks 
that deliver high quality and enable otherwise complex results in minimal 
time. 

" Using Artisan brush tools

ASCII file 
A text file in the American Standard Code for Information Interchange 
(ASCII) format. Maya scene files can be saved in an ASCII format (file 
extension .ma) or in a binary format (file extension .mb). 

Binary files are usually smaller and load faster than ASCII files, and are 
the default. However, only ASCII files can be edited using a text editor. 

" Organization of Maya ASCII files

aspect ratio

In compositing, the proportions of an image expressed as the ratio 
between the horizontal and vertical dimensions. 

Because pixels are not necessarily proportional, the aspect ratio is 
independent of the number of pixels in the X and Y directions. For 
example, both NTSC and PAL television screens are 4 x 3 (for an aspect 
ratio of 1.33). However, a CCIR601 NTSC image is 720 x 486 pixels, while 
a PAL image is 720 x 576 pixels.
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" Set the resolution and pixel aspect ratio

atmosphere

In rendering, the environment that surrounds the objects in a scene. For 
example, the simulation of fine particles (fog, smoke, or dust) in the air. 

When you photograph an object in the real world, it is usually within an 
atmosphere (for example, air) and can be surrounded by other 
background objects. In Maya, you may want to model only the foreground 
objects in a scene, represent background objects using a two-dimensional 
background, and then simulate the effect of an atmosphere surrounding 
the objects in your scene.

See also environment fog.

" Surface, displacement, volumetric materials

" Environment Fog

attenuation

In dynamics, the amount the strength of a field diminishes as distance 
from the affected object increases.

" Fields > Radial

attractor

In Maya Fur, a joint chain that attracts the hairs in a fur description. 
Attractors can be used to affect the movement of hair using dynamics and 
forces.

" Create attractors

attribute

A quality or characteristic of a node. For example, a sphere’s transform 
node has a Rotate X attribute that represents the sphere’s orientation 
around the X axis. 

A node’s attributes can connect to the attributes of other nodes, thus 
forming an intricate web of nodes. This means that you can create a 
virtually unlimited variety of complex, dynamic relationships between the 
many entities that comprise a scene.

See Attribute Editor.
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Attribute Editor
Attribute Editor 
An editing window that shows all the attributes of one particular node in 
detail, using an explanatory interface. The Attribute Editor is useful for 
viewing and changing detailed information about an object.

In other software packages, similar functionality is provided by change 
creation parameters, parameter panel or hierarchy panel.

" The Attribute Editor

For more information, search the online help for Attribute Editor

attribute map

In painting, a two-dimensional image with values that correspond, or 
map, to attributes of points on a three-dimensional surface. This mapping 
is relative to the UV parameterization of the surface, and ensure that 
attribute values are applied to the surface every time the scene is opened.

" Map attributes

" Sculpt according to an attribute map

" Fur > Paint Fur Attributes Tool

Attribute Spread Sheet

A general editor where you can view and edit the attributes for such 
rendering items as a shading group, camera, light, or texture. 

This editor doesn’t provide the detail of the Attribute Editor, but is useful 
for viewing, assigning, and editing attributes for multiple objects or nodes 
simultaneously.

" View and edit multiple attributes on multiple nodes

" Window > Attribute Spread Sheet

For more information, search the online help for Attribute Spread Sheet

axis

One of three vectors (X, Y, and Z) that define the three dimensions of a 
scene.

See also local space, object space, origin axis, world space.

azimuth

The angle of a camera’s sight line relative to a plane perpendicular to the 
ground plane.
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 azimuth
" Use the mouse to control camera azimuth, elevation, yaw or pitch

" View > Camera Tools > Azimuth Elevation Tool
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 back shadow
Glossary: B

back shadow

In Maya Fur, a simulation of the lighting of fur pointing away from the 
light on the back side of an object.

" Adding fur shading effects

" Shadow Effects

backdrop

An image that you display in the background of a scene.

" Image file backgrounds

backface culling (backculling)

A method of selecting and drawing only those surfaces that face into the 
surface normal. One-sided polygons facing away from the surface normal 
are not shown. 

Backface culling helps speed up the display and manipulation of objects. 

Contrast with occlusion culling.

" Display > Custom Polygon Display

background

An image, texture, or color that is rendered behind all objects in a scene. 

Backgrounds are useful in providing more realistic images when 
rendering, or as a temporary reference when modeling or animating 
objects in a scene.

In other software packages, known as shadow object.

See also image plane. 

" Use Background

bake

1 In animation, the process of creating a single animation curve for an 
object whose actions are being provided by simulation rather than by 
keys and animation curves (keysets). This process makes many types of 
animation available that are not available for keyset editing. 

" Baking simulations
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bake-set
" Bake keys

" Edit > Keys > Bake Simulation

2 In rendering, the process of rendering illumination, shadow, shading, 
and textures to a file texture or to per-vertex color mesh. Baking lets 
you render an object once and either re-use the file texture as a texture 
map or bake colors onto vertex meshes. Texture maps can also be 
manipulated to obtain lighting effects that would be difficult to 
achieve in other ways. 

In mental ray for Maya, also known as light mapping. 

" Baking illumination and color

" Baking with global illumination

" Edit Polygons > Colors > Prelight

bake-set

In mental ray rendering, a logical collection of baking properties, which 
allows objects to be collected together and baked at the same time with 
their various parameters.

" Bake-sets

ball joint

In animation, a joint that can rotate about all three of its local axes.

See joint.

" Joints and bones

barrier constraint

In dynamics, a constraint that places an infinite barrier plane beyond 
which the center of mass of the rigid body will not move. 

Barrier constraints are useful for creating walls and floors.

" Create a Barrier constraint

batch render

A method of rendering launched in a separate session of Maya, using a 
saved copy of a scene file. Batch renders allow you to continue working 
on a scene while it is being rendered, launch renders remotely, and render 
scenes faster than from within the Maya user interface.

Contrast with hardware render.
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 bend deformer
In other software packages, known as command line render or render.

" Batch render a still or animation

" Render > Batch Render

bend deformer

In animation, a method used to bend an object along an arc.

" Creating bend deformers

" Deform > Create Nonlinear > Bend

beveling

In polygonal modeling, the expansion of vertices and edges into a new 
face. You can use options to position these faces at an offset, or scale them 
towards the original face center.

" Bevel edges

" Polygon Bevel

" Surfaces > Bevel

Bezier curve

In modeling, a curve with at least four control points available to control 
the shape of the curve.

In other software packages, this term may refer to a NURBS curve.

" Curve components

Bezier patch

In modeling, a parametric surface, approximately rectangular, that is 
quilted together with other Bezier patches to form a large, curved surface. 
The shape of a Bezier patch is controlled by 16 control points distributed 
uniformly over the surface.

Contrast with B-spline patch. In other software packages, known as patch 
surface.

" Edit NURBS > Rebuild Surfaces

bin

See sorting bin.
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binary file
binary file

A file in binary (non-text) format. Contrast with ASCII file.

bind pose

In animation, the default position of a skeleton, used to keep track of 
transformation attributes for all the skeleton’s joints and influence objects. 

" Set bind pose

For more information, search the online help for Bind pose

binding skin

In animation, the process of attaching deformable objects (skin) to a 
skeleton. Maya provides two binding methods: rigid skin and smooth 
skin.

See also skinning, rigid skin, smooth skin. In other software packages, known 
as envelope.

" Bind skin

" Bind smooth skin

" Skin > Bind Skin > Smooth Bind

" Skin > Bind Skin > Rigid Bind

birail

In modeling, a surface created by sweeping one or more profile curves 
along two path curves.

In other software packages, known as skinning.

" Sweep one or more profile curves along two path curves (birail)

" Surfaces > Birail > Birail 1 Tool, Birail 2 Tool, Birail 3+ Tool

blacking

In film and video post production, the process of pre-recording a time 
code on the audio track of a videotape to prepare it for frame-accurate 
recording and capture. 

Also known as striping.
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 blend
blend 

1 In animation, a shape deformer that changes the shape of one object 
into the shapes of other objects. In other software packages, known as 
morpher.

" Blend Shape deformers

" Blending objects with different topologies.

2 In frame animation, a way of combining two clips together to form a 
clip that is colored or lit differently.

" Create and edit blends

3 In painting, the influence of the shading or shape of a brush on the 
next brush chosen. 

" Blending brushes

4 In modeling, a transitional surface that connects two surfaces, creating 
a particular aesthetic effect. See also fillet blend. surface.

" Create a surface between two sets of boundary curves

blind data

Information stored with polygons that is not used by Maya in any way, 
but is useful to the platform to which the polygons are exported, such as a 
games engine.

" Set up the structure of blind data

" Make blind data visible

" Blind Data Editor

Blinn material

A shading material for 3D surfaces developed by James Blinn. It offers 
high-quality specular highlights useful for simulating glass and metals.

" Material Types

" Blinn

blobby surface

In dynamics, a render type that displays particles as metaballs (spheres that 
blend together to form surfaces). Blobby surfaces appear only in images 
that are software-rendered.

" Choose how particles render
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blur
blur

1 In painting, the softening of edges of adjacent colors by averaging 
their color values. Contrast with smear.

" Smear and blur paint on the canvas

2 In rendering, the simulation of the blurring that occurs when a fast-
moving surface is captured by a camera. See motion blur.

" Set motion blur

bone

In animation, the rigid extension of a joint, controlled by the joint’s 
rotation and movement. Each joint can have one or more bones attached 
to it. 

See also joint, skeleton.

" Joints and bones

bone lattice flexor

In animation, a simulation based on lattice deformers that provides 
smoothing and bulging effects around bones. See also lattice deformer.

" Flexors

bone sculpt flexor

In animation, a simulation based on sculpt deformers that provides 
rounded deformation effects around bones. See also sculpt deformer.

" Flexors

bookmark

A way to mark a view for future use, allowing you to keep a variety of 
camera views for a scene.

Maya has four predefined bookmarks: Perspective, Front, Top, and Side. 
You can change the view in any of these predefined bookmarks, and 
create additional bookmarks of your own.

" Return to previous views

Boolean operation

In polygonal and NURBS modeling, a modeling method where one shape 
can act upon another as a volumetric tool. 
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Boolean operations include the union, difference, and intersection logic 
operations, which can be applied to two solid objects to combine, remove, 
or keep only the intersections of their volumes.

For example, a cylinder can be subtracted from a cube using the difference 
operation to create a cube with a hole.

" Combine meshes using boolean operations

" Polygons > Booleans

BOT

Block Ordered Texture, a rendering caching method that reduces the RAM 
memory needed for texture files.

" Cache texture tiles using BOT (block ordered texture)

bounciness

In dynamics, the resilience of a rigid body.

In other software packages, known as elasticity.

" Edit particle collision attributes

bounding box

The display of an object as a box delineating the dimensions of the object. 

" Display > Object Display

" Modify > Snap Align Objects > Align Objects

breakdown

In Maya animation, a type of key that maintains a proportional 
relationship with adjacent keys. See also key.

" Breakdowns

broadcast quality

In film and video post-production, a video signal of sufficient quality to be 
used by the broadcast industry. 

Contrast with industrial quality.

" Hardware, software, and vector rendering
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Brownian texture
Brownian texture

Textures that can be used to create rough, bumpy surfaces. Used as a 
bump map, they are good for creating effects such as thickly-painted 
metal. 

This texture gets its name from "Brownian Motion", the random motion of 
molecules in a liquid as they bump into one another. 

" brownian

browser

A Web browser invoked from a Maya panel that lets you browse through 
and view Web content, or issue MEL commands from an HTML page. 
This makes it possible to integrate Internet solutions into your Maya 
workflow.

" Web browser in a panel

brush

A tool used In Maya Artisan and Paint Effects that allows you to apply 
paint, objects, fur, or other attributes to a canvas or surface.

" Working with brushes

" Paint Effects > Get Brush

brush stamp

The area of influence of a brush on a surface. By default, the area is 
circular, but you can change the brush shape. 

The characteristics of a brush stamp are defined by its stamp profile. The 
stamp profile can include characteristics such as brush radius, brush 
opacity, brush value, and  brush shape.

" How Artisan brush tools work

" Brush Profile

B-spline patch

In modeling, a parametric surface, approximately rectangular in shape, 
that can be quilted together with other B-spline patches to form a large, 
curved surface. 

The shape of a B-spline patch is controlled by 16 control points that can be 
repositioned, thereby allowing the patch to be reshaped interactively. 
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 bump map
Contrast with Bezier patch.

" Brief history of splines

" NURBS

" Change a curve or surface's degree or number of spans/patches

" Edit Curves > Fit B-spline 

bump map

In rendering, the simulation of 3-dimensional surface detail effects by 
creating the illusion of bumps or other types of surface relief. 

A bump map does not alter the shape of surfaces to which it is assigned.

Contrast with displacement map.

" Painting a bump map texture

bumpiness

In rendering, the appearance of a surface as bumpy (for example, like the 
peel of an orange). Bumpy surfaces can be either simulated with a texture, 
or created by displacing the actual surface of an object. 

See also bump map, displacement map.

" Surface texture?

" Painting a bump map texture

" Modifying a bump texture

" Creating a texture within the Hypershade Editor
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 cache file
Glossary: C

cache file

A file that stores positions of vertices and other data for Maya simulations 
such as cloth or fluids.

The cache file lets you quickly preview the results of a simulation without 
having to render the scene. This offers many benefits, including being able 
to scrub back and forth in the time slider, and re-using a cache over again.

The cache file can become quite large, but can be compressed once a 
simulation is optimized.

" Manage cache files (for cloth)

" Use particle disk caching

" Use hair caches

" Create fluids cache files

" Caching fluids

camera

In Maya, the method for setting up the view of a scene, especially one that 
will be rendered. 

Like a real-world camera, the Maya camera frames the view of a scene by 
tracking, tumbling, panning, and zooming.

Unlike a real-world camera, the Maya camera does not automatically 
capture lighting, motion blur, and other effects. These effects must be 
explicitly created, turned on, and in some cases rendered.

" Create a camera

" Angle of view (focal length)

" View > Camera Tools

canvas

A 2D plane on which can be painted colors, patterns, or textures.

A canvas can be used as an independent piece of art, as a background 
image in a scene, or as a texture applied to a 3D surface.

" Set up the canvas

" Paint on the canvas

" Create seamless repeating textures
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chamfer
chamfer

In polygonal modeling, the removal of a vertex to create a chamfered (cut-
off) corner.

" Chamfer a vertex

" Edit Polygons > Chamfer Vertex

channel

1 In animation, an animatable attribute displayed in the Channel Box. 
See Channel Box.

" Channel Box

2 In rendering and imaging, a component of a pixel. Primary channels 
are typically primary colors, such as RGB, but may also be alpha or Z-
depth.

" Channels

" Color, Depth, and Mask (alpha) channels

Channel Box

An editing window where you can view and edit an object’s keyable 
attributes (such as transformations, keys, and expressions).

The Channel Box is the most streamlined tool for editing object attributes. 
To add or remove attributes, use the Channel Control.

See also Channel Control. In other software packages, known as parameter 
panel, coordinate manager, or transformation/rotation menu cells.

" The Channel Box

For more information, search the online help for Channel Box

Channel Control

A window that displays all of a node’s attributes, and lets you make them 
keyable or not keyable, and editable or not editable (that is, unlocked or 
locked). 

The Channel Control lets you add attributes to the items displayed in the 
Channel Box, which lists only keyable attributes.

See also Channel Box.

" Channel Control window

" Disable the editability of attributes without deleting them
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 character
character

In animation, a model that uses special attributes such as skeleton joints 
and IK for animation. These attributes are set up and animated together, 
making it possible to create the complex mechanics required by 
characters.

" Setting up the components of your scene for animation

character mapper

A window that lets you map animation from a source character to a target 
character. 

Use the Character Mapper to establish a relationship between a source 
and target character's nodes or attributes so that you can import and 
export or copy and paste animation clips between the mapped characters 
in the Trax Editor.

See also retargeting, source, target, Trax Editor.

" What is character mapping?

" Character > Character Mapper

character partition

In animation, a partition that by default includes all the character sets. 
Partitions prevent the sets in them from including any overlapping 
members that could cause problems.

" View and edit the character partition

character set 
In animation, a set that includes all of a character’s attributes.

" Character sets

" Create character sets

character setup

In animation, the process of preparing a 3D model with accompanying 
joints and skeletons for animation.

Also known as rigging.

" Setting up the components of your scene for animation

" Using skeletons

" Skinning your character
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child object
" Creating deformation effects

" Constraining objects

child object

An object whose attributes are controlled by its parent. A child can be the 
parent of other children.

Contrast with parent object.

" View and edit the hierarchy of nodes

" Control complex motion and forces

" Edit > Select All, Select Hierarchy, Invert Selection

chroma keying

In compositing, the process of defining a selected color or range of colors 
to be transparent. Usually chroma keying is done in blue (blue screening) or 
green (green screening). By making a blue or green background 
transparent, it can be replaced with other imagery later.

" Stencil

clip

1 In Maya’s nonlinear character animation editing, an animation 
segment that can be edited nonlinearly using the Trax Editor. See also 
nonlinear deformer, Trax Editor.

" Nonlinear animation tools in Maya

" Animate > Create Clip

2 In audio, a segment of sound. 

" How do I use the new Trax Editor?

3 In video editing, a continuous series of images that can be edited as a 
distinct segment.

clipping plane

An imaginary plane located at a specific point along a camera’s sight line. 

A camera has two clipping planes: near and far. Only those objects 
between these two clipping planes are visible in a camera’s view. 

" Clipping planes

" Create > Cameras > Camera
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 cloth

e 
cloth

Polygonal or NURBS shapes that can be tessellated and draped over other 
objects. These shapes are used in Maya Cloth to simulate real-world cloth.

See also cloth solver.

" Create a cloth object

For more information, search the online help for Cloth

cloth solver

An algorithm that provides the intelligence required to simulate th
movement of cloth.

" Use the cloth solver

" Adjust the cloth solver

cloud

In dynamics, a render type that displays particles as blurred or cloudy 
metaballs (spheres that blend together to form surfaces).

Clouds appear only in software rendered images.

" Choose how particles render

For more information, search the online help for cloud

clumping

In Maya Fur, the placement of fur into a series of compact masses (clumps). 

You can control clumping attributes such as the degree to which hairs are 
pulled in towards a clump’s center, the frequency of clumps, and the 
spacing of clumps.

" Make fur clump together

cluster deformer

In animation, deformers that let you control a set of points (CVs, vertices, 
or lattice points) with varying weights (degrees of influence). 

Also known as cluster.

" Cluster deformers

" Deform > Create Cluster
Glossary

49



CMYK
CMYK

Cyan/Magenta/Yellow/Black, the four ink colors used in 4-color process 
printing.

Contrast with RGB, HSV.

color bar

1 In Maya, an interface control for setting the color of an material, 
texture, fluid, or other quality.

2 In film post-production, an electronically generated set of colors used 
as a visual reference standard.

color curve

In lighting, a curve that represents one of the values that specify a color.

" Create custom spot light intensity or color decay

" Light decay

" Light Effects

color map

A texture map that modifies the color of a material.

See texture map.

" Texture mapping

combing

In Maya Fur, the act of painting the fur direction attribute. Combing 
changes the polar value of the fur to correspond to the direction you are 
painting with the brush.

" Change fur attributes

" Create body fur, whiskers, and eyelashes

common edge

An edge shared by polygons.

" Sculpt across seams and surface edges

common end point

An end point shared by polygons.
Glossary

50



 component
" Surfaces > Boundary

component

In general, a constituent part.

In polygonal modeling, any of the constituent parts of a polygon (namely, 
vertices, edges, faces, or UVs).

" Components

Component Editor

An editing window where you can edit data assigned to components. For 
example, the weights assigned to individual CVs by cluster deformers.

In other software packages, known as geometry spreedsheet or structure 
manager.

For more information, search the online help for component editor

component video

A video signal format commonly used in the broadcast industry because 
of its high quality. 

In component video, each color component (red, green, and blue) is 
carried over a separate video cable. The sync signal is carried on a fourth 
cable, or is included with the green signal (known as sync-on-green, not 
readable on many pieces of video equipment).

Contrast with composite video. See also decoder, encoder, NTSC, PAL.

composite video

The most common of video signal formats, where the color, intensity, and 
timing formation are combined into a single signal that can be carried 
over a single video cable. 

Because it combines video information into a single signal, composite 
video is lower in quality than component video. 

Contrast with component video. See also decoder, encoder, NTSC, PAL.

compositing 
The process of combining two or more images to form a new image. 
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compound attribute
In video, compositing is the process of combining two or more video 
events to form a new video sequence. Often an alpha channel is used to 
determine how the video is mixed. 

See also alpha channel.

" Render parts of a scene separately

compound attribute

An attribute consisting of one or more other attributes. For example, a 
scale attribute could be a compound attribute that consists of three 
attributes: Scale X, Scale Y, and Scale Z.

" Complex Attributes

" Dope Sheet outliner

comprehensive solver

In Maya Live, an IK solver algorithm that creates a solution for all frames 
after running one pass. 

Using technology developed by the MIT Media Lab and Alchemy3D, this 
algorithm builds an internal representation of the 3D scene, computes the 
scene’s fundamental 3D geometry, and applies a dynamic motion model 
to produce a smooth result.

" Overall solve workflow

" Run the  solver

concave polygon

A polygon with notches or concave areas along its perimeter (as opposed 
to convex polygon). A five-pointed star is an example of a concave polygon. 

To determine if a polygon is concave, apply the rubber band test. If an 
imaginary rubber band placed around the outside of a polygon would not 
touch all sides, then the polygon is concave.

Concave polygons must be triangulated (formed into various triangles) 
before they can be rendered.

" Smooth polygons

" Edit Polygons > Selection > Selection Constraints
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 Connection Editor
Connection Editor

In rendering, a window that provides node network information in a side-
by-side layout where you can view two connected nodes in a node 
network. 

This editor is useful for fine-tuning a shading network. Use it to make 
non-default connections, to traverse nodes to view their inputs or outputs, 
or to make connections going in either direction of the network.

In other software packages, known as parameter wiring.

See also shading network. 

" Render node connections

constrained object

In animation, an object whose attributes are restricted in some way by 
constraints.

" Constraining objects

" Introducing Constraints

constraint

In animation, a restriction of the position, orientation, or scale of an object.

See also: 

• aim constraint 

• geometry constraint

• normal constraint

• orient constraint

• point constraint

• pole vector constraint

• scale constraint

• tangent constraint

 

" Introducing Constraints

" Constraining objects
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construction history
construction history

In modeling, saved information about how an object was created. For 
example, the original curves or surfaces used to create a surface. By 
default, a surface with construction history is displayed in dark pink.

In other software packages, known as modeling relation.

For more information, search the online help for construction history

construction plane

In modeling, a plane used as an aid when creating objects not necessarily 
aligned to the XYZ orientation.

When you make a construction plane live, all new curves and objects are 
snapped to that plane.

" Construction planes

" Snap all creation tools to a surface or construction plane

" Create > Construction Plane

contour rendering

The creation of simple contour lines during non-photorealistic rendering, 
using standard shading and lighting workflow.

To control contour rendering, define the color and width of lines in the 
Shading Group and Render Globals windows. 

" Integrated contour rendering

control curve

In painting, curves that are associated with strokes. You can set stroke 
tubes to follow or be attracted to control curves, for example if you want 
to simulate lightning.

" Modify tube behavior using control curves

" Paint Effects > Curve Utilities > Set Stroke Control Curves

control point

A point that controls the shape of a deformable object. Examples of control 
points include NURBS control vertices (CVs), polygonal vertices, and 
lattice points.

An object must have control points to be deformable. 
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 control vertex (CV)
Also known as point, deformable object point. See also control vertex (CV), edit 
point, lattice deformer.

" Create a new level to increase available control points in a region

control vertex (CV)

In modeling, a point that controls the shape of a NURBS curve or surface. 
It is displayed as a small filled box.

See also control point. In other software packages, known as control point.

" Surface components: CVs, isoparms, and patches

" Curve components

" Draw curves

" Moving edit points vs. moving CVs

" Insert additional edit points/isoparms in a curve or surface to add more CVs

" Multi-knots and CV multiplicity

" Create > CV Curve Tool

coordinate system

A method by which points are located in space.

See UV coordinate system, XYZ coordinate system.

" Switch between Y-up and Z-up

" World space, object space, and local space

creation expression

In animation, an expression that executes at start time and doesn’t change 
during the animation.

See expression. Contrast with runtime expression.

" Write creation expressions

" Creation expression execution

culling

A method of improving shading display performance by not drawing 
unseen objects.

See backface culling (backculling), occlusion culling.
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current character set
current character set

In animation, the character you are working on. Set a character set as the 
current character set so that you can animate that character only.

" Set the current character Set

curve-on-surface

A type of curve that exists in the parameter space of a surface, typically 
used to trim the surface. Curves-on-surface can be drawn manually, but 
are usually created by intersecting surfaces or projecting lines onto 
surfaces.

" Curves-on-surface

CV

See control vertex (CV).

cylindrical projection

A process of applying an image onto an object, as if the image were rolled 
into a tube and projected inwards towards the object.

" Project UVs onto polygons from a cylinder or sphere

" Edit Polygons > Texture > Cylindrical Mapping, Spherical Mapping
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DAG
Glossary: D

DAG

Directed Acyclic Graph, a graphical representation of the ordered 
arrangement of objects, lights, cameras, and other items that make up a 
scene, viewable from the Hypergraph window.

The DAG is similar to the Outliner but has more features and visual aids 
for working with the hierarchy of scene components.

Also known as scene hierarchy. Contrast with dependency graph (DG), 
Outliner. See also hierarchy.

" DAG paths

" Dependency Graph (DG) nodes

For more information, search the online help for scene hierarchy

DAG object

See transform node.

damping

In dynamics, an opposing force against a rigid body’s movement. This 
attribute is similar to drag: it affects object movement before, during, and 
after contact with another object. A positive value diminishes movement; 
a negative value increases movement.

" Edit spring operation

" Soft/Rigid Bodies > Create Constraint

decoder

In video and film post production, a device that produces component 
video from composite video. 

Contrast with encoder. 

deformable object

In animation, any object you can deform (for example, with deformers or 
by skinning). A deformable object’s shape is defined by control points (or 
deformable object points).

See also control point.

" Deformable objects and skin objects
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 deformation
" Set the display of deformation objects

deformation

In animation, a change in the shape of an object.

" Creating deformation effects

" Deformers overview

deformation chain 
In animation, the node connections involved in specifying an object’s 
deformation order.

Maya evaluates an object starting from the make node and working all the 
way through in order to the final (deformed) shape node. The node 
connections involved in this process are said to provide a deformation 
chain.

See also node.

" Nodes, history, and the deformation order

" Advanced deformer options

deformation order

In animation, the specification of where a deformer fits in a deformable 
object’s history.

Choose from Default, Before, After, Split, Parallel, and (for the blend 
shape deformer only), Front Of Chain. 

" Nodes, history, and the deformation order

" Advanced deformer options

For more information, search the online help for deformation order

deformer

In animation, a tool that changes the shape of deformable objects.

In other software packages, known as modifier or space warp.

" Creating deformation effects

" Deformers overview
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deformer set
deformer set

In animation, the set of control points (deformable object points) that a 
deformer can affect.

See also control point.

" Editing deformer set membership

dependency graph (DG)

A graphical representation of the relationships between connected nodes, 
viewable from the Hypergraph window. For any particular node, the 
dependency graph shows the node’s history, including all connected 
nodes and their connected nodes.

For example, a dependency graph could show connections between 
shading group elements that create an object’s material appearance.

Unlike the DAG, these relationships can be cyclic, and do not represent a 
parenting relationship. Instead, the connections in the graph allow data to 
move from one entity in the graph to another. The entities in the graph 
which accept and output data are called dependency graph nodes.

Contrast with DAG. See also Hypergraph.

" Dependency Graph (DG) nodes

" Nodes, history, and the deformation order

depth channel

The distance of objects from the camera.

Also known as Z depth channel or Z buffer channel.

" Mask and depth channels

" Enable color, depth, and mask channels for rendered images

depth constraint

In Maya Live, the distance from a given point to the camera lens for a 
given frame. 

Depth constraints are useful for solving tripod shots with camera rotation, 
when the solver cannot determine depth of points without this additional 
information.

" Choose survey constraints
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 depth map
depth map

In rendering, an image file that represents the distance from a specific 
light source to the surfaces that the light source illuminates, from the point 
of view of the light source. Each pixel in the depth map represents the 
distance from the light to the nearest shadow-casting surface in a specific 
direction. 

Depth mapping is one way to produce shadows. Contrast with raytracing. 
See also shadow.

" Depth map and raytraced shadows

" Render depth map shadows

depth of field 
In photography, the range of distances within which objects will be 
sharply focused. (Objects outside of this range appear blurred or out of 
focus.)

In Maya, all objects are sharply focused by default, no matter how near or 
far they are from the camera. However, Maya does selectively focus on 
objects to simulate depth of field.

" Adjust depth of field

" Focus and blur

digital disk recorder

In post-production video, a real-time recording device that stores images 
electronically on a disk in a digital format rather than on video tape. 

These devices are commonly used with computer graphics because they 
are much faster than videotape recorders, and provide high-quality 
recording capabilities.

directional light

In rendering, a light that shines evenly in one direction only. Its light rays 
are parallel to each other, as if emitted perpendicular to an infinitely large 
plane. Use a directional light to simulate a very distant point light source 
(for example, the sun).

In other software packages, known as infinite light.

" Directional Lights

" Directional Light Attributes

" Create > Lights > Directional Light
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directional point emitter

ce 
directional point emitter

In dynamics, a particle emitter that emits particles only in a specified 
direction. See emitter.

" Connect to selected fields or emitters of an object

" Vary emission from different points of point emitters

displacement map

In rendering, the simulation of 3-dimensional surface detail effects by 
altering the surface of the geometry. Displacement occurs along the 
surface normals according to the intensity of the pixels in the texture map.

A displacement map is useful if objects will be viewed in silhouette, but 
takes longer to render than a bump map due to the complex surface detail 
being created.

Contrast with bump map.

" Displacement maps

" Mountain

" Bulge

" Convert wave displacement to polygons

displacement material

In rendering, a description of what an object looks like when it is rendered 
with a displacement map. 

The displacement material lets you use an image to specify surfa
relief on objects in your scene.

See also displacement map, material.

" Displacement

" Surface, displacement, volumetric materials

distance constraint

In Maya Live, the scaling of a solution to fit a given distance between two 
points, used mainly to set an appropriate scale when locators are too 
condensed or too spread out. 

" Creating a Distance constraint
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 dolly
dolly

The action of moving the camera toward or away from its center of 
interest.

 The scene in the camera’s view becomes larger or smaller, and the relative 
size of objects in the scene changes based on their distance from the 
camera.

" View > Camera Tools > Dolly Tool

dongle

A piece of hardware that attaches to a computer that provides a method of 
licensing Maya. 

The advantage of the dongle is it allows you to easily move your license 
from one computer to another. The disadvantage of a dongle is that it is 
only available on the Windows platform and only works on a parallel 
port. Also, if you lose a dongle, you have lost your Maya software and 
must purchase another copy of Maya to get it replaced.

Also known as hardware lock.

" Licensing: Hardware lock devices

dope sheet

In animation, a window that lets you edit event and sound 
synchronization and timing. 

In other software packages, known as channel editor or track view (edit keys 
mode).

" Display the Graph Editor and Dope Sheet

" Dope Sheet menu bar 

" Dope Sheet toolbar 

" Dope Sheet outliner 

" Dope Sheet view area 

double transformation effect

In animation, a situation where skin object points are subjected to the 
action of a joint more than once, resulting in extreme, undesirable shape 
changes. 

" Double transformation effects
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dress-up pose
dress-up pose

In Maya Cloth, the positioning of a character to eliminate any self-collision 
of the garment worn by the character, and minimize wrinkling in the 
initial fitting of the garment.

Contrast with start pose.

" Pose the character

" About cloth animation

driven key

In animation, a keyframe where one attribute value is related to the value 
of another attribute. See also set driven key.

" Driven keys

" Set a driven key relationship

dropouts

In film post-production, the missing bits of picture or sound information, 
usually caused by flaws in the medium being used (for example, 
videotape).

DWG

The native file format of AutoCAD and Mechanical Desktop.

" DWG/DXF file translator

DXF

Data eXchange File, a file format used to transfer 2D and 3D information 
between various graphic and CAD programs.

" DWG/DXF file translator

dynamic attribute

An attribute having predefined names and purposes. You must explicitly 
add a dynamic attribute to an object.  

You can set per object and per particle opacity and color of a particle 
object. 

" Adding dynamic attributes

" Work with particle attributes
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 dynamics
" Complex Attributes

dynamics

A branch of physics that describes how objects move using physical rules 
to simulate the natural forces that act upon them. 

Dynamic simulations are difficult to achieve with traditional keyframe 
animation techniques, but Maya lets you set up the conditions and 
constraints that you want to occur, and then automatically solves how to 
animate the objects in the scene.

" Animating with dynamics
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 EBU time code
Glossary: E

EBU time code

European Broadcast Union time code, a method of denoting hours, 
minutes, seconds, and frames on videotape. This code lets you access 
individual frames on videotape. EBU time code is used with PAL and 
SECAM video.

edge

In modeling, a side or edge of a polygonal model, represented by a 
straight line between the two ordered vertices that define it.

" Merge edges

" Smoothing edges

" Bevel edges

" Align surface edges

" Split an edge into segments

" Extrude a vertex, edges, or faces

edit point

In modeling, a point that lies on a curve or surface (spline) where 
polynomials are joined. An edit point is displayed as a small letter x. You 
can add edit points to an existing curve without affecting its shape. 
However, when you add edit points to a curve, you create more spans on 
the associated surface.

See also spline. 

In other software packages, known as knot.

" Curve components

" Draw curves

" Moving edit points vs. moving CVs

" Insert additional edit points/isoparms in a curve or surface to add more CVs

" Multi-knots and CV multiplicity

" Create > EP Curve Tool

effects

In dynamics, built-in programs that make it easy to create complex 
animation effects such as smoke and fire.
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elevation
" Create Fire 

" Create Smoke 

" Create fireworks 

" Create lightning 

" Create shatter 

" Connect shards to fields 

" Create curve flow 

" Create a surface flow 

" Surface Flow procedures 

elevation

The angle of a camera’s sight line relative to the ground plane.

" View > Camera Tools > Azimuth Elevation Tool

" Use the mouse to control camera azimuth, elevation, yaw or pitch

ELF

Extension Layer Framework. ELF commands are commands added to 
MEL that create custom interface elements.

" ELF commands

emitter

In dynamics, an object that generates moving or stationary particles while 
an animation plays. Emitters are useful for producing smoke, fire, 
fireworks, rain, and similar effects. 

You can create a standalone emitter, or you can use a surface, curve, 
volume or even another particle as an emitter.

" Emitters

encoder

In post-production, a device that converts component video signals into a 
single composite signal. An encoder typically produces composite video 
from RGB output.

Contrast with decoder. See also component video, composite video.
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 end effector
end effector

In IK animation, an additional node that is created automatically when an 
IK handle is created. The IK handle is connected to the end effector. As 
you pose the IK handle, the end effector drives the IK chain. By default the 
end effector is located at the last joint of an IK chain, but it can be moved 
to make the IK handle appear to be at a different point in the skeletal 
hierarchy.

An example is an arm with joints created at the shoulder, elbow, forearm 
and wrist. The IK chain goes from shoulder to forearm. Moving the end 
effector to the wrist puts the IK handle in a more intuitive location for the 
animator.

See also IK chain, IK handle.

" IK handles

end joint 
In IK animation, the last joint in the joint chain controlled by an IK handle. 
The end joint is located below the start joint in the skeleton’s action 
hierarchy. See also IK handle.

" IK handles

environment fog

In rendering, the simulation of atmospheric particles in a scene.

See also atmosphere.  Contrast with light fog (illuminated fog). 

In other software packages, known as depth fading or atmosphere.

" Simulate fog, smoke, or dust

For more information, search the online help for environment fog

environment map

In rendering, the simulation of reflections of an environment onto objects. 

Contrast with projection map. In other software packages, known as 
reflection map.

environment variable

A configuration variable that controls some aspect of Maya.
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equalizer map
Many of the variables are included in the Maya program and are set 
automatically when you start Maya. To configure Maya further, you can 
set additional environment variables.

" Setting environment variables using Maya.env

" Setting environment variables using system commands on Windows and 
IRIX and Linux

equalizer map

In Maya Fur, the simulation of evenly distributed fur across a surface.

An equalizer map compensates for the uneven distribution of fur caused 
by uneven parameterization.

" Build equalizer maps separately

" Invoke Advanced Fur Rendering from the Script Editor or MEL prompt

ethernet address

The physical address of an Ethernet network board, expressed as a 48-bit 
number in hexadecimal notation. If you are using a SPAR form for 
licensing, you will need to send Alias an encrypted form of your ethernet 
address (known as a hardware ID) to license Maya.

On a Windows computer, the Ethernet address is also known as a MAC 
(Media Access Control) address. 

" Understanding licenses

Euler angle

A method of specifying the angle of rotation about one of the standard 
axes: X, Y or Z. See also Euler rotation.

" Graph Editor

Euler rotation

In animation, a method of rotation that uses three angle values (X, Y and 
Z) plus a rotation order to specify three-dimensional orientation. 

Euler rotation has several drawbacks, including gimbal lock and choppy 
interpolation between keyframes.

Contrast with quaternion rotation. See also gimbal lock, rotate order.

" Set rotation interpolation for curves
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 expression
expression

In animation, an instruction that controls keyable attributes over time. 
Expressions can be comprised of mathematical equations, conditional 
statements, or MEL commands.

See also creation expression, runtime expression.

" Editing expressions

" Creating expressions to control a single attribute

extrude

1 In modeling, the process of creating a 3D surface or shape by 
sweeping a cross-section or profile along a curve. In other software 
packages, known as loft.

" Surfaces > Extrude

" Sweep a profile curve along a path curve

2 In polygonal modeling, the process of extending a vertex, edge, or 
face, thereby creating additional faces off of surrounding faces.

" Extrude a vertex, edges, or faces

" Edit Polygons > Extrude Vertex
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face
Glossary: F

face

In polygonal modeling, the closed space formed when three or more 
vertices are linked by edges.

A polygonal object is a set of connected faces. When these faces form a 
closed volume, the object becomes a solid model, which can be edited and 
textured on a per-face basis. 

By default, a face is shown as a solid unit with a dot in the center.

" Disconnect faces from their shared edges (extract) 

" Split a face into multiple faces 

" Split faces into triangles or quadrangles 

" Split a face and move the new center vertex (poke) 

" Subdivide faces by painting 

" Change polygon tool settings

falloff radius

The radius at which a deformation falls off to zero.

" Soft Modification

Fcheck

A rendering utility that lets you examine batch-rendered images at a 
speed that approximates video or film.

In other software packages, equivalents are mplay, RAM player, showpic, 
imgshow.

" Overview of FCheck features

" FCheck windows

FFD (free-form deformation)

A spatial deformation algorithm that takes objects located within the base 
(undeformed) lattice and maps them into the space of the deformed lattice 
shape. 

See free-form geometry.
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 field
field

1 In dynamics, a force used to animate the motion of particles, soft 
bodies, and rigid bodies. In other software packages, known as force.

" Fields

2 In film and video post-production, half of a video frame. Frames are 
divided into fields to store alternating scanlines, odd vs. even. Rates of 
sampling and storage methods vary with video standards (NTSC vs. 
PAL, for example). See video field.

" Frames vs. Fields

" Specify frame or field rendering

" Deinterlacing video shots

field rendering

In rendering, a technique used to improve the frame-to-frame continuity 
in a rendered animation. 

Field rendering combines interleaved portions of two consecutive 
rendered images to create a single image, which is then recorded onto 
video. Sequences of field rendered images yield better continuity of 
motion between frames.

" Specify frame or field rendering

" Frames vs. Fields

file texture

A bitmap image that can be mapped to shading attributes.

Contrast with procedural texture.

" File textures

" Convert a texture or shading network to a File Texture

" Edit > Convert to File Texture

fillet blend

In modeling, a seamless blend between two boundaries that is made up of 
sets of surface curves. For example, a fillet blend can be used to create a 
smooth surface between a creature's arm and torso.

" Create a fillet curve between two existing curves

" Create a surface between two sets of boundary curves

" Edit NURBS > Surface Fillet > Fillet Blend Tool
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final gather
final gather

A rendering option that yields extremely realistic shading effects. It can be 
used in conjunction with Global Illumination to create optimal lighting 
and shading effects. 

With Final Gather, rays are first cast from the light (rather than from the 
camera, as with simple ray tracing). When a ray strikes an object, a series 
of secondary rays are diverted at random angles to calculate the light 
energy contribution from surrounding objects, which is then evaluated 
during the ray tracing process to add the effect of the bounced light. This 
basically turns every object into a light source so each object in a scene 
influences the color of its surroundings as in the  real world. 

" Final Gather 

" Render with final gather

FK (forward kinematics)

In animation, a method for posing a joint chain by rotating each joint 
individually. 

FK is the easiest way to animate joint chains with detailed arc motions. 

See kinematics. Contrast with IK (inverse kinematics).

" Forward and Inverse Kinematics 
" IK/FK blending

FK posing 
In animation, a direct movement and rotation of joints, without the use of 
IK handles.

" IK/FK blending

" Pose joints with FK

flag

A variable you can use to keep track of a condition in your application. 

In Maya, you need to define both short flags and long flags. Short flags are 
three letters or less; long flags are four letters or more. 

" Flags

flare deformer

In animation, a deformer that flares or tapers an object about two axes.
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 flat shading
" Editing flare deformation effects

" Flare Nonlinear deformer

" Deform > Create Nonlinear > Flare

flat shading

In rendering, a geometry object display technique that shades surfaces 
very quickly. 

" Change the look and smoothness of the selected objects

flexor

In animation, a special deformer designed to improve and enhance the 
effects of rigid skinning. 

Types of flexors include bone lattice flexor, bone sculpt flexor, joint cluster 
flexor, joint lattice flexor, and joint sculpt flexor.

In other software packages, known as deformation parameter.

" Flexors

" Create all types of flexors

" Skin > Edit Rigid Skin > Create Flexor

floating license

A type of multiple software license that is served from one license server 
machine to other machines over a network. See the Installation and 
Licensing Guide for details.

" Types of licenses

" Additional setup for floating licenses

fluid effects

In dynamics, the simulation of realistic fluid motion, such as water, clouds 
or fog. 

For example, you can texture dynamic fluids, have them collide with and 
move geometry, or interact with particles. 

" Fluid Effects Overview

" Create dynamic fluid effects

" Create non-dynamic fluid effects
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focal length

 

focal length

In photography, the distance from the camera lens to the film plane that 
determines the angle of view.

In Maya, a focal length constraint is useful for controlling the angle of 
view in a scene. 

" Angle of view (focal length)

" View > Camera Tools > Zoom Tool

" Create a focal length constraint

fractal

A three-dimensional random function with a particular frequency 
distribution (a fractal).

Fractal textures are useful for simulating many natural phenomena, such 
as rock surfaces, clouds, or flames.

" Solid Fractal

For more information, search the online help for Fractal

frame

1 In animation, the basic unit of time measurement. The duration of an 
animation is changed by increasing or decreasing its frame range. 
Typically, 30 frames of animation correspond to one second on NTSC 
video tape (25 frames for PAL video tape, and 24 frames for film).

" Frames vs. Fields

" Batch rendering a sequence of animation frames

2 In film and video post-production, a standard unit of film or video 
information consisting of a single complete image. 

" Frames vs. Fields

3 The act of composing an image or scene by specifying the outer 
border.

" Frame all objects

" Frame selected objects

" Render > Render Current Frame

4 In MEL animation expressions, an internal variable that returns the 
current frame position along the timeline. This variable can be used in the
Attribute Editor to go to the current frame.

" time and frame keywords
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 frame range
" Differences between expression and MEL syntax

" Change attribute values in the Attribute Editor or Channel Box

frame range

In animation, a set of contiguous frames.

" Frames vs. Fields

" Batch rendering a sequence of animation frames

free-form geometry

In modeling, geometry that is formed from user-created (free-form) curves 
and surfaces, rather than from the exact conics of parabolic curves, circles, 
or ellipses.

For example, the lattice deformer creates free-form geometry.

" Edit NURBS > Surface Fillet > Freeform Fillet 

" Create > CV Curve Tool

" Lattices

For more information, search the online help for Free-Form Surfaces

Fresnel reflection

In rendering, reflection created from light striking a diffuse surface at a 
glancing angle. 

Fresnel reflection is used by the raytracing method.

" Ramp Shader (Specular Roll Off attributes)

" Anisotropic

frustrum

A volume of space that includes everything that is currently visible from a 
given camera viewpoint. A frustrum is defined by six planes arranged in 
the shape of a pyramid with the top chopped off. If a point is inside this 
volume then it's in the frustum and it's potentially visible (if not obscured 
by another object). If a point is outside of this volume then it is outside the 
frustum. 

" View > Camera Settings
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fur
fur

In Maya Fur, the simulation of realistic, self-shadowing fur and short hair. 
Fur characteristics are defined by a fur description. 

See also fur description, fur feedback, fur file, fur globals, fur normal, fur shading 
effects.

" Create fur

For more information, search the online help for fur

fur description

In Maya Fur, the definition of all attributes for a particular type of fur (for 
example, fur color, width, length, baldness, opacity, scraggle, curl, 
density, and so on). 

You can attach a fur description to any single or multi-surface NURBS or 
polygonal model. You can then style the fur (for example, shorten or 
lengthen the fur on some parts of the model) using attribute value maps, 
or by painting fur attribute values directly on the model using Maya 
Artisan.

" Create fur

" Select the surfaces a fur description is attached to

" Copy fur descriptions into other scenes

" Fur > Edit Fur Description

fur feedback 
In Maya Fur, a visual approximation of the fur description, shown on 
your model while you work. 

When you attach a fur description to a surface, fur feedback appears 
automatically on the surface. If a surface has more than one fur 
description attached to it, you can select which fur feedback displays, or 
choose to display no fur feedback at all.

" Preview fur using fur feedback

fur file

In Maya Fur, a file that defines all aspects of fur. This file is required to 
build equalizer maps, shadow maps, and fur images.

" Advanced Fur Rendering

" Fur > Advanced Fur Rendering 
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 fur globals
fur globals

In Maya Fur, default settings that determine fur render options.

" Set up Fur Render Globals before rendering

fur normal

In Maya Fur, a direction normal to the surface of an object. By default, 
each hair making up the fur points towards the fur normals.

If the fur appears too short, the fur normals may need to be reversed so 
that the fur points outwards. (You can reverse the fur normals without 
changing the surface normals.)

" Reverse fur normals

" Fur > Reverse Fur Normals

fur shading effects 
In Maya Fur, shadow and shading effects that make the fur or hair look 
more realistic, created with fur light attributes. 

" Adding fur shading effects

" Fur > Fur Shadowing Attributes
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gamma
Glossary: G

gamma

In film and video production, a number indicating the degree of 
brightness of an image. 

See also gamma correction.

" Gamma Correct

" Adjust color values

" Image adjustment keys

gamma correction

In film and video production, a method of adjusting pixel values so they 
can be represented properly on an output device. Gamma correction lets 
you compensate for lack of contrast in a video display.

See also gamma.

" Gamma Correct

" Adjust color values

" Image adjustment keys

garment

In Maya Cloth, a collection of seamed panels. A garment is represented by 
a poly mesh that is the cloth object.

" About cloth animation

" Creating a garment

" Cloth > Create Garment

geometry 

In general, a NURBS surface, NURBS curve, subdivision surface, or 
polygonal surface (mesh).

" Appendix A: NURBS Geometry

" Geometry constraints

" 2-manifold, non-manifold, and invalid polygonal geometry

Links on converting geometry from one type to another:

" Prepare polygons for conversion to a subdivision surface
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 geometry constraint
" Prepare a NURBS surface for conversion to a subdivision surface

" Convert a NURBS or polygonal surface to a subdivision surface

" Convert a subdivision surface to polygons

" Convert a subdivision surface to NURBS

geometry constraint

In animation, a constraint that restricts an object to a NURBS surface, 
NURBS curve, subdivision surface or polygonal surface (mesh). 

To orient the constrained object relative to the surface of the target objects, 
use a normal constraint as well.

See also constraint, normal constraint.

" Geometry constraints

ghosting

The simulation of a technique in classical animation where an animator 
rapidly flips through a handful of cell drawings to get a feel for the timing 
of the action he is working on. 

Ghosting is useful to sketch out and visualize the flow of a character's 
motion through an animation, and to solve problems with the timing of 
that motion. 

In other software packages, this term may refer to template.

" Previewing animation

" Ghost an object

" Animate > Ghost Selected

gimbal lock

In animation, a situation where one rotational axis is placed over another, 
causing the two axes to lead to the same result when animated. 

To avoid gimbal lock, either quaternion rotation must be used instead of  
Euler rotation, or a node must be provided for each rotational axis.

" Graph Editor

global space

See world space.
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glow object
glow object

In rendering, the simulation of a bright, fuzzy disk at the location of a 
light source.

You can also control how the glow from one surface affects the intensity of 
another's surface glow, or create illuminated fog for a particular light.

In other software packages, known as lens flare shader.

See also optical FX node. 

" Glows, halos, and lens flares

" Adjust the size of the glow object

gnomon

Axial-shaped icons typically provided by Maya for moving the end of 
joints and other objects.

goal

In dynamics, an object that particles follow or move towards.

Goals are useful to give trailing particles a flowing motion that’s hard to 
generate with other animation techniques.

" Goals

" Multiple goals

" Nonparticle goals

Graph Editor

A window for editing animation curves.

See also dope sheet. In other software packages, known as track view 
(function curves mode),  f-curve view or channel editor (graphics mode).

" Using the Graph Editor

" Display the Graph Editor and Dope Sheet

For more information, search the online help for Graph Editor

grid 

A 2D plane that shows scalar dimensions. 

Grids are useful for building models, or for animating motion relative to a 
solid surface.
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 grouping
" Show, hide, or change the grid

grouping

The assignment of two or more objects together, so that they can be 
moved, scaled, or rotated as one unit.

" Grouping objects

" Edit > Group
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hair
Glossary: H

hair

In Maya, a set of dynamic curves that simulate hairstyles and hair 
behavior, as well as other effects such as ropes, chains, suspension 
bridges, sea creatures, or lofted surface behavior. 

A hair system is a collection of hair follicles, each of which hosts a hair 
curve and includes various attributes for modifying the appearance and 
style of the hair, including a braid attribute. The hair system output can be 
in the form of NURBS curves, Paint Effects strokes, or both. 

" Hair overview

" Creating Hair

halo

In rendering, the simulation of a bright ring surrounding a light source. 
See also optical FX node.

" Glows, halos, and lens flares

" Optical FX Attributes

handle

In general, an icon displayed in the workspace that you can use to 
manipulate objects. 

See also IK handle.

handle vector

In animation, the line drawn from the start joint to the IK handle’s end 
effector. 

See also end effector, IK handle.

" IK handles

handle wire

In animation, the line that runs through all the joints and bones in a joint 
chain controlled by the IK handle. See also IK handle.

" IK handles
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hardware ID

An encrypted form of your ethernet address. 

This number is accessible from the Online Product Activation (OPA) 
wizard, or from the FlexLM licensing tools. See the Installation and 
Licensing Guide for details.

See also ethernet address.

" Understanding licenses

" Obtaining a license

hardware render

An interactive rendering method that uses the capabilities of a computer’s 
graphics card to create lighting and texturing effects.

Contrast with software render, batch render.

" Maya Hardware renderer

" Hardware, software, and vector rendering

" Use the hardware render buffer

HDTV 
High-Definition Television. A television format that has 1,125 scan lines, 
over twice the resolution of standard television.

" Set up filmback and aspect ratios

hidden-line

A display (and rendering) technique for displaying only those lines visible 
from the current perspective view. 

" Maya Vector renderer

hierarchy

1 In general, the arrangement of parent-child relationships for all 
connected nodes that make up an object (also known as object 
hierarchy) or a scene (also known as DAG or scene hierarchy).

" Scene hierarchy

" Select objects based on hierarchy 

" View and edit the hierarchy of nodes
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highlight
2 In animation, a hierarchy of joint chains. Also known as skeleton 
hierarchy.

" Skeleton hierarchy

3 In subdivision modeling, the number of levels in a subdivision 
surface. In other software packages, known as mesh smooth.

" Subdivision surfaces

" Subdiv Surfaces > Collapse Hierarchy

highlight

The color of a rendered surface where it directly reflects a light source.

See surface highlights.

high-quality interactive shading

A high quality display of your work as you build, shade, texture, and light 
your scenes in the scene view. This type of interactive shading lets you see 
a very good representation of the look of the final render, before you 
software-render the scene.

High quality shading uses the same technology that enables hardware 
rendering.

" High quality interactive shading

hinge joint 
In animation, a joint that can rotate only about one of its local axes. A 
human knee is a good example of a hinge joint.

See also hinge rigid body constraint.

" Joints and bones

hinge rigid body constraint 
In dynamics, a constraint keeping rigid bodies along a specified axis by a 
hinge. Use hinge constraints to create effects such as a door on a hinge, a 
link connecting train cars, or the pendulum of a clock. 

See also constraint.

" Create a Hinge constraint

" Rigid body constraints
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 hotbox
hotbox

A method for accessing menu items and tools at the cursor position, 
accessible by pressing and holding down the Space bar on the keyboard. 
The tools that appear in the hotbox can be customized to streamline your 
workflow.

In other software packages, known as viewport option, display option, or 
quad box.

" Choose actions from the hotbox

" Customize the hotbox

" Hotbox Controls > Hotbox Style

hotkey

One keyboard key, or combination of keys, providing quick access to a 
tool.

You can customize hotkeys from a Hotkey Editor, or from MEL custom 
commands.

" Hotkeys

" View a list of all assigned hotkeys

" Hotkey editor

" Assign a predefined command to a hotkey

HSL

Hue, Saturation and Lightness. A color model that determines the shading 
and lightness of a color.

Hue corresponds to the pure color; saturation to the amount of white 
mixed with the hue; and light to the brightness of the hue.

Contrast with HSV.

HSV 
Hue, Saturation, and Value. A color model that determines the shading 
and tint of a color.

Hue corresponds to the pure color; saturation to the amount of white 
mixed with the hue; and value to the amount of black mixed with the hue.

" RGB to HSV (utility)

" HSV to RGB (utility)
" Color editor
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hull
hull

In modeling, a line that connects CVs. In other software packages, known 
as control line.

" Curve components

" Draw curves

Hypergraph

A window that shows the graphical relationship between nodes and their 
connections in a scene. The Hypergraph shows either a DAG or a 
dependency graph.

See also DAG, dependency graph (DG). 

In other software packages, known as delete modifiers,  schematic view, tree 
view, or object manager.

" The Hypergraph

For more information, search the online help for hypergraph

Hypershade

A window where you can create, edit, and connect rendering nodes, such 
as textures, materials, lights, rendering utilities, and special effects.

Hypershade displays each node as an icon (or swatch) representing the 
characteristics of the node. When you edit node attributes or assign 
textures or special effects, the swatch updates to visually reflect these 
changes.

To open the Hypershade window, use Window > Rendering Editors > 
Hypershade.

In other software packages, known as material editor, VOP editor (shading 
context), or surface editor.

" Open and navigate Hypershade

For more information, search the online help for Hypershade
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 IFF
Glossary: I

IFF

Image File Format, a generic structured file access mechanism used by 
Maya to output bitmap images, viewed using Fcheck.

" File formats

" Set the rendered image file format

" Generate IFF files with Maya

IGES™

Initial Graphics Exchange Specification. A file format for transferring 
graphics data between CAD/CAM systems.

" IGES Translator plug-in

" New IGES import/export options

IK (inverse kinematics)

In animation, a method of posing a joint chain by specifying the location 
in space you want the joint chain to reach. 

IK is the easiest way to position the end of a joint chain on a particular 
object or point in space, because you don’t have to define how each joint 
needs to rotate. 

IK requires IK handles and IK solvers, special tools for posing and 
animating. 

See also IK chain, IK handle, IK posing, IK solver, IK spline curve, IK system, 
kinematics.

Contrast with FK (forward kinematics). 

" Using skeletons

" Posing skeletons

" Forward and Inverse Kinematics

" Pose joints with spline IK curves

" IK solvers

IK chain 
In animation, a joint chain that has an IK handle.

See IK (inverse kinematics).
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IK handle
" IK handles

" Prevent flipping in the spline IK chain

IK handle

In animation, a tool for posing joint chains.

An IK handle resembles a wire running through a joint chain, and enables 
you to pose the entire joint chain in one action. As you pose and animate 
the joint chain, its IK handle automatically figures out how to rotate all the 
joints in the joint chain using an IK solver.

Types of IK handles include the IK rotate plane handle, IK single chain 
handle, IK two bone handle, and IK spline handle.

See IK (inverse kinematics).

" IK handles

" Skeleton > IK Handle Tool

IK posing 
In animation, the use of IK handles to pose joint chains. The effect of each 
IK handle on its joint chain depends on the type of IK solver being used.

See IK (inverse kinematics).

" Setting up joints for posing and animation

" Posing skeletons

" IK solvers

IK solver

In animation, an algorithm that provides the motor intelligence required 
by IK handles. 

For example, IK solvers figure out how to rotate all the joints in a joint 
chain that is controlled by an IK handle.

IK solvers available from the Maya interface include the IK single chain 
solver, the IK rotate plane (RP) solver, and the spline IK solver 

Additionally, the IK multi-chain (MC) solver and the IK Power Animator 
(PA) solver are available through MEL commands only.

See IK (inverse kinematics).

" IK solvers

" Animate > IK/FK Keys > Enable IK Solver
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 IK spline curve
IK spline curve

In animation, a NURBS curve used to control an IK spline handle.

See IK (inverse kinematics).

" Pose joints with spline IK curves

IK system

In animation, a system for organizing Maya’s default IK solvers. 

The IK system controls whether all the IK handles using IK solvers in the 
system snap to their end effectors, whether the IK solvers are active, and 
the order in which Maya evaluates the solvers.

See  IK (inverse kinematics).

" Planning an animation for an IK system

" IK solver nodes

image-based lighting (IBL)

The simulation of light emitted from an infinitely distant (environment) 
sphere to create photo-realistic images. 

With image-based lighting, an environment texture (an image file, 
typically a photograph of a real environment.) is needed to illuminate the 
scene and provide the necessary environment reflections. 

" Rendering Image-Based Lighting (sky-like illumination)

image plane

A 2D object (plane) that enables the placement of an image file into a 
view. Image planes are used extensively to create backgrounds and 
environments (for reflections). 

In other software packages, known as rotoscoping view mode.

" Create, edit, or position an image plane

" View > Image plane 

For more information, search the online help for Image plane

IMF

IMage File, a component used by Maya to handle the reading and writing of 
various image file formats. IMF is a proprietary component of Alias and is 
used on the Windows, LINUX and IRIX versions of Maya. 
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impulse
On the Macintosh platform, an equivalent to IMF is QuickTime.

" Maya lists new IMF plug-ins

impulse

In dynamics, an instantaneous force, with magnitude and direction, 
applied to a rigid body at the local space position. The higher the impulse 
value, the greater the magnitude of force.

" Control complex motion and forces

" Soft/Rigid Bodies > Create Active Rigid Body

industrial quality

In film and video post-production, a video signal that is not of sufficient 
quality to be used by the broadcast industry. Contrast with broadcast 
quality.

" Hardware, software, and vector rendering

influence object

In character animation, an object that influences the shape of smooth skin. 
For example, an influence object would be required to simulate a bicep or 
elbow.

In other software packages, known as envelope assignment.

" Using smooth skin influence objects

" Add an influence object

" Skin > Edit Smooth Skin > Add Influence

in-point

In film and video production, the beginning of a video edit, indicated by 
an eight-digit time code.

input connection

A node that provides input to the selected node. 

Also known as upstream connection. See also node.

" Shading networks

" Show node connections

" Graph > Input Connections
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 input node
input node

A node with connection feeding into a selected node. Input nodes must be 
evaluated by Maya before the selected node itself is evaluated.

If caching is on, Maya can use the information stored in the cache rather 
than re-evaluating the input nodes each time.

Also known as upstream node. See also input connection.

" Show node connections

" Connect render nodes using the Connection Editor

instance

The same object, displayed multiple times. Changing the shape of this 
object changes the shape of all of its instances.

Instancing an object saves system memory, and is useful to display an 
object multiple times while maintaining its exact properties. 

" Copies vs. instances

" Instance geometry to particles (single and animated) 

invisible node

The node of any hidden object. 

The default cameras top, front, side, and persp are invisible nodes, along 
with any nodes explicitly hidden using Display > Hide.

" Display > Hide, Show

invisible object

Any object hidden using Display > Hide.

" Display > Hide, Show

IPR

Interactive Photorealistic Rendering, a type of software rendering that 
allows you to adjust shading and lighting attributes and then update part 
of the rendered image to see the effect of your changes.

" Interactive Photorealistic Rendering (IPR)
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isoparm
isoparm

In modeling, a line of constant U or V value on a surface or at an edit 
point. 

Short form for isoparametric curve.

" Surface components: CVs, isoparms, and patches

" Edit NURBS > Insert Isoparms
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jaggies
Glossary: J

jaggies

Jagged perturbations on lines or surfaces caused by aliasing.

See also aliasing, anti-aliasing.

" Troubleshoot:Jagged edges

" Anti-aliasing and flicker

" Troubleshoot:Troubleshooting Surfaces (Maya software)

" Effects > Create Shatter

jiggle deformer

A deformer that causes points on a surface or curve to shake as they 
move, speed up, or slow down. Jiggle deformers help you create effects 
such as a wrestler's stomach shaking, hair jiggling, or an insect's antennae 
vibrating.

You can apply jiggle to entire objects or to specific points (CVs, lattice 
points, or the vertices of polygonal or subdivision surfaces). 

See deformer.

" Jiggle deformers

joint

In animation, a place where two or more bones are attached together. 
Joints are the building blocks of skeletons. The action of a bone attached to 
a joint is controlled by the joint’s rotation and movement. 

Attributes specify how a joint acts. For example, there can be limitations 
on how far a joint can rotate.

" Joints and bones

" Create a joint or joint chain

joint chain

In animation, any group of joints and their bones connected in a series. 
The joints are connected linearly (that is, you could draw a line through a 
joint chain’s series of joints and their bones without having to retrace your 
path). 

A given joint chain begins at the highest joint in the joint chain’s action 
hierarchy, the parent joint.
Glossary

96



 joint chain plane
" Joint chains

" Create a joint or joint chain

joint chain plane

In animation, a plane that would best contain all the joints in the joint 
chain, thereby controlling how the joint chain can twist. The joint chain 
plane can rotate about the handle vector, having the effect of twisting the 
joint chain.

" IK solvers

joint chain plane indicator 
In animation, an indicator of the orientation of a joint chain plane relative 
to the reference plane. It can be thought of as the shadow of the joint chain 
plane in the rotation disc.

" IK solvers

joint cluster flexor

In animation, a deformer based on a cluster deformer that provides 
weighted deformation control around joints. See also cluster deformer.

" Edit with joint cluster flexor manipulators

" Flexors

" Create all types of flexors

" Skin > Edit Rigid Skin > Create Flexor

joint lattice flexor

In animation, a deformer based on a lattice deformer that provides 
smoothing effects around joints.

 See also lattice deformer.

" Flexors

" Lattice deformers and lattice flexors

" Create all types of flexors

" Skin > Edit Rigid Skin > Create Flexor

joint sculpt flexor

In animation, a deformer based on a sculpt deformer that provides 
rounded deformation effects around joints. 
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joint sculpt flexor
See also sculpt deformer.

" Flexors

" Create all types of flexors

" Skin > Edit Rigid Skin > Create Flexor
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Glossary: K

key

In animation, the assignment of a particular set of values to an object’s 
attributes (for example, translate, rotate, scale, color, etc.) at a specific time 
(or frame).

Also known as keyframe. See also frame.

" Keys

" Setting keyframes

kinematics

In animation, a method of simulating body mechanics by setting up and 
animating skeletons. The two main types of kinematics are forward 
kinematics (FK), and inverse kinematics (IK).

See also FK (forward kinematics), IK (inverse kinematics), skeleton.

" Posing skeletons

" Using skeletons

" Forward and Inverse Kinematics

 



lattice deformer
Glossary: L

lattice deformer

In animation, a deformer that surrounds a deformable object with a 
structure of points (lattice) that can be manipulated to change the object’s 
shape.

See also STU space, outside points transform. 

In other software packages, known as FFD or  Lattice SOP > Lattice Mode.

" Lattice deformers

" Set lattice deformers

" Edit lattice deformers

" Skinning with lattice deformers

" Deform points outside the lattice

" Deform > Create Lattice

layer set

In Adobe PhotoShop, a collection of layers that helps you better organize 
and manage layers. Use layer sets to easily move layers as a group, to 
apply attributes and masks to groups of layers, or to reduce clutter in the 
Layers palette. 

" Create render layers

" Layer Editor

" Adobe Photoshop file support

lens flare 
In rendering, a simulation of several bright disks of light, of various sizes, 
extending in one direction from the light source. See also optical FX node.

" Glows, halos, and lens flares

" flare

license file

A file that contains an encrypted license string, allowing you to run Maya 
on your workstation. It is the end result of the licensing process.

This file is named aw*.dat and is located in the C:\flexlm directory 
(Windows) or the /var/flexlm directory (Mac OSX/IRIX/Linux). 
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 light fog (illuminated fog)
When you reinstall the operating system, you need to back up this file. 

" Overview of licensing

" Understanding licenses

" Obtaining a license

" Examining a licensing log file

light fog (illuminated fog)

In rendering, the simulation of light shining through fine particles (fog, 
smoke, or dust) in the air. 

In Maya, you must add fog to a light to simulate light fog. This fog is 
associated with a specific light, and can only appear within the light’s 
illumination. 

To create fog that fills the entire scene, use environment fog.

" Create illuminated fog

" Light Effects

" Light Fog

light source

In rendering, an object that provides illumination to a scene.

In the real world, the surfaces of objects are illuminated by light rays 
emitted from various light sources (for example, light bulbs, flashlights, 
the sun, fire, and so on). 

In Maya, by setting the properties of a light source you can simulate many 
of the different types of real-world light sources that illuminate surfaces. 

Also known as light. 

For  light source types, see ambient light, area light, directional light, point 
light, spot light.

" Create a Maya light source

" Link light sources to surfaces

" Adjust a light source's attributes

" Plan light sources

" Move a light source to another location
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linear unit
linear unit

The unit of measure for operations that use linear values (for example, 
moving and scaling). The default unit for measuring linear values is 
centimeters.

" Other Maya setup

LMB

Left Mouse Button.

local axes

In animation, a coordinate system aligned to the orientation of a joint. If 
the position of the joint is changed, its local axes may have to be realigned. 

To display the local axis, open the Attribute Editor. Click the transform 
tab for the object, and in the Display section, toggle on Display Local Axis.

" Display all the local axes in a skeleton

" Orient a joint's local axes manually

" Skeleton > Orient Joint

local space

The coordinate system (origin and axes) from the point of view of an 
object's parent node in the hierarchy of objects.

Contrast with object space, world space.

" World space, object space, and local space

" Apply forces in an object's local space

locator

A particular position in world space, marked by a small gnomon whose 
lines extend in each direction along the X, Y and Z axes.

See also gnomon. In other software packages, known as dummy object.

" Add locators

" Review the Locator Summary

" Reference locators and reference manipulation

" Create > Locator
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 loft
loft

In modeling, a series of splines that define the shape of an object, then can 
be lofted together to form a surface.

An analogy is to boat building, where a skeleton of ribs is built, then 
covered by planks or metal sheets to form the hull.

In other software packages, this term is known as cross section and surface 
modifiers surface or skinning, or may refer to extrude.

" Lofting a surface

" Surfaces > Loft

luminance 
The measurable brightness of a surface.

" Image adjustment keys

For more information, search the online help for Luminance
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.ma file format
Glossary: M

.ma file format 
Maya ASCII, the native ASCII file format used by Maya. See also ASCII 
file.

" Organization of Maya ASCII files

" File formats limitations

macro

A combination of several Maya commands that have been saved to the 
shelf, hotkey, or marking menu.

Macros are time-saving tools that allow you to take repetitive tasks and 
combine them into a single button.

In Maya, macros are enabled by the MEL scripting language.

manipulator

A visual and interactive tool for changing an object's attributes. Many 
Maya tools provide manipulators for you to directly position and scale 
objects in the workspace. 

Also known as manip.

" What is a manipulator?

" Use manipulators

" Writing a manipulator

marking menu

A subset of menu choices that appear around the current cursor position, 
providing quick access to a few of the most commonly used tools for the 
particular chosen object.

Marking menus are used throughout the Maya interface. They can be 
accessed either by pressing the right mouse button over an object, or 
sometimes by pressing down a key and then pressing a particular mouse 
button.

" Marking menus

" Choose actions from marking menus

" Create or edit a marking menu

" Assign a marking menu to a hotkey
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 mask channel
" Add a marking menu to the hotbox

mask channel

See alpha channel.

match moving

In Maya Live, the process of matching the camera or object movement 
from live action footage with a computer-generated (CG) scene. 

" Introducing Live

" Import track points

" Export track points

" Load Live

" Fine Tune

material

In rendering, a description of what an object looks like when it is 
rendered. Also known as shader.

Types of materials include: displacement material, surface material, volumetric 
material, illumination model.

" Material Types

" Surface shading

" Surface Materials

" Creating shading materials for objects

matrix

In general, an array of interconnected attributes. These attributes are 
combined to create one single entity.

" Matrices

" Can I specify a dynamic matrix?

matte

In rendering, information that defines the transparency of each pixel 
(opaque, partly transparent, completely transparent). The unused pixels of 
an image (black space) have a completely transparent matte.

" Common Volumetric material attributes
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matte channel
" Modify a mask channel

matte channel

See alpha channel.

Maya

1 The art of illusion. 

2 The most advanced 3D animation and special effects software in the 
market.

.mb file format

Maya Binary, a native binary file format used by Maya. This is the default 
file format. See also ASCII file.

" Supported file formats

" File formats limitations

" File > Save Scene

MEL

Maya Embedded Language, Maya’s interpreted command and scripting 
language.

" MEL for programmers

" Get help on a MEL command

" Downloading Alias MEL scripts

" Pre Render MEL and Post Render MEL scripts 

For more information, search the online help for MEL

.mel file format

A MEL script (ASCII) file format used in Maya.

See MEL.

mental ray

An integrated plug-in renderer that allows interactive and batch mental 
ray rendering from within the Maya user interface. 
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 mesh
mental ray offers all the features traditionally expected of photorealistic 
rendering, and includes functionality not found in most rendering 
software, such as host and network parallel rendering, area light sources 
for soft shadows, global illumination, and caustics (light patterns).

" mental ray for Maya renderer

" mental ray for Maya Shaders

" mental ray for Maya diagnostics

mesh

A collection of polygons, which can be of different types (triangles, quads, 
n-sided).

Also known as polyset or polygonal object.

" Meshes and shells

" Combine separate meshes into one new mesh

For more information, search the online help for mesh

mesh brush

In Paint Effects, a type of brush that renders paint effects with 
triangulated mesh tubes rather than brush stamps, resulting in accurate 
conical geometry with textures that correctly map to the surface. 

The mesh brush is useful for rendering flat surfaces more accurately, for 
creating more convincing Paint Effects trees and plants, and for creating 
hard-edged geometry such as buildings.

" Mesh Brushes

" Converting mesh strokes to polygons

" Paint Effects > Paint Effects Mesh Quality

MMB

Middle Mouse Button.

model 

A computer-based description and representation of a three-dimensional 
object. Models can be created with modeling software tools, 3D digitizers, 
and so on.

" The Maya interface

" NURBS modeling limitations
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motion blur
For more information, search the online help for model

motion blur

In rendering, the simulation of the blurring that occurs when a fast-
moving surface is captured by a camera. 

Maya can compute real-world blur either accurately (3D motion blur, an 
expensive operation), or approximately (2D motion blur, a cheaper 
operation acceptable in some situations).

" Set motion blur

" Create > Cameras > Camera

For more information, search the online help for motion blur

motion capture

In animation, the recording of joint positions and rotations from 
movements performed typically by a human actor. This information is 
then applied to a skeleton to simulate real-life motion on a character.

" Motion capture devices

" Motion capture process

" Prepare motion capture data

" Create simple motion capture

motion history dependence

In animation, the case where an object displays different motion effects in 
situations that are identical except that the object has been previously 
manipulated or animated.

For example, an object is motion history dependent if, when you animate 
the object and run the animation in a loop, the object ends up moving in 
slightly different ways at the same frame in each loop. By contrast, if the 
object moves in exactly the same way during each loop, then the object is 
motion history independent.

Motion history dependence effects can be a problem if you want 
predictable motion effects, but an advantage if you want unpredictable 
motion effects.

" Geometry constraint motion history dependence

" Control motion history dependence effects for aim constraints

" Control motion history dependence effects for normal constraints
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 motion path
motion path

In animation, the use of a curve to control the motion of an object.

" Using motion path markers

" Create a motion path using a curve

" Set motion path markers

" Create a motion path using keys

" Delete motion paths

motion warping

In animation, the modification of an object’s motion with the addition of 
new keys.

" Create and edit time warps

" Reviewing the motion

" Animate > Create Clip

MultiPoint

In dynamics, a render type that displays each particle as multiple points. 
The extra points make the particle object appear denser. 

Use this render type to create dust, clouds, mist, or other gaseous 
emissions.

" Choose how particles render

" List of particle attributes

MultiStreak

A render type that is a combination of streak and multiPoint render types. 
It displays multiple points with tails for each moving particle. The faster 
the particles move, the longer the tails.

" Choose how particles render

" List of particle attributes

muting

The disabling of animation on a selected channel without removing the 
animation curve from the Graph Editor.

" mute

" Muting animation
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muting
" Change the status of a mute node from the Channel Box

" Exposed muting in the Dope Sheet and Graph Editor
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nail rigid body constraint
Glossary: N

nail rigid body constraint 

In dynamics, a constraint that places a single active rigid body at a position 
in the workspace. This constraint works as if a solid bar connects the rigid 
body to the constraint position. 

You cannot use a nail constraint on a passive rigid body.

" Create a Nail constraint

" Edit constraints

" Fix rigid body problems

neutral pose

The common pose you want both the source and target skeletons to be in 
when retargeting animation data.

The neutral pose maintains the distinct characteristics of the source and 
target skeletons. For example, when retargeting animation from an 
android to a hunchbacked character, the neutral pose would prevent the 
android character's stiff back from overriding the hunchback's slouch. 

" How do I set my skeleton's neutral pose?

" Set a skeleton's neutral pose

" Retargeting > Set Neutral Pose

" Skeleton > Retargeting > Set Neutral Pose

" Skeleton > Retargeting > Go to Neutral Pose

" Possible animation retargeting problems

Newton field

In dynamics, a field that pulls objects towards it. It is based on the 
principle that a mutual attractive force exists between any two objects in 
the universe, proportional to the product of their masses. As the distance 
between the objects increases, the force of the field decreases. 

Use Newton fields to create orbiting planets or tethered, colliding balls, 
for example.

" Fields > Newton

" Fields > Turbulence

For more information, search the online help for Newton field
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 nickeling
nickeling

Visually apparent faceting caused by low polygon resolution. Term 
derives from the faceted edges of a 5-cent piece. See also tessellation.

" Set the resolution and pixel aspect ratio

" Render > Set NURBS Tessellation

node

A construct that holds specific information, along with the actions 
associated with that information.

Maya creates, connects, evaluates, and destroys nodes. At any moment, 
what you see in the Maya workspace is the result of Maya’s dynamic, 
node-based architecture, which continuously evaluates the web of nodes 
that underlie and comprise your work.

Each node can receive, hold, and provide information with attributes. A 
node’s attributes connects to the attributes of other nodes, thus forming a 
web of nodes (node network). 

" Nodes

" Render nodes

" invisible node

" Create a node

" Surface, displacement, volumetric materials

" Common Volumetric material attributes

" Node filtering improvements in Hypershade

node-locked license

A type of license that is locked to one workstation and cannot be used on 
other machines. Node-locked versions of Maya are licensed to the 
hardware ID of a computer. See also hardware ID.

" Understanding licenses

" Installing licenses

" Additional setup for floating licenses

" Limiting the use of Maya Unlimited product licenses

nonlinear deformer

In animation, a deformer that acts independently of time. Nonlinear 
deformers in Maya include: end, flare, sine, squash, twist, and wave.
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nonmanifold topology
In other software packages, known as geometric/deferrable, modifier-based, or 
quickstretch.

" Flare Nonlinear deformer

" Set flare nonlinear deformers

" Sine Nonlinear deformer

" Edit sine nonlinear deformers

" Squash Nonlinear deformer

" Twist Nonlinear deformer

" Set twist nonlinear deformers

" Set bend nonlinear deformers

" Wave Nonlinear deformer

nonmanifold topology

Geometric configurations that, if unfolded, could not lie flat on a plane 
without overlapping pieces. Typically this situation occurs if the surface 
consists of several patches sharing a boundary. Natural examples include 
a fish with fins, a plane with wings, or a bag with compartments.

 The following are examples of nonmanifold topology:

In the first example (the T shape), more than two faces share an edge. In 
the second example (the bowtie shape), two faces share a single vertex 
without also sharing an edge. In the third example, a single shape has 
non-contiguous normals (without border edges). This is a less obvious 
example of nonmanifold geometry.

" 2-manifold, non-manifold, and invalid polygonal geometry

" Prepare polygons for conversion to a subdivision surface

non-planar polygon

In modeling, a polygon that has more than three vertices, and those 
vertices do not lie in the same plane (that is, are not planar, or flat).

Three or more faces 
share an edge.

Two or more faces share a 
single vertex but no edge.

Adjacent faces have 
opposite normals.
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 normal
" 2-manifold, non-manifold, and invalid polygonal geometry

" Polygons > Cleanup

" Delete all non-skin history

" How polygons are handled internally

normal

In modeling, the directional line perpendicular to a surface.

Polygon normals indicate the orientation of polygonal faces. Because 
shaded (or rendered) faces are visible only when the normals are facing 
towards the viewer, it is sometimes necessary to reverse a normal to 
correct a face’s orientation.

See also fur normal, vertex normal.

" Normal constraints

For more information, search the online help for Normals

normal constraint

In animation, a constraint that keeps an object’s orientation so that it 
aligns with the normal vectors of a NURBS or polygonal surface (mesh).

Normal constraints are useful for keeping an object oriented as it travels 
across a surface that has a unique, complex shape.

See also constraint, geometry constraint.

" Normal constraints

" Constrain > Normal

" Delete normal constraints

" Set normal constraint options

" Edit normal constraint attributes

" Edit normal constraint channels

" Add target objects for normal constraints

" Remove normal constraint target objects

" Prevent rolling effects for normal constraints
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NTSC
NTSC

National Television Standards Committee. The standard for composite 
video in North America, Japan, and most of South America. NTSC divides 
a video image into 486 horizontal scanlines. The resolution across a 
scanline can vary from 512 pixels to 1024 pixels. (Pixel resolutions above 
720 are not discernible on most equipment.)

See also aspect ratio, real time.

" Settings

numeric render type

In dynamics, a render type that displays the current values of any 
attribute of a particle object. This type is useful when you want to know 
the value of an attribute such as velocity at a certain frame. By default, 
Maya displays particle IDs for this render type.

" Choose how particles render

NURBS

Non-Uniform Rational B-Spline. A type of geometry that includes curves, 
patches, surfaces, and so on.

NURBS are a superset of conics, splines, and Bezier curves. They are 
particularly suited for modeling in 3D, because they provide excellent 
continuity with a minimum number of control points.

" Convert NURBS to polygons

" Convert a subdivision surface to NURBS

" Modify > Convert > Subdiv to NURBS

" Create > NURBS Primitives

" Render > Set NURBS Tessellation

For more information, search the online help for NURBS
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Glossary: O

object

In Maya, any entity in a scene.

object space

The coordinate system from an object's point of view. The origin of object 
space is at the object's pivot point, and its axes are rotated with the object.

Contrast with local space, world space.

" World space, object space, and local space

" Apply forces in an object's local space

" How can I get an object's pivot point in world space?

occlusion culling

An option that improves shading display performance by not drawing 
any objects obscured from the viewpoint of the active camera. 

Contrast with backface culling (backculling).

" High quality interactive shading

" New performance-enhancing render globals

ocean

In fluid effects, a shaded surface that simulates open water effects (for 
example, waves) by using surface displacement. Boat wakes and other 
effects caused by objects can be created with wakes.

See also pond, wake.

" Oceans

" Create new oceans

" Create ocean effects using example oceans

" Fluid Effects > Ocean > Create Ocean

offset

In modeling, a curve or surface that is a duplicate of an existing curve or 
surface, but is set off from the original copy.

" Create an offset copy of a curve or surface

" Edit Curves > Offset > Offset Curve, Offset Curve on Surface
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Online Product Activation (OPA)
" Edit NURBS > Offset Surfaces

Online Product Activation (OPA)

An activation key generation process where users submit an online form 
with the serial number they received upon purchase, and an activation 
key is automatically generated and sent back.

OPA is available to users of node-locked versions of Maya 4.5 and later.

Contrast with SPAR. See also activation key, serial number.

" Overview of licensing

" Installing Maya

" Activation keys for node-locked licenses through OPA

" Limiting the use of Maya Unlimited product licenses

" Confirming Maya startup

optical FX node

A node that lets you create the glows, halos, or lens flares that are 
produced when a light shines directly into the camera. You can add an 
optical FX to any light. 

See also glow object, halo, lens flare., 

" Create a light optical effect

" Glows, halos, and lens flares

" Create environments that glow

" Create illuminated fog

" Adjust the size of the glow object

orient constraint

In animation, a constraint that matches the orientation of one object to one 
or more other objects. Orient constraints are useful for keeping objects 
aligned.

See also constraint.

" Create orient constraints

" Edit orient constraint attributes

" Edit orient constraint channels

" Set orient constraint options

" Add orient constraint target objects
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 origin axis
" Animate target object weights for orient constraints

" Delete orient constraints

origin axis

A display of the XYZ coordinates at the origin, the point at which 
coordinate values are all zero (that is, 0, 0, 0). 

See also axis.

" Move the center of interest or origin

" Creating volume axis fields

" Volume Axis field

" Sweep out a surface by rotating a curve around an axis

orthographic projection

In rendering, the process of applying a flat image of a surface onto an 
object.

Outliner

A window that lists the objects, lights, cameras, and other items in a scene. 

You can use the Outliner to examine the structure and components of the 
scene hierarchy, display shape nodes, connections, and attributes, select 
and rename an object, and reorder nodes (that is, change the evaluation 
order).

Contrast with DAG. In other software packages, also known as selection 
floater, object manager or schematic view.

" The Outliner

" Device outliner

" The Graph Editor outliner

" Using the Outliner to parent objects

out-point

In video and film editing, the last frame of an edit.

output connection 
A node that receives input from the selected node. Also known as 
downstream connection. See also node.
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output node
" Show node connections

" Render node connections

" Graph > Output Connections

output node

A node in a node’s history that can be evaluated only after the node itself 
is evaluated. 

Also known as downstream node. See also output connection, node.

" Show node connections

" Connect render nodes using the Connection Editor

outside points transform

A set of lattice deformer options that let you transform all points of an 
object, even those  points of the object outside of the lattice.

See lattice deformer.

" Deform points outside the lattice

oversampling

The process of removing jagged lines and edges that appear because of 
aliasing. Oversampling improves the smoothness of lines in an image, but 
it increases the time required to create the image.

See also aliasing, anti-aliasing.

" Paint Effects Rendering Options

" Runtime expression execution

" Fix playback problems

" Deform > Create Jiggle Disk Cache
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 Paint Effects
Glossary: P

Paint Effects

A component of Maya used to paint brush strokes and particle effects on a 
2D canvas or on or between 3D geometry. Paint Effects can be used as a 
traditional paint program to paint images on a canvas, to paint repeatable 
textures applied to 3D geometry in scenes, or to paint in 3D space

In other software packages, know as texture.

" Painting in 3D

" Prepare to use Paint Effects

" Paint Effects > Paint Effects Tool

paint sculpt map

A technique for painting deformation strengths over the surface of a 
deformer using the 3D paint tool. This makes it easy to use the Sculpt 
Deformer to create realistic muscle shapes. 

The paint sculpt map creates a new file texture, which it connects to the 
sculpt deformer's Texture attribute. If a non-file texture is already 
connected to the deformer, it is disconnected before painting begins. 

Paint Sculpt Map is a button in the Sculpt History section of the sculpt 
node. 

" sculpt

" Sculpt according to an attribute map

" Sculpt deform with texture map 

" 3D Paint Tool

PAL

Phase Alternate Line. The industry standard for composite video in most 
of Europe and in many other nations. 

PAL divides video images into 576 horizontal scanlines, and the 
resolution across a scanline can vary from 512 pixels to 1024 pixels. The 
highest effective pixel resolution is the same as NTSC, somewhere around 
720. The frame rate for PAL is approximately 25 frames per second.

See also EBU time code, SECAM.

" Troubleshoot:Objects vibrate when an animation is rendered as fields

" Sample diagnostic messages
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panel
" Corrective options

" Settings

" Supported file formats

panel

1 In general, a part of the Maya interface that allows you to view objects 
or use controls.

You can set up the division of the main window into panels, adjust 
their size, and change the contents of panels between view and 
editors.

" Change the panel layout

" Panel editor

" Use Live control panels

" Use the Track Display panel

" Painting in the Paint Effects Panel

2 In Maya Cloth, a closed set of planar NURBS curves that define the 
extent of a cloth before the cloth is draped.

" Create panels

" Cloth > Create Panel

" Apply properties to panels

" Change the panel lighting

parameter

In modeling, a unique numeric value (like a coordinate) of a point on a 
curve or surface. Parameters let you refer to specific points along the 
length of a curve. 

" Parameters and parameterization

" Adjust scene anti-aliasing parameters (Maya software)

parameterization

The method used to number the points along a curve.

Maya provides two types of parameterization: uniform (where edit points 
are numbered with consecutive integers), and chord-length (where edit 
points are numbered with decimal values representing their location on 
the curve).

" Parameters and parameterization
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 parametric space
" Convert a curve or surface to uniform parameterization

" Build equalizer maps separately

" Changing the timing of an object along a motion path

parametric space

A coordinate system measured across the surface of an object, rather than 
in 3-dimensional world space.

" Animate > Motion Paths > Attach to Motion Path

" Edit Curves > Extend > Extend Curve on Surface

parent constraint

A constraint relating the position (translation and rotation) of one object to 
another object, so that they behave as if part of a parent-child relationship.

See constraint, child object, parent object.

" Parent constraint workflow

" Create a parent constraint

" Key and parent constraints

" Edit a parent constraint

" Offset parent constraints

" Applying parent constraints on an IK system

" Constrain > Parent

parent object

An object or other item that controls the attributes of one or more child 
objects. A parent can also be the child of another parent.

Contrast with child object. In other software packages, similar to link.

" Using the Outliner to parent objects

" Make an object move with a dynamic parent

particle

In dynamics, a point displayed as a dot, streak, sphere, blobby surface, or 
other effect. You can animate the display and movement of particles with 
various techniques (for example, keys, expressions, and fields such as 
gravity).

" Particles > Particle Tool
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particle object
" Particle collisions

" Animate particles

" Rendering particles

" Choose how particles render

" Set attributes on a per particle basis

" Particle caching

particle object

In dynamics, a collection of one or more particles that share the same 
attributes. Each particle in a scene belongs to some particle object.

" Understand per particle and per object attributes

" Creating particle objects

" Duplicate particle objects

partition set

A group of mutually exclusive sets. Sets in a partition can have no 
common members. 

" Rigid skin point sets

" View and edit the character partition

" Skin > Bind Skin > Rigid Bind

" Deform > Create Cluster

patch

In modeling, a rectangular portion of a surface bounded by adjacent edit 
point isoparametric curves.

" Surface components: CVs, isoparms, and patches

" Change a curve or surface's degree or number of spans/patches

" Preview a patch of ocean

path

In animation, a curve that controls the motion of an object.

In other software packages, known as curve deformation.

" Understanding path animation

" Create a motion path using a curve

" Create a motion path using keys
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 path curve
" Animate > Motion Paths > Set Motion Path Key

" Animate > Motion Paths > Flow Path Object

" Delete motion paths

path curve

In modeling, a curve that controls the path of an extrusion.

Contrast with profile curve.

" Orienting your object on a path curve

" Create a motion path using a curve

" Animate an object along a surface

" Sweep a profile curve along a path curve

" Sweep one or more profile curves along two path curves (birail)

" Deform an object along a motion path curve

Phong material

A shading material for 3D surfaces developed by Phong Bui-Tuong. The 
Phong shading method uses three characteristics (diffusion, specularity, 
and shininess) to create a smoothly curving surface with light-reflecting 
highlights.

See material. Contrast with Phong E material.

" Phong

" Create double-sided shaded surfaces

Phong E material

A shading material that is an extension of the Phong material.

" Phong E

photon map

A 3D representation of the accumulated light energy at certain photon 
bounce points, required to produce global illumination and caustic effects. 

" Photon maps

" Photon and Final Gather visualization maps

pick mask

See selection mask.
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pin constraint
pin constraint

In dynamics, a constraint that links two rigid bodies at a specified 
position. It works as if the two objects were connected by a metal pin with 
a ball joint between its ends. You can pin together two active rigid bodies 
or an active and a passive rigid body.

Use pin constraints to create effects such as a link in a chain or a robotic 
arm. 

See also constraint.

" Create a Pin constraint

" Soft/Rigid Bodies > Create Constraint

" Edit constraints

" Use constraints

pivot point

A specific position in 3D space used as a reference for the transformations 
of objects, particularly for rotations. 

Every object (and group of objects) has a pivot point that can be moved 
relative to the object.

In other software packages, known as center.

" Pivot points

" Move the pivot point

" Show, hide, or resize a light manipulator

pixel

The smallest controllable segment of a display.

Also known as picture element.

" Paint pixels

" Pixel aspect ratio

" Set the resolution and pixel aspect ratio

planar polygon

In modeling, a polygon with vertices all lying in the same plane. For 
example, a tri-polygon is always planar because you cannot bend or twist 
a polygon with only three vertices describing it.

" Planar and non-planar polygons
Glossary

126



 plane
" Edit Polygons > Texture > Planar Mapping

" Polygons > Tool Options > Keep New Faces Planar

plane

In general, a flat surface.

See also clipping plane, construction plane, image plane, plane constraint.

" Cut faces with a plane

" Creating an ocean plane and shader

plane constraint

In Maya Live, a constraint that keeps points attached to a wall, floor, table, 
ground or other flat surface.

See constraint.

" Creating a Plane constraint

" Choose survey constraints

" Create and modify survey constraints

Playblast

A window lets you preview an animation quickly. 

The Playblast process takes a screen grab of the view at each frame, and 
then plays (blasts) the resulting images to a desktop movie player or the 
Fcheck utility. 

Playblast images can be saved either as a movie file or as a sequence of 
images in various formats.

In other software packages, similar to make preview or linetest.

" Playblast animation

" Window > Playblast

" FCheck windows

" FCheck options

" Use the hardware render buffer

plug-in

An add-on module that extends Maya’s capabilities. You can create or 
purchase specialty plug-ins to customize Maya for a specific job (for 
example, for importing or exporting file formats, for rendering, etc.)
Glossary

127



point
In other software packages, known as utility.

" Loading a Plug-in

" Unloading a plug-in

" Writing a simple plug-in

point

1 For modeling and animation, see control point.

2 In dynamics, a render type that displays particles as points. This is the 
default render type.

" Choose how particles render

point constraint

1 In animation, a constraint that causes an object to move to and follow 
the position of an object, or the average position of several objects. 
This type of constraint is useful for matching the motion of an object 
to that of other objects. See also constraint. In other software packages, 
known as position constraint.

" Create point constraints

" Constrain > Point

" Set point constraint options

" Edit point constraint attributes

" Delete point constraints

" Using a point constraint with a geometry constraint

2 In Maya Live, a constraint that provides explicit control over a point’s 
coordinates. 

" Add target objects for point constraints

" Remove target objects for point constraints

point light

A light that illuminates in all directions, radiating from a point in space. 
For example, a point light can simulate an incandescent light bulb.

See light source.

" Point Light Attributes

" Create > Lights > Point Light
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 point of view
point of view

In general, the location from where you are viewing a scene.

" Camera Tools

pole vector

In animation, a part of an IK rotate plane handle that begins at the start 
joint, and along with the handle vector defines the IK handle’s reference 
plane. 

The pole vector changes the orientation of the reference plane, so can 
change the orientation of the joint chain directly. This is because the joint 
chain’s degree of orientation, or twist, is defined as the difference in 
orientation between the reference plane and the joint chain plane.

In other software packages, known as up-vector. 

See also IK handle, pole vector constraint. 

" Create a pole vector constraint

" Delete pole vector constraints

" Set pole Vector constraint options

" Edit pole vector constraint attributes

pole vector constraint

In animation, a constraint that causes the end of a pole vector to move to 
and follow the position of an object, or the average position of several 
objects.

See also constraint.

" Create a pole vector constraint

" Delete pole vector constraints

" Set pole Vector constraint options

" Edit pole vector constraint attributes

polygon

An n-sided shape defined by a group of ordered vertices and the edges 
that are defined between pairs of those vertices. 

Polygons can be either simple shapes, such as polygonal primitives, or 
complex models built from the various Maya polygonal tools.

A polygonal object can be closed, open, or made up of shells, which are 
disjointed pieces of geometry.
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polygon count
In other software packages, known as mesh.

" Polygons

" Smooth polygons

" Polygons > Create Polygon Tool

" Polygons > Append to Polygon Tool

" Polygons > Average Vertices

" Polygons > Reduce

polygon count

The number of polygons in a scene.

" Show polygon counts in the heads-up display

" How can I count polygons?

" Polygons > Reduce

polygon proxy mode

In subdivision surface modeling, a view mode that creates a polygonal 
object that matches the base mesh (level 0) of a subdivision surface. This 
polygonal object is temporary, and deleted when you switch back to 
standard mode. 

In polygon proxy mode, you can use polygon tools and functions to 
indirectly modify the base mesh (level 0) of the subdivision surface. For 
example, to extrude or delete faces.

" Standard mode and polygon proxy mode

" Edit UVs in Polygon Proxy Mode

" Subdivision Surface Polygon Proxy Mode

" Splitting a surface in polygon proxy mode

" Reshape a subdivision surface using polygon tools

" Subdivision surface levels

polygonal shell

In modeling, a polygonal object that consists of one or more shells. If there 
is more than one shell, there are one or more edges which only belong to a 
single shell (that is, the surfaces are disconnected).

See also shell.

" Meshes and shells

" Automatically separate polygon shells into individual meshes
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 polygonal solid
" Combine separate meshes into one new mesh

" Edit Polygons > Separate

polygonal solid

In modeling, an object created by faces that form a closed volume. Each 
edge in a solid is shared by exactly two faces. A solid always has an inside 
and outside, defined by the direction of the normals.

See also face, normal.

" Splitting polygons

" Display > Custom Polygon Display

pond

In fluid effects, a 2D fluid that simulates small bodies of water.

Waves, bubbles, ripples, and other surface displacements can be created 
using pond wake settings.

See also ocean, wake.

" Create Ponds

" Create Pond wakes

" Create ocean effects using example oceans

" Make boats float

" Fluid Effects > Pond > Create Pond

" Fluid Effects > Pond > Create Wake

" Fluid Effects > Ocean > Create Wake

popup help

Descriptive text that appears when the mouse cursor is held over an icon 
or button.

" Maya Help

pose

In animation, the state of a skeleton at a given time (or frame), including 
the orientations of all the skeleton’s joints.

" Create poses

" Pose the character

For more information, search the online help for pose
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preroll
preroll

In film and video production, a location on videotape to which the tape is 
cued, occurring a few seconds before the in-point. The videotape recorder 
(VTR) starts from this preroll point top ensure that the tape speed is stable 
before recording begins.

preset

A collection of attribute settings that can be saved from one node and 
reapplied to any number of other nodes.

" Use Fur Presets

" Use fluid attribute presets

" Select preset brushes

" Modifying the colors of a preset brush

" Blend preset brush settings

" Create new brush presets

primitive

A simple shape that can be molded or expanded to add more detail. 
Primitives include spheres, cubes, cylinders, cones, planes, and toruses.

" Primitive Objects

" Creating a foundation shape from a primitive

" Modifying a primitive object

" Create > Volume primitives

" Create > Polygon Primitives

" Create > NURBS Primitives

procedural texture

A texture that is calculated based on some algorithm or mathematical 
formula.

Contrast with file texture.

" Texture mapping

" 2D and 3D textures

" Texturing fluids

" Texture a fluid
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 profile curve
profile curve

In modeling, a curve that determines the cross-sectional shape of an 
extrusion.

Contrast with path curve.

" Creating a profile curve

" Creating profile curves for a surface

" Skin a surface across profile curves

" Sweep a profile curve along a path curve

" Sweep one or more profile curves along two path curves (birail)

projection map

A technique of projecting a 2D image onto 3D geometry, useful for 
creating textures or icons on a rendered object.

Contrast with environment map.

" Projection

" Use the Projection utility

property

In Maya Cloth, a specification of the physical properties of cloth. 
Properties affect how the cloth behaves when it moves. For example, you 
could create a property that makes your cloth behave like denim. 

" Paint properties on cloth

" Remove cloth properties

" Simulation > Properties > Paint Cloth Properties Tool

PSD

A proprietary file format used by Adobe Photoshop. 

You can use a flattened or layered PSD file as a Maya texture, and can 
export a layered PSD file from Maya to facilitate simple painting of 
multiple channels on objects in Adobe Photoshop.

" Adobe Photoshop file support
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quaternion rotation

Glossary: Q

quaternion rotation

A method of rotation that uses a unit quaternion (a quaternion of length 
one) to represent an orientation in three dimensions. A quaternion is a four 
dimensional extension to complex numbers. Maya uses XYZ curves and 
computes a fourth curve (W) to determine the quaternion rotation. 

Quaternion rotation is an option that is useful for avoiding gimbal lock.

Contrast with Euler rotation. See also gimbal lock.

" Set rotation interpolation for curves



 radial field
Glossary: R

radial field

In dynamics, the simulation of a force field that either pushes objects away 
from itself or pulls objects toward itself, like a magnet.

" Fields > Radial

" Keep particles inside the volume

" Duplicate particle objects

For more information, search the online help for Radial field

radial wrinkle deformer

In animation, a deformer that wrinkles objects using influence wires that 
branch from a single point, like spokes on a wheel. The radial wrinkle 
deformer can only deform single NURBS surfaces.

" Wrinkle deformers

" Creating wrinkle deformers

" Deform > Wrinkle Tool

" Edit wrinkle deformers

" Set wrinkle deformers

" Editing wrinkle deformation effects

ramp

A 2D texture or color gradient in which the color or grayscale value 
changes from one value to another across the extent of the image. 

" Set particle attributes with a ramp texture

" Adding color to particles with a color ramp

" Map a 2D or 3D texture

For more information, search the online help for Ramp

ray (light ray)

In rendering, the simulation of a straight line of light radiating from a  
light source. 

The number of light rays that need to be calculated by the renderer 
depend on desired qualities, such as blurriness, resolution, refractions, 
specularity, and so on. In general, more rays are required for more blurry 
reflections or refractions. 
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raytracing
See refraction, reflection map.

" Absorption, reflection, and refraction of light

" Use lights, reflections, refractions, and shadows

raytracing

A rendering technique used to create photorealistic reflections and 
refractions on reflective surfaces, and  to produce shadows. Raytracing is a 
high-quality alternative to reflection mapping, although it requires more 
computation time. 

Contrast with reflection map, depth map. See also shadow.

" Render the scene using raytracing

" Render raytraced shadows

" Produce raytraced shadows

" Set raytracing quality

" Depth map and raytraced shadows

real time

In film and video compositing, the display, recording, or playback speed 
at which motion appears natural. In NTSC, real time is 30 frames per 
second; in PAL, it is 25 frames per second.

" Play an audio file

" Adding sound to your animation

redirect control

A handle available at the origin of a character for translation and/or 
rotation of the character.

When a character is redirectable, you can change the translation and 
orientation of its already established animation (for example, during 
motion capture).

" What is motion redirection? 

" Redirect the motion of an animated character

" Character > Redirect

reflection map

In rendering, the simulation from images of background reflections onto 
reflective surfaces.
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 refraction
Reflection mapping is a faster alternative to raytracing, but it can only 
approximate relatively simple reflections (such as an image of the sky), or 
enhance the reflectivity of metallic surfaces.

Contrast with raytracing.

" Simulated reflections

" Common surface material Specular Shading attributes

refraction

In general, the bending of light as it travels through dense transparent 
material such as glass or water. 

In rendering, the simulation of refraction, which requires raytracing.

See also raytracing.

" Absorption, reflection, and refraction of light

" Use lights, reflections, refractions, and shadows

" Render blurry reflections and refractions

Relationship Editor 
A window that provides a single place to work with relationships in 
Maya. A relationship is a collection or grouping of objects or components 
for sets, deformer sets, character sets, partitions, display layers, shading 
groups, and light linking. 

" Dynamic relationship editor

" Edit deformer sets with the Relationship editor

" Window > Relationship Editors > Dynamic Relationships

relative mode

The state where an object is moved relative to its current position.

Contrast with absolute mode.

" Selection Modes and Masks

render globals

Attributes that affect all rendering tasks in a scene (for example, how 
renders display, what format they are in, and whether or not shadows or 
other rendering components are included).
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rendering
Render globals can be set in the Render Globals Settings window, which 
consolidates render globals for the hardware renderer, the mental ray for 
Maya renderer, and the Maya software renderer. 

In other software packages, known as render scene, render setup or ROP 
settings.

" Global illumination

" Window > Rendering Editors > Render Globals

" Render Global Settings window

" Render with global illumination

" Render the scene using Global Illumination

" Render a separate global illumination pass

" Set up Fur Render Globals before rendering

rendering 
The process of creating an image or sequence of images from a scene. 
During rendering, Maya generates a two-dimensional image, or series of 
images, from a specific view of a three-dimensional scene, and saves it as 
an image file. 

You can control the properties of rendered image files according to your 
post-production or presentation requirements.

" Render the scene using raytracing

" Render the scene using Global Illumination

" Render the scene using caustics

" Render a single frame

" Render parts of a scene separately

" Render multiple scenes

" Batch renders from within Maya (UI)

For more information, search the online help for rendering

reserved word

A word that is essential for MEL’s syntax and therefore must not be used 
as a variable name. 

See also MEL.

" MEL for programmers

" Get help on a MEL command

" Testing if a function is available in MEL
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 resolution
resolution

1 For images, the total pixel size of a bitmap image. 

In other software packages, known as output.

" Set the resolution and pixel aspect ratio

" Pixel aspect ratio

" Set resolution

" Render > Test Resolution

For more information, search the online help for resolution

2 For fluids, the number of voxels in a fluid volume.

" Change the resolution of a fluid

retargeting

The process of using a solver to change the animation on a source 
skeleton's joints to the corresponding, labeled joints of the target skeleton. 
Retargeting is useful when you want to transfer animation between 
skeletons that have the same or different proportions.

See also source, target.

" Animation retargeting

" Skeleton > Retargeting > Retarget Skeleton

" Retargeting > Retarget Skeleton

revolve surface

A surface created by revolving a profile curve about an axis. The profile 
curve can be a curve, curve-on-surface, surface isoparm, or trim edge.

In other software packages, known as lathe.

" Creating a revolve surface

" Editing a revolve surface

" Sweep out a surface by rotating a curve around an axis

" Surfaces > Revolve

RGB

Red, Green, and Blue. A color space most commonly used in computer 
graphics and component video, where the three additive color 
components are mixed to create a color. 
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RGBA
Most computer-generated images are stored on disk in RGB format, so it 
is easiest and quickest to display them in RGB video. Because few video 
recording devices accept RGB video, another piece of equipment is often 
used to translate the RGB signals into other formats such as NTSC, or 
Y,R_Y, B-Y. 

See also decoder, encoder.

" Display RGB, luminance, or alpha channels

" HSV to RGB

" rgb_to_hsv

RGBA

Red, Green, Blue, and Alpha. Three additive color components used to 
create any color by mixing, along with an extra component called Alpha 
that is used to indicate transparency. See also alpha channel.

" Better support for mental ray texture formats

" Introduction to the image library

" Vertex Bake set

rigging

See character setup.

rigid body

In dynamics, a polygonal or NURBS surface converted to an unyielding 
shape. Rigid bodies collide rather than pass through each other during 
animation. 

An active rigid body reacts to dynamics fields, collisions, and springs, but 
not to keys. A passive rigid body can have active rigid bodies collide with 
it, but is not affected by dynamics.

In other software packages, known as collision obstacle, dynamic obstacle.

Contrast with soft body. 

" Rigid bodies

" Rigid body constraints

" Create rigid bodies

" Edit attributes of a rigid body

" Soft/Rigid Bodies > Create Passive Rigid Body

" Soft/Rigid Bodies > Create Active Rigid Body
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 rigid body constraint
" Fix rigid body problems

rigid body constraint

In dynamics, a constraint that restricts the motion of rigid bodies. These 
constraints simulate the behavior of real-world items such as pins, nails, 
barriers, hinges, and springs. 

" Rigid body constraints

" Edit attributes of a rigid body solver

" Fix rigid body problems

" Soft/Rigid Bodies > Create Constraint

rigid skin

In animation, a deformable rigid object that is bound to a skeleton to 
simulate articulated deformation effects.

In other software packages, known as rigid envelope.

" Rigid Skinning

" Understanding rigid skinning

" rigid skin point

" Rigid skin point weights

" Adjusting rigid skin behavior

" Rigid skin point sets

rigid skin object

In animation, a deformable object that can be bound to a skeleton to create 
a rigid skin.

" Rigid skin objects and points

" Bind skin

" Paint rigid skin membership

" Paint rigid skin weights

rigid skin point

In animation, a control point (NURBS CV, polygonal vertex, lattice point) 
of a rigid skin object. See also control point.
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RLE
The set of all these points that can be influenced by a particular joint is 
called the rigid skin point set. By default, these sets are organized into a 
partition, so that the sets have no members in common. Consequently, a 
point can be influenced only one joint.

The weight assigned to a joint that controls the influence of that joint on 
each rigid skin point is called the rigid skin point weight. By default, each 
joint can influence the skin points of its nearest skin object equally, but 
you can edit the amount by which a joint can influence a skin point.

" Rigid skin point weights

" Editing rigid skin point set membership

RLE

Run Length Encoding, a form of data compression encoding.

" Window > Playblast

RMB

Right Mouse Button.

rolling camera

A camera movement technique that rotates the camera about its sight line 
(the line connecting the camera to its center of interest).

" Camera aim

" View > Camera Tools

rolling effect

In animation, the rapid rotation of a constrained object about its aim 
vector. This is usually an undesirable effect, and can be prevented by 
moving or animating the world up vector.

See also world up vector.

" Prevent rolling effects for aim constraints

" Prevent rolling effects for normal constraints

" Edit tangent constraint attributes
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 root frame solver
root frame solver

In Maya Live, a solver that operates in distinct steps, which can be run 
separately or in one automatic process. The solver bases its solution on 
root frames, which are important frames selected by the user or 
automatically from the shot.

Root frame solvers offer more flexibility and control over the solver 
process.

" Overall solve workflow

" Run the solver

" Evaluate a solution

" Improve solutions

root joint

In animation, the highest joint in a skeleton’s hierarchy. A skeleton can 
have only one root joint.

Also known as root.

" Skeleton hierarchy

" Building skeletons

" Connect joints

" Skeleton > Connect Joint

rotate order

The order in which an object can rotate about its axes. Each rotation order 
provides a different type of movement.

For example, an object could rotate first about its X axis, then its Y axis, 
and finally its Z axis.

See also Euler rotation.

" Rotate tool

" Transform attributes

rotation

A transformation that turns (or orients) an object about an axis.

See also Euler rotation, quaternion rotation.
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rotoscoping
Links for rotation as an object transformation:

" Rotate tool

" Use manipulators

" Move, rotate, or scale objects

" Move, rotate or scale components proportionally

" Flip texture placement by flipping or rotating UVs

" Sweep out a surface by rotating a curve around an axis

Links for rotation in animation:

" Set rotation interpolation for curves

" Create a rotate plane IK handle

" Pose joints with rotate plane IK handles

" Create camera translation and rotation constraints

" Rotating an object along a motion path

" Blending keyframe and motion path animation

rotoscoping

A process that lets you view digitized video in real time, so that you can 
synchronize each frame in an animation to a digitized background.

" Size and position an image file background

roughness

The property of a surface that causes scattering as light reflects off of it. 

" Apply shadow casting to particles

" Change the look and smoothness of the selected objects

" Anisotropic

runtime expression

An expression that executes for each frame during playback.

See also expression. Contrast with creation expression.

" Using runtime expressions

" Modifying runtime expressions

" Write runtime expressions

" Runtime expression execution
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scale constraint
Glossary: S

scale constraint

In animation, a constraint that matches the orientation of one object to one 
or more other objects. 

This constraint is useful for making several objects orient themselves 
simultaneously.

See also constraint.

" Scale constraints

scanline

A row of pixels in a rendered image. 

" Deinterlacing video shots

" Maya Software tab (Look under “Field options” to set zeroth scanline.)

scene hierarchy

See DAG.

scene view

The perspective, top, front, or side view modeling  panels where work is 
performed. 

Also known as modeling view or workspace. 

" The Maya interface

" Switch between views (Paint Effects)

screen projection

The application of paint onto a screen as if cinematic film were being 
projected. Paint appears where the projection strikes the surface.

" Common Artisan Brush Tool Settings 

Script Editor

An editor for developing MEL scripts.

To access the script editor, select Window > General Editors > Script Editor.

In other software packages, known as Textport, or MelScipt listener.
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 scrubbing
" Using MEL commands

" See or record the MEL commands associated with actions

" Script Editor changes

" Invoke Advanced Fur Rendering from the Script Editor or MEL prompt

scrubbing

In animation, the action of manually moving the current frame along the 
timeline to examine animation, without actually playing the animation.

Scrubbing is enabled by caching. See cache file. 

" Live playback tools

" FCheck Mouse controls

sculpt deformer

In animation, a deformer that uses a spherical wireframe influence object 
called a sculpt sphere to deform an object. Sculpt deformer modes include 
flip, project, and stretch.

" Sculpt deformers

" Creating sculpt deformers

" Set sculpt deformers

sculpt map

See paint sculpt map.

SECAM

Sequential Coleur Au Memoir. A television format used in France, Russia, 
and much of eastern Europe. It has 625 scanlines and plays at 25 frames 
per second. SECAM is a TV broadcast method typically produced with 
PAL video equipment.

See also PAL, EBU time code.

selection mask

A way to limit the items that can be selected in the workspace to specific 
types of objects, components, or hierarchy elements. By limiting which 
items can be selected, you can prevent the unintentional selection of 
nearby objects. 
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selective file loading
Also known as pick mask. In other software packages, known as sub-object 
selection.

" Selection Modes and Masks

" Select only certain types of objects or components (selection masks)

" Select objects based on hierarchy

" Make fur move using dynamics

" Adjust the seams

selective file loading

A feature that lets you control which reference files are loaded when you 
open a file. This improves file opening performance for large scenes. 

By saving out the selective load settings with a given file, or building a set 
before opening the file, you can reduce the time it takes to open a large file 
by only loading reference files of interest. 

" Selective load of references

For more information, search the online help for Selective file loading

self-illumination

In rendering, the simulation of self-illuminating or glowing objects (for 
example, the glow from stars or the moon).

Glow attributes define the type of glow as produced either from light 
reflecting off a surface or from surface incandescence.

" Basic shader properties (go to “Incandescence”)

" True reflections

" Simulated reflections

self-shading

In Maya Fur, the effect of fur shading itself. 

For example, with self-shaded thick fur the tips of the fur will look light 
and the roots look dark.

" Adding fur shading effects

" Fur shading with the Maya Software renderer 

" Fur shading with the mental ray for Maya renderer 
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 serial number
serial number

A series of numbers and letters that identifies an individual copy of Maya, 
part of the Online Product Activation (OPA) Process.

A serial number starts with the letter "M." You need to use this number to 
register Maya and receive an activation key via email.

See also activation key, Online Product Activation (OPA).

" Overview of licensing

" Activation keys for node-locked licenses through OPA

" Overview of manual license installation

set

A collection of objects. See also partition set.

" Sets and partitions

" Create > Sets > Set, Partition

set driven key

In animation, a key with attributes that drive the values of other 
attributes. 

See also driven key, key.

" Driven keys

" Set a driven key relationship

" Animate > Set Driven Key > Set

shaded surface

A display technique that shows a geometric object in a solid shaded 
surface.

Contrast with wireframe.

" Change the look and smoothness of the selected objects

" Surface shading

shader

The specification of properties and lighting for a surface. See material.

" Shader names

" Assigning a shading material
Glossary

149



shader manager
" Load shaders

" Layered shaders

" Use double-sided shaders

" Defining shader attributes for a fluid

" View the Shader Library Gallery

" Write a shader declaration file

" Use a mental ray for Maya shader

shader manager

A tool for interactively loading and unloading mental ray shader libraries 
and working with them during a Maya session. 

You can select from a list of .mi library files that contain the mental ray 
shader declarations. The shaders contained in the selected .mi library files 
automatically appear in Hypershade, just like the Maya and mental ray 
for Maya base shader nodes. mental ray for Maya base shaders are now 
fully integrated into Hypershade and create the render node panel.

(With the shader manager, you do not need the environment variables 
MI_CUSTOM_SHADER_PATH and 
MAYA_MRFM_SHOW_CUSTOM_SHADERS.)

See Hypershade, mental ray, shader.

" mental ray shader manager

" Load shaders

" Assigning a shading material

" Use a phenomenon in a scene

" Write a shader declaration file

shading 
In general, the difference in color across a surface due to different surface 
characteristics and lighting. Shading includes the materials of a surface, 
and the lighting of a surface.

" Lighting/shading > Material Attributes

" Shading

" Texturing

" Assigning a shading material

" Shading networks

" Surface, displacement, volumetric materials
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 shading map
" Writing a shading node plug-in

shading map

In rendering, a material in the form of a color map that is applied to 
surfaces after they are rendered. 

Shading maps are useful for creating non-photorealistic effects (for 
example, cartoon shading), or to highlight threshold values in a rendered 
image. 

See also color map.

" Assigning a shading material

" Map a 2D or 3D texture

" Map file textures to color and opacity

For more information, search the online help for Shading Map

shading network

A network of connected nodes that control specific aspects of the shading 
effect. 

Shading networks define how various color and texture nodes work with 
associated lights and surfaces. The placement of textures on surfaces is 
also controlled by nodes within the network.

You can connect nodes in a shading network in a non-linear way to create 
the effects you want. You can also share nodes to create visual 
relationships or make rendering more efficient. 

To fine-tune the shading network, use the Connection Editor.

" Shading networks

" Import and export shading networks

" Convert a texture or shading network to a File Texture

" Assign a shading group from the Shader Library

" View the Shader Library Gallery

" Imported shading network optimizations

shadow

In general, an area that is totally or partially obscured from light by an 
object. 

In Maya, an individual light source can produce no shadows (the default), 
depth map shadows or raytraced shadows. 
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shape node
You can combine depth map shadow casting lights and raytraced shadow 
casting lights in a scene. Adjusting the attributes of depth map shadows or 
raytraced shadows can simulate shadows from many different types of 
real-world light sources and objects. 

Depth map shadows and raytraced shadows produce similar results, 
though depth map shadows usually take less time to render. Generally, 
choose depth map shadows unless they cannot accomplish your visual 
goal.

See also depth map, raytracing.

" Shadows

" Remove shadows

" Control which objects cast shadows

" Shadow in Maya

" Render raytraced shadows

" Depth map and raytraced shadows

For more information, search the online help for shadows

shape node

A node that holds an object’s geometry attributes or attributes other than 
the object’s transform node attributes. A shape node is always a child of a 
transform node. Unlike transform nodes, shape nodes do not appear in 
the Outliner by default.

See also node, Outliner.

" Anatomy of a shading node plug-in

" Special shading nodes

" Shading nodes classification

" Writing a shading node plug-in

" Evaluating shading nodes outside of the rendering context

" Shading group node

" Hide shape and transform nodes in Hypershade

shared polygons

In polygonal modeling, adjacent polygons that share vertices where they 
meet. These vertices continue to be shared if the polygons are transformed 
or edited.

" Split shared vertices

" Merge vertices, edges, or faces into one vertex
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 shelf
" Disconnect faces from their shared edges (extract)

shelf

A customizable collection of tools located directly below the status line, 
useful for storing tools and frequently-used items.

" Shelves

" Choose actions on a shelf

" Change the display of shelves

" Add a tool, action, or MEL script to a shelf

" Edit the contents of a shelf

" Make a shelf button for a script

" Create, rename, rearrange, or delete a shelf

" Create an Artisan tool shelf

" Creating a Shelf button for a MEL command

" Use a custom name or icon for a shelf item

" Edit the MEL script associated with a shelf item

" Window > Settings/Preferences > Shelves

shell

In polygonal modeling, a collection of faces that are connected in a single 
piece. For example, a primitive plane.

" Meshes and shells

" Automatically separate polygon shells into individual meshes

" Edit Polygons > Separate

" Select UV components

shininess

In rendering, the intensity of the shiny attribute of a surface. For example, 
a wet fish has a shinier surface than a dry leaf. 

In animations, surfaces reflect light in different ways depending on their 
shininess. The Blinn material is preferable for shiny surfaces in 
animations. Highlights on other specular materials, like Phong and 
PhongE, may flicker when animated.

See also Phong material, specular reflection.

" Surface Materials
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sine deformer
" Assigning a shading material

" Blinn

" Creating shading materials for objects

" Modifying surface specularity

sine deformer

In animation, a deformer that undulates any deformable object along a 
sine wave.

" Deformers overview

" Deformable objects, points, and sets

" Sine Nonlinear deformer

" Set sine nonlinear deformers

" Creating sine deformers

" Editing sine deformation effects

" Edit sine nonlinear deformers

" Advanced deformer options

" Deform > Create Nonlinear > Sine

skeleton

In animation, a structure that consists of joints and their bones, used to 
create hierarchical, articulated deformation effects on deformable objects 
such as NURBS surfaces.

" Skeletons

" Using skeletons 

" Joints and bones

" Joint chains

" Skeleton hierarchy

" Reroot skeletons

skin object

In animation, a deformable object that is bound to a skeleton to create 
skin. In the binding process, one or several skin objects can be used.

" Deformable objects and skin objects

" Rigid skin objects and points

" Smooth skin objects and points
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 skin point
" Point tweaking skinned objects

" Change a skinned object's deformation order

skin point

In animation, a control point of a skin object influenced by binding skin.

Ideally, a skin object should have a denser concentration of skin points 
around where it deforms the most. 

Skin points can be weighted to control how much they are influenced by 
the action of joints.

See also binding skin, control point.

" rigid skin point

" Editing skin point weights

" Smooth skin point sets

" Rigid skin point sets

" Painting smooth skin point weights

" Reset skin point weights to default weights

" Controlling smooth skin weight normalization

skinning

In animation, the process of binding deformable objects to a skeleton.

The surface of a character after that surface is bound to the character’s 
skeleton is called the skin.

It is important that a character’s skin deforms naturally as the skeleton 
moves. Near joints, the skin should bulge or indent as the joints are 
rotated.

See also binding skin, smooth skin.

In other software packages, known as envelope.

In other software packages, skinning may refer to birail surfaces. See birail.

" Understanding skinning

" Skeletons and skinning

" Skin > Edit Smooth Skin > Copy Skin Weights

" Skin > Edit Smooth Skin > Mirror Skin Weights

" Skin > Detach Skin

" Bind skin

" Set rigid bind options
Glossary

155



smear
" Skin > Bind Skin > Smooth Bind

" Skin > Bind Skin > Rigid Bind

smear

In painting, the blending of adjacent colors together along a stroke path.

Contrast with blur.

" Smearing and blurring

" Smear and blur paint on the canvas

" Smearing, blurring, and erasing paint

" Change the Brush Type

smooth shading

A geometry object display technique that can quickly shade the surfaces of 
objects. Smooth shading is more realistic but slower than flat shading or 
wireframe display.

Contrast with wireframe.

" Shading menu

" Change the look and smoothness of the selected objects

" Paint deformer set membership

smooth skin

In animation, a surface with smooth, articulated deformation, where 
several joints can influence the same deformable object points.

In other software packages, known as local/global envelope.

" Understanding smooth skinning

" Smooth skinning

" Smooth skin influence objects

" Mirror smooth skin weights

" Using smooth skin influence objects

" Copy smooth skin weights

" Bind smooth skin

smooth skin influence object

In animation, a NURBS or polygonal object that further shapes and 
controls the deformation of smooth skinned objects. 
Glossary

156



 smooth skin object
Influence objects are useful to restrict undesirable deformations (for 
example, popping shoulders), or to create desirable deformations (for 
example, bulging muscles).

" Understanding smooth skinning

" Smooth skin influence objects

" Using smooth skin influence objects

smooth skin object

In animation, a deformable object that can be bound to a skeleton to create 
a smooth skin.

" Understanding smooth skinning

" Smooth skin objects and points

" Normalize weights

" Controlling smooth skin weight normalization

smooth skin point

In animation, a control point of a smooth skin object. See also control point.

The set of all these points that can be influenced by the skeleton is called 
the smooth skin point set.

The weight assigned to a joint that controls the influence of that joint on 
each of these points is called the smooth skin point weight.

" Understanding smooth skinning

" Smooth skin objects and points

" Smooth skin point weights

" Painting smooth skin point weights

" Skin > Bind Skin > Smooth Bind

smoothing

In polygonal modeling, a modification of the surface topology by 
smoothing out vertices and their connected edges. 

In other software packages, known as meshsmooth.

" Smooth polygons

" Smoothing methods

" Polygons > Smooth

" Polygons > Smooth Proxy
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SMPTE time code
" Polygons > Average Vertices

SMPTE time code

Society of Motion Picture and Television Engineers time code. In film and 
video compositing, a method of denoting hours, minutes, seconds, and 
frames on videotape so that individual frames can be accessed. SMPTE 
time code is used with NTSC video. Longitudinal Time Code (LTC) is a 
type of SMPTE time code.

soft body

In dynamics, a polygonal surface, NURBS surface, NURBS curve, lattice, 
wire, or wrap deformer that bends and deforms when influenced by a 
field or struck by a collision object.

Contrast with rigid body.

" Soft bodies

" Create soft bodies

" Duplicate soft bodies

" Special uses of soft bodies

" Paint Soft Body Weights Tool

" Render soft bodies with motion blur

soft modification

A tool that lets you push and pull geometry as a sculptor would pull and 
push on a soft material when sculpting. The amount of deformation is 
greatest at the point being  pushed or pulled, and gradually falls off 
further away from the center.

The Soft Modification Tool is applicable for NURBS surfaces, polygonal 
surfaces, subdivision surfaces, curves, particles or any object with 
components. It works on clusters like a deformer.

The Soft Modification Tool is located in the Toolbox (or at Deform > Soft 
Modification). 

" Soft Modification Tool and Deformer

" Reshape a curve or surface manually

For more information, search the online help for Soft Modification
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 software render

e 
software render

A rendering method that uses software to create lighting and texturing 
effects. Software rendering may take longer than hardware rendering, but 
is required for certain kinds of details and effects.

Contrast with batch render, hardware render. See also IPR, mental ray.

" Maya Software renderer

" Maya Software rendering

" Rendering using the Maya software renderer

solver

An algorithm that provides the intelligence required to simulate th
details of physical motion.

See cloth solver, IK solver, root frame solver.

sorting bin

A container that helps you organize and track shading nodes (materials, 
textures, etc.) in your scenes. It is accessible from the Hypershade 
window.

A default master bin contains all shading nodes in your scene, but to 
quickly locate shading assets you can add other bins and give them 
strategic names (for example, wood, metal, doors, foliage).

When a node is assigned to a bin, all its input nodes are also assigned to 
this bin.

" Organize render nodes with Hypershade sorting bins 

" Automatically sort out overlapping texture pieces

soundtrack

1 In general, the area on a motion-picture film, videotape, or 
multimedia clip that carries the sound recording. 

2 In Maya, a sound file. Although you can import many sound files into 
a Maya scene, only one soundtrack can be displayed and played at a 
time in the Maya Time Slider.

" Play an audio file

3 In the Trax Editor, a user interface control that shows multiple audio 
waveforms, and lets you import .wav or .aiff audio files as audio clips 
that can later be moved and renamed. 
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source
" Sound

" Adding sound to your animation

" Delete audio from your scene

" Import an audio file

" How do I use the new Trax Editor?

" Revised Trax Editor track view area 

source

1 In animation, the original skeleton from which joint animation is 
retargeted to the joints of a second skeleton (target). In other words, 
the source skeleton is the skeleton from which you want to retarget 
animation data, and the target skeleton is the skeleton to which you 
want to retarget the source's animation. See also retargeting. Contrast 
with target.

" Animation retargeting

2 In rendering, an object that provides illumination to a scene. See light 
source.

" Create a Maya light source

3 In MEL, a directive that causes MEL to compile and execute the 
contents of a script that is stored in a file. 

For more information, search the online help for source command

SPAR

Software Product Authorization Request. A licensing method where 
licenses are generated by the Alias Sales Support team. For details, see the 
Installation and Licensing Guide.

Contrast with Online Product Activation (OPA).

" Sending your license request

" Online Product Activation (OPA)

specular reflection

A type of reflection that occurs when light hits a shiny surface. It causes 
highlights on the object.

" Absorption, reflection, and refraction of light

" Common surface material Specular Shading attributes

" Modifying surface specularity

" Create true reflections
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 sphere render type
" Render blurry reflections and refractions

" Render finitely distant illumination and reflection

sphere render type 

In dynamics, a type of rendering that displays particles as opaque spheres. 
(You cannot display these spheres with transparency.)

" Choose how particles render

" Setting the particle render type

spherical projection 
In rendering, the projection of a texture onto some surface, from an 
imaginary sphere that surrounds the surface.

" Projection

" Use the Projection utility

" Map UVs onto polygons automatically

spin impulse

In dynamics, an instantaneous rotational force (torque) on a rigid body’s 
center of mass in a specified direction.

" Control complex motion and forces

" Soft/Rigid Bodies > Create Active Rigid Body

spline

In general, a curved line, made up of segments and defined by control 
points (for example, CVs). Types of splines include polylines, cardinal 
splines, B-splines, and non-uniform rational B-splines (NURBS).

Splines were originally developed for shipbuilding. A way to draw a 
smooth curve through a set of points was needed. The solution was to 
place metal weights at points and pass a thin wooden beam between the 
weights. The beam, called a spline, adopts a minimum energy position 
with respect to the weights, producing a smooth curve. The influence of 
each weight is maximum at the point of contact, and decreases smoothly 
away from that point.

" Brief history of splines

" Mathematical representations of curves

" Curve components
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spot light
spot light

A light that shines evenly within a narrow range of directions (defined by 
a cone) from the light’s location. 

Spot lights create a beam of light that gradually becomes wider (for 
example, a flashlight or car headlight).

" Spot Light Attributes

" Create > Lights > Spot Light

" Control a spot light's circle boundary

" Determine a light's area of illumination

" Move the Cone Radius of a spot light

" Move the Decay regions of a spot light

" Move the Penumbra Radius of a spot light

spring constraint

In dynamics, a constraint that simulates an elastic cord. Use spring 
constraints to create effects such as a man bungee-jumping off a building. 

See also constraint.

" Create a Spring constraint

" Soft/Rigid Bodies > Create Constraint

sprite

In dynamics, a render type that displays a texture image or image 
sequence at each particle. At any given particle, the texture image or 
image sequence displayed can be identical to or different from those at 
other particles.

Depending on the type of texture image used, sprites can be used to create 
effects such as smoke, clouds, fog, or stars. A sprite appears as a small 
rectangle until a texture image is mapped to it. The image faces the 
camera directly regardless of the camera’s position or orientation.

" Sprite attributes

" Render attributes

" Sprite Wizard

" Choose how particles render

" Particles > Sprite Wizard

" Assign image sequences to sprites
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 squash deformer
squash deformer

In animation, a deformer that squashes and stretches any deformable 
object along an axis. 

Squash deformers are useful both for character setup (classic squash and 
stretch effects) and for modeling.

" Squash Nonlinear deformer

" squash

" Creating squash deformers

" Editing squash deformation effects

" Set squash nonlinear deformers

" Edit squash nonlinear deformers

start pose

The position of a character at the start of an animation. 

Note that before an animation starts, a character must be moved from 
dress-up pose to start pose, to allow the cloth solver to calculate the 
collisions and motion of the cloth.

Contrast with dress-up pose.

" Create the animation start pose

" Setting keyframes

stitching

1 In modeling, the action of sewing points or edges together on NURBS 
surfaces. 

Stitching is useful to keep surface edges together while they are being 
deformed, or for patching NURBS surfaces together to create surface 
continuity.

" Manually stitch surface edges together

" Automatically stitch multiple surfaces together

" Edit NURBS > Stitch > Stitch Edges Tool

2 In cloth, a constraint that simulates stitches in fabric. The Offset, 
Damping and Stiffness attributes are disabled for constrained cloth 
vertices so that they are kept very close (0.1 mm away) to the closest 
point on the target, so that there is no gap between the cloth vertices. 

" Stitch attribute for Cloth constraint

" Constraints > Cloth
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storyboard
storyboard

A series of drawings for planning an animation.

" Planning an animation for an IK system

streak

In dynamics, a render type that displays moving particles with an 
elongated tail. The streak render type creates the display of objects such as 
meteors or rain. 

Streak length is based on the velocity of particles, so if the particles are 
stationary or moving slowly, they aren’t seen.

" Setting the particle render type

" Connect to selected fields or emitters of an object

stress

In cloth, the energy exerted on each vertex of the cloth. 

The Stress Visualizer lets you view areas of stress on the cloth, as defined 
by the cloth solver. Use it to find problem areas, which you can then fix by 
increasing cloth resolution, adding collision constraints, or modifying the 
collision geometry.

" Visualizing Cloth stress

" Create a cloth object

" Simulation > Show Cloth Stress

" Simulation > Hide Cloth Stress

stroke

The action of an Artisan brush.

" How Artisan brush tools work

" Paint strokes 

" Select strokes

" Hide and show strokes and curves

" Delete strokes 

STU space

A coordinate system that defines the divisions of a lattice.

See also lattice deformer.
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 subcarrier
" Deform > Create Lattice

" Skin > Edit Rigid Skin > Create Flexor

subcarrier

In compositing, that part of the composite video signal, generated by the 
sync generator, that maintains the color phase (hue) in non-component 
video. Usually the subcarrier is handled automatically, but some devices 
will require a separate subcarrier signal with a sync signal.

subdivision surface

A hybrid surface type that provides both the smooth organic forms of 
NURBS modeling, and the detail and extrusion capabilities of polygonal 
modeling. A subdivision surface can have different levels of detail 
(density of control points) in different regions.

Subdivision surfaces allow you to model complex shapes from a single 
surface. They can have varying levels of detail (see hierarchy).

Also known as subd surface or hyper NURBS.

" Subdivision surfaces

" Creating a subdivision surface

" Attach subdivision surfaces

" Fur on Subdivision Surfaces

" Convert a subdivision surface to NURBS

" Convert a subdivision surface to polygons

" Render subdivision surfaces

summary

In the Trax editor, an interface control that exists for each level in the Trax 
hierarchy and gives you a high level of control over the collection of tracks 
under a character, group, or subcharacter.

You can collapse and expand summaries for characters, subcharacters, or 
groups by clicking the arrow that is beside each of their names in their 
respective summaries.

Each summary contains a summary clip, which you click-drag to move all 
the clips in all the tracks under the character, group, or subcharacter in the 
summary. You can also Shift+drag a summary clip to scale it.

See Trax Editor.

" Trax Editor
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surface
" How do I use the new Trax Editor?

surface

1 In modeling, a connected sequence of curves.

" Curves-on-surface

" Create a flat surface inside a curve

2 In rendering, the covering applied to an object to determine how the 
object will react when light strikes it. Some surfaces provide just a 
color, while others provide a pattern or rough or smooth appearance.

" Surface shading

surface highlights

In rendering, distinct shading characteristics provided by the particular 
specular attributes of a material. 

For example, specular highlights for Anisotropic or Phong materials, 
eccentricity and specular roll off for Blinn materials, roughness for 
PhongE.

" Select lights illuminating a specific object

" Common surface material Specular Shading attributes

surface material

In rendering, a description of what a surface looks like when it is 
rendered. Common surface material attributes include color, reflectivity, 
and reflected color.

Types of surface materials include: Blinn material, Phong material, Phong E 
material, and so on.

" Common surface material Specular Shading attributes

sync

In film and video production, a timing signal that must accompany video 
signals for an image to display or record correctly. 

Sync can be part of the video signal (with composite video) or it can be a 
separate signal (with component video). Usually, a sync generator provides 
identical signals to all pieces of video equipment so that they are 
synchronized together.
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 sync generator
sync generator

In film and video production, a device that generates the signal used to 
synchronize the operation of all devices in a video system.
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tangent
Glossary: T

tangent 

In general, a line or vector that indicates the slope of a curve at a given 
point.

See also tangent constraint.

" Edit tangents

" Align a curve with a curve or surface

" Edit Curves > Project Tangent

" Edit NURBS > Surface Editing > Surface Editing Tool, Break Tangent, 
Smooth Tangent

tangent constraint

In animation, a constraint that keeps an object moving along, and oriented 
to, a curve. The curve provides the path of the object’s motion, and the 
object orients itself to point along the curve.

See also constraint.

" Tangent constraints

" Constrain > Tangent

target

In animation, the skeleton to which joint animation is retargeted from the 
joints of an original skeleton (source). In other words, the source skeleton 
is the skeleton from which you want to retarget animation data, and the 
target skeleton is the skeleton to which you want to retarget the source's 
animation. 

See also retargeting. Contrast with source.

" Animation retargeting

template

1 The action of making an object unselectable. The object is still visible, 
but changes to a gray color to indicate that it cannot be selected or 
changed.

In other software packages, known as freeze or ghost.

" Template Display

" Display > Object Display > Template, Untemplate
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 tessellation

e 
s.
2 In painting, the initial settings for a brush. Any changes you 
make to the template brush settings affect what the next strok
looks like, but they do not affect any previously painted stroke

" Define template brush settings

tessellation

1 In general, the covering of a geometric model by congruent plane 
figures of various shapes and sizes of the same type (polygons) , 
without any gaps or overlaps.

" Maya software

" Adjust displacement sampling rates

" Render > Set NURBS Tessellation

" Modify > Convert > NURBS to Polygons

" Modify > Convert > Subdiv to Polygons

2 In dynamics, the internal conversion of NURBS objects to polygons 
before rigid body dynamics are animated. 

The tessellation factor sets the approximate number of polygons created 
during this conversion. Low numbers create coarser geometry (and 
nickeling) and lessen animation accuracy, but increase the playback 
speed.

" Fluid Effects > Make Collide

texture

An image that modifies surface detail.

See file texture, procedural texture, texture map.

" File textures

" Procedural textures

texture map

An image that modifies the appearance of a surface, created from painted 
or scanned-in two-dimensional images. These images are wrapped around 
the surface of a three dimensional object so that the patterns in the images 
curve and distort in a realistic manner.

Commonly-used texture maps include background, bump map, color map, 
displacement map, environment map, reflection map, specular reflection.

" Texture mapping
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thorn
thorn

In Paint Effects, a protruberance from the surface of triangles, created 
from the mesh brush type. Large numbers of thorns can be generated and 
rendered quickly, and can be used to add thorns or prickles to plants, or 
to create furry or fuzzy tubes.

" Define template brush settings

" Mesh

time

In MEL animation expressions, an internal variable that returns the 
current time position along the timeline.

" time and frame keywords

" Differences between expression and MEL syntax

time warp

An animation curve that lets you change the timing of a clip without 
modifying the animation curves of the clip itself. Time warps are typically 
used for reversing the clip, or easing in and easing out of a clip.

You can create time warps automatically when you create, duplicate, or 
instance a clip. However, they can slow performance so should be created 
only when needed.

See motion warping.

" Create and edit time warps

time working units

The default frames per second (FPS) for animation playback. 

" Edit animation preferences

" Window > Settings/Preferences > Preferences > Settings > Working 
Units

topology

1 The totality of an object’s shape, number of spans, and degree.

" Match the topology of one curve to another

" Transfer vertex positions (shape), UVs, or vertex color between meshes

2 The relationships between surfaces in a solid model: for example, 
between loops, edges, and vertices.
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 track
See also nonmanifold topology.

" 2-manifold, non-manifold, and invalid polygonal geometry

" Blending objects with different topologies

" Make subdivision surfaces more efficient

" Subdiv Surfaces > Match Topology

track

1 To slide the camera view either horizontally or vertically. 

In other software packages, known as pan.

" View > Camera Tools > Track Tool

" Animating camera moves

2 In Maya Live, the activity of following a given point of colour or 
luminance (called a tracking region) on a 2D image over a period of 
time. A locator is created at this tracking region's position and is 
keyframed at every frame. 

With this tracking information, the solver can analyze the shot to 
extract 3D locations and camera or object movement. 

See also key, locator.

" Tracking

" Overall tracking workflow

transform (xform)

To translate (move), rotate, or scale an object.

" Transformations

" Modify > Transformation Tools > Move Tool, Rotate Tool, Scale Tool, 
Show Manipulator Tool

transform node

A node that contains an object’s transformation attributes. That is, values 
for its translation, rotation, and scale. A transform node also holds 
information on any parent-child relationships it has with other nodes. 

Also known as DAG object. See also node. 

" Nodes

" Hide shape and transform nodes in Hypershade
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transformation
transformation

An operation that changes the position or shape of an object, such as 
translation (linear movement), rotation, and scaling.

" Transformations

" Modify > Transformation Tools > Move Tool, Rotate Tool, Scale Tool, 
Show Manipulator Tool

translate

To change the position of an object without changing its shape, size, or 
orientation.

" Transformations

" Modify > Transformation Tools > Move Tool, Rotate Tool, Scale Tool, 
Show Manipulator Tool

transparency 
A surface can be transparent or opaque. When ray tracing a transparent 
surface, light rays that penetrate the surface bend, and the light is 
refracted.

See also refraction.

" Common surface material attributes

" Layered Shader

Trax Editor

In animation, a window where animation sequences (clips) can be 
positioned, scaled, cycled and mixed.

See also character mapper, clip.

" Nonlinear animation tools in Maya

" How do I use the new Trax Editor?

trim

To remove or make invisible a portion of a NURBS surface defined by a 
curve-on-surface. 

See also curve-on-surface.

" Trimming

" Edit NURBS > Trim Tool
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 tube
tube

1 In Paint Effects, the application of paint to form tubes along the 
stroke path. 

" Tubes

" Painting in 3D

" Painting in 2D

" Editing strokes with tubes attributes

" Paint Effects > Flip Tube Direction

2 In dynamics, a render type that displays particles as tubes. Tubes 
appear only in software-rendered images.

" Choose how particles render

" Flow Animation

tumble

To change the position from which the camera views its center of interest. 
The scene in the camera’s view appears to rotate about the center of 
interest. 

The angle of a camera’s sight line relative to the ground plane is also 
referred to as its elevation; the angle of a camera’s sight line relative to a 
plane perpendicular to the ground plane is also referred to as its azimuth.

In other software packages, known as arc rotate.

" Tumble, track, dolly, or tilt the view

" View > Camera Tools > Tumble Tool

turbulence field 
In dynamics, a type of  Newton field that causes irregularities in the motion 
of affected objects. These irregularities are also called noise or jitter. 
Combine turbulence with other fields to mimic the random motion in 
liquid or gaseous mediums such as water and air. 

" Fields > Turbulence

For more information, search the online help for Turbulence field

tweaking 
In animation, the activity of moving or setting keys on individual points 
of an object. Tweaking is useful to avoid unexpected effects caused by 
deformers.
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twist deformer
Also known as point tweaking.

" Point tweaking objects

" Construction History and Tweaks

twist deformer

In animation, a deformer that twists a deformable object about an axis. 
Twist deformers are useful for both character setup and modeling.

" Twist Nonlinear deformer

" Creating twist deformers

" Editing twist deformation effects

" Deform > Create Nonlinear > Twist
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 underworld nodes
Glossary: U

underworld nodes

A pair of nodes that are automatically created by Maya for a shape node. 
When you create a curve on a NURBS surface, Maya generates an 
underworld transform node and shape node below the shape node of the 
surface. An example of an underworld node is a curve-on-surface. 

The CV positions of underworld nodes have UV coordinates on the 
surface rather than coordinates in world or local space.

See also node.

" Transforms with multiple shapes

uniform field

In dynamics, a field that pushes objects in a uniform magnitude and 
direction.

" Fields > Uniform

universal joint

In animation, a joint that can rotate only about any two of its local axes. 

A human wrist is a good example of a universal joint (although a wrist 
has limitations on the extent it can rotate).

" Joints and bones

up axis 
The global axis that is pointing upwards. By default, the up axis is the Y 
axis.

" Use the advanced Spline IK twist controls

" Animate > Motion Paths > Attach to Motion Path

" aimConstraint

up vector

In animation, a vector that works with the aim vector to control the 
orientation of a constrained object. By default, the up vector tries to stay as 
closely aligned as possible to the world up vector. 

See also aim vector, vector, world up vector. In other software packages, 
known as pole vector.
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utility node
" Prevent rolling effects for normal constraints

" Prevent rolling effects for aim constraints

" Constrain > Normal

" aimConstraint

utility node

A node that allows the creation of specific shading effects, most 
commonly used in shading networks. Render utility nodes are created 
from the Hypershade window.

See also node, shading network.

UV coordinate system

A coordinate system for 2D surfaces, used to identify locations when 
projecting a texture map onto an object.

" UVs

UV set

A particular texture that can be applied to an object. UV sets are required 
in multitexturing, when different textures, each with a different UV layer, 
need to be applied to a surface.

For example, if you create a brick wall and want to layer spray paint on 
top, you can use one texture for the bricks and one texture for the paint 
using a layered texture.

" UV sets
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 vector
Glossary: V

vector

The quantity of an attribute (such as color) that has direction (X, Y, Z) as 
well as magnitude.

See also aim vector, handle vector, pole vector, up vector, world up vector.

" Vectors

vector render

A rendering method that creates stylized renderings (for example, 
cartoon, tonal art, line art, hidden line, wireframe) in various bitmap 
image or 2D vector formats.

" Hardware, software, and vector rendering

" Maya Vector renderer

" Overview of the Vector Renderer

vertex

Plural is vertices.

1 In general, a point in 3D space. 

2 In polygonal modeling, a corner shared by two or more polygonal 
faces.

" Edit Polygons > Extrude Vertex 

" Edit Polygons > Chamfer Vertex 

" Edit Polygons > Merge Vertices 

" Edit Polygons > Colors > Paint Vertex Color Tool

See also vertex normal for more vertex editing tools.

vertex normal

In polygonal modeling, a normal associated with a vertex that is used for 
the calculation of the curvature of the surface at that particular vertex.

" Edit Polygons > Normals > Vertex Normal Edit Tool 

" Edit Polygons > Normals > Set Vertex Normal

" Edit Polygons > Normals > Average Normals 

" Edit Polygons > Normals > Set to Face 

" Edit Polygons > Normals > Reverse 
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video field
" Edit Polygons > Normals > Soften/Harden 

video field

In film and video production, either of the two half-frames that constitute 
an individual frame. Video fields are used by most video systems to 
display a frame, first by illuminating odd and then even rows of 
phosphors on a television screen.

The process of combining fields together is referred to as interlacing, used 
by the NTSC and PAL video systems 

Because video systems display an individual frame in two stages, if you 
render images as frames (that is, in one stage) and then display them on a 
video system, the motion of fast-moving objects may appear jerky or 
choppy.

If your post-production process or final presentation format involve 
interlaced video systems, you should render images as video fields. (If 
your animation does not contain fast-moving objects, you could try 
rendering images as frames.) When you render images as video fields, 
Maya generates two image files for each frame of an animation, one for 
each field. (Maya renders a frame at time "x" by rendering one field at 
time "x" and one field at time "x+0.5".) To properly view these fields, you 
must interlace them together.

" Frames vs. Fields

" Specify frame or field rendering

" Deinterlacing video shots

videotape controller

In film and video production, a device that controls a video tape recorder 
to allow it to record a single frame at a time. 

See animation control.

view

1 In general, the way a scene is seen through a default or custom 
camera. Among the characteristics that define a view are the camera’s 
position, viewing direction, rotation, and field of view.

See also active view, angle of view,  camera, point of view,  scene view, view axis.

" View > Camera Tools

" Angle of view (focal length)
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 view axis
2 A panel for rendering, painting, texturing, modeling, or performing 
other Maya activities. 

" Switch between views

view axis

A display of the XYZ coordinates, located in the bottom left corner of a 
view. 

See coordinate system, view.

Visor

A window that displays the rendering-related nodes currently used in a 
scene, and provides access to files on disk which the user may wish to 
bring into the scene (animation clips, brushes, shader libraries, or texture 
libraries, for example). 

" Common surface material attributes

" Select preset brushes

" Import or export animation data

For more information, search the online help for Visor

visualization map

A 3-dimensional visualization of a photon map or final gather map. 

Visualization maps are useful to see the distribution of photons (and their 
energies) or to see final gather points (with stored irradiance). This 
feedback can help you diagnose possibly unexpected global illumination 
effects so that you can tune your scene more efficiently to get the desired 
look. 

Generated photon or final gather visualization maps appear in either 
shaded view (where photons and final gather points are displayed as 
colored points, the color representing the irradiance estimate) or 
wireframe view (where normals and directions are shown).

" Photon and Final Gather visualization maps

volume axis field

In dynamics, an effect that moves particles in various directions in a 
volume, relative to the axis of the volume. 
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volumetric material
The volume axis field can be used to create effects such as particles 
flowing around obstacles, solar flares, mushroom clouds, explosions, 
tornadoes, or rocket exhaust.

" Creating volume axis fields

" Fields > Volume Axis

For more information, search the online help for Volume Axis field

volumetric material

In rendering, a description of the physical appearance of phenomena 
which occupy a volume of space (for example, fog or particles). 
Volumetric materials must be raytraced to produce effects such as the 
display of light fog through mirror reflections and refractions.

See also cloud, material, particle, raytracing.

" Surface, displacement, volumetric materials

" Common Volumetric material attributes

" Simulate fog, smoke, or dust

vortex field

In dynamics, an effect that pulls objects in a circular or spiraling direction. 
Use vortex fields with particles to create effects such as whirlpools or 
tornados.

" Fields > Vortex

voxel

An individual grid unit in a fluid container. Short for volume pixel.

" What are the components of a fluid?

" Defining the contents of a fluid container

" Changing fluid container size

" Change fluid resolution

VTR

Videotape Recorder.
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 wake
Glossary: W

wake

In fluid effects, the use of fluid emitters to simulate boat wakes, bubbles, 
ripples and other types of turbulence on an ocean or pond.

See also ocean, pond.

" Wakes

wave deformer

In animation, a deformer that alters the shape of an object based on a 
circular sine wave for ripple effects.

" Wave Nonlinear deformer

" Creating wave deformers

" Editing wave deformation effects

weight 

The degree of influence of a point during deformation.

See cluster deformer.

wheelmouse

The scrolling wheel on a mouse input device. 

In Maya, you can use the wheelmouse to:

• dolly in perspective or orthographic views 

• zoom in the Hypershade, the Graph Editor, the Dope Sheet, the 
Render View, Paint Effects, and other windows and editors 

• scroll in the Script Editor and the Console window 

wire deformer 
In animation, a deformer that uses one or more NURBS curves to change 
the shape of objects. Wire deformers are like the armatures used by 
sculptors to shape objects. 

" Wire deformers

" Creating wire deformers

" Deform > Wire tool
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wire dropoff locator
wire dropoff locator

In animation, a way for you to create localized deformation effects along a 
wire deformer’s influence curve. 

" Edit wire deformers

" Deform > Wire Dropoff Locator 

wireframe

A display technique that shows a geometric object as a collection of lines.

Contrast with shaded surface.

" Change the look and smoothness of the selected objects

" Change an object's wireframe color

workspace

The area in the Maya window where view panels appear. For example, 
when you start a new scene, the workspace shows the perspective view 
panel. 

" The Maya interface

" The Toolbox: Layout shortcuts

world space

The coordinate system for the entire scene. Its origin is at the center of the 
scene.

The grid you see in view windows shows the world space axes.

Also known as global space. Contrast with local space, object space.

" World space, object space, and local space

world up vector

In animation, the up direction. By default, this is the up direction of a 
scene’s world space, but can be set relative to an object’s local space. By 
default, the up vector of an object tries to stay as closely aligned as 
possible to the world up vector. 

See vector, up vector.

" Normal constraints

" Constrain > Normal

" Tangent constraints
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 wrap deformer
" Constrain > Tangent

wrap deformer

In animation, a deformer that uses NURBS or polygonal objects to shape 
deformable objects. 

The objects used by the wrap deformer to deform other objects are called 
wrap influence objects.

In other software packages, known as surface deformer.

" Understanding wrap deformers

" Creating wrap deformers

" Editing wrap deformation effects

" Skinning with wrap deformers

wrinkle deformer

In animation, a deformer that combines a cluster deformer with one or 
more wire deformers, useful for creating detailed wrinkling effects.

" Wrinkle deformers

" Creating wrinkle deformers

" Editing wrinkle deformation effects
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wrinkle deformer
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Glossary: X

xform

See transform (xform).

x-ray shading

A display technique that shows shaded surfaces as semi-transparent.

" Change the look and smoothness of the selected objects

XYZ coordinate system

A 3D coordinate system that lets you create characters and scenes with 
dimensionally accurate values. 

In the XYZ coordinate system, the origin is the center with coordinates 
0,0,0. All points are defined by three coordinates, one along the X-axis, one 
along the Y-axis, and one along the Z-axis. You can orient the XYZ 
coordinate system in either Y-up or Z-up.

See also axis, coordinate system, Y-up world, Z-up world.

" Switch between Y-up and Z-up
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Y-up world

Glossary: Y

Y-up world 
An orientation of the XYZ coordinate system where the X axis is the 
horizontal and Z is the depth of the scene. 

This orientation is often used by animators (and games developers) who 
have evolved from the 2D world of vertical (Y) and horizontal (X) to 
include movement toward or away from the camera (Z).

Contrast with Z-up world. See also coordinate system.

" Switch between Y-up and Z-up
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Glossary: Z

zoom

In general, the act of moving closer to or farther away from an object. In 
Maya, zooming a camera means changing the lens’s focal length. The 
camera does not move, but the scene in the camera’s view becomes larger 
or smaller.

In other software packages, known as camera zoom.

" Zoom and track

" View > Camera Tools > Zoom Tool

Z-up world 
An orientation of the XYZ coordinate system that starts with a ground 
plane representing the X and Y directions, with Z representing the up 
direction. 

This orientation is used by designers, whose main concern is the ground 
plane where their plans are placed.

Contrast with Y-up world. See also coordinate system.

" Switch between Y-up and Z-up
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2D motion blur

Glossary: Numerics

2D motion blur

In rendering, a fast way to approximate true (3D) motion blur. 2D motion 
blur is a post process that looks more uniform, and therefore not quite as 
realistic, as 3D motion blur. 2D motion blur is perfect for medium-to-far-
away surfaces, where level of detail is not important.

Also known as fake blur. 

Contrast with 3D motion blur. See also motion blur. 

" Set motion blur

" Troubleshoot:2D Motion Blur problems

" Create > Cameras > Camera

For more information, search the online help for motion blur

3D motion blur

In rendering, a technique that computes accurate blur based on a camera’s 
shutter angle, and the motion blur frame step. 

3D motion blur is required when a surface is turning (so that a new part of 
the surface becomes visible), or when a surface is moving and revealing 
another surface behind it.

See also motion blur. Contrast with 2D motion blur.

" Set motion blur

" Create > Cameras > Camera

For more information, search the online help for motion blur

3D paint tool

A technique of painting directly on models in 3D space using either 
Artisan and Paint Effects brushes. You can paint renderable attributes 
such as color, bump, transparency, and specular color on polygons, 
NURBS, or subdivision surfaces. 

Alternatively, you can paint on file textures that were created outside of 
the 3D paint tool.

To paint in 3D, see Paint Effects.

" Paint Textures on 3D objects

" Texturing > 3D Paint Tool
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